Merge "NULL Check the ApplicationData properties before use" into devel/wrt2
[platform/framework/web/crosswalk-tizen.git] / packaging / wrt.spec
1 %bcond_with wayland
2 %bcond_with x
3
4 Name:       wrt
5 Summary:    Runtime for Web Application
6 Version:    2.0.0
7 Release:    1
8 Group:      Development/Libraries
9 License:    Apache License, Version 2.0 / BSD
10 URL:        N/A
11 Source0:    %{name}-%{version}.tar.gz
12
13 BuildRequires: cmake
14 BuildRequires: edje-tools
15 BuildRequires: pkgconfig(appsvc)
16 BuildRequires: pkgconfig(bundle)
17 BuildRequires: pkgconfig(dlog)
18 BuildRequires: pkgconfig(elementary)
19 BuildRequires: pkgconfig(capi-appfw-application)
20 BuildRequires: pkgconfig(manifest-parser)
21 BuildRequires: pkgconfig(manifest-handlers)
22 BuildRequires: pkgconfig(capi-appfw-package-manager)
23 BuildRequires: pkgconfig(efl-assist)
24 BuildRequires: pkgconfig(deviced)
25 BuildRequires: pkgconfig(capi-system-runtime-info)
26 BuildRequires: pkgconfig(cert-svc)
27 BuildRequires: pkgconfig(uuid)
28 BuildRequires: boost-devel
29 %if %{with x}
30 BuildRequires: pkgconfig(ecore-x)
31 %endif
32 %if %{with wayland}
33 BuildRequires: pkgconfig(ecore-wayland)
34 %endif
35
36 #web-engine
37 BuildRequires:  pkgconfig(chromium-efl)
38
39 %description
40 Runtime for Web Application
41
42 %prep
43 %setup -q
44
45 %build
46
47 %ifarch %{arm}
48 %define build_dir build-arm
49 %else
50 %define build_dir build-x86
51 %endif
52
53 %if %{with x}
54 %define enable_x11 On
55 %else
56 %define enable_x11 Off
57 %endif
58
59 %if %{with wayland}
60 %define enable_wayland On
61 %else
62 %define enable_wayland Off
63 %endif
64
65 mkdir -p %{build_dir}
66 cd %{build_dir}
67
68 cmake .. -DCMAKE_INSTALL_PREFIX=%{_prefix} \
69          -DCMAKE_BUILD_TYPE=%{?build_type:%build_type} \
70          -DX11_SUPPORT=%{enable_x11} \
71          -DWAYLAND_SUPPORT=%{enable_wayland}
72
73 make %{?jobs:-j%jobs}
74
75 %install
76 cd %{build_dir}
77 %make_install
78
79 %clean
80 rm -fr %{buildroot}
81
82 %files
83 %attr(755,root,root) %{_bindir}/wrt
84 %attr(644,root,root) %{_datadir}/edje/wrt/wrt.edj
85 %attr(644,root,root) %{_libdir}/libwrt-injected-bundle.so