Merge "Add edc file for native window of wrt" into devel/wrt2
[platform/framework/web/crosswalk-tizen.git] / packaging / wrt.spec
1 %bcond_with wayland
2 %bcond_with x
3
4 Name:       wrt
5 Summary:    Runtime for Web Application
6 Version:    2.0.0
7 Release:    1
8 Group:      Development/Libraries
9 License:    Apache License, Version 2.0 / BSD
10 URL:        N/A
11 Source0:    %{name}-%{version}.tar.gz
12
13 BuildRequires: cmake
14 BuildRequires: edje-tools
15 BuildRequires: pkgconfig(dlog)
16 BuildRequires: pkgconfig(elementary)
17 BuildRequires: pkgconfig(capi-appfw-application)
18 BuildRequires: pkgconfig(efl-assist)
19 BuildRequires: pkgconfig(deviced)
20 BuildRequires: pkgconfig(cert-svc)
21 %if %{with x}
22 BuildRequires: pkgconfig(ecore-x)
23 %endif
24 %if %{with wayland}
25 BuildRequires: pkgconfig(ecore-wayland)
26 %endif
27
28 #web-engine
29 BuildRequires:  pkgconfig(chromium-efl)
30
31 %description
32 Runtime for Web Application
33
34 %prep
35 %setup -q
36
37 %build
38
39 %ifarch %{arm}
40 %define build_dir build-arm
41 %else
42 %define build_dir build-x86
43 %endif
44
45 %if %{with x}
46 %define enable_x11 On
47 %else
48 %define enable_x11 Off
49 %endif
50
51 %if %{with wayland}
52 %define enable_wayland On
53 %else
54 %define enable_wayland Off
55 %endif
56
57 mkdir -p %{build_dir}
58 cd %{build_dir}
59
60 cmake .. -DCMAKE_INSTALL_PREFIX=%{_prefix} \
61          -DCMAKE_BUILD_TYPE=%{?build_type:%build_type} \
62          -DX11_SUPPORT=%{enable_x11} \
63          -DWAYLAND_SUPPORT=%{enable_wayland}
64
65 make %{?jobs:-j%jobs}
66
67 %install
68 cd %{build_dir}
69 %make_install
70
71 %clean
72 rm -fr %{buildroot}
73
74 %files
75 %attr(755,root,root) %{_bindir}/wrt
76 %attr(644,root,root) %{_datadir}/edje/wrt/wrt.edj