Merge "Change ewk initialize code position - issue : ewk context was created before...
[platform/framework/web/crosswalk-tizen.git] / packaging / wrt.spec
1 %bcond_with wayland
2 %bcond_with x
3
4 Name:       wrt
5 Summary:    Runtime for Web Application
6 Version:    2.0.0
7 Release:    1
8 Group:      Development/Libraries
9 License:    Apache License, Version 2.0 / BSD
10 URL:        N/A
11 Source0:    %{name}-%{version}.tar.gz
12
13 BuildRequires: cmake
14 BuildRequires: pkgconfig(dlog)
15 BuildRequires: pkgconfig(elementary)
16 BuildRequires: pkgconfig(capi-appfw-application)
17 BuildRequires: pkgconfig(efl-assist)
18 BuildRequires: pkgconfig(deviced)
19 BuildRequires: pkgconfig(cert-svc)
20 %if %{with x}
21 BuildRequires: pkgconfig(ecore-x)
22 %endif
23 %if %{with wayland}
24 BuildRequires: pkgconfig(ecore-wayland)
25 %endif
26
27 #web-engine
28 BuildRequires:  pkgconfig(chromium-efl)
29
30 %description
31 Runtime for Web Application
32
33 %prep
34 %setup -q
35
36 %build
37
38 %ifarch %{arm}
39 %define build_dir build-arm
40 %else
41 %define build_dir build-x86
42 %endif
43
44 %if %{with x}
45 %define enable_x11 On
46 %else
47 %define enable_x11 Off
48 %endif
49
50 %if %{with wayland}
51 %define enable_wayland On
52 %else
53 %define enable_wayland Off
54 %endif
55
56 mkdir -p %{build_dir}
57 cd %{build_dir}
58
59 cmake .. \
60   -DCMAKE_BUILD_TYPE=%{?build_type:%build_type} \
61   -DX11_SUPPORT=%{enable_x11} \
62   -DWAYLAND_SUPPORT=%{enable_wayland}
63
64 make %{?jobs:-j%jobs}
65
66 %install
67 cd %{build_dir}
68 %make_install
69
70 %clean
71 rm -fr %{buildroot}
72
73 %files
74 /usr/local/bin/wrt
75