Merge "Fix javascript code to remov temporary variable" into devel/wrt2
[platform/framework/web/crosswalk-tizen.git] / packaging / wrt.spec
1 %bcond_with wayland
2 %bcond_with x
3
4 Name:       wrt
5 Summary:    Runtime for Web Application
6 Version:    2.0.0
7 Release:    1
8 Group:      Development/Libraries
9 License:    Apache License, Version 2.0 / BSD
10 URL:        N/A
11 Source0:    %{name}-%{version}.tar.gz
12
13 BuildRequires: cmake
14 BuildRequires: edje-tools
15 BuildRequires: pkgconfig(appsvc)
16 BuildRequires: pkgconfig(bundle)
17 BuildRequires: pkgconfig(dlog)
18 BuildRequires: pkgconfig(elementary)
19 BuildRequires: pkgconfig(capi-appfw-application)
20 BuildRequires: pkgconfig(manifest-parser)
21 BuildRequires: pkgconfig(manifest-handlers)
22 BuildRequires: pkgconfig(capi-appfw-package-manager)
23 BuildRequires: pkgconfig(efl-assist)
24 BuildRequires: pkgconfig(deviced)
25 BuildRequires: pkgconfig(capi-system-runtime-info)
26 BuildRequires: pkgconfig(cert-svc)
27 BuildRequires: boost-devel
28 %if %{with x}
29 BuildRequires: pkgconfig(ecore-x)
30 %endif
31 %if %{with wayland}
32 BuildRequires: pkgconfig(ecore-wayland)
33 %endif
34
35 #web-engine
36 BuildRequires:  pkgconfig(chromium-efl)
37
38 %description
39 Runtime for Web Application
40
41 %prep
42 %setup -q
43
44 %build
45
46 %ifarch %{arm}
47 %define build_dir build-arm
48 %else
49 %define build_dir build-x86
50 %endif
51
52 %if %{with x}
53 %define enable_x11 On
54 %else
55 %define enable_x11 Off
56 %endif
57
58 %if %{with wayland}
59 %define enable_wayland On
60 %else
61 %define enable_wayland Off
62 %endif
63
64 mkdir -p %{build_dir}
65 cd %{build_dir}
66
67 cmake .. -DCMAKE_INSTALL_PREFIX=%{_prefix} \
68          -DCMAKE_BUILD_TYPE=%{?build_type:%build_type} \
69          -DX11_SUPPORT=%{enable_x11} \
70          -DWAYLAND_SUPPORT=%{enable_wayland}
71
72 make %{?jobs:-j%jobs}
73
74 %install
75 cd %{build_dir}
76 %make_install
77
78 %clean
79 rm -fr %{buildroot}
80
81 %files
82 %attr(755,root,root) %{_bindir}/wrt
83 %attr(644,root,root) %{_datadir}/edje/wrt/wrt.edj
84 %attr(644,root,root) %{_libdir}/libwrt-injected-bundle.so