[wearable] Refactored the logic for create AP object
[apps/native/ug-wifi-efl.git] / packaging / wifi-efl-ug.spec
1 %define _unpackaged_files_terminate_build 0
2 Name:           wifi-efl-ug
3 Summary:        Wi-Fi UI Gadget for TIZEN
4 Version:        1.0.222
5 Release:        1
6 Group:          App/Network
7 License:        Flora-1.1
8 Source0:        %{name}-%{version}.tar.gz
9
10 %if "%{?profile}" == "tv"
11 ExcludeArch: %{arm} %ix86 x86_64
12 %endif
13
14 BuildRequires:  pkgconfig(ecore)
15 BuildRequires:  pkgconfig(ecore-imf)
16 BuildRequires:  pkgconfig(ecore-input)
17 BuildRequires:  pkgconfig(appcore-efl)
18 BuildRequires:  pkgconfig(elementary)
19 BuildRequires:  pkgconfig(glib-2.0)
20 BuildRequires:  pkgconfig(openssl)
21 BuildRequires:  pkgconfig(cert-svc-vcore)
22 BuildRequires:  pkgconfig(ui-gadget-1)
23 BuildRequires:  pkgconfig(sensor)
24 BuildRequires:  pkgconfig(capi-network-wifi)
25 BuildRequires:  pkgconfig(capi-network-connection)
26 %if "%{?profile}" != "wearable"
27 BuildRequires:  pkgconfig(capi-network-tethering)
28 %endif
29 BuildRequires:  pkgconfig(capi-ui-efl-util)
30 BuildRequires:  pkgconfig(network)
31 BuildRequires:  pkgconfig(feedback)
32 BuildRequires:  pkgconfig(efl-extension)
33 BuildRequires:  pkgconfig(aul)
34 #BuildRequires:  pkgconfig(setting-common-internal)
35 #BuildRequires:  pkgconfig(setting-lite-common-internal)
36 BuildRequires:  cmake
37 BuildRequires:  gettext-tools
38 BuildRequires:  edje-tools
39 Requires(post):         /sbin/ldconfig
40 requires(postun):       /sbin/ldconfig
41
42 %description
43 Wi-Fi UI Gadget
44
45 %if "%{profile}" == "mobile"
46 %package -n net.wifi-qs
47 Summary:    Wi-Fi System popup
48 Requires:   %{name} = %{version}
49
50 %description -n net.wifi-qs
51 Wi-Fi System popup for TIZEN
52 %endif
53
54 %if "%{profile}" == "wearable"
55 %package -n org.tizen.w-wifi
56 Summary:    Wi-Fi UI Gadget for wearable
57
58 %description -n org.tizen.w-wifi
59 Wi-Fi UI Gadget for wearable
60 %endif
61
62 %prep
63 %setup -q
64
65 %define PREFIX /usr/
66
67 %build
68 #LDFLAGS+="-Wl,--rpath=%{PREFIX}/lib -Wl,--as-needed"
69 cmake -DCMAKE_INSTALL_PREFIX=%{PREFIX} \
70 %if "%{profile}" != "wearable"
71         -DTIZEN_TETHERING_ENABLE=1 \
72 %endif
73         -DMODEL_BUILD_FEATURE_WLAN_CONCURRENT_MODE=1 \
74 %if "%{profile}" == "mobile"
75         -DTIZEN_MOBILE=1 \
76 %endif
77 %if "%{profile}" == "wearable"
78         -DTIZEN_WEARABLE=1 \
79 %endif
80 %if "%{?_with_emulator}" == "1"
81         -DTIZEN_EMULATOR=1 \
82 %endif
83         .
84
85 make %{?_smp_mflags}
86
87
88 %install
89 %make_install
90
91 #License
92 mkdir -p %{buildroot}%{_datadir}/license
93 cp LICENSE %{buildroot}%{_datadir}/license/wifi-efl-ug
94 %if "%{profile}" == "mobile"
95 cp LICENSE %{buildroot}%{_datadir}/license/net.wifi-qs
96 %endif
97 %if "%{profile}" == "wearable"
98 cp LICENSE %{buildroot}%{_datadir}/license/org.tizen.w-wifi
99 %endif
100
101 %post
102 /sbin/ldconfig
103
104 mkdir -p %{PREFIX}/bin/
105 mkdir -p /usr/apps/wifi-efl-ug/bin/ -m 777
106
107 %postun -p /sbin/ldconfig
108
109 %files
110 %manifest wifi-efl-ug.manifest
111 %{PREFIX}/ug/lib/*
112 %attr(644,-,-) %{PREFIX}/ug/lib/*
113 %attr(755,-,-) %{PREFIX}/ug/lib/
114 %{PREFIX}/apps/wifi-efl-ug/res/edje/*.edj
115 %{_datadir}/license/wifi-efl-ug
116 %{_datadir}/packages/wifi-efl-ug.xml
117 %if "%{profile}" == "mobile"
118 %{_datadir}/locale/*/LC_MESSAGES/*.mo
119 %{_datadir}/icons/*.png
120 %endif
121 /usr/apps/wifi-efl-ug/shared/res/tables/ug-wifi-efl_ChangeableColorTable.xml
122 /usr/apps/wifi-efl-ug/shared/res/tables/ug-wifi-efl_FontInfoTable.xml
123
124 %if "%{profile}" == "mobile"
125 %files -n net.wifi-qs
126 %manifest net.wifi-qs.manifest
127 %{_bindir}/wifi-qs
128 %{_datadir}/packages/net.wifi-qs.xml
129 %{_datadir}/icons/*.png
130 %{PREFIX}/apps/net.wifi-qs/res/edje/*.edj
131 %{_datadir}/license/net.wifi-qs
132 %endif
133
134 %if "%{profile}" == "wearable"
135 %files -n org.tizen.w-wifi
136 %manifest org.tizen.w-wifi.manifest
137 /usr/shared/res/tables/color_table.xml
138 /usr/shared/res/tables/font_table.xml
139 %defattr(-,root,root,-)
140 %attr(-,inhouse,inhouse)
141 %{PREFIX}/apps/org.tizen.w-wifi/bin/*
142 %{PREFIX}/apps/org.tizen.w-wifi/res/images/*.png
143 %{PREFIX}/apps/org.tizen.w-wifi/res/locale/*/LC_MESSAGES/*.mo
144 %{PREFIX}/apps/org.tizen.w-wifi/res/edje/*
145 %{_datadir}/packages/org.tizen.w-wifi.xml
146 %{_datadir}/license/org.tizen.w-wifi
147 %endif