Release version 0.15.19
[platform/core/appfw/wgt-backend.git] / packaging / wgt-backend.spec
1 Name:           wgt-backend
2 Summary:        Application installer backend for WGT
3 Version:        0.15.19
4 Release:        1
5 Group:          Application Framework/Package Management
6 License:        Apache-2.0
7 Source0:        %{name}-%{version}.tar.gz
8
9 Source1000:     wgt-backend.manifest
10 Source1001:     wgt-installer.manifest
11 Source1002:     wgt-installer-tests.manifest
12
13 Requires:       wgt-installer = %{version}
14 BuildRequires:  boost-devel
15 BuildRequires:  cmake
16 BuildRequires:  app-installers-tests
17 BuildRequires:  pkgconfig(app-installers)
18 BuildRequires:  pkgconfig(manifest-parser)
19 BuildRequires:  pkgconfig(wgt-manifest-handlers)
20 BuildRequires:  pkgconfig(pkgmgr-installer)
21 BuildRequires:  pkgconfig(pkgmgr-types)
22 BuildRequires:  pkgconfig(libwebappenc)
23 BuildRequires:  pkgconfig(tpk-installer)
24 BuildRequires:  pkgconfig(vconf)
25 BuildRequires:  pkgconfig(libgum)
26 BuildRequires:  pkgconfig(gmock)
27
28 %description
29 This is a package that installs the WGT backend of pkgmgr.
30
31 %package -n wgt-installer
32 Summary: Wgt-installer library
33 Group:   Application Framework/Package Management
34
35 %description -n wgt-installer
36 This package contains wgt-installer library
37
38 %package -n wgt-installer-devel
39 Summary:  Wgt-installer development files
40 Group:    Application Framework/Package Management
41 Requires: wgt-installer = %{version}
42
43 %description -n wgt-installer-devel
44 This package contains header files of wgt-installer library
45
46 %package -n wgt-installer-tests
47 Summary: Unit tests for wgt-installer
48 Requires: wgt-installer = %{version}
49
50 %description -n wgt-installer-tests
51 Unit tests for wgt-installer
52
53 %prep
54 %setup -q
55
56 cp %{SOURCE1000} .
57 cp %{SOURCE1001} .
58 cp %{SOURCE1002} .
59
60 %build
61 %cmake . -DCMAKE_BUILD_TYPE=%{?build_type:%build_type}
62 make %{?_smp_mflags}
63
64 %install
65 %make_install
66 mkdir -p %{buildroot}/etc/package-manager/backend
67 ln -s %{_bindir}/wgt-backend %{buildroot}%{_sysconfdir}/package-manager/backend/wgt
68
69 %post -n wgt-installer-tests
70 /usr/sbin/setcap cap_chown,cap_dac_override,cap_fowner=eip %{_bindir}/wgt-installer-ut/smoke-test
71 /usr/sbin/setcap cap_chown,cap_dac_override,cap_fowner=eip %{_bindir}/wgt-installer-ut/smoke-test-helper
72
73 %files
74 %manifest wgt-backend.manifest
75 %license LICENSE
76 %{_sysconfdir}/package-manager/backend/wgt
77 %{_bindir}/wgt-backend
78 %{_datadir}/wgt-backend/default.png
79
80 %files -n wgt-installer
81 %manifest wgt-installer.manifest
82 %{_sysconfdir}/package-manager/backendlib/libwgt.so
83 %{_libdir}/libwgt-installer.so*
84 %{_libdir}/libhybrid-installer.so*
85
86 %files -n wgt-installer-devel
87 %{_includedir}/app-installers/wgt/*.h
88 %{_includedir}/app-installers/wgt/*/*.h
89 %{_includedir}/app-installers/wgt/*/*/*.h
90 %{_includedir}/app-installers/hybrid/*.h
91 %{_includedir}/app-installers/hybrid/*/*/*.h
92 %{_libdir}/pkgconfig/wgt-installer.pc
93
94 %files -n wgt-installer-tests
95 %manifest wgt-installer-tests.manifest
96 %{_bindir}/wgt-installer-ut/*
97 %{_datadir}/wgt-installer-ut/*
98 %{_libdir}/libwgt-smoke-utils.so*
99 %{_includedir}/app-installers/smoke_tests/wgt_smoke_utils.h
100
101 %changelog
102 * Thu Dec 18 2015 Pawel Sikorski <p.sikorski@samsung.com> 0.1-1
103 - initial files creation