Release version 0.15.38
[platform/core/appfw/wgt-backend.git] / packaging / wgt-backend.spec
1 Name:           wgt-backend
2 Summary:        Application installer backend for WGT
3 Version:        0.15.38
4 Release:        1
5 Group:          Application Framework/Package Management
6 License:        Apache-2.0
7 Source0:        %{name}-%{version}.tar.gz
8
9 Source1000:     wgt-backend.manifest
10 Source1001:     wgt-installer.manifest
11 Source1002:     wgt-installer-tests.manifest
12
13 Requires:       wgt-installer = %{version}
14 BuildRequires:  cmake
15 BuildRequires:  app-installers-tests
16 BuildRequires:  pkgconfig(app-installers)
17 BuildRequires:  pkgconfig(manifest-parser)
18 BuildRequires:  pkgconfig(wgt-manifest-handlers)
19 BuildRequires:  pkgconfig(pkgmgr-installer)
20 BuildRequires:  pkgconfig(pkgmgr-types)
21 BuildRequires:  pkgconfig(libwebappenc)
22 BuildRequires:  pkgconfig(tpk-installer)
23 BuildRequires:  pkgconfig(vconf)
24 BuildRequires:  pkgconfig(libgum)
25 BuildRequires:  pkgconfig(gmock)
26
27 %description
28 This is a package that installs the WGT backend of pkgmgr.
29
30 %package -n wgt-installer
31 Summary: Wgt-installer library
32 Group:   Application Framework/Package Management
33
34 %description -n wgt-installer
35 This package contains wgt-installer library
36
37 %package -n wgt-installer-devel
38 Summary:  Wgt-installer development files
39 Group:    Application Framework/Package Management
40 Requires: wgt-installer = %{version}
41
42 %description -n wgt-installer-devel
43 This package contains header files of wgt-installer library
44
45 %package -n wgt-installer-tests
46 Summary: Unit tests for wgt-installer
47 Requires: wgt-installer = %{version}
48
49 %description -n wgt-installer-tests
50 Unit tests for wgt-installer
51
52 %prep
53 %setup -q
54
55 cp %{SOURCE1000} .
56 cp %{SOURCE1001} .
57 cp %{SOURCE1002} .
58
59 %build
60 %ifnarch x86_64 aarch64
61 ISARC64=0
62 %else
63 ISARC64=1
64 %endif
65 %cmake . -DCMAKE_BUILD_TYPE=%{?build_type:%build_type} \
66          -DISARC64=${ISARC64}
67 make %{?_smp_mflags}
68
69 %install
70 %make_install
71 mkdir -p %{buildroot}/etc/package-manager/backend
72 ln -s %{_bindir}/wgt-backend %{buildroot}%{_sysconfdir}/package-manager/backend/wgt
73
74 %post -n wgt-installer-tests
75 /usr/sbin/setcap cap_chown,cap_dac_override,cap_fowner,cap_mac_override=eip %{_bindir}/wgt-installer-ut/smoke-test
76 /usr/sbin/setcap cap_chown,cap_dac_override,cap_fowner,cap_mac_override=eip %{_bindir}/wgt-installer-ut/smoke-test-helper
77 /usr/sbin/setcap cap_chown,cap_dac_override,cap_fowner,cap_mac_override=eip %{_bindir}/wgt-installer-ut/hybrid-smoke-test-helper
78 /usr/sbin/setcap cap_chown,cap_dac_override,cap_fowner,cap_mac_override=eip %{_bindir}/wgt-installer-ut/extensive-smoke-test
79
80 %files
81 %manifest wgt-backend.manifest
82 %license LICENSE
83 %{_sysconfdir}/package-manager/backend/wgt
84 %{_bindir}/wgt-backend
85 %{_datadir}/wgt-backend/default.png
86
87 %files -n wgt-installer
88 %manifest wgt-installer.manifest
89 %{_sysconfdir}/package-manager/backendlib/libwgt.so
90 %{_libdir}/libwgt-installer.so*
91 %{_libdir}/libhybrid-installer.so*
92
93 %files -n wgt-installer-devel
94 %{_includedir}/app-installers/wgt/*.h
95 %{_includedir}/app-installers/wgt/*/*.h
96 %{_includedir}/app-installers/wgt/*/*/*.h
97 %{_includedir}/app-installers/hybrid/*.h
98 %{_includedir}/app-installers/hybrid/*/*/*.h
99 %{_libdir}/pkgconfig/wgt-installer.pc
100
101 %files -n wgt-installer-tests
102 %manifest wgt-installer-tests.manifest
103 %{_bindir}/wgt-installer-ut/*
104 %ifnarch x86_64 aarch64
105 %{_datadir}/wgt-installer-ut/*
106 %endif
107 %{_libdir}/libwgt-smoke-utils.so*
108 %{_includedir}/app-installers/smoke_tests/wgt_smoke_utils.h
109
110 %changelog
111 * Thu Dec 18 2015 Pawel Sikorski <p.sikorski@samsung.com> 0.1-1
112 - initial files creation