Release version 0.12.13
[platform/core/appfw/wgt-backend.git] / packaging / wgt-backend.spec
1 Name:           wgt-backend
2 Summary:        Application installer backend for WGT
3 Version:        0.12.13
4 Release:        1
5 Group:          Application Framework/Package Management
6 License:        Apache-2.0
7 Source0:        %{name}-%{version}.tar.gz
8
9 Source1000:     wgt-backend.manifest
10 Source1001:     wgt-backend-tests.manifest
11
12 BuildRequires:  boost-devel
13 BuildRequires:  cmake
14 BuildRequires:  gtest-devel
15 BuildRequires:  app-installers-tests
16 BuildRequires:  pkgconfig(app-installers)
17 BuildRequires:  pkgconfig(manifest-parser)
18 BuildRequires:  pkgconfig(wgt-manifest-handlers)
19 BuildRequires:  pkgconfig(pkgmgr-installer)
20 BuildRequires:  pkgconfig(pkgmgr-types)
21 BuildRequires:  pkgconfig(libwebappenc)
22 BuildRequires:  pkgconfig(tpk-installer)
23 BuildRequires:  pkgconfig(vconf)
24 BuildRequires:  pkgconfig(libgum)
25
26 %description
27 This is a package that installs the WGT backend of pkgmgr.
28
29 %package tests
30 Summary: Unit tests for wgt-backend
31 Requires: %{name} = %{version}
32
33 %description tests
34 Unit tests for wgt-backend
35
36 %prep
37 %setup -q
38
39 cp %{SOURCE1000} .
40 cp %{SOURCE1001} .
41
42 %build
43 %cmake . -DCMAKE_BUILD_TYPE=%{?build_type:%build_type}
44 make %{?_smp_mflags}
45
46 %install
47 %make_install
48 mkdir -p %{buildroot}/etc/package-manager/backend
49 ln -s %{_bindir}/wgt-backend %{buildroot}%{_sysconfdir}/package-manager/backend/wgt
50
51 %post tests
52 /usr/sbin/setcap cap_chown,cap_dac_override,cap_fowner=eip %{_bindir}/wgt-backend-ut/smoke-test
53 /usr/sbin/setcap cap_chown,cap_dac_override,cap_fowner=eip %{_bindir}/wgt-backend-ut/smoke-test-helper
54
55 %files
56 %manifest wgt-backend.manifest
57 %license LICENSE
58 %{_sysconfdir}/package-manager/backend/wgt
59 %{_sysconfdir}/package-manager/backendlib/libwgt.so
60 %{_bindir}/wgt-backend
61 %{_datadir}/wgt-backend/default.png
62
63 %files tests
64 %manifest wgt-backend-tests.manifest
65 %{_bindir}/wgt-backend-ut/*
66 %{_datadir}/wgt-backend-ut/*
67
68 %changelog
69 * Thu Dec 18 2015 Pawel Sikorski <p.sikorski@samsung.com> 0.1-1
70 - initial files creation