Updated packaging change log.
[profile/ivi/weston.git] / packaging / weston.spec
1 Name:       weston
2 Summary:    Weston Compositor
3 Version:    1.0.2
4 Release:    1
5 Group:      System/Libraries
6 License:    MIT
7 URL:        http://wayland.freedesktop.org
8 Source0:    %{name}-%{version}.tar.bz2
9 Source1:    cursors.tar.bz2
10 Source2:    weston.service
11 Source3:    99-vtc1000-quirk.rules
12 Source4:    rc.weston
13 Source5:    weston.sh
14 Source6:    weston.manifest
15 BuildRequires: pkgconfig(wayland-server)
16 BuildRequires: pkgconfig(egl)
17 BuildRequires: pkgconfig(gl)
18 BuildRequires: pkgconfig(glesv2)
19 BuildRequires: pkgconfig(pixman-1)
20 BuildRequires: pkgconfig(libpng)
21 BuildRequires: pkgconfig(libudev)
22 BuildRequires: pkgconfig(libdrm)
23 BuildRequires: pkgconfig(gbm)
24 BuildRequires: pkgconfig(wayland-client)
25 BuildRequires: pkgconfig(wayland-egl)
26 BuildRequires: pkgconfig(cairo)
27 BuildRequires: pkgconfig(gdk-pixbuf-2.0)
28 BuildRequires: pkgconfig(glib-2.0)
29 BuildRequires: pkgconfig(gobject-2.0)
30 BuildRequires: pkgconfig(gio-2.0)
31 BuildRequires: pkgconfig(xkbcommon)
32 BuildRequires: pkgconfig(libpng)
33 BuildRequires: pkgconfig(mtdev)
34 BuildRequires: pkgconfig(xcursor)
35 BuildRequires: libjpeg-devel
36 Requires: xkeyboard-config
37
38 %description
39 Weston compositor
40
41 %package cursors
42 Summary:    Adds a simple cursor theme to the default cursor theme
43 Group:      System/Libraries
44 Requires:   %{name} = %{version}-%{release}
45
46 %description cursors
47 Adds a simple cursor theme to the default cursor theme
48
49 %prep
50 %setup -q -n %{name}-%{version}
51
52 %build
53
54 %autogen -disable-weston-launch --disable-setuid-install --disable-x11-compositor --disable-xwayland
55
56 make %{?jobs:-j%jobs}
57
58 %install
59 rm -rf %{buildroot}
60 %make_install
61
62 install -m 755 clients/dnd $RPM_BUILD_ROOT%{_bindir}/wayland-dnd
63 install -m 755 clients/eventdemo $RPM_BUILD_ROOT%{_bindir}/wayland-eventdemo
64 install -m 755 clients/flower $RPM_BUILD_ROOT%{_bindir}/wayland-flower
65 install -m 755 clients/image $RPM_BUILD_ROOT%{_bindir}/wayland-image
66 install -m 755 clients/resizor $RPM_BUILD_ROOT%{_bindir}/wayland-resizor
67 install -m 755 clients/simple-egl $RPM_BUILD_ROOT%{_bindir}/wayland-simple-egl
68 install -m 755 clients/simple-shm $RPM_BUILD_ROOT%{_bindir}/wayland-simple-shm
69 install -m 755 clients/simple-touch $RPM_BUILD_ROOT%{_bindir}/wayland-simple-touch
70 install -m 755 clients/smoke $RPM_BUILD_ROOT%{_bindir}/wayland-smoke
71
72 # Systemd
73 mkdir -p $RPM_BUILD_ROOT/%{_libdir}/systemd/system/graphical.target.wants
74 install -m 0644 %{SOURCE2} $RPM_BUILD_ROOT/%{_libdir}/systemd/system/
75 mkdir -p $RPM_BUILD_ROOT/%{_libdir}/udev/rules.d/
76 install -m 0644 %{SOURCE3} $RPM_BUILD_ROOT/%{_libdir}/udev/rules.d/
77 ln -sf ../weston.service $RPM_BUILD_ROOT/%{_libdir}/systemd/system/graphical.target.wants/weston.service
78
79 # System V
80 mkdir -p %{buildroot}%{_sysconfdir}/rc.d/init.d
81 mkdir -p %{buildroot}%{_sysconfdir}/rc.d/rc3.d
82 install -m 0755 %{SOURCE4} %{buildroot}%{_sysconfdir}/rc.d/init.d/weston
83 ln -sf %{_sysconfdir}/rc.d/init.d/weston %{buildroot}%{_sysconfdir}/rc.d/rc3.d/S20weston
84
85 # Environment variables necessary to run Weston and Wayland clients.
86 mkdir -p %{buildroot}%{_sysconfdir}/profile.d
87 install -m 0644 %{SOURCE5} %{buildroot}%{_sysconfdir}/profile.d
88
89 mkdir -p $RPM_BUILD_ROOT%{_datadir}/icons/default
90 tar -C $RPM_BUILD_ROOT%{_datadir}/icons/default -xvf %{SOURCE1}
91
92 %files
93 %manifest packaging/weston.manifest
94 %defattr(-,root,root,-)
95 %{_bindir}/weston
96 %{_bindir}/weston-terminal
97 %{_bindir}/weston-info
98 %{_bindir}/wayland-*
99 %{_bindir}/wcap-decode
100 %dir %{_libdir}/weston/
101 %{_libdir}/weston/*.so
102 %{_libexecdir}/weston-desktop-shell
103 %{_libexecdir}/weston-tablet-shell
104 %{_libexecdir}/weston-screenshooter
105 %dir %{_datadir}/weston/
106 %{_datadir}/weston/*.*
107 %{_datadir}/man/*/*
108 %{_libdir}/systemd/system/weston.service
109 %{_libdir}/systemd/system/graphical.target.wants/weston.service
110 %{_libdir}/udev/rules.d/99-vtc1000-quirk.rules
111 %{_sysconfdir}/profile.d/weston.sh
112 %{_sysconfdir}/rc.d/init.d/weston
113 %{_sysconfdir}/rc.d/rc3.d/S20weston
114
115 %files cursors
116 %defattr(-,root,root,-)
117 %{_datadir}/icons/default/cursors/*