Added missing weston-devel package dependencies.
[profile/ivi/weston.git] / packaging / weston.spec
1 Name:       weston
2 Summary:    Weston Compositor
3 Version:    1.0.6
4 Release:    1
5 Group:      System/Libraries
6 License:    MIT
7 URL:        http://wayland.freedesktop.org
8 Source0:    %{name}-%{version}.tar.bz2
9 Source1:    cursors.tar.bz2
10 Source2:    weston.service
11 Source3:    99-vtc1000-quirk.rules
12 Source4:    rc.weston
13 Source5:    weston.sh
14 Source6:    weston.manifest
15 BuildRequires: pkgconfig(wayland-server)
16 BuildRequires: pkgconfig(egl)
17 BuildRequires: pkgconfig(gl)
18 BuildRequires: pkgconfig(glesv2)
19 BuildRequires: pkgconfig(pixman-1)
20 BuildRequires: pkgconfig(libpng)
21 BuildRequires: pkgconfig(libudev)
22 BuildRequires: pkgconfig(libdrm)
23 BuildRequires: pkgconfig(gbm)
24 BuildRequires: pkgconfig(wayland-client)
25 BuildRequires: pkgconfig(wayland-egl)
26 BuildRequires: pkgconfig(cairo)
27 BuildRequires: pkgconfig(gdk-pixbuf-2.0)
28 BuildRequires: pkgconfig(glib-2.0)
29 BuildRequires: pkgconfig(gobject-2.0)
30 BuildRequires: pkgconfig(gio-2.0)
31 BuildRequires: pkgconfig(xkbcommon)
32 BuildRequires: pkgconfig(libpng)
33 BuildRequires: pkgconfig(mtdev)
34 BuildRequires: pkgconfig(xcursor)
35 BuildRequires: libjpeg-devel
36 Requires: xkeyboard-config
37
38 %description
39 Weston compositor
40
41 %package devel
42 Summary:    Development files for %{name}
43 Group:      Development/Libraries
44 Requires:   %{name} = %{version}-%{release}
45 Requires:   wayland-devel = %{version}
46 Requires:   libGLESv2-devel
47 Requires:   libEGL-devel
48 Requires:   libxkbcommon-devel
49 Requires:   pixman-devel
50
51 %description devel
52 Development files needed for building Weston modules
53
54 %package cursors
55 Summary:    Adds a simple cursor theme to the default cursor theme
56 Group:      System/Libraries
57 Requires:   %{name} = %{version}-%{release}
58
59 %description cursors
60 Adds a simple cursor theme to the default cursor theme
61
62 %prep
63 %setup -q -n %{name}-%{version}
64
65 %build
66
67 %autogen --disable-weston-launch --disable-setuid-install --disable-x11-compositor --disable-xwayland
68
69 make %{?_smp_mflag}
70
71 %install
72 rm -rf %{buildroot}
73 %make_install
74
75 install -m 755 clients/dnd $RPM_BUILD_ROOT%{_bindir}/wayland-dnd
76 install -m 755 clients/eventdemo $RPM_BUILD_ROOT%{_bindir}/wayland-eventdemo
77 install -m 755 clients/flower $RPM_BUILD_ROOT%{_bindir}/wayland-flower
78 install -m 755 clients/image $RPM_BUILD_ROOT%{_bindir}/wayland-image
79 install -m 755 clients/resizor $RPM_BUILD_ROOT%{_bindir}/wayland-resizor
80 install -m 755 clients/simple-egl $RPM_BUILD_ROOT%{_bindir}/wayland-simple-egl
81 install -m 755 clients/simple-shm $RPM_BUILD_ROOT%{_bindir}/wayland-simple-shm
82 install -m 755 clients/simple-touch $RPM_BUILD_ROOT%{_bindir}/wayland-simple-touch
83 install -m 755 clients/smoke $RPM_BUILD_ROOT%{_bindir}/wayland-smoke
84
85 # Systemd
86 mkdir -p $RPM_BUILD_ROOT/%{_libdir}/systemd/system/graphical.target.wants
87 install -m 0644 %{SOURCE2} $RPM_BUILD_ROOT/%{_libdir}/systemd/system/
88 mkdir -p $RPM_BUILD_ROOT/%{_libdir}/udev/rules.d/
89 install -m 0644 %{SOURCE3} $RPM_BUILD_ROOT/%{_libdir}/udev/rules.d/
90 ln -sf ../weston.service $RPM_BUILD_ROOT/%{_libdir}/systemd/system/graphical.target.wants/weston.service
91
92 # System V
93 mkdir -p %{buildroot}%{_sysconfdir}/rc.d/init.d
94 mkdir -p %{buildroot}%{_sysconfdir}/rc.d/rc3.d
95 install -m 0755 %{SOURCE4} %{buildroot}%{_sysconfdir}/rc.d/init.d/weston
96 ln -sf %{_sysconfdir}/rc.d/init.d/weston %{buildroot}%{_sysconfdir}/rc.d/rc3.d/S20weston
97
98 # Environment variables necessary to run Weston and Wayland clients.
99 mkdir -p %{buildroot}%{_sysconfdir}/profile.d
100 install -m 0644 %{SOURCE5} %{buildroot}%{_sysconfdir}/profile.d
101
102 mkdir -p $RPM_BUILD_ROOT%{_datadir}/icons/default
103 tar -C $RPM_BUILD_ROOT%{_datadir}/icons/default -xvf %{SOURCE1}
104
105 %files
106 %manifest packaging/weston.manifest
107 %defattr(-,root,root,-)
108 %{_bindir}/weston
109 %{_bindir}/weston-terminal
110 %{_bindir}/weston-info
111 %{_bindir}/wayland-*
112 %{_bindir}/wcap-decode
113 %dir %{_libdir}/weston/
114 %{_libdir}/weston/*.so
115 %{_libexecdir}/weston-desktop-shell
116 %{_libexecdir}/weston-tablet-shell
117 %{_libexecdir}/weston-screenshooter
118 %dir %{_datadir}/weston/
119 %{_datadir}/weston/*.*
120 %{_datadir}/man/*/*
121 %{_libdir}/systemd/system/weston.service
122 %{_libdir}/systemd/system/graphical.target.wants/weston.service
123 %{_libdir}/udev/rules.d/99-vtc1000-quirk.rules
124 %{_sysconfdir}/profile.d/weston.sh
125 %{_sysconfdir}/rc.d/init.d/weston
126 %{_sysconfdir}/rc.d/rc3.d/S20weston
127
128 %files devel
129 %defattr(-,root,root,-)
130 %{_includedir}/weston/*.h
131 %{_libdir}/pkgconfig/*.pc
132
133 %files cursors
134 %defattr(-,root,root,-)
135 %{_datadir}/icons/default/cursors/*