463028a95bfd0b9e3ade69a07146074d65f76236
[profile/ivi/webskeleton.git] / packaging / webskeleton.spec
1 Name:       webskeleton
2 Summary:    Simple native container for hosting webapps without the advantage of a full webruntime
3 Version:    0.2
4 Release:    1
5 Group:      System/Libraries
6 License:    GPLv2.1
7 URL:        https://github.com/otcshare/webskeleton
8 Source0:    %{name}-%{version}.tar.bz2
9 Requires(post): /sbin/ldconfig
10 Requires(postun): /sbin/ldconfig
11
12 BuildRequires: pkgconfig(ecore)
13 BuildRequires: pkgconfig(evas)
14 BuildRequires: pkgconfig(eina)
15 BuildRequires: pkgconfig(ewebkit2)
16 BuildRequires: pkgconfig(elementary)
17
18 %description
19 Webskeleton application container
20
21 %prep
22 %setup -q -n %{name}-%{version}
23
24 %build
25
26 make %{?jobs:-j%jobs}
27
28 %install
29 rm -rf %{buildroot}
30 %make_install
31
32 %post -p /sbin/ldconfig
33
34 %postun -p /sbin/ldconfig
35
36 %files
37 %defattr(-,root,root,-)
38 %{_bindir}/webskeleton