2a86a562c93c354946c8073367d6b2018ce39b6b
[profile/ivi/webskeleton.git] / packaging / webskeleton.spec
1 Name:       webskeleton
2 Summary:    Simple native container for hosting webapps without the advantage of a full webruntime
3 Version:    0.2
4 Release:    1
5 Group:      System/Libraries
6 License:    GPLv2.1
7 URL:        https://github.com/otcshare/webskeleton
8 Source0:    %{name}-%{version}.tar.bz2
9 Requires(post): /sbin/ldconfig
10 Requires(postun): /sbin/ldconfig
11
12 BuildRequires: pkgconfig(ecore)
13 BuildRequires: pkgconfig(evas)
14 BuildRequires: pkgconfig(eina)
15 BuildRequires: pkgconfig(ewebkit2)
16
17 %description
18 Webskeleton application container
19
20 %prep
21 %setup -q -n %{name}-%{version}
22
23 %build
24
25 make %{?jobs:-j%jobs}
26
27 %install
28 rm -rf %{buildroot}
29 %make_install
30
31 %post -p /sbin/ldconfig
32
33 %postun -p /sbin/ldconfig
34
35 %files
36 %defattr(-,root,root,-)
37 %{_bindir}/webskeleton