[version] 0.38
[platform/core/api/webapi-plugins.git] / packaging / webapi-plugins.spec
1 %define _manifestdir %{TZ_SYS_RW_PACKAGES}
2 %define _desktop_icondir %{TZ_SYS_SHARE}/icons/default/small
3
4 %define crosswalk_extensions tizen-extensions-crosswalk
5
6 Name:       webapi-plugins
7 Version:    0.38
8 Release:    0
9 License:    Apache-2.0 and BSD-2.0 and MIT
10 Group:      Development/Libraries
11 Summary:    Tizen Web APIs implemented
12 Source0:    %{name}-%{version}.tar.gz
13
14 %ifarch %{arm}
15 # ARM
16 %define tizen_is_emulator           0
17 %else
18 # I586
19 %define tizen_is_emulator           1
20 %endif
21
22 ####################################################################
23 #       Mobile Profile :  Redwood(SM-Z910F), KIRAN(Z130H)          #
24 ####################################################################
25 %if "%{?tizen_profile_name}" == "mobile"
26
27 %define tizen_privilege_engine                        ACE
28
29 %define tizen_feature_account_support                 1
30 %define tizen_feature_alarm_support                   1
31 %define tizen_feature_app_control_settings_support    1
32 %define tizen_feature_application_support             1
33 %define tizen_feature_archive_support                 1
34 %define tizen_feature_badge_support                   1
35 %ifarch %{arm}
36 # ARM
37 %define tizen_feature_bluetooth_support               1
38 %else
39 # I586
40 %define tizen_feature_bluetooth_support               0
41 %endif
42 %define tizen_feature_bookmark_support                1
43 %define tizen_feature_calendar_support                1
44 %define tizen_feature_contact_support                 1
45 %define tizen_feature_content_support                 1
46 %define tizen_feature_datacontrol_support             1
47 %define tizen_feature_datasync_support                0
48 %define tizen_feature_download_support                1
49 %define tizen_feature_exif_support                    1
50 %define tizen_feature_filesystem_support              1
51 %define tizen_feature_fm_radio_support                1
52 %ifarch %{arm}
53 # ARM
54 %define tizen_feature_ham_support                     0
55 %else
56 # I586
57 %define tizen_feature_ham_support                     1
58 %endif
59 %define tizen_feature_location_batch                  0
60 %define tizen_feature_key_manager_support             0
61 %define tizen_feature_media_controller_support        1
62 %ifarch %{arm}
63 # ARM
64 %define tizen_feature_media_key_support               1
65 %else
66 # I586
67 %define tizen_feature_media_key_support               0
68 %endif
69 %define tizen_feature_message_port_support            1
70 %define tizen_feature_messaging_support               1
71
72 %if 0%{?model_build_feature_nfc}
73 %define tizen_feature_nfc_emulation_support           0
74 %define tizen_feature_nfc_support                     1
75 %else
76 %define tizen_feature_nfc_emulation_support           0
77 %define tizen_feature_nfc_support                     0
78 %endif
79 %define tizen_feature_notification_support            1
80 %define tizen_feature_package_support                 1
81 %define tizen_feature_power_support                   1
82 %define tizen_feature_push_support                    1
83 %ifarch %{arm}
84 # ARM
85 %define tizen_feature_se_support                      1
86 %else
87 # I586
88 %define tizen_feature_se_support                      0
89 %endif
90 %define tizen_feature_sensor_support                  1
91 %define tizen_feature_sound_support                   1
92 %define tizen_feature_system_info_support             1
93 %define tizen_feature_system_setting_support          1
94 %ifarch %{arm}
95 # ARM
96 %define tizen_feature_telephony_support               1
97 %else
98 # I586
99 %define tizen_feature_telephony_support               0
100 %endif
101 %define tizen_feature_time_support                    1
102 %define tizen_feature_web_setting_support             1
103 %ifarch %{arm}
104 # ARM
105 %define tizen_feature_wi_fi_support                   1
106 %else
107 # I586
108 %define tizen_feature_wi_fi_support                   0
109 %endif
110 %define tizen_feature_tvaudio_support                 0
111 %define tizen_feature_tvchannel_support               0
112 %define tizen_feature_tv_display_support              0
113 %define tizen_feature_tvinputdevice_support           0
114 %define tizen_feature_inputdevice_support             1
115 %define tizen_feature_tvwindow_support                0
116
117 %if 0%{?tizen_feature_telephony_support}
118 %define tizen_feature_callhistory_support             1
119 %define tizen_feature_nbs_support                     1
120 %else
121 %define tizen_feature_callhistory_support             0
122 %define tizen_feature_nbs_support                     0
123 %endif
124
125 %endif # tizen_profile_mobile
126
127 ####################################################################
128 #       Wearable Profile :  B2                          #
129 ####################################################################
130 %if "%{?tizen_profile_name}" == "wearable"
131
132 %define tizen_privilege_engine                        ACE
133
134 # Account API is optional in Tizen Wearable Profile.
135 %define tizen_feature_account_support                 0
136
137 %define tizen_feature_alarm_support                   1
138 %define tizen_feature_app_control_settings_support    1
139 %define tizen_feature_application_support             1
140
141 # Archive API is optional in Tizen Wearable Profile.
142 %define tizen_feature_archive_support                 1
143
144 # Badge API is mandatory in Tizen Wearable Profile.
145 %define tizen_feature_badge_support                   1
146
147 %define tizen_feature_bluetooth_support               1
148
149 # Bookmark API is optional in Tizen Wearable Profile.
150 %define tizen_feature_bookmark_support                0
151
152 # Calendar API is mandatory in Tizen Wearable Profile.
153 %define tizen_feature_calendar_support                0
154 %define tizen_feature_contact_support                 0
155 %define tizen_feature_content_support                 1
156 %define tizen_feature_datacontrol_support             0
157 %define tizen_feature_datasync_support                0
158 %ifarch %{arm}
159 %define tizen_feature_download_support                0
160 %else
161 %define tizen_feature_download_support                1
162 %endif
163 %define tizen_feature_exif_support                    1
164 %define tizen_feature_filesystem_support              1
165 %define tizen_feature_fm_radio_support                0
166 %define tizen_feature_ham_support                     1
167 %define tizen_feature_location_batch                  0
168 %define tizen_feature_media_controller_support        1
169
170 # MediayKey API is optional in Tizen Wearable Profile.
171 # tizen.org/feature/network.bluetooth.audio.media is required for MediayKey API
172 %ifarch %{arm}
173 # ARM
174 %define tizen_feature_media_key_support               1
175 %else
176 # I586
177 %define tizen_feature_media_key_support               0
178 %endif
179 %define tizen_feature_key_manager_support             0
180 %define tizen_feature_message_port_support            1
181 %define tizen_feature_messaging_support               0
182
183 %if 0%{?model_build_feature_nfc}
184 %define tizen_feature_nfc_emulation_support           0
185 %define tizen_feature_nfc_support                     1
186 %else
187 %define tizen_feature_nfc_emulation_support           0
188 %define tizen_feature_nfc_support                     0
189 %endif
190 %define tizen_feature_notification_support            1
191 %define tizen_feature_package_support                 1
192 %define tizen_feature_power_support                   1
193 %define tizen_feature_push_support                    1
194 %if 0%{?model_build_feature_smartcard }
195 %define tizen_feature_se_support                      1
196 %else
197 %define tizen_feature_se_support                      0
198 %endif
199 %define tizen_feature_sensor_support                  1
200 %define tizen_feature_sound_support                   1
201 %define tizen_feature_system_info_support             1
202 %define tizen_feature_system_setting_support          1
203 %define tizen_feature_telephony_support               0
204 %define tizen_feature_time_support                    1
205 %define tizen_feature_web_setting_support             0
206 %define tizen_feature_wi_fi_support                   1
207 %define tizen_feature_tvaudio_support                 0
208 %define tizen_feature_tvchannel_support               0
209 %define tizen_feature_tv_display_support              0
210 %define tizen_feature_tvinputdevice_support           0
211 %define tizen_feature_inputdevice_support             1
212 %define tizen_feature_tvwindow_support                0
213
214 #- telephony related APIs
215 # CallHistory API is optional in Tizen Wearable Profile.
216 # NetworkBearerSelection API is optional in Tizen Wearable Profile.
217 %if 0%{?tizen_feature_telephony_support}
218 %define    tizen_feature_callhistory_support          1
219 %define    tizen_feature_nbs_support                  1
220 %else
221 %define    tizen_feature_callhistory_support          0
222 %define    tizen_feature_nbs_support                  0
223 %endif
224
225 %endif # tizen_profile_wearable
226
227 ####################################################################
228 #       TV Profile                                                 #
229 ####################################################################
230 %if "%{?tizen_profile_name}" == "tv"
231
232 %define tizen_privilege_engine                        ACE
233
234 %define tizen_feature_account_support                 0
235 %define tizen_feature_alarm_support                   1
236 %define tizen_feature_app_control_settings_support    0
237 %define tizen_feature_application_support             1
238 %define tizen_feature_archive_support                 1
239 %define tizen_feature_badge_support                   0
240 %define tizen_feature_bluetooth_support               0
241 %define tizen_feature_bookmark_support                0
242 %define tizen_feature_calendar_support                0
243 %define tizen_feature_callhistory_support             0
244 %define tizen_feature_contact_support                 0
245 %define tizen_feature_content_support                 1
246 %define tizen_feature_datacontrol_support             0
247 %define tizen_feature_datasync_support                0
248 %define tizen_feature_download_support                1
249 %define tizen_feature_exif_support                    1
250 %define tizen_feature_filesystem_support              1
251 %define tizen_feature_fm_radio_support                0
252 %define tizen_feature_ham_support                     0
253 %define tizen_feature_key_manager_support             0
254 %define tizen_feature_media_controller_support        1
255 %define tizen_feature_media_key_support               1
256 %define tizen_feature_message_port_support            1
257 %define tizen_feature_messaging_support               0
258 %define tizen_feature_nbs_support                     0
259 %define tizen_feature_nfc_emulation_support           0
260 %define tizen_feature_nfc_support                     0
261 %define tizen_feature_notification_support            0
262 %define tizen_feature_package_support                 1
263 %define tizen_feature_power_support                   0
264 %define tizen_feature_push_support                    0
265 %define tizen_feature_se_support                      0
266 %define tizen_feature_sensor_support                  0
267 %define tizen_feature_sound_support                   0
268 %define tizen_feature_system_info_support             1
269 %define tizen_feature_system_setting_support          0
270 %define tizen_feature_telephony_support               0
271 %define tizen_feature_time_support                    1
272 %define tizen_feature_web_setting_support             1
273 %define tizen_feature_wi_fi_support                   1
274 #off for tizen 3.0 (no libavoc)
275 %define tizen_feature_tvaudio_support                 0
276 #off for tizen 3.0 (no tvs-api)
277 %define tizen_feature_tvchannel_support               0
278 #off for tizen 3.0 (no systeminfo definitions)
279 %define tizen_feature_tv_display_support              0
280 %define tizen_feature_tvinputdevice_support           1
281 %define tizen_feature_inputdevice_support             0
282 %define tizen_feature_tvwindow_support                0
283
284 %endif # tizen_profile_tv
285
286 BuildRequires: ninja
287 BuildRequires: pkgconfig(appcore-common)
288 BuildRequires: pkgconfig(dbus-1)
289 BuildRequires: pkgconfig(dbus-glib-1)
290 BuildRequires: pkgconfig(dlog)
291 BuildRequires: pkgconfig(evas)
292 BuildRequires: pkgconfig(gio-2.0)
293 BuildRequires: pkgconfig(glib-2.0)
294 BuildRequires: pkgconfig(libudev)
295 BuildRequires: pkgconfig(minizip)
296 BuildRequires: pkgconfig(zlib)
297 BuildRequires: pkgconfig(pkgmgr)
298 BuildRequires: pkgconfig(pkgmgr-info)
299 BuildRequires: pkgconfig(vconf)
300 BuildRequires: pkgconfig(x11)
301 BuildRequires: pkgconfig(xrandr)
302 BuildRequires: pkgconfig(ecore)
303 BuildRequires: pkgconfig(icu-i18n)
304 BuildRequires: pkgconfig(aul)
305 BuildRequires: pkgconfig(storage)
306 BuildRequires: python
307 BuildRequires: pkgconfig(capi-base-common)
308 BuildRequires: pkgconfig(capi-system-info)
309 BuildRequires: pkgconfig(capi-system-runtime-info)
310 BuildRequires: pkgconfig(capi-network-connection)
311 BuildRequires: pkgconfig(capi-system-device)
312 BuildRequires: pkgconfig(capi-system-system-settings)
313 BuildRequires: pkgconfig(capi-network-bluetooth)
314 BuildRequires: pkgconfig(capi-network-wifi)
315 BuildRequires: pkgconfig(tapi)
316 BuildRequires: pkgconfig(libpcrecpp)
317 BuildRequires: pkgconfig(capi-appfw-application)
318 BuildRequires: pkgconfig(capi-appfw-app-manager)
319 BuildRequires: pkgconfig(capi-appfw-package-manager)
320 BuildRequires: pkgconfig(capi-content-media-content)
321 BuildRequires: pkgconfig(capi-media-metadata-extractor)
322
323 %if "%{?tizen_privilege_engine}" == "ACE"
324 BuildRequires: pkgconfig(security-privilege-checker)
325 %endif
326
327 %if "%{?tizen_privilege_engine}" == "CYNARA"
328 BuildRequires: pkgconfig(cynara-client)
329 BuildRequires: pkgconfig(libsmack)
330 %endif
331
332 %if 0%{?tizen_feature_account_support}
333 BuildRequires: pkgconfig(accounts-svc)
334 %endif
335
336 %if 0%{?tizen_feature_alarm_support}
337 BuildRequires: pkgconfig(capi-appfw-alarm)
338 BuildRequires: pkgconfig(alarm-service)
339 %endif
340
341 %if 0%{?tizen_feature_bookmark_support}
342 BuildRequires: pkgconfig(capi-web-bookmark)
343 BuildRequires: pkgconfig(bookmark-adaptor)
344 %endif
345
346 %if 0%{?tizen_feature_datacontrol_support}
347 BuildRequires: pkgconfig(capi-data-control)
348 %endif
349
350 %if 0%{?tizen_feature_download_support}
351 BuildRequires: pkgconfig(capi-web-url-download)
352 %endif
353
354 %if 0%{?tizen_feature_ham_support}
355 BuildRequires: pkgconfig(motion)
356 BuildRequires: pkgconfig(capi-system-sensor)
357 BuildRequires: pkgconfig(capi-location-manager)
358 %endif
359
360 %if 0%{?tizen_feature_power_support}
361 BuildRequires: pkgconfig(deviced)
362 %endif
363
364 %if 0%{?tizen_feature_power_support}
365 BuildRequires: pkgconfig(capi-appfw-application)
366 %endif
367
368 %if 0%{?tizen_feature_push_support}
369 BuildRequires: pkgconfig(push)
370 %endif
371
372 %if 0%{?tizen_feature_key_manager_support}
373 BuildRequires: pkgconfig(key-manager)
374 %endif
375
376 %if 0%{?tizen_feature_media_controller_support}
377 BuildRequires: pkgconfig(capi-media-controller)
378 %endif
379
380 %if 0%{?tizen_feature_messaging_support}
381 BuildRequires:  pkgconfig(ecore-file)
382 BuildRequires:  pkgconfig(email-service)
383 BuildRequires:  pkgconfig(msg-service)
384 BuildRequires:  pkgconfig(db-util)
385 %endif
386
387 %if 0%{?tizen_feature_badge_support}
388 BuildRequires:  pkgconfig(badge)
389 %endif
390
391 %if 0%{?tizen_feature_calendar_support}
392 BuildRequires:  pkgconfig(calendar-service2)
393 %endif
394
395 %if 0%{?tizen_feature_contact_support}
396 BuildRequires:  pkgconfig(contacts-service2)
397 %endif
398
399 %if 0%{?tizen_feature_callhistory_support}
400 BuildRequires:  pkgconfig(contacts-service2)
401 %endif
402
403 %if 0%{?tizen_feature_tvchannel_support}
404 BuildRequires: pkgconfig(tvs-api)
405 %endif
406
407 %if 0%{?tizen_feature_tvwindow_support}
408 #TODO Currently, TVWindow does not have implementation yet.
409 #Hence, below dependency can be disabled (there is no tvs-api on tizen 3.0 yet)
410 #BuildRequires: pkgconfig(tvs-api)
411 %endif
412
413 %if 0%{?tizen_feature_exif_support}
414 BuildRequires:  pkgconfig(libexif)
415 %endif
416
417 %if 0%{?tizen_feature_nfc_support}
418 BuildRequires:  pkgconfig(capi-network-nfc)
419 %endif
420
421 %if 0%{?tizen_feature_fm_radio_support}
422 BuildRequires: pkgconfig(capi-media-radio)
423 %endif
424
425 %if 0%{?tizen_feature_tvaudio_support}
426 BuildRequires:  pkgconfig(libavoc)
427 BuildRequires:  pkgconfig(capi-media-audio-io)
428 %endif
429
430 %if 0%{?tizen_feature_se_support}
431 BuildRequires:  pkgconfig(smartcard-service)
432 BuildRequires:  pkgconfig(smartcard-service-common)
433 %endif
434
435 %if 0%{?tizen_feature_message_port_support}
436 BuildRequires: pkgconfig(capi-message-port)
437 %endif
438
439 %if 0%{?tizen_feature_notification_support}
440 BuildRequires: pkgconfig(notification)
441 %endif
442
443 %if 0%{?tizen_feature_sound_support}
444 BuildRequires:  pkgconfig(capi-media-sound-manager)
445 %endif
446
447 %if 0%{?tizen_feature_sensor_support}
448 BuildRequires: pkgconfig(capi-system-sensor)
449 %endif
450
451 %if 0%{?tizen_feature_media_key_support}
452 BuildRequires:  pkgconfig(capi-system-media-key)
453 %endif
454
455 %description
456 Tizen Web APIs implemented.
457
458 %package devel
459 Summary:    webapi-plugins development headers
460 Group:      Development/Libraries
461 Requires:   %{name} = %{version}
462
463 %description devel
464 webapi-plugins development headers
465
466 %prep
467 %setup -q
468
469 %build
470
471 export GYP_GENERATORS='ninja'
472 GYP_OPTIONS="--depth=. -Dtizen=1 -Dextension_build_type=Debug -Dextension_host_os=%{tizen_profile_name} -Dprivilege_engine=%{tizen_privilege_engine}"
473 GYP_OPTIONS="$GYP_OPTIONS -Ddisplay_type=x11"
474
475 # feature flags
476 GYP_OPTIONS="$GYP_OPTIONS -Dtizen_is_emulator=%{?tizen_is_emulator}"
477 GYP_OPTIONS="$GYP_OPTIONS -Dtizen_feature_account_support=%{?tizen_feature_account_support}"
478 GYP_OPTIONS="$GYP_OPTIONS -Dtizen_feature_alarm_support=%{?tizen_feature_alarm_support}"
479 GYP_OPTIONS="$GYP_OPTIONS -Dtizen_feature_app_control_settings_support=%{?tizen_feature_app_control_settings_support}"
480 GYP_OPTIONS="$GYP_OPTIONS -Dtizen_feature_application_support=%{?tizen_feature_application_support}"
481 GYP_OPTIONS="$GYP_OPTIONS -Dtizen_feature_archive_support=%{?tizen_feature_archive_support}"
482 GYP_OPTIONS="$GYP_OPTIONS -Dtizen_feature_badge_support=%{?tizen_feature_badge_support}"
483 GYP_OPTIONS="$GYP_OPTIONS -Dtizen_feature_bluetooth_support=%{?tizen_feature_bluetooth_support}"
484 GYP_OPTIONS="$GYP_OPTIONS -Dtizen_feature_bookmark_support=%{?tizen_feature_bookmark_support}"
485 GYP_OPTIONS="$GYP_OPTIONS -Dtizen_feature_calendar_support=%{?tizen_feature_calendar_support}"
486 GYP_OPTIONS="$GYP_OPTIONS -Dtizen_feature_callhistory_support=%{?tizen_feature_callhistory_support}"
487 GYP_OPTIONS="$GYP_OPTIONS -Dtizen_feature_contact_support=%{?tizen_feature_contact_support}"
488 GYP_OPTIONS="$GYP_OPTIONS -Dtizen_feature_content_support=%{?tizen_feature_content_support}"
489 GYP_OPTIONS="$GYP_OPTIONS -Dtizen_feature_datacontrol_support=%{?tizen_feature_datacontrol_support}"
490 GYP_OPTIONS="$GYP_OPTIONS -Dtizen_feature_datasync_support=%{?tizen_feature_datasync_support}"
491 GYP_OPTIONS="$GYP_OPTIONS -Dtizen_feature_download_support=%{?tizen_feature_download_support}"
492 GYP_OPTIONS="$GYP_OPTIONS -Dtizen_feature_exif_support=%{?tizen_feature_exif_support}"
493 GYP_OPTIONS="$GYP_OPTIONS -Dtizen_feature_filesystem_support=%{?tizen_feature_filesystem_support}"
494 GYP_OPTIONS="$GYP_OPTIONS -Dtizen_feature_fm_radio_support=%{?tizen_feature_fm_radio_support}"
495 GYP_OPTIONS="$GYP_OPTIONS -Dtizen_feature_ham_support=%{?tizen_feature_ham_support}"
496 GYP_OPTIONS="$GYP_OPTIONS -Dtizen_feature_location_batch=%{?tizen_feature_location_batch}"
497 GYP_OPTIONS="$GYP_OPTIONS -Dtizen_feature_key_manager_support=%{?tizen_feature_key_manager_support}"
498 GYP_OPTIONS="$GYP_OPTIONS -Dtizen_feature_media_controller_support=%{?tizen_feature_media_controller_support}"
499 GYP_OPTIONS="$GYP_OPTIONS -Dtizen_feature_media_key_support=%{?tizen_feature_media_key_support}"
500 GYP_OPTIONS="$GYP_OPTIONS -Dtizen_feature_message_port_support=%{?tizen_feature_message_port_support}"
501 GYP_OPTIONS="$GYP_OPTIONS -Dtizen_feature_messaging_support=%{?tizen_feature_messaging_support}"
502 GYP_OPTIONS="$GYP_OPTIONS -Dtizen_feature_nbs_support=%{?tizen_feature_nbs_support}"
503 GYP_OPTIONS="$GYP_OPTIONS -Dtizen_feature_nfc_emulation_support=%{?tizen_feature_nfc_emulation_support}"
504 GYP_OPTIONS="$GYP_OPTIONS -Dtizen_feature_nfc_support=%{?tizen_feature_nfc_support}"
505 GYP_OPTIONS="$GYP_OPTIONS -Dtizen_feature_notification_support=%{?tizen_feature_notification_support}"
506 GYP_OPTIONS="$GYP_OPTIONS -Dtizen_feature_package_support=%{?tizen_feature_package_support}"
507 GYP_OPTIONS="$GYP_OPTIONS -Dtizen_feature_power_support=%{?tizen_feature_power_support}"
508 GYP_OPTIONS="$GYP_OPTIONS -Dtizen_feature_push_support=%{?tizen_feature_push_support}"
509 GYP_OPTIONS="$GYP_OPTIONS -Dtizen_feature_sap_support=%{?tizen_feature_sap_support}"
510 GYP_OPTIONS="$GYP_OPTIONS -Dtizen_feature_sensor_support=%{?tizen_feature_sensor_support}"
511 GYP_OPTIONS="$GYP_OPTIONS -Dtizen_feature_se_support=%{?tizen_feature_se_support}"
512 GYP_OPTIONS="$GYP_OPTIONS -Dtizen_feature_sound_support=%{?tizen_feature_sound_support}"
513 GYP_OPTIONS="$GYP_OPTIONS -Dtizen_feature_system_info_support=%{?tizen_feature_system_info_support}"
514 GYP_OPTIONS="$GYP_OPTIONS -Dtizen_feature_system_setting_support=%{?tizen_feature_system_setting_support}"
515 GYP_OPTIONS="$GYP_OPTIONS -Dtizen_feature_telephony_support=%{?tizen_feature_telephony_support}"
516 GYP_OPTIONS="$GYP_OPTIONS -Dtizen_feature_time_support=%{tizen_feature_time_support}"
517 GYP_OPTIONS="$GYP_OPTIONS -Dtizen_feature_tvaudio_support=%{?tizen_feature_tvaudio_support}"
518 GYP_OPTIONS="$GYP_OPTIONS -Dtizen_feature_tvchannel_support=%{?tizen_feature_tvchannel_support}"
519 GYP_OPTIONS="$GYP_OPTIONS -Dtizen_feature_tv_display_support=%{?tizen_feature_tv_display_support}"
520 GYP_OPTIONS="$GYP_OPTIONS -Dtizen_feature_tvinputdevice_support=%{?tizen_feature_tvinputdevice_support}"
521 GYP_OPTIONS="$GYP_OPTIONS -Dtizen_feature_inputdevice_support=%{?tizen_feature_inputdevice_support}"
522 GYP_OPTIONS="$GYP_OPTIONS -Dtizen_feature_tvwindow_support=%{?tizen_feature_tvwindow_support}"
523 GYP_OPTIONS="$GYP_OPTIONS -Dtizen_feature_web_setting_support=%{?tizen_feature_web_setting_support}"
524 GYP_OPTIONS="$GYP_OPTIONS -Dtizen_feature_wi_fi_support=%{?tizen_feature_wi_fi_support}"
525
526 ./tools/gyp/gyp $GYP_OPTIONS src/tizen-wrt.gyp
527
528 ninja -C out/Default %{?_smp_mflags}
529
530 %install
531 mkdir -p %{buildroot}/usr/share/license
532 cp LICENSE %{buildroot}/usr/share/license/%{name}
533 cat LICENSE.BSD-2.0 >> %{buildroot}/usr/share/license/%{name}
534
535 # Extensions.
536 mkdir -p %{buildroot}%{_libdir}/%{crosswalk_extensions}
537 install -p -m 644 out/Default/libtizen*.so %{buildroot}%{_libdir}/%{crosswalk_extensions}
538
539 # devel files
540 mkdir -p %{buildroot}%{_libdir}/pkgconfig
541 cp packaging/%{name}.pc %{buildroot}%{_libdir}/pkgconfig
542 mkdir -p %{buildroot}%{_includedir}/%{name}/src/common
543 install -p -m 644 src/common/*.h %{buildroot}%{_includedir}/%{name}/src/common
544 install -p -m 644 src/common/*.gypi %{buildroot}%{_includedir}/%{name}/src/common
545 install -p -m 644 src/common/XW_Extension.cc %{buildroot}%{_includedir}/%{name}/src/common
546 mkdir -p %{buildroot}%{_includedir}/%{name}/tools
547 install -p -m 644 tools/generate_api.py %{buildroot}%{_includedir}/%{name}/tools
548 install -p -m 644 tools/mergejs.py %{buildroot}%{_includedir}/%{name}/tools
549 install -p -m 644 tools/js_minimize.py %{buildroot}%{_includedir}/%{name}/tools
550 cp -a tools/gyp %{buildroot}%{_includedir}/%{name}/tools/gyp
551 cp -a tools/slimit %{buildroot}%{_includedir}/%{name}/tools/slimit
552
553 %if 0%{?tizen_feature_tvaudio_support}
554 # tv audio beep files:
555 %define ringtones_directory /opt/usr/share/settings/Ringtones/
556 mkdir -p %{buildroot}%{ringtones_directory}
557 cp res/tvsounds/*.pcm %{buildroot}%{ringtones_directory}
558 %endif
559
560 # execute desc_gentool
561 LD_LIBRARY_PATH=$LD_LIBRARY_PATH:%{buildroot}%{_libdir}/%{crosswalk_extensions} out/Default/desc_gentool %{buildroot}%{_libdir}/%{crosswalk_extensions} > plugins.json
562
563 # temporary plugins description for lazy loading
564 install -p -m 644 plugins.json %{buildroot}%{_libdir}/%{crosswalk_extensions}/plugins.json
565
566
567 %files
568 %{_libdir}/%{crosswalk_extensions}/libtizen*.so
569 %{_libdir}/%{crosswalk_extensions}/plugins.json
570 %{_datadir}/license/%{name}
571 %manifest webapi-plugins.manifest
572
573 %if 0%{?tizen_feature_tvaudio_support}
574 # tv audio beep files:
575 %{ringtones_directory}/*.pcm
576 %endif
577
578 %files devel
579 %{_includedir}/*
580 %{_libdir}/pkgconfig/*