0.2.11 release
[platform/framework/web/web-ui-fw.git] / packaging / web-ui-fw.spec
1 Name:       web-ui-fw
2 Version:    0.2.11
3 Release:    0
4 Summary:    Tizen Web UI Framework Library
5 Group:      Development/Other
6 License:    MIT
7 BuildArch:  noarch
8 BuildRequires:  make
9 BuildRequires:  nodejs
10 %ifarch %{arm}
11 BuildRequires:  nodejs-x86-arm
12 %endif
13
14 Source0:    %{name}-%{version}.tar.gz
15
16 %description
17 Tizen Web UI Framework library and theme packages
18
19 %prep
20 %setup -q
21
22 %build
23 make all
24
25 %install
26 make DESTDIR=%{buildroot} install
27
28 %post
29
30 %files
31 %manifest web-ui-fw.manifest
32 /usr/share/tizen-web-ui-fw/*/js
33 /usr/share/tizen-web-ui-fw/latest
34 /usr/share/tizen-web-ui-fw/VERSION
35
36 ###############################
37 %package -n web-ui-fw-theme-tizen-gray
38 BuildArch:  noarch
39 Summary:    Tizen Web UI Framework Theme : tizen-gray
40 %Description -n web-ui-fw-theme-tizen-gray
41     Tizen Web UI Framework Theme : tizen-gray
42
43 ###############################
44 %package -n web-ui-fw-theme-tizen-white
45 BuildArch:  noarch
46 Summary:    Tizen Web UI Framework Theme : tizen-white
47 %Description -n web-ui-fw-theme-tizen-white
48     Tizen Web UI Framework Theme : tizen-white
49 %files -n web-ui-fw-theme-tizen-white
50 %manifest web-ui-fw-theme-tizen-white.manifest
51 /usr/share/tizen-web-ui-fw/*/themes/tizen-white
52 /usr/share/tizen-web-ui-fw/*/themes/tizen-tizen
53
54 ###############################
55 %package -n web-ui-fw-theme-default
56 BuildArch:  noarch
57 Summary:    Tizen Web UI Framework Theme : default
58 %Description -n web-ui-fw-theme-default
59     Tizen Web UI Framework Theme : default
60 %files -n web-ui-fw-theme-default
61 %manifest web-ui-fw-theme-default.manifest
62 /usr/share/tizen-web-ui-fw/*/themes/default
63
64 ###############################
65 %package -n web-ui-fw-devel
66 BuildArch:  noarch
67 Summary:    Tizen Web UI Framework Developer's files
68 %Description -n web-ui-fw-devel
69     Tizen Web UI Framework Developer's files
70 %files -n web-ui-fw-devel
71 /usr/share/tizen-web-ui-fw/bin
72 /usr/share/tizen-web-ui-fw/template
73
74 ###############################
75 %package -n web-ui-fw-demo-tizen-winsets
76 BuildArch:  noarch
77 Summary:    Tizen Web UI Framework Demo Application: tizen winset demo
78 %Description -n web-ui-fw-demo-tizen-winsets
79     Tizen Web UI Framework Demo Application: tizen winset demo
80 %files  -n web-ui-fw-demo-tizen-winsets
81 /usr/share/tizen-web-ui-fw/demos/tizen-winsets
82
83
84 ###############################
85 %changelog
86 * Tue Jan 22 2013 Minkyu Kang <mk7.kang@samsung.com> 0.2.11
87         - demo: clear input text value with cancel button click
88         - demo: Adjust textarea height automatically
89         - naviframe : bug fix
90         - tabbar : bug fix
91         - Fastscroll: popup position has been changed
92         - Button: custom button icon path, margin have been changed
93         - toggleswitch : bug fix
94         - slider: increase the margin
95         - datetimepicker: close the popup after select the value
96         - unit-test : add page backbutton control test
97         - Demo: added guide text and change input type in list vi
98         - remove legacy codes : jquery-geo
99         - Datetimepicker: text-main max-width has been removed
100         - Radio: control group border has been removed
101         - Demo: remove 'tab' space
102         - UnitTC: swipe unit tc has been fixed
103         - UnitTC: jQuery path has been fixed
104         - Button: bug fix when button has not a text
105         - tizen-winset: timepicker: demo title is changed
106
107 * Fri Jan 18 2013 Minkyu Kang <mk7.kang@samsung.com> 0.2.10
108         - tizen-winsets: codes cleanup
109         - datetimepicker: date calibration when year is changed
110         - Demo: textarea size has been changed
111         - Demo: Naviframe morebutton demo has been changed
112         - remove unused unit test cases : gallery3d
113         - tizen-winset: remove links
114
115 * Thu Jan 17 2013 Minkyu Kang <mk7.kang@samsung.com> 0.2.9
116         - gallery: use timeout function instead of interval
117         - Tokentextarea: Display error fixed.
118         - scrollview: Fix not selector to respond with jQuery1.8.2
119         - tabbar: remove the width of last element
120         - Demo: apply css 'user-select:none'
121         - Button: guide text has been shorten
122         - build: Update jQuery to 1.8.2 (JQM1.2 compliant)
123         - virtuallist: Fix mistyping
124         - demo: Fix tizen function namespace in demo
125         - virtuallist: Rewrite listitem replacing algorithm
126         - fastscroll: modify from not selector to function
127         - extendablelist: Fix unit-test
128         - tabbar : prefix to tabbar scroll event
129         - Popupwindow: removed unvalid selector in jquery 1.8.2
130         - slider: adjust handle text as length of value
131         - Demo: 3 buttons in popup text has been changed
132         - src: codes cleanup
133         - demo : remove trailing empty strings
134         - demo : rename TizenWinset list items
135         - button : change from long text list to multiline list
136         - build: Remove JQM1.1.0 patches
137         - Popup: Apply tizen style popup and attribute support
138         - JQM: Fix buttonmarkup bug keeping ui-btn-down class
139         - UnitTest: folder and file renamed, QUnit path was modified
140         - tizen-winsets: button: fix textarea width
141         - Swipe: event name error has been fixed
142
143 * Tue Jan 15 2013 Minkyu Kang <mk7.kang@samsung.com> 0.2.8
144         - Button: button padding has been updated
145         - virtuallist: fix unique listitem ID bug
146         - checkbox, radio : change display attr
147         - Button: bug fix ( when data style circle button on text )
148         - handler: bug fix (when scrolling with multi selection)
149         - JQM: adjust patch number
150         - gallery: show the widget after pageshow
151         - TokenTextArea : resource add ( press image )
152         - gallery: adds function that set the index to value API
153         - configure: set TIZEN default configures
154         - footer: h tag display attribute value has been changed
155         - buttons : demo bug fix
156         - searchbar : demo page bug fix
157         - tizen demo : bug fix
158         - build: remove JQM1.1.0
159         - Tokentextarea: Fix issues
160         - scrollview: block the multi touch
161         - list : dialogue list demo change
162         - pagelayout : update dynamic control
163         - Demo: Context popup close method has been changed
164
165 * Fri Jan 11 2013 Minkyu Kang <mk7.kang@samsung.com> 0.2.7
166         - slider: set text container's width as text length
167         - Timepicker: li max-width has been changed
168         - remove experimental feature - mapview.
169         - scrollview: added conditions for finding slider
170         - UnitTC: Pass,error count save method has been changed
171         - confix.xml: default config added for tizen basic applications
172         - Swipe: p tag margin value is set '0'
173         - packaging: remove unused file
174         - tabbar : bug fix
175         - list demo : bug fix
176         - tizen-winsets: gallery: move to new section
177         - tizen-winsets: autodivider: removes link of list
178         - demos: entry of number-pattern name is changed from 'number' to 'number-pattern'
179         - pagelayout : padding calculate change, ime footer check changed
180         - tizen-winsets: searchbar: scroll to the top when type the character
181         - searchbar : bug fix
182         - demo: Fix virtuallist demo following new list style
183         - demo: Add word-wrap:break-word and remove parag. width
184         - Demo: button max-width has been set( 3 buttons in popup )
185         - back button control demo : bug fix
186         - toggleswitch : demo page modify
187         - slider: add margin-top and margin-bottom
188         - tabbar demo : bug fix
189         - Popup: IME hide when popup is closed
190         - token textarea : bug fix
191         - Timepicker: change get attribute method
192         - footer demo : bug fix
193         - unit-test: gallery: add new APIs
194         - gallery: adds support new APIs
195
196 * Fri Jan 04 2013 Minkyu Kang <mk7.kang@samsung.com> 0.2.6
197         - JQM: patches cleanup
198         - Button: data-corners attribute has been added
199         - unit-test: slider: fix class name of background
200         - progressbar, slider: fix less variable typo
201         - Tabbar : VI update
202         - notification: add top position at fix class
203         - demo: entry demo page change
204         - css: .ui-disabled added
205         - tizen-winset: token textarea: remove back button at demo page
206         - theme: Remove unused less file
207         - pagelayout : content min height bug fix
208         - scrollview: skip the dragging when target is slider's handle
209         - scrollview: update and refactoring the scroll effect
210         - UnitTest:JQM Unit TC helper has been added,TCs have been modified
211         - Swipe: demo page html error has been fixed
212         - listview: Add add/delete animation (VI)
213         - Popup: demo page has been modified
214         - tizen demo : bug fix
215         - searchbar : demo page change(change front button and add behaviour)
216         - pagelayout : add min height to content
217         - gallery: rename 'Image Slider' to 'Gallery' in tizen-winsets demo and tests
218         - back button control demo : change url link to data-rel="back"
219         - loader: Skip loading theme CSS with a custom css code
220         - Button: support no-text in button
221         - collapsible: Fix syntax error
222         - slider: use data-highlight attribute
223         - collapsible: Rotate animation to collapsible heading icon
224         - toggleswitch : text switch bug fix
225         - remove candidates-calendarpicker
226         - Patch: Fix misc mistakes in JQM patches
227         - searchbar : animation change
228         - gallery: get the width correctly
229         - demo: data-framework-viewport-scale attribute is changed to data-framework-viewport-width
230         - collapsible: Add collapse/expand animation (VI)
231         - datetimepicker: VI update
232         - JQM: set transition to pop as default
233         - tabbar : bug fix in case none li element case
234         - scrollview: fix the drag bug
235         - Button: Button icon scrolltop, left has beed added
236         - Swipe: VI update and swipe speed has been changed
237         - jqm: fix errors in patch files
238         - unit-test: swipe: fixed the destroy test
239
240 * Wed Dec 26 2012 Youmin Ha <youmin.ha@samsung.com> 0.2.5
241         - Revert "[checkboxradio] exception handling for input"
242                 This reverts commit 72478c32704fa96362db577e6cf9511777919ea8.
243                 Tizen style supports no-label radio and checkbox when making lists.
244                 So it ignores html input operation. Instead, it supports tizen style radio and checkbox theme.
245
246 * Thu Dec 20 2012 Youmin Ha <youmin.ha@samsung.com> 0.2.4
247 - Fix:
248         - modify segment background
249         - rearrange check, radio input
250         - CtxPopup: Scale up/ down popup vi(poptop, popbottom)
251         - button: style has beed added(box,circle,nobg,round)
252         - favorite resource added
253         - demo/tizen-winsets: add footer and back button
254         - remove autodividers unit test
255         - add divider for tabbar
256         - checkboxradio: exception handling for input
257         - segment control backward compatiblity
258         - Fix collapsible unit-test
259         - remove toggleswitch
260         - add patch for remove segment text
261 - Spec changes:
262         - replace controlbar to tabbar
263
264 * Fri Dec 14 2012 Minkyu Kang <mk7.kang@samsung.com> 0.2.3
265 - FIX:
266         - slider: add image
267         - button: data-icon support, styles fix
268         - progressbar: modify the background
269         - scrollview: auto scrolling bug fix
270         - pagelayout: IME concept is changed
271 - Spec changes:
272         - dialogue: add edit mode
273         - nocontents: removed
274         - pagecontrol: removed
275         - dayselector: removed
276         - expandablelist: removed
277
278 * Thu Dec 10 2012 Youmin Ha <youmin.ha@samsung.com> 0.2.2
279 - FIX:
280         - chang searchbar/slider images
281         - delete redundant button images
282 - Spec changes:
283         - Change widget name: shortcutscroll -> fastscroll
284
285 * Thu Dec 07 2012 Youmin Ha <youmin.ha@samsung.com> 0.2.1
286 - FIX:
287         - jqm1.2: Change collapsible style to meet expandable list
288         - remove jquery-geo-1.0.a4
289         - unit-test: rename from imageslider to gallery
290         - nocontent: add warning message
291         - Handler: Fix issues in jqm1.2
292         - Multimediaview: modify APIs & comments
293         - Mapview: Fix issues in jqm1.2
294         - JQM: clean up patches
295         - Swipelist: refactoring swipelist
296         - Popup,Ctxpopup: Apply tizen style popup in JQM1.2
297         - rearrange button's data-icon resources
298 - Spec changes:
299         - Virtualgrid: remove option ('data-itemcount')
300         - gallery: rename the widget from imageslider to gallery
301         - add new style for searchbar
302         [tokentextarea] multi-button entry renamed as token text area. API & comments modified.
303
304 * Thu Dec 06 2012 Minkyu Kang <mk7.kang@samsung.com> 0.2.0
305 - FIX:
306         - fix jslint error
307         - remove unused files
308         - change naviframe style
309 - Spec changes:
310         - applied jQuery Mobile 1.2.0
311         - remove optionheader
312
313 * Fri Nov 30 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.64
314 - FIX:
315         - fix unit tests
316         - remove unused theme files
317         - timepicker: text position fix
318         - scrollview: set dragstop when mouse is out of window
319         - listview: fix margin
320 - Spec changes:
321         - support data-framework-viewport-width
322
323 * Fri Nov 23 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.63
324 - FIX:
325         - dayselector: fix size
326         - remove unised styles
327         - divider: set non-press effect to default option
328         - popupwindow: fix window closing failure
329         - handler: GUI implementation
330         - TC: fix unit TCs
331         - scrollview: fix padding size
332 - Spec changes:
333         - Remove color widgets
334         - add $.tizen.pkgVersion for SDK
335 - Etc.
336         - JSDuck documents
337
338 * Fri Nov 16 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.62
339 - FIX:
340         - Many winsets: Fix layout
341         - Footer: fix position to bottom
342 - Spec changes:
343         - Remove color widgets
344
345 * Fri Nov 09 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.61
346 - FIX:
347         - Many widgets: New UX 0.6 theme implementation
348         - widgetex: init speed up
349         - scrollview: fix scrollbar and scale animation
350         - scrollview: fix scroll position when updatelayout is triggered
351         - header/footer: make textselection disable, except input type="text"
352
353 * Wed Nov 07 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.60
354 - FIX:
355         - Remove tizen-black theme package description
356
357 * Tue Nov 06 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.59
358 - FIX:
359         - Fix theme name to meet the change of system theme name: white->tizen
360         - Popupwindow: fix left position
361         - Remove black theme
362         - footer: remove label, legend drawing
363 - Spec changes:
364         - UX guide v0.4 : button, layout
365
366 * Wed Oct 24 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.57
367 - FIX:
368         - expandablelist: icon color fix
369         - scrollview: Fix xy scroll
370         - footer: Remove dummy div
371         - Make string concatnation effective in inline-protos.sh
372 - Spec changes:
373         - refresh header/footer when drag&drop event is fired in GUI builder
374         - searchbar: delete cancel button
375         - don't trigger updatelayout event when keyup event comes
376
377 * Mon Oct 15 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.56
378 - FIX:
379         - Toggleswitch: Change event name from 'changed' to 'change'
380         - Notification: Revert interval feature
381
382 * Tue Oct 09 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.55
383 - FIX:
384         - Fix SMACK manifest bug (S1-9098)
385
386 * Fri Oct 05 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.54
387 - FIX:
388         - handler: don't append a handler if handler is not enabled
389         - scrollview: use static value
390         - datetimepicker: fix date-format HH display error
391 - ETC:
392         - provide jquery.min.js
393         - barlayout: codes clean
394         - remove unused file
395
396 * Wed Sep 26 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.53
397 - FIX:
398         - listview: change focused color
399         - multibuttonentry: code refactoring
400         - datetimepicker: modify date format when triggered date-changed event
401         - slider: fix the top of slider bar
402         - add event blocker when load a first page
403
404 * Fri Sep 21 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.52
405 - ETC.
406         - Move SMACK manifest files to the top SRCDIR
407
408 * Fri Sep 21 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.51
409 - FIX:
410         - Popup: Do not focus container
411         - Header: show backbutton when both tabbar and header are present together
412         - Multi button entry: text ellipsis, code refactoring
413
414 * Fri Sep 21 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.50
415 - ETC.
416         - Apply SMACK manifest
417
418 * Thu Sep 20 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.49
419 - FIX:
420         - JSLINT code clean-up
421         - scrollview: firefox support
422         - scrollview: fix finding slider handle
423         - list: tweak text ellipsis
424         - checkbox: fix selecting wrong label tag (N_SE-8370)
425         - imageslider: check parameter
426         - smallpopup: fix position
427         - searchbar: fix 'clear' button size
428 - Spec changes:
429         - scrollview: support outer scroll
430         - JQM: block click event only with the element that does preventdefault on vclick(N_SE-6090)
431         - remove S/W IME control
432
433 * Thu Sep 13 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.48
434 - FIX:
435         - Add missing icon: controlbar
436         - scrollview: tune scrolling animatio ninterval
437         - datetimepicker: digit/triangle position
438         - datetimepicker: fix day overflow issue
439 - Spec changes:
440         - scrollview: show scrollbar when page is showed
441         - scrollview: disable outer scroll
442         - extendablelist: change api with legacy support
443         - add ui-text-ellipsis class
444
445 * Mon Sep 10 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.47
446 - FIX:
447         - scrollveiw: fix height of view
448         - searchbar: support placeholder
449 - Spec changes:
450         - add ui-text-ellipsis class
451
452 * Fri Sep 07 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.46
453 - FIX:
454         - scrollview: scrolling bug fix
455         - controlbar: fix width of controlbar item
456 - Spec changes:
457         - searchbar: don't hide icon
458         - popup: update JQM poup widget
459
460 * Fri Sep 05 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.45
461 - FIX:
462         - controlbar: set correct controlbar width of last element
463         - slider: get popup enable value correctly
464         - use Date.now() instead of (new Data()).getTime()
465         - popupwindow: fix the background color of popup scroller
466         - listview: add padding-left to expandable list
467         - add ellipsis for title area support
468
469 * Fri Aug 31 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.44
470 - FIX:
471         - swipelist: show list items correctly
472         - datetimepicker: set last day, if day is overflowed
473 - Spec changes:
474         - controlbar: update icons
475
476 * Tue Aug 29 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.43
477 - FIX:
478         - notification: fix typo
479 - Spec changes:
480         - controlbar: update icons
481
482 * Tue Aug 28 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.42
483 - FIX:
484         - multimediaview: video progress bar display normally for too samll
485         - segmentcontrol: remove media query
486         - scrollview: add outer scroll condition
487         - datetimepicker: modify triangle size
488         - popupwindow: set the screen height explicitly
489         - notification: add multiline text
490 - Spec changes:
491         - mutibuttonentry: support new GUI
492         - virtualgrid: support new GUI
493
494 * Mon Aug 27 2012 Jinhyuk Jun <jinhyuk.jun@samsung.com> 0.1.41
495 - FIX:
496         - radio/check button : button size bug fix
497
498 * Fri Aug 24 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.40
499 - FIX:
500         - build error fixed
501
502 * Fri Aug 24 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.39
503 - FIX:
504         - listview: style fix, remove filter placeholder
505         - controlbar: divide styles
506         - scrollview: don't skip dragging when click button or inputbox
507         - slider: trim the text on text slider
508 - Spec changes:
509         - remove gray and blue theme
510         - add white and black theme
511         - support new GUI guide
512
513 * Mon Aug 20 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.38
514 - FIX:
515         - fix coment of version tag
516
517 * Fri Aug 17 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.37
518 - FIX :
519         - button: fix alignment
520         - listview: adjust the main text width
521         - virtualgrid: refactoring
522 - Spec changes:
523         - transition: support JQM 1.1.0 transitions
524         - scrollview: support the outer scroll
525         - notification: remove interval feature
526
527 * Tue Aug 14 2012 Youmin Ha <youmin.ha@samasung.com> 0.1.36
528 - FIX :
529         - checkboxRadio: Add left/right padding
530         - button: custom button & icon position
531         - virtuallist: remove 'recreate' test
532 - Spec changes:
533         - header/footer: enable/disable support
534
535 * Fri Aug 10 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.35
536 - FIX :
537         - expandablelist: modify show animation
538         - virtualgrid: Redesign programming interface
539         - popupwindow: code clean and fixed issues
540         - pagelayout: fix content height
541         - license file update
542         - virtuallist: Change programming interface
543         - datetimepicker: getting days correctly
544         - searchbar: set to hidden when cancel button is hide
545         - White theme title font tuning
546 - Spec changes:
547         - default theme tizen-gray to tizen-white
548         - set default page transition to none
549
550 * Mon Aug 02 2012 Jinhyuk Jun <jinhyuk.jun@samsung.com> 0.1.34
551 - FIX :
552         - Back Button : enlarge backbutton click size for white theme
553 - Feature :
554         - Expandable List : Add refresh api
555 * Mon Aug 02 2012 Jinhyuk Jun <jinhyuk.jun@samsung.com> 0.1.33
556 - FIX :
557         - click event touch threshold tuning
558
559 * Mon Aug 02 2012 Jinhyuk Jun <jinhyuk.jun@samsung.com> 0.1.32
560 - FIX : 
561         - Add back button highlight effect for white theme
562
563 * Mon Aug 01 2012 Jinhyuk Jun <jinhyuk.jun@samsnug.com> 0.1.31
564 - FIX : 
565         - IME checkroutine update, improve relayout on resize event
566         - Add highlight effect for radio button list 
567         - Scrollview : fix condition of updatelayout event
568 - Feature : progressing : add show/hide api
569
570 * Mon Jul 27 2012 Koeun Choi <koeun.choi@samsung.com> 0.1.30
571 - FIX : virtuallist, virtualgrid: Clean up temporary jquery.template object to clear cache
572         add default theme option on buttonMarkup for tizen theme
573         [searchbar] first fix : focus/blur fixed
574         back button does not work when long press
575         scrollview: don't auto scrolling if resizing area is too large
576 - Feature : notification : add api to set the icon at tickernoti
577         demo : update the list sample demo
578         Support tizen default theme
579
580 * Mon Jul 23 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.29
581 - Improvements & Bugfixes
582    - HOTFIX: Revert template function with jquery.template
583
584 * Thu Jul 19 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.28
585 - Improvements & Bugfixes
586    - Fix #WEB-1028: memory leak on virtuallist/virtualgrid
587 - Spec changes
588    - $.tizen.loadTheme() function accepts theme name as arguement
589    - Scrollview supports 'updatelayout' callback
590
591 * Tue Jul 17 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.27
592 - Improvements & Bugfixes
593    - Revert 'preventing long-press popup' patch, to fix backbutton to work in SocialMagazine
594
595 * Tue Jul 17 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.26
596 - Improvements & Bugfixes
597    - Add tizen-white theme package, to make rpm build to be finished
598
599 * Tue Jul 17 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.25
600 - Improvements & Bugfixes
601    - Set 'slide' as default page transition effect, by JQM patch
602
603 * Fri Jul 13 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.24
604 - Improvements & Bugfixes
605    - Fix IME show/hide algorithm
606    - Fix error on virtualgrid: link _set_scrollbar_size() function to the one in virtuallist
607
608 * Wed Jul 11 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.23
609 - Improvements & Bugfixes
610    - Fix notification position
611    - Fix unit tests
612
613  Fri Jul 6 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.22
614 - Spec changes
615         - JQM 1.1 upgrade
616 - Improvements & Bugfixes
617         - Transform3D support on scrollview
618         - Page layout supports IME control
619         - Mapview supports pinch zoom on JQM 1.1
620         - Fix wrong character on button in minified version
621         - Virtualgrid supports scrollbar
622         - Lots of bugfixes
623
624 * Fri Jun 22 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.20
625 - Spec changes
626         - Support 'latest' version (by symlink) for tizen-web-ui-fw.js path.
627         - imageslider : supports 'resize' event.
628         - listview : listview has 1px padding-bottom.
629         - loader : Change global namespace, from S to $.tizen.
630         - loader : Move loadCustomGlobalizeCulture() into $.tizen.util namespace.
631 - Improvements & Bugfixes
632         - Scrollview : supports 'translate3d', instead of 'translate'.
633         - notification : reset timer when 'show' or 'refresh' event.
634         - JQM patch : Fix vclick event triggered twice.
635 - Etc.
636         - Add & fix unit tests.
637
638 * Thu Jun 14 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.19
639 - Spec changes
640         - mapview : new widget.
641         - notification : add .refresh() API.
642         - pagecontrol : add .value([val]) API, and change an attribute name 'data-initVal' to 'data-value'.
643 - Improvements & Bugfixes
644         - Support minified CSS.
645         - loader : Fix & refactor 'loading globalize culture file' routine.
646         - JQM Patch : Calculate min-height of window in javascript code, and remove predefined min-height value from CSS.
647         - Many more bugfixes.
648 - Etc.
649         - Add many unit tests.
650         - Fix test coverage instrumentation tool to work with current source code.