Export 0.1.64
[platform/framework/web/web-ui-fw.git] / packaging / web-ui-fw.spec
1 Name:       web-ui-fw
2 Version:    0.1.64
3 Release:    0
4 Summary:    Tizen Web UI Framework Library
5 Group:      Development/Other
6 License:    MIT
7 BuildArch:  noarch
8 BuildRequires:  make
9 BuildRequires:  nodejs
10 %ifarch %{arm}
11 BuildRequires:  nodejs-x86-arm
12 %endif
13
14 Source0:    %{name}-%{version}.tar.gz
15
16 %description
17 Tizen Web UI Framework library and theme packages
18
19 %prep
20 %setup -q
21
22 %build
23 make all
24
25 %install
26 make DESTDIR=%{buildroot} install
27
28 %post
29
30 %files
31 %manifest web-ui-fw.manifest
32 /usr/share/tizen-web-ui-fw/*/js
33 /usr/share/tizen-web-ui-fw/latest
34
35 ###############################
36 %package -n web-ui-fw-theme-tizen-gray
37 BuildArch:  noarch
38 Summary:    Tizen Web UI Framework Theme : tizen-gray
39 %Description -n web-ui-fw-theme-tizen-gray
40     Tizen Web UI Framework Theme : tizen-gray
41
42 ###############################
43 %package -n web-ui-fw-theme-tizen-white
44 BuildArch:  noarch
45 Summary:    Tizen Web UI Framework Theme : tizen-white
46 %Description -n web-ui-fw-theme-tizen-white
47     Tizen Web UI Framework Theme : tizen-white
48 %files -n web-ui-fw-theme-tizen-white
49 %manifest web-ui-fw-theme-tizen-white.manifest
50 /usr/share/tizen-web-ui-fw/*/themes/tizen-white
51 /usr/share/tizen-web-ui-fw/*/themes/tizen-tizen
52
53 ###############################
54 %package -n web-ui-fw-theme-default
55 BuildArch:  noarch
56 Summary:    Tizen Web UI Framework Theme : default
57 %Description -n web-ui-fw-theme-default
58     Tizen Web UI Framework Theme : default
59 %files -n web-ui-fw-theme-default
60 %manifest web-ui-fw-theme-default.manifest
61 /usr/share/tizen-web-ui-fw/*/themes/default
62
63 ###############################
64 %package -n web-ui-fw-devel
65 BuildArch:  noarch
66 Summary:    Tizen Web UI Framework Developer's files
67 %Description -n web-ui-fw-devel
68     Tizen Web UI Framework Developer's files
69 %files -n web-ui-fw-devel
70 /usr/share/tizen-web-ui-fw/bin
71 /usr/share/tizen-web-ui-fw/template
72
73 ###############################
74 %package -n web-ui-fw-demo-tizen-winsets
75 BuildArch:  noarch
76 Summary:    Tizen Web UI Framework Demo Application: tizen winset demo
77 %Description -n web-ui-fw-demo-tizen-winsets
78     Tizen Web UI Framework Demo Application: tizen winset demo
79 %files  -n web-ui-fw-demo-tizen-winsets
80 /usr/share/tizen-web-ui-fw/demos/tizen-winsets
81
82
83 ###############################
84 %changelog
85 * Fri Nov 30 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.64
86 - FIX:
87         - fix unit tests
88         - remove unused theme files
89         - timepicker: text position fix
90         - scrollview: set dragstop when mouse is out of window
91         - listview: fix margin
92 - Spec changes:
93         - support data-framework-viewport-width
94
95 * Fri Nov 23 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.63
96 - FIX:
97         - dayselector: fix size
98         - remove unised styles
99         - divider: set non-press effect to default option
100         - popupwindow: fix window closing failure
101         - handler: GUI implementation
102         - TC: fix unit TCs
103         - scrollview: fix padding size
104 - Spec changes:
105         - Remove color widgets
106         - add $.tizen.pkgVersion for SDK
107 - Etc.
108         - JSDuck documents
109
110 * Fri Nov 16 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.62
111 - FIX:
112         - Many winsets: Fix layout
113         - Footer: fix position to bottom
114 - Spec changes:
115         - Remove color widgets
116
117 * Fri Nov 09 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.61
118 - FIX:
119         - Many widgets: New UX 0.6 theme implementation
120         - widgetex: init speed up
121         - scrollview: fix scrollbar and scale animation
122         - scrollview: fix scroll position when updatelayout is triggered
123         - header/footer: make textselection disable, except input type="text"
124
125 * Wed Nov 07 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.60
126 - FIX:
127         - Remove tizen-black theme package description
128
129 * Tue Nov 06 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.59
130 - FIX:
131         - Fix theme name to meet the change of system theme name: white->tizen
132         - Popupwindow: fix left position
133         - Remove black theme
134         - footer: remove label, legend drawing
135 - Spec changes:
136         - UX guide v0.4 : button, layout
137
138 * Wed Oct 24 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.57
139 - FIX:
140         - expandablelist: icon color fix
141         - scrollview: Fix xy scroll
142         - footer: Remove dummy div
143         - Make string concatnation effective in inline-protos.sh
144 - Spec changes:
145         - refresh header/footer when drag&drop event is fired in GUI builder
146         - searchbar: delete cancel button
147         - don't trigger updatelayout event when keyup event comes
148
149 * Mon Oct 15 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.56
150 - FIX:
151         - Toggleswitch: Change event name from 'changed' to 'change'
152         - Notification: Revert interval feature
153
154 * Tue Oct 09 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.55
155 - FIX:
156         - Fix SMACK manifest bug (S1-9098)
157
158 * Fri Oct 05 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.54
159 - FIX:
160         - handler: don't append a handler if handler is not enabled
161         - scrollview: use static value
162         - datetimepicker: fix date-format HH display error
163 - ETC:
164         - provide jquery.min.js
165         - barlayout: codes clean
166         - remove unused file
167
168 * Wed Sep 26 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.53
169 - FIX:
170         - listview: change focused color
171         - multibuttonentry: code refactoring
172         - datetimepicker: modify date format when triggered date-changed event
173         - slider: fix the top of slider bar
174         - add event blocker when load a first page
175
176 * Fri Sep 21 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.52
177 - ETC.
178         - Move SMACK manifest files to the top SRCDIR
179
180 * Fri Sep 21 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.51
181 - FIX:
182         - Popup: Do not focus container
183         - Header: show backbutton when both tabbar and header are present together
184         - Multi button entry: text ellipsis, code refactoring
185
186 * Fri Sep 21 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.50
187 - ETC.
188         - Apply SMACK manifest
189
190 * Thu Sep 20 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.49
191 - FIX:
192         - JSLINT code clean-up
193         - scrollview: firefox support
194         - scrollview: fix finding slider handle
195         - list: tweak text ellipsis
196         - checkbox: fix selecting wrong label tag (N_SE-8370)
197         - imageslider: check parameter
198         - smallpopup: fix position
199         - searchbar: fix 'clear' button size
200 - Spec changes:
201         - scrollview: support outer scroll
202         - JQM: block click event only with the element that does preventdefault on vclick(N_SE-6090)
203         - remove S/W IME control
204
205 * Thu Sep 13 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.48
206 - FIX:
207         - Add missing icon: controlbar
208         - scrollview: tune scrolling animatio ninterval
209         - datetimepicker: digit/triangle position
210         - datetimepicker: fix day overflow issue
211 - Spec changes:
212         - scrollview: show scrollbar when page is showed
213         - scrollview: disable outer scroll
214         - extendablelist: change api with legacy support
215         - add ui-text-ellipsis class
216
217 * Mon Sep 10 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.47
218 - FIX:
219         - scrollveiw: fix height of view
220         - searchbar: support placeholder
221 - Spec changes:
222         - add ui-text-ellipsis class
223
224 * Fri Sep 07 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.46
225 - FIX:
226         - scrollview: scrolling bug fix
227         - controlbar: fix width of controlbar item
228 - Spec changes:
229         - searchbar: don't hide icon
230         - popup: update JQM poup widget
231
232 * Fri Sep 05 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.45
233 - FIX:
234         - controlbar: set correct controlbar width of last element
235         - slider: get popup enable value correctly
236         - use Date.now() instead of (new Data()).getTime()
237         - popupwindow: fix the background color of popup scroller
238         - listview: add padding-left to expandable list
239         - add ellipsis for title area support
240
241 * Fri Aug 31 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.44
242 - FIX:
243         - swipelist: show list items correctly
244         - datetimepicker: set last day, if day is overflowed
245 - Spec changes:
246         - controlbar: update icons
247
248 * Tue Aug 29 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.43
249 - FIX:
250         - notification: fix typo
251 - Spec changes:
252         - controlbar: update icons
253
254 * Tue Aug 28 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.42
255 - FIX:
256         - multimediaview: video progress bar display normally for too samll
257         - segmentcontrol: remove media query
258         - scrollview: add outer scroll condition
259         - datetimepicker: modify triangle size
260         - popupwindow: set the screen height explicitly
261         - notification: add multiline text
262 - Spec changes:
263         - mutibuttonentry: support new GUI
264         - virtualgrid: support new GUI
265
266 * Mon Aug 27 2012 Jinhyuk Jun <jinhyuk.jun@samsung.com> 0.1.41
267 - FIX:
268         - radio/check button : button size bug fix
269
270 * Fri Aug 24 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.40
271 - FIX:
272         - build error fixed
273
274 * Fri Aug 24 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.39
275 - FIX:
276         - listview: style fix, remove filter placeholder
277         - controlbar: divide styles
278         - scrollview: don't skip dragging when click button or inputbox
279         - slider: trim the text on text slider
280 - Spec changes:
281         - remove gray and blue theme
282         - add white and black theme
283         - support new GUI guide
284
285 * Mon Aug 20 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.38
286 - FIX:
287         - fix coment of version tag
288
289 * Fri Aug 17 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.37
290 - FIX :
291         - button: fix alignment
292         - listview: adjust the main text width
293         - virtualgrid: refactoring
294 - Spec changes:
295         - transition: support JQM 1.1.0 transitions
296         - scrollview: support the outer scroll
297         - notification: remove interval feature
298
299 * Tue Aug 14 2012 Youmin Ha <youmin.ha@samasung.com> 0.1.36
300 - FIX :
301         - checkboxRadio: Add left/right padding
302         - button: custom button & icon position
303         - virtuallist: remove 'recreate' test
304 - Spec changes:
305         - header/footer: enable/disable support
306
307 * Fri Aug 10 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.35
308 - FIX :
309         - expandablelist: modify show animation
310         - virtualgrid: Redesign programming interface
311         - popupwindow: code clean and fixed issues
312         - pagelayout: fix content height
313         - license file update
314         - virtuallist: Change programming interface
315         - datetimepicker: getting days correctly
316         - searchbar: set to hidden when cancel button is hide
317         - White theme title font tuning
318 - Spec changes:
319         - default theme tizen-gray to tizen-white
320         - set default page transition to none
321
322 * Mon Aug 02 2012 Jinhyuk Jun <jinhyuk.jun@samsung.com> 0.1.34
323 - FIX :
324         - Back Button : enlarge backbutton click size for white theme
325 - Feature :
326         - Expandable List : Add refresh api
327 * Mon Aug 02 2012 Jinhyuk Jun <jinhyuk.jun@samsung.com> 0.1.33
328 - FIX :
329         - click event touch threshold tuning
330
331 * Mon Aug 02 2012 Jinhyuk Jun <jinhyuk.jun@samsung.com> 0.1.32
332 - FIX : 
333         - Add back button highlight effect for white theme
334
335 * Mon Aug 01 2012 Jinhyuk Jun <jinhyuk.jun@samsnug.com> 0.1.31
336 - FIX : 
337         - IME checkroutine update, improve relayout on resize event
338         - Add highlight effect for radio button list 
339         - Scrollview : fix condition of updatelayout event
340 - Feature : progressing : add show/hide api
341
342 * Mon Jul 27 2012 Koeun Choi <koeun.choi@samsung.com> 0.1.30
343 - FIX : virtuallist, virtualgrid: Clean up temporary jquery.template object to clear cache
344         add default theme option on buttonMarkup for tizen theme
345         [searchbar] first fix : focus/blur fixed
346         back button does not work when long press
347         scrollview: don't auto scrolling if resizing area is too large
348 - Feature : notification : add api to set the icon at tickernoti
349         demo : update the list sample demo
350         Support tizen default theme
351
352 * Mon Jul 23 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.29
353 - Improvements & Bugfixes
354    - HOTFIX: Revert template function with jquery.template
355
356 * Thu Jul 19 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.28
357 - Improvements & Bugfixes
358    - Fix #WEB-1028: memory leak on virtuallist/virtualgrid
359 - Spec changes
360    - $.tizen.loadTheme() function accepts theme name as arguement
361    - Scrollview supports 'updatelayout' callback
362
363 * Tue Jul 17 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.27
364 - Improvements & Bugfixes
365    - Revert 'preventing long-press popup' patch, to fix backbutton to work in SocialMagazine
366
367 * Tue Jul 17 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.26
368 - Improvements & Bugfixes
369    - Add tizen-white theme package, to make rpm build to be finished
370
371 * Tue Jul 17 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.25
372 - Improvements & Bugfixes
373    - Set 'slide' as default page transition effect, by JQM patch
374
375 * Fri Jul 13 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.24
376 - Improvements & Bugfixes
377    - Fix IME show/hide algorithm
378    - Fix error on virtualgrid: link _set_scrollbar_size() function to the one in virtuallist
379
380 * Wed Jul 11 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.23
381 - Improvements & Bugfixes
382    - Fix notification position
383    - Fix unit tests
384
385  Fri Jul 6 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.22
386 - Spec changes
387         - JQM 1.1 upgrade
388 - Improvements & Bugfixes
389         - Transform3D support on scrollview
390         - Page layout supports IME control
391         - Mapview supports pinch zoom on JQM 1.1
392         - Fix wrong character on button in minified version
393         - Virtualgrid supports scrollbar
394         - Lots of bugfixes
395
396 * Fri Jun 22 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.20
397 - Spec changes
398         - Support 'latest' version (by symlink) for tizen-web-ui-fw.js path.
399         - imageslider : supports 'resize' event.
400         - listview : listview has 1px padding-bottom.
401         - loader : Change global namespace, from S to $.tizen.
402         - loader : Move loadCustomGlobalizeCulture() into $.tizen.util namespace.
403 - Improvements & Bugfixes
404         - Scrollview : supports 'translate3d', instead of 'translate'.
405         - notification : reset timer when 'show' or 'refresh' event.
406         - JQM patch : Fix vclick event triggered twice.
407 - Etc.
408         - Add & fix unit tests.
409
410 * Thu Jun 14 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.19
411 - Spec changes
412         - mapview : new widget.
413         - notification : add .refresh() API.
414         - pagecontrol : add .value([val]) API, and change an attribute name 'data-initVal' to 'data-value'.
415 - Improvements & Bugfixes
416         - Support minified CSS.
417         - loader : Fix & refactor 'loading globalize culture file' routine.
418         - JQM Patch : Calculate min-height of window in javascript code, and remove predefined min-height value from CSS.
419         - Many more bugfixes.
420 - Etc.
421         - Add many unit tests.
422         - Fix test coverage instrumentation tool to work with current source code.