0.2.23 release
[platform/framework/web/web-ui-fw.git] / packaging / web-ui-fw.spec
1 Name:       web-ui-fw
2 Version:    0.2.23
3 Release:    0
4 Summary:    Tizen Web UI Framework Library
5 Group:      Development/Other
6 License:    MIT
7 BuildArch:  noarch
8 BuildRequires:  make
9 BuildRequires:  nodejs
10 %ifarch %{arm}
11 BuildRequires:  nodejs-x86-arm
12 %endif
13
14 Source0:    %{name}-%{version}.tar.gz
15
16 %description
17 Tizen Web UI Framework library and theme packages
18
19 %prep
20 %setup -q
21
22 %build
23 make all
24
25 %install
26 make DESTDIR=%{buildroot} install
27
28 %post
29
30 %files
31 %manifest web-ui-fw.manifest
32 /usr/share/tizen-web-ui-fw/*/js/*.js
33 /usr/share/tizen-web-ui-fw/*/js/cultures
34 /usr/share/tizen-web-ui-fw/latest
35 /usr/share/tizen-web-ui-fw/VERSION
36
37 ###############################
38 %package -n web-ui-fw-theme-tizen-gray
39 BuildArch:  noarch
40 Summary:    Tizen Web UI Framework Theme : tizen-gray
41 %Description -n web-ui-fw-theme-tizen-gray
42     Tizen Web UI Framework Theme : tizen-gray
43     Deprecated package, but some binaries still refer this.
44
45 ###############################
46 %package -n web-ui-fw-theme-tizen-white
47 BuildArch:  noarch
48 Summary:    Tizen Web UI Framework Theme : tizen-white
49 %Description -n web-ui-fw-theme-tizen-white
50     Tizen Web UI Framework Theme : tizen-white
51 %files -n web-ui-fw-theme-tizen-white
52 %manifest web-ui-fw-theme-tizen-white.manifest
53 /usr/share/tizen-web-ui-fw/*/themes/tizen-white
54 /usr/share/tizen-web-ui-fw/*/themes/tizen-tizen
55
56 ###############################
57 %package -n web-ui-fw-theme-tizen-black
58 BuildArch:  noarch
59 Summary:    Tizen Web UI Framework Theme : tizen-black
60 %Description -n web-ui-fw-theme-tizen-black
61     Tizen Web UI Framework Theme : tizen-black
62 %files -n web-ui-fw-theme-tizen-black
63 %manifest web-ui-fw-theme-tizen-black.manifest
64 /usr/share/tizen-web-ui-fw/*/themes/tizen-black
65
66 ###############################
67 %package -n web-ui-fw-theme-default
68 BuildArch:  noarch
69 Summary:    Tizen Web UI Framework Theme : default
70 %Description -n web-ui-fw-theme-default
71     Tizen Web UI Framework Theme : default
72 %files -n web-ui-fw-theme-default
73 %manifest web-ui-fw-theme-default.manifest
74 /usr/share/tizen-web-ui-fw/*/themes/default
75
76 ###############################
77 %package -n web-ui-fw-devel
78 BuildArch:  noarch
79 Summary:    Tizen Web UI Framework Developer's files
80 %Description -n web-ui-fw-devel
81     Tizen Web UI Framework Developer's files
82 %files -n web-ui-fw-devel
83 /usr/share/tizen-web-ui-fw/bin
84 /usr/share/tizen-web-ui-fw/template
85 /usr/share/tizen-web-ui-fw/*/js/src
86 /usr/share/tizen-web-ui-fw/*/js/depData.json
87
88 ###############################
89 %package -n web-ui-fw-demo-tizen-winsets
90 BuildArch:  noarch
91 Summary:    Tizen Web UI Framework Demo Application: tizen winset demo
92 %Description -n web-ui-fw-demo-tizen-winsets
93     Tizen Web UI Framework Demo Application: tizen winset demo
94 %files  -n web-ui-fw-demo-tizen-winsets
95 /usr/share/tizen-web-ui-fw/demos/tizen-winsets
96
97
98 ###############################
99 %changelog
100 * Wed Apr 10 2013 Youmin Ha <youmin.ha@samsung.com> 0.2.23
101         - Naviframe : modify SIP down button's position
102         - Core: Performance fix for disableSelection and enableSelection
103         - Tests: Core tests for disableSelection
104         - patch: fix small mistakes on the patches
105         - virtuallist: Change demo button style
106         - Button: btn-icon only css has been changed
107         - loader: Fix screen-width option processing
108         - pagelayout: Remember back key when it is hidden
109         - Tizen Black Theme : Tizen black theme png file changed.
110         - UnitTC: tizen winset unit tc bugs have been fixed
111         - TizenWinset: Swipe list sample has been fixed
112         - Radio : remove default radio's width(N_SE-33579)
113         - Scrollview : divide x/y overflow attribute
114         - Gallery: orientation image showing issue has been fixed
115         - Gallery: remove method bug has been fixed
116         - virtualgrid : fix unit-test error and increase test items
117         - Gallery3d: Modify demo & source codes for visibility enhancement.
118         - Gallery3d: Reduce loading time of widget
119         - Gallery3d: Change files' format to unix
120         - Contextpopup: context popup close when window resize event fire
121         - Popup: reverse orientation bug has been fixed
122         - Tokentextarea: modify description
123         - Multimediaview: modify description
124         - JQM: Do not add ui-btn-icon-only class at the select button
125         - build: tizen-black theme package
126         - Tizenwinset: popup script has been removed
127         - Tizenwinset: substring split view text message
128         - Timepicker: data-changed event will be deprecated
129
130 * Fri Apr 5 2013 Youmin Ha <youmin.ha@samsung.com> 0.2.22
131         - tizen-winsets: Fix demo menu
132         - Tizenwinset: Reorder tizenwinset menu
133         - SearchBar: Header button size issue has been fixed
134         - Swipe: list item overflow: hidden has been added
135         - Tizenwinset: href has been added in grouped list
136         - Tizenwinset: Page transition page has been added
137         - Tizenwinset: Radio description has been fixed
138         - This patch fixes problem when base url is changed when site is prefetched.
139         - Entry : limit textarea's width (N_SE-28653)
140         - Naviframe : hide backbutton in case SIP up(remove backbutton makes problem in binding event)
141         - Gallery : next, prev images position bug has been fixed
142         - Multimediaview: Fix display error while handling orientationchange event.
143         - Pagelayout : modify innerHeight dpr calculation in non scrollview mode
144         - Datetimepicker: picker position has been fixed when browser resize event fired
145         - Tips: generate elements sample page javascript has been fixed
146         - Tokentextarea: Fix Tizen-winsets demo.
147
148 * Wed Apr 3 2013 Youmin Ha <youmin.ha@samsung.com> 0.2.21
149         - VirtualGrid: Fix errors on centerTo and resize methods
150         - loader: Fix default font size at device-width viewport
151         - scrollview : remove overflow-x property
152         - Naviframe : fix backbutton position/ change down button icon
153         - Naviframe : bug fix
154         - Tizenwinset : Tizen-winset demo page titles changed Tizen-winset demo page titles changed from lower case to upper case.
155
156 * Fri Mar 29 2013 Youmin Ha <youmin.ha@samsung.com> 0.2.20
157         - JQM Navigation : remove page min-height
158         - Pagelayout : add refresh to pagelayout
159         - Tokentextarea: Changes 'remove' tests to asyncTest
160         - Popup: input tag alignment has been fixed
161         - Tokentextarea: add/remove events are deprecated.
162         - Contextpopup: Support horizontal list
163         - Select: icon z-index has been deleted
164         - Tizenwinset: ui widget order has been changed
165         - Tool: make web app template disable context menu by default
166         - Tizen-winset: change tips for using listview
167         - Loader: calculate font size with mobile width
168         - Naviframe : fix header's back button position
169         - TizenWinset : move locale info to another file
170
171 * Fri Mar 29 2013 Youmin Ha <youmin.ha@samsung.com> 0.2.20
172         - JQM Navigation : remove page min-height
173         - Pagelayout : add refresh to pagelayout
174         - Tokentextarea: Changes 'remove' tests to asyncTest
175         - Popup: input tag alignment has been fixed
176         - Tokentextarea: add/remove events are deprecated.
177         - Contextpopup: Support horizontal list
178         - Select: icon z-index has been deleted
179         - Tizenwinset: ui widget order has been changed
180         - Tool: make web app template disable context menu by default
181         - Tizen-winset: change tips for using listview
182         - Loader: calculate font size with mobile width
183         - Naviframe : fix header's back button position
184         - TizenWinset : move locale info to another file
185
186 * Fri Mar 22 2013 Youmin Ha <youmin.ha@samsung.com> 0.2.19
187         - Tizen-winset: Support accessibility for tizen-winset
188         - Orientation : add orientataionchange to tizen-winset
189         - Tokentextarea: Adjusts VI effect for add/remove block
190         - splitview: Support accessibility for splitview
191         - Tizen-winset: Date/time picker guide text has been fixed
192         - Popup: context popup arrow position, setTimeout open method bug have been fixed
193         - fastscroll: Add new indexString API to Fastscroll widget.
194         - splitview: Add new widget
195         - gallery3d: Add new widget
196         - Scrollview : disable VI effect for gesture event
197         - Scrollview : disable SIP outerscroll
198         - Tizen-winset: resize VirtualGrid widget in demo
199         - Tizen-winsets: Refactor searchbar subpages
200         - Tizen-winsets: Remove depracated usage of virtuallist
201         - Tizen-winsets: Move js code from main.js to subpages
202         - Tizen-winsets: Refactor virtual grid demo subpages
203         - Tizen-winsets: Move css files from index to proper subpages
204         - Tizen-winsets: Refactor list dialogue edit subpage
205         - Tizen-winsets: Refactor pagelayout subpages
206         - Tizen-winsets: Refactor tips subpages
207         - Tizen-winsets: Move subpages popup files from index.html
208         - Tizen-winsets: Move subpages javascript files from index.html
209         - virtualgrid: fix improperly merged codes
210         - ColorTheme : remove unused color value(1st)
211         - Scrollview : change scrollbar draw
212         - Popup: Apply popup background dim
213         - Tizen-winsets: Move tokentextarea demo to external page.
214         - Tizen-winsets: Move tabbar persist demo to external page.
215         - Tizen-winsets: Remove notImplemented page
216         - Tizen-winsets: Move slider demo page to external subpage
217         - Tizen-winsets: Fix ids, remove duplicated names for sliders
218         - Tizen-winsets: Remove event for changing theme
219         - tool: Fix wgt sample app generator tool to make apps be installed
220         - demos : change live to on
221         - build: Trim compiled CSS files
222         - Gallery: CSS left -> translate or translate3D
223         - Tokentextarea: Disfunctional APIs fixed.
224
225 * Thu Mar 7 2013 Youmin Ha <youmin.ha@samsung.com> 0.2.18
226         - build: Fix Makefile to add globalize to the minified lib
227         - build-tools : upgrade less to v1.3.3
228         - demos : change normal js path to minified js
229         - Theme : remove reduantant less - dayselector, optionheader, nocontents
230         - multimediaview : fix full-screen mode.
231         - multimediaview : fix 'width', 'height' and 'fullScreen' methods
232         - Extendablelist: Added min-height "load more button" in listitem
233         - virtualgrid: adjusts VI effect for an overflow action
234         - ControlGroup : change ellipsis font color (press/normal)
235         - multimediaview: Add an error message to Multimediaview
236         - virtualgrid: adjusts triple flick gesture
237         - scrollview: add function for getting width of view
238         - scrollview: adds support x axis gesture scroll
239         - multimediaview : fix audio control
240         - tabbar : tabbar slide animation change
241         - TizenWinsetDemo : 2line-text demo bug fix
242         - collapsible: Fix demo to show radio button correctly in the collapsible list
243         - collapsible: Set listitem position to relative
244         - UnitTC: added list divider unit test
245         - Style: unnecessary color codes have been deleted and modified
246         - build: Module build implementation
247         - UnitTC: Additional unit testcases have been added
248         - listview : bug fix
249         - Naviframe : remove back button's hover effect
250         - TizenDemo : remove back button
251         - Transition: added more-button vi
252         - pinch: added new event called pinch
253         - Popup: css word-wrap:break-word has been added
254         - virtualgrid: memory leak fix
255         - progress: set to init state at pending bar
256         - progress: add margin of top/bottom
257         - unit-test: split progress test and progressbar test
258         - Tizen-winset: Context popup sample page guide text has been changed
259         - multimediaview: fix the height of widget when full-screen mode
260         - JQM: performance tuning
261
262 * Tue Feb 19 2013 Minkyu Kang <mk7.kang@samsung.com> 0.2.17
263         - DialogueList : delete border top value / add sample's text ellipsis
264         - Tokentextarea: Add scroll-to-top for Grouping On/Off regarding #N_SE-24877
265         - Multimediaview: Fix mute function
266         - Tizen-winset: list vi index guide textbox has been removed
267         - Tizen-winset: custom button texts have been changed
268         - slider: move popup div to out of content
269         - TizenWinset: disable context popup in multimediaview
270         - Swipe: wrong style name has been fixed
271         - demo: add the sample at dialogue list
272         - listview: Add ui-li-has-right-btn class with toggleswitch
273         - WinsetDemo : change wrong title name
274
275 * Mon Jan 28 2013 Youmin Ha <youmin.ha@samsung.com> 0.2.16
276         - demo: checkbox: reduce button's width
277         - tabbar : delete right/left tab animation color
278         - scrollview: fix the scroll position at keydown event
279         - groupControl : change footer groupControl from min-width to percentage
280         - scrollview: get height of softkeyboard correctly
281         - tizen-winset: Add name attr to all radio inputs
282         - virtualgrid: changes event binding target
283         - scrollview: skip the drag if target is textarea
284         - scrollview: skip the dragging of parent scrollview
285         - scrollview: apply the scaling ratio to the soft keyboard
286         - demos: apply disabled option in textarea
287         - demo: remove unused codes
288         - demo: datetimepicker: show selected date correctly
289         - listview: Adjust bubble listitem width and margin
290         - pagelayout : change external refresh call and ime status follow only current page
291         - toggleSwitch : bug fix
292         - unit-test: slider: fix the move test
293         - handler: fix jslint error
294         - ToggleSwitch : set image toggleswitch background attribute
295
296 * Mon Jan 28 2013 Youmin Ha <youmin.ha@samsung.com> 0.2.15
297         - slider: increase the text width(N_SE-23397)
298         - virtualgrid: DOM element leak fix
299         - header: Move button top higher in header with tabbar(N_SE-22253)
300         - datatimepicker: don't open the popup before popupafterclose event is fired(N_SE-23027)
301         - handler: bug fix (regarding enableHandler function )
302         - demo:fix syntax error
303
304 * Sat Jan 26 2013 Youmin Ha <youmin.ha@samsung.com> 0.2.14
305         - demo: fix demo using tizen device API
306         - multimediaview: reset the height of container
307         - input: modify css correctly
308         - multimediaview: fix the height of widget
309         - gallery: bind create event
310         - progress: bind create event
311         - slider: bind create event
312         - progressbar: bind create event
313         - progressbar: event trigger correctly
314         - popup: fix height of popup scroller
315         - build: add continue option to jslint
316         - ctxpopup demo : bug fix
317         - demo: fix searchbar demo to use different IDs
318         - demo: extract routine executing Tizen device API
319         - toggleswitch : set default margin, delete box padding
320
321 * Thu Jan 24 2013 Youmin Ha <youmin.ha@samsung.com> 0.2.13
322         - virtuallist: Prevent replacing contents on nonexist element
323         - JQM: Trim text in listitem to get index in autodivider
324         - JQM: Remove trailing whitespace in jqm patch
325         - scrollview: get the height including margin
326         - multimediaview: bug fix ( scrolling in full-screen mode )
327         - virtuallist: set listitem width to exclude listitem left/right margin
328         - demo: fix virtuallist sample layout
329         - progress: set the position explicitly
330         - progress: rename from progressing to progress
331         - build: remove unused files
332         - searchbar: fix jslint errors
333         - src: fix file permissions
334         - button : change jump left icon
335
336 * Wed Jan 23 2013 Minkyu Kang <mk7.kang@samsung.com> 0.2.12
337         - theme : button icon - scrolltop, scrolleft icon changed.
338         - build: cleanaup Makefile
339         - pagelayout: fix jslint error
340         - virtualgrid: Fix jslint errors
341         - tabbar : jslint bug error fix
342         - build: add regexp option to jslint
343         - virtuallist: fix jslint errors
344         - handler: Apply the exceptional principle for scrollbar on Handler.
345         - build: remove unused copyright
346         - loader: extract log class for tizen web, and fix jslint errors
347         - loader: Viewport width is set to document width
348         - popupwindow: fix jslint error
349         - build: fix Makefile for tizen-white theme
350         - build: remove unused libraries
351         - datetimepicker: fix jslint error
352         - slider: fix jslint error
353         - demo: remove deprecated demos
354         - pagelayout : change to call relayout with this page
355         - Tokentextarea: Block size error fixed.
356         - handler: bug fix (handler activation)
357
358 * Tue Jan 22 2013 Minkyu Kang <mk7.kang@samsung.com> 0.2.11
359         - demo: clear input text value with cancel button click
360         - demo: Adjust textarea height automatically
361         - naviframe : bug fix
362         - tabbar : bug fix
363         - Fastscroll: popup position has been changed
364         - Button: custom button icon path, margin have been changed
365         - toggleswitch : bug fix
366         - slider: increase the margin
367         - datetimepicker: close the popup after select the value
368         - unit-test : add page backbutton control test
369         - Demo: added guide text and change input type in list vi
370         - remove legacy codes : jquery-geo
371         - Datetimepicker: text-main max-width has been removed
372         - Radio: control group border has been removed
373         - Demo: remove 'tab' space
374         - UnitTC: swipe unit tc has been fixed
375         - UnitTC: jQuery path has been fixed
376         - Button: bug fix when button has not a text
377         - tizen-winset: timepicker: demo title is changed
378
379 * Fri Jan 18 2013 Minkyu Kang <mk7.kang@samsung.com> 0.2.10
380         - tizen-winsets: codes cleanup
381         - datetimepicker: date calibration when year is changed
382         - Demo: textarea size has been changed
383         - Demo: Naviframe morebutton demo has been changed
384         - remove unused unit test cases : gallery3d
385         - tizen-winset: remove links
386
387 * Thu Jan 17 2013 Minkyu Kang <mk7.kang@samsung.com> 0.2.9
388         - gallery: use timeout function instead of interval
389         - Tokentextarea: Display error fixed.
390         - scrollview: Fix not selector to respond with jQuery1.8.2
391         - tabbar: remove the width of last element
392         - Demo: apply css 'user-select:none'
393         - Button: guide text has been shorten
394         - build: Update jQuery to 1.8.2 (JQM1.2 compliant)
395         - virtuallist: Fix mistyping
396         - demo: Fix tizen function namespace in demo
397         - virtuallist: Rewrite listitem replacing algorithm
398         - fastscroll: modify from not selector to function
399         - extendablelist: Fix unit-test
400         - tabbar : prefix to tabbar scroll event
401         - Popupwindow: removed unvalid selector in jquery 1.8.2
402         - slider: adjust handle text as length of value
403         - Demo: 3 buttons in popup text has been changed
404         - src: codes cleanup
405         - demo : remove trailing empty strings
406         - demo : rename TizenWinset list items
407         - button : change from long text list to multiline list
408         - build: Remove JQM1.1.0 patches
409         - Popup: Apply tizen style popup and attribute support
410         - JQM: Fix buttonmarkup bug keeping ui-btn-down class
411         - UnitTest: folder and file renamed, QUnit path was modified
412         - tizen-winsets: button: fix textarea width
413         - Swipe: event name error has been fixed
414
415 * Tue Jan 15 2013 Minkyu Kang <mk7.kang@samsung.com> 0.2.8
416         - Button: button padding has been updated
417         - virtuallist: fix unique listitem ID bug
418         - checkbox, radio : change display attr
419         - Button: bug fix ( when data style circle button on text )
420         - handler: bug fix (when scrolling with multi selection)
421         - JQM: adjust patch number
422         - gallery: show the widget after pageshow
423         - TokenTextArea : resource add ( press image )
424         - gallery: adds function that set the index to value API
425         - configure: set TIZEN default configures
426         - footer: h tag display attribute value has been changed
427         - buttons : demo bug fix
428         - searchbar : demo page bug fix
429         - tizen demo : bug fix
430         - build: remove JQM1.1.0
431         - Tokentextarea: Fix issues
432         - scrollview: block the multi touch
433         - list : dialogue list demo change
434         - pagelayout : update dynamic control
435         - Demo: Context popup close method has been changed
436
437 * Fri Jan 11 2013 Minkyu Kang <mk7.kang@samsung.com> 0.2.7
438         - slider: set text container's width as text length
439         - Timepicker: li max-width has been changed
440         - remove experimental feature - mapview.
441         - scrollview: added conditions for finding slider
442         - UnitTC: Pass,error count save method has been changed
443         - confix.xml: default config added for tizen basic applications
444         - Swipe: p tag margin value is set '0'
445         - packaging: remove unused file
446         - tabbar : bug fix
447         - list demo : bug fix
448         - tizen-winsets: gallery: move to new section
449         - tizen-winsets: autodivider: removes link of list
450         - demos: entry of number-pattern name is changed from 'number' to 'number-pattern'
451         - pagelayout : padding calculate change, ime footer check changed
452         - tizen-winsets: searchbar: scroll to the top when type the character
453         - searchbar : bug fix
454         - demo: Fix virtuallist demo following new list style
455         - demo: Add word-wrap:break-word and remove parag. width
456         - Demo: button max-width has been set( 3 buttons in popup )
457         - back button control demo : bug fix
458         - toggleswitch : demo page modify
459         - slider: add margin-top and margin-bottom
460         - tabbar demo : bug fix
461         - Popup: IME hide when popup is closed
462         - token textarea : bug fix
463         - Timepicker: change get attribute method
464         - footer demo : bug fix
465         - unit-test: gallery: add new APIs
466         - gallery: adds support new APIs
467
468 * Fri Jan 04 2013 Minkyu Kang <mk7.kang@samsung.com> 0.2.6
469         - JQM: patches cleanup
470         - Button: data-corners attribute has been added
471         - unit-test: slider: fix class name of background
472         - progressbar, slider: fix less variable typo
473         - Tabbar : VI update
474         - notification: add top position at fix class
475         - demo: entry demo page change
476         - css: .ui-disabled added
477         - tizen-winset: token textarea: remove back button at demo page
478         - theme: Remove unused less file
479         - pagelayout : content min height bug fix
480         - scrollview: skip the dragging when target is slider's handle
481         - scrollview: update and refactoring the scroll effect
482         - UnitTest:JQM Unit TC helper has been added,TCs have been modified
483         - Swipe: demo page html error has been fixed
484         - listview: Add add/delete animation (VI)
485         - Popup: demo page has been modified
486         - tizen demo : bug fix
487         - searchbar : demo page change(change front button and add behaviour)
488         - pagelayout : add min height to content
489         - gallery: rename 'Image Slider' to 'Gallery' in tizen-winsets demo and tests
490         - back button control demo : change url link to data-rel="back"
491         - loader: Skip loading theme CSS with a custom css code
492         - Button: support no-text in button
493         - collapsible: Fix syntax error
494         - slider: use data-highlight attribute
495         - collapsible: Rotate animation to collapsible heading icon
496         - toggleswitch : text switch bug fix
497         - remove candidates-calendarpicker
498         - Patch: Fix misc mistakes in JQM patches
499         - searchbar : animation change
500         - gallery: get the width correctly
501         - demo: data-framework-viewport-scale attribute is changed to data-framework-viewport-width
502         - collapsible: Add collapse/expand animation (VI)
503         - datetimepicker: VI update
504         - JQM: set transition to pop as default
505         - tabbar : bug fix in case none li element case
506         - scrollview: fix the drag bug
507         - Button: Button icon scrolltop, left has beed added
508         - Swipe: VI update and swipe speed has been changed
509         - jqm: fix errors in patch files
510         - unit-test: swipe: fixed the destroy test
511
512 * Wed Dec 26 2012 Youmin Ha <youmin.ha@samsung.com> 0.2.5
513         - Revert "[checkboxradio] exception handling for input"
514                 This reverts commit 72478c32704fa96362db577e6cf9511777919ea8.
515                 Tizen style supports no-label radio and checkbox when making lists.
516                 So it ignores html input operation. Instead, it supports tizen style radio and checkbox theme.
517
518 * Thu Dec 20 2012 Youmin Ha <youmin.ha@samsung.com> 0.2.4
519 - Fix:
520         - modify segment background
521         - rearrange check, radio input
522         - CtxPopup: Scale up/ down popup vi(poptop, popbottom)
523         - button: style has beed added(box,circle,nobg,round)
524         - favorite resource added
525         - demo/tizen-winsets: add footer and back button
526         - remove autodividers unit test
527         - add divider for tabbar
528         - checkboxradio: exception handling for input
529         - segment control backward compatiblity
530         - Fix collapsible unit-test
531         - remove toggleswitch
532         - add patch for remove segment text
533 - Spec changes:
534         - replace controlbar to tabbar
535
536 * Fri Dec 14 2012 Minkyu Kang <mk7.kang@samsung.com> 0.2.3
537 - FIX:
538         - slider: add image
539         - button: data-icon support, styles fix
540         - progressbar: modify the background
541         - scrollview: auto scrolling bug fix
542         - pagelayout: IME concept is changed
543 - Spec changes:
544         - dialogue: add edit mode
545         - nocontents: removed
546         - pagecontrol: removed
547         - dayselector: removed
548         - expandablelist: removed
549
550 * Thu Dec 10 2012 Youmin Ha <youmin.ha@samsung.com> 0.2.2
551 - FIX:
552         - chang searchbar/slider images
553         - delete redundant button images
554 - Spec changes:
555         - Change widget name: shortcutscroll -> fastscroll
556
557 * Thu Dec 07 2012 Youmin Ha <youmin.ha@samsung.com> 0.2.1
558 - FIX:
559         - jqm1.2: Change collapsible style to meet expandable list
560         - remove jquery-geo-1.0.a4
561         - unit-test: rename from imageslider to gallery
562         - nocontent: add warning message
563         - Handler: Fix issues in jqm1.2
564         - Multimediaview: modify APIs & comments
565         - Mapview: Fix issues in jqm1.2
566         - JQM: clean up patches
567         - Swipelist: refactoring swipelist
568         - Popup,Ctxpopup: Apply tizen style popup in JQM1.2
569         - rearrange button's data-icon resources
570 - Spec changes:
571         - Virtualgrid: remove option ('data-itemcount')
572         - gallery: rename the widget from imageslider to gallery
573         - add new style for searchbar
574         [tokentextarea] multi-button entry renamed as token text area. API & comments modified.
575
576 * Thu Dec 06 2012 Minkyu Kang <mk7.kang@samsung.com> 0.2.0
577 - FIX:
578         - fix jslint error
579         - remove unused files
580         - change naviframe style
581 - Spec changes:
582         - applied jQuery Mobile 1.2.0
583         - remove optionheader
584
585 * Fri Nov 30 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.64
586 - FIX:
587         - fix unit tests
588         - remove unused theme files
589         - timepicker: text position fix
590         - scrollview: set dragstop when mouse is out of window
591         - listview: fix margin
592 - Spec changes:
593         - support data-framework-viewport-width
594
595 * Fri Nov 23 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.63
596 - FIX:
597         - dayselector: fix size
598         - remove unised styles
599         - divider: set non-press effect to default option
600         - popupwindow: fix window closing failure
601         - handler: GUI implementation
602         - TC: fix unit TCs
603         - scrollview: fix padding size
604 - Spec changes:
605         - Remove color widgets
606         - add $.tizen.pkgVersion for SDK
607 - Etc.
608         - JSDuck documents
609
610 * Fri Nov 16 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.62
611 - FIX:
612         - Many winsets: Fix layout
613         - Footer: fix position to bottom
614 - Spec changes:
615         - Remove color widgets
616
617 * Fri Nov 09 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.61
618 - FIX:
619         - Many widgets: New UX 0.6 theme implementation
620         - widgetex: init speed up
621         - scrollview: fix scrollbar and scale animation
622         - scrollview: fix scroll position when updatelayout is triggered
623         - header/footer: make textselection disable, except input type="text"
624
625 * Wed Nov 07 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.60
626 - FIX:
627         - Remove tizen-black theme package description
628
629 * Tue Nov 06 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.59
630 - FIX:
631         - Fix theme name to meet the change of system theme name: white->tizen
632         - Popupwindow: fix left position
633         - Remove black theme
634         - footer: remove label, legend drawing
635 - Spec changes:
636         - UX guide v0.4 : button, layout
637
638 * Fri Oct 26 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.58
639 - FIX:
640         - scrollview: Fix outer scroll amount
641         - tabbar: fix tapping twice
642         - popupwindow: fix left position
643
644 * Wed Oct 24 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.57
645 - FIX:
646         - expandablelist: icon color fix
647         - scrollview: Fix xy scroll
648         - footer: Remove dummy div
649         - Make string concatnation effective in inline-protos.sh
650 - Spec changes:
651         - refresh header/footer when drag&drop event is fired in GUI builder
652         - searchbar: delete cancel button
653         - don't trigger updatelayout event when keyup event comes
654
655 * Mon Oct 15 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.56
656 - FIX:
657         - Toggleswitch: Change event name from 'changed' to 'change'
658         - Notification: Revert interval feature
659
660 * Tue Oct 09 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.55
661 - FIX:
662         - Fix SMACK manifest bug (S1-9098)
663
664 * Fri Oct 05 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.54
665 - FIX:
666         - handler: don't append a handler if handler is not enabled
667         - scrollview: use static value
668         - datetimepicker: fix date-format HH display error
669 - ETC:
670         - provide jquery.min.js
671         - barlayout: codes clean
672         - remove unused file
673
674 * Wed Sep 26 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.53
675 - FIX:
676         - listview: change focused color
677         - multibuttonentry: code refactoring
678         - datetimepicker: modify date format when triggered date-changed event
679         - slider: fix the top of slider bar
680         - add event blocker when load a first page
681
682 * Fri Sep 21 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.52
683 - ETC.
684         - Move SMACK manifest files to the top SRCDIR
685
686 * Fri Sep 21 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.51
687 - FIX:
688         - Popup: Do not focus container
689         - Header: show backbutton when both tabbar and header are present together
690         - Multi button entry: text ellipsis, code refactoring
691
692 * Fri Sep 21 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.50
693 - ETC.
694         - Apply SMACK manifest
695
696 * Thu Sep 20 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.49
697 - FIX:
698         - JSLINT code clean-up
699         - scrollview: firefox support
700         - scrollview: fix finding slider handle
701         - list: tweak text ellipsis
702         - checkbox: fix selecting wrong label tag (N_SE-8370)
703         - imageslider: check parameter
704         - smallpopup: fix position
705         - searchbar: fix 'clear' button size
706 - Spec changes:
707         - scrollview: support outer scroll
708         - JQM: block click event only with the element that does preventdefault on vclick(N_SE-6090)
709         - remove S/W IME control
710
711 * Thu Sep 13 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.48
712 - FIX:
713         - Add missing icon: controlbar
714         - scrollview: tune scrolling animatio ninterval
715         - datetimepicker: digit/triangle position
716         - datetimepicker: fix day overflow issue
717 - Spec changes:
718         - scrollview: show scrollbar when page is showed
719         - scrollview: disable outer scroll
720         - extendablelist: change api with legacy support
721         - add ui-text-ellipsis class
722
723 * Mon Sep 10 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.47
724 - FIX:
725         - scrollveiw: fix height of view
726         - searchbar: support placeholder
727 - Spec changes:
728         - add ui-text-ellipsis class
729
730 * Fri Sep 07 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.46
731 - FIX:
732         - scrollview: scrolling bug fix
733         - controlbar: fix width of controlbar item
734 - Spec changes:
735         - searchbar: don't hide icon
736         - popup: update JQM poup widget
737
738 * Fri Sep 05 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.45
739 - FIX:
740         - controlbar: set correct controlbar width of last element
741         - slider: get popup enable value correctly
742         - use Date.now() instead of (new Data()).getTime()
743         - popupwindow: fix the background color of popup scroller
744         - listview: add padding-left to expandable list
745         - add ellipsis for title area support
746
747 * Fri Aug 31 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.44
748 - FIX:
749         - swipelist: show list items correctly
750         - datetimepicker: set last day, if day is overflowed
751 - Spec changes:
752         - controlbar: update icons
753
754 * Tue Aug 29 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.43
755 - FIX:
756         - notification: fix typo
757 - Spec changes:
758         - controlbar: update icons
759
760 * Tue Aug 28 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.42
761 - FIX:
762         - multimediaview: video progress bar display normally for too samll
763         - segmentcontrol: remove media query
764         - scrollview: add outer scroll condition
765         - datetimepicker: modify triangle size
766         - popupwindow: set the screen height explicitly
767         - notification: add multiline text
768 - Spec changes:
769         - mutibuttonentry: support new GUI
770         - virtualgrid: support new GUI
771
772 * Mon Aug 27 2012 Jinhyuk Jun <jinhyuk.jun@samsung.com> 0.1.41
773 - FIX:
774         - radio/check button : button size bug fix
775
776 * Fri Aug 24 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.40
777 - FIX:
778         - build error fixed
779
780 * Fri Aug 24 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.39
781 - FIX:
782         - listview: style fix, remove filter placeholder
783         - controlbar: divide styles
784         - scrollview: don't skip dragging when click button or inputbox
785         - slider: trim the text on text slider
786 - Spec changes:
787         - remove gray and blue theme
788         - add white and black theme
789         - support new GUI guide
790
791 * Mon Aug 20 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.38
792 - FIX:
793         - fix coment of version tag
794
795 * Fri Aug 17 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.37
796 - FIX :
797         - button: fix alignment
798         - listview: adjust the main text width
799         - virtualgrid: refactoring
800 - Spec changes:
801         - transition: support JQM 1.1.0 transitions
802         - scrollview: support the outer scroll
803         - notification: remove interval feature
804
805 * Tue Aug 14 2012 Youmin Ha <youmin.ha@samasung.com> 0.1.36
806 - FIX :
807         - checkboxRadio: Add left/right padding
808         - button: custom button & icon position
809         - virtuallist: remove 'recreate' test
810 - Spec changes:
811         - header/footer: enable/disable support
812
813 * Fri Aug 10 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.35
814 - FIX :
815         - expandablelist: modify show animation
816         - virtualgrid: Redesign programming interface
817         - popupwindow: code clean and fixed issues
818         - pagelayout: fix content height
819         - license file update
820         - virtuallist: Change programming interface
821         - datetimepicker: getting days correctly
822         - searchbar: set to hidden when cancel button is hide
823         - White theme title font tuning
824 - Spec changes:
825         - default theme tizen-gray to tizen-white
826         - set default page transition to none
827
828 * Mon Aug 02 2012 Jinhyuk Jun <jinhyuk.jun@samsung.com> 0.1.34
829 - FIX :
830         - Back Button : enlarge backbutton click size for white theme
831 - Feature :
832         - Expandable List : Add refresh api
833 * Mon Aug 02 2012 Jinhyuk Jun <jinhyuk.jun@samsung.com> 0.1.33
834 - FIX :
835         - click event touch threshold tuning
836
837 * Mon Aug 02 2012 Jinhyuk Jun <jinhyuk.jun@samsung.com> 0.1.32
838 - FIX : 
839         - Add back button highlight effect for white theme
840
841 * Mon Aug 01 2012 Jinhyuk Jun <jinhyuk.jun@samsnug.com> 0.1.31
842 - FIX : 
843         - IME checkroutine update, improve relayout on resize event
844         - Add highlight effect for radio button list 
845         - Scrollview : fix condition of updatelayout event
846 - Feature : progressing : add show/hide api
847
848 * Mon Jul 27 2012 Koeun Choi <koeun.choi@samsung.com> 0.1.30
849 - FIX : virtuallist, virtualgrid: Clean up temporary jquery.template object to clear cache
850         add default theme option on buttonMarkup for tizen theme
851         [searchbar] first fix : focus/blur fixed
852         back button does not work when long press
853         scrollview: don't auto scrolling if resizing area is too large
854 - Feature : notification : add api to set the icon at tickernoti
855         demo : update the list sample demo
856         Support tizen default theme
857
858 * Mon Jul 23 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.29
859 - Improvements & Bugfixes
860    - HOTFIX: Revert template function with jquery.template
861
862 * Thu Jul 19 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.28
863 - Improvements & Bugfixes
864    - Fix #WEB-1028: memory leak on virtuallist/virtualgrid
865 - Spec changes
866    - $.tizen.loadTheme() function accepts theme name as arguement
867    - Scrollview supports 'updatelayout' callback
868
869 * Tue Jul 17 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.27
870 - Improvements & Bugfixes
871    - Revert 'preventing long-press popup' patch, to fix backbutton to work in SocialMagazine
872
873 * Tue Jul 17 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.26
874 - Improvements & Bugfixes
875    - Add tizen-white theme package, to make rpm build to be finished
876
877 * Tue Jul 17 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.25
878 - Improvements & Bugfixes
879    - Set 'slide' as default page transition effect, by JQM patch
880
881 * Fri Jul 13 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.24
882 - Improvements & Bugfixes
883    - Fix IME show/hide algorithm
884    - Fix error on virtualgrid: link _set_scrollbar_size() function to the one in virtuallist
885
886 * Wed Jul 11 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.23
887 - Improvements & Bugfixes
888    - Fix notification position
889    - Fix unit tests
890
891  Fri Jul 6 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.22
892 - Spec changes
893         - JQM 1.1 upgrade
894 - Improvements & Bugfixes
895         - Transform3D support on scrollview
896         - Page layout supports IME control
897         - Mapview supports pinch zoom on JQM 1.1
898         - Fix wrong character on button in minified version
899         - Virtualgrid supports scrollbar
900         - Lots of bugfixes
901
902 * Fri Jun 22 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.20
903 - Spec changes
904         - Support 'latest' version (by symlink) for tizen-web-ui-fw.js path.
905         - imageslider : supports 'resize' event.
906         - listview : listview has 1px padding-bottom.
907         - loader : Change global namespace, from S to $.tizen.
908         - loader : Move loadCustomGlobalizeCulture() into $.tizen.util namespace.
909 - Improvements & Bugfixes
910         - Scrollview : supports 'translate3d', instead of 'translate'.
911         - notification : reset timer when 'show' or 'refresh' event.
912         - JQM patch : Fix vclick event triggered twice.
913 - Etc.
914         - Add & fix unit tests.
915
916 * Thu Jun 14 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.19
917 - Spec changes
918         - mapview : new widget.
919         - notification : add .refresh() API.
920         - pagecontrol : add .value([val]) API, and change an attribute name 'data-initVal' to 'data-value'.
921 - Improvements & Bugfixes
922         - Support minified CSS.
923         - loader : Fix & refactor 'loading globalize culture file' routine.
924         - JQM Patch : Calculate min-height of window in javascript code, and remove predefined min-height value from CSS.
925         - Many more bugfixes.
926 - Etc.
927         - Add many unit tests.
928         - Fix test coverage instrumentation tool to work with current source code.