0.2.10 release
[platform/framework/web/web-ui-fw.git] / packaging / web-ui-fw.spec
1 Name:       web-ui-fw
2 Version:    0.2.10
3 Release:    0
4 Summary:    Tizen Web UI Framework Library
5 Group:      Development/Other
6 License:    MIT
7 BuildArch:  noarch
8 BuildRequires:  make
9 BuildRequires:  nodejs
10 %ifarch %{arm}
11 BuildRequires:  nodejs-x86-arm
12 %endif
13
14 Source0:    %{name}-%{version}.tar.gz
15
16 %description
17 Tizen Web UI Framework library and theme packages
18
19 %prep
20 %setup -q
21
22 %build
23 make all
24
25 %install
26 make DESTDIR=%{buildroot} install
27
28 %post
29
30 %files
31 %manifest web-ui-fw.manifest
32 /usr/share/tizen-web-ui-fw/*/js
33 /usr/share/tizen-web-ui-fw/latest
34 /usr/share/tizen-web-ui-fw/VERSION
35
36 ###############################
37 %package -n web-ui-fw-theme-tizen-gray
38 BuildArch:  noarch
39 Summary:    Tizen Web UI Framework Theme : tizen-gray
40 %Description -n web-ui-fw-theme-tizen-gray
41     Tizen Web UI Framework Theme : tizen-gray
42
43 ###############################
44 %package -n web-ui-fw-theme-tizen-white
45 BuildArch:  noarch
46 Summary:    Tizen Web UI Framework Theme : tizen-white
47 %Description -n web-ui-fw-theme-tizen-white
48     Tizen Web UI Framework Theme : tizen-white
49 %files -n web-ui-fw-theme-tizen-white
50 %manifest web-ui-fw-theme-tizen-white.manifest
51 /usr/share/tizen-web-ui-fw/*/themes/tizen-white
52 /usr/share/tizen-web-ui-fw/*/themes/tizen-tizen
53
54 ###############################
55 %package -n web-ui-fw-theme-default
56 BuildArch:  noarch
57 Summary:    Tizen Web UI Framework Theme : default
58 %Description -n web-ui-fw-theme-default
59     Tizen Web UI Framework Theme : default
60 %files -n web-ui-fw-theme-default
61 %manifest web-ui-fw-theme-default.manifest
62 /usr/share/tizen-web-ui-fw/*/themes/default
63
64 ###############################
65 %package -n web-ui-fw-devel
66 BuildArch:  noarch
67 Summary:    Tizen Web UI Framework Developer's files
68 %Description -n web-ui-fw-devel
69     Tizen Web UI Framework Developer's files
70 %files -n web-ui-fw-devel
71 /usr/share/tizen-web-ui-fw/bin
72 /usr/share/tizen-web-ui-fw/template
73
74 ###############################
75 %package -n web-ui-fw-demo-tizen-winsets
76 BuildArch:  noarch
77 Summary:    Tizen Web UI Framework Demo Application: tizen winset demo
78 %Description -n web-ui-fw-demo-tizen-winsets
79     Tizen Web UI Framework Demo Application: tizen winset demo
80 %files  -n web-ui-fw-demo-tizen-winsets
81 /usr/share/tizen-web-ui-fw/demos/tizen-winsets
82
83
84 ###############################
85 %changelog
86
87 * Fri Jan 18 2013 Minkyu Kang <mk7.kang@samsung.com> 0.2.10
88         - tizen-winsets: codes cleanup
89         - datetimepicker: date calibration when year is changed
90         - Demo: textarea size has been changed
91         - Demo: Naviframe morebutton demo has been changed
92         - remove unused unit test cases : gallery3d
93         - tizen-winset: remove links
94
95 * Thu Jan 17 2013 Minkyu Kang <mk7.kang@samsung.com> 0.2.9
96         - gallery: use timeout function instead of interval
97         - Tokentextarea: Display error fixed.
98         - scrollview: Fix not selector to respond with jQuery1.8.2
99         - tabbar: remove the width of last element
100         - Demo: apply css 'user-select:none'
101         - Button: guide text has been shorten
102         - build: Update jQuery to 1.8.2 (JQM1.2 compliant)
103         - virtuallist: Fix mistyping
104         - demo: Fix tizen function namespace in demo
105         - virtuallist: Rewrite listitem replacing algorithm
106         - fastscroll: modify from not selector to function
107         - extendablelist: Fix unit-test
108         - tabbar : prefix to tabbar scroll event
109         - Popupwindow: removed unvalid selector in jquery 1.8.2
110         - slider: adjust handle text as length of value
111         - Demo: 3 buttons in popup text has been changed
112         - src: codes cleanup
113         - demo : remove trailing empty strings
114         - demo : rename TizenWinset list items
115         - button : change from long text list to multiline list
116         - build: Remove JQM1.1.0 patches
117         - Popup: Apply tizen style popup and attribute support
118         - JQM: Fix buttonmarkup bug keeping ui-btn-down class
119         - UnitTest: folder and file renamed, QUnit path was modified
120         - tizen-winsets: button: fix textarea width
121         - Swipe: event name error has been fixed
122
123 * Tue Jan 15 2013 Minkyu Kang <mk7.kang@samsung.com> 0.2.8
124         - Button: button padding has been updated
125         - virtuallist: fix unique listitem ID bug
126         - checkbox, radio : change display attr
127         - Button: bug fix ( when data style circle button on text )
128         - handler: bug fix (when scrolling with multi selection)
129         - JQM: adjust patch number
130         - gallery: show the widget after pageshow
131         - TokenTextArea : resource add ( press image )
132         - gallery: adds function that set the index to value API
133         - configure: set TIZEN default configures
134         - footer: h tag display attribute value has been changed
135         - buttons : demo bug fix
136         - searchbar : demo page bug fix
137         - tizen demo : bug fix
138         - build: remove JQM1.1.0
139         - Tokentextarea: Fix issues
140         - scrollview: block the multi touch
141         - list : dialogue list demo change
142         - pagelayout : update dynamic control
143         - Demo: Context popup close method has been changed
144
145 * Fri Jan 11 2013 Minkyu Kang <mk7.kang@samsung.com> 0.2.7
146         - slider: set text container's width as text length
147         - Timepicker: li max-width has been changed
148         - remove experimental feature - mapview.
149         - scrollview: added conditions for finding slider
150         - UnitTC: Pass,error count save method has been changed
151         - confix.xml: default config added for tizen basic applications
152         - Swipe: p tag margin value is set '0'
153         - packaging: remove unused file
154         - tabbar : bug fix
155         - list demo : bug fix
156         - tizen-winsets: gallery: move to new section
157         - tizen-winsets: autodivider: removes link of list
158         - demos: entry of number-pattern name is changed from 'number' to 'number-pattern'
159         - pagelayout : padding calculate change, ime footer check changed
160         - tizen-winsets: searchbar: scroll to the top when type the character
161         - searchbar : bug fix
162         - demo: Fix virtuallist demo following new list style
163         - demo: Add word-wrap:break-word and remove parag. width
164         - Demo: button max-width has been set( 3 buttons in popup )
165         - back button control demo : bug fix
166         - toggleswitch : demo page modify
167         - slider: add margin-top and margin-bottom
168         - tabbar demo : bug fix
169         - Popup: IME hide when popup is closed
170         - token textarea : bug fix
171         - Timepicker: change get attribute method
172         - footer demo : bug fix
173         - unit-test: gallery: add new APIs
174         - gallery: adds support new APIs
175
176 * Fri Jan 04 2013 Minkyu Kang <mk7.kang@samsung.com> 0.2.6
177         - JQM: patches cleanup
178         - Button: data-corners attribute has been added
179         - unit-test: slider: fix class name of background
180         - progressbar, slider: fix less variable typo
181         - Tabbar : VI update
182         - notification: add top position at fix class
183         - demo: entry demo page change
184         - css: .ui-disabled added
185         - tizen-winset: token textarea: remove back button at demo page
186         - theme: Remove unused less file
187         - pagelayout : content min height bug fix
188         - scrollview: skip the dragging when target is slider's handle
189         - scrollview: update and refactoring the scroll effect
190         - UnitTest:JQM Unit TC helper has been added,TCs have been modified
191         - Swipe: demo page html error has been fixed
192         - listview: Add add/delete animation (VI)
193         - Popup: demo page has been modified
194         - tizen demo : bug fix
195         - searchbar : demo page change(change front button and add behaviour)
196         - pagelayout : add min height to content
197         - gallery: rename 'Image Slider' to 'Gallery' in tizen-winsets demo and tests
198         - back button control demo : change url link to data-rel="back"
199         - loader: Skip loading theme CSS with a custom css code
200         - Button: support no-text in button
201         - collapsible: Fix syntax error
202         - slider: use data-highlight attribute
203         - collapsible: Rotate animation to collapsible heading icon
204         - toggleswitch : text switch bug fix
205         - remove candidates-calendarpicker
206         - Patch: Fix misc mistakes in JQM patches
207         - searchbar : animation change
208         - gallery: get the width correctly
209         - demo: data-framework-viewport-scale attribute is changed to data-framework-viewport-width
210         - collapsible: Add collapse/expand animation (VI)
211         - datetimepicker: VI update
212         - JQM: set transition to pop as default
213         - tabbar : bug fix in case none li element case
214         - scrollview: fix the drag bug
215         - Button: Button icon scrolltop, left has beed added
216         - Swipe: VI update and swipe speed has been changed
217         - jqm: fix errors in patch files
218         - unit-test: swipe: fixed the destroy test
219
220 * Wed Dec 26 2012 Youmin Ha <youmin.ha@samsung.com> 0.2.5
221         - Revert "[checkboxradio] exception handling for input"
222                 This reverts commit 72478c32704fa96362db577e6cf9511777919ea8.
223                 Tizen style supports no-label radio and checkbox when making lists.
224                 So it ignores html input operation. Instead, it supports tizen style radio and checkbox theme.
225
226 * Thu Dec 20 2012 Youmin Ha <youmin.ha@samsung.com> 0.2.4
227 - Fix:
228         - modify segment background
229         - rearrange check, radio input
230         - CtxPopup: Scale up/ down popup vi(poptop, popbottom)
231         - button: style has beed added(box,circle,nobg,round)
232         - favorite resource added
233         - demo/tizen-winsets: add footer and back button
234         - remove autodividers unit test
235         - add divider for tabbar
236         - checkboxradio: exception handling for input
237         - segment control backward compatiblity
238         - Fix collapsible unit-test
239         - remove toggleswitch
240         - add patch for remove segment text
241 - Spec changes:
242         - replace controlbar to tabbar
243
244 * Fri Dec 14 2012 Minkyu Kang <mk7.kang@samsung.com> 0.2.3
245 - FIX:
246         - slider: add image
247         - button: data-icon support, styles fix
248         - progressbar: modify the background
249         - scrollview: auto scrolling bug fix
250         - pagelayout: IME concept is changed
251 - Spec changes:
252         - dialogue: add edit mode
253         - nocontents: removed
254         - pagecontrol: removed
255         - dayselector: removed
256         - expandablelist: removed
257
258 * Thu Dec 10 2012 Youmin Ha <youmin.ha@samsung.com> 0.2.2
259 - FIX:
260         - chang searchbar/slider images
261         - delete redundant button images
262 - Spec changes:
263         - Change widget name: shortcutscroll -> fastscroll
264
265 * Thu Dec 07 2012 Youmin Ha <youmin.ha@samsung.com> 0.2.1
266 - FIX:
267         - jqm1.2: Change collapsible style to meet expandable list
268         - remove jquery-geo-1.0.a4
269         - unit-test: rename from imageslider to gallery
270         - nocontent: add warning message
271         - Handler: Fix issues in jqm1.2
272         - Multimediaview: modify APIs & comments
273         - Mapview: Fix issues in jqm1.2
274         - JQM: clean up patches
275         - Swipelist: refactoring swipelist
276         - Popup,Ctxpopup: Apply tizen style popup in JQM1.2
277         - rearrange button's data-icon resources
278 - Spec changes:
279         - Virtualgrid: remove option ('data-itemcount')
280         - gallery: rename the widget from imageslider to gallery
281         - add new style for searchbar
282         [tokentextarea] multi-button entry renamed as token text area. API & comments modified.
283
284 * Thu Dec 06 2012 Minkyu Kang <mk7.kang@samsung.com> 0.2.0
285 - FIX:
286         - fix jslint error
287         - remove unused files
288         - change naviframe style
289 - Spec changes:
290         - applied jQuery Mobile 1.2.0
291         - remove optionheader
292
293 * Fri Nov 30 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.64
294 - FIX:
295         - fix unit tests
296         - remove unused theme files
297         - timepicker: text position fix
298         - scrollview: set dragstop when mouse is out of window
299         - listview: fix margin
300 - Spec changes:
301         - support data-framework-viewport-width
302
303 * Fri Nov 23 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.63
304 - FIX:
305         - dayselector: fix size
306         - remove unised styles
307         - divider: set non-press effect to default option
308         - popupwindow: fix window closing failure
309         - handler: GUI implementation
310         - TC: fix unit TCs
311         - scrollview: fix padding size
312 - Spec changes:
313         - Remove color widgets
314         - add $.tizen.pkgVersion for SDK
315 - Etc.
316         - JSDuck documents
317
318 * Fri Nov 16 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.62
319 - FIX:
320         - Many winsets: Fix layout
321         - Footer: fix position to bottom
322 - Spec changes:
323         - Remove color widgets
324
325 * Fri Nov 09 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.61
326 - FIX:
327         - Many widgets: New UX 0.6 theme implementation
328         - widgetex: init speed up
329         - scrollview: fix scrollbar and scale animation
330         - scrollview: fix scroll position when updatelayout is triggered
331         - header/footer: make textselection disable, except input type="text"
332
333 * Wed Nov 07 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.60
334 - FIX:
335         - Remove tizen-black theme package description
336
337 * Tue Nov 06 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.59
338 - FIX:
339         - Fix theme name to meet the change of system theme name: white->tizen
340         - Popupwindow: fix left position
341         - Remove black theme
342         - footer: remove label, legend drawing
343 - Spec changes:
344         - UX guide v0.4 : button, layout
345
346 * Wed Oct 24 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.57
347 - FIX:
348         - expandablelist: icon color fix
349         - scrollview: Fix xy scroll
350         - footer: Remove dummy div
351         - Make string concatnation effective in inline-protos.sh
352 - Spec changes:
353         - refresh header/footer when drag&drop event is fired in GUI builder
354         - searchbar: delete cancel button
355         - don't trigger updatelayout event when keyup event comes
356
357 * Mon Oct 15 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.56
358 - FIX:
359         - Toggleswitch: Change event name from 'changed' to 'change'
360         - Notification: Revert interval feature
361
362 * Tue Oct 09 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.55
363 - FIX:
364         - Fix SMACK manifest bug (S1-9098)
365
366 * Fri Oct 05 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.54
367 - FIX:
368         - handler: don't append a handler if handler is not enabled
369         - scrollview: use static value
370         - datetimepicker: fix date-format HH display error
371 - ETC:
372         - provide jquery.min.js
373         - barlayout: codes clean
374         - remove unused file
375
376 * Wed Sep 26 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.53
377 - FIX:
378         - listview: change focused color
379         - multibuttonentry: code refactoring
380         - datetimepicker: modify date format when triggered date-changed event
381         - slider: fix the top of slider bar
382         - add event blocker when load a first page
383
384 * Fri Sep 21 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.52
385 - ETC.
386         - Move SMACK manifest files to the top SRCDIR
387
388 * Fri Sep 21 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.51
389 - FIX:
390         - Popup: Do not focus container
391         - Header: show backbutton when both tabbar and header are present together
392         - Multi button entry: text ellipsis, code refactoring
393
394 * Fri Sep 21 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.50
395 - ETC.
396         - Apply SMACK manifest
397
398 * Thu Sep 20 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.49
399 - FIX:
400         - JSLINT code clean-up
401         - scrollview: firefox support
402         - scrollview: fix finding slider handle
403         - list: tweak text ellipsis
404         - checkbox: fix selecting wrong label tag (N_SE-8370)
405         - imageslider: check parameter
406         - smallpopup: fix position
407         - searchbar: fix 'clear' button size
408 - Spec changes:
409         - scrollview: support outer scroll
410         - JQM: block click event only with the element that does preventdefault on vclick(N_SE-6090)
411         - remove S/W IME control
412
413 * Thu Sep 13 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.48
414 - FIX:
415         - Add missing icon: controlbar
416         - scrollview: tune scrolling animatio ninterval
417         - datetimepicker: digit/triangle position
418         - datetimepicker: fix day overflow issue
419 - Spec changes:
420         - scrollview: show scrollbar when page is showed
421         - scrollview: disable outer scroll
422         - extendablelist: change api with legacy support
423         - add ui-text-ellipsis class
424
425 * Mon Sep 10 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.47
426 - FIX:
427         - scrollveiw: fix height of view
428         - searchbar: support placeholder
429 - Spec changes:
430         - add ui-text-ellipsis class
431
432 * Fri Sep 07 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.46
433 - FIX:
434         - scrollview: scrolling bug fix
435         - controlbar: fix width of controlbar item
436 - Spec changes:
437         - searchbar: don't hide icon
438         - popup: update JQM poup widget
439
440 * Fri Sep 05 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.45
441 - FIX:
442         - controlbar: set correct controlbar width of last element
443         - slider: get popup enable value correctly
444         - use Date.now() instead of (new Data()).getTime()
445         - popupwindow: fix the background color of popup scroller
446         - listview: add padding-left to expandable list
447         - add ellipsis for title area support
448
449 * Fri Aug 31 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.44
450 - FIX:
451         - swipelist: show list items correctly
452         - datetimepicker: set last day, if day is overflowed
453 - Spec changes:
454         - controlbar: update icons
455
456 * Tue Aug 29 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.43
457 - FIX:
458         - notification: fix typo
459 - Spec changes:
460         - controlbar: update icons
461
462 * Tue Aug 28 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.42
463 - FIX:
464         - multimediaview: video progress bar display normally for too samll
465         - segmentcontrol: remove media query
466         - scrollview: add outer scroll condition
467         - datetimepicker: modify triangle size
468         - popupwindow: set the screen height explicitly
469         - notification: add multiline text
470 - Spec changes:
471         - mutibuttonentry: support new GUI
472         - virtualgrid: support new GUI
473
474 * Mon Aug 27 2012 Jinhyuk Jun <jinhyuk.jun@samsung.com> 0.1.41
475 - FIX:
476         - radio/check button : button size bug fix
477
478 * Fri Aug 24 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.40
479 - FIX:
480         - build error fixed
481
482 * Fri Aug 24 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.39
483 - FIX:
484         - listview: style fix, remove filter placeholder
485         - controlbar: divide styles
486         - scrollview: don't skip dragging when click button or inputbox
487         - slider: trim the text on text slider
488 - Spec changes:
489         - remove gray and blue theme
490         - add white and black theme
491         - support new GUI guide
492
493 * Mon Aug 20 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.38
494 - FIX:
495         - fix coment of version tag
496
497 * Fri Aug 17 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.37
498 - FIX :
499         - button: fix alignment
500         - listview: adjust the main text width
501         - virtualgrid: refactoring
502 - Spec changes:
503         - transition: support JQM 1.1.0 transitions
504         - scrollview: support the outer scroll
505         - notification: remove interval feature
506
507 * Tue Aug 14 2012 Youmin Ha <youmin.ha@samasung.com> 0.1.36
508 - FIX :
509         - checkboxRadio: Add left/right padding
510         - button: custom button & icon position
511         - virtuallist: remove 'recreate' test
512 - Spec changes:
513         - header/footer: enable/disable support
514
515 * Fri Aug 10 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.35
516 - FIX :
517         - expandablelist: modify show animation
518         - virtualgrid: Redesign programming interface
519         - popupwindow: code clean and fixed issues
520         - pagelayout: fix content height
521         - license file update
522         - virtuallist: Change programming interface
523         - datetimepicker: getting days correctly
524         - searchbar: set to hidden when cancel button is hide
525         - White theme title font tuning
526 - Spec changes:
527         - default theme tizen-gray to tizen-white
528         - set default page transition to none
529
530 * Mon Aug 02 2012 Jinhyuk Jun <jinhyuk.jun@samsung.com> 0.1.34
531 - FIX :
532         - Back Button : enlarge backbutton click size for white theme
533 - Feature :
534         - Expandable List : Add refresh api
535 * Mon Aug 02 2012 Jinhyuk Jun <jinhyuk.jun@samsung.com> 0.1.33
536 - FIX :
537         - click event touch threshold tuning
538
539 * Mon Aug 02 2012 Jinhyuk Jun <jinhyuk.jun@samsung.com> 0.1.32
540 - FIX : 
541         - Add back button highlight effect for white theme
542
543 * Mon Aug 01 2012 Jinhyuk Jun <jinhyuk.jun@samsnug.com> 0.1.31
544 - FIX : 
545         - IME checkroutine update, improve relayout on resize event
546         - Add highlight effect for radio button list 
547         - Scrollview : fix condition of updatelayout event
548 - Feature : progressing : add show/hide api
549
550 * Mon Jul 27 2012 Koeun Choi <koeun.choi@samsung.com> 0.1.30
551 - FIX : virtuallist, virtualgrid: Clean up temporary jquery.template object to clear cache
552         add default theme option on buttonMarkup for tizen theme
553         [searchbar] first fix : focus/blur fixed
554         back button does not work when long press
555         scrollview: don't auto scrolling if resizing area is too large
556 - Feature : notification : add api to set the icon at tickernoti
557         demo : update the list sample demo
558         Support tizen default theme
559
560 * Mon Jul 23 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.29
561 - Improvements & Bugfixes
562    - HOTFIX: Revert template function with jquery.template
563
564 * Thu Jul 19 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.28
565 - Improvements & Bugfixes
566    - Fix #WEB-1028: memory leak on virtuallist/virtualgrid
567 - Spec changes
568    - $.tizen.loadTheme() function accepts theme name as arguement
569    - Scrollview supports 'updatelayout' callback
570
571 * Tue Jul 17 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.27
572 - Improvements & Bugfixes
573    - Revert 'preventing long-press popup' patch, to fix backbutton to work in SocialMagazine
574
575 * Tue Jul 17 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.26
576 - Improvements & Bugfixes
577    - Add tizen-white theme package, to make rpm build to be finished
578
579 * Tue Jul 17 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.25
580 - Improvements & Bugfixes
581    - Set 'slide' as default page transition effect, by JQM patch
582
583 * Fri Jul 13 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.24
584 - Improvements & Bugfixes
585    - Fix IME show/hide algorithm
586    - Fix error on virtualgrid: link _set_scrollbar_size() function to the one in virtuallist
587
588 * Wed Jul 11 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.23
589 - Improvements & Bugfixes
590    - Fix notification position
591    - Fix unit tests
592
593  Fri Jul 6 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.22
594 - Spec changes
595         - JQM 1.1 upgrade
596 - Improvements & Bugfixes
597         - Transform3D support on scrollview
598         - Page layout supports IME control
599         - Mapview supports pinch zoom on JQM 1.1
600         - Fix wrong character on button in minified version
601         - Virtualgrid supports scrollbar
602         - Lots of bugfixes
603
604 * Fri Jun 22 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.20
605 - Spec changes
606         - Support 'latest' version (by symlink) for tizen-web-ui-fw.js path.
607         - imageslider : supports 'resize' event.
608         - listview : listview has 1px padding-bottom.
609         - loader : Change global namespace, from S to $.tizen.
610         - loader : Move loadCustomGlobalizeCulture() into $.tizen.util namespace.
611 - Improvements & Bugfixes
612         - Scrollview : supports 'translate3d', instead of 'translate'.
613         - notification : reset timer when 'show' or 'refresh' event.
614         - JQM patch : Fix vclick event triggered twice.
615 - Etc.
616         - Add & fix unit tests.
617
618 * Thu Jun 14 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.19
619 - Spec changes
620         - mapview : new widget.
621         - notification : add .refresh() API.
622         - pagecontrol : add .value([val]) API, and change an attribute name 'data-initVal' to 'data-value'.
623 - Improvements & Bugfixes
624         - Support minified CSS.
625         - loader : Fix & refactor 'loading globalize culture file' routine.
626         - JQM Patch : Calculate min-height of window in javascript code, and remove predefined min-height value from CSS.
627         - Many more bugfixes.
628 - Etc.
629         - Add many unit tests.
630         - Fix test coverage instrumentation tool to work with current source code.