Merge branch 'master' into t21
[platform/framework/web/web-ui-fw.git] / packaging / web-ui-fw.spec
1 Name:       web-ui-fw
2 Version:    0.2.19
3 Release:    1
4 Summary:    Tizen Web UI Framework Library
5 Group:      Development/Other
6 License:    MIT
7 BuildArch:  noarch
8 BuildRequires:  make
9 BuildRequires:  nodejs
10 %ifarch %{arm}
11 BuildRequires:  nodejs-x86-arm
12 %endif
13
14 Source0:    %{name}-%{version}.tar.gz
15
16 %description
17 Tizen Web UI Framework library and theme packages
18
19 %prep
20 %setup -q
21
22 %build
23 make all
24
25 %install
26 make DESTDIR=%{buildroot} install
27
28 %post
29
30 %files
31 %manifest web-ui-fw.manifest
32 /usr/share/tizen-web-ui-fw/*/js
33 /usr/share/tizen-web-ui-fw/latest
34 /usr/share/tizen-web-ui-fw/VERSION
35
36 ###############################
37 %package -n web-ui-fw-theme-tizen-gray
38 BuildArch:  noarch
39 Summary:    Tizen Web UI Framework Theme : tizen-gray
40 %Description -n web-ui-fw-theme-tizen-gray
41     Tizen Web UI Framework Theme : tizen-gray
42
43 ###############################
44 %package -n web-ui-fw-theme-tizen-white
45 BuildArch:  noarch
46 Summary:    Tizen Web UI Framework Theme : tizen-white
47 %Description -n web-ui-fw-theme-tizen-white
48     Tizen Web UI Framework Theme : tizen-white
49 %files -n web-ui-fw-theme-tizen-white
50 %manifest web-ui-fw-theme-tizen-white.manifest
51 /usr/share/tizen-web-ui-fw/*/themes/tizen-white
52 /usr/share/tizen-web-ui-fw/*/themes/tizen-tizen
53
54 ###############################
55 %package -n web-ui-fw-theme-default
56 BuildArch:  noarch
57 Summary:    Tizen Web UI Framework Theme : default
58 %Description -n web-ui-fw-theme-default
59     Tizen Web UI Framework Theme : default
60 %files -n web-ui-fw-theme-default
61 %manifest web-ui-fw-theme-default.manifest
62 /usr/share/tizen-web-ui-fw/*/themes/default
63
64 ###############################
65 %package -n web-ui-fw-devel
66 BuildArch:  noarch
67 Summary:    Tizen Web UI Framework Developer's files
68 %Description -n web-ui-fw-devel
69     Tizen Web UI Framework Developer's files
70 %files -n web-ui-fw-devel
71 /usr/share/tizen-web-ui-fw/bin
72 /usr/share/tizen-web-ui-fw/template
73
74 ###############################
75 %package -n web-ui-fw-demo-tizen-winsets
76 BuildArch:  noarch
77 Summary:    Tizen Web UI Framework Demo Application: tizen winset demo
78 %Description -n web-ui-fw-demo-tizen-winsets
79     Tizen Web UI Framework Demo Application: tizen winset demo
80 %files  -n web-ui-fw-demo-tizen-winsets
81 /usr/share/tizen-web-ui-fw/demos/tizen-winsets
82
83
84 ###############################
85 %changelog
86
87 * Fri Mar 22 2013 Youmin Ha <youmin.ha@samsung.com> 0.2.19
88         - Tizen-winset: Support accessibility for tizen-winset
89         - Orientation : add orientataionchange to tizen-winset
90         - Tokentextarea: Adjusts VI effect for add/remove block
91         - splitview: Support accessibility for splitview
92         - Tizen-winset: Date/time picker guide text has been fixed
93         - Popup: context popup arrow position, setTimeout open method bug have been fixed
94         - fastscroll: Add new indexString API to Fastscroll widget.
95         - splitview: Add new widget
96         - gallery3d: Add new widget
97         - Scrollview : disable VI effect for gesture event
98         - Scrollview : disable SIP outerscroll
99         - Tizen-winset: resize VirtualGrid widget in demo
100         - Tizen-winsets: Refactor searchbar subpages
101         - Tizen-winsets: Remove depracated usage of virtuallist
102         - Tizen-winsets: Move js code from main.js to subpages
103         - Tizen-winsets: Refactor virtual grid demo subpages
104         - Tizen-winsets: Move css files from index to proper subpages
105         - Tizen-winsets: Refactor list dialogue edit subpage
106         - Tizen-winsets: Refactor pagelayout subpages
107         - Tizen-winsets: Refactor tips subpages
108         - Tizen-winsets: Move subpages popup files from index.html
109         - Tizen-winsets: Move subpages javascript files from index.html
110         - virtualgrid: fix improperly merged codes
111         - ColorTheme : remove unused color value(1st)
112         - Scrollview : change scrollbar draw
113         - Popup: Apply popup background dim
114         - Tizen-winsets: Move tokentextarea demo to external page.
115         - Tizen-winsets: Move tabbar persist demo to external page.
116         - Tizen-winsets: Remove notImplemented page
117         - Tizen-winsets: Move slider demo page to external subpage
118         - Tizen-winsets: Fix ids, remove duplicated names for sliders
119         - Tizen-winsets: Remove event for changing theme
120         - tool: Fix wgt sample app generator tool to make apps be installed
121         - demos : change live to on
122         - build: Trim compiled CSS files
123         - Gallery: CSS left -> translate or translate3D
124         - Tokentextarea: Disfunctional APIs fixed.
125
126 * Thu Mar 7 2013 Youmin Ha <youmin.ha@samsung.com> 0.2.18
127         - build: Fix Makefile to add globalize to the minified lib
128         - build-tools : upgrade less to v1.3.3
129         - demos : change normal js path to minified js
130         - Theme : remove reduantant less - dayselector, optionheader, nocontents
131         - multimediaview : fix full-screen mode.
132         - multimediaview : fix 'width', 'height' and 'fullScreen' methods
133         - Extendablelist: Added min-height "load more button" in listitem
134         - virtualgrid: adjusts VI effect for an overflow action
135         - ControlGroup : change ellipsis font color (press/normal)
136         - multimediaview: Add an error message to Multimediaview
137         - virtualgrid: adjusts triple flick gesture
138         - scrollview: add function for getting width of view
139         - scrollview: adds support x axis gesture scroll
140         - multimediaview : fix audio control
141         - tabbar : tabbar slide animation change
142         - TizenWinsetDemo : 2line-text demo bug fix
143         - collapsible: Fix demo to show radio button correctly in the collapsible list
144         - collapsible: Set listitem position to relative
145         - UnitTC: added list divider unit test
146         - Style: unnecessary color codes have been deleted and modified
147         - build: Module build implementation
148         - UnitTC: Additional unit testcases have been added
149         - listview : bug fix
150         - Naviframe : remove back button's hover effect
151         - TizenDemo : remove back button
152         - Transition: added more-button vi
153         - pinch: added new event called pinch
154         - Popup: css word-wrap:break-word has been added
155         - virtualgrid: memory leak fix
156         - progress: set to init state at pending bar
157         - progress: add margin of top/bottom
158         - unit-test: split progress test and progressbar test
159         - Tizen-winset: Context popup sample page guide text has been changed
160         - multimediaview: fix the height of widget when full-screen mode
161         - JQM: performance tuning
162
163 * Tue Feb 19 2013 Minkyu Kang <mk7.kang@samsung.com> 0.2.17
164         - DialogueList : delete border top value / add sample's text ellipsis
165         - Tokentextarea: Add scroll-to-top for Grouping On/Off regarding #N_SE-24877
166         - Multimediaview: Fix mute function
167         - Tizen-winset: list vi index guide textbox has been removed
168         - Tizen-winset: custom button texts have been changed
169         - slider: move popup div to out of content
170         - TizenWinset: disable context popup in multimediaview
171         - Swipe: wrong style name has been fixed
172         - demo: add the sample at dialogue list
173         - listview: Add ui-li-has-right-btn class with toggleswitch
174         - WinsetDemo : change wrong title name
175
176 * Mon Jan 28 2013 Youmin Ha <youmin.ha@samsung.com> 0.2.16
177         - demo: checkbox: reduce button's width
178         - tabbar : delete right/left tab animation color
179         - scrollview: fix the scroll position at keydown event
180         - groupControl : change footer groupControl from min-width to percentage
181         - scrollview: get height of softkeyboard correctly
182         - tizen-winset: Add name attr to all radio inputs
183         - virtualgrid: changes event binding target
184         - scrollview: skip the drag if target is textarea
185         - scrollview: skip the dragging of parent scrollview
186         - scrollview: apply the scaling ratio to the soft keyboard
187         - demos: apply disabled option in textarea
188         - demo: remove unused codes
189         - demo: datetimepicker: show selected date correctly
190         - listview: Adjust bubble listitem width and margin
191         - pagelayout : change external refresh call and ime status follow only current page
192         - toggleSwitch : bug fix
193         - unit-test: slider: fix the move test
194         - handler: fix jslint error
195         - ToggleSwitch : set image toggleswitch background attribute
196
197 * Mon Jan 28 2013 Youmin Ha <youmin.ha@samsung.com> 0.2.15
198         - slider: increase the text width(N_SE-23397)
199         - virtualgrid: DOM element leak fix
200         - header: Move button top higher in header with tabbar(N_SE-22253)
201         - datatimepicker: don't open the popup before popupafterclose event is fired(N_SE-23027)
202         - handler: bug fix (regarding enableHandler function )
203         - demo:fix syntax error
204
205 * Sat Jan 26 2013 Youmin Ha <youmin.ha@samsung.com> 0.2.14
206         - demo: fix demo using tizen device API
207         - multimediaview: reset the height of container
208         - input: modify css correctly
209         - multimediaview: fix the height of widget
210         - gallery: bind create event
211         - progress: bind create event
212         - slider: bind create event
213         - progressbar: bind create event
214         - progressbar: event trigger correctly
215         - popup: fix height of popup scroller
216         - build: add continue option to jslint
217         - ctxpopup demo : bug fix
218         - demo: fix searchbar demo to use different IDs
219         - demo: extract routine executing Tizen device API
220         - toggleswitch : set default margin, delete box padding
221
222 * Thu Jan 24 2013 Youmin Ha <youmin.ha@samsung.com> 0.2.13
223         - virtuallist: Prevent replacing contents on nonexist element
224         - JQM: Trim text in listitem to get index in autodivider
225         - JQM: Remove trailing whitespace in jqm patch
226         - scrollview: get the height including margin
227         - multimediaview: bug fix ( scrolling in full-screen mode )
228         - virtuallist: set listitem width to exclude listitem left/right margin
229         - demo: fix virtuallist sample layout
230         - progress: set the position explicitly
231         - progress: rename from progressing to progress
232         - build: remove unused files
233         - searchbar: fix jslint errors
234         - src: fix file permissions
235         - button : change jump left icon
236
237 * Wed Jan 23 2013 Minkyu Kang <mk7.kang@samsung.com> 0.2.12
238         - theme : button icon - scrolltop, scrolleft icon changed.
239         - build: cleanaup Makefile
240         - pagelayout: fix jslint error
241         - virtualgrid: Fix jslint errors
242         - tabbar : jslint bug error fix
243         - build: add regexp option to jslint
244         - virtuallist: fix jslint errors
245         - handler: Apply the exceptional principle for scrollbar on Handler.
246         - build: remove unused copyright
247         - loader: extract log class for tizen web, and fix jslint errors
248         - loader: Viewport width is set to document width
249         - popupwindow: fix jslint error
250         - build: fix Makefile for tizen-white theme
251         - build: remove unused libraries
252         - datetimepicker: fix jslint error
253         - slider: fix jslint error
254         - demo: remove deprecated demos
255         - pagelayout : change to call relayout with this page
256         - Tokentextarea: Block size error fixed.
257         - handler: bug fix (handler activation)
258
259 * Tue Jan 22 2013 Minkyu Kang <mk7.kang@samsung.com> 0.2.11
260         - demo: clear input text value with cancel button click
261         - demo: Adjust textarea height automatically
262         - naviframe : bug fix
263         - tabbar : bug fix
264         - Fastscroll: popup position has been changed
265         - Button: custom button icon path, margin have been changed
266         - toggleswitch : bug fix
267         - slider: increase the margin
268         - datetimepicker: close the popup after select the value
269         - unit-test : add page backbutton control test
270         - Demo: added guide text and change input type in list vi
271         - remove legacy codes : jquery-geo
272         - Datetimepicker: text-main max-width has been removed
273         - Radio: control group border has been removed
274         - Demo: remove 'tab' space
275         - UnitTC: swipe unit tc has been fixed
276         - UnitTC: jQuery path has been fixed
277         - Button: bug fix when button has not a text
278         - tizen-winset: timepicker: demo title is changed
279
280 * Fri Jan 18 2013 Minkyu Kang <mk7.kang@samsung.com> 0.2.10
281         - tizen-winsets: codes cleanup
282         - datetimepicker: date calibration when year is changed
283         - Demo: textarea size has been changed
284         - Demo: Naviframe morebutton demo has been changed
285         - remove unused unit test cases : gallery3d
286         - tizen-winset: remove links
287
288 * Thu Jan 17 2013 Minkyu Kang <mk7.kang@samsung.com> 0.2.9
289         - gallery: use timeout function instead of interval
290         - Tokentextarea: Display error fixed.
291         - scrollview: Fix not selector to respond with jQuery1.8.2
292         - tabbar: remove the width of last element
293         - Demo: apply css 'user-select:none'
294         - Button: guide text has been shorten
295         - build: Update jQuery to 1.8.2 (JQM1.2 compliant)
296         - virtuallist: Fix mistyping
297         - demo: Fix tizen function namespace in demo
298         - virtuallist: Rewrite listitem replacing algorithm
299         - fastscroll: modify from not selector to function
300         - extendablelist: Fix unit-test
301         - tabbar : prefix to tabbar scroll event
302         - Popupwindow: removed unvalid selector in jquery 1.8.2
303         - slider: adjust handle text as length of value
304         - Demo: 3 buttons in popup text has been changed
305         - src: codes cleanup
306         - demo : remove trailing empty strings
307         - demo : rename TizenWinset list items
308         - button : change from long text list to multiline list
309         - build: Remove JQM1.1.0 patches
310         - Popup: Apply tizen style popup and attribute support
311         - JQM: Fix buttonmarkup bug keeping ui-btn-down class
312         - UnitTest: folder and file renamed, QUnit path was modified
313         - tizen-winsets: button: fix textarea width
314         - Swipe: event name error has been fixed
315
316 * Tue Jan 15 2013 Minkyu Kang <mk7.kang@samsung.com> 0.2.8
317         - Button: button padding has been updated
318         - virtuallist: fix unique listitem ID bug
319         - checkbox, radio : change display attr
320         - Button: bug fix ( when data style circle button on text )
321         - handler: bug fix (when scrolling with multi selection)
322         - JQM: adjust patch number
323         - gallery: show the widget after pageshow
324         - TokenTextArea : resource add ( press image )
325         - gallery: adds function that set the index to value API
326         - configure: set TIZEN default configures
327         - footer: h tag display attribute value has been changed
328         - buttons : demo bug fix
329         - searchbar : demo page bug fix
330         - tizen demo : bug fix
331         - build: remove JQM1.1.0
332         - Tokentextarea: Fix issues
333         - scrollview: block the multi touch
334         - list : dialogue list demo change
335         - pagelayout : update dynamic control
336         - Demo: Context popup close method has been changed
337
338 * Fri Jan 11 2013 Minkyu Kang <mk7.kang@samsung.com> 0.2.7
339         - slider: set text container's width as text length
340         - Timepicker: li max-width has been changed
341         - remove experimental feature - mapview.
342         - scrollview: added conditions for finding slider
343         - UnitTC: Pass,error count save method has been changed
344         - confix.xml: default config added for tizen basic applications
345         - Swipe: p tag margin value is set '0'
346         - packaging: remove unused file
347         - tabbar : bug fix
348         - list demo : bug fix
349         - tizen-winsets: gallery: move to new section
350         - tizen-winsets: autodivider: removes link of list
351         - demos: entry of number-pattern name is changed from 'number' to 'number-pattern'
352         - pagelayout : padding calculate change, ime footer check changed
353         - tizen-winsets: searchbar: scroll to the top when type the character
354         - searchbar : bug fix
355         - demo: Fix virtuallist demo following new list style
356         - demo: Add word-wrap:break-word and remove parag. width
357         - Demo: button max-width has been set( 3 buttons in popup )
358         - back button control demo : bug fix
359         - toggleswitch : demo page modify
360         - slider: add margin-top and margin-bottom
361         - tabbar demo : bug fix
362         - Popup: IME hide when popup is closed
363         - token textarea : bug fix
364         - Timepicker: change get attribute method
365         - footer demo : bug fix
366         - unit-test: gallery: add new APIs
367         - gallery: adds support new APIs
368
369 * Fri Jan 04 2013 Minkyu Kang <mk7.kang@samsung.com> 0.2.6
370         - JQM: patches cleanup
371         - Button: data-corners attribute has been added
372         - unit-test: slider: fix class name of background
373         - progressbar, slider: fix less variable typo
374         - Tabbar : VI update
375         - notification: add top position at fix class
376         - demo: entry demo page change
377         - css: .ui-disabled added
378         - tizen-winset: token textarea: remove back button at demo page
379         - theme: Remove unused less file
380         - pagelayout : content min height bug fix
381         - scrollview: skip the dragging when target is slider's handle
382         - scrollview: update and refactoring the scroll effect
383         - UnitTest:JQM Unit TC helper has been added,TCs have been modified
384         - Swipe: demo page html error has been fixed
385         - listview: Add add/delete animation (VI)
386         - Popup: demo page has been modified
387         - tizen demo : bug fix
388         - searchbar : demo page change(change front button and add behaviour)
389         - pagelayout : add min height to content
390         - gallery: rename 'Image Slider' to 'Gallery' in tizen-winsets demo and tests
391         - back button control demo : change url link to data-rel="back"
392         - loader: Skip loading theme CSS with a custom css code
393         - Button: support no-text in button
394         - collapsible: Fix syntax error
395         - slider: use data-highlight attribute
396         - collapsible: Rotate animation to collapsible heading icon
397         - toggleswitch : text switch bug fix
398         - remove candidates-calendarpicker
399         - Patch: Fix misc mistakes in JQM patches
400         - searchbar : animation change
401         - gallery: get the width correctly
402         - demo: data-framework-viewport-scale attribute is changed to data-framework-viewport-width
403         - collapsible: Add collapse/expand animation (VI)
404         - datetimepicker: VI update
405         - JQM: set transition to pop as default
406         - tabbar : bug fix in case none li element case
407         - scrollview: fix the drag bug
408         - Button: Button icon scrolltop, left has beed added
409         - Swipe: VI update and swipe speed has been changed
410         - jqm: fix errors in patch files
411         - unit-test: swipe: fixed the destroy test
412
413 * Wed Dec 26 2012 Youmin Ha <youmin.ha@samsung.com> 0.2.5
414         - Revert "[checkboxradio] exception handling for input"
415                 This reverts commit 72478c32704fa96362db577e6cf9511777919ea8.
416                 Tizen style supports no-label radio and checkbox when making lists.
417                 So it ignores html input operation. Instead, it supports tizen style radio and checkbox theme.
418
419 * Thu Dec 20 2012 Youmin Ha <youmin.ha@samsung.com> 0.2.4
420 - Fix:
421         - modify segment background
422         - rearrange check, radio input
423         - CtxPopup: Scale up/ down popup vi(poptop, popbottom)
424         - button: style has beed added(box,circle,nobg,round)
425         - favorite resource added
426         - demo/tizen-winsets: add footer and back button
427         - remove autodividers unit test
428         - add divider for tabbar
429         - checkboxradio: exception handling for input
430         - segment control backward compatiblity
431         - Fix collapsible unit-test
432         - remove toggleswitch
433         - add patch for remove segment text
434 - Spec changes:
435         - replace controlbar to tabbar
436
437 * Fri Dec 14 2012 Minkyu Kang <mk7.kang@samsung.com> 0.2.3
438 - FIX:
439         - slider: add image
440         - button: data-icon support, styles fix
441         - progressbar: modify the background
442         - scrollview: auto scrolling bug fix
443         - pagelayout: IME concept is changed
444 - Spec changes:
445         - dialogue: add edit mode
446         - nocontents: removed
447         - pagecontrol: removed
448         - dayselector: removed
449         - expandablelist: removed
450
451 * Thu Dec 10 2012 Youmin Ha <youmin.ha@samsung.com> 0.2.2
452 - FIX:
453         - chang searchbar/slider images
454         - delete redundant button images
455 - Spec changes:
456         - Change widget name: shortcutscroll -> fastscroll
457
458 * Thu Dec 07 2012 Youmin Ha <youmin.ha@samsung.com> 0.2.1
459 - FIX:
460         - jqm1.2: Change collapsible style to meet expandable list
461         - remove jquery-geo-1.0.a4
462         - unit-test: rename from imageslider to gallery
463         - nocontent: add warning message
464         - Handler: Fix issues in jqm1.2
465         - Multimediaview: modify APIs & comments
466         - Mapview: Fix issues in jqm1.2
467         - JQM: clean up patches
468         - Swipelist: refactoring swipelist
469         - Popup,Ctxpopup: Apply tizen style popup in JQM1.2
470         - rearrange button's data-icon resources
471 - Spec changes:
472         - Virtualgrid: remove option ('data-itemcount')
473         - gallery: rename the widget from imageslider to gallery
474         - add new style for searchbar
475         [tokentextarea] multi-button entry renamed as token text area. API & comments modified.
476
477 * Thu Dec 06 2012 Minkyu Kang <mk7.kang@samsung.com> 0.2.0
478 - FIX:
479         - fix jslint error
480         - remove unused files
481         - change naviframe style
482 - Spec changes:
483         - applied jQuery Mobile 1.2.0
484         - remove optionheader
485
486 * Fri Nov 30 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.64
487 - FIX:
488         - fix unit tests
489         - remove unused theme files
490         - timepicker: text position fix
491         - scrollview: set dragstop when mouse is out of window
492         - listview: fix margin
493 - Spec changes:
494         - support data-framework-viewport-width
495
496 * Fri Nov 23 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.63
497 - FIX:
498         - dayselector: fix size
499         - remove unised styles
500         - divider: set non-press effect to default option
501         - popupwindow: fix window closing failure
502         - handler: GUI implementation
503         - TC: fix unit TCs
504         - scrollview: fix padding size
505 - Spec changes:
506         - Remove color widgets
507         - add $.tizen.pkgVersion for SDK
508 - Etc.
509         - JSDuck documents
510
511 * Fri Nov 16 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.62
512 - FIX:
513         - Many winsets: Fix layout
514         - Footer: fix position to bottom
515 - Spec changes:
516         - Remove color widgets
517
518 * Fri Nov 09 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.61
519 - FIX:
520         - Many widgets: New UX 0.6 theme implementation
521         - widgetex: init speed up
522         - scrollview: fix scrollbar and scale animation
523         - scrollview: fix scroll position when updatelayout is triggered
524         - header/footer: make textselection disable, except input type="text"
525
526 * Wed Nov 07 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.60
527 - FIX:
528         - Remove tizen-black theme package description
529
530 * Tue Nov 06 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.59
531 - FIX:
532         - Fix theme name to meet the change of system theme name: white->tizen
533         - Popupwindow: fix left position
534         - Remove black theme
535         - footer: remove label, legend drawing
536 - Spec changes:
537         - UX guide v0.4 : button, layout
538
539 * Fri Oct 26 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.58
540 - FIX:
541         - scrollview: Fix outer scroll amount
542         - tabbar: fix tapping twice
543         - popupwindow: fix left position
544
545 * Wed Oct 24 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.57
546 - FIX:
547         - expandablelist: icon color fix
548         - scrollview: Fix xy scroll
549         - footer: Remove dummy div
550         - Make string concatnation effective in inline-protos.sh
551 - Spec changes:
552         - refresh header/footer when drag&drop event is fired in GUI builder
553         - searchbar: delete cancel button
554         - don't trigger updatelayout event when keyup event comes
555
556 * Mon Oct 15 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.56
557 - FIX:
558         - Toggleswitch: Change event name from 'changed' to 'change'
559         - Notification: Revert interval feature
560
561 * Tue Oct 09 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.55
562 - FIX:
563         - Fix SMACK manifest bug (S1-9098)
564
565 * Fri Oct 05 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.54
566 - FIX:
567         - handler: don't append a handler if handler is not enabled
568         - scrollview: use static value
569         - datetimepicker: fix date-format HH display error
570 - ETC:
571         - provide jquery.min.js
572         - barlayout: codes clean
573         - remove unused file
574
575 * Wed Sep 26 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.53
576 - FIX:
577         - listview: change focused color
578         - multibuttonentry: code refactoring
579         - datetimepicker: modify date format when triggered date-changed event
580         - slider: fix the top of slider bar
581         - add event blocker when load a first page
582
583 * Fri Sep 21 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.52
584 - ETC.
585         - Move SMACK manifest files to the top SRCDIR
586
587 * Fri Sep 21 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.51
588 - FIX:
589         - Popup: Do not focus container
590         - Header: show backbutton when both tabbar and header are present together
591         - Multi button entry: text ellipsis, code refactoring
592
593 * Fri Sep 21 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.50
594 - ETC.
595         - Apply SMACK manifest
596
597 * Thu Sep 20 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.49
598 - FIX:
599         - JSLINT code clean-up
600         - scrollview: firefox support
601         - scrollview: fix finding slider handle
602         - list: tweak text ellipsis
603         - checkbox: fix selecting wrong label tag (N_SE-8370)
604         - imageslider: check parameter
605         - smallpopup: fix position
606         - searchbar: fix 'clear' button size
607 - Spec changes:
608         - scrollview: support outer scroll
609         - JQM: block click event only with the element that does preventdefault on vclick(N_SE-6090)
610         - remove S/W IME control
611
612 * Thu Sep 13 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.48
613 - FIX:
614         - Add missing icon: controlbar
615         - scrollview: tune scrolling animatio ninterval
616         - datetimepicker: digit/triangle position
617         - datetimepicker: fix day overflow issue
618 - Spec changes:
619         - scrollview: show scrollbar when page is showed
620         - scrollview: disable outer scroll
621         - extendablelist: change api with legacy support
622         - add ui-text-ellipsis class
623
624 * Mon Sep 10 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.47
625 - FIX:
626         - scrollveiw: fix height of view
627         - searchbar: support placeholder
628 - Spec changes:
629         - add ui-text-ellipsis class
630
631 * Fri Sep 07 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.46
632 - FIX:
633         - scrollview: scrolling bug fix
634         - controlbar: fix width of controlbar item
635 - Spec changes:
636         - searchbar: don't hide icon
637         - popup: update JQM poup widget
638
639 * Fri Sep 05 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.45
640 - FIX:
641         - controlbar: set correct controlbar width of last element
642         - slider: get popup enable value correctly
643         - use Date.now() instead of (new Data()).getTime()
644         - popupwindow: fix the background color of popup scroller
645         - listview: add padding-left to expandable list
646         - add ellipsis for title area support
647
648 * Fri Aug 31 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.44
649 - FIX:
650         - swipelist: show list items correctly
651         - datetimepicker: set last day, if day is overflowed
652 - Spec changes:
653         - controlbar: update icons
654
655 * Tue Aug 29 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.43
656 - FIX:
657         - notification: fix typo
658 - Spec changes:
659         - controlbar: update icons
660
661 * Tue Aug 28 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.42
662 - FIX:
663         - multimediaview: video progress bar display normally for too samll
664         - segmentcontrol: remove media query
665         - scrollview: add outer scroll condition
666         - datetimepicker: modify triangle size
667         - popupwindow: set the screen height explicitly
668         - notification: add multiline text
669 - Spec changes:
670         - mutibuttonentry: support new GUI
671         - virtualgrid: support new GUI
672
673 * Mon Aug 27 2012 Jinhyuk Jun <jinhyuk.jun@samsung.com> 0.1.41
674 - FIX:
675         - radio/check button : button size bug fix
676
677 * Fri Aug 24 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.40
678 - FIX:
679         - build error fixed
680
681 * Fri Aug 24 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.39
682 - FIX:
683         - listview: style fix, remove filter placeholder
684         - controlbar: divide styles
685         - scrollview: don't skip dragging when click button or inputbox
686         - slider: trim the text on text slider
687 - Spec changes:
688         - remove gray and blue theme
689         - add white and black theme
690         - support new GUI guide
691
692 * Mon Aug 20 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.38
693 - FIX:
694         - fix coment of version tag
695
696 * Fri Aug 17 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.37
697 - FIX :
698         - button: fix alignment
699         - listview: adjust the main text width
700         - virtualgrid: refactoring
701 - Spec changes:
702         - transition: support JQM 1.1.0 transitions
703         - scrollview: support the outer scroll
704         - notification: remove interval feature
705
706 * Tue Aug 14 2012 Youmin Ha <youmin.ha@samasung.com> 0.1.36
707 - FIX :
708         - checkboxRadio: Add left/right padding
709         - button: custom button & icon position
710         - virtuallist: remove 'recreate' test
711 - Spec changes:
712         - header/footer: enable/disable support
713
714 * Fri Aug 10 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.35
715 - FIX :
716         - expandablelist: modify show animation
717         - virtualgrid: Redesign programming interface
718         - popupwindow: code clean and fixed issues
719         - pagelayout: fix content height
720         - license file update
721         - virtuallist: Change programming interface
722         - datetimepicker: getting days correctly
723         - searchbar: set to hidden when cancel button is hide
724         - White theme title font tuning
725 - Spec changes:
726         - default theme tizen-gray to tizen-white
727         - set default page transition to none
728
729 * Mon Aug 02 2012 Jinhyuk Jun <jinhyuk.jun@samsung.com> 0.1.34
730 - FIX :
731         - Back Button : enlarge backbutton click size for white theme
732 - Feature :
733         - Expandable List : Add refresh api
734 * Mon Aug 02 2012 Jinhyuk Jun <jinhyuk.jun@samsung.com> 0.1.33
735 - FIX :
736         - click event touch threshold tuning
737
738 * Mon Aug 02 2012 Jinhyuk Jun <jinhyuk.jun@samsung.com> 0.1.32
739 - FIX : 
740         - Add back button highlight effect for white theme
741
742 * Mon Aug 01 2012 Jinhyuk Jun <jinhyuk.jun@samsnug.com> 0.1.31
743 - FIX : 
744         - IME checkroutine update, improve relayout on resize event
745         - Add highlight effect for radio button list 
746         - Scrollview : fix condition of updatelayout event
747 - Feature : progressing : add show/hide api
748
749 * Mon Jul 27 2012 Koeun Choi <koeun.choi@samsung.com> 0.1.30
750 - FIX : virtuallist, virtualgrid: Clean up temporary jquery.template object to clear cache
751         add default theme option on buttonMarkup for tizen theme
752         [searchbar] first fix : focus/blur fixed
753         back button does not work when long press
754         scrollview: don't auto scrolling if resizing area is too large
755 - Feature : notification : add api to set the icon at tickernoti
756         demo : update the list sample demo
757         Support tizen default theme
758
759 * Mon Jul 23 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.29
760 - Improvements & Bugfixes
761    - HOTFIX: Revert template function with jquery.template
762
763 * Thu Jul 19 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.28
764 - Improvements & Bugfixes
765    - Fix #WEB-1028: memory leak on virtuallist/virtualgrid
766 - Spec changes
767    - $.tizen.loadTheme() function accepts theme name as arguement
768    - Scrollview supports 'updatelayout' callback
769
770 * Tue Jul 17 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.27
771 - Improvements & Bugfixes
772    - Revert 'preventing long-press popup' patch, to fix backbutton to work in SocialMagazine
773
774 * Tue Jul 17 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.26
775 - Improvements & Bugfixes
776    - Add tizen-white theme package, to make rpm build to be finished
777
778 * Tue Jul 17 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.25
779 - Improvements & Bugfixes
780    - Set 'slide' as default page transition effect, by JQM patch
781
782 * Fri Jul 13 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.24
783 - Improvements & Bugfixes
784    - Fix IME show/hide algorithm
785    - Fix error on virtualgrid: link _set_scrollbar_size() function to the one in virtuallist
786
787 * Wed Jul 11 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.23
788 - Improvements & Bugfixes
789    - Fix notification position
790    - Fix unit tests
791
792  Fri Jul 6 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.22
793 - Spec changes
794         - JQM 1.1 upgrade
795 - Improvements & Bugfixes
796         - Transform3D support on scrollview
797         - Page layout supports IME control
798         - Mapview supports pinch zoom on JQM 1.1
799         - Fix wrong character on button in minified version
800         - Virtualgrid supports scrollbar
801         - Lots of bugfixes
802
803 * Fri Jun 22 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.20
804 - Spec changes
805         - Support 'latest' version (by symlink) for tizen-web-ui-fw.js path.
806         - imageslider : supports 'resize' event.
807         - listview : listview has 1px padding-bottom.
808         - loader : Change global namespace, from S to $.tizen.
809         - loader : Move loadCustomGlobalizeCulture() into $.tizen.util namespace.
810 - Improvements & Bugfixes
811         - Scrollview : supports 'translate3d', instead of 'translate'.
812         - notification : reset timer when 'show' or 'refresh' event.
813         - JQM patch : Fix vclick event triggered twice.
814 - Etc.
815         - Add & fix unit tests.
816
817 * Thu Jun 14 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.19
818 - Spec changes
819         - mapview : new widget.
820         - notification : add .refresh() API.
821         - pagecontrol : add .value([val]) API, and change an attribute name 'data-initVal' to 'data-value'.
822 - Improvements & Bugfixes
823         - Support minified CSS.
824         - loader : Fix & refactor 'loading globalize culture file' routine.
825         - JQM Patch : Calculate min-height of window in javascript code, and remove predefined min-height value from CSS.
826         - Many more bugfixes.
827 - Etc.
828         - Add many unit tests.
829         - Fix test coverage instrumentation tool to work with current source code.