0.2.24 release
[platform/framework/web/web-ui-fw.git] / packaging / web-ui-fw.spec
1 Name:       web-ui-fw
2 Version:    0.2.24
3 Release:    0
4 Summary:    Tizen Web UI Framework Library
5 Group:      Development/Other
6 License:    MIT
7 BuildArch:  noarch
8 BuildRequires:  make
9 BuildRequires:  nodejs
10 %ifarch %{arm}
11 BuildRequires:  nodejs-x86-arm
12 %endif
13
14 Source0:    %{name}-%{version}.tar.gz
15
16 %description
17 Tizen Web UI Framework library and theme packages
18
19 %prep
20 %setup -q
21
22 %build
23 make all
24
25 %install
26 make DESTDIR=%{buildroot} install
27
28 %post
29
30 %files
31 %manifest web-ui-fw.manifest
32 /usr/share/tizen-web-ui-fw/*/js/*.js
33 /usr/share/tizen-web-ui-fw/*/js/cultures
34 /usr/share/tizen-web-ui-fw/latest
35 /usr/share/tizen-web-ui-fw/VERSION
36
37 ###############################
38 %package -n web-ui-fw-theme-tizen-gray
39 BuildArch:  noarch
40 Summary:    Tizen Web UI Framework Theme : tizen-gray
41 %Description -n web-ui-fw-theme-tizen-gray
42     Tizen Web UI Framework Theme : tizen-gray
43     Deprecated package, but some binaries still refer this.
44
45 ###############################
46 %package -n web-ui-fw-theme-tizen-white
47 BuildArch:  noarch
48 Summary:    Tizen Web UI Framework Theme : tizen-white
49 %Description -n web-ui-fw-theme-tizen-white
50     Tizen Web UI Framework Theme : tizen-white
51 %files -n web-ui-fw-theme-tizen-white
52 %manifest web-ui-fw-theme-tizen-white.manifest
53 /usr/share/tizen-web-ui-fw/*/themes/tizen-white
54 /usr/share/tizen-web-ui-fw/*/themes/tizen-tizen
55
56 ###############################
57 %package -n web-ui-fw-theme-tizen-black
58 BuildArch:  noarch
59 Summary:    Tizen Web UI Framework Theme : tizen-black
60 %Description -n web-ui-fw-theme-tizen-black
61     Tizen Web UI Framework Theme : tizen-black
62 %files -n web-ui-fw-theme-tizen-black
63 %manifest web-ui-fw-theme-tizen-black.manifest
64 /usr/share/tizen-web-ui-fw/*/themes/tizen-black
65
66 ###############################
67 %package -n web-ui-fw-theme-default
68 BuildArch:  noarch
69 Summary:    Tizen Web UI Framework Theme : default
70 %Description -n web-ui-fw-theme-default
71     Tizen Web UI Framework Theme : default
72 %files -n web-ui-fw-theme-default
73 %manifest web-ui-fw-theme-default.manifest
74 /usr/share/tizen-web-ui-fw/*/themes/default
75
76 ###############################
77 %package -n web-ui-fw-devel
78 BuildArch:  noarch
79 Summary:    Tizen Web UI Framework Developer's files
80 %Description -n web-ui-fw-devel
81     Tizen Web UI Framework Developer's files
82 %files -n web-ui-fw-devel
83 /usr/share/tizen-web-ui-fw/bin
84 /usr/share/tizen-web-ui-fw/template
85 /usr/share/tizen-web-ui-fw/*/js/src
86 /usr/share/tizen-web-ui-fw/*/js/depData.json
87
88 ###############################
89 %package -n web-ui-fw-demo-tizen-winsets
90 BuildArch:  noarch
91 Summary:    Tizen Web UI Framework Demo Application: tizen winset demo
92 %Description -n web-ui-fw-demo-tizen-winsets
93     Tizen Web UI Framework Demo Application: tizen winset demo
94 %files  -n web-ui-fw-demo-tizen-winsets
95 /usr/share/tizen-web-ui-fw/demos/tizen-winsets
96
97
98 ###############################
99 %changelog
100 * Tue Apr 16 2013 Youmin Ha <youmin.ha@samsung.com> 0.2.24
101         - SegmentControl: 2-buttons display issue (N_SE-34200)
102         - Naviframe : remove unnecessary img positioning(N_SE-33969)
103         - Gallery: jslint error fix
104         - TizenWinset : remove landscape SIP on mode
105         - Tizen Black Theme png file changed
106         - Gallery: Images showing bug has been fixed
107         - Scrollview : change horizontal scrollview demo(N_SE-33997)
108         - Tizenwinset: added return false in popup sample
109         - Naviframe : support data-role="button" in header
110         - Additional UnitTC: tizen winset unit tc bugs have been fixed
111         - Checkbox : remove favorite button's display:block(N_SE-33896)
112         - UnitTC: QUnit path has been changed. Priority, function type check function has been added
113         - Tizen-winset : Footer changed from lower case to upper case.
114         - Slider: enhance performance fix
115         - UnitTC: Addtional unit tc ref path has been fixed
116         - virtualgrid: apply overscrolling images to the style of widget
117         - Tabbar : Change overscroll image(left/right)
118         - ensurens: optimizations
119         - ensurens: qunit tests
120         - Tokentextarea: Fix block size error
121         - Fastscroll: Add a feature to fade out Fastscroll widget.
122         - Fastscroll: Add a user interaction at the omitted items.
123         - ImageLoader: Performance fix: apply lazy loading for canvas element
124         - Tests: Add tests for $.imageloader
125         - SegmentControl: 2-buttons display issue (N_SE-34200)
126         - virtuallist: fix width resizing trigger
127         - Timepicker: timepicker is closed when orientationchange event fired
128         - TizenWinset : Tabbar-persist issue.(N_SE-33996)
129         - Add Flora license
130         - collapsible: Fix collapsible list animation bug
131
132 * Wed Apr 10 2013 Youmin Ha <youmin.ha@samsung.com> 0.2.23
133         - Naviframe : modify SIP down button's position
134         - Core: Performance fix for disableSelection and enableSelection
135         - Tests: Core tests for disableSelection
136         - patch: fix small mistakes on the patches
137         - virtuallist: Change demo button style
138         - Button: btn-icon only css has been changed
139         - loader: Fix screen-width option processing
140         - pagelayout: Remember back key when it is hidden
141         - Tizen Black Theme : Tizen black theme png file changed.
142         - UnitTC: tizen winset unit tc bugs have been fixed
143         - TizenWinset: Swipe list sample has been fixed
144         - Radio : remove default radio's width(N_SE-33579)
145         - Scrollview : divide x/y overflow attribute
146         - Gallery: orientation image showing issue has been fixed
147         - Gallery: remove method bug has been fixed
148         - virtualgrid : fix unit-test error and increase test items
149         - Gallery3d: Modify demo & source codes for visibility enhancement.
150         - Gallery3d: Reduce loading time of widget
151         - Gallery3d: Change files' format to unix
152         - Contextpopup: context popup close when window resize event fire
153         - Popup: reverse orientation bug has been fixed
154         - Tokentextarea: modify description
155         - Multimediaview: modify description
156         - JQM: Do not add ui-btn-icon-only class at the select button
157         - build: tizen-black theme package
158         - Tizenwinset: popup script has been removed
159         - Tizenwinset: substring split view text message
160         - Timepicker: data-changed event will be deprecated
161
162 * Fri Apr 5 2013 Youmin Ha <youmin.ha@samsung.com> 0.2.22
163         - tizen-winsets: Fix demo menu
164         - Tizenwinset: Reorder tizenwinset menu
165         - SearchBar: Header button size issue has been fixed
166         - Swipe: list item overflow: hidden has been added
167         - Tizenwinset: href has been added in grouped list
168         - Tizenwinset: Page transition page has been added
169         - Tizenwinset: Radio description has been fixed
170         - This patch fixes problem when base url is changed when site is prefetched.
171         - Entry : limit textarea's width (N_SE-28653)
172         - Naviframe : hide backbutton in case SIP up(remove backbutton makes problem in binding event)
173         - Gallery : next, prev images position bug has been fixed
174         - Multimediaview: Fix display error while handling orientationchange event.
175         - Pagelayout : modify innerHeight dpr calculation in non scrollview mode
176         - Datetimepicker: picker position has been fixed when browser resize event fired
177         - Tips: generate elements sample page javascript has been fixed
178         - Tokentextarea: Fix Tizen-winsets demo.
179
180 * Wed Apr 3 2013 Youmin Ha <youmin.ha@samsung.com> 0.2.21
181         - VirtualGrid: Fix errors on centerTo and resize methods
182         - loader: Fix default font size at device-width viewport
183         - scrollview : remove overflow-x property
184         - Naviframe : fix backbutton position/ change down button icon
185         - Naviframe : bug fix
186         - Tizenwinset : Tizen-winset demo page titles changed Tizen-winset demo page titles changed from lower case to upper case.
187
188 * Fri Mar 29 2013 Youmin Ha <youmin.ha@samsung.com> 0.2.20
189         - JQM Navigation : remove page min-height
190         - Pagelayout : add refresh to pagelayout
191         - Tokentextarea: Changes 'remove' tests to asyncTest
192         - Popup: input tag alignment has been fixed
193         - Tokentextarea: add/remove events are deprecated.
194         - Contextpopup: Support horizontal list
195         - Select: icon z-index has been deleted
196         - Tizenwinset: ui widget order has been changed
197         - Tool: make web app template disable context menu by default
198         - Tizen-winset: change tips for using listview
199         - Loader: calculate font size with mobile width
200         - Naviframe : fix header's back button position
201         - TizenWinset : move locale info to another file
202
203 * Fri Mar 22 2013 Youmin Ha <youmin.ha@samsung.com> 0.2.19
204         - Tizen-winset: Support accessibility for tizen-winset
205         - Orientation : add orientataionchange to tizen-winset
206         - Tokentextarea: Adjusts VI effect for add/remove block
207         - splitview: Support accessibility for splitview
208         - Tizen-winset: Date/time picker guide text has been fixed
209         - Popup: context popup arrow position, setTimeout open method bug have been fixed
210         - fastscroll: Add new indexString API to Fastscroll widget.
211         - splitview: Add new widget
212         - gallery3d: Add new widget
213         - Scrollview : disable VI effect for gesture event
214         - Scrollview : disable SIP outerscroll
215         - Tizen-winset: resize VirtualGrid widget in demo
216         - Tizen-winsets: Refactor searchbar subpages
217         - Tizen-winsets: Remove depracated usage of virtuallist
218         - Tizen-winsets: Move js code from main.js to subpages
219         - Tizen-winsets: Refactor virtual grid demo subpages
220         - Tizen-winsets: Move css files from index to proper subpages
221         - Tizen-winsets: Refactor list dialogue edit subpage
222         - Tizen-winsets: Refactor pagelayout subpages
223         - Tizen-winsets: Refactor tips subpages
224         - Tizen-winsets: Move subpages popup files from index.html
225         - Tizen-winsets: Move subpages javascript files from index.html
226         - virtualgrid: fix improperly merged codes
227         - ColorTheme : remove unused color value(1st)
228         - Scrollview : change scrollbar draw
229         - Popup: Apply popup background dim
230         - Tizen-winsets: Move tokentextarea demo to external page.
231         - Tizen-winsets: Move tabbar persist demo to external page.
232         - Tizen-winsets: Remove notImplemented page
233         - Tizen-winsets: Move slider demo page to external subpage
234         - Tizen-winsets: Fix ids, remove duplicated names for sliders
235         - Tizen-winsets: Remove event for changing theme
236         - tool: Fix wgt sample app generator tool to make apps be installed
237         - demos : change live to on
238         - build: Trim compiled CSS files
239         - Gallery: CSS left -> translate or translate3D
240         - Tokentextarea: Disfunctional APIs fixed.
241
242 * Thu Mar 7 2013 Youmin Ha <youmin.ha@samsung.com> 0.2.18
243         - build: Fix Makefile to add globalize to the minified lib
244         - build-tools : upgrade less to v1.3.3
245         - demos : change normal js path to minified js
246         - Theme : remove reduantant less - dayselector, optionheader, nocontents
247         - multimediaview : fix full-screen mode.
248         - multimediaview : fix 'width', 'height' and 'fullScreen' methods
249         - Extendablelist: Added min-height "load more button" in listitem
250         - virtualgrid: adjusts VI effect for an overflow action
251         - ControlGroup : change ellipsis font color (press/normal)
252         - multimediaview: Add an error message to Multimediaview
253         - virtualgrid: adjusts triple flick gesture
254         - scrollview: add function for getting width of view
255         - scrollview: adds support x axis gesture scroll
256         - multimediaview : fix audio control
257         - tabbar : tabbar slide animation change
258         - TizenWinsetDemo : 2line-text demo bug fix
259         - collapsible: Fix demo to show radio button correctly in the collapsible list
260         - collapsible: Set listitem position to relative
261         - UnitTC: added list divider unit test
262         - Style: unnecessary color codes have been deleted and modified
263         - build: Module build implementation
264         - UnitTC: Additional unit testcases have been added
265         - listview : bug fix
266         - Naviframe : remove back button's hover effect
267         - TizenDemo : remove back button
268         - Transition: added more-button vi
269         - pinch: added new event called pinch
270         - Popup: css word-wrap:break-word has been added
271         - virtualgrid: memory leak fix
272         - progress: set to init state at pending bar
273         - progress: add margin of top/bottom
274         - unit-test: split progress test and progressbar test
275         - Tizen-winset: Context popup sample page guide text has been changed
276         - multimediaview: fix the height of widget when full-screen mode
277         - JQM: performance tuning
278
279 * Tue Feb 19 2013 Minkyu Kang <mk7.kang@samsung.com> 0.2.17
280         - DialogueList : delete border top value / add sample's text ellipsis
281         - Tokentextarea: Add scroll-to-top for Grouping On/Off regarding #N_SE-24877
282         - Multimediaview: Fix mute function
283         - Tizen-winset: list vi index guide textbox has been removed
284         - Tizen-winset: custom button texts have been changed
285         - slider: move popup div to out of content
286         - TizenWinset: disable context popup in multimediaview
287         - Swipe: wrong style name has been fixed
288         - demo: add the sample at dialogue list
289         - listview: Add ui-li-has-right-btn class with toggleswitch
290         - WinsetDemo : change wrong title name
291
292 * Mon Jan 28 2013 Youmin Ha <youmin.ha@samsung.com> 0.2.16
293         - demo: checkbox: reduce button's width
294         - tabbar : delete right/left tab animation color
295         - scrollview: fix the scroll position at keydown event
296         - groupControl : change footer groupControl from min-width to percentage
297         - scrollview: get height of softkeyboard correctly
298         - tizen-winset: Add name attr to all radio inputs
299         - virtualgrid: changes event binding target
300         - scrollview: skip the drag if target is textarea
301         - scrollview: skip the dragging of parent scrollview
302         - scrollview: apply the scaling ratio to the soft keyboard
303         - demos: apply disabled option in textarea
304         - demo: remove unused codes
305         - demo: datetimepicker: show selected date correctly
306         - listview: Adjust bubble listitem width and margin
307         - pagelayout : change external refresh call and ime status follow only current page
308         - toggleSwitch : bug fix
309         - unit-test: slider: fix the move test
310         - handler: fix jslint error
311         - ToggleSwitch : set image toggleswitch background attribute
312
313 * Mon Jan 28 2013 Youmin Ha <youmin.ha@samsung.com> 0.2.15
314         - slider: increase the text width(N_SE-23397)
315         - virtualgrid: DOM element leak fix
316         - header: Move button top higher in header with tabbar(N_SE-22253)
317         - datatimepicker: don't open the popup before popupafterclose event is fired(N_SE-23027)
318         - handler: bug fix (regarding enableHandler function )
319         - demo:fix syntax error
320
321 * Sat Jan 26 2013 Youmin Ha <youmin.ha@samsung.com> 0.2.14
322         - demo: fix demo using tizen device API
323         - multimediaview: reset the height of container
324         - input: modify css correctly
325         - multimediaview: fix the height of widget
326         - gallery: bind create event
327         - progress: bind create event
328         - slider: bind create event
329         - progressbar: bind create event
330         - progressbar: event trigger correctly
331         - popup: fix height of popup scroller
332         - build: add continue option to jslint
333         - ctxpopup demo : bug fix
334         - demo: fix searchbar demo to use different IDs
335         - demo: extract routine executing Tizen device API
336         - toggleswitch : set default margin, delete box padding
337
338 * Thu Jan 24 2013 Youmin Ha <youmin.ha@samsung.com> 0.2.13
339         - virtuallist: Prevent replacing contents on nonexist element
340         - JQM: Trim text in listitem to get index in autodivider
341         - JQM: Remove trailing whitespace in jqm patch
342         - scrollview: get the height including margin
343         - multimediaview: bug fix ( scrolling in full-screen mode )
344         - virtuallist: set listitem width to exclude listitem left/right margin
345         - demo: fix virtuallist sample layout
346         - progress: set the position explicitly
347         - progress: rename from progressing to progress
348         - build: remove unused files
349         - searchbar: fix jslint errors
350         - src: fix file permissions
351         - button : change jump left icon
352
353 * Wed Jan 23 2013 Minkyu Kang <mk7.kang@samsung.com> 0.2.12
354         - theme : button icon - scrolltop, scrolleft icon changed.
355         - build: cleanaup Makefile
356         - pagelayout: fix jslint error
357         - virtualgrid: Fix jslint errors
358         - tabbar : jslint bug error fix
359         - build: add regexp option to jslint
360         - virtuallist: fix jslint errors
361         - handler: Apply the exceptional principle for scrollbar on Handler.
362         - build: remove unused copyright
363         - loader: extract log class for tizen web, and fix jslint errors
364         - loader: Viewport width is set to document width
365         - popupwindow: fix jslint error
366         - build: fix Makefile for tizen-white theme
367         - build: remove unused libraries
368         - datetimepicker: fix jslint error
369         - slider: fix jslint error
370         - demo: remove deprecated demos
371         - pagelayout : change to call relayout with this page
372         - Tokentextarea: Block size error fixed.
373         - handler: bug fix (handler activation)
374
375 * Tue Jan 22 2013 Minkyu Kang <mk7.kang@samsung.com> 0.2.11
376         - demo: clear input text value with cancel button click
377         - demo: Adjust textarea height automatically
378         - naviframe : bug fix
379         - tabbar : bug fix
380         - Fastscroll: popup position has been changed
381         - Button: custom button icon path, margin have been changed
382         - toggleswitch : bug fix
383         - slider: increase the margin
384         - datetimepicker: close the popup after select the value
385         - unit-test : add page backbutton control test
386         - Demo: added guide text and change input type in list vi
387         - remove legacy codes : jquery-geo
388         - Datetimepicker: text-main max-width has been removed
389         - Radio: control group border has been removed
390         - Demo: remove 'tab' space
391         - UnitTC: swipe unit tc has been fixed
392         - UnitTC: jQuery path has been fixed
393         - Button: bug fix when button has not a text
394         - tizen-winset: timepicker: demo title is changed
395
396 * Fri Jan 18 2013 Minkyu Kang <mk7.kang@samsung.com> 0.2.10
397         - tizen-winsets: codes cleanup
398         - datetimepicker: date calibration when year is changed
399         - Demo: textarea size has been changed
400         - Demo: Naviframe morebutton demo has been changed
401         - remove unused unit test cases : gallery3d
402         - tizen-winset: remove links
403
404 * Thu Jan 17 2013 Minkyu Kang <mk7.kang@samsung.com> 0.2.9
405         - gallery: use timeout function instead of interval
406         - Tokentextarea: Display error fixed.
407         - scrollview: Fix not selector to respond with jQuery1.8.2
408         - tabbar: remove the width of last element
409         - Demo: apply css 'user-select:none'
410         - Button: guide text has been shorten
411         - build: Update jQuery to 1.8.2 (JQM1.2 compliant)
412         - virtuallist: Fix mistyping
413         - demo: Fix tizen function namespace in demo
414         - virtuallist: Rewrite listitem replacing algorithm
415         - fastscroll: modify from not selector to function
416         - extendablelist: Fix unit-test
417         - tabbar : prefix to tabbar scroll event
418         - Popupwindow: removed unvalid selector in jquery 1.8.2
419         - slider: adjust handle text as length of value
420         - Demo: 3 buttons in popup text has been changed
421         - src: codes cleanup
422         - demo : remove trailing empty strings
423         - demo : rename TizenWinset list items
424         - button : change from long text list to multiline list
425         - build: Remove JQM1.1.0 patches
426         - Popup: Apply tizen style popup and attribute support
427         - JQM: Fix buttonmarkup bug keeping ui-btn-down class
428         - UnitTest: folder and file renamed, QUnit path was modified
429         - tizen-winsets: button: fix textarea width
430         - Swipe: event name error has been fixed
431
432 * Tue Jan 15 2013 Minkyu Kang <mk7.kang@samsung.com> 0.2.8
433         - Button: button padding has been updated
434         - virtuallist: fix unique listitem ID bug
435         - checkbox, radio : change display attr
436         - Button: bug fix ( when data style circle button on text )
437         - handler: bug fix (when scrolling with multi selection)
438         - JQM: adjust patch number
439         - gallery: show the widget after pageshow
440         - TokenTextArea : resource add ( press image )
441         - gallery: adds function that set the index to value API
442         - configure: set TIZEN default configures
443         - footer: h tag display attribute value has been changed
444         - buttons : demo bug fix
445         - searchbar : demo page bug fix
446         - tizen demo : bug fix
447         - build: remove JQM1.1.0
448         - Tokentextarea: Fix issues
449         - scrollview: block the multi touch
450         - list : dialogue list demo change
451         - pagelayout : update dynamic control
452         - Demo: Context popup close method has been changed
453
454 * Fri Jan 11 2013 Minkyu Kang <mk7.kang@samsung.com> 0.2.7
455         - slider: set text container's width as text length
456         - Timepicker: li max-width has been changed
457         - remove experimental feature - mapview.
458         - scrollview: added conditions for finding slider
459         - UnitTC: Pass,error count save method has been changed
460         - confix.xml: default config added for tizen basic applications
461         - Swipe: p tag margin value is set '0'
462         - packaging: remove unused file
463         - tabbar : bug fix
464         - list demo : bug fix
465         - tizen-winsets: gallery: move to new section
466         - tizen-winsets: autodivider: removes link of list
467         - demos: entry of number-pattern name is changed from 'number' to 'number-pattern'
468         - pagelayout : padding calculate change, ime footer check changed
469         - tizen-winsets: searchbar: scroll to the top when type the character
470         - searchbar : bug fix
471         - demo: Fix virtuallist demo following new list style
472         - demo: Add word-wrap:break-word and remove parag. width
473         - Demo: button max-width has been set( 3 buttons in popup )
474         - back button control demo : bug fix
475         - toggleswitch : demo page modify
476         - slider: add margin-top and margin-bottom
477         - tabbar demo : bug fix
478         - Popup: IME hide when popup is closed
479         - token textarea : bug fix
480         - Timepicker: change get attribute method
481         - footer demo : bug fix
482         - unit-test: gallery: add new APIs
483         - gallery: adds support new APIs
484
485 * Fri Jan 04 2013 Minkyu Kang <mk7.kang@samsung.com> 0.2.6
486         - JQM: patches cleanup
487         - Button: data-corners attribute has been added
488         - unit-test: slider: fix class name of background
489         - progressbar, slider: fix less variable typo
490         - Tabbar : VI update
491         - notification: add top position at fix class
492         - demo: entry demo page change
493         - css: .ui-disabled added
494         - tizen-winset: token textarea: remove back button at demo page
495         - theme: Remove unused less file
496         - pagelayout : content min height bug fix
497         - scrollview: skip the dragging when target is slider's handle
498         - scrollview: update and refactoring the scroll effect
499         - UnitTest:JQM Unit TC helper has been added,TCs have been modified
500         - Swipe: demo page html error has been fixed
501         - listview: Add add/delete animation (VI)
502         - Popup: demo page has been modified
503         - tizen demo : bug fix
504         - searchbar : demo page change(change front button and add behaviour)
505         - pagelayout : add min height to content
506         - gallery: rename 'Image Slider' to 'Gallery' in tizen-winsets demo and tests
507         - back button control demo : change url link to data-rel="back"
508         - loader: Skip loading theme CSS with a custom css code
509         - Button: support no-text in button
510         - collapsible: Fix syntax error
511         - slider: use data-highlight attribute
512         - collapsible: Rotate animation to collapsible heading icon
513         - toggleswitch : text switch bug fix
514         - remove candidates-calendarpicker
515         - Patch: Fix misc mistakes in JQM patches
516         - searchbar : animation change
517         - gallery: get the width correctly
518         - demo: data-framework-viewport-scale attribute is changed to data-framework-viewport-width
519         - collapsible: Add collapse/expand animation (VI)
520         - datetimepicker: VI update
521         - JQM: set transition to pop as default
522         - tabbar : bug fix in case none li element case
523         - scrollview: fix the drag bug
524         - Button: Button icon scrolltop, left has beed added
525         - Swipe: VI update and swipe speed has been changed
526         - jqm: fix errors in patch files
527         - unit-test: swipe: fixed the destroy test
528
529 * Wed Dec 26 2012 Youmin Ha <youmin.ha@samsung.com> 0.2.5
530         - Revert "[checkboxradio] exception handling for input"
531                 This reverts commit 72478c32704fa96362db577e6cf9511777919ea8.
532                 Tizen style supports no-label radio and checkbox when making lists.
533                 So it ignores html input operation. Instead, it supports tizen style radio and checkbox theme.
534
535 * Thu Dec 20 2012 Youmin Ha <youmin.ha@samsung.com> 0.2.4
536 - Fix:
537         - modify segment background
538         - rearrange check, radio input
539         - CtxPopup: Scale up/ down popup vi(poptop, popbottom)
540         - button: style has beed added(box,circle,nobg,round)
541         - favorite resource added
542         - demo/tizen-winsets: add footer and back button
543         - remove autodividers unit test
544         - add divider for tabbar
545         - checkboxradio: exception handling for input
546         - segment control backward compatiblity
547         - Fix collapsible unit-test
548         - remove toggleswitch
549         - add patch for remove segment text
550 - Spec changes:
551         - replace controlbar to tabbar
552
553 * Fri Dec 14 2012 Minkyu Kang <mk7.kang@samsung.com> 0.2.3
554 - FIX:
555         - slider: add image
556         - button: data-icon support, styles fix
557         - progressbar: modify the background
558         - scrollview: auto scrolling bug fix
559         - pagelayout: IME concept is changed
560 - Spec changes:
561         - dialogue: add edit mode
562         - nocontents: removed
563         - pagecontrol: removed
564         - dayselector: removed
565         - expandablelist: removed
566
567 * Thu Dec 10 2012 Youmin Ha <youmin.ha@samsung.com> 0.2.2
568 - FIX:
569         - chang searchbar/slider images
570         - delete redundant button images
571 - Spec changes:
572         - Change widget name: shortcutscroll -> fastscroll
573
574 * Thu Dec 07 2012 Youmin Ha <youmin.ha@samsung.com> 0.2.1
575 - FIX:
576         - jqm1.2: Change collapsible style to meet expandable list
577         - remove jquery-geo-1.0.a4
578         - unit-test: rename from imageslider to gallery
579         - nocontent: add warning message
580         - Handler: Fix issues in jqm1.2
581         - Multimediaview: modify APIs & comments
582         - Mapview: Fix issues in jqm1.2
583         - JQM: clean up patches
584         - Swipelist: refactoring swipelist
585         - Popup,Ctxpopup: Apply tizen style popup in JQM1.2
586         - rearrange button's data-icon resources
587 - Spec changes:
588         - Virtualgrid: remove option ('data-itemcount')
589         - gallery: rename the widget from imageslider to gallery
590         - add new style for searchbar
591         [tokentextarea] multi-button entry renamed as token text area. API & comments modified.
592
593 * Thu Dec 06 2012 Minkyu Kang <mk7.kang@samsung.com> 0.2.0
594 - FIX:
595         - fix jslint error
596         - remove unused files
597         - change naviframe style
598 - Spec changes:
599         - applied jQuery Mobile 1.2.0
600         - remove optionheader
601
602 * Fri Nov 30 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.64
603 - FIX:
604         - fix unit tests
605         - remove unused theme files
606         - timepicker: text position fix
607         - scrollview: set dragstop when mouse is out of window
608         - listview: fix margin
609 - Spec changes:
610         - support data-framework-viewport-width
611
612 * Fri Nov 23 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.63
613 - FIX:
614         - dayselector: fix size
615         - remove unised styles
616         - divider: set non-press effect to default option
617         - popupwindow: fix window closing failure
618         - handler: GUI implementation
619         - TC: fix unit TCs
620         - scrollview: fix padding size
621 - Spec changes:
622         - Remove color widgets
623         - add $.tizen.pkgVersion for SDK
624 - Etc.
625         - JSDuck documents
626
627 * Fri Nov 16 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.62
628 - FIX:
629         - Many winsets: Fix layout
630         - Footer: fix position to bottom
631 - Spec changes:
632         - Remove color widgets
633
634 * Fri Nov 09 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.61
635 - FIX:
636         - Many widgets: New UX 0.6 theme implementation
637         - widgetex: init speed up
638         - scrollview: fix scrollbar and scale animation
639         - scrollview: fix scroll position when updatelayout is triggered
640         - header/footer: make textselection disable, except input type="text"
641
642 * Wed Nov 07 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.60
643 - FIX:
644         - Remove tizen-black theme package description
645
646 * Tue Nov 06 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.59
647 - FIX:
648         - Fix theme name to meet the change of system theme name: white->tizen
649         - Popupwindow: fix left position
650         - Remove black theme
651         - footer: remove label, legend drawing
652 - Spec changes:
653         - UX guide v0.4 : button, layout
654
655 * Fri Oct 26 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.58
656 - FIX:
657         - scrollview: Fix outer scroll amount
658         - tabbar: fix tapping twice
659         - popupwindow: fix left position
660
661 * Wed Oct 24 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.57
662 - FIX:
663         - expandablelist: icon color fix
664         - scrollview: Fix xy scroll
665         - footer: Remove dummy div
666         - Make string concatnation effective in inline-protos.sh
667 - Spec changes:
668         - refresh header/footer when drag&drop event is fired in GUI builder
669         - searchbar: delete cancel button
670         - don't trigger updatelayout event when keyup event comes
671
672 * Mon Oct 15 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.56
673 - FIX:
674         - Toggleswitch: Change event name from 'changed' to 'change'
675         - Notification: Revert interval feature
676
677 * Tue Oct 09 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.55
678 - FIX:
679         - Fix SMACK manifest bug (S1-9098)
680
681 * Fri Oct 05 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.54
682 - FIX:
683         - handler: don't append a handler if handler is not enabled
684         - scrollview: use static value
685         - datetimepicker: fix date-format HH display error
686 - ETC:
687         - provide jquery.min.js
688         - barlayout: codes clean
689         - remove unused file
690
691 * Wed Sep 26 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.53
692 - FIX:
693         - listview: change focused color
694         - multibuttonentry: code refactoring
695         - datetimepicker: modify date format when triggered date-changed event
696         - slider: fix the top of slider bar
697         - add event blocker when load a first page
698
699 * Fri Sep 21 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.52
700 - ETC.
701         - Move SMACK manifest files to the top SRCDIR
702
703 * Fri Sep 21 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.51
704 - FIX:
705         - Popup: Do not focus container
706         - Header: show backbutton when both tabbar and header are present together
707         - Multi button entry: text ellipsis, code refactoring
708
709 * Fri Sep 21 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.50
710 - ETC.
711         - Apply SMACK manifest
712
713 * Thu Sep 20 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.49
714 - FIX:
715         - JSLINT code clean-up
716         - scrollview: firefox support
717         - scrollview: fix finding slider handle
718         - list: tweak text ellipsis
719         - checkbox: fix selecting wrong label tag (N_SE-8370)
720         - imageslider: check parameter
721         - smallpopup: fix position
722         - searchbar: fix 'clear' button size
723 - Spec changes:
724         - scrollview: support outer scroll
725         - JQM: block click event only with the element that does preventdefault on vclick(N_SE-6090)
726         - remove S/W IME control
727
728 * Thu Sep 13 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.48
729 - FIX:
730         - Add missing icon: controlbar
731         - scrollview: tune scrolling animatio ninterval
732         - datetimepicker: digit/triangle position
733         - datetimepicker: fix day overflow issue
734 - Spec changes:
735         - scrollview: show scrollbar when page is showed
736         - scrollview: disable outer scroll
737         - extendablelist: change api with legacy support
738         - add ui-text-ellipsis class
739
740 * Mon Sep 10 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.47
741 - FIX:
742         - scrollveiw: fix height of view
743         - searchbar: support placeholder
744 - Spec changes:
745         - add ui-text-ellipsis class
746
747 * Fri Sep 07 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.46
748 - FIX:
749         - scrollview: scrolling bug fix
750         - controlbar: fix width of controlbar item
751 - Spec changes:
752         - searchbar: don't hide icon
753         - popup: update JQM poup widget
754
755 * Fri Sep 05 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.45
756 - FIX:
757         - controlbar: set correct controlbar width of last element
758         - slider: get popup enable value correctly
759         - use Date.now() instead of (new Data()).getTime()
760         - popupwindow: fix the background color of popup scroller
761         - listview: add padding-left to expandable list
762         - add ellipsis for title area support
763
764 * Fri Aug 31 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.44
765 - FIX:
766         - swipelist: show list items correctly
767         - datetimepicker: set last day, if day is overflowed
768 - Spec changes:
769         - controlbar: update icons
770
771 * Tue Aug 29 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.43
772 - FIX:
773         - notification: fix typo
774 - Spec changes:
775         - controlbar: update icons
776
777 * Tue Aug 28 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.42
778 - FIX:
779         - multimediaview: video progress bar display normally for too samll
780         - segmentcontrol: remove media query
781         - scrollview: add outer scroll condition
782         - datetimepicker: modify triangle size
783         - popupwindow: set the screen height explicitly
784         - notification: add multiline text
785 - Spec changes:
786         - mutibuttonentry: support new GUI
787         - virtualgrid: support new GUI
788
789 * Mon Aug 27 2012 Jinhyuk Jun <jinhyuk.jun@samsung.com> 0.1.41
790 - FIX:
791         - radio/check button : button size bug fix
792
793 * Fri Aug 24 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.40
794 - FIX:
795         - build error fixed
796
797 * Fri Aug 24 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.39
798 - FIX:
799         - listview: style fix, remove filter placeholder
800         - controlbar: divide styles
801         - scrollview: don't skip dragging when click button or inputbox
802         - slider: trim the text on text slider
803 - Spec changes:
804         - remove gray and blue theme
805         - add white and black theme
806         - support new GUI guide
807
808 * Mon Aug 20 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.38
809 - FIX:
810         - fix coment of version tag
811
812 * Fri Aug 17 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.37
813 - FIX :
814         - button: fix alignment
815         - listview: adjust the main text width
816         - virtualgrid: refactoring
817 - Spec changes:
818         - transition: support JQM 1.1.0 transitions
819         - scrollview: support the outer scroll
820         - notification: remove interval feature
821
822 * Tue Aug 14 2012 Youmin Ha <youmin.ha@samasung.com> 0.1.36
823 - FIX :
824         - checkboxRadio: Add left/right padding
825         - button: custom button & icon position
826         - virtuallist: remove 'recreate' test
827 - Spec changes:
828         - header/footer: enable/disable support
829
830 * Fri Aug 10 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.35
831 - FIX :
832         - expandablelist: modify show animation
833         - virtualgrid: Redesign programming interface
834         - popupwindow: code clean and fixed issues
835         - pagelayout: fix content height
836         - license file update
837         - virtuallist: Change programming interface
838         - datetimepicker: getting days correctly
839         - searchbar: set to hidden when cancel button is hide
840         - White theme title font tuning
841 - Spec changes:
842         - default theme tizen-gray to tizen-white
843         - set default page transition to none
844
845 * Mon Aug 02 2012 Jinhyuk Jun <jinhyuk.jun@samsung.com> 0.1.34
846 - FIX :
847         - Back Button : enlarge backbutton click size for white theme
848 - Feature :
849         - Expandable List : Add refresh api
850 * Mon Aug 02 2012 Jinhyuk Jun <jinhyuk.jun@samsung.com> 0.1.33
851 - FIX :
852         - click event touch threshold tuning
853
854 * Mon Aug 02 2012 Jinhyuk Jun <jinhyuk.jun@samsung.com> 0.1.32
855 - FIX : 
856         - Add back button highlight effect for white theme
857
858 * Mon Aug 01 2012 Jinhyuk Jun <jinhyuk.jun@samsnug.com> 0.1.31
859 - FIX : 
860         - IME checkroutine update, improve relayout on resize event
861         - Add highlight effect for radio button list 
862         - Scrollview : fix condition of updatelayout event
863 - Feature : progressing : add show/hide api
864
865 * Mon Jul 27 2012 Koeun Choi <koeun.choi@samsung.com> 0.1.30
866 - FIX : virtuallist, virtualgrid: Clean up temporary jquery.template object to clear cache
867         add default theme option on buttonMarkup for tizen theme
868         [searchbar] first fix : focus/blur fixed
869         back button does not work when long press
870         scrollview: don't auto scrolling if resizing area is too large
871 - Feature : notification : add api to set the icon at tickernoti
872         demo : update the list sample demo
873         Support tizen default theme
874
875 * Mon Jul 23 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.29
876 - Improvements & Bugfixes
877    - HOTFIX: Revert template function with jquery.template
878
879 * Thu Jul 19 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.28
880 - Improvements & Bugfixes
881    - Fix #WEB-1028: memory leak on virtuallist/virtualgrid
882 - Spec changes
883    - $.tizen.loadTheme() function accepts theme name as arguement
884    - Scrollview supports 'updatelayout' callback
885
886 * Tue Jul 17 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.27
887 - Improvements & Bugfixes
888    - Revert 'preventing long-press popup' patch, to fix backbutton to work in SocialMagazine
889
890 * Tue Jul 17 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.26
891 - Improvements & Bugfixes
892    - Add tizen-white theme package, to make rpm build to be finished
893
894 * Tue Jul 17 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.25
895 - Improvements & Bugfixes
896    - Set 'slide' as default page transition effect, by JQM patch
897
898 * Fri Jul 13 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.24
899 - Improvements & Bugfixes
900    - Fix IME show/hide algorithm
901    - Fix error on virtualgrid: link _set_scrollbar_size() function to the one in virtuallist
902
903 * Wed Jul 11 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.23
904 - Improvements & Bugfixes
905    - Fix notification position
906    - Fix unit tests
907
908  Fri Jul 6 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.22
909 - Spec changes
910         - JQM 1.1 upgrade
911 - Improvements & Bugfixes
912         - Transform3D support on scrollview
913         - Page layout supports IME control
914         - Mapview supports pinch zoom on JQM 1.1
915         - Fix wrong character on button in minified version
916         - Virtualgrid supports scrollbar
917         - Lots of bugfixes
918
919 * Fri Jun 22 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.20
920 - Spec changes
921         - Support 'latest' version (by symlink) for tizen-web-ui-fw.js path.
922         - imageslider : supports 'resize' event.
923         - listview : listview has 1px padding-bottom.
924         - loader : Change global namespace, from S to $.tizen.
925         - loader : Move loadCustomGlobalizeCulture() into $.tizen.util namespace.
926 - Improvements & Bugfixes
927         - Scrollview : supports 'translate3d', instead of 'translate'.
928         - notification : reset timer when 'show' or 'refresh' event.
929         - JQM patch : Fix vclick event triggered twice.
930 - Etc.
931         - Add & fix unit tests.
932
933 * Thu Jun 14 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.19
934 - Spec changes
935         - mapview : new widget.
936         - notification : add .refresh() API.
937         - pagecontrol : add .value([val]) API, and change an attribute name 'data-initVal' to 'data-value'.
938 - Improvements & Bugfixes
939         - Support minified CSS.
940         - loader : Fix & refactor 'loading globalize culture file' routine.
941         - JQM Patch : Calculate min-height of window in javascript code, and remove predefined min-height value from CSS.
942         - Many more bugfixes.
943 - Etc.
944         - Add many unit tests.
945         - Fix test coverage instrumentation tool to work with current source code.