0.2.5 release
[platform/framework/web/web-ui-fw.git] / packaging / web-ui-fw.spec
1 Name:       web-ui-fw
2 Version:    0.2.5
3 Release:    0
4 Summary:    Tizen Web UI Framework Library
5 Group:      Development/Other
6 License:    MIT
7 BuildArch:  noarch
8 BuildRequires:  make
9 BuildRequires:  nodejs
10 %ifarch %{arm}
11 BuildRequires:  nodejs-x86-arm
12 %endif
13
14 Source0:    %{name}-%{version}.tar.gz
15
16 %description
17 Tizen Web UI Framework library and theme packages
18
19 %prep
20 %setup -q
21
22 %build
23 make all
24
25 %install
26 make DESTDIR=%{buildroot} install
27
28 %post
29
30 %files
31 %manifest web-ui-fw.manifest
32 /usr/share/tizen-web-ui-fw/*/js
33 /usr/share/tizen-web-ui-fw/latest
34 /usr/share/tizen-web-ui-fw/VERSION
35
36 ###############################
37 %package -n web-ui-fw-theme-tizen-gray
38 BuildArch:  noarch
39 Summary:    Tizen Web UI Framework Theme : tizen-gray
40 %Description -n web-ui-fw-theme-tizen-gray
41     Tizen Web UI Framework Theme : tizen-gray
42
43 ###############################
44 %package -n web-ui-fw-theme-tizen-white
45 BuildArch:  noarch
46 Summary:    Tizen Web UI Framework Theme : tizen-white
47 %Description -n web-ui-fw-theme-tizen-white
48     Tizen Web UI Framework Theme : tizen-white
49 %files -n web-ui-fw-theme-tizen-white
50 %manifest web-ui-fw-theme-tizen-white.manifest
51 /usr/share/tizen-web-ui-fw/*/themes/tizen-white
52 /usr/share/tizen-web-ui-fw/*/themes/tizen-tizen
53
54 ###############################
55 %package -n web-ui-fw-theme-default
56 BuildArch:  noarch
57 Summary:    Tizen Web UI Framework Theme : default
58 %Description -n web-ui-fw-theme-default
59     Tizen Web UI Framework Theme : default
60 %files -n web-ui-fw-theme-default
61 %manifest web-ui-fw-theme-default.manifest
62 /usr/share/tizen-web-ui-fw/*/themes/default
63
64 ###############################
65 %package -n web-ui-fw-devel
66 BuildArch:  noarch
67 Summary:    Tizen Web UI Framework Developer's files
68 %Description -n web-ui-fw-devel
69     Tizen Web UI Framework Developer's files
70 %files -n web-ui-fw-devel
71 /usr/share/tizen-web-ui-fw/bin
72 /usr/share/tizen-web-ui-fw/template
73
74 ###############################
75 %package -n web-ui-fw-demo-tizen-winsets
76 BuildArch:  noarch
77 Summary:    Tizen Web UI Framework Demo Application: tizen winset demo
78 %Description -n web-ui-fw-demo-tizen-winsets
79     Tizen Web UI Framework Demo Application: tizen winset demo
80 %files  -n web-ui-fw-demo-tizen-winsets
81 /usr/share/tizen-web-ui-fw/demos/tizen-winsets
82
83
84 ###############################
85 %changelog
86 * Wed Dec 26 2012 Youmin Ha <youmin.ha@samsung.com> 0.2.5
87         - Revert "[checkboxradio] exception handling for input"
88                 This reverts commit 72478c32704fa96362db577e6cf9511777919ea8.
89                 Tizen style supports no-label radio and checkbox when making lists.
90                 So it ignores html input operation. Instead, it supports tizen style radio and checkbox theme.
91
92 * Thu Dec 20 2012 Youmin Ha <youmin.ha@samsung.com> 0.2.4
93 - Fix:
94         - modify segment background
95         - rearrange check, radio input
96         - CtxPopup: Scale up/ down popup vi(poptop, popbottom)
97         - button: style has beed added(box,circle,nobg,round)
98         - favorite resource added
99         - demo/tizen-winsets: add footer and back button
100         - remove autodividers unit test
101         - add divider for tabbar
102         - checkboxradio: exception handling for input
103         - segment control backward compatiblity
104         - Fix collapsible unit-test
105         - remove toggleswitch
106         - add patch for remove segment text
107 - Spec changes:
108         - replace controlbar to tabbar
109
110 * Fri Dec 14 2012 Minkyu Kang <mk7.kang@samsung.com> 0.2.3
111 - FIX:
112         - slider: add image
113         - button: data-icon support, styles fix
114         - progressbar: modify the background
115         - scrollview: auto scrolling bug fix
116         - pagelayout: IME concept is changed
117 - Spec changes:
118         - dialogue: add edit mode
119         - nocontents: removed
120         - pagecontrol: removed
121         - dayselector: removed
122         - expandablelist: removed
123
124 * Thu Dec 10 2012 Youmin Ha <youmin.ha@samsung.com> 0.2.2
125 - FIX:
126         - chang searchbar/slider images
127         - delete redundant button images
128 - Spec changes:
129         - Change widget name: shortcutscroll -> fastscroll
130
131 * Thu Dec 07 2012 Youmin Ha <youmin.ha@samsung.com> 0.2.1
132 - FIX:
133         - jqm1.2: Change collapsible style to meet expandable list
134         - remove jquery-geo-1.0.a4
135         - unit-test: rename from imageslider to gallery
136         - nocontent: add warning message
137         - Handler: Fix issues in jqm1.2
138         - Multimediaview: modify APIs & comments
139         - Mapview: Fix issues in jqm1.2
140         - JQM: clean up patches
141         - Swipelist: refactoring swipelist
142         - Popup,Ctxpopup: Apply tizen style popup in JQM1.2
143         - rearrange button's data-icon resources
144 - Spec changes:
145         - Virtualgrid: remove option ('data-itemcount')
146         - gallery: rename the widget from imageslider to gallery
147         - add new style for searchbar
148         [tokentextarea] multi-button entry renamed as token text area. API & comments modified.
149
150 * Thu Dec 06 2012 Minkyu Kang <mk7.kang@samsung.com> 0.2.0
151 - FIX:
152         - fix jslint error
153         - remove unused files
154         - change naviframe style
155 - Spec changes:
156         - applied jQuery Mobile 1.2.0
157         - remove optionheader
158
159 * Fri Nov 30 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.64
160 - FIX:
161         - fix unit tests
162         - remove unused theme files
163         - timepicker: text position fix
164         - scrollview: set dragstop when mouse is out of window
165         - listview: fix margin
166 - Spec changes:
167         - support data-framework-viewport-width
168
169 * Fri Nov 23 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.63
170 - FIX:
171         - dayselector: fix size
172         - remove unised styles
173         - divider: set non-press effect to default option
174         - popupwindow: fix window closing failure
175         - handler: GUI implementation
176         - TC: fix unit TCs
177         - scrollview: fix padding size
178 - Spec changes:
179         - Remove color widgets
180         - add $.tizen.pkgVersion for SDK
181 - Etc.
182         - JSDuck documents
183
184 * Fri Nov 16 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.62
185 - FIX:
186         - Many winsets: Fix layout
187         - Footer: fix position to bottom
188 - Spec changes:
189         - Remove color widgets
190
191 * Fri Nov 09 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.61
192 - FIX:
193         - Many widgets: New UX 0.6 theme implementation
194         - widgetex: init speed up
195         - scrollview: fix scrollbar and scale animation
196         - scrollview: fix scroll position when updatelayout is triggered
197         - header/footer: make textselection disable, except input type="text"
198
199 * Wed Nov 07 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.60
200 - FIX:
201         - Remove tizen-black theme package description
202
203 * Tue Nov 06 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.59
204 - FIX:
205         - Fix theme name to meet the change of system theme name: white->tizen
206         - Popupwindow: fix left position
207         - Remove black theme
208         - footer: remove label, legend drawing
209 - Spec changes:
210         - UX guide v0.4 : button, layout
211
212 * Wed Oct 24 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.57
213 - FIX:
214         - expandablelist: icon color fix
215         - scrollview: Fix xy scroll
216         - footer: Remove dummy div
217         - Make string concatnation effective in inline-protos.sh
218 - Spec changes:
219         - refresh header/footer when drag&drop event is fired in GUI builder
220         - searchbar: delete cancel button
221         - don't trigger updatelayout event when keyup event comes
222
223 * Mon Oct 15 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.56
224 - FIX:
225         - Toggleswitch: Change event name from 'changed' to 'change'
226         - Notification: Revert interval feature
227
228 * Tue Oct 09 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.55
229 - FIX:
230         - Fix SMACK manifest bug (S1-9098)
231
232 * Fri Oct 05 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.54
233 - FIX:
234         - handler: don't append a handler if handler is not enabled
235         - scrollview: use static value
236         - datetimepicker: fix date-format HH display error
237 - ETC:
238         - provide jquery.min.js
239         - barlayout: codes clean
240         - remove unused file
241
242 * Wed Sep 26 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.53
243 - FIX:
244         - listview: change focused color
245         - multibuttonentry: code refactoring
246         - datetimepicker: modify date format when triggered date-changed event
247         - slider: fix the top of slider bar
248         - add event blocker when load a first page
249
250 * Fri Sep 21 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.52
251 - ETC.
252         - Move SMACK manifest files to the top SRCDIR
253
254 * Fri Sep 21 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.51
255 - FIX:
256         - Popup: Do not focus container
257         - Header: show backbutton when both tabbar and header are present together
258         - Multi button entry: text ellipsis, code refactoring
259
260 * Fri Sep 21 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.50
261 - ETC.
262         - Apply SMACK manifest
263
264 * Thu Sep 20 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.49
265 - FIX:
266         - JSLINT code clean-up
267         - scrollview: firefox support
268         - scrollview: fix finding slider handle
269         - list: tweak text ellipsis
270         - checkbox: fix selecting wrong label tag (N_SE-8370)
271         - imageslider: check parameter
272         - smallpopup: fix position
273         - searchbar: fix 'clear' button size
274 - Spec changes:
275         - scrollview: support outer scroll
276         - JQM: block click event only with the element that does preventdefault on vclick(N_SE-6090)
277         - remove S/W IME control
278
279 * Thu Sep 13 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.48
280 - FIX:
281         - Add missing icon: controlbar
282         - scrollview: tune scrolling animatio ninterval
283         - datetimepicker: digit/triangle position
284         - datetimepicker: fix day overflow issue
285 - Spec changes:
286         - scrollview: show scrollbar when page is showed
287         - scrollview: disable outer scroll
288         - extendablelist: change api with legacy support
289         - add ui-text-ellipsis class
290
291 * Mon Sep 10 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.47
292 - FIX:
293         - scrollveiw: fix height of view
294         - searchbar: support placeholder
295 - Spec changes:
296         - add ui-text-ellipsis class
297
298 * Fri Sep 07 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.46
299 - FIX:
300         - scrollview: scrolling bug fix
301         - controlbar: fix width of controlbar item
302 - Spec changes:
303         - searchbar: don't hide icon
304         - popup: update JQM poup widget
305
306 * Fri Sep 05 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.45
307 - FIX:
308         - controlbar: set correct controlbar width of last element
309         - slider: get popup enable value correctly
310         - use Date.now() instead of (new Data()).getTime()
311         - popupwindow: fix the background color of popup scroller
312         - listview: add padding-left to expandable list
313         - add ellipsis for title area support
314
315 * Fri Aug 31 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.44
316 - FIX:
317         - swipelist: show list items correctly
318         - datetimepicker: set last day, if day is overflowed
319 - Spec changes:
320         - controlbar: update icons
321
322 * Tue Aug 29 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.43
323 - FIX:
324         - notification: fix typo
325 - Spec changes:
326         - controlbar: update icons
327
328 * Tue Aug 28 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.42
329 - FIX:
330         - multimediaview: video progress bar display normally for too samll
331         - segmentcontrol: remove media query
332         - scrollview: add outer scroll condition
333         - datetimepicker: modify triangle size
334         - popupwindow: set the screen height explicitly
335         - notification: add multiline text
336 - Spec changes:
337         - mutibuttonentry: support new GUI
338         - virtualgrid: support new GUI
339
340 * Mon Aug 27 2012 Jinhyuk Jun <jinhyuk.jun@samsung.com> 0.1.41
341 - FIX:
342         - radio/check button : button size bug fix
343
344 * Fri Aug 24 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.40
345 - FIX:
346         - build error fixed
347
348 * Fri Aug 24 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.39
349 - FIX:
350         - listview: style fix, remove filter placeholder
351         - controlbar: divide styles
352         - scrollview: don't skip dragging when click button or inputbox
353         - slider: trim the text on text slider
354 - Spec changes:
355         - remove gray and blue theme
356         - add white and black theme
357         - support new GUI guide
358
359 * Mon Aug 20 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.38
360 - FIX:
361         - fix coment of version tag
362
363 * Fri Aug 17 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.37
364 - FIX :
365         - button: fix alignment
366         - listview: adjust the main text width
367         - virtualgrid: refactoring
368 - Spec changes:
369         - transition: support JQM 1.1.0 transitions
370         - scrollview: support the outer scroll
371         - notification: remove interval feature
372
373 * Tue Aug 14 2012 Youmin Ha <youmin.ha@samasung.com> 0.1.36
374 - FIX :
375         - checkboxRadio: Add left/right padding
376         - button: custom button & icon position
377         - virtuallist: remove 'recreate' test
378 - Spec changes:
379         - header/footer: enable/disable support
380
381 * Fri Aug 10 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.35
382 - FIX :
383         - expandablelist: modify show animation
384         - virtualgrid: Redesign programming interface
385         - popupwindow: code clean and fixed issues
386         - pagelayout: fix content height
387         - license file update
388         - virtuallist: Change programming interface
389         - datetimepicker: getting days correctly
390         - searchbar: set to hidden when cancel button is hide
391         - White theme title font tuning
392 - Spec changes:
393         - default theme tizen-gray to tizen-white
394         - set default page transition to none
395
396 * Mon Aug 02 2012 Jinhyuk Jun <jinhyuk.jun@samsung.com> 0.1.34
397 - FIX :
398         - Back Button : enlarge backbutton click size for white theme
399 - Feature :
400         - Expandable List : Add refresh api
401 * Mon Aug 02 2012 Jinhyuk Jun <jinhyuk.jun@samsung.com> 0.1.33
402 - FIX :
403         - click event touch threshold tuning
404
405 * Mon Aug 02 2012 Jinhyuk Jun <jinhyuk.jun@samsung.com> 0.1.32
406 - FIX : 
407         - Add back button highlight effect for white theme
408
409 * Mon Aug 01 2012 Jinhyuk Jun <jinhyuk.jun@samsnug.com> 0.1.31
410 - FIX : 
411         - IME checkroutine update, improve relayout on resize event
412         - Add highlight effect for radio button list 
413         - Scrollview : fix condition of updatelayout event
414 - Feature : progressing : add show/hide api
415
416 * Mon Jul 27 2012 Koeun Choi <koeun.choi@samsung.com> 0.1.30
417 - FIX : virtuallist, virtualgrid: Clean up temporary jquery.template object to clear cache
418         add default theme option on buttonMarkup for tizen theme
419         [searchbar] first fix : focus/blur fixed
420         back button does not work when long press
421         scrollview: don't auto scrolling if resizing area is too large
422 - Feature : notification : add api to set the icon at tickernoti
423         demo : update the list sample demo
424         Support tizen default theme
425
426 * Mon Jul 23 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.29
427 - Improvements & Bugfixes
428    - HOTFIX: Revert template function with jquery.template
429
430 * Thu Jul 19 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.28
431 - Improvements & Bugfixes
432    - Fix #WEB-1028: memory leak on virtuallist/virtualgrid
433 - Spec changes
434    - $.tizen.loadTheme() function accepts theme name as arguement
435    - Scrollview supports 'updatelayout' callback
436
437 * Tue Jul 17 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.27
438 - Improvements & Bugfixes
439    - Revert 'preventing long-press popup' patch, to fix backbutton to work in SocialMagazine
440
441 * Tue Jul 17 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.26
442 - Improvements & Bugfixes
443    - Add tizen-white theme package, to make rpm build to be finished
444
445 * Tue Jul 17 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.25
446 - Improvements & Bugfixes
447    - Set 'slide' as default page transition effect, by JQM patch
448
449 * Fri Jul 13 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.24
450 - Improvements & Bugfixes
451    - Fix IME show/hide algorithm
452    - Fix error on virtualgrid: link _set_scrollbar_size() function to the one in virtuallist
453
454 * Wed Jul 11 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.23
455 - Improvements & Bugfixes
456    - Fix notification position
457    - Fix unit tests
458
459  Fri Jul 6 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.22
460 - Spec changes
461         - JQM 1.1 upgrade
462 - Improvements & Bugfixes
463         - Transform3D support on scrollview
464         - Page layout supports IME control
465         - Mapview supports pinch zoom on JQM 1.1
466         - Fix wrong character on button in minified version
467         - Virtualgrid supports scrollbar
468         - Lots of bugfixes
469
470 * Fri Jun 22 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.20
471 - Spec changes
472         - Support 'latest' version (by symlink) for tizen-web-ui-fw.js path.
473         - imageslider : supports 'resize' event.
474         - listview : listview has 1px padding-bottom.
475         - loader : Change global namespace, from S to $.tizen.
476         - loader : Move loadCustomGlobalizeCulture() into $.tizen.util namespace.
477 - Improvements & Bugfixes
478         - Scrollview : supports 'translate3d', instead of 'translate'.
479         - notification : reset timer when 'show' or 'refresh' event.
480         - JQM patch : Fix vclick event triggered twice.
481 - Etc.
482         - Add & fix unit tests.
483
484 * Thu Jun 14 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.19
485 - Spec changes
486         - mapview : new widget.
487         - notification : add .refresh() API.
488         - pagecontrol : add .value([val]) API, and change an attribute name 'data-initVal' to 'data-value'.
489 - Improvements & Bugfixes
490         - Support minified CSS.
491         - loader : Fix & refactor 'loading globalize culture file' routine.
492         - JQM Patch : Calculate min-height of window in javascript code, and remove predefined min-height value from CSS.
493         - Many more bugfixes.
494 - Etc.
495         - Add many unit tests.
496         - Fix test coverage instrumentation tool to work with current source code.