0.2.18 release
[platform/framework/web/web-ui-fw.git] / packaging / web-ui-fw.spec
1 Name:       web-ui-fw
2 Version:    0.2.18
3 Release:    0
4 Summary:    Tizen Web UI Framework Library
5 Group:      Development/Other
6 License:    MIT
7 BuildArch:  noarch
8 BuildRequires:  make
9 BuildRequires:  nodejs
10 %ifarch %{arm}
11 BuildRequires:  nodejs-x86-arm
12 %endif
13
14 Source0:    %{name}-%{version}.tar.gz
15
16 %description
17 Tizen Web UI Framework library and theme packages
18
19 %prep
20 %setup -q
21
22 %build
23 make all
24
25 %install
26 make DESTDIR=%{buildroot} install
27
28 %post
29
30 %files
31 %manifest web-ui-fw.manifest
32 /usr/share/tizen-web-ui-fw/*/js
33 /usr/share/tizen-web-ui-fw/latest
34 /usr/share/tizen-web-ui-fw/VERSION
35
36 ###############################
37 %package -n web-ui-fw-theme-tizen-gray
38 BuildArch:  noarch
39 Summary:    Tizen Web UI Framework Theme : tizen-gray
40 %Description -n web-ui-fw-theme-tizen-gray
41     Tizen Web UI Framework Theme : tizen-gray
42
43 ###############################
44 %package -n web-ui-fw-theme-tizen-white
45 BuildArch:  noarch
46 Summary:    Tizen Web UI Framework Theme : tizen-white
47 %Description -n web-ui-fw-theme-tizen-white
48     Tizen Web UI Framework Theme : tizen-white
49 %files -n web-ui-fw-theme-tizen-white
50 %manifest web-ui-fw-theme-tizen-white.manifest
51 /usr/share/tizen-web-ui-fw/*/themes/tizen-white
52 /usr/share/tizen-web-ui-fw/*/themes/tizen-tizen
53
54 ###############################
55 %package -n web-ui-fw-theme-default
56 BuildArch:  noarch
57 Summary:    Tizen Web UI Framework Theme : default
58 %Description -n web-ui-fw-theme-default
59     Tizen Web UI Framework Theme : default
60 %files -n web-ui-fw-theme-default
61 %manifest web-ui-fw-theme-default.manifest
62 /usr/share/tizen-web-ui-fw/*/themes/default
63
64 ###############################
65 %package -n web-ui-fw-devel
66 BuildArch:  noarch
67 Summary:    Tizen Web UI Framework Developer's files
68 %Description -n web-ui-fw-devel
69     Tizen Web UI Framework Developer's files
70 %files -n web-ui-fw-devel
71 /usr/share/tizen-web-ui-fw/bin
72 /usr/share/tizen-web-ui-fw/template
73
74 ###############################
75 %package -n web-ui-fw-demo-tizen-winsets
76 BuildArch:  noarch
77 Summary:    Tizen Web UI Framework Demo Application: tizen winset demo
78 %Description -n web-ui-fw-demo-tizen-winsets
79     Tizen Web UI Framework Demo Application: tizen winset demo
80 %files  -n web-ui-fw-demo-tizen-winsets
81 /usr/share/tizen-web-ui-fw/demos/tizen-winsets
82
83
84 ###############################
85 %changelog
86
87 * Thu Mar 7 2013 Youmin Ha <youmin.ha@samsung.com> 0.2.18
88         - build: Fix Makefile to add globalize to the minified lib
89         - build-tools : upgrade less to v1.3.3
90         - demos : change normal js path to minified js
91         - Theme : remove reduantant less - dayselector, optionheader, nocontents
92         - multimediaview : fix full-screen mode.
93         - multimediaview : fix 'width', 'height' and 'fullScreen' methods
94         - Extendablelist: Added min-height "load more button" in listitem
95         - virtualgrid: adjusts VI effect for an overflow action
96         - ControlGroup : change ellipsis font color (press/normal)
97         - multimediaview: Add an error message to Multimediaview
98         - virtualgrid: adjusts triple flick gesture
99         - scrollview: add function for getting width of view
100         - scrollview: adds support x axis gesture scroll
101         - multimediaview : fix audio control
102         - tabbar : tabbar slide animation change
103         - TizenWinsetDemo : 2line-text demo bug fix
104         - collapsible: Fix demo to show radio button correctly in the collapsible list
105         - collapsible: Set listitem position to relative
106         - UnitTC: added list divider unit test
107         - Style: unnecessary color codes have been deleted and modified
108         - build: Module build implementation
109         - UnitTC: Additional unit testcases have been added
110         - listview : bug fix
111         - Naviframe : remove back button's hover effect
112         - TizenDemo : remove back button
113         - Transition: added more-button vi
114         - pinch: added new event called pinch
115         - Popup: css word-wrap:break-word has been added
116         - virtualgrid: memory leak fix
117         - progress: set to init state at pending bar
118         - progress: add margin of top/bottom
119         - unit-test: split progress test and progressbar test
120         - Tizen-winset: Context popup sample page guide text has been changed
121         - multimediaview: fix the height of widget when full-screen mode
122         - JQM: performance tuning
123
124 * Tue Feb 19 2013 Minkyu Kang <mk7.kang@samsung.com> 0.2.17
125         - DialogueList : delete border top value / add sample's text ellipsis
126         - Tokentextarea: Add scroll-to-top for Grouping On/Off regarding #N_SE-24877
127         - Multimediaview: Fix mute function
128         - Tizen-winset: list vi index guide textbox has been removed
129         - Tizen-winset: custom button texts have been changed
130         - slider: move popup div to out of content
131         - TizenWinset: disable context popup in multimediaview
132         - Swipe: wrong style name has been fixed
133         - demo: add the sample at dialogue list
134         - listview: Add ui-li-has-right-btn class with toggleswitch
135         - WinsetDemo : change wrong title name
136
137 * Mon Jan 28 2013 Youmin Ha <youmin.ha@samsung.com> 0.2.16
138         - demo: checkbox: reduce button's width
139         - tabbar : delete right/left tab animation color
140         - scrollview: fix the scroll position at keydown event
141         - groupControl : change footer groupControl from min-width to percentage
142         - scrollview: get height of softkeyboard correctly
143         - tizen-winset: Add name attr to all radio inputs
144         - virtualgrid: changes event binding target
145         - scrollview: skip the drag if target is textarea
146         - scrollview: skip the dragging of parent scrollview
147         - scrollview: apply the scaling ratio to the soft keyboard
148         - demos: apply disabled option in textarea
149         - demo: remove unused codes
150         - demo: datetimepicker: show selected date correctly
151         - listview: Adjust bubble listitem width and margin
152         - pagelayout : change external refresh call and ime status follow only current page
153         - toggleSwitch : bug fix
154         - unit-test: slider: fix the move test
155         - handler: fix jslint error
156         - ToggleSwitch : set image toggleswitch background attribute
157
158 * Mon Jan 28 2013 Youmin Ha <youmin.ha@samsung.com> 0.2.15
159         - slider: increase the text width(N_SE-23397)
160         - virtualgrid: DOM element leak fix
161         - header: Move button top higher in header with tabbar(N_SE-22253)
162         - datatimepicker: don't open the popup before popupafterclose event is fired(N_SE-23027)
163         - handler: bug fix (regarding enableHandler function )
164         - demo:fix syntax error
165
166 * Sat Jan 26 2013 Youmin Ha <youmin.ha@samsung.com> 0.2.14
167         - demo: fix demo using tizen device API
168         - multimediaview: reset the height of container
169         - input: modify css correctly
170         - multimediaview: fix the height of widget
171         - gallery: bind create event
172         - progress: bind create event
173         - slider: bind create event
174         - progressbar: bind create event
175         - progressbar: event trigger correctly
176         - popup: fix height of popup scroller
177         - build: add continue option to jslint
178         - ctxpopup demo : bug fix
179         - demo: fix searchbar demo to use different IDs
180         - demo: extract routine executing Tizen device API
181         - toggleswitch : set default margin, delete box padding
182
183 * Thu Jan 24 2013 Youmin Ha <youmin.ha@samsung.com> 0.2.13
184         - virtuallist: Prevent replacing contents on nonexist element
185         - JQM: Trim text in listitem to get index in autodivider
186         - JQM: Remove trailing whitespace in jqm patch
187         - scrollview: get the height including margin
188         - multimediaview: bug fix ( scrolling in full-screen mode )
189         - virtuallist: set listitem width to exclude listitem left/right margin
190         - demo: fix virtuallist sample layout
191         - progress: set the position explicitly
192         - progress: rename from progressing to progress
193         - build: remove unused files
194         - searchbar: fix jslint errors
195         - src: fix file permissions
196         - button : change jump left icon
197
198 * Wed Jan 23 2013 Minkyu Kang <mk7.kang@samsung.com> 0.2.12
199         - theme : button icon - scrolltop, scrolleft icon changed.
200         - build: cleanaup Makefile
201         - pagelayout: fix jslint error
202         - virtualgrid: Fix jslint errors
203         - tabbar : jslint bug error fix
204         - build: add regexp option to jslint
205         - virtuallist: fix jslint errors
206         - handler: Apply the exceptional principle for scrollbar on Handler.
207         - build: remove unused copyright
208         - loader: extract log class for tizen web, and fix jslint errors
209         - loader: Viewport width is set to document width
210         - popupwindow: fix jslint error
211         - build: fix Makefile for tizen-white theme
212         - build: remove unused libraries
213         - datetimepicker: fix jslint error
214         - slider: fix jslint error
215         - demo: remove deprecated demos
216         - pagelayout : change to call relayout with this page
217         - Tokentextarea: Block size error fixed.
218         - handler: bug fix (handler activation)
219
220 * Tue Jan 22 2013 Minkyu Kang <mk7.kang@samsung.com> 0.2.11
221         - demo: clear input text value with cancel button click
222         - demo: Adjust textarea height automatically
223         - naviframe : bug fix
224         - tabbar : bug fix
225         - Fastscroll: popup position has been changed
226         - Button: custom button icon path, margin have been changed
227         - toggleswitch : bug fix
228         - slider: increase the margin
229         - datetimepicker: close the popup after select the value
230         - unit-test : add page backbutton control test
231         - Demo: added guide text and change input type in list vi
232         - remove legacy codes : jquery-geo
233         - Datetimepicker: text-main max-width has been removed
234         - Radio: control group border has been removed
235         - Demo: remove 'tab' space
236         - UnitTC: swipe unit tc has been fixed
237         - UnitTC: jQuery path has been fixed
238         - Button: bug fix when button has not a text
239         - tizen-winset: timepicker: demo title is changed
240
241 * Fri Jan 18 2013 Minkyu Kang <mk7.kang@samsung.com> 0.2.10
242         - tizen-winsets: codes cleanup
243         - datetimepicker: date calibration when year is changed
244         - Demo: textarea size has been changed
245         - Demo: Naviframe morebutton demo has been changed
246         - remove unused unit test cases : gallery3d
247         - tizen-winset: remove links
248
249 * Thu Jan 17 2013 Minkyu Kang <mk7.kang@samsung.com> 0.2.9
250         - gallery: use timeout function instead of interval
251         - Tokentextarea: Display error fixed.
252         - scrollview: Fix not selector to respond with jQuery1.8.2
253         - tabbar: remove the width of last element
254         - Demo: apply css 'user-select:none'
255         - Button: guide text has been shorten
256         - build: Update jQuery to 1.8.2 (JQM1.2 compliant)
257         - virtuallist: Fix mistyping
258         - demo: Fix tizen function namespace in demo
259         - virtuallist: Rewrite listitem replacing algorithm
260         - fastscroll: modify from not selector to function
261         - extendablelist: Fix unit-test
262         - tabbar : prefix to tabbar scroll event
263         - Popupwindow: removed unvalid selector in jquery 1.8.2
264         - slider: adjust handle text as length of value
265         - Demo: 3 buttons in popup text has been changed
266         - src: codes cleanup
267         - demo : remove trailing empty strings
268         - demo : rename TizenWinset list items
269         - button : change from long text list to multiline list
270         - build: Remove JQM1.1.0 patches
271         - Popup: Apply tizen style popup and attribute support
272         - JQM: Fix buttonmarkup bug keeping ui-btn-down class
273         - UnitTest: folder and file renamed, QUnit path was modified
274         - tizen-winsets: button: fix textarea width
275         - Swipe: event name error has been fixed
276
277 * Tue Jan 15 2013 Minkyu Kang <mk7.kang@samsung.com> 0.2.8
278         - Button: button padding has been updated
279         - virtuallist: fix unique listitem ID bug
280         - checkbox, radio : change display attr
281         - Button: bug fix ( when data style circle button on text )
282         - handler: bug fix (when scrolling with multi selection)
283         - JQM: adjust patch number
284         - gallery: show the widget after pageshow
285         - TokenTextArea : resource add ( press image )
286         - gallery: adds function that set the index to value API
287         - configure: set TIZEN default configures
288         - footer: h tag display attribute value has been changed
289         - buttons : demo bug fix
290         - searchbar : demo page bug fix
291         - tizen demo : bug fix
292         - build: remove JQM1.1.0
293         - Tokentextarea: Fix issues
294         - scrollview: block the multi touch
295         - list : dialogue list demo change
296         - pagelayout : update dynamic control
297         - Demo: Context popup close method has been changed
298
299 * Fri Jan 11 2013 Minkyu Kang <mk7.kang@samsung.com> 0.2.7
300         - slider: set text container's width as text length
301         - Timepicker: li max-width has been changed
302         - remove experimental feature - mapview.
303         - scrollview: added conditions for finding slider
304         - UnitTC: Pass,error count save method has been changed
305         - confix.xml: default config added for tizen basic applications
306         - Swipe: p tag margin value is set '0'
307         - packaging: remove unused file
308         - tabbar : bug fix
309         - list demo : bug fix
310         - tizen-winsets: gallery: move to new section
311         - tizen-winsets: autodivider: removes link of list
312         - demos: entry of number-pattern name is changed from 'number' to 'number-pattern'
313         - pagelayout : padding calculate change, ime footer check changed
314         - tizen-winsets: searchbar: scroll to the top when type the character
315         - searchbar : bug fix
316         - demo: Fix virtuallist demo following new list style
317         - demo: Add word-wrap:break-word and remove parag. width
318         - Demo: button max-width has been set( 3 buttons in popup )
319         - back button control demo : bug fix
320         - toggleswitch : demo page modify
321         - slider: add margin-top and margin-bottom
322         - tabbar demo : bug fix
323         - Popup: IME hide when popup is closed
324         - token textarea : bug fix
325         - Timepicker: change get attribute method
326         - footer demo : bug fix
327         - unit-test: gallery: add new APIs
328         - gallery: adds support new APIs
329
330 * Fri Jan 04 2013 Minkyu Kang <mk7.kang@samsung.com> 0.2.6
331         - JQM: patches cleanup
332         - Button: data-corners attribute has been added
333         - unit-test: slider: fix class name of background
334         - progressbar, slider: fix less variable typo
335         - Tabbar : VI update
336         - notification: add top position at fix class
337         - demo: entry demo page change
338         - css: .ui-disabled added
339         - tizen-winset: token textarea: remove back button at demo page
340         - theme: Remove unused less file
341         - pagelayout : content min height bug fix
342         - scrollview: skip the dragging when target is slider's handle
343         - scrollview: update and refactoring the scroll effect
344         - UnitTest:JQM Unit TC helper has been added,TCs have been modified
345         - Swipe: demo page html error has been fixed
346         - listview: Add add/delete animation (VI)
347         - Popup: demo page has been modified
348         - tizen demo : bug fix
349         - searchbar : demo page change(change front button and add behaviour)
350         - pagelayout : add min height to content
351         - gallery: rename 'Image Slider' to 'Gallery' in tizen-winsets demo and tests
352         - back button control demo : change url link to data-rel="back"
353         - loader: Skip loading theme CSS with a custom css code
354         - Button: support no-text in button
355         - collapsible: Fix syntax error
356         - slider: use data-highlight attribute
357         - collapsible: Rotate animation to collapsible heading icon
358         - toggleswitch : text switch bug fix
359         - remove candidates-calendarpicker
360         - Patch: Fix misc mistakes in JQM patches
361         - searchbar : animation change
362         - gallery: get the width correctly
363         - demo: data-framework-viewport-scale attribute is changed to data-framework-viewport-width
364         - collapsible: Add collapse/expand animation (VI)
365         - datetimepicker: VI update
366         - JQM: set transition to pop as default
367         - tabbar : bug fix in case none li element case
368         - scrollview: fix the drag bug
369         - Button: Button icon scrolltop, left has beed added
370         - Swipe: VI update and swipe speed has been changed
371         - jqm: fix errors in patch files
372         - unit-test: swipe: fixed the destroy test
373
374 * Wed Dec 26 2012 Youmin Ha <youmin.ha@samsung.com> 0.2.5
375         - Revert "[checkboxradio] exception handling for input"
376                 This reverts commit 72478c32704fa96362db577e6cf9511777919ea8.
377                 Tizen style supports no-label radio and checkbox when making lists.
378                 So it ignores html input operation. Instead, it supports tizen style radio and checkbox theme.
379
380 * Thu Dec 20 2012 Youmin Ha <youmin.ha@samsung.com> 0.2.4
381 - Fix:
382         - modify segment background
383         - rearrange check, radio input
384         - CtxPopup: Scale up/ down popup vi(poptop, popbottom)
385         - button: style has beed added(box,circle,nobg,round)
386         - favorite resource added
387         - demo/tizen-winsets: add footer and back button
388         - remove autodividers unit test
389         - add divider for tabbar
390         - checkboxradio: exception handling for input
391         - segment control backward compatiblity
392         - Fix collapsible unit-test
393         - remove toggleswitch
394         - add patch for remove segment text
395 - Spec changes:
396         - replace controlbar to tabbar
397
398 * Fri Dec 14 2012 Minkyu Kang <mk7.kang@samsung.com> 0.2.3
399 - FIX:
400         - slider: add image
401         - button: data-icon support, styles fix
402         - progressbar: modify the background
403         - scrollview: auto scrolling bug fix
404         - pagelayout: IME concept is changed
405 - Spec changes:
406         - dialogue: add edit mode
407         - nocontents: removed
408         - pagecontrol: removed
409         - dayselector: removed
410         - expandablelist: removed
411
412 * Thu Dec 10 2012 Youmin Ha <youmin.ha@samsung.com> 0.2.2
413 - FIX:
414         - chang searchbar/slider images
415         - delete redundant button images
416 - Spec changes:
417         - Change widget name: shortcutscroll -> fastscroll
418
419 * Thu Dec 07 2012 Youmin Ha <youmin.ha@samsung.com> 0.2.1
420 - FIX:
421         - jqm1.2: Change collapsible style to meet expandable list
422         - remove jquery-geo-1.0.a4
423         - unit-test: rename from imageslider to gallery
424         - nocontent: add warning message
425         - Handler: Fix issues in jqm1.2
426         - Multimediaview: modify APIs & comments
427         - Mapview: Fix issues in jqm1.2
428         - JQM: clean up patches
429         - Swipelist: refactoring swipelist
430         - Popup,Ctxpopup: Apply tizen style popup in JQM1.2
431         - rearrange button's data-icon resources
432 - Spec changes:
433         - Virtualgrid: remove option ('data-itemcount')
434         - gallery: rename the widget from imageslider to gallery
435         - add new style for searchbar
436         [tokentextarea] multi-button entry renamed as token text area. API & comments modified.
437
438 * Thu Dec 06 2012 Minkyu Kang <mk7.kang@samsung.com> 0.2.0
439 - FIX:
440         - fix jslint error
441         - remove unused files
442         - change naviframe style
443 - Spec changes:
444         - applied jQuery Mobile 1.2.0
445         - remove optionheader
446
447 * Fri Nov 30 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.64
448 - FIX:
449         - fix unit tests
450         - remove unused theme files
451         - timepicker: text position fix
452         - scrollview: set dragstop when mouse is out of window
453         - listview: fix margin
454 - Spec changes:
455         - support data-framework-viewport-width
456
457 * Fri Nov 23 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.63
458 - FIX:
459         - dayselector: fix size
460         - remove unised styles
461         - divider: set non-press effect to default option
462         - popupwindow: fix window closing failure
463         - handler: GUI implementation
464         - TC: fix unit TCs
465         - scrollview: fix padding size
466 - Spec changes:
467         - Remove color widgets
468         - add $.tizen.pkgVersion for SDK
469 - Etc.
470         - JSDuck documents
471
472 * Fri Nov 16 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.62
473 - FIX:
474         - Many winsets: Fix layout
475         - Footer: fix position to bottom
476 - Spec changes:
477         - Remove color widgets
478
479 * Fri Nov 09 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.61
480 - FIX:
481         - Many widgets: New UX 0.6 theme implementation
482         - widgetex: init speed up
483         - scrollview: fix scrollbar and scale animation
484         - scrollview: fix scroll position when updatelayout is triggered
485         - header/footer: make textselection disable, except input type="text"
486
487 * Wed Nov 07 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.60
488 - FIX:
489         - Remove tizen-black theme package description
490
491 * Tue Nov 06 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.59
492 - FIX:
493         - Fix theme name to meet the change of system theme name: white->tizen
494         - Popupwindow: fix left position
495         - Remove black theme
496         - footer: remove label, legend drawing
497 - Spec changes:
498         - UX guide v0.4 : button, layout
499
500 * Wed Oct 24 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.57
501 - FIX:
502         - expandablelist: icon color fix
503         - scrollview: Fix xy scroll
504         - footer: Remove dummy div
505         - Make string concatnation effective in inline-protos.sh
506 - Spec changes:
507         - refresh header/footer when drag&drop event is fired in GUI builder
508         - searchbar: delete cancel button
509         - don't trigger updatelayout event when keyup event comes
510
511 * Mon Oct 15 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.56
512 - FIX:
513         - Toggleswitch: Change event name from 'changed' to 'change'
514         - Notification: Revert interval feature
515
516 * Tue Oct 09 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.55
517 - FIX:
518         - Fix SMACK manifest bug (S1-9098)
519
520 * Fri Oct 05 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.54
521 - FIX:
522         - handler: don't append a handler if handler is not enabled
523         - scrollview: use static value
524         - datetimepicker: fix date-format HH display error
525 - ETC:
526         - provide jquery.min.js
527         - barlayout: codes clean
528         - remove unused file
529
530 * Wed Sep 26 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.53
531 - FIX:
532         - listview: change focused color
533         - multibuttonentry: code refactoring
534         - datetimepicker: modify date format when triggered date-changed event
535         - slider: fix the top of slider bar
536         - add event blocker when load a first page
537
538 * Fri Sep 21 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.52
539 - ETC.
540         - Move SMACK manifest files to the top SRCDIR
541
542 * Fri Sep 21 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.51
543 - FIX:
544         - Popup: Do not focus container
545         - Header: show backbutton when both tabbar and header are present together
546         - Multi button entry: text ellipsis, code refactoring
547
548 * Fri Sep 21 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.50
549 - ETC.
550         - Apply SMACK manifest
551
552 * Thu Sep 20 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.49
553 - FIX:
554         - JSLINT code clean-up
555         - scrollview: firefox support
556         - scrollview: fix finding slider handle
557         - list: tweak text ellipsis
558         - checkbox: fix selecting wrong label tag (N_SE-8370)
559         - imageslider: check parameter
560         - smallpopup: fix position
561         - searchbar: fix 'clear' button size
562 - Spec changes:
563         - scrollview: support outer scroll
564         - JQM: block click event only with the element that does preventdefault on vclick(N_SE-6090)
565         - remove S/W IME control
566
567 * Thu Sep 13 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.48
568 - FIX:
569         - Add missing icon: controlbar
570         - scrollview: tune scrolling animatio ninterval
571         - datetimepicker: digit/triangle position
572         - datetimepicker: fix day overflow issue
573 - Spec changes:
574         - scrollview: show scrollbar when page is showed
575         - scrollview: disable outer scroll
576         - extendablelist: change api with legacy support
577         - add ui-text-ellipsis class
578
579 * Mon Sep 10 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.47
580 - FIX:
581         - scrollveiw: fix height of view
582         - searchbar: support placeholder
583 - Spec changes:
584         - add ui-text-ellipsis class
585
586 * Fri Sep 07 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.46
587 - FIX:
588         - scrollview: scrolling bug fix
589         - controlbar: fix width of controlbar item
590 - Spec changes:
591         - searchbar: don't hide icon
592         - popup: update JQM poup widget
593
594 * Fri Sep 05 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.45
595 - FIX:
596         - controlbar: set correct controlbar width of last element
597         - slider: get popup enable value correctly
598         - use Date.now() instead of (new Data()).getTime()
599         - popupwindow: fix the background color of popup scroller
600         - listview: add padding-left to expandable list
601         - add ellipsis for title area support
602
603 * Fri Aug 31 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.44
604 - FIX:
605         - swipelist: show list items correctly
606         - datetimepicker: set last day, if day is overflowed
607 - Spec changes:
608         - controlbar: update icons
609
610 * Tue Aug 29 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.43
611 - FIX:
612         - notification: fix typo
613 - Spec changes:
614         - controlbar: update icons
615
616 * Tue Aug 28 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.42
617 - FIX:
618         - multimediaview: video progress bar display normally for too samll
619         - segmentcontrol: remove media query
620         - scrollview: add outer scroll condition
621         - datetimepicker: modify triangle size
622         - popupwindow: set the screen height explicitly
623         - notification: add multiline text
624 - Spec changes:
625         - mutibuttonentry: support new GUI
626         - virtualgrid: support new GUI
627
628 * Mon Aug 27 2012 Jinhyuk Jun <jinhyuk.jun@samsung.com> 0.1.41
629 - FIX:
630         - radio/check button : button size bug fix
631
632 * Fri Aug 24 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.40
633 - FIX:
634         - build error fixed
635
636 * Fri Aug 24 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.39
637 - FIX:
638         - listview: style fix, remove filter placeholder
639         - controlbar: divide styles
640         - scrollview: don't skip dragging when click button or inputbox
641         - slider: trim the text on text slider
642 - Spec changes:
643         - remove gray and blue theme
644         - add white and black theme
645         - support new GUI guide
646
647 * Mon Aug 20 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.38
648 - FIX:
649         - fix coment of version tag
650
651 * Fri Aug 17 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.37
652 - FIX :
653         - button: fix alignment
654         - listview: adjust the main text width
655         - virtualgrid: refactoring
656 - Spec changes:
657         - transition: support JQM 1.1.0 transitions
658         - scrollview: support the outer scroll
659         - notification: remove interval feature
660
661 * Tue Aug 14 2012 Youmin Ha <youmin.ha@samasung.com> 0.1.36
662 - FIX :
663         - checkboxRadio: Add left/right padding
664         - button: custom button & icon position
665         - virtuallist: remove 'recreate' test
666 - Spec changes:
667         - header/footer: enable/disable support
668
669 * Fri Aug 10 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.35
670 - FIX :
671         - expandablelist: modify show animation
672         - virtualgrid: Redesign programming interface
673         - popupwindow: code clean and fixed issues
674         - pagelayout: fix content height
675         - license file update
676         - virtuallist: Change programming interface
677         - datetimepicker: getting days correctly
678         - searchbar: set to hidden when cancel button is hide
679         - White theme title font tuning
680 - Spec changes:
681         - default theme tizen-gray to tizen-white
682         - set default page transition to none
683
684 * Mon Aug 02 2012 Jinhyuk Jun <jinhyuk.jun@samsung.com> 0.1.34
685 - FIX :
686         - Back Button : enlarge backbutton click size for white theme
687 - Feature :
688         - Expandable List : Add refresh api
689 * Mon Aug 02 2012 Jinhyuk Jun <jinhyuk.jun@samsung.com> 0.1.33
690 - FIX :
691         - click event touch threshold tuning
692
693 * Mon Aug 02 2012 Jinhyuk Jun <jinhyuk.jun@samsung.com> 0.1.32
694 - FIX : 
695         - Add back button highlight effect for white theme
696
697 * Mon Aug 01 2012 Jinhyuk Jun <jinhyuk.jun@samsnug.com> 0.1.31
698 - FIX : 
699         - IME checkroutine update, improve relayout on resize event
700         - Add highlight effect for radio button list 
701         - Scrollview : fix condition of updatelayout event
702 - Feature : progressing : add show/hide api
703
704 * Mon Jul 27 2012 Koeun Choi <koeun.choi@samsung.com> 0.1.30
705 - FIX : virtuallist, virtualgrid: Clean up temporary jquery.template object to clear cache
706         add default theme option on buttonMarkup for tizen theme
707         [searchbar] first fix : focus/blur fixed
708         back button does not work when long press
709         scrollview: don't auto scrolling if resizing area is too large
710 - Feature : notification : add api to set the icon at tickernoti
711         demo : update the list sample demo
712         Support tizen default theme
713
714 * Mon Jul 23 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.29
715 - Improvements & Bugfixes
716    - HOTFIX: Revert template function with jquery.template
717
718 * Thu Jul 19 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.28
719 - Improvements & Bugfixes
720    - Fix #WEB-1028: memory leak on virtuallist/virtualgrid
721 - Spec changes
722    - $.tizen.loadTheme() function accepts theme name as arguement
723    - Scrollview supports 'updatelayout' callback
724
725 * Tue Jul 17 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.27
726 - Improvements & Bugfixes
727    - Revert 'preventing long-press popup' patch, to fix backbutton to work in SocialMagazine
728
729 * Tue Jul 17 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.26
730 - Improvements & Bugfixes
731    - Add tizen-white theme package, to make rpm build to be finished
732
733 * Tue Jul 17 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.25
734 - Improvements & Bugfixes
735    - Set 'slide' as default page transition effect, by JQM patch
736
737 * Fri Jul 13 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.24
738 - Improvements & Bugfixes
739    - Fix IME show/hide algorithm
740    - Fix error on virtualgrid: link _set_scrollbar_size() function to the one in virtuallist
741
742 * Wed Jul 11 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.23
743 - Improvements & Bugfixes
744    - Fix notification position
745    - Fix unit tests
746
747  Fri Jul 6 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.22
748 - Spec changes
749         - JQM 1.1 upgrade
750 - Improvements & Bugfixes
751         - Transform3D support on scrollview
752         - Page layout supports IME control
753         - Mapview supports pinch zoom on JQM 1.1
754         - Fix wrong character on button in minified version
755         - Virtualgrid supports scrollbar
756         - Lots of bugfixes
757
758 * Fri Jun 22 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.20
759 - Spec changes
760         - Support 'latest' version (by symlink) for tizen-web-ui-fw.js path.
761         - imageslider : supports 'resize' event.
762         - listview : listview has 1px padding-bottom.
763         - loader : Change global namespace, from S to $.tizen.
764         - loader : Move loadCustomGlobalizeCulture() into $.tizen.util namespace.
765 - Improvements & Bugfixes
766         - Scrollview : supports 'translate3d', instead of 'translate'.
767         - notification : reset timer when 'show' or 'refresh' event.
768         - JQM patch : Fix vclick event triggered twice.
769 - Etc.
770         - Add & fix unit tests.
771
772 * Thu Jun 14 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.19
773 - Spec changes
774         - mapview : new widget.
775         - notification : add .refresh() API.
776         - pagecontrol : add .value([val]) API, and change an attribute name 'data-initVal' to 'data-value'.
777 - Improvements & Bugfixes
778         - Support minified CSS.
779         - loader : Fix & refactor 'loading globalize culture file' routine.
780         - JQM Patch : Calculate min-height of window in javascript code, and remove predefined min-height value from CSS.
781         - Many more bugfixes.
782 - Etc.
783         - Add many unit tests.
784         - Fix test coverage instrumentation tool to work with current source code.