0.2.29 release
[platform/framework/web/web-ui-fw.git] / packaging / web-ui-fw.spec
1 Name:       web-ui-fw
2 Version:    0.2.29
3 Release:    0
4 Summary:    Tizen Web UI Framework Library
5 Group:      Development/Other
6 License:    MIT
7 BuildArch:  noarch
8 BuildRequires:  make
9 BuildRequires:  nodejs
10 %ifarch %{arm}
11 BuildRequires:  nodejs-x86-arm
12 %endif
13
14 Source0:    %{name}-%{version}.tar.gz
15
16 %description
17 Tizen Web UI Framework library and theme packages
18
19 %prep
20 %setup -q
21
22 %build
23 make all
24
25 %install
26 make DESTDIR=%{buildroot} install
27
28 %post
29
30 %files
31 %manifest web-ui-fw.manifest
32 /usr/share/tizen-web-ui-fw/*/js/*.js
33 /usr/share/tizen-web-ui-fw/*/js/cultures
34 /usr/share/tizen-web-ui-fw/latest
35 /usr/share/tizen-web-ui-fw/VERSION
36
37 ###############################
38 %package -n web-ui-fw-theme-tizen-gray
39 BuildArch:  noarch
40 Summary:    Tizen Web UI Framework Theme : tizen-gray
41 %Description -n web-ui-fw-theme-tizen-gray
42     Tizen Web UI Framework Theme : tizen-gray
43     Deprecated package, but some binaries still refer this.
44
45 ###############################
46 %package -n web-ui-fw-theme-tizen-white
47 BuildArch:  noarch
48 Summary:    Tizen Web UI Framework Theme : tizen-white
49 %Description -n web-ui-fw-theme-tizen-white
50     Tizen Web UI Framework Theme : tizen-white
51 %files -n web-ui-fw-theme-tizen-white
52 %manifest web-ui-fw-theme-tizen-white.manifest
53 /usr/share/tizen-web-ui-fw/*/themes/tizen-white
54 /usr/share/tizen-web-ui-fw/*/themes/tizen-tizen
55
56 ###############################
57 %package -n web-ui-fw-theme-tizen-black
58 BuildArch:  noarch
59 Summary:    Tizen Web UI Framework Theme : tizen-black
60 %Description -n web-ui-fw-theme-tizen-black
61     Tizen Web UI Framework Theme : tizen-black
62 %files -n web-ui-fw-theme-tizen-black
63 %manifest web-ui-fw-theme-tizen-black.manifest
64 /usr/share/tizen-web-ui-fw/*/themes/tizen-black
65
66 ###############################
67 %package -n web-ui-fw-theme-default
68 BuildArch:  noarch
69 Summary:    Tizen Web UI Framework Theme : default
70 %Description -n web-ui-fw-theme-default
71     Tizen Web UI Framework Theme : default
72 %files -n web-ui-fw-theme-default
73 %manifest web-ui-fw-theme-default.manifest
74 /usr/share/tizen-web-ui-fw/*/themes/default
75
76 ###############################
77 %package -n web-ui-fw-devel
78 BuildArch:  noarch
79 Summary:    Tizen Web UI Framework Developer's files
80 %Description -n web-ui-fw-devel
81     Tizen Web UI Framework Developer's files
82 %files -n web-ui-fw-devel
83 /usr/share/tizen-web-ui-fw/bin
84 /usr/share/tizen-web-ui-fw/template
85 /usr/share/tizen-web-ui-fw/*/js/src
86 /usr/share/tizen-web-ui-fw/*/js/depData.json
87
88 ###############################
89 %package -n web-ui-fw-demo-tizen-winsets
90 BuildArch:  noarch
91 Summary:    Tizen Web UI Framework Demo Application: tizen winset demo
92 %Description -n web-ui-fw-demo-tizen-winsets
93     Tizen Web UI Framework Demo Application: tizen winset demo
94 %files  -n web-ui-fw-demo-tizen-winsets
95 /usr/share/tizen-web-ui-fw/demos/tizen-winsets
96
97
98 ###############################
99 %changelog
100 * Fri May 10 2013 Hyunjung Kim <hjnim.kim@samsung.com> 0.2.29
101         - loader: change a warn msg to debug msg
102         - Radio: Radio issue has been fixed ( N_SE-38015 )
103         - Add gallery3D source to the flora license list
104         - Slider: JQM patch fixed ( event.target match )
105         - Tizen-winset: remove unnecessary file
106
107 * Tue May 07 2013 Hyunjung kim <hjnim.kim@samsung.com> 0.2.28
108         - Orientation : add landscape UX
109         - ToggleSwitch : divide jQM and Tizen slider on dragging outside of toggle area 
110         - Slider: Popup slider issue has been fixed ( N_SE-36430 )
111
112 * Fri May 03 2013 Hyunjung kim <hjnim.kim@samsung.com> 0.2.27
113         - Splitview: Fix popup error
114         - Tests: Add slider tests checking if jqm slider is used for select elements
115         - Adjust the latest GUI
116         - Handler: Adjust the latest GUI
117         - Swipe: Adjust the latest GUI
118         - Fastscroll: Adjust the latest GUI
119         - ToggleSwitch : bug fix
120         - TizenWinset : bug fix(N_SE-36666)
121         - Gallery3d: Fix Gallery3d TC failure
122         - UnitTC: fix virtualgrid test error
123         - Popup: popup background image have been added
124         - Tokentextarea: Use jQM popup instead of window.alert().
125         - Splitview: Use jQM popup instead of window.alert().
126         - Splitview: Change an option name to start with a capital letter
127         - License: Change flora license version
128         - Tabbar: Adjust the latest GUI
129         - Tokentextarea: Change from 'px' to 'em.'
130         - Fastscroll: Add 'orientationchange' event handler.
131         - Gallery3d: Fix null reference error
132
133 * Fri Apr 26 2013 Youmin Ha <youmin.ha@samsung.com> 0.2.26
134         - PageLayout : bug fix
135         - Gallery3d: Change timing of 'gl-matrix' library's execution
136         - Replace in LoadTheme function strings build with array join with the string concat
137         - Contextpopup: context popup reposition module has been added
138         - Pagelayout : skip to calculate min-height using data-scroll="none"(Issue: DCM-1453)
139         - Splitview: Fix the touchend event error.
140         - Gallery3d: Change event registration method from $.bind() to $.on()
141         - Scrollview : remove useless setTimeout in case scrolls go outside
142         - Naviframe : adjust new SIP down button
143         - Timepicker: Added return false; after vclick
144         - Popupwindow: reserved words has been removed
145         - minor changes: replace one occurrence of array.join with string concat and simplify jQuery arguments
146         - TizenWinset : set default margin for checkbox demo
147         - Tizenwinset: Context popup demo has been changed
148         - TizenDemo : add initial orientation mode to popup demo
149         - Widgets: removed parsing error for legacy javascript engine
150         - Delegate init of popup widget with delegateSelfInitWithSingleSelector
151
152 * Tue Apr 18 2013 Youmin Ha <youmin.ha@samsung.com> 0.2.25
153         - Pinch: pinch event re-implementation to use size
154         - Pagelayout : prevent code inserting window.innerHeight when content calculate
155         - BlachTheme : add missing icon (SIP down)
156         - Scrollview : support absolute position
157         - tizen-winsets: change the font-family in virtualgrid demo to default
158         - TizenWinset : Change default font
159         - tizen-winsets: Change image link
160         - tizenwinset: change images for virtual grid pages
161
162 * Tue Apr 16 2013 Youmin Ha <youmin.ha@samsung.com> 0.2.24
163         - SegmentControl: 2-buttons display issue (N_SE-34200)
164         - Naviframe : remove unnecessary img positioning(N_SE-33969)
165         - Gallery: jslint error fix
166         - TizenWinset : remove landscape SIP on mode
167         - Tizen Black Theme png file changed
168         - Gallery: Images showing bug has been fixed
169         - Scrollview : change horizontal scrollview demo(N_SE-33997)
170         - Tizenwinset: added return false in popup sample
171         - Naviframe : support data-role="button" in header
172         - Additional UnitTC: tizen winset unit tc bugs have been fixed
173         - Checkbox : remove favorite button's display:block(N_SE-33896)
174         - UnitTC: QUnit path has been changed. Priority, function type check function has been added
175         - Tizen-winset : Footer changed from lower case to upper case.
176         - Slider: enhance performance fix
177         - UnitTC: Addtional unit tc ref path has been fixed
178         - virtualgrid: apply overscrolling images to the style of widget
179         - Tabbar : Change overscroll image(left/right)
180         - ensurens: optimizations
181         - ensurens: qunit tests
182         - Tokentextarea: Fix block size error
183         - Fastscroll: Add a feature to fade out Fastscroll widget.
184         - Fastscroll: Add a user interaction at the omitted items.
185         - ImageLoader: Performance fix: apply lazy loading for canvas element
186         - Tests: Add tests for $.imageloader
187         - SegmentControl: 2-buttons display issue (N_SE-34200)
188         - virtuallist: fix width resizing trigger
189         - Timepicker: timepicker is closed when orientationchange event fired
190         - TizenWinset : Tabbar-persist issue.(N_SE-33996)
191         - Add Flora license
192         - collapsible: Fix collapsible list animation bug
193
194 * Wed Apr 10 2013 Youmin Ha <youmin.ha@samsung.com> 0.2.23
195         - Naviframe : modify SIP down button's position
196         - Core: Performance fix for disableSelection and enableSelection
197         - Tests: Core tests for disableSelection
198         - patch: fix small mistakes on the patches
199         - virtuallist: Change demo button style
200         - Button: btn-icon only css has been changed
201         - loader: Fix screen-width option processing
202         - pagelayout: Remember back key when it is hidden
203         - Tizen Black Theme : Tizen black theme png file changed.
204         - UnitTC: tizen winset unit tc bugs have been fixed
205         - TizenWinset: Swipe list sample has been fixed
206         - Radio : remove default radio's width(N_SE-33579)
207         - Scrollview : divide x/y overflow attribute
208         - Gallery: orientation image showing issue has been fixed
209         - Gallery: remove method bug has been fixed
210         - virtualgrid : fix unit-test error and increase test items
211         - Gallery3d: Modify demo & source codes for visibility enhancement.
212         - Gallery3d: Reduce loading time of widget
213         - Gallery3d: Change files' format to unix
214         - Contextpopup: context popup close when window resize event fire
215         - Popup: reverse orientation bug has been fixed
216         - Tokentextarea: modify description
217         - Multimediaview: modify description
218         - JQM: Do not add ui-btn-icon-only class at the select button
219         - build: tizen-black theme package
220         - Tizenwinset: popup script has been removed
221         - Tizenwinset: substring split view text message
222         - Timepicker: data-changed event will be deprecated
223
224 * Fri Apr 5 2013 Youmin Ha <youmin.ha@samsung.com> 0.2.22
225         - tizen-winsets: Fix demo menu
226         - Tizenwinset: Reorder tizenwinset menu
227         - SearchBar: Header button size issue has been fixed
228         - Swipe: list item overflow: hidden has been added
229         - Tizenwinset: href has been added in grouped list
230         - Tizenwinset: Page transition page has been added
231         - Tizenwinset: Radio description has been fixed
232         - This patch fixes problem when base url is changed when site is prefetched.
233         - Entry : limit textarea's width (N_SE-28653)
234         - Naviframe : hide backbutton in case SIP up(remove backbutton makes problem in binding event)
235         - Gallery : next, prev images position bug has been fixed
236         - Multimediaview: Fix display error while handling orientationchange event.
237         - Pagelayout : modify innerHeight dpr calculation in non scrollview mode
238         - Datetimepicker: picker position has been fixed when browser resize event fired
239         - Tips: generate elements sample page javascript has been fixed
240         - Tokentextarea: Fix Tizen-winsets demo.
241
242 * Wed Apr 3 2013 Youmin Ha <youmin.ha@samsung.com> 0.2.21
243         - VirtualGrid: Fix errors on centerTo and resize methods
244         - loader: Fix default font size at device-width viewport
245         - scrollview : remove overflow-x property
246         - Naviframe : fix backbutton position/ change down button icon
247         - Naviframe : bug fix
248         - Tizenwinset : Tizen-winset demo page titles changed Tizen-winset demo page titles changed from lower case to upper case.
249
250 * Fri Mar 29 2013 Youmin Ha <youmin.ha@samsung.com> 0.2.20
251         - JQM Navigation : remove page min-height
252         - Pagelayout : add refresh to pagelayout
253         - Tokentextarea: Changes 'remove' tests to asyncTest
254         - Popup: input tag alignment has been fixed
255         - Tokentextarea: add/remove events are deprecated.
256         - Contextpopup: Support horizontal list
257         - Select: icon z-index has been deleted
258         - Tizenwinset: ui widget order has been changed
259         - Tool: make web app template disable context menu by default
260         - Tizen-winset: change tips for using listview
261         - Loader: calculate font size with mobile width
262         - Naviframe : fix header's back button position
263         - TizenWinset : move locale info to another file
264
265 * Fri Mar 22 2013 Youmin Ha <youmin.ha@samsung.com> 0.2.19
266         - Tizen-winset: Support accessibility for tizen-winset
267         - Orientation : add orientataionchange to tizen-winset
268         - Tokentextarea: Adjusts VI effect for add/remove block
269         - splitview: Support accessibility for splitview
270         - Tizen-winset: Date/time picker guide text has been fixed
271         - Popup: context popup arrow position, setTimeout open method bug have been fixed
272         - fastscroll: Add new indexString API to Fastscroll widget.
273         - splitview: Add new widget
274         - gallery3d: Add new widget
275         - Scrollview : disable VI effect for gesture event
276         - Scrollview : disable SIP outerscroll
277         - Tizen-winset: resize VirtualGrid widget in demo
278         - Tizen-winsets: Refactor searchbar subpages
279         - Tizen-winsets: Remove depracated usage of virtuallist
280         - Tizen-winsets: Move js code from main.js to subpages
281         - Tizen-winsets: Refactor virtual grid demo subpages
282         - Tizen-winsets: Move css files from index to proper subpages
283         - Tizen-winsets: Refactor list dialogue edit subpage
284         - Tizen-winsets: Refactor pagelayout subpages
285         - Tizen-winsets: Refactor tips subpages
286         - Tizen-winsets: Move subpages popup files from index.html
287         - Tizen-winsets: Move subpages javascript files from index.html
288         - virtualgrid: fix improperly merged codes
289         - ColorTheme : remove unused color value(1st)
290         - Scrollview : change scrollbar draw
291         - Popup: Apply popup background dim
292         - Tizen-winsets: Move tokentextarea demo to external page.
293         - Tizen-winsets: Move tabbar persist demo to external page.
294         - Tizen-winsets: Remove notImplemented page
295         - Tizen-winsets: Move slider demo page to external subpage
296         - Tizen-winsets: Fix ids, remove duplicated names for sliders
297         - Tizen-winsets: Remove event for changing theme
298         - tool: Fix wgt sample app generator tool to make apps be installed
299         - demos : change live to on
300         - build: Trim compiled CSS files
301         - Gallery: CSS left -> translate or translate3D
302         - Tokentextarea: Disfunctional APIs fixed.
303
304 * Thu Mar 7 2013 Youmin Ha <youmin.ha@samsung.com> 0.2.18
305         - build: Fix Makefile to add globalize to the minified lib
306         - build-tools : upgrade less to v1.3.3
307         - demos : change normal js path to minified js
308         - Theme : remove reduantant less - dayselector, optionheader, nocontents
309         - multimediaview : fix full-screen mode.
310         - multimediaview : fix 'width', 'height' and 'fullScreen' methods
311         - Extendablelist: Added min-height "load more button" in listitem
312         - virtualgrid: adjusts VI effect for an overflow action
313         - ControlGroup : change ellipsis font color (press/normal)
314         - multimediaview: Add an error message to Multimediaview
315         - virtualgrid: adjusts triple flick gesture
316         - scrollview: add function for getting width of view
317         - scrollview: adds support x axis gesture scroll
318         - multimediaview : fix audio control
319         - tabbar : tabbar slide animation change
320         - TizenWinsetDemo : 2line-text demo bug fix
321         - collapsible: Fix demo to show radio button correctly in the collapsible list
322         - collapsible: Set listitem position to relative
323         - UnitTC: added list divider unit test
324         - Style: unnecessary color codes have been deleted and modified
325         - build: Module build implementation
326         - UnitTC: Additional unit testcases have been added
327         - listview : bug fix
328         - Naviframe : remove back button's hover effect
329         - TizenDemo : remove back button
330         - Transition: added more-button vi
331         - pinch: added new event called pinch
332         - Popup: css word-wrap:break-word has been added
333         - virtualgrid: memory leak fix
334         - progress: set to init state at pending bar
335         - progress: add margin of top/bottom
336         - unit-test: split progress test and progressbar test
337         - Tizen-winset: Context popup sample page guide text has been changed
338         - multimediaview: fix the height of widget when full-screen mode
339         - JQM: performance tuning
340
341 * Tue Feb 19 2013 Minkyu Kang <mk7.kang@samsung.com> 0.2.17
342         - DialogueList : delete border top value / add sample's text ellipsis
343         - Tokentextarea: Add scroll-to-top for Grouping On/Off regarding #N_SE-24877
344         - Multimediaview: Fix mute function
345         - Tizen-winset: list vi index guide textbox has been removed
346         - Tizen-winset: custom button texts have been changed
347         - slider: move popup div to out of content
348         - TizenWinset: disable context popup in multimediaview
349         - Swipe: wrong style name has been fixed
350         - demo: add the sample at dialogue list
351         - listview: Add ui-li-has-right-btn class with toggleswitch
352         - WinsetDemo : change wrong title name
353
354 * Mon Jan 28 2013 Youmin Ha <youmin.ha@samsung.com> 0.2.16
355         - demo: checkbox: reduce button's width
356         - tabbar : delete right/left tab animation color
357         - scrollview: fix the scroll position at keydown event
358         - groupControl : change footer groupControl from min-width to percentage
359         - scrollview: get height of softkeyboard correctly
360         - tizen-winset: Add name attr to all radio inputs
361         - virtualgrid: changes event binding target
362         - scrollview: skip the drag if target is textarea
363         - scrollview: skip the dragging of parent scrollview
364         - scrollview: apply the scaling ratio to the soft keyboard
365         - demos: apply disabled option in textarea
366         - demo: remove unused codes
367         - demo: datetimepicker: show selected date correctly
368         - listview: Adjust bubble listitem width and margin
369         - pagelayout : change external refresh call and ime status follow only current page
370         - toggleSwitch : bug fix
371         - unit-test: slider: fix the move test
372         - handler: fix jslint error
373         - ToggleSwitch : set image toggleswitch background attribute
374
375 * Mon Jan 28 2013 Youmin Ha <youmin.ha@samsung.com> 0.2.15
376         - slider: increase the text width(N_SE-23397)
377         - virtualgrid: DOM element leak fix
378         - header: Move button top higher in header with tabbar(N_SE-22253)
379         - datatimepicker: don't open the popup before popupafterclose event is fired(N_SE-23027)
380         - handler: bug fix (regarding enableHandler function )
381         - demo:fix syntax error
382
383 * Sat Jan 26 2013 Youmin Ha <youmin.ha@samsung.com> 0.2.14
384         - demo: fix demo using tizen device API
385         - multimediaview: reset the height of container
386         - input: modify css correctly
387         - multimediaview: fix the height of widget
388         - gallery: bind create event
389         - progress: bind create event
390         - slider: bind create event
391         - progressbar: bind create event
392         - progressbar: event trigger correctly
393         - popup: fix height of popup scroller
394         - build: add continue option to jslint
395         - ctxpopup demo : bug fix
396         - demo: fix searchbar demo to use different IDs
397         - demo: extract routine executing Tizen device API
398         - toggleswitch : set default margin, delete box padding
399
400 * Thu Jan 24 2013 Youmin Ha <youmin.ha@samsung.com> 0.2.13
401         - virtuallist: Prevent replacing contents on nonexist element
402         - JQM: Trim text in listitem to get index in autodivider
403         - JQM: Remove trailing whitespace in jqm patch
404         - scrollview: get the height including margin
405         - multimediaview: bug fix ( scrolling in full-screen mode )
406         - virtuallist: set listitem width to exclude listitem left/right margin
407         - demo: fix virtuallist sample layout
408         - progress: set the position explicitly
409         - progress: rename from progressing to progress
410         - build: remove unused files
411         - searchbar: fix jslint errors
412         - src: fix file permissions
413         - button : change jump left icon
414
415 * Wed Jan 23 2013 Minkyu Kang <mk7.kang@samsung.com> 0.2.12
416         - theme : button icon - scrolltop, scrolleft icon changed.
417         - build: cleanaup Makefile
418         - pagelayout: fix jslint error
419         - virtualgrid: Fix jslint errors
420         - tabbar : jslint bug error fix
421         - build: add regexp option to jslint
422         - virtuallist: fix jslint errors
423         - handler: Apply the exceptional principle for scrollbar on Handler.
424         - build: remove unused copyright
425         - loader: extract log class for tizen web, and fix jslint errors
426         - loader: Viewport width is set to document width
427         - popupwindow: fix jslint error
428         - build: fix Makefile for tizen-white theme
429         - build: remove unused libraries
430         - datetimepicker: fix jslint error
431         - slider: fix jslint error
432         - demo: remove deprecated demos
433         - pagelayout : change to call relayout with this page
434         - Tokentextarea: Block size error fixed.
435         - handler: bug fix (handler activation)
436
437 * Tue Jan 22 2013 Minkyu Kang <mk7.kang@samsung.com> 0.2.11
438         - demo: clear input text value with cancel button click
439         - demo: Adjust textarea height automatically
440         - naviframe : bug fix
441         - tabbar : bug fix
442         - Fastscroll: popup position has been changed
443         - Button: custom button icon path, margin have been changed
444         - toggleswitch : bug fix
445         - slider: increase the margin
446         - datetimepicker: close the popup after select the value
447         - unit-test : add page backbutton control test
448         - Demo: added guide text and change input type in list vi
449         - remove legacy codes : jquery-geo
450         - Datetimepicker: text-main max-width has been removed
451         - Radio: control group border has been removed
452         - Demo: remove 'tab' space
453         - UnitTC: swipe unit tc has been fixed
454         - UnitTC: jQuery path has been fixed
455         - Button: bug fix when button has not a text
456         - tizen-winset: timepicker: demo title is changed
457
458 * Fri Jan 18 2013 Minkyu Kang <mk7.kang@samsung.com> 0.2.10
459         - tizen-winsets: codes cleanup
460         - datetimepicker: date calibration when year is changed
461         - Demo: textarea size has been changed
462         - Demo: Naviframe morebutton demo has been changed
463         - remove unused unit test cases : gallery3d
464         - tizen-winset: remove links
465
466 * Thu Jan 17 2013 Minkyu Kang <mk7.kang@samsung.com> 0.2.9
467         - gallery: use timeout function instead of interval
468         - Tokentextarea: Display error fixed.
469         - scrollview: Fix not selector to respond with jQuery1.8.2
470         - tabbar: remove the width of last element
471         - Demo: apply css 'user-select:none'
472         - Button: guide text has been shorten
473         - build: Update jQuery to 1.8.2 (JQM1.2 compliant)
474         - virtuallist: Fix mistyping
475         - demo: Fix tizen function namespace in demo
476         - virtuallist: Rewrite listitem replacing algorithm
477         - fastscroll: modify from not selector to function
478         - extendablelist: Fix unit-test
479         - tabbar : prefix to tabbar scroll event
480         - Popupwindow: removed unvalid selector in jquery 1.8.2
481         - slider: adjust handle text as length of value
482         - Demo: 3 buttons in popup text has been changed
483         - src: codes cleanup
484         - demo : remove trailing empty strings
485         - demo : rename TizenWinset list items
486         - button : change from long text list to multiline list
487         - build: Remove JQM1.1.0 patches
488         - Popup: Apply tizen style popup and attribute support
489         - JQM: Fix buttonmarkup bug keeping ui-btn-down class
490         - UnitTest: folder and file renamed, QUnit path was modified
491         - tizen-winsets: button: fix textarea width
492         - Swipe: event name error has been fixed
493
494 * Tue Jan 15 2013 Minkyu Kang <mk7.kang@samsung.com> 0.2.8
495         - Button: button padding has been updated
496         - virtuallist: fix unique listitem ID bug
497         - checkbox, radio : change display attr
498         - Button: bug fix ( when data style circle button on text )
499         - handler: bug fix (when scrolling with multi selection)
500         - JQM: adjust patch number
501         - gallery: show the widget after pageshow
502         - TokenTextArea : resource add ( press image )
503         - gallery: adds function that set the index to value API
504         - configure: set TIZEN default configures
505         - footer: h tag display attribute value has been changed
506         - buttons : demo bug fix
507         - searchbar : demo page bug fix
508         - tizen demo : bug fix
509         - build: remove JQM1.1.0
510         - Tokentextarea: Fix issues
511         - scrollview: block the multi touch
512         - list : dialogue list demo change
513         - pagelayout : update dynamic control
514         - Demo: Context popup close method has been changed
515
516 * Fri Jan 11 2013 Minkyu Kang <mk7.kang@samsung.com> 0.2.7
517         - slider: set text container's width as text length
518         - Timepicker: li max-width has been changed
519         - remove experimental feature - mapview.
520         - scrollview: added conditions for finding slider
521         - UnitTC: Pass,error count save method has been changed
522         - confix.xml: default config added for tizen basic applications
523         - Swipe: p tag margin value is set '0'
524         - packaging: remove unused file
525         - tabbar : bug fix
526         - list demo : bug fix
527         - tizen-winsets: gallery: move to new section
528         - tizen-winsets: autodivider: removes link of list
529         - demos: entry of number-pattern name is changed from 'number' to 'number-pattern'
530         - pagelayout : padding calculate change, ime footer check changed
531         - tizen-winsets: searchbar: scroll to the top when type the character
532         - searchbar : bug fix
533         - demo: Fix virtuallist demo following new list style
534         - demo: Add word-wrap:break-word and remove parag. width
535         - Demo: button max-width has been set( 3 buttons in popup )
536         - back button control demo : bug fix
537         - toggleswitch : demo page modify
538         - slider: add margin-top and margin-bottom
539         - tabbar demo : bug fix
540         - Popup: IME hide when popup is closed
541         - token textarea : bug fix
542         - Timepicker: change get attribute method
543         - footer demo : bug fix
544         - unit-test: gallery: add new APIs
545         - gallery: adds support new APIs
546
547 * Fri Jan 04 2013 Minkyu Kang <mk7.kang@samsung.com> 0.2.6
548         - JQM: patches cleanup
549         - Button: data-corners attribute has been added
550         - unit-test: slider: fix class name of background
551         - progressbar, slider: fix less variable typo
552         - Tabbar : VI update
553         - notification: add top position at fix class
554         - demo: entry demo page change
555         - css: .ui-disabled added
556         - tizen-winset: token textarea: remove back button at demo page
557         - theme: Remove unused less file
558         - pagelayout : content min height bug fix
559         - scrollview: skip the dragging when target is slider's handle
560         - scrollview: update and refactoring the scroll effect
561         - UnitTest:JQM Unit TC helper has been added,TCs have been modified
562         - Swipe: demo page html error has been fixed
563         - listview: Add add/delete animation (VI)
564         - Popup: demo page has been modified
565         - tizen demo : bug fix
566         - searchbar : demo page change(change front button and add behaviour)
567         - pagelayout : add min height to content
568         - gallery: rename 'Image Slider' to 'Gallery' in tizen-winsets demo and tests
569         - back button control demo : change url link to data-rel="back"
570         - loader: Skip loading theme CSS with a custom css code
571         - Button: support no-text in button
572         - collapsible: Fix syntax error
573         - slider: use data-highlight attribute
574         - collapsible: Rotate animation to collapsible heading icon
575         - toggleswitch : text switch bug fix
576         - remove candidates-calendarpicker
577         - Patch: Fix misc mistakes in JQM patches
578         - searchbar : animation change
579         - gallery: get the width correctly
580         - demo: data-framework-viewport-scale attribute is changed to data-framework-viewport-width
581         - collapsible: Add collapse/expand animation (VI)
582         - datetimepicker: VI update
583         - JQM: set transition to pop as default
584         - tabbar : bug fix in case none li element case
585         - scrollview: fix the drag bug
586         - Button: Button icon scrolltop, left has beed added
587         - Swipe: VI update and swipe speed has been changed
588         - jqm: fix errors in patch files
589         - unit-test: swipe: fixed the destroy test
590
591 * Wed Dec 26 2012 Youmin Ha <youmin.ha@samsung.com> 0.2.5
592         - Revert "[checkboxradio] exception handling for input"
593                 This reverts commit 72478c32704fa96362db577e6cf9511777919ea8.
594                 Tizen style supports no-label radio and checkbox when making lists.
595                 So it ignores html input operation. Instead, it supports tizen style radio and checkbox theme.
596
597 * Thu Dec 20 2012 Youmin Ha <youmin.ha@samsung.com> 0.2.4
598 - Fix:
599         - modify segment background
600         - rearrange check, radio input
601         - CtxPopup: Scale up/ down popup vi(poptop, popbottom)
602         - button: style has beed added(box,circle,nobg,round)
603         - favorite resource added
604         - demo/tizen-winsets: add footer and back button
605         - remove autodividers unit test
606         - add divider for tabbar
607         - checkboxradio: exception handling for input
608         - segment control backward compatiblity
609         - Fix collapsible unit-test
610         - remove toggleswitch
611         - add patch for remove segment text
612 - Spec changes:
613         - replace controlbar to tabbar
614
615 * Fri Dec 14 2012 Minkyu Kang <mk7.kang@samsung.com> 0.2.3
616 - FIX:
617         - slider: add image
618         - button: data-icon support, styles fix
619         - progressbar: modify the background
620         - scrollview: auto scrolling bug fix
621         - pagelayout: IME concept is changed
622 - Spec changes:
623         - dialogue: add edit mode
624         - nocontents: removed
625         - pagecontrol: removed
626         - dayselector: removed
627         - expandablelist: removed
628
629 * Thu Dec 10 2012 Youmin Ha <youmin.ha@samsung.com> 0.2.2
630 - FIX:
631         - chang searchbar/slider images
632         - delete redundant button images
633 - Spec changes:
634         - Change widget name: shortcutscroll -> fastscroll
635
636 * Thu Dec 07 2012 Youmin Ha <youmin.ha@samsung.com> 0.2.1
637 - FIX:
638         - jqm1.2: Change collapsible style to meet expandable list
639         - remove jquery-geo-1.0.a4
640         - unit-test: rename from imageslider to gallery
641         - nocontent: add warning message
642         - Handler: Fix issues in jqm1.2
643         - Multimediaview: modify APIs & comments
644         - Mapview: Fix issues in jqm1.2
645         - JQM: clean up patches
646         - Swipelist: refactoring swipelist
647         - Popup,Ctxpopup: Apply tizen style popup in JQM1.2
648         - rearrange button's data-icon resources
649 - Spec changes:
650         - Virtualgrid: remove option ('data-itemcount')
651         - gallery: rename the widget from imageslider to gallery
652         - add new style for searchbar
653         [tokentextarea] multi-button entry renamed as token text area. API & comments modified.
654
655 * Thu Dec 06 2012 Minkyu Kang <mk7.kang@samsung.com> 0.2.0
656 - FIX:
657         - fix jslint error
658         - remove unused files
659         - change naviframe style
660 - Spec changes:
661         - applied jQuery Mobile 1.2.0
662         - remove optionheader
663
664 * Fri Nov 30 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.64
665 - FIX:
666         - fix unit tests
667         - remove unused theme files
668         - timepicker: text position fix
669         - scrollview: set dragstop when mouse is out of window
670         - listview: fix margin
671 - Spec changes:
672         - support data-framework-viewport-width
673
674 * Fri Nov 23 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.63
675 - FIX:
676         - dayselector: fix size
677         - remove unised styles
678         - divider: set non-press effect to default option
679         - popupwindow: fix window closing failure
680         - handler: GUI implementation
681         - TC: fix unit TCs
682         - scrollview: fix padding size
683 - Spec changes:
684         - Remove color widgets
685         - add $.tizen.pkgVersion for SDK
686 - Etc.
687         - JSDuck documents
688
689 * Fri Nov 16 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.62
690 - FIX:
691         - Many winsets: Fix layout
692         - Footer: fix position to bottom
693 - Spec changes:
694         - Remove color widgets
695
696 * Fri Nov 09 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.61
697 - FIX:
698         - Many widgets: New UX 0.6 theme implementation
699         - widgetex: init speed up
700         - scrollview: fix scrollbar and scale animation
701         - scrollview: fix scroll position when updatelayout is triggered
702         - header/footer: make textselection disable, except input type="text"
703
704 * Wed Nov 07 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.60
705 - FIX:
706         - Remove tizen-black theme package description
707
708 * Tue Nov 06 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.59
709 - FIX:
710         - Fix theme name to meet the change of system theme name: white->tizen
711         - Popupwindow: fix left position
712         - Remove black theme
713         - footer: remove label, legend drawing
714 - Spec changes:
715         - UX guide v0.4 : button, layout
716
717 * Fri Oct 26 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.58
718 - FIX:
719         - scrollview: Fix outer scroll amount
720         - tabbar: fix tapping twice
721         - popupwindow: fix left position
722
723 * Wed Oct 24 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.57
724 - FIX:
725         - expandablelist: icon color fix
726         - scrollview: Fix xy scroll
727         - footer: Remove dummy div
728         - Make string concatnation effective in inline-protos.sh
729 - Spec changes:
730         - refresh header/footer when drag&drop event is fired in GUI builder
731         - searchbar: delete cancel button
732         - don't trigger updatelayout event when keyup event comes
733
734 * Mon Oct 15 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.56
735 - FIX:
736         - Toggleswitch: Change event name from 'changed' to 'change'
737         - Notification: Revert interval feature
738
739 * Tue Oct 09 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.55
740 - FIX:
741         - Fix SMACK manifest bug (S1-9098)
742
743 * Fri Oct 05 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.54
744 - FIX:
745         - handler: don't append a handler if handler is not enabled
746         - scrollview: use static value
747         - datetimepicker: fix date-format HH display error
748 - ETC:
749         - provide jquery.min.js
750         - barlayout: codes clean
751         - remove unused file
752
753 * Wed Sep 26 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.53
754 - FIX:
755         - listview: change focused color
756         - multibuttonentry: code refactoring
757         - datetimepicker: modify date format when triggered date-changed event
758         - slider: fix the top of slider bar
759         - add event blocker when load a first page
760
761 * Fri Sep 21 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.52
762 - ETC.
763         - Move SMACK manifest files to the top SRCDIR
764
765 * Fri Sep 21 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.51
766 - FIX:
767         - Popup: Do not focus container
768         - Header: show backbutton when both tabbar and header are present together
769         - Multi button entry: text ellipsis, code refactoring
770
771 * Fri Sep 21 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.50
772 - ETC.
773         - Apply SMACK manifest
774
775 * Thu Sep 20 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.49
776 - FIX:
777         - JSLINT code clean-up
778         - scrollview: firefox support
779         - scrollview: fix finding slider handle
780         - list: tweak text ellipsis
781         - checkbox: fix selecting wrong label tag (N_SE-8370)
782         - imageslider: check parameter
783         - smallpopup: fix position
784         - searchbar: fix 'clear' button size
785 - Spec changes:
786         - scrollview: support outer scroll
787         - JQM: block click event only with the element that does preventdefault on vclick(N_SE-6090)
788         - remove S/W IME control
789
790 * Thu Sep 13 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.48
791 - FIX:
792         - Add missing icon: controlbar
793         - scrollview: tune scrolling animatio ninterval
794         - datetimepicker: digit/triangle position
795         - datetimepicker: fix day overflow issue
796 - Spec changes:
797         - scrollview: show scrollbar when page is showed
798         - scrollview: disable outer scroll
799         - extendablelist: change api with legacy support
800         - add ui-text-ellipsis class
801
802 * Mon Sep 10 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.47
803 - FIX:
804         - scrollveiw: fix height of view
805         - searchbar: support placeholder
806 - Spec changes:
807         - add ui-text-ellipsis class
808
809 * Fri Sep 07 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.46
810 - FIX:
811         - scrollview: scrolling bug fix
812         - controlbar: fix width of controlbar item
813 - Spec changes:
814         - searchbar: don't hide icon
815         - popup: update JQM poup widget
816
817 * Fri Sep 05 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.45
818 - FIX:
819         - controlbar: set correct controlbar width of last element
820         - slider: get popup enable value correctly
821         - use Date.now() instead of (new Data()).getTime()
822         - popupwindow: fix the background color of popup scroller
823         - listview: add padding-left to expandable list
824         - add ellipsis for title area support
825
826 * Fri Aug 31 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.44
827 - FIX:
828         - swipelist: show list items correctly
829         - datetimepicker: set last day, if day is overflowed
830 - Spec changes:
831         - controlbar: update icons
832
833 * Tue Aug 29 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.43
834 - FIX:
835         - notification: fix typo
836 - Spec changes:
837         - controlbar: update icons
838
839 * Tue Aug 28 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.42
840 - FIX:
841         - multimediaview: video progress bar display normally for too samll
842         - segmentcontrol: remove media query
843         - scrollview: add outer scroll condition
844         - datetimepicker: modify triangle size
845         - popupwindow: set the screen height explicitly
846         - notification: add multiline text
847 - Spec changes:
848         - mutibuttonentry: support new GUI
849         - virtualgrid: support new GUI
850
851 * Mon Aug 27 2012 Jinhyuk Jun <jinhyuk.jun@samsung.com> 0.1.41
852 - FIX:
853         - radio/check button : button size bug fix
854
855 * Fri Aug 24 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.40
856 - FIX:
857         - build error fixed
858
859 * Fri Aug 24 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.39
860 - FIX:
861         - listview: style fix, remove filter placeholder
862         - controlbar: divide styles
863         - scrollview: don't skip dragging when click button or inputbox
864         - slider: trim the text on text slider
865 - Spec changes:
866         - remove gray and blue theme
867         - add white and black theme
868         - support new GUI guide
869
870 * Mon Aug 20 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.38
871 - FIX:
872         - fix coment of version tag
873
874 * Fri Aug 17 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.37
875 - FIX :
876         - button: fix alignment
877         - listview: adjust the main text width
878         - virtualgrid: refactoring
879 - Spec changes:
880         - transition: support JQM 1.1.0 transitions
881         - scrollview: support the outer scroll
882         - notification: remove interval feature
883
884 * Tue Aug 14 2012 Youmin Ha <youmin.ha@samasung.com> 0.1.36
885 - FIX :
886         - checkboxRadio: Add left/right padding
887         - button: custom button & icon position
888         - virtuallist: remove 'recreate' test
889 - Spec changes:
890         - header/footer: enable/disable support
891
892 * Fri Aug 10 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.35
893 - FIX :
894         - expandablelist: modify show animation
895         - virtualgrid: Redesign programming interface
896         - popupwindow: code clean and fixed issues
897         - pagelayout: fix content height
898         - license file update
899         - virtuallist: Change programming interface
900         - datetimepicker: getting days correctly
901         - searchbar: set to hidden when cancel button is hide
902         - White theme title font tuning
903 - Spec changes:
904         - default theme tizen-gray to tizen-white
905         - set default page transition to none
906
907 * Mon Aug 02 2012 Jinhyuk Jun <jinhyuk.jun@samsung.com> 0.1.34
908 - FIX :
909         - Back Button : enlarge backbutton click size for white theme
910 - Feature :
911         - Expandable List : Add refresh api
912 * Mon Aug 02 2012 Jinhyuk Jun <jinhyuk.jun@samsung.com> 0.1.33
913 - FIX :
914         - click event touch threshold tuning
915
916 * Mon Aug 02 2012 Jinhyuk Jun <jinhyuk.jun@samsung.com> 0.1.32
917 - FIX : 
918         - Add back button highlight effect for white theme
919
920 * Mon Aug 01 2012 Jinhyuk Jun <jinhyuk.jun@samsnug.com> 0.1.31
921 - FIX : 
922         - IME checkroutine update, improve relayout on resize event
923         - Add highlight effect for radio button list 
924         - Scrollview : fix condition of updatelayout event
925 - Feature : progressing : add show/hide api
926
927 * Mon Jul 27 2012 Koeun Choi <koeun.choi@samsung.com> 0.1.30
928 - FIX : virtuallist, virtualgrid: Clean up temporary jquery.template object to clear cache
929         add default theme option on buttonMarkup for tizen theme
930         [searchbar] first fix : focus/blur fixed
931         back button does not work when long press
932         scrollview: don't auto scrolling if resizing area is too large
933 - Feature : notification : add api to set the icon at tickernoti
934         demo : update the list sample demo
935         Support tizen default theme
936
937 * Mon Jul 23 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.29
938 - Improvements & Bugfixes
939    - HOTFIX: Revert template function with jquery.template
940
941 * Thu Jul 19 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.28
942 - Improvements & Bugfixes
943    - Fix #WEB-1028: memory leak on virtuallist/virtualgrid
944 - Spec changes
945    - $.tizen.loadTheme() function accepts theme name as arguement
946    - Scrollview supports 'updatelayout' callback
947
948 * Tue Jul 17 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.27
949 - Improvements & Bugfixes
950    - Revert 'preventing long-press popup' patch, to fix backbutton to work in SocialMagazine
951
952 * Tue Jul 17 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.26
953 - Improvements & Bugfixes
954    - Add tizen-white theme package, to make rpm build to be finished
955
956 * Tue Jul 17 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.25
957 - Improvements & Bugfixes
958    - Set 'slide' as default page transition effect, by JQM patch
959
960 * Fri Jul 13 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.24
961 - Improvements & Bugfixes
962    - Fix IME show/hide algorithm
963    - Fix error on virtualgrid: link _set_scrollbar_size() function to the one in virtuallist
964
965 * Wed Jul 11 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.23
966 - Improvements & Bugfixes
967    - Fix notification position
968    - Fix unit tests
969
970  Fri Jul 6 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.22
971 - Spec changes
972         - JQM 1.1 upgrade
973 - Improvements & Bugfixes
974         - Transform3D support on scrollview
975         - Page layout supports IME control
976         - Mapview supports pinch zoom on JQM 1.1
977         - Fix wrong character on button in minified version
978         - Virtualgrid supports scrollbar
979         - Lots of bugfixes
980
981 * Fri Jun 22 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.20
982 - Spec changes
983         - Support 'latest' version (by symlink) for tizen-web-ui-fw.js path.
984         - imageslider : supports 'resize' event.
985         - listview : listview has 1px padding-bottom.
986         - loader : Change global namespace, from S to $.tizen.
987         - loader : Move loadCustomGlobalizeCulture() into $.tizen.util namespace.
988 - Improvements & Bugfixes
989         - Scrollview : supports 'translate3d', instead of 'translate'.
990         - notification : reset timer when 'show' or 'refresh' event.
991         - JQM patch : Fix vclick event triggered twice.
992 - Etc.
993         - Add & fix unit tests.
994
995 * Thu Jun 14 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.19
996 - Spec changes
997         - mapview : new widget.
998         - notification : add .refresh() API.
999         - pagecontrol : add .value([val]) API, and change an attribute name 'data-initVal' to 'data-value'.
1000 - Improvements & Bugfixes
1001         - Support minified CSS.
1002         - loader : Fix & refactor 'loading globalize culture file' routine.
1003         - JQM Patch : Calculate min-height of window in javascript code, and remove predefined min-height value from CSS.
1004         - Many more bugfixes.
1005 - Etc.
1006         - Add many unit tests.
1007         - Fix test coverage instrumentation tool to work with current source code.