Export 0.1.41
[platform/framework/web/web-ui-fw.git] / packaging / web-ui-fw.spec
1 Name:       web-ui-fw
2 Version:    0.1.41
3 Release:    0
4 Summary:    Tizen Web UI Framework Library
5 Group:      Development/Other
6 License:    MIT
7 BuildArch:  noarch
8 BuildRequires:  make
9 BuildRequires:  nodejs
10 %ifarch %{arm}
11 BuildRequires:  nodejs-x86-arm
12 %endif
13
14 Source0:    %{name}-%{version}.tar.gz
15
16 %description
17 Tizen Web UI Framework library and theme packages
18
19 %prep
20 %setup -q
21
22 %build
23 make all
24
25 %install
26 make DESTDIR=%{buildroot} install
27
28 %post
29
30 %files
31 /usr/share/tizen-web-ui-fw/*/js
32 /usr/share/tizen-web-ui-fw/latest
33
34 ###############################
35 %package -n web-ui-fw-theme-tizen-gray
36 BuildArch:  noarch
37 Summary:    Tizen Web UI Framework Theme : tizen-gray
38 %Description -n web-ui-fw-theme-tizen-gray
39     Tizen Web UI Framework Theme : tizen-gray
40
41 ###############################
42 %package -n web-ui-fw-theme-tizen-black
43 BuildArch:  noarch
44 Summary:    Tizen Web UI Framework Theme : tizen-black
45 %Description -n web-ui-fw-theme-tizen-black
46     Tizen Web UI Framework Theme : tizen-black
47 %files -n web-ui-fw-theme-tizen-black
48 /usr/share/tizen-web-ui-fw/*/themes/tizen-black
49
50 ###############################
51 %package -n web-ui-fw-theme-tizen-white
52 BuildArch:  noarch
53 Summary:    Tizen Web UI Framework Theme : tizen-white
54 %Description -n web-ui-fw-theme-tizen-white
55     Tizen Web UI Framework Theme : tizen-white
56 %files -n web-ui-fw-theme-tizen-white
57 /usr/share/tizen-web-ui-fw/*/themes/tizen-white
58
59 ###############################
60 %package -n web-ui-fw-theme-default
61 BuildArch:  noarch
62 Summary:    Tizen Web UI Framework Theme : default
63 %Description -n web-ui-fw-theme-default
64     Tizen Web UI Framework Theme : default
65 %files -n web-ui-fw-theme-default
66 /usr/share/tizen-web-ui-fw/*/themes/default
67
68 ###############################
69 %package -n web-ui-fw-devel
70 BuildArch:  noarch
71 Summary:    Tizen Web UI Framework Developer's files
72 %Description -n web-ui-fw-devel
73     Tizen Web UI Framework Developer's files
74 %files -n web-ui-fw-devel
75 /usr/share/tizen-web-ui-fw/bin
76 /usr/share/tizen-web-ui-fw/template
77
78 ###############################
79 %package -n web-ui-fw-demo-tizen-winsets
80 BuildArch:  noarch
81 Summary:    Tizen Web UI Framework Demo Application: tizen winset demo
82 %Description -n web-ui-fw-demo-tizen-winsets
83     Tizen Web UI Framework Demo Application: tizen winset demo
84 %files  -n web-ui-fw-demo-tizen-winsets
85 /usr/share/tizen-web-ui-fw/demos/tizen-winsets
86
87
88 ###############################
89 %changelog
90
91 * Mon Aug 27 2012 Jinhyuk Jun <jinhyuk.jun@samsung.com> 0.1.41
92 - FIX:
93     - radio/check button : button size bug fix
94
95 * Fri Aug 24 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.40
96 - FIX:
97         - build error fixed
98
99 * Fri Aug 24 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.39
100 - FIX:
101         - listview: style fix, remove filter placeholder
102         - controlbar: divide styles
103         - scrollview: don't skip dragging when click button or inputbox
104         - slider: trim the text on text slider
105 - Spec changes:
106         - remove gray and blue theme
107         - add white and black theme
108         - support new GUI guide
109
110 * Mon Aug 20 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.38
111 - FIX:
112         - fix coment of version tag
113
114 * Fri Aug 17 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.37
115 - FIX :
116         - button: fix alignment
117         - listview: adjust the main text width
118         - virtualgrid: refactoring
119 - Spec changes:
120         - transition: support JQM 1.1.0 transitions
121         - scrollview: support the outer scroll
122         - notification: remove interval feature
123
124 * Tue Aug 14 2012 Youmin Ha <youmin.ha@samasung.com> 0.1.36
125 - FIX :
126         - checkboxRadio: Add left/right padding
127         - button: custom button & icon position
128         - virtuallist: remove 'recreate' test
129 - Spec changes:
130         - header/footer: enable/disable support
131
132 * Fri Aug 10 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.35
133 - FIX :
134         - expandablelist: modify show animation
135         - virtualgrid: Redesign programming interface
136         - popupwindow: code clean and fixed issues
137         - pagelayout: fix content height
138         - license file update
139         - virtuallist: Change programming interface
140         - datetimepicker: getting days correctly
141         - searchbar: set to hidden when cancel button is hide
142         - White theme title font tuning
143 - Spec changes:
144         - default theme tizen-gray to tizen-white
145         - set default page transition to none
146
147 * Mon Aug 02 2012 Jinhyuk Jun <jinhyuk.jun@samsung.com> 0.1.34
148 - FIX :
149         - Back Button : enlarge backbutton click size for white theme
150 - Feature :
151         - Expandable List : Add refresh api
152 * Mon Aug 02 2012 Jinhyuk Jun <jinhyuk.jun@samsung.com> 0.1.33
153 - FIX :
154         - click event touch threshold tuning
155
156 * Mon Aug 02 2012 Jinhyuk Jun <jinhyuk.jun@samsung.com> 0.1.32
157 - FIX : 
158         - Add back button highlight effect for white theme
159
160 * Mon Aug 01 2012 Jinhyuk Jun <jinhyuk.jun@samsnug.com> 0.1.31
161 - FIX : 
162         - IME checkroutine update, improve relayout on resize event
163         - Add highlight effect for radio button list 
164         - Scrollview : fix condition of updatelayout event
165 - Feature : progressing : add show/hide api
166
167 * Mon Jul 27 2012 Koeun Choi <koeun.choi@samsung.com> 0.1.30
168 - FIX : virtuallist, virtualgrid: Clean up temporary jquery.template object to clear cache
169         add default theme option on buttonMarkup for tizen theme
170         [searchbar] first fix : focus/blur fixed
171         back button does not work when long press
172         scrollview: don't auto scrolling if resizing area is too large
173 - Feature : notification : add api to set the icon at tickernoti
174         demo : update the list sample demo
175         Support tizen default theme
176
177 * Mon Jul 23 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.29
178 - Improvements & Bugfixes
179    - HOTFIX: Revert template function with jquery.template
180
181 * Thu Jul 19 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.28
182 - Improvements & Bugfixes
183    - Fix #WEB-1028: memory leak on virtuallist/virtualgrid
184 - Spec changes
185    - $.tizen.loadTheme() function accepts theme name as arguement
186    - Scrollview supports 'updatelayout' callback
187
188 * Tue Jul 17 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.27
189 - Improvements & Bugfixes
190    - Revert 'preventing long-press popup' patch, to fix backbutton to work in SocialMagazine
191
192 * Tue Jul 17 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.26
193 - Improvements & Bugfixes
194    - Add tizen-white theme package, to make rpm build to be finished
195
196 * Tue Jul 17 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.25
197 - Improvements & Bugfixes
198    - Set 'slide' as default page transition effect, by JQM patch
199
200 * Fri Jul 13 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.24
201 - Improvements & Bugfixes
202    - Fix IME show/hide algorithm
203    - Fix error on virtualgrid: link _set_scrollbar_size() function to the one in virtuallist
204
205 * Wed Jul 11 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.23
206 - Improvements & Bugfixes
207    - Fix notification position
208    - Fix unit tests
209
210  Fri Jul 6 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.22
211 - Spec changes
212         - JQM 1.1 upgrade
213 - Improvements & Bugfixes
214         - Transform3D support on scrollview
215         - Page layout supports IME control
216         - Mapview supports pinch zoom on JQM 1.1
217         - Fix wrong character on button in minified version
218         - Virtualgrid supports scrollbar
219         - Lots of bugfixes
220
221 * Fri Jun 22 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.20
222 - Spec changes
223         - Support 'latest' version (by symlink) for tizen-web-ui-fw.js path.
224         - imageslider : supports 'resize' event.
225         - listview : listview has 1px padding-bottom.
226         - loader : Change global namespace, from S to $.tizen.
227         - loader : Move loadCustomGlobalizeCulture() into $.tizen.util namespace.
228 - Improvements & Bugfixes
229         - Scrollview : supports 'translate3d', instead of 'translate'.
230         - notification : reset timer when 'show' or 'refresh' event.
231         - JQM patch : Fix vclick event triggered twice.
232 - Etc.
233         - Add & fix unit tests.
234
235 * Thu Jun 14 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.19
236 - Spec changes
237         - mapview : new widget.
238         - notification : add .refresh() API.
239         - pagecontrol : add .value([val]) API, and change an attribute name 'data-initVal' to 'data-value'.
240 - Improvements & Bugfixes
241         - Support minified CSS.
242         - loader : Fix & refactor 'loading globalize culture file' routine.
243         - JQM Patch : Calculate min-height of window in javascript code, and remove predefined min-height value from CSS.
244         - Many more bugfixes.
245 - Etc.
246         - Add many unit tests.
247         - Fix test coverage instrumentation tool to work with current source code.