Export 0.1.63
[platform/framework/web/web-ui-fw.git] / packaging / web-ui-fw.spec
1 Name:       web-ui-fw
2 Version:    0.1.63
3 Release:    0
4 Summary:    Tizen Web UI Framework Library
5 Group:      Development/Other
6 License:    MIT
7 BuildArch:  noarch
8 BuildRequires:  make
9 BuildRequires:  nodejs
10 %ifarch %{arm}
11 BuildRequires:  nodejs-x86-arm
12 %endif
13
14 Source0:    %{name}-%{version}.tar.gz
15
16 %description
17 Tizen Web UI Framework library and theme packages
18
19 %prep
20 %setup -q
21
22 %build
23 make all
24
25 %install
26 make DESTDIR=%{buildroot} install
27
28 %post
29
30 %files
31 %manifest web-ui-fw.manifest
32 /usr/share/tizen-web-ui-fw/*/js
33 /usr/share/tizen-web-ui-fw/latest
34
35 ###############################
36 %package -n web-ui-fw-theme-tizen-gray
37 BuildArch:  noarch
38 Summary:    Tizen Web UI Framework Theme : tizen-gray
39 %Description -n web-ui-fw-theme-tizen-gray
40     Tizen Web UI Framework Theme : tizen-gray
41
42 ###############################
43 %package -n web-ui-fw-theme-tizen-white
44 BuildArch:  noarch
45 Summary:    Tizen Web UI Framework Theme : tizen-white
46 %Description -n web-ui-fw-theme-tizen-white
47     Tizen Web UI Framework Theme : tizen-white
48 %files -n web-ui-fw-theme-tizen-white
49 %manifest web-ui-fw-theme-tizen-white.manifest
50 /usr/share/tizen-web-ui-fw/*/themes/tizen-white
51 /usr/share/tizen-web-ui-fw/*/themes/tizen-tizen
52
53 ###############################
54 %package -n web-ui-fw-theme-default
55 BuildArch:  noarch
56 Summary:    Tizen Web UI Framework Theme : default
57 %Description -n web-ui-fw-theme-default
58     Tizen Web UI Framework Theme : default
59 %files -n web-ui-fw-theme-default
60 %manifest web-ui-fw-theme-default.manifest
61 /usr/share/tizen-web-ui-fw/*/themes/default
62
63 ###############################
64 %package -n web-ui-fw-devel
65 BuildArch:  noarch
66 Summary:    Tizen Web UI Framework Developer's files
67 %Description -n web-ui-fw-devel
68     Tizen Web UI Framework Developer's files
69 %files -n web-ui-fw-devel
70 /usr/share/tizen-web-ui-fw/bin
71 /usr/share/tizen-web-ui-fw/template
72
73 ###############################
74 %package -n web-ui-fw-demo-tizen-winsets
75 BuildArch:  noarch
76 Summary:    Tizen Web UI Framework Demo Application: tizen winset demo
77 %Description -n web-ui-fw-demo-tizen-winsets
78     Tizen Web UI Framework Demo Application: tizen winset demo
79 %files  -n web-ui-fw-demo-tizen-winsets
80 /usr/share/tizen-web-ui-fw/demos/tizen-winsets
81
82
83 ###############################
84 %changelog
85 * Fri Nov 23 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.63
86 - FIX:
87         - dayselector: fix size
88         - remove unised styles
89         - divider: set non-press effect to default option
90         - popupwindow: fix window closing failure
91         - handler: GUI implementation
92         - TC: fix unit TCs
93         - scrollview: fix padding size
94 - Spec changes:
95         - Remove color widgets
96         - add $.tizen.pkgVersion for SDK
97 - Etc.
98         - JSDuck documents
99
100 * Fri Nov 16 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.62
101 - FIX:
102         - Many winsets: Fix layout
103         - Footer: fix position to bottom
104 - Spec changes:
105         - Remove color widgets
106
107 * Fri Nov 09 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.61
108 - FIX:
109         - Many widgets: New UX 0.6 theme implementation
110         - widgetex: init speed up
111         - scrollview: fix scrollbar and scale animation
112         - scrollview: fix scroll position when updatelayout is triggered
113         - header/footer: make textselection disable, except input type="text"
114
115 * Wed Nov 07 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.60
116 - FIX:
117         - Remove tizen-black theme package description
118
119 * Tue Nov 06 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.59
120 - FIX:
121         - Fix theme name to meet the change of system theme name: white->tizen
122         - Popupwindow: fix left position
123         - Remove black theme
124         - footer: remove label, legend drawing
125 - Spec changes:
126         - UX guide v0.4 : button, layout
127
128 * Wed Oct 24 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.57
129 - FIX:
130         - expandablelist: icon color fix
131         - scrollview: Fix xy scroll
132         - footer: Remove dummy div
133         - Make string concatnation effective in inline-protos.sh
134 - Spec changes:
135         - refresh header/footer when drag&drop event is fired in GUI builder
136         - searchbar: delete cancel button
137         - don't trigger updatelayout event when keyup event comes
138
139 * Mon Oct 15 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.56
140 - FIX:
141         - Toggleswitch: Change event name from 'changed' to 'change'
142         - Notification: Revert interval feature
143
144 * Tue Oct 09 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.55
145 - FIX:
146         - Fix SMACK manifest bug (S1-9098)
147
148 * Fri Oct 05 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.54
149 - FIX:
150         - handler: don't append a handler if handler is not enabled
151         - scrollview: use static value
152         - datetimepicker: fix date-format HH display error
153 - ETC:
154         - provide jquery.min.js
155         - barlayout: codes clean
156         - remove unused file
157
158 * Wed Sep 26 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.53
159 - FIX:
160         - listview: change focused color
161         - multibuttonentry: code refactoring
162         - datetimepicker: modify date format when triggered date-changed event
163         - slider: fix the top of slider bar
164         - add event blocker when load a first page
165
166 * Fri Sep 21 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.52
167 - ETC.
168         - Move SMACK manifest files to the top SRCDIR
169
170 * Fri Sep 21 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.51
171 - FIX:
172         - Popup: Do not focus container
173         - Header: show backbutton when both tabbar and header are present together
174         - Multi button entry: text ellipsis, code refactoring
175
176 * Fri Sep 21 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.50
177 - ETC.
178         - Apply SMACK manifest
179
180 * Thu Sep 20 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.49
181 - FIX:
182         - JSLINT code clean-up
183         - scrollview: firefox support
184         - scrollview: fix finding slider handle
185         - list: tweak text ellipsis
186         - checkbox: fix selecting wrong label tag (N_SE-8370)
187         - imageslider: check parameter
188         - smallpopup: fix position
189         - searchbar: fix 'clear' button size
190 - Spec changes:
191         - scrollview: support outer scroll
192         - JQM: block click event only with the element that does preventdefault on vclick(N_SE-6090)
193         - remove S/W IME control
194
195 * Thu Sep 13 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.48
196 - FIX:
197         - Add missing icon: controlbar
198         - scrollview: tune scrolling animatio ninterval
199         - datetimepicker: digit/triangle position
200         - datetimepicker: fix day overflow issue
201 - Spec changes:
202         - scrollview: show scrollbar when page is showed
203         - scrollview: disable outer scroll
204         - extendablelist: change api with legacy support
205         - add ui-text-ellipsis class
206
207 * Mon Sep 10 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.47
208 - FIX:
209         - scrollveiw: fix height of view
210         - searchbar: support placeholder
211 - Spec changes:
212         - add ui-text-ellipsis class
213
214 * Fri Sep 07 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.46
215 - FIX:
216         - scrollview: scrolling bug fix
217         - controlbar: fix width of controlbar item
218 - Spec changes:
219         - searchbar: don't hide icon
220         - popup: update JQM poup widget
221
222 * Fri Sep 05 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.45
223 - FIX:
224         - controlbar: set correct controlbar width of last element
225         - slider: get popup enable value correctly
226         - use Date.now() instead of (new Data()).getTime()
227         - popupwindow: fix the background color of popup scroller
228         - listview: add padding-left to expandable list
229         - add ellipsis for title area support
230
231 * Fri Aug 31 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.44
232 - FIX:
233         - swipelist: show list items correctly
234         - datetimepicker: set last day, if day is overflowed
235 - Spec changes:
236         - controlbar: update icons
237
238 * Tue Aug 29 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.43
239 - FIX:
240         - notification: fix typo
241 - Spec changes:
242         - controlbar: update icons
243
244 * Tue Aug 28 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.42
245 - FIX:
246         - multimediaview: video progress bar display normally for too samll
247         - segmentcontrol: remove media query
248         - scrollview: add outer scroll condition
249         - datetimepicker: modify triangle size
250         - popupwindow: set the screen height explicitly
251         - notification: add multiline text
252 - Spec changes:
253         - mutibuttonentry: support new GUI
254         - virtualgrid: support new GUI
255
256 * Mon Aug 27 2012 Jinhyuk Jun <jinhyuk.jun@samsung.com> 0.1.41
257 - FIX:
258         - radio/check button : button size bug fix
259
260 * Fri Aug 24 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.40
261 - FIX:
262         - build error fixed
263
264 * Fri Aug 24 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.39
265 - FIX:
266         - listview: style fix, remove filter placeholder
267         - controlbar: divide styles
268         - scrollview: don't skip dragging when click button or inputbox
269         - slider: trim the text on text slider
270 - Spec changes:
271         - remove gray and blue theme
272         - add white and black theme
273         - support new GUI guide
274
275 * Mon Aug 20 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.38
276 - FIX:
277         - fix coment of version tag
278
279 * Fri Aug 17 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.37
280 - FIX :
281         - button: fix alignment
282         - listview: adjust the main text width
283         - virtualgrid: refactoring
284 - Spec changes:
285         - transition: support JQM 1.1.0 transitions
286         - scrollview: support the outer scroll
287         - notification: remove interval feature
288
289 * Tue Aug 14 2012 Youmin Ha <youmin.ha@samasung.com> 0.1.36
290 - FIX :
291         - checkboxRadio: Add left/right padding
292         - button: custom button & icon position
293         - virtuallist: remove 'recreate' test
294 - Spec changes:
295         - header/footer: enable/disable support
296
297 * Fri Aug 10 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.35
298 - FIX :
299         - expandablelist: modify show animation
300         - virtualgrid: Redesign programming interface
301         - popupwindow: code clean and fixed issues
302         - pagelayout: fix content height
303         - license file update
304         - virtuallist: Change programming interface
305         - datetimepicker: getting days correctly
306         - searchbar: set to hidden when cancel button is hide
307         - White theme title font tuning
308 - Spec changes:
309         - default theme tizen-gray to tizen-white
310         - set default page transition to none
311
312 * Mon Aug 02 2012 Jinhyuk Jun <jinhyuk.jun@samsung.com> 0.1.34
313 - FIX :
314         - Back Button : enlarge backbutton click size for white theme
315 - Feature :
316         - Expandable List : Add refresh api
317 * Mon Aug 02 2012 Jinhyuk Jun <jinhyuk.jun@samsung.com> 0.1.33
318 - FIX :
319         - click event touch threshold tuning
320
321 * Mon Aug 02 2012 Jinhyuk Jun <jinhyuk.jun@samsung.com> 0.1.32
322 - FIX : 
323         - Add back button highlight effect for white theme
324
325 * Mon Aug 01 2012 Jinhyuk Jun <jinhyuk.jun@samsnug.com> 0.1.31
326 - FIX : 
327         - IME checkroutine update, improve relayout on resize event
328         - Add highlight effect for radio button list 
329         - Scrollview : fix condition of updatelayout event
330 - Feature : progressing : add show/hide api
331
332 * Mon Jul 27 2012 Koeun Choi <koeun.choi@samsung.com> 0.1.30
333 - FIX : virtuallist, virtualgrid: Clean up temporary jquery.template object to clear cache
334         add default theme option on buttonMarkup for tizen theme
335         [searchbar] first fix : focus/blur fixed
336         back button does not work when long press
337         scrollview: don't auto scrolling if resizing area is too large
338 - Feature : notification : add api to set the icon at tickernoti
339         demo : update the list sample demo
340         Support tizen default theme
341
342 * Mon Jul 23 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.29
343 - Improvements & Bugfixes
344    - HOTFIX: Revert template function with jquery.template
345
346 * Thu Jul 19 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.28
347 - Improvements & Bugfixes
348    - Fix #WEB-1028: memory leak on virtuallist/virtualgrid
349 - Spec changes
350    - $.tizen.loadTheme() function accepts theme name as arguement
351    - Scrollview supports 'updatelayout' callback
352
353 * Tue Jul 17 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.27
354 - Improvements & Bugfixes
355    - Revert 'preventing long-press popup' patch, to fix backbutton to work in SocialMagazine
356
357 * Tue Jul 17 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.26
358 - Improvements & Bugfixes
359    - Add tizen-white theme package, to make rpm build to be finished
360
361 * Tue Jul 17 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.25
362 - Improvements & Bugfixes
363    - Set 'slide' as default page transition effect, by JQM patch
364
365 * Fri Jul 13 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.24
366 - Improvements & Bugfixes
367    - Fix IME show/hide algorithm
368    - Fix error on virtualgrid: link _set_scrollbar_size() function to the one in virtuallist
369
370 * Wed Jul 11 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.23
371 - Improvements & Bugfixes
372    - Fix notification position
373    - Fix unit tests
374
375  Fri Jul 6 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.22
376 - Spec changes
377         - JQM 1.1 upgrade
378 - Improvements & Bugfixes
379         - Transform3D support on scrollview
380         - Page layout supports IME control
381         - Mapview supports pinch zoom on JQM 1.1
382         - Fix wrong character on button in minified version
383         - Virtualgrid supports scrollbar
384         - Lots of bugfixes
385
386 * Fri Jun 22 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.20
387 - Spec changes
388         - Support 'latest' version (by symlink) for tizen-web-ui-fw.js path.
389         - imageslider : supports 'resize' event.
390         - listview : listview has 1px padding-bottom.
391         - loader : Change global namespace, from S to $.tizen.
392         - loader : Move loadCustomGlobalizeCulture() into $.tizen.util namespace.
393 - Improvements & Bugfixes
394         - Scrollview : supports 'translate3d', instead of 'translate'.
395         - notification : reset timer when 'show' or 'refresh' event.
396         - JQM patch : Fix vclick event triggered twice.
397 - Etc.
398         - Add & fix unit tests.
399
400 * Thu Jun 14 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.19
401 - Spec changes
402         - mapview : new widget.
403         - notification : add .refresh() API.
404         - pagecontrol : add .value([val]) API, and change an attribute name 'data-initVal' to 'data-value'.
405 - Improvements & Bugfixes
406         - Support minified CSS.
407         - loader : Fix & refactor 'loading globalize culture file' routine.
408         - JQM Patch : Calculate min-height of window in javascript code, and remove predefined min-height value from CSS.
409         - Many more bugfixes.
410 - Etc.
411         - Add many unit tests.
412         - Fix test coverage instrumentation tool to work with current source code.