Merge branch 'master' into tizen_2.1
[platform/framework/web/web-ui-fw.git] / packaging / web-ui-fw.spec
1 Name:       web-ui-fw
2 Version:    0.2.25
3 Release:    0
4 Summary:    Tizen Web UI Framework Library
5 Group:      Development/Other
6 License:    MIT
7 BuildArch:  noarch
8 BuildRequires:  make
9 BuildRequires:  nodejs
10 %ifarch %{arm}
11 BuildRequires:  nodejs-x86-arm
12 %endif
13
14 Source0:    %{name}-%{version}.tar.gz
15
16 %description
17 Tizen Web UI Framework library and theme packages
18
19 %prep
20 %setup -q
21
22 %build
23 make all
24
25 %install
26 make DESTDIR=%{buildroot} install
27
28 %post
29
30 %files
31 %manifest web-ui-fw.manifest
32 /usr/share/tizen-web-ui-fw/*/js/*.js
33 /usr/share/tizen-web-ui-fw/*/js/cultures
34 /usr/share/tizen-web-ui-fw/latest
35 /usr/share/tizen-web-ui-fw/VERSION
36
37 ###############################
38 %package -n web-ui-fw-theme-tizen-gray
39 BuildArch:  noarch
40 Summary:    Tizen Web UI Framework Theme : tizen-gray
41 %Description -n web-ui-fw-theme-tizen-gray
42     Tizen Web UI Framework Theme : tizen-gray
43     Deprecated package, but some binaries still refer this.
44
45 ###############################
46 %package -n web-ui-fw-theme-tizen-white
47 BuildArch:  noarch
48 Summary:    Tizen Web UI Framework Theme : tizen-white
49 %Description -n web-ui-fw-theme-tizen-white
50     Tizen Web UI Framework Theme : tizen-white
51 %files -n web-ui-fw-theme-tizen-white
52 %manifest web-ui-fw-theme-tizen-white.manifest
53 /usr/share/tizen-web-ui-fw/*/themes/tizen-white
54 /usr/share/tizen-web-ui-fw/*/themes/tizen-tizen
55
56 ###############################
57 %package -n web-ui-fw-theme-tizen-black
58 BuildArch:  noarch
59 Summary:    Tizen Web UI Framework Theme : tizen-black
60 %Description -n web-ui-fw-theme-tizen-black
61     Tizen Web UI Framework Theme : tizen-black
62 %files -n web-ui-fw-theme-tizen-black
63 %manifest web-ui-fw-theme-tizen-black.manifest
64 /usr/share/tizen-web-ui-fw/*/themes/tizen-black
65
66 ###############################
67 %package -n web-ui-fw-theme-default
68 BuildArch:  noarch
69 Summary:    Tizen Web UI Framework Theme : default
70 %Description -n web-ui-fw-theme-default
71     Tizen Web UI Framework Theme : default
72 %files -n web-ui-fw-theme-default
73 %manifest web-ui-fw-theme-default.manifest
74 /usr/share/tizen-web-ui-fw/*/themes/default
75
76 ###############################
77 %package -n web-ui-fw-devel
78 BuildArch:  noarch
79 Summary:    Tizen Web UI Framework Developer's files
80 %Description -n web-ui-fw-devel
81     Tizen Web UI Framework Developer's files
82 %files -n web-ui-fw-devel
83 /usr/share/tizen-web-ui-fw/bin
84 /usr/share/tizen-web-ui-fw/template
85 /usr/share/tizen-web-ui-fw/*/js/src
86 /usr/share/tizen-web-ui-fw/*/js/depData.json
87
88 ###############################
89 %package -n web-ui-fw-demo-tizen-winsets
90 BuildArch:  noarch
91 Summary:    Tizen Web UI Framework Demo Application: tizen winset demo
92 %Description -n web-ui-fw-demo-tizen-winsets
93     Tizen Web UI Framework Demo Application: tizen winset demo
94 %files  -n web-ui-fw-demo-tizen-winsets
95 /usr/share/tizen-web-ui-fw/demos/tizen-winsets
96
97
98 ###############################
99 %changelog
100 * Tue Apr 18 2013 Youmin Ha <youmin.ha@samsung.com> 0.2.25
101         - Pinch: pinch event re-implementation to use size
102         - Pagelayout : prevent code inserting window.innerHeight when content calculate
103         - BlachTheme : add missing icon (SIP down)
104         - Scrollview : support absolute position
105         - tizen-winsets: change the font-family in virtualgrid demo to default
106         - TizenWinset : Change default font
107         - tizen-winsets: Change image link
108         - tizenwinset: change images for virtual grid pages
109
110 * Tue Apr 16 2013 Youmin Ha <youmin.ha@samsung.com> 0.2.24
111         - SegmentControl: 2-buttons display issue (N_SE-34200)
112         - Naviframe : remove unnecessary img positioning(N_SE-33969)
113         - Gallery: jslint error fix
114         - TizenWinset : remove landscape SIP on mode
115         - Tizen Black Theme png file changed
116         - Gallery: Images showing bug has been fixed
117         - Scrollview : change horizontal scrollview demo(N_SE-33997)
118         - Tizenwinset: added return false in popup sample
119         - Naviframe : support data-role="button" in header
120         - Additional UnitTC: tizen winset unit tc bugs have been fixed
121         - Checkbox : remove favorite button's display:block(N_SE-33896)
122         - UnitTC: QUnit path has been changed. Priority, function type check function has been added
123         - Tizen-winset : Footer changed from lower case to upper case.
124         - Slider: enhance performance fix
125         - UnitTC: Addtional unit tc ref path has been fixed
126         - virtualgrid: apply overscrolling images to the style of widget
127         - Tabbar : Change overscroll image(left/right)
128         - ensurens: optimizations
129         - ensurens: qunit tests
130         - Tokentextarea: Fix block size error
131         - Fastscroll: Add a feature to fade out Fastscroll widget.
132         - Fastscroll: Add a user interaction at the omitted items.
133         - ImageLoader: Performance fix: apply lazy loading for canvas element
134         - Tests: Add tests for $.imageloader
135         - SegmentControl: 2-buttons display issue (N_SE-34200)
136         - virtuallist: fix width resizing trigger
137         - Timepicker: timepicker is closed when orientationchange event fired
138         - TizenWinset : Tabbar-persist issue.(N_SE-33996)
139         - Add Flora license
140         - collapsible: Fix collapsible list animation bug
141
142 * Wed Apr 10 2013 Youmin Ha <youmin.ha@samsung.com> 0.2.23
143         - Naviframe : modify SIP down button's position
144         - Core: Performance fix for disableSelection and enableSelection
145         - Tests: Core tests for disableSelection
146         - patch: fix small mistakes on the patches
147         - virtuallist: Change demo button style
148         - Button: btn-icon only css has been changed
149         - loader: Fix screen-width option processing
150         - pagelayout: Remember back key when it is hidden
151         - Tizen Black Theme : Tizen black theme png file changed.
152         - UnitTC: tizen winset unit tc bugs have been fixed
153         - TizenWinset: Swipe list sample has been fixed
154         - Radio : remove default radio's width(N_SE-33579)
155         - Scrollview : divide x/y overflow attribute
156         - Gallery: orientation image showing issue has been fixed
157         - Gallery: remove method bug has been fixed
158         - virtualgrid : fix unit-test error and increase test items
159         - Gallery3d: Modify demo & source codes for visibility enhancement.
160         - Gallery3d: Reduce loading time of widget
161         - Gallery3d: Change files' format to unix
162         - Contextpopup: context popup close when window resize event fire
163         - Popup: reverse orientation bug has been fixed
164         - Tokentextarea: modify description
165         - Multimediaview: modify description
166         - JQM: Do not add ui-btn-icon-only class at the select button
167         - build: tizen-black theme package
168         - Tizenwinset: popup script has been removed
169         - Tizenwinset: substring split view text message
170         - Timepicker: data-changed event will be deprecated
171
172 * Fri Apr 5 2013 Youmin Ha <youmin.ha@samsung.com> 0.2.22
173         - tizen-winsets: Fix demo menu
174         - Tizenwinset: Reorder tizenwinset menu
175         - SearchBar: Header button size issue has been fixed
176         - Swipe: list item overflow: hidden has been added
177         - Tizenwinset: href has been added in grouped list
178         - Tizenwinset: Page transition page has been added
179         - Tizenwinset: Radio description has been fixed
180         - This patch fixes problem when base url is changed when site is prefetched.
181         - Entry : limit textarea's width (N_SE-28653)
182         - Naviframe : hide backbutton in case SIP up(remove backbutton makes problem in binding event)
183         - Gallery : next, prev images position bug has been fixed
184         - Multimediaview: Fix display error while handling orientationchange event.
185         - Pagelayout : modify innerHeight dpr calculation in non scrollview mode
186         - Datetimepicker: picker position has been fixed when browser resize event fired
187         - Tips: generate elements sample page javascript has been fixed
188         - Tokentextarea: Fix Tizen-winsets demo.
189
190 * Wed Apr 3 2013 Youmin Ha <youmin.ha@samsung.com> 0.2.21
191         - VirtualGrid: Fix errors on centerTo and resize methods
192         - loader: Fix default font size at device-width viewport
193         - scrollview : remove overflow-x property
194         - Naviframe : fix backbutton position/ change down button icon
195         - Naviframe : bug fix
196         - Tizenwinset : Tizen-winset demo page titles changed Tizen-winset demo page titles changed from lower case to upper case.
197
198 * Fri Mar 29 2013 Youmin Ha <youmin.ha@samsung.com> 0.2.20
199         - JQM Navigation : remove page min-height
200         - Pagelayout : add refresh to pagelayout
201         - Tokentextarea: Changes 'remove' tests to asyncTest
202         - Popup: input tag alignment has been fixed
203         - Tokentextarea: add/remove events are deprecated.
204         - Contextpopup: Support horizontal list
205         - Select: icon z-index has been deleted
206         - Tizenwinset: ui widget order has been changed
207         - Tool: make web app template disable context menu by default
208         - Tizen-winset: change tips for using listview
209         - Loader: calculate font size with mobile width
210         - Naviframe : fix header's back button position
211         - TizenWinset : move locale info to another file
212
213 * Fri Mar 22 2013 Youmin Ha <youmin.ha@samsung.com> 0.2.19
214         - Tizen-winset: Support accessibility for tizen-winset
215         - Orientation : add orientataionchange to tizen-winset
216         - Tokentextarea: Adjusts VI effect for add/remove block
217         - splitview: Support accessibility for splitview
218         - Tizen-winset: Date/time picker guide text has been fixed
219         - Popup: context popup arrow position, setTimeout open method bug have been fixed
220         - fastscroll: Add new indexString API to Fastscroll widget.
221         - splitview: Add new widget
222         - gallery3d: Add new widget
223         - Scrollview : disable VI effect for gesture event
224         - Scrollview : disable SIP outerscroll
225         - Tizen-winset: resize VirtualGrid widget in demo
226         - Tizen-winsets: Refactor searchbar subpages
227         - Tizen-winsets: Remove depracated usage of virtuallist
228         - Tizen-winsets: Move js code from main.js to subpages
229         - Tizen-winsets: Refactor virtual grid demo subpages
230         - Tizen-winsets: Move css files from index to proper subpages
231         - Tizen-winsets: Refactor list dialogue edit subpage
232         - Tizen-winsets: Refactor pagelayout subpages
233         - Tizen-winsets: Refactor tips subpages
234         - Tizen-winsets: Move subpages popup files from index.html
235         - Tizen-winsets: Move subpages javascript files from index.html
236         - virtualgrid: fix improperly merged codes
237         - ColorTheme : remove unused color value(1st)
238         - Scrollview : change scrollbar draw
239         - Popup: Apply popup background dim
240         - Tizen-winsets: Move tokentextarea demo to external page.
241         - Tizen-winsets: Move tabbar persist demo to external page.
242         - Tizen-winsets: Remove notImplemented page
243         - Tizen-winsets: Move slider demo page to external subpage
244         - Tizen-winsets: Fix ids, remove duplicated names for sliders
245         - Tizen-winsets: Remove event for changing theme
246         - tool: Fix wgt sample app generator tool to make apps be installed
247         - demos : change live to on
248         - build: Trim compiled CSS files
249         - Gallery: CSS left -> translate or translate3D
250         - Tokentextarea: Disfunctional APIs fixed.
251
252 * Thu Mar 7 2013 Youmin Ha <youmin.ha@samsung.com> 0.2.18
253         - build: Fix Makefile to add globalize to the minified lib
254         - build-tools : upgrade less to v1.3.3
255         - demos : change normal js path to minified js
256         - Theme : remove reduantant less - dayselector, optionheader, nocontents
257         - multimediaview : fix full-screen mode.
258         - multimediaview : fix 'width', 'height' and 'fullScreen' methods
259         - Extendablelist: Added min-height "load more button" in listitem
260         - virtualgrid: adjusts VI effect for an overflow action
261         - ControlGroup : change ellipsis font color (press/normal)
262         - multimediaview: Add an error message to Multimediaview
263         - virtualgrid: adjusts triple flick gesture
264         - scrollview: add function for getting width of view
265         - scrollview: adds support x axis gesture scroll
266         - multimediaview : fix audio control
267         - tabbar : tabbar slide animation change
268         - TizenWinsetDemo : 2line-text demo bug fix
269         - collapsible: Fix demo to show radio button correctly in the collapsible list
270         - collapsible: Set listitem position to relative
271         - UnitTC: added list divider unit test
272         - Style: unnecessary color codes have been deleted and modified
273         - build: Module build implementation
274         - UnitTC: Additional unit testcases have been added
275         - listview : bug fix
276         - Naviframe : remove back button's hover effect
277         - TizenDemo : remove back button
278         - Transition: added more-button vi
279         - pinch: added new event called pinch
280         - Popup: css word-wrap:break-word has been added
281         - virtualgrid: memory leak fix
282         - progress: set to init state at pending bar
283         - progress: add margin of top/bottom
284         - unit-test: split progress test and progressbar test
285         - Tizen-winset: Context popup sample page guide text has been changed
286         - multimediaview: fix the height of widget when full-screen mode
287         - JQM: performance tuning
288
289 * Tue Feb 19 2013 Minkyu Kang <mk7.kang@samsung.com> 0.2.17
290         - DialogueList : delete border top value / add sample's text ellipsis
291         - Tokentextarea: Add scroll-to-top for Grouping On/Off regarding #N_SE-24877
292         - Multimediaview: Fix mute function
293         - Tizen-winset: list vi index guide textbox has been removed
294         - Tizen-winset: custom button texts have been changed
295         - slider: move popup div to out of content
296         - TizenWinset: disable context popup in multimediaview
297         - Swipe: wrong style name has been fixed
298         - demo: add the sample at dialogue list
299         - listview: Add ui-li-has-right-btn class with toggleswitch
300         - WinsetDemo : change wrong title name
301
302 * Mon Jan 28 2013 Youmin Ha <youmin.ha@samsung.com> 0.2.16
303         - demo: checkbox: reduce button's width
304         - tabbar : delete right/left tab animation color
305         - scrollview: fix the scroll position at keydown event
306         - groupControl : change footer groupControl from min-width to percentage
307         - scrollview: get height of softkeyboard correctly
308         - tizen-winset: Add name attr to all radio inputs
309         - virtualgrid: changes event binding target
310         - scrollview: skip the drag if target is textarea
311         - scrollview: skip the dragging of parent scrollview
312         - scrollview: apply the scaling ratio to the soft keyboard
313         - demos: apply disabled option in textarea
314         - demo: remove unused codes
315         - demo: datetimepicker: show selected date correctly
316         - listview: Adjust bubble listitem width and margin
317         - pagelayout : change external refresh call and ime status follow only current page
318         - toggleSwitch : bug fix
319         - unit-test: slider: fix the move test
320         - handler: fix jslint error
321         - ToggleSwitch : set image toggleswitch background attribute
322
323 * Mon Jan 28 2013 Youmin Ha <youmin.ha@samsung.com> 0.2.15
324         - slider: increase the text width(N_SE-23397)
325         - virtualgrid: DOM element leak fix
326         - header: Move button top higher in header with tabbar(N_SE-22253)
327         - datatimepicker: don't open the popup before popupafterclose event is fired(N_SE-23027)
328         - handler: bug fix (regarding enableHandler function )
329         - demo:fix syntax error
330
331 * Sat Jan 26 2013 Youmin Ha <youmin.ha@samsung.com> 0.2.14
332         - demo: fix demo using tizen device API
333         - multimediaview: reset the height of container
334         - input: modify css correctly
335         - multimediaview: fix the height of widget
336         - gallery: bind create event
337         - progress: bind create event
338         - slider: bind create event
339         - progressbar: bind create event
340         - progressbar: event trigger correctly
341         - popup: fix height of popup scroller
342         - build: add continue option to jslint
343         - ctxpopup demo : bug fix
344         - demo: fix searchbar demo to use different IDs
345         - demo: extract routine executing Tizen device API
346         - toggleswitch : set default margin, delete box padding
347
348 * Thu Jan 24 2013 Youmin Ha <youmin.ha@samsung.com> 0.2.13
349         - virtuallist: Prevent replacing contents on nonexist element
350         - JQM: Trim text in listitem to get index in autodivider
351         - JQM: Remove trailing whitespace in jqm patch
352         - scrollview: get the height including margin
353         - multimediaview: bug fix ( scrolling in full-screen mode )
354         - virtuallist: set listitem width to exclude listitem left/right margin
355         - demo: fix virtuallist sample layout
356         - progress: set the position explicitly
357         - progress: rename from progressing to progress
358         - build: remove unused files
359         - searchbar: fix jslint errors
360         - src: fix file permissions
361         - button : change jump left icon
362
363 * Wed Jan 23 2013 Minkyu Kang <mk7.kang@samsung.com> 0.2.12
364         - theme : button icon - scrolltop, scrolleft icon changed.
365         - build: cleanaup Makefile
366         - pagelayout: fix jslint error
367         - virtualgrid: Fix jslint errors
368         - tabbar : jslint bug error fix
369         - build: add regexp option to jslint
370         - virtuallist: fix jslint errors
371         - handler: Apply the exceptional principle for scrollbar on Handler.
372         - build: remove unused copyright
373         - loader: extract log class for tizen web, and fix jslint errors
374         - loader: Viewport width is set to document width
375         - popupwindow: fix jslint error
376         - build: fix Makefile for tizen-white theme
377         - build: remove unused libraries
378         - datetimepicker: fix jslint error
379         - slider: fix jslint error
380         - demo: remove deprecated demos
381         - pagelayout : change to call relayout with this page
382         - Tokentextarea: Block size error fixed.
383         - handler: bug fix (handler activation)
384
385 * Tue Jan 22 2013 Minkyu Kang <mk7.kang@samsung.com> 0.2.11
386         - demo: clear input text value with cancel button click
387         - demo: Adjust textarea height automatically
388         - naviframe : bug fix
389         - tabbar : bug fix
390         - Fastscroll: popup position has been changed
391         - Button: custom button icon path, margin have been changed
392         - toggleswitch : bug fix
393         - slider: increase the margin
394         - datetimepicker: close the popup after select the value
395         - unit-test : add page backbutton control test
396         - Demo: added guide text and change input type in list vi
397         - remove legacy codes : jquery-geo
398         - Datetimepicker: text-main max-width has been removed
399         - Radio: control group border has been removed
400         - Demo: remove 'tab' space
401         - UnitTC: swipe unit tc has been fixed
402         - UnitTC: jQuery path has been fixed
403         - Button: bug fix when button has not a text
404         - tizen-winset: timepicker: demo title is changed
405
406 * Fri Jan 18 2013 Minkyu Kang <mk7.kang@samsung.com> 0.2.10
407         - tizen-winsets: codes cleanup
408         - datetimepicker: date calibration when year is changed
409         - Demo: textarea size has been changed
410         - Demo: Naviframe morebutton demo has been changed
411         - remove unused unit test cases : gallery3d
412         - tizen-winset: remove links
413
414 * Thu Jan 17 2013 Minkyu Kang <mk7.kang@samsung.com> 0.2.9
415         - gallery: use timeout function instead of interval
416         - Tokentextarea: Display error fixed.
417         - scrollview: Fix not selector to respond with jQuery1.8.2
418         - tabbar: remove the width of last element
419         - Demo: apply css 'user-select:none'
420         - Button: guide text has been shorten
421         - build: Update jQuery to 1.8.2 (JQM1.2 compliant)
422         - virtuallist: Fix mistyping
423         - demo: Fix tizen function namespace in demo
424         - virtuallist: Rewrite listitem replacing algorithm
425         - fastscroll: modify from not selector to function
426         - extendablelist: Fix unit-test
427         - tabbar : prefix to tabbar scroll event
428         - Popupwindow: removed unvalid selector in jquery 1.8.2
429         - slider: adjust handle text as length of value
430         - Demo: 3 buttons in popup text has been changed
431         - src: codes cleanup
432         - demo : remove trailing empty strings
433         - demo : rename TizenWinset list items
434         - button : change from long text list to multiline list
435         - build: Remove JQM1.1.0 patches
436         - Popup: Apply tizen style popup and attribute support
437         - JQM: Fix buttonmarkup bug keeping ui-btn-down class
438         - UnitTest: folder and file renamed, QUnit path was modified
439         - tizen-winsets: button: fix textarea width
440         - Swipe: event name error has been fixed
441
442 * Tue Jan 15 2013 Minkyu Kang <mk7.kang@samsung.com> 0.2.8
443         - Button: button padding has been updated
444         - virtuallist: fix unique listitem ID bug
445         - checkbox, radio : change display attr
446         - Button: bug fix ( when data style circle button on text )
447         - handler: bug fix (when scrolling with multi selection)
448         - JQM: adjust patch number
449         - gallery: show the widget after pageshow
450         - TokenTextArea : resource add ( press image )
451         - gallery: adds function that set the index to value API
452         - configure: set TIZEN default configures
453         - footer: h tag display attribute value has been changed
454         - buttons : demo bug fix
455         - searchbar : demo page bug fix
456         - tizen demo : bug fix
457         - build: remove JQM1.1.0
458         - Tokentextarea: Fix issues
459         - scrollview: block the multi touch
460         - list : dialogue list demo change
461         - pagelayout : update dynamic control
462         - Demo: Context popup close method has been changed
463
464 * Fri Jan 11 2013 Minkyu Kang <mk7.kang@samsung.com> 0.2.7
465         - slider: set text container's width as text length
466         - Timepicker: li max-width has been changed
467         - remove experimental feature - mapview.
468         - scrollview: added conditions for finding slider
469         - UnitTC: Pass,error count save method has been changed
470         - confix.xml: default config added for tizen basic applications
471         - Swipe: p tag margin value is set '0'
472         - packaging: remove unused file
473         - tabbar : bug fix
474         - list demo : bug fix
475         - tizen-winsets: gallery: move to new section
476         - tizen-winsets: autodivider: removes link of list
477         - demos: entry of number-pattern name is changed from 'number' to 'number-pattern'
478         - pagelayout : padding calculate change, ime footer check changed
479         - tizen-winsets: searchbar: scroll to the top when type the character
480         - searchbar : bug fix
481         - demo: Fix virtuallist demo following new list style
482         - demo: Add word-wrap:break-word and remove parag. width
483         - Demo: button max-width has been set( 3 buttons in popup )
484         - back button control demo : bug fix
485         - toggleswitch : demo page modify
486         - slider: add margin-top and margin-bottom
487         - tabbar demo : bug fix
488         - Popup: IME hide when popup is closed
489         - token textarea : bug fix
490         - Timepicker: change get attribute method
491         - footer demo : bug fix
492         - unit-test: gallery: add new APIs
493         - gallery: adds support new APIs
494
495 * Fri Jan 04 2013 Minkyu Kang <mk7.kang@samsung.com> 0.2.6
496         - JQM: patches cleanup
497         - Button: data-corners attribute has been added
498         - unit-test: slider: fix class name of background
499         - progressbar, slider: fix less variable typo
500         - Tabbar : VI update
501         - notification: add top position at fix class
502         - demo: entry demo page change
503         - css: .ui-disabled added
504         - tizen-winset: token textarea: remove back button at demo page
505         - theme: Remove unused less file
506         - pagelayout : content min height bug fix
507         - scrollview: skip the dragging when target is slider's handle
508         - scrollview: update and refactoring the scroll effect
509         - UnitTest:JQM Unit TC helper has been added,TCs have been modified
510         - Swipe: demo page html error has been fixed
511         - listview: Add add/delete animation (VI)
512         - Popup: demo page has been modified
513         - tizen demo : bug fix
514         - searchbar : demo page change(change front button and add behaviour)
515         - pagelayout : add min height to content
516         - gallery: rename 'Image Slider' to 'Gallery' in tizen-winsets demo and tests
517         - back button control demo : change url link to data-rel="back"
518         - loader: Skip loading theme CSS with a custom css code
519         - Button: support no-text in button
520         - collapsible: Fix syntax error
521         - slider: use data-highlight attribute
522         - collapsible: Rotate animation to collapsible heading icon
523         - toggleswitch : text switch bug fix
524         - remove candidates-calendarpicker
525         - Patch: Fix misc mistakes in JQM patches
526         - searchbar : animation change
527         - gallery: get the width correctly
528         - demo: data-framework-viewport-scale attribute is changed to data-framework-viewport-width
529         - collapsible: Add collapse/expand animation (VI)
530         - datetimepicker: VI update
531         - JQM: set transition to pop as default
532         - tabbar : bug fix in case none li element case
533         - scrollview: fix the drag bug
534         - Button: Button icon scrolltop, left has beed added
535         - Swipe: VI update and swipe speed has been changed
536         - jqm: fix errors in patch files
537         - unit-test: swipe: fixed the destroy test
538
539 * Wed Dec 26 2012 Youmin Ha <youmin.ha@samsung.com> 0.2.5
540         - Revert "[checkboxradio] exception handling for input"
541                 This reverts commit 72478c32704fa96362db577e6cf9511777919ea8.
542                 Tizen style supports no-label radio and checkbox when making lists.
543                 So it ignores html input operation. Instead, it supports tizen style radio and checkbox theme.
544
545 * Thu Dec 20 2012 Youmin Ha <youmin.ha@samsung.com> 0.2.4
546 - Fix:
547         - modify segment background
548         - rearrange check, radio input
549         - CtxPopup: Scale up/ down popup vi(poptop, popbottom)
550         - button: style has beed added(box,circle,nobg,round)
551         - favorite resource added
552         - demo/tizen-winsets: add footer and back button
553         - remove autodividers unit test
554         - add divider for tabbar
555         - checkboxradio: exception handling for input
556         - segment control backward compatiblity
557         - Fix collapsible unit-test
558         - remove toggleswitch
559         - add patch for remove segment text
560 - Spec changes:
561         - replace controlbar to tabbar
562
563 * Fri Dec 14 2012 Minkyu Kang <mk7.kang@samsung.com> 0.2.3
564 - FIX:
565         - slider: add image
566         - button: data-icon support, styles fix
567         - progressbar: modify the background
568         - scrollview: auto scrolling bug fix
569         - pagelayout: IME concept is changed
570 - Spec changes:
571         - dialogue: add edit mode
572         - nocontents: removed
573         - pagecontrol: removed
574         - dayselector: removed
575         - expandablelist: removed
576
577 * Thu Dec 10 2012 Youmin Ha <youmin.ha@samsung.com> 0.2.2
578 - FIX:
579         - chang searchbar/slider images
580         - delete redundant button images
581 - Spec changes:
582         - Change widget name: shortcutscroll -> fastscroll
583
584 * Thu Dec 07 2012 Youmin Ha <youmin.ha@samsung.com> 0.2.1
585 - FIX:
586         - jqm1.2: Change collapsible style to meet expandable list
587         - remove jquery-geo-1.0.a4
588         - unit-test: rename from imageslider to gallery
589         - nocontent: add warning message
590         - Handler: Fix issues in jqm1.2
591         - Multimediaview: modify APIs & comments
592         - Mapview: Fix issues in jqm1.2
593         - JQM: clean up patches
594         - Swipelist: refactoring swipelist
595         - Popup,Ctxpopup: Apply tizen style popup in JQM1.2
596         - rearrange button's data-icon resources
597 - Spec changes:
598         - Virtualgrid: remove option ('data-itemcount')
599         - gallery: rename the widget from imageslider to gallery
600         - add new style for searchbar
601         [tokentextarea] multi-button entry renamed as token text area. API & comments modified.
602
603 * Thu Dec 06 2012 Minkyu Kang <mk7.kang@samsung.com> 0.2.0
604 - FIX:
605         - fix jslint error
606         - remove unused files
607         - change naviframe style
608 - Spec changes:
609         - applied jQuery Mobile 1.2.0
610         - remove optionheader
611
612 * Fri Nov 30 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.64
613 - FIX:
614         - fix unit tests
615         - remove unused theme files
616         - timepicker: text position fix
617         - scrollview: set dragstop when mouse is out of window
618         - listview: fix margin
619 - Spec changes:
620         - support data-framework-viewport-width
621
622 * Fri Nov 23 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.63
623 - FIX:
624         - dayselector: fix size
625         - remove unised styles
626         - divider: set non-press effect to default option
627         - popupwindow: fix window closing failure
628         - handler: GUI implementation
629         - TC: fix unit TCs
630         - scrollview: fix padding size
631 - Spec changes:
632         - Remove color widgets
633         - add $.tizen.pkgVersion for SDK
634 - Etc.
635         - JSDuck documents
636
637 * Fri Nov 16 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.62
638 - FIX:
639         - Many winsets: Fix layout
640         - Footer: fix position to bottom
641 - Spec changes:
642         - Remove color widgets
643
644 * Fri Nov 09 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.61
645 - FIX:
646         - Many widgets: New UX 0.6 theme implementation
647         - widgetex: init speed up
648         - scrollview: fix scrollbar and scale animation
649         - scrollview: fix scroll position when updatelayout is triggered
650         - header/footer: make textselection disable, except input type="text"
651
652 * Wed Nov 07 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.60
653 - FIX:
654         - Remove tizen-black theme package description
655
656 * Tue Nov 06 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.59
657 - FIX:
658         - Fix theme name to meet the change of system theme name: white->tizen
659         - Popupwindow: fix left position
660         - Remove black theme
661         - footer: remove label, legend drawing
662 - Spec changes:
663         - UX guide v0.4 : button, layout
664
665 * Fri Oct 26 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.58
666 - FIX:
667         - scrollview: Fix outer scroll amount
668         - tabbar: fix tapping twice
669         - popupwindow: fix left position
670
671 * Wed Oct 24 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.57
672 - FIX:
673         - expandablelist: icon color fix
674         - scrollview: Fix xy scroll
675         - footer: Remove dummy div
676         - Make string concatnation effective in inline-protos.sh
677 - Spec changes:
678         - refresh header/footer when drag&drop event is fired in GUI builder
679         - searchbar: delete cancel button
680         - don't trigger updatelayout event when keyup event comes
681
682 * Mon Oct 15 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.56
683 - FIX:
684         - Toggleswitch: Change event name from 'changed' to 'change'
685         - Notification: Revert interval feature
686
687 * Tue Oct 09 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.55
688 - FIX:
689         - Fix SMACK manifest bug (S1-9098)
690
691 * Fri Oct 05 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.54
692 - FIX:
693         - handler: don't append a handler if handler is not enabled
694         - scrollview: use static value
695         - datetimepicker: fix date-format HH display error
696 - ETC:
697         - provide jquery.min.js
698         - barlayout: codes clean
699         - remove unused file
700
701 * Wed Sep 26 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.53
702 - FIX:
703         - listview: change focused color
704         - multibuttonentry: code refactoring
705         - datetimepicker: modify date format when triggered date-changed event
706         - slider: fix the top of slider bar
707         - add event blocker when load a first page
708
709 * Fri Sep 21 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.52
710 - ETC.
711         - Move SMACK manifest files to the top SRCDIR
712
713 * Fri Sep 21 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.51
714 - FIX:
715         - Popup: Do not focus container
716         - Header: show backbutton when both tabbar and header are present together
717         - Multi button entry: text ellipsis, code refactoring
718
719 * Fri Sep 21 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.50
720 - ETC.
721         - Apply SMACK manifest
722
723 * Thu Sep 20 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.49
724 - FIX:
725         - JSLINT code clean-up
726         - scrollview: firefox support
727         - scrollview: fix finding slider handle
728         - list: tweak text ellipsis
729         - checkbox: fix selecting wrong label tag (N_SE-8370)
730         - imageslider: check parameter
731         - smallpopup: fix position
732         - searchbar: fix 'clear' button size
733 - Spec changes:
734         - scrollview: support outer scroll
735         - JQM: block click event only with the element that does preventdefault on vclick(N_SE-6090)
736         - remove S/W IME control
737
738 * Thu Sep 13 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.48
739 - FIX:
740         - Add missing icon: controlbar
741         - scrollview: tune scrolling animatio ninterval
742         - datetimepicker: digit/triangle position
743         - datetimepicker: fix day overflow issue
744 - Spec changes:
745         - scrollview: show scrollbar when page is showed
746         - scrollview: disable outer scroll
747         - extendablelist: change api with legacy support
748         - add ui-text-ellipsis class
749
750 * Mon Sep 10 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.47
751 - FIX:
752         - scrollveiw: fix height of view
753         - searchbar: support placeholder
754 - Spec changes:
755         - add ui-text-ellipsis class
756
757 * Fri Sep 07 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.46
758 - FIX:
759         - scrollview: scrolling bug fix
760         - controlbar: fix width of controlbar item
761 - Spec changes:
762         - searchbar: don't hide icon
763         - popup: update JQM poup widget
764
765 * Fri Sep 05 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.45
766 - FIX:
767         - controlbar: set correct controlbar width of last element
768         - slider: get popup enable value correctly
769         - use Date.now() instead of (new Data()).getTime()
770         - popupwindow: fix the background color of popup scroller
771         - listview: add padding-left to expandable list
772         - add ellipsis for title area support
773
774 * Fri Aug 31 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.44
775 - FIX:
776         - swipelist: show list items correctly
777         - datetimepicker: set last day, if day is overflowed
778 - Spec changes:
779         - controlbar: update icons
780
781 * Tue Aug 29 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.43
782 - FIX:
783         - notification: fix typo
784 - Spec changes:
785         - controlbar: update icons
786
787 * Tue Aug 28 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.42
788 - FIX:
789         - multimediaview: video progress bar display normally for too samll
790         - segmentcontrol: remove media query
791         - scrollview: add outer scroll condition
792         - datetimepicker: modify triangle size
793         - popupwindow: set the screen height explicitly
794         - notification: add multiline text
795 - Spec changes:
796         - mutibuttonentry: support new GUI
797         - virtualgrid: support new GUI
798
799 * Mon Aug 27 2012 Jinhyuk Jun <jinhyuk.jun@samsung.com> 0.1.41
800 - FIX:
801         - radio/check button : button size bug fix
802
803 * Fri Aug 24 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.40
804 - FIX:
805         - build error fixed
806
807 * Fri Aug 24 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.39
808 - FIX:
809         - listview: style fix, remove filter placeholder
810         - controlbar: divide styles
811         - scrollview: don't skip dragging when click button or inputbox
812         - slider: trim the text on text slider
813 - Spec changes:
814         - remove gray and blue theme
815         - add white and black theme
816         - support new GUI guide
817
818 * Mon Aug 20 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.38
819 - FIX:
820         - fix coment of version tag
821
822 * Fri Aug 17 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.37
823 - FIX :
824         - button: fix alignment
825         - listview: adjust the main text width
826         - virtualgrid: refactoring
827 - Spec changes:
828         - transition: support JQM 1.1.0 transitions
829         - scrollview: support the outer scroll
830         - notification: remove interval feature
831
832 * Tue Aug 14 2012 Youmin Ha <youmin.ha@samasung.com> 0.1.36
833 - FIX :
834         - checkboxRadio: Add left/right padding
835         - button: custom button & icon position
836         - virtuallist: remove 'recreate' test
837 - Spec changes:
838         - header/footer: enable/disable support
839
840 * Fri Aug 10 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.35
841 - FIX :
842         - expandablelist: modify show animation
843         - virtualgrid: Redesign programming interface
844         - popupwindow: code clean and fixed issues
845         - pagelayout: fix content height
846         - license file update
847         - virtuallist: Change programming interface
848         - datetimepicker: getting days correctly
849         - searchbar: set to hidden when cancel button is hide
850         - White theme title font tuning
851 - Spec changes:
852         - default theme tizen-gray to tizen-white
853         - set default page transition to none
854
855 * Mon Aug 02 2012 Jinhyuk Jun <jinhyuk.jun@samsung.com> 0.1.34
856 - FIX :
857         - Back Button : enlarge backbutton click size for white theme
858 - Feature :
859         - Expandable List : Add refresh api
860 * Mon Aug 02 2012 Jinhyuk Jun <jinhyuk.jun@samsung.com> 0.1.33
861 - FIX :
862         - click event touch threshold tuning
863
864 * Mon Aug 02 2012 Jinhyuk Jun <jinhyuk.jun@samsung.com> 0.1.32
865 - FIX : 
866         - Add back button highlight effect for white theme
867
868 * Mon Aug 01 2012 Jinhyuk Jun <jinhyuk.jun@samsnug.com> 0.1.31
869 - FIX : 
870         - IME checkroutine update, improve relayout on resize event
871         - Add highlight effect for radio button list 
872         - Scrollview : fix condition of updatelayout event
873 - Feature : progressing : add show/hide api
874
875 * Mon Jul 27 2012 Koeun Choi <koeun.choi@samsung.com> 0.1.30
876 - FIX : virtuallist, virtualgrid: Clean up temporary jquery.template object to clear cache
877         add default theme option on buttonMarkup for tizen theme
878         [searchbar] first fix : focus/blur fixed
879         back button does not work when long press
880         scrollview: don't auto scrolling if resizing area is too large
881 - Feature : notification : add api to set the icon at tickernoti
882         demo : update the list sample demo
883         Support tizen default theme
884
885 * Mon Jul 23 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.29
886 - Improvements & Bugfixes
887    - HOTFIX: Revert template function with jquery.template
888
889 * Thu Jul 19 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.28
890 - Improvements & Bugfixes
891    - Fix #WEB-1028: memory leak on virtuallist/virtualgrid
892 - Spec changes
893    - $.tizen.loadTheme() function accepts theme name as arguement
894    - Scrollview supports 'updatelayout' callback
895
896 * Tue Jul 17 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.27
897 - Improvements & Bugfixes
898    - Revert 'preventing long-press popup' patch, to fix backbutton to work in SocialMagazine
899
900 * Tue Jul 17 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.26
901 - Improvements & Bugfixes
902    - Add tizen-white theme package, to make rpm build to be finished
903
904 * Tue Jul 17 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.25
905 - Improvements & Bugfixes
906    - Set 'slide' as default page transition effect, by JQM patch
907
908 * Fri Jul 13 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.24
909 - Improvements & Bugfixes
910    - Fix IME show/hide algorithm
911    - Fix error on virtualgrid: link _set_scrollbar_size() function to the one in virtuallist
912
913 * Wed Jul 11 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.23
914 - Improvements & Bugfixes
915    - Fix notification position
916    - Fix unit tests
917
918  Fri Jul 6 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.22
919 - Spec changes
920         - JQM 1.1 upgrade
921 - Improvements & Bugfixes
922         - Transform3D support on scrollview
923         - Page layout supports IME control
924         - Mapview supports pinch zoom on JQM 1.1
925         - Fix wrong character on button in minified version
926         - Virtualgrid supports scrollbar
927         - Lots of bugfixes
928
929 * Fri Jun 22 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.20
930 - Spec changes
931         - Support 'latest' version (by symlink) for tizen-web-ui-fw.js path.
932         - imageslider : supports 'resize' event.
933         - listview : listview has 1px padding-bottom.
934         - loader : Change global namespace, from S to $.tizen.
935         - loader : Move loadCustomGlobalizeCulture() into $.tizen.util namespace.
936 - Improvements & Bugfixes
937         - Scrollview : supports 'translate3d', instead of 'translate'.
938         - notification : reset timer when 'show' or 'refresh' event.
939         - JQM patch : Fix vclick event triggered twice.
940 - Etc.
941         - Add & fix unit tests.
942
943 * Thu Jun 14 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.19
944 - Spec changes
945         - mapview : new widget.
946         - notification : add .refresh() API.
947         - pagecontrol : add .value([val]) API, and change an attribute name 'data-initVal' to 'data-value'.
948 - Improvements & Bugfixes
949         - Support minified CSS.
950         - loader : Fix & refactor 'loading globalize culture file' routine.
951         - JQM Patch : Calculate min-height of window in javascript code, and remove predefined min-height value from CSS.
952         - Many more bugfixes.
953 - Etc.
954         - Add many unit tests.
955         - Fix test coverage instrumentation tool to work with current source code.