0.2.14 release
[platform/framework/web/web-ui-fw.git] / packaging / web-ui-fw.spec
1 Name:       web-ui-fw
2 Version:    0.2.14
3 Release:    0
4 Summary:    Tizen Web UI Framework Library
5 Group:      Development/Other
6 License:    MIT
7 BuildArch:  noarch
8 BuildRequires:  make
9 BuildRequires:  nodejs
10 %ifarch %{arm}
11 BuildRequires:  nodejs-x86-arm
12 %endif
13
14 Source0:    %{name}-%{version}.tar.gz
15
16 %description
17 Tizen Web UI Framework library and theme packages
18
19 %prep
20 %setup -q
21
22 %build
23 make all
24
25 %install
26 make DESTDIR=%{buildroot} install
27
28 %post
29
30 %files
31 %manifest web-ui-fw.manifest
32 /usr/share/tizen-web-ui-fw/*/js
33 /usr/share/tizen-web-ui-fw/latest
34 /usr/share/tizen-web-ui-fw/VERSION
35
36 ###############################
37 %package -n web-ui-fw-theme-tizen-gray
38 BuildArch:  noarch
39 Summary:    Tizen Web UI Framework Theme : tizen-gray
40 %Description -n web-ui-fw-theme-tizen-gray
41     Tizen Web UI Framework Theme : tizen-gray
42
43 ###############################
44 %package -n web-ui-fw-theme-tizen-white
45 BuildArch:  noarch
46 Summary:    Tizen Web UI Framework Theme : tizen-white
47 %Description -n web-ui-fw-theme-tizen-white
48     Tizen Web UI Framework Theme : tizen-white
49 %files -n web-ui-fw-theme-tizen-white
50 %manifest web-ui-fw-theme-tizen-white.manifest
51 /usr/share/tizen-web-ui-fw/*/themes/tizen-white
52 /usr/share/tizen-web-ui-fw/*/themes/tizen-tizen
53
54 ###############################
55 %package -n web-ui-fw-theme-default
56 BuildArch:  noarch
57 Summary:    Tizen Web UI Framework Theme : default
58 %Description -n web-ui-fw-theme-default
59     Tizen Web UI Framework Theme : default
60 %files -n web-ui-fw-theme-default
61 %manifest web-ui-fw-theme-default.manifest
62 /usr/share/tizen-web-ui-fw/*/themes/default
63
64 ###############################
65 %package -n web-ui-fw-devel
66 BuildArch:  noarch
67 Summary:    Tizen Web UI Framework Developer's files
68 %Description -n web-ui-fw-devel
69     Tizen Web UI Framework Developer's files
70 %files -n web-ui-fw-devel
71 /usr/share/tizen-web-ui-fw/bin
72 /usr/share/tizen-web-ui-fw/template
73
74 ###############################
75 %package -n web-ui-fw-demo-tizen-winsets
76 BuildArch:  noarch
77 Summary:    Tizen Web UI Framework Demo Application: tizen winset demo
78 %Description -n web-ui-fw-demo-tizen-winsets
79     Tizen Web UI Framework Demo Application: tizen winset demo
80 %files  -n web-ui-fw-demo-tizen-winsets
81 /usr/share/tizen-web-ui-fw/demos/tizen-winsets
82
83
84 ###############################
85 %changelog
86 * Sat Jan 26 2013 Youmin Ha <youmin.ha@samsung.com> 0.2.14
87         - demo: fix demo using tizen device API
88         - multimediaview: reset the height of container
89         - input: modify css correctly
90         - multimediaview: fix the height of widget
91         - gallery: bind create event
92         - progress: bind create event
93         - slider: bind create event
94         - progressbar: bind create event
95         - progressbar: event trigger correctly
96         - popup: fix height of popup scroller
97         - build: add continue option to jslint
98         - ctxpopup demo : bug fix
99         - demo: fix searchbar demo to use different IDs
100         - demo: extract routine executing Tizen device API
101         - toggleswitch : set default margin, delete box padding
102
103 * Thu Jan 24 2013 Youmin Ha <youmin.ha@samsung.com> 0.2.13
104         - virtuallist: Prevent replacing contents on nonexist element
105         - JQM: Trim text in listitem to get index in autodivider
106         - JQM: Remove trailing whitespace in jqm patch
107         - scrollview: get the height including margin
108         - multimediaview: bug fix ( scrolling in full-screen mode )
109         - virtuallist: set listitem width to exclude listitem left/right margin
110         - demo: fix virtuallist sample layout
111         - progress: set the position explicitly
112         - progress: rename from progressing to progress
113         - build: remove unused files
114         - searchbar: fix jslint errors
115         - src: fix file permissions
116         - button : change jump left icon
117
118 * Wed Jan 23 2013 Minkyu Kang <mk7.kang@samsung.com> 0.2.12
119         - theme : button icon - scrolltop, scrolleft icon changed.
120         - build: cleanaup Makefile
121         - pagelayout: fix jslint error
122         - virtualgrid: Fix jslint errors
123         - tabbar : jslint bug error fix
124         - build: add regexp option to jslint
125         - virtuallist: fix jslint errors
126         - handler: Apply the exceptional principle for scrollbar on Handler.
127         - build: remove unused copyright
128         - loader: extract log class for tizen web, and fix jslint errors
129         - loader: Viewport width is set to document width
130         - popupwindow: fix jslint error
131         - build: fix Makefile for tizen-white theme
132         - build: remove unused libraries
133         - datetimepicker: fix jslint error
134         - slider: fix jslint error
135         - demo: remove deprecated demos
136         - pagelayout : change to call relayout with this page
137         - Tokentextarea: Block size error fixed.
138         - handler: bug fix (handler activation)
139
140 * Tue Jan 22 2013 Minkyu Kang <mk7.kang@samsung.com> 0.2.11
141         - demo: clear input text value with cancel button click
142         - demo: Adjust textarea height automatically
143         - naviframe : bug fix
144         - tabbar : bug fix
145         - Fastscroll: popup position has been changed
146         - Button: custom button icon path, margin have been changed
147         - toggleswitch : bug fix
148         - slider: increase the margin
149         - datetimepicker: close the popup after select the value
150         - unit-test : add page backbutton control test
151         - Demo: added guide text and change input type in list vi
152         - remove legacy codes : jquery-geo
153         - Datetimepicker: text-main max-width has been removed
154         - Radio: control group border has been removed
155         - Demo: remove 'tab' space
156         - UnitTC: swipe unit tc has been fixed
157         - UnitTC: jQuery path has been fixed
158         - Button: bug fix when button has not a text
159         - tizen-winset: timepicker: demo title is changed
160
161 * Fri Jan 18 2013 Minkyu Kang <mk7.kang@samsung.com> 0.2.10
162         - tizen-winsets: codes cleanup
163         - datetimepicker: date calibration when year is changed
164         - Demo: textarea size has been changed
165         - Demo: Naviframe morebutton demo has been changed
166         - remove unused unit test cases : gallery3d
167         - tizen-winset: remove links
168
169 * Thu Jan 17 2013 Minkyu Kang <mk7.kang@samsung.com> 0.2.9
170         - gallery: use timeout function instead of interval
171         - Tokentextarea: Display error fixed.
172         - scrollview: Fix not selector to respond with jQuery1.8.2
173         - tabbar: remove the width of last element
174         - Demo: apply css 'user-select:none'
175         - Button: guide text has been shorten
176         - build: Update jQuery to 1.8.2 (JQM1.2 compliant)
177         - virtuallist: Fix mistyping
178         - demo: Fix tizen function namespace in demo
179         - virtuallist: Rewrite listitem replacing algorithm
180         - fastscroll: modify from not selector to function
181         - extendablelist: Fix unit-test
182         - tabbar : prefix to tabbar scroll event
183         - Popupwindow: removed unvalid selector in jquery 1.8.2
184         - slider: adjust handle text as length of value
185         - Demo: 3 buttons in popup text has been changed
186         - src: codes cleanup
187         - demo : remove trailing empty strings
188         - demo : rename TizenWinset list items
189         - button : change from long text list to multiline list
190         - build: Remove JQM1.1.0 patches
191         - Popup: Apply tizen style popup and attribute support
192         - JQM: Fix buttonmarkup bug keeping ui-btn-down class
193         - UnitTest: folder and file renamed, QUnit path was modified
194         - tizen-winsets: button: fix textarea width
195         - Swipe: event name error has been fixed
196
197 * Tue Jan 15 2013 Minkyu Kang <mk7.kang@samsung.com> 0.2.8
198         - Button: button padding has been updated
199         - virtuallist: fix unique listitem ID bug
200         - checkbox, radio : change display attr
201         - Button: bug fix ( when data style circle button on text )
202         - handler: bug fix (when scrolling with multi selection)
203         - JQM: adjust patch number
204         - gallery: show the widget after pageshow
205         - TokenTextArea : resource add ( press image )
206         - gallery: adds function that set the index to value API
207         - configure: set TIZEN default configures
208         - footer: h tag display attribute value has been changed
209         - buttons : demo bug fix
210         - searchbar : demo page bug fix
211         - tizen demo : bug fix
212         - build: remove JQM1.1.0
213         - Tokentextarea: Fix issues
214         - scrollview: block the multi touch
215         - list : dialogue list demo change
216         - pagelayout : update dynamic control
217         - Demo: Context popup close method has been changed
218
219 * Fri Jan 11 2013 Minkyu Kang <mk7.kang@samsung.com> 0.2.7
220         - slider: set text container's width as text length
221         - Timepicker: li max-width has been changed
222         - remove experimental feature - mapview.
223         - scrollview: added conditions for finding slider
224         - UnitTC: Pass,error count save method has been changed
225         - confix.xml: default config added for tizen basic applications
226         - Swipe: p tag margin value is set '0'
227         - packaging: remove unused file
228         - tabbar : bug fix
229         - list demo : bug fix
230         - tizen-winsets: gallery: move to new section
231         - tizen-winsets: autodivider: removes link of list
232         - demos: entry of number-pattern name is changed from 'number' to 'number-pattern'
233         - pagelayout : padding calculate change, ime footer check changed
234         - tizen-winsets: searchbar: scroll to the top when type the character
235         - searchbar : bug fix
236         - demo: Fix virtuallist demo following new list style
237         - demo: Add word-wrap:break-word and remove parag. width
238         - Demo: button max-width has been set( 3 buttons in popup )
239         - back button control demo : bug fix
240         - toggleswitch : demo page modify
241         - slider: add margin-top and margin-bottom
242         - tabbar demo : bug fix
243         - Popup: IME hide when popup is closed
244         - token textarea : bug fix
245         - Timepicker: change get attribute method
246         - footer demo : bug fix
247         - unit-test: gallery: add new APIs
248         - gallery: adds support new APIs
249
250 * Fri Jan 04 2013 Minkyu Kang <mk7.kang@samsung.com> 0.2.6
251         - JQM: patches cleanup
252         - Button: data-corners attribute has been added
253         - unit-test: slider: fix class name of background
254         - progressbar, slider: fix less variable typo
255         - Tabbar : VI update
256         - notification: add top position at fix class
257         - demo: entry demo page change
258         - css: .ui-disabled added
259         - tizen-winset: token textarea: remove back button at demo page
260         - theme: Remove unused less file
261         - pagelayout : content min height bug fix
262         - scrollview: skip the dragging when target is slider's handle
263         - scrollview: update and refactoring the scroll effect
264         - UnitTest:JQM Unit TC helper has been added,TCs have been modified
265         - Swipe: demo page html error has been fixed
266         - listview: Add add/delete animation (VI)
267         - Popup: demo page has been modified
268         - tizen demo : bug fix
269         - searchbar : demo page change(change front button and add behaviour)
270         - pagelayout : add min height to content
271         - gallery: rename 'Image Slider' to 'Gallery' in tizen-winsets demo and tests
272         - back button control demo : change url link to data-rel="back"
273         - loader: Skip loading theme CSS with a custom css code
274         - Button: support no-text in button
275         - collapsible: Fix syntax error
276         - slider: use data-highlight attribute
277         - collapsible: Rotate animation to collapsible heading icon
278         - toggleswitch : text switch bug fix
279         - remove candidates-calendarpicker
280         - Patch: Fix misc mistakes in JQM patches
281         - searchbar : animation change
282         - gallery: get the width correctly
283         - demo: data-framework-viewport-scale attribute is changed to data-framework-viewport-width
284         - collapsible: Add collapse/expand animation (VI)
285         - datetimepicker: VI update
286         - JQM: set transition to pop as default
287         - tabbar : bug fix in case none li element case
288         - scrollview: fix the drag bug
289         - Button: Button icon scrolltop, left has beed added
290         - Swipe: VI update and swipe speed has been changed
291         - jqm: fix errors in patch files
292         - unit-test: swipe: fixed the destroy test
293
294 * Wed Dec 26 2012 Youmin Ha <youmin.ha@samsung.com> 0.2.5
295         - Revert "[checkboxradio] exception handling for input"
296                 This reverts commit 72478c32704fa96362db577e6cf9511777919ea8.
297                 Tizen style supports no-label radio and checkbox when making lists.
298                 So it ignores html input operation. Instead, it supports tizen style radio and checkbox theme.
299
300 * Thu Dec 20 2012 Youmin Ha <youmin.ha@samsung.com> 0.2.4
301 - Fix:
302         - modify segment background
303         - rearrange check, radio input
304         - CtxPopup: Scale up/ down popup vi(poptop, popbottom)
305         - button: style has beed added(box,circle,nobg,round)
306         - favorite resource added
307         - demo/tizen-winsets: add footer and back button
308         - remove autodividers unit test
309         - add divider for tabbar
310         - checkboxradio: exception handling for input
311         - segment control backward compatiblity
312         - Fix collapsible unit-test
313         - remove toggleswitch
314         - add patch for remove segment text
315 - Spec changes:
316         - replace controlbar to tabbar
317
318 * Fri Dec 14 2012 Minkyu Kang <mk7.kang@samsung.com> 0.2.3
319 - FIX:
320         - slider: add image
321         - button: data-icon support, styles fix
322         - progressbar: modify the background
323         - scrollview: auto scrolling bug fix
324         - pagelayout: IME concept is changed
325 - Spec changes:
326         - dialogue: add edit mode
327         - nocontents: removed
328         - pagecontrol: removed
329         - dayselector: removed
330         - expandablelist: removed
331
332 * Thu Dec 10 2012 Youmin Ha <youmin.ha@samsung.com> 0.2.2
333 - FIX:
334         - chang searchbar/slider images
335         - delete redundant button images
336 - Spec changes:
337         - Change widget name: shortcutscroll -> fastscroll
338
339 * Thu Dec 07 2012 Youmin Ha <youmin.ha@samsung.com> 0.2.1
340 - FIX:
341         - jqm1.2: Change collapsible style to meet expandable list
342         - remove jquery-geo-1.0.a4
343         - unit-test: rename from imageslider to gallery
344         - nocontent: add warning message
345         - Handler: Fix issues in jqm1.2
346         - Multimediaview: modify APIs & comments
347         - Mapview: Fix issues in jqm1.2
348         - JQM: clean up patches
349         - Swipelist: refactoring swipelist
350         - Popup,Ctxpopup: Apply tizen style popup in JQM1.2
351         - rearrange button's data-icon resources
352 - Spec changes:
353         - Virtualgrid: remove option ('data-itemcount')
354         - gallery: rename the widget from imageslider to gallery
355         - add new style for searchbar
356         [tokentextarea] multi-button entry renamed as token text area. API & comments modified.
357
358 * Thu Dec 06 2012 Minkyu Kang <mk7.kang@samsung.com> 0.2.0
359 - FIX:
360         - fix jslint error
361         - remove unused files
362         - change naviframe style
363 - Spec changes:
364         - applied jQuery Mobile 1.2.0
365         - remove optionheader
366
367 * Fri Nov 30 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.64
368 - FIX:
369         - fix unit tests
370         - remove unused theme files
371         - timepicker: text position fix
372         - scrollview: set dragstop when mouse is out of window
373         - listview: fix margin
374 - Spec changes:
375         - support data-framework-viewport-width
376
377 * Fri Nov 23 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.63
378 - FIX:
379         - dayselector: fix size
380         - remove unised styles
381         - divider: set non-press effect to default option
382         - popupwindow: fix window closing failure
383         - handler: GUI implementation
384         - TC: fix unit TCs
385         - scrollview: fix padding size
386 - Spec changes:
387         - Remove color widgets
388         - add $.tizen.pkgVersion for SDK
389 - Etc.
390         - JSDuck documents
391
392 * Fri Nov 16 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.62
393 - FIX:
394         - Many winsets: Fix layout
395         - Footer: fix position to bottom
396 - Spec changes:
397         - Remove color widgets
398
399 * Fri Nov 09 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.61
400 - FIX:
401         - Many widgets: New UX 0.6 theme implementation
402         - widgetex: init speed up
403         - scrollview: fix scrollbar and scale animation
404         - scrollview: fix scroll position when updatelayout is triggered
405         - header/footer: make textselection disable, except input type="text"
406
407 * Wed Nov 07 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.60
408 - FIX:
409         - Remove tizen-black theme package description
410
411 * Tue Nov 06 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.59
412 - FIX:
413         - Fix theme name to meet the change of system theme name: white->tizen
414         - Popupwindow: fix left position
415         - Remove black theme
416         - footer: remove label, legend drawing
417 - Spec changes:
418         - UX guide v0.4 : button, layout
419
420 * Wed Oct 24 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.57
421 - FIX:
422         - expandablelist: icon color fix
423         - scrollview: Fix xy scroll
424         - footer: Remove dummy div
425         - Make string concatnation effective in inline-protos.sh
426 - Spec changes:
427         - refresh header/footer when drag&drop event is fired in GUI builder
428         - searchbar: delete cancel button
429         - don't trigger updatelayout event when keyup event comes
430
431 * Mon Oct 15 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.56
432 - FIX:
433         - Toggleswitch: Change event name from 'changed' to 'change'
434         - Notification: Revert interval feature
435
436 * Tue Oct 09 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.55
437 - FIX:
438         - Fix SMACK manifest bug (S1-9098)
439
440 * Fri Oct 05 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.54
441 - FIX:
442         - handler: don't append a handler if handler is not enabled
443         - scrollview: use static value
444         - datetimepicker: fix date-format HH display error
445 - ETC:
446         - provide jquery.min.js
447         - barlayout: codes clean
448         - remove unused file
449
450 * Wed Sep 26 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.53
451 - FIX:
452         - listview: change focused color
453         - multibuttonentry: code refactoring
454         - datetimepicker: modify date format when triggered date-changed event
455         - slider: fix the top of slider bar
456         - add event blocker when load a first page
457
458 * Fri Sep 21 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.52
459 - ETC.
460         - Move SMACK manifest files to the top SRCDIR
461
462 * Fri Sep 21 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.51
463 - FIX:
464         - Popup: Do not focus container
465         - Header: show backbutton when both tabbar and header are present together
466         - Multi button entry: text ellipsis, code refactoring
467
468 * Fri Sep 21 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.50
469 - ETC.
470         - Apply SMACK manifest
471
472 * Thu Sep 20 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.49
473 - FIX:
474         - JSLINT code clean-up
475         - scrollview: firefox support
476         - scrollview: fix finding slider handle
477         - list: tweak text ellipsis
478         - checkbox: fix selecting wrong label tag (N_SE-8370)
479         - imageslider: check parameter
480         - smallpopup: fix position
481         - searchbar: fix 'clear' button size
482 - Spec changes:
483         - scrollview: support outer scroll
484         - JQM: block click event only with the element that does preventdefault on vclick(N_SE-6090)
485         - remove S/W IME control
486
487 * Thu Sep 13 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.48
488 - FIX:
489         - Add missing icon: controlbar
490         - scrollview: tune scrolling animatio ninterval
491         - datetimepicker: digit/triangle position
492         - datetimepicker: fix day overflow issue
493 - Spec changes:
494         - scrollview: show scrollbar when page is showed
495         - scrollview: disable outer scroll
496         - extendablelist: change api with legacy support
497         - add ui-text-ellipsis class
498
499 * Mon Sep 10 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.47
500 - FIX:
501         - scrollveiw: fix height of view
502         - searchbar: support placeholder
503 - Spec changes:
504         - add ui-text-ellipsis class
505
506 * Fri Sep 07 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.46
507 - FIX:
508         - scrollview: scrolling bug fix
509         - controlbar: fix width of controlbar item
510 - Spec changes:
511         - searchbar: don't hide icon
512         - popup: update JQM poup widget
513
514 * Fri Sep 05 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.45
515 - FIX:
516         - controlbar: set correct controlbar width of last element
517         - slider: get popup enable value correctly
518         - use Date.now() instead of (new Data()).getTime()
519         - popupwindow: fix the background color of popup scroller
520         - listview: add padding-left to expandable list
521         - add ellipsis for title area support
522
523 * Fri Aug 31 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.44
524 - FIX:
525         - swipelist: show list items correctly
526         - datetimepicker: set last day, if day is overflowed
527 - Spec changes:
528         - controlbar: update icons
529
530 * Tue Aug 29 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.43
531 - FIX:
532         - notification: fix typo
533 - Spec changes:
534         - controlbar: update icons
535
536 * Tue Aug 28 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.42
537 - FIX:
538         - multimediaview: video progress bar display normally for too samll
539         - segmentcontrol: remove media query
540         - scrollview: add outer scroll condition
541         - datetimepicker: modify triangle size
542         - popupwindow: set the screen height explicitly
543         - notification: add multiline text
544 - Spec changes:
545         - mutibuttonentry: support new GUI
546         - virtualgrid: support new GUI
547
548 * Mon Aug 27 2012 Jinhyuk Jun <jinhyuk.jun@samsung.com> 0.1.41
549 - FIX:
550         - radio/check button : button size bug fix
551
552 * Fri Aug 24 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.40
553 - FIX:
554         - build error fixed
555
556 * Fri Aug 24 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.39
557 - FIX:
558         - listview: style fix, remove filter placeholder
559         - controlbar: divide styles
560         - scrollview: don't skip dragging when click button or inputbox
561         - slider: trim the text on text slider
562 - Spec changes:
563         - remove gray and blue theme
564         - add white and black theme
565         - support new GUI guide
566
567 * Mon Aug 20 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.38
568 - FIX:
569         - fix coment of version tag
570
571 * Fri Aug 17 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.37
572 - FIX :
573         - button: fix alignment
574         - listview: adjust the main text width
575         - virtualgrid: refactoring
576 - Spec changes:
577         - transition: support JQM 1.1.0 transitions
578         - scrollview: support the outer scroll
579         - notification: remove interval feature
580
581 * Tue Aug 14 2012 Youmin Ha <youmin.ha@samasung.com> 0.1.36
582 - FIX :
583         - checkboxRadio: Add left/right padding
584         - button: custom button & icon position
585         - virtuallist: remove 'recreate' test
586 - Spec changes:
587         - header/footer: enable/disable support
588
589 * Fri Aug 10 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.35
590 - FIX :
591         - expandablelist: modify show animation
592         - virtualgrid: Redesign programming interface
593         - popupwindow: code clean and fixed issues
594         - pagelayout: fix content height
595         - license file update
596         - virtuallist: Change programming interface
597         - datetimepicker: getting days correctly
598         - searchbar: set to hidden when cancel button is hide
599         - White theme title font tuning
600 - Spec changes:
601         - default theme tizen-gray to tizen-white
602         - set default page transition to none
603
604 * Mon Aug 02 2012 Jinhyuk Jun <jinhyuk.jun@samsung.com> 0.1.34
605 - FIX :
606         - Back Button : enlarge backbutton click size for white theme
607 - Feature :
608         - Expandable List : Add refresh api
609 * Mon Aug 02 2012 Jinhyuk Jun <jinhyuk.jun@samsung.com> 0.1.33
610 - FIX :
611         - click event touch threshold tuning
612
613 * Mon Aug 02 2012 Jinhyuk Jun <jinhyuk.jun@samsung.com> 0.1.32
614 - FIX : 
615         - Add back button highlight effect for white theme
616
617 * Mon Aug 01 2012 Jinhyuk Jun <jinhyuk.jun@samsnug.com> 0.1.31
618 - FIX : 
619         - IME checkroutine update, improve relayout on resize event
620         - Add highlight effect for radio button list 
621         - Scrollview : fix condition of updatelayout event
622 - Feature : progressing : add show/hide api
623
624 * Mon Jul 27 2012 Koeun Choi <koeun.choi@samsung.com> 0.1.30
625 - FIX : virtuallist, virtualgrid: Clean up temporary jquery.template object to clear cache
626         add default theme option on buttonMarkup for tizen theme
627         [searchbar] first fix : focus/blur fixed
628         back button does not work when long press
629         scrollview: don't auto scrolling if resizing area is too large
630 - Feature : notification : add api to set the icon at tickernoti
631         demo : update the list sample demo
632         Support tizen default theme
633
634 * Mon Jul 23 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.29
635 - Improvements & Bugfixes
636    - HOTFIX: Revert template function with jquery.template
637
638 * Thu Jul 19 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.28
639 - Improvements & Bugfixes
640    - Fix #WEB-1028: memory leak on virtuallist/virtualgrid
641 - Spec changes
642    - $.tizen.loadTheme() function accepts theme name as arguement
643    - Scrollview supports 'updatelayout' callback
644
645 * Tue Jul 17 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.27
646 - Improvements & Bugfixes
647    - Revert 'preventing long-press popup' patch, to fix backbutton to work in SocialMagazine
648
649 * Tue Jul 17 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.26
650 - Improvements & Bugfixes
651    - Add tizen-white theme package, to make rpm build to be finished
652
653 * Tue Jul 17 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.25
654 - Improvements & Bugfixes
655    - Set 'slide' as default page transition effect, by JQM patch
656
657 * Fri Jul 13 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.24
658 - Improvements & Bugfixes
659    - Fix IME show/hide algorithm
660    - Fix error on virtualgrid: link _set_scrollbar_size() function to the one in virtuallist
661
662 * Wed Jul 11 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.23
663 - Improvements & Bugfixes
664    - Fix notification position
665    - Fix unit tests
666
667  Fri Jul 6 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.22
668 - Spec changes
669         - JQM 1.1 upgrade
670 - Improvements & Bugfixes
671         - Transform3D support on scrollview
672         - Page layout supports IME control
673         - Mapview supports pinch zoom on JQM 1.1
674         - Fix wrong character on button in minified version
675         - Virtualgrid supports scrollbar
676         - Lots of bugfixes
677
678 * Fri Jun 22 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.20
679 - Spec changes
680         - Support 'latest' version (by symlink) for tizen-web-ui-fw.js path.
681         - imageslider : supports 'resize' event.
682         - listview : listview has 1px padding-bottom.
683         - loader : Change global namespace, from S to $.tizen.
684         - loader : Move loadCustomGlobalizeCulture() into $.tizen.util namespace.
685 - Improvements & Bugfixes
686         - Scrollview : supports 'translate3d', instead of 'translate'.
687         - notification : reset timer when 'show' or 'refresh' event.
688         - JQM patch : Fix vclick event triggered twice.
689 - Etc.
690         - Add & fix unit tests.
691
692 * Thu Jun 14 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.19
693 - Spec changes
694         - mapview : new widget.
695         - notification : add .refresh() API.
696         - pagecontrol : add .value([val]) API, and change an attribute name 'data-initVal' to 'data-value'.
697 - Improvements & Bugfixes
698         - Support minified CSS.
699         - loader : Fix & refactor 'loading globalize culture file' routine.
700         - JQM Patch : Calculate min-height of window in javascript code, and remove predefined min-height value from CSS.
701         - Many more bugfixes.
702 - Etc.
703         - Add many unit tests.
704         - Fix test coverage instrumentation tool to work with current source code.