0.2.15 release
[platform/framework/web/web-ui-fw.git] / packaging / web-ui-fw.spec
1 Name:       web-ui-fw
2 Version:    0.2.15
3 Release:    0
4 Summary:    Tizen Web UI Framework Library
5 Group:      Development/Other
6 License:    MIT
7 BuildArch:  noarch
8 BuildRequires:  make
9 BuildRequires:  nodejs
10 %ifarch %{arm}
11 BuildRequires:  nodejs-x86-arm
12 %endif
13
14 Source0:    %{name}-%{version}.tar.gz
15
16 %description
17 Tizen Web UI Framework library and theme packages
18
19 %prep
20 %setup -q
21
22 %build
23 make all
24
25 %install
26 make DESTDIR=%{buildroot} install
27
28 %post
29
30 %files
31 %manifest web-ui-fw.manifest
32 /usr/share/tizen-web-ui-fw/*/js
33 /usr/share/tizen-web-ui-fw/latest
34 /usr/share/tizen-web-ui-fw/VERSION
35
36 ###############################
37 %package -n web-ui-fw-theme-tizen-gray
38 BuildArch:  noarch
39 Summary:    Tizen Web UI Framework Theme : tizen-gray
40 %Description -n web-ui-fw-theme-tizen-gray
41     Tizen Web UI Framework Theme : tizen-gray
42
43 ###############################
44 %package -n web-ui-fw-theme-tizen-white
45 BuildArch:  noarch
46 Summary:    Tizen Web UI Framework Theme : tizen-white
47 %Description -n web-ui-fw-theme-tizen-white
48     Tizen Web UI Framework Theme : tizen-white
49 %files -n web-ui-fw-theme-tizen-white
50 %manifest web-ui-fw-theme-tizen-white.manifest
51 /usr/share/tizen-web-ui-fw/*/themes/tizen-white
52 /usr/share/tizen-web-ui-fw/*/themes/tizen-tizen
53
54 ###############################
55 %package -n web-ui-fw-theme-default
56 BuildArch:  noarch
57 Summary:    Tizen Web UI Framework Theme : default
58 %Description -n web-ui-fw-theme-default
59     Tizen Web UI Framework Theme : default
60 %files -n web-ui-fw-theme-default
61 %manifest web-ui-fw-theme-default.manifest
62 /usr/share/tizen-web-ui-fw/*/themes/default
63
64 ###############################
65 %package -n web-ui-fw-devel
66 BuildArch:  noarch
67 Summary:    Tizen Web UI Framework Developer's files
68 %Description -n web-ui-fw-devel
69     Tizen Web UI Framework Developer's files
70 %files -n web-ui-fw-devel
71 /usr/share/tizen-web-ui-fw/bin
72 /usr/share/tizen-web-ui-fw/template
73
74 ###############################
75 %package -n web-ui-fw-demo-tizen-winsets
76 BuildArch:  noarch
77 Summary:    Tizen Web UI Framework Demo Application: tizen winset demo
78 %Description -n web-ui-fw-demo-tizen-winsets
79     Tizen Web UI Framework Demo Application: tizen winset demo
80 %files  -n web-ui-fw-demo-tizen-winsets
81 /usr/share/tizen-web-ui-fw/demos/tizen-winsets
82
83
84 ###############################
85 %changelog
86 * Mon Jan 28 2013 Youmin Ha <youmin.ha@samsung.com> 0.2.15
87         - slider: increase the text width(N_SE-23397)
88         - virtualgrid: DOM element leak fix
89         - header: Move button top higher in header with tabbar(N_SE-22253)
90         - datatimepicker: don't open the popup before popupafterclose event is fired(N_SE-23027)
91         - handler: bug fix (regarding enableHandler function )
92         - demo:fix syntax error
93
94 * Sat Jan 26 2013 Youmin Ha <youmin.ha@samsung.com> 0.2.14
95         - demo: fix demo using tizen device API
96         - multimediaview: reset the height of container
97         - input: modify css correctly
98         - multimediaview: fix the height of widget
99         - gallery: bind create event
100         - progress: bind create event
101         - slider: bind create event
102         - progressbar: bind create event
103         - progressbar: event trigger correctly
104         - popup: fix height of popup scroller
105         - build: add continue option to jslint
106         - ctxpopup demo : bug fix
107         - demo: fix searchbar demo to use different IDs
108         - demo: extract routine executing Tizen device API
109         - toggleswitch : set default margin, delete box padding
110
111 * Thu Jan 24 2013 Youmin Ha <youmin.ha@samsung.com> 0.2.13
112         - virtuallist: Prevent replacing contents on nonexist element
113         - JQM: Trim text in listitem to get index in autodivider
114         - JQM: Remove trailing whitespace in jqm patch
115         - scrollview: get the height including margin
116         - multimediaview: bug fix ( scrolling in full-screen mode )
117         - virtuallist: set listitem width to exclude listitem left/right margin
118         - demo: fix virtuallist sample layout
119         - progress: set the position explicitly
120         - progress: rename from progressing to progress
121         - build: remove unused files
122         - searchbar: fix jslint errors
123         - src: fix file permissions
124         - button : change jump left icon
125
126 * Wed Jan 23 2013 Minkyu Kang <mk7.kang@samsung.com> 0.2.12
127         - theme : button icon - scrolltop, scrolleft icon changed.
128         - build: cleanaup Makefile
129         - pagelayout: fix jslint error
130         - virtualgrid: Fix jslint errors
131         - tabbar : jslint bug error fix
132         - build: add regexp option to jslint
133         - virtuallist: fix jslint errors
134         - handler: Apply the exceptional principle for scrollbar on Handler.
135         - build: remove unused copyright
136         - loader: extract log class for tizen web, and fix jslint errors
137         - loader: Viewport width is set to document width
138         - popupwindow: fix jslint error
139         - build: fix Makefile for tizen-white theme
140         - build: remove unused libraries
141         - datetimepicker: fix jslint error
142         - slider: fix jslint error
143         - demo: remove deprecated demos
144         - pagelayout : change to call relayout with this page
145         - Tokentextarea: Block size error fixed.
146         - handler: bug fix (handler activation)
147
148 * Tue Jan 22 2013 Minkyu Kang <mk7.kang@samsung.com> 0.2.11
149         - demo: clear input text value with cancel button click
150         - demo: Adjust textarea height automatically
151         - naviframe : bug fix
152         - tabbar : bug fix
153         - Fastscroll: popup position has been changed
154         - Button: custom button icon path, margin have been changed
155         - toggleswitch : bug fix
156         - slider: increase the margin
157         - datetimepicker: close the popup after select the value
158         - unit-test : add page backbutton control test
159         - Demo: added guide text and change input type in list vi
160         - remove legacy codes : jquery-geo
161         - Datetimepicker: text-main max-width has been removed
162         - Radio: control group border has been removed
163         - Demo: remove 'tab' space
164         - UnitTC: swipe unit tc has been fixed
165         - UnitTC: jQuery path has been fixed
166         - Button: bug fix when button has not a text
167         - tizen-winset: timepicker: demo title is changed
168
169 * Fri Jan 18 2013 Minkyu Kang <mk7.kang@samsung.com> 0.2.10
170         - tizen-winsets: codes cleanup
171         - datetimepicker: date calibration when year is changed
172         - Demo: textarea size has been changed
173         - Demo: Naviframe morebutton demo has been changed
174         - remove unused unit test cases : gallery3d
175         - tizen-winset: remove links
176
177 * Thu Jan 17 2013 Minkyu Kang <mk7.kang@samsung.com> 0.2.9
178         - gallery: use timeout function instead of interval
179         - Tokentextarea: Display error fixed.
180         - scrollview: Fix not selector to respond with jQuery1.8.2
181         - tabbar: remove the width of last element
182         - Demo: apply css 'user-select:none'
183         - Button: guide text has been shorten
184         - build: Update jQuery to 1.8.2 (JQM1.2 compliant)
185         - virtuallist: Fix mistyping
186         - demo: Fix tizen function namespace in demo
187         - virtuallist: Rewrite listitem replacing algorithm
188         - fastscroll: modify from not selector to function
189         - extendablelist: Fix unit-test
190         - tabbar : prefix to tabbar scroll event
191         - Popupwindow: removed unvalid selector in jquery 1.8.2
192         - slider: adjust handle text as length of value
193         - Demo: 3 buttons in popup text has been changed
194         - src: codes cleanup
195         - demo : remove trailing empty strings
196         - demo : rename TizenWinset list items
197         - button : change from long text list to multiline list
198         - build: Remove JQM1.1.0 patches
199         - Popup: Apply tizen style popup and attribute support
200         - JQM: Fix buttonmarkup bug keeping ui-btn-down class
201         - UnitTest: folder and file renamed, QUnit path was modified
202         - tizen-winsets: button: fix textarea width
203         - Swipe: event name error has been fixed
204
205 * Tue Jan 15 2013 Minkyu Kang <mk7.kang@samsung.com> 0.2.8
206         - Button: button padding has been updated
207         - virtuallist: fix unique listitem ID bug
208         - checkbox, radio : change display attr
209         - Button: bug fix ( when data style circle button on text )
210         - handler: bug fix (when scrolling with multi selection)
211         - JQM: adjust patch number
212         - gallery: show the widget after pageshow
213         - TokenTextArea : resource add ( press image )
214         - gallery: adds function that set the index to value API
215         - configure: set TIZEN default configures
216         - footer: h tag display attribute value has been changed
217         - buttons : demo bug fix
218         - searchbar : demo page bug fix
219         - tizen demo : bug fix
220         - build: remove JQM1.1.0
221         - Tokentextarea: Fix issues
222         - scrollview: block the multi touch
223         - list : dialogue list demo change
224         - pagelayout : update dynamic control
225         - Demo: Context popup close method has been changed
226
227 * Fri Jan 11 2013 Minkyu Kang <mk7.kang@samsung.com> 0.2.7
228         - slider: set text container's width as text length
229         - Timepicker: li max-width has been changed
230         - remove experimental feature - mapview.
231         - scrollview: added conditions for finding slider
232         - UnitTC: Pass,error count save method has been changed
233         - confix.xml: default config added for tizen basic applications
234         - Swipe: p tag margin value is set '0'
235         - packaging: remove unused file
236         - tabbar : bug fix
237         - list demo : bug fix
238         - tizen-winsets: gallery: move to new section
239         - tizen-winsets: autodivider: removes link of list
240         - demos: entry of number-pattern name is changed from 'number' to 'number-pattern'
241         - pagelayout : padding calculate change, ime footer check changed
242         - tizen-winsets: searchbar: scroll to the top when type the character
243         - searchbar : bug fix
244         - demo: Fix virtuallist demo following new list style
245         - demo: Add word-wrap:break-word and remove parag. width
246         - Demo: button max-width has been set( 3 buttons in popup )
247         - back button control demo : bug fix
248         - toggleswitch : demo page modify
249         - slider: add margin-top and margin-bottom
250         - tabbar demo : bug fix
251         - Popup: IME hide when popup is closed
252         - token textarea : bug fix
253         - Timepicker: change get attribute method
254         - footer demo : bug fix
255         - unit-test: gallery: add new APIs
256         - gallery: adds support new APIs
257
258 * Fri Jan 04 2013 Minkyu Kang <mk7.kang@samsung.com> 0.2.6
259         - JQM: patches cleanup
260         - Button: data-corners attribute has been added
261         - unit-test: slider: fix class name of background
262         - progressbar, slider: fix less variable typo
263         - Tabbar : VI update
264         - notification: add top position at fix class
265         - demo: entry demo page change
266         - css: .ui-disabled added
267         - tizen-winset: token textarea: remove back button at demo page
268         - theme: Remove unused less file
269         - pagelayout : content min height bug fix
270         - scrollview: skip the dragging when target is slider's handle
271         - scrollview: update and refactoring the scroll effect
272         - UnitTest:JQM Unit TC helper has been added,TCs have been modified
273         - Swipe: demo page html error has been fixed
274         - listview: Add add/delete animation (VI)
275         - Popup: demo page has been modified
276         - tizen demo : bug fix
277         - searchbar : demo page change(change front button and add behaviour)
278         - pagelayout : add min height to content
279         - gallery: rename 'Image Slider' to 'Gallery' in tizen-winsets demo and tests
280         - back button control demo : change url link to data-rel="back"
281         - loader: Skip loading theme CSS with a custom css code
282         - Button: support no-text in button
283         - collapsible: Fix syntax error
284         - slider: use data-highlight attribute
285         - collapsible: Rotate animation to collapsible heading icon
286         - toggleswitch : text switch bug fix
287         - remove candidates-calendarpicker
288         - Patch: Fix misc mistakes in JQM patches
289         - searchbar : animation change
290         - gallery: get the width correctly
291         - demo: data-framework-viewport-scale attribute is changed to data-framework-viewport-width
292         - collapsible: Add collapse/expand animation (VI)
293         - datetimepicker: VI update
294         - JQM: set transition to pop as default
295         - tabbar : bug fix in case none li element case
296         - scrollview: fix the drag bug
297         - Button: Button icon scrolltop, left has beed added
298         - Swipe: VI update and swipe speed has been changed
299         - jqm: fix errors in patch files
300         - unit-test: swipe: fixed the destroy test
301
302 * Wed Dec 26 2012 Youmin Ha <youmin.ha@samsung.com> 0.2.5
303         - Revert "[checkboxradio] exception handling for input"
304                 This reverts commit 72478c32704fa96362db577e6cf9511777919ea8.
305                 Tizen style supports no-label radio and checkbox when making lists.
306                 So it ignores html input operation. Instead, it supports tizen style radio and checkbox theme.
307
308 * Thu Dec 20 2012 Youmin Ha <youmin.ha@samsung.com> 0.2.4
309 - Fix:
310         - modify segment background
311         - rearrange check, radio input
312         - CtxPopup: Scale up/ down popup vi(poptop, popbottom)
313         - button: style has beed added(box,circle,nobg,round)
314         - favorite resource added
315         - demo/tizen-winsets: add footer and back button
316         - remove autodividers unit test
317         - add divider for tabbar
318         - checkboxradio: exception handling for input
319         - segment control backward compatiblity
320         - Fix collapsible unit-test
321         - remove toggleswitch
322         - add patch for remove segment text
323 - Spec changes:
324         - replace controlbar to tabbar
325
326 * Fri Dec 14 2012 Minkyu Kang <mk7.kang@samsung.com> 0.2.3
327 - FIX:
328         - slider: add image
329         - button: data-icon support, styles fix
330         - progressbar: modify the background
331         - scrollview: auto scrolling bug fix
332         - pagelayout: IME concept is changed
333 - Spec changes:
334         - dialogue: add edit mode
335         - nocontents: removed
336         - pagecontrol: removed
337         - dayselector: removed
338         - expandablelist: removed
339
340 * Thu Dec 10 2012 Youmin Ha <youmin.ha@samsung.com> 0.2.2
341 - FIX:
342         - chang searchbar/slider images
343         - delete redundant button images
344 - Spec changes:
345         - Change widget name: shortcutscroll -> fastscroll
346
347 * Thu Dec 07 2012 Youmin Ha <youmin.ha@samsung.com> 0.2.1
348 - FIX:
349         - jqm1.2: Change collapsible style to meet expandable list
350         - remove jquery-geo-1.0.a4
351         - unit-test: rename from imageslider to gallery
352         - nocontent: add warning message
353         - Handler: Fix issues in jqm1.2
354         - Multimediaview: modify APIs & comments
355         - Mapview: Fix issues in jqm1.2
356         - JQM: clean up patches
357         - Swipelist: refactoring swipelist
358         - Popup,Ctxpopup: Apply tizen style popup in JQM1.2
359         - rearrange button's data-icon resources
360 - Spec changes:
361         - Virtualgrid: remove option ('data-itemcount')
362         - gallery: rename the widget from imageslider to gallery
363         - add new style for searchbar
364         [tokentextarea] multi-button entry renamed as token text area. API & comments modified.
365
366 * Thu Dec 06 2012 Minkyu Kang <mk7.kang@samsung.com> 0.2.0
367 - FIX:
368         - fix jslint error
369         - remove unused files
370         - change naviframe style
371 - Spec changes:
372         - applied jQuery Mobile 1.2.0
373         - remove optionheader
374
375 * Fri Nov 30 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.64
376 - FIX:
377         - fix unit tests
378         - remove unused theme files
379         - timepicker: text position fix
380         - scrollview: set dragstop when mouse is out of window
381         - listview: fix margin
382 - Spec changes:
383         - support data-framework-viewport-width
384
385 * Fri Nov 23 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.63
386 - FIX:
387         - dayselector: fix size
388         - remove unised styles
389         - divider: set non-press effect to default option
390         - popupwindow: fix window closing failure
391         - handler: GUI implementation
392         - TC: fix unit TCs
393         - scrollview: fix padding size
394 - Spec changes:
395         - Remove color widgets
396         - add $.tizen.pkgVersion for SDK
397 - Etc.
398         - JSDuck documents
399
400 * Fri Nov 16 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.62
401 - FIX:
402         - Many winsets: Fix layout
403         - Footer: fix position to bottom
404 - Spec changes:
405         - Remove color widgets
406
407 * Fri Nov 09 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.61
408 - FIX:
409         - Many widgets: New UX 0.6 theme implementation
410         - widgetex: init speed up
411         - scrollview: fix scrollbar and scale animation
412         - scrollview: fix scroll position when updatelayout is triggered
413         - header/footer: make textselection disable, except input type="text"
414
415 * Wed Nov 07 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.60
416 - FIX:
417         - Remove tizen-black theme package description
418
419 * Tue Nov 06 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.59
420 - FIX:
421         - Fix theme name to meet the change of system theme name: white->tizen
422         - Popupwindow: fix left position
423         - Remove black theme
424         - footer: remove label, legend drawing
425 - Spec changes:
426         - UX guide v0.4 : button, layout
427
428 * Wed Oct 24 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.57
429 - FIX:
430         - expandablelist: icon color fix
431         - scrollview: Fix xy scroll
432         - footer: Remove dummy div
433         - Make string concatnation effective in inline-protos.sh
434 - Spec changes:
435         - refresh header/footer when drag&drop event is fired in GUI builder
436         - searchbar: delete cancel button
437         - don't trigger updatelayout event when keyup event comes
438
439 * Mon Oct 15 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.56
440 - FIX:
441         - Toggleswitch: Change event name from 'changed' to 'change'
442         - Notification: Revert interval feature
443
444 * Tue Oct 09 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.55
445 - FIX:
446         - Fix SMACK manifest bug (S1-9098)
447
448 * Fri Oct 05 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.54
449 - FIX:
450         - handler: don't append a handler if handler is not enabled
451         - scrollview: use static value
452         - datetimepicker: fix date-format HH display error
453 - ETC:
454         - provide jquery.min.js
455         - barlayout: codes clean
456         - remove unused file
457
458 * Wed Sep 26 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.53
459 - FIX:
460         - listview: change focused color
461         - multibuttonentry: code refactoring
462         - datetimepicker: modify date format when triggered date-changed event
463         - slider: fix the top of slider bar
464         - add event blocker when load a first page
465
466 * Fri Sep 21 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.52
467 - ETC.
468         - Move SMACK manifest files to the top SRCDIR
469
470 * Fri Sep 21 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.51
471 - FIX:
472         - Popup: Do not focus container
473         - Header: show backbutton when both tabbar and header are present together
474         - Multi button entry: text ellipsis, code refactoring
475
476 * Fri Sep 21 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.50
477 - ETC.
478         - Apply SMACK manifest
479
480 * Thu Sep 20 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.49
481 - FIX:
482         - JSLINT code clean-up
483         - scrollview: firefox support
484         - scrollview: fix finding slider handle
485         - list: tweak text ellipsis
486         - checkbox: fix selecting wrong label tag (N_SE-8370)
487         - imageslider: check parameter
488         - smallpopup: fix position
489         - searchbar: fix 'clear' button size
490 - Spec changes:
491         - scrollview: support outer scroll
492         - JQM: block click event only with the element that does preventdefault on vclick(N_SE-6090)
493         - remove S/W IME control
494
495 * Thu Sep 13 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.48
496 - FIX:
497         - Add missing icon: controlbar
498         - scrollview: tune scrolling animatio ninterval
499         - datetimepicker: digit/triangle position
500         - datetimepicker: fix day overflow issue
501 - Spec changes:
502         - scrollview: show scrollbar when page is showed
503         - scrollview: disable outer scroll
504         - extendablelist: change api with legacy support
505         - add ui-text-ellipsis class
506
507 * Mon Sep 10 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.47
508 - FIX:
509         - scrollveiw: fix height of view
510         - searchbar: support placeholder
511 - Spec changes:
512         - add ui-text-ellipsis class
513
514 * Fri Sep 07 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.46
515 - FIX:
516         - scrollview: scrolling bug fix
517         - controlbar: fix width of controlbar item
518 - Spec changes:
519         - searchbar: don't hide icon
520         - popup: update JQM poup widget
521
522 * Fri Sep 05 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.45
523 - FIX:
524         - controlbar: set correct controlbar width of last element
525         - slider: get popup enable value correctly
526         - use Date.now() instead of (new Data()).getTime()
527         - popupwindow: fix the background color of popup scroller
528         - listview: add padding-left to expandable list
529         - add ellipsis for title area support
530
531 * Fri Aug 31 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.44
532 - FIX:
533         - swipelist: show list items correctly
534         - datetimepicker: set last day, if day is overflowed
535 - Spec changes:
536         - controlbar: update icons
537
538 * Tue Aug 29 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.43
539 - FIX:
540         - notification: fix typo
541 - Spec changes:
542         - controlbar: update icons
543
544 * Tue Aug 28 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.42
545 - FIX:
546         - multimediaview: video progress bar display normally for too samll
547         - segmentcontrol: remove media query
548         - scrollview: add outer scroll condition
549         - datetimepicker: modify triangle size
550         - popupwindow: set the screen height explicitly
551         - notification: add multiline text
552 - Spec changes:
553         - mutibuttonentry: support new GUI
554         - virtualgrid: support new GUI
555
556 * Mon Aug 27 2012 Jinhyuk Jun <jinhyuk.jun@samsung.com> 0.1.41
557 - FIX:
558         - radio/check button : button size bug fix
559
560 * Fri Aug 24 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.40
561 - FIX:
562         - build error fixed
563
564 * Fri Aug 24 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.39
565 - FIX:
566         - listview: style fix, remove filter placeholder
567         - controlbar: divide styles
568         - scrollview: don't skip dragging when click button or inputbox
569         - slider: trim the text on text slider
570 - Spec changes:
571         - remove gray and blue theme
572         - add white and black theme
573         - support new GUI guide
574
575 * Mon Aug 20 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.38
576 - FIX:
577         - fix coment of version tag
578
579 * Fri Aug 17 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.37
580 - FIX :
581         - button: fix alignment
582         - listview: adjust the main text width
583         - virtualgrid: refactoring
584 - Spec changes:
585         - transition: support JQM 1.1.0 transitions
586         - scrollview: support the outer scroll
587         - notification: remove interval feature
588
589 * Tue Aug 14 2012 Youmin Ha <youmin.ha@samasung.com> 0.1.36
590 - FIX :
591         - checkboxRadio: Add left/right padding
592         - button: custom button & icon position
593         - virtuallist: remove 'recreate' test
594 - Spec changes:
595         - header/footer: enable/disable support
596
597 * Fri Aug 10 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.35
598 - FIX :
599         - expandablelist: modify show animation
600         - virtualgrid: Redesign programming interface
601         - popupwindow: code clean and fixed issues
602         - pagelayout: fix content height
603         - license file update
604         - virtuallist: Change programming interface
605         - datetimepicker: getting days correctly
606         - searchbar: set to hidden when cancel button is hide
607         - White theme title font tuning
608 - Spec changes:
609         - default theme tizen-gray to tizen-white
610         - set default page transition to none
611
612 * Mon Aug 02 2012 Jinhyuk Jun <jinhyuk.jun@samsung.com> 0.1.34
613 - FIX :
614         - Back Button : enlarge backbutton click size for white theme
615 - Feature :
616         - Expandable List : Add refresh api
617 * Mon Aug 02 2012 Jinhyuk Jun <jinhyuk.jun@samsung.com> 0.1.33
618 - FIX :
619         - click event touch threshold tuning
620
621 * Mon Aug 02 2012 Jinhyuk Jun <jinhyuk.jun@samsung.com> 0.1.32
622 - FIX : 
623         - Add back button highlight effect for white theme
624
625 * Mon Aug 01 2012 Jinhyuk Jun <jinhyuk.jun@samsnug.com> 0.1.31
626 - FIX : 
627         - IME checkroutine update, improve relayout on resize event
628         - Add highlight effect for radio button list 
629         - Scrollview : fix condition of updatelayout event
630 - Feature : progressing : add show/hide api
631
632 * Mon Jul 27 2012 Koeun Choi <koeun.choi@samsung.com> 0.1.30
633 - FIX : virtuallist, virtualgrid: Clean up temporary jquery.template object to clear cache
634         add default theme option on buttonMarkup for tizen theme
635         [searchbar] first fix : focus/blur fixed
636         back button does not work when long press
637         scrollview: don't auto scrolling if resizing area is too large
638 - Feature : notification : add api to set the icon at tickernoti
639         demo : update the list sample demo
640         Support tizen default theme
641
642 * Mon Jul 23 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.29
643 - Improvements & Bugfixes
644    - HOTFIX: Revert template function with jquery.template
645
646 * Thu Jul 19 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.28
647 - Improvements & Bugfixes
648    - Fix #WEB-1028: memory leak on virtuallist/virtualgrid
649 - Spec changes
650    - $.tizen.loadTheme() function accepts theme name as arguement
651    - Scrollview supports 'updatelayout' callback
652
653 * Tue Jul 17 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.27
654 - Improvements & Bugfixes
655    - Revert 'preventing long-press popup' patch, to fix backbutton to work in SocialMagazine
656
657 * Tue Jul 17 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.26
658 - Improvements & Bugfixes
659    - Add tizen-white theme package, to make rpm build to be finished
660
661 * Tue Jul 17 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.25
662 - Improvements & Bugfixes
663    - Set 'slide' as default page transition effect, by JQM patch
664
665 * Fri Jul 13 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.24
666 - Improvements & Bugfixes
667    - Fix IME show/hide algorithm
668    - Fix error on virtualgrid: link _set_scrollbar_size() function to the one in virtuallist
669
670 * Wed Jul 11 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.23
671 - Improvements & Bugfixes
672    - Fix notification position
673    - Fix unit tests
674
675  Fri Jul 6 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.22
676 - Spec changes
677         - JQM 1.1 upgrade
678 - Improvements & Bugfixes
679         - Transform3D support on scrollview
680         - Page layout supports IME control
681         - Mapview supports pinch zoom on JQM 1.1
682         - Fix wrong character on button in minified version
683         - Virtualgrid supports scrollbar
684         - Lots of bugfixes
685
686 * Fri Jun 22 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.20
687 - Spec changes
688         - Support 'latest' version (by symlink) for tizen-web-ui-fw.js path.
689         - imageslider : supports 'resize' event.
690         - listview : listview has 1px padding-bottom.
691         - loader : Change global namespace, from S to $.tizen.
692         - loader : Move loadCustomGlobalizeCulture() into $.tizen.util namespace.
693 - Improvements & Bugfixes
694         - Scrollview : supports 'translate3d', instead of 'translate'.
695         - notification : reset timer when 'show' or 'refresh' event.
696         - JQM patch : Fix vclick event triggered twice.
697 - Etc.
698         - Add & fix unit tests.
699
700 * Thu Jun 14 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.19
701 - Spec changes
702         - mapview : new widget.
703         - notification : add .refresh() API.
704         - pagecontrol : add .value([val]) API, and change an attribute name 'data-initVal' to 'data-value'.
705 - Improvements & Bugfixes
706         - Support minified CSS.
707         - loader : Fix & refactor 'loading globalize culture file' routine.
708         - JQM Patch : Calculate min-height of window in javascript code, and remove predefined min-height value from CSS.
709         - Many more bugfixes.
710 - Etc.
711         - Add many unit tests.
712         - Fix test coverage instrumentation tool to work with current source code.