0.2.4 release
[platform/framework/web/web-ui-fw.git] / packaging / web-ui-fw.spec
1 Name:       web-ui-fw
2 Version:    0.2.4
3 Release:    0
4 Summary:    Tizen Web UI Framework Library
5 Group:      Development/Other
6 License:    MIT
7 BuildArch:  noarch
8 BuildRequires:  make
9 BuildRequires:  nodejs
10 %ifarch %{arm}
11 BuildRequires:  nodejs-x86-arm
12 %endif
13
14 Source0:    %{name}-%{version}.tar.gz
15
16 %description
17 Tizen Web UI Framework library and theme packages
18
19 %prep
20 %setup -q
21
22 %build
23 make all
24
25 %install
26 make DESTDIR=%{buildroot} install
27
28 %post
29
30 %files
31 %manifest web-ui-fw.manifest
32 /usr/share/tizen-web-ui-fw/*/js
33 /usr/share/tizen-web-ui-fw/latest
34 /usr/share/tizen-web-ui-fw/VERSION
35
36 ###############################
37 %package -n web-ui-fw-theme-tizen-gray
38 BuildArch:  noarch
39 Summary:    Tizen Web UI Framework Theme : tizen-gray
40 %Description -n web-ui-fw-theme-tizen-gray
41     Tizen Web UI Framework Theme : tizen-gray
42
43 ###############################
44 %package -n web-ui-fw-theme-tizen-white
45 BuildArch:  noarch
46 Summary:    Tizen Web UI Framework Theme : tizen-white
47 %Description -n web-ui-fw-theme-tizen-white
48     Tizen Web UI Framework Theme : tizen-white
49 %files -n web-ui-fw-theme-tizen-white
50 %manifest web-ui-fw-theme-tizen-white.manifest
51 /usr/share/tizen-web-ui-fw/*/themes/tizen-white
52 /usr/share/tizen-web-ui-fw/*/themes/tizen-tizen
53
54 ###############################
55 %package -n web-ui-fw-theme-default
56 BuildArch:  noarch
57 Summary:    Tizen Web UI Framework Theme : default
58 %Description -n web-ui-fw-theme-default
59     Tizen Web UI Framework Theme : default
60 %files -n web-ui-fw-theme-default
61 %manifest web-ui-fw-theme-default.manifest
62 /usr/share/tizen-web-ui-fw/*/themes/default
63
64 ###############################
65 %package -n web-ui-fw-devel
66 BuildArch:  noarch
67 Summary:    Tizen Web UI Framework Developer's files
68 %Description -n web-ui-fw-devel
69     Tizen Web UI Framework Developer's files
70 %files -n web-ui-fw-devel
71 /usr/share/tizen-web-ui-fw/bin
72 /usr/share/tizen-web-ui-fw/template
73
74 ###############################
75 %package -n web-ui-fw-demo-tizen-winsets
76 BuildArch:  noarch
77 Summary:    Tizen Web UI Framework Demo Application: tizen winset demo
78 %Description -n web-ui-fw-demo-tizen-winsets
79     Tizen Web UI Framework Demo Application: tizen winset demo
80 %files  -n web-ui-fw-demo-tizen-winsets
81 /usr/share/tizen-web-ui-fw/demos/tizen-winsets
82
83
84 ###############################
85 %changelog
86
87 * Fri Dec 20 2012 Youmin Ha <youmin.ha@samsung.com> 0.2.4
88 - Fix:
89         - modify segment background
90         - rearrange check, radio input
91         - CtxPopup: Scale up/ down popup vi(poptop, popbottom)
92         - button: style has beed added(box,circle,nobg,round)
93         - favorite resource added
94         - demo/tizen-winsets: add footer and back button
95         - remove autodividers unit test
96         - add divider for tabbar
97         - checkboxradio: exception handling for input
98         - segment control backward compatiblity
99         - Fix collapsible unit-test
100         - remove toggleswitch
101         - add patch for remove segment text
102 - Spec changes:
103         - replace controlbar to tabbar
104
105 * Fri Dec 14 2012 Minkyu Kang <mk7.kang@samsung.com> 0.2.3
106 - FIX:
107         - slider: add image
108         - button: data-icon support, styles fix
109         - progressbar: modify the background
110         - scrollview: auto scrolling bug fix
111         - pagelayout: IME concept is changed
112 - Spec changes:
113         - dialogue: add edit mode
114         - nocontents: removed
115         - pagecontrol: removed
116         - dayselector: removed
117         - expandablelist: removed
118
119 * Thu Dec 10 2012 Youmin Ha <youmin.ha@samsung.com> 0.2.2
120 - FIX:
121         - chang searchbar/slider images
122         - delete redundant button images
123 - Spec changes:
124         - Change widget name: shortcutscroll -> fastscroll
125
126 * Thu Dec 07 2012 Youmin Ha <youmin.ha@samsung.com> 0.2.1
127 - FIX:
128         - jqm1.2: Change collapsible style to meet expandable list
129         - remove jquery-geo-1.0.a4
130         - unit-test: rename from imageslider to gallery
131         - nocontent: add warning message
132         - Handler: Fix issues in jqm1.2
133         - Multimediaview: modify APIs & comments
134         - Mapview: Fix issues in jqm1.2
135         - JQM: clean up patches
136         - Swipelist: refactoring swipelist
137         - Popup,Ctxpopup: Apply tizen style popup in JQM1.2
138         - rearrange button's data-icon resources
139 - Spec changes:
140         - Virtualgrid: remove option ('data-itemcount')
141         - gallery: rename the widget from imageslider to gallery
142         - add new style for searchbar
143         [tokentextarea] multi-button entry renamed as token text area. API & comments modified.
144
145 * Thu Dec 06 2012 Minkyu Kang <mk7.kang@samsung.com> 0.2.0
146 - FIX:
147         - fix jslint error
148         - remove unused files
149         - change naviframe style
150 - Spec changes:
151         - applied jQuery Mobile 1.2.0
152         - remove optionheader
153
154 * Fri Nov 30 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.64
155 - FIX:
156         - fix unit tests
157         - remove unused theme files
158         - timepicker: text position fix
159         - scrollview: set dragstop when mouse is out of window
160         - listview: fix margin
161 - Spec changes:
162         - support data-framework-viewport-width
163
164 * Fri Nov 23 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.63
165 - FIX:
166         - dayselector: fix size
167         - remove unised styles
168         - divider: set non-press effect to default option
169         - popupwindow: fix window closing failure
170         - handler: GUI implementation
171         - TC: fix unit TCs
172         - scrollview: fix padding size
173 - Spec changes:
174         - Remove color widgets
175         - add $.tizen.pkgVersion for SDK
176 - Etc.
177         - JSDuck documents
178
179 * Fri Nov 16 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.62
180 - FIX:
181         - Many winsets: Fix layout
182         - Footer: fix position to bottom
183 - Spec changes:
184         - Remove color widgets
185
186 * Fri Nov 09 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.61
187 - FIX:
188         - Many widgets: New UX 0.6 theme implementation
189         - widgetex: init speed up
190         - scrollview: fix scrollbar and scale animation
191         - scrollview: fix scroll position when updatelayout is triggered
192         - header/footer: make textselection disable, except input type="text"
193
194 * Wed Nov 07 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.60
195 - FIX:
196         - Remove tizen-black theme package description
197
198 * Tue Nov 06 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.59
199 - FIX:
200         - Fix theme name to meet the change of system theme name: white->tizen
201         - Popupwindow: fix left position
202         - Remove black theme
203         - footer: remove label, legend drawing
204 - Spec changes:
205         - UX guide v0.4 : button, layout
206
207 * Wed Oct 24 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.57
208 - FIX:
209         - expandablelist: icon color fix
210         - scrollview: Fix xy scroll
211         - footer: Remove dummy div
212         - Make string concatnation effective in inline-protos.sh
213 - Spec changes:
214         - refresh header/footer when drag&drop event is fired in GUI builder
215         - searchbar: delete cancel button
216         - don't trigger updatelayout event when keyup event comes
217
218 * Mon Oct 15 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.56
219 - FIX:
220         - Toggleswitch: Change event name from 'changed' to 'change'
221         - Notification: Revert interval feature
222
223 * Tue Oct 09 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.55
224 - FIX:
225         - Fix SMACK manifest bug (S1-9098)
226
227 * Fri Oct 05 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.54
228 - FIX:
229         - handler: don't append a handler if handler is not enabled
230         - scrollview: use static value
231         - datetimepicker: fix date-format HH display error
232 - ETC:
233         - provide jquery.min.js
234         - barlayout: codes clean
235         - remove unused file
236
237 * Wed Sep 26 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.53
238 - FIX:
239         - listview: change focused color
240         - multibuttonentry: code refactoring
241         - datetimepicker: modify date format when triggered date-changed event
242         - slider: fix the top of slider bar
243         - add event blocker when load a first page
244
245 * Fri Sep 21 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.52
246 - ETC.
247         - Move SMACK manifest files to the top SRCDIR
248
249 * Fri Sep 21 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.51
250 - FIX:
251         - Popup: Do not focus container
252         - Header: show backbutton when both tabbar and header are present together
253         - Multi button entry: text ellipsis, code refactoring
254
255 * Fri Sep 21 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.50
256 - ETC.
257         - Apply SMACK manifest
258
259 * Thu Sep 20 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.49
260 - FIX:
261         - JSLINT code clean-up
262         - scrollview: firefox support
263         - scrollview: fix finding slider handle
264         - list: tweak text ellipsis
265         - checkbox: fix selecting wrong label tag (N_SE-8370)
266         - imageslider: check parameter
267         - smallpopup: fix position
268         - searchbar: fix 'clear' button size
269 - Spec changes:
270         - scrollview: support outer scroll
271         - JQM: block click event only with the element that does preventdefault on vclick(N_SE-6090)
272         - remove S/W IME control
273
274 * Thu Sep 13 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.48
275 - FIX:
276         - Add missing icon: controlbar
277         - scrollview: tune scrolling animatio ninterval
278         - datetimepicker: digit/triangle position
279         - datetimepicker: fix day overflow issue
280 - Spec changes:
281         - scrollview: show scrollbar when page is showed
282         - scrollview: disable outer scroll
283         - extendablelist: change api with legacy support
284         - add ui-text-ellipsis class
285
286 * Mon Sep 10 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.47
287 - FIX:
288         - scrollveiw: fix height of view
289         - searchbar: support placeholder
290 - Spec changes:
291         - add ui-text-ellipsis class
292
293 * Fri Sep 07 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.46
294 - FIX:
295         - scrollview: scrolling bug fix
296         - controlbar: fix width of controlbar item
297 - Spec changes:
298         - searchbar: don't hide icon
299         - popup: update JQM poup widget
300
301 * Fri Sep 05 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.45
302 - FIX:
303         - controlbar: set correct controlbar width of last element
304         - slider: get popup enable value correctly
305         - use Date.now() instead of (new Data()).getTime()
306         - popupwindow: fix the background color of popup scroller
307         - listview: add padding-left to expandable list
308         - add ellipsis for title area support
309
310 * Fri Aug 31 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.44
311 - FIX:
312         - swipelist: show list items correctly
313         - datetimepicker: set last day, if day is overflowed
314 - Spec changes:
315         - controlbar: update icons
316
317 * Tue Aug 29 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.43
318 - FIX:
319         - notification: fix typo
320 - Spec changes:
321         - controlbar: update icons
322
323 * Tue Aug 28 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.42
324 - FIX:
325         - multimediaview: video progress bar display normally for too samll
326         - segmentcontrol: remove media query
327         - scrollview: add outer scroll condition
328         - datetimepicker: modify triangle size
329         - popupwindow: set the screen height explicitly
330         - notification: add multiline text
331 - Spec changes:
332         - mutibuttonentry: support new GUI
333         - virtualgrid: support new GUI
334
335 * Mon Aug 27 2012 Jinhyuk Jun <jinhyuk.jun@samsung.com> 0.1.41
336 - FIX:
337         - radio/check button : button size bug fix
338
339 * Fri Aug 24 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.40
340 - FIX:
341         - build error fixed
342
343 * Fri Aug 24 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.39
344 - FIX:
345         - listview: style fix, remove filter placeholder
346         - controlbar: divide styles
347         - scrollview: don't skip dragging when click button or inputbox
348         - slider: trim the text on text slider
349 - Spec changes:
350         - remove gray and blue theme
351         - add white and black theme
352         - support new GUI guide
353
354 * Mon Aug 20 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.38
355 - FIX:
356         - fix coment of version tag
357
358 * Fri Aug 17 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.37
359 - FIX :
360         - button: fix alignment
361         - listview: adjust the main text width
362         - virtualgrid: refactoring
363 - Spec changes:
364         - transition: support JQM 1.1.0 transitions
365         - scrollview: support the outer scroll
366         - notification: remove interval feature
367
368 * Tue Aug 14 2012 Youmin Ha <youmin.ha@samasung.com> 0.1.36
369 - FIX :
370         - checkboxRadio: Add left/right padding
371         - button: custom button & icon position
372         - virtuallist: remove 'recreate' test
373 - Spec changes:
374         - header/footer: enable/disable support
375
376 * Fri Aug 10 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.35
377 - FIX :
378         - expandablelist: modify show animation
379         - virtualgrid: Redesign programming interface
380         - popupwindow: code clean and fixed issues
381         - pagelayout: fix content height
382         - license file update
383         - virtuallist: Change programming interface
384         - datetimepicker: getting days correctly
385         - searchbar: set to hidden when cancel button is hide
386         - White theme title font tuning
387 - Spec changes:
388         - default theme tizen-gray to tizen-white
389         - set default page transition to none
390
391 * Mon Aug 02 2012 Jinhyuk Jun <jinhyuk.jun@samsung.com> 0.1.34
392 - FIX :
393         - Back Button : enlarge backbutton click size for white theme
394 - Feature :
395         - Expandable List : Add refresh api
396 * Mon Aug 02 2012 Jinhyuk Jun <jinhyuk.jun@samsung.com> 0.1.33
397 - FIX :
398         - click event touch threshold tuning
399
400 * Mon Aug 02 2012 Jinhyuk Jun <jinhyuk.jun@samsung.com> 0.1.32
401 - FIX : 
402         - Add back button highlight effect for white theme
403
404 * Mon Aug 01 2012 Jinhyuk Jun <jinhyuk.jun@samsnug.com> 0.1.31
405 - FIX : 
406         - IME checkroutine update, improve relayout on resize event
407         - Add highlight effect for radio button list 
408         - Scrollview : fix condition of updatelayout event
409 - Feature : progressing : add show/hide api
410
411 * Mon Jul 27 2012 Koeun Choi <koeun.choi@samsung.com> 0.1.30
412 - FIX : virtuallist, virtualgrid: Clean up temporary jquery.template object to clear cache
413         add default theme option on buttonMarkup for tizen theme
414         [searchbar] first fix : focus/blur fixed
415         back button does not work when long press
416         scrollview: don't auto scrolling if resizing area is too large
417 - Feature : notification : add api to set the icon at tickernoti
418         demo : update the list sample demo
419         Support tizen default theme
420
421 * Mon Jul 23 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.29
422 - Improvements & Bugfixes
423    - HOTFIX: Revert template function with jquery.template
424
425 * Thu Jul 19 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.28
426 - Improvements & Bugfixes
427    - Fix #WEB-1028: memory leak on virtuallist/virtualgrid
428 - Spec changes
429    - $.tizen.loadTheme() function accepts theme name as arguement
430    - Scrollview supports 'updatelayout' callback
431
432 * Tue Jul 17 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.27
433 - Improvements & Bugfixes
434    - Revert 'preventing long-press popup' patch, to fix backbutton to work in SocialMagazine
435
436 * Tue Jul 17 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.26
437 - Improvements & Bugfixes
438    - Add tizen-white theme package, to make rpm build to be finished
439
440 * Tue Jul 17 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.25
441 - Improvements & Bugfixes
442    - Set 'slide' as default page transition effect, by JQM patch
443
444 * Fri Jul 13 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.24
445 - Improvements & Bugfixes
446    - Fix IME show/hide algorithm
447    - Fix error on virtualgrid: link _set_scrollbar_size() function to the one in virtuallist
448
449 * Wed Jul 11 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.23
450 - Improvements & Bugfixes
451    - Fix notification position
452    - Fix unit tests
453
454  Fri Jul 6 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.22
455 - Spec changes
456         - JQM 1.1 upgrade
457 - Improvements & Bugfixes
458         - Transform3D support on scrollview
459         - Page layout supports IME control
460         - Mapview supports pinch zoom on JQM 1.1
461         - Fix wrong character on button in minified version
462         - Virtualgrid supports scrollbar
463         - Lots of bugfixes
464
465 * Fri Jun 22 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.20
466 - Spec changes
467         - Support 'latest' version (by symlink) for tizen-web-ui-fw.js path.
468         - imageslider : supports 'resize' event.
469         - listview : listview has 1px padding-bottom.
470         - loader : Change global namespace, from S to $.tizen.
471         - loader : Move loadCustomGlobalizeCulture() into $.tizen.util namespace.
472 - Improvements & Bugfixes
473         - Scrollview : supports 'translate3d', instead of 'translate'.
474         - notification : reset timer when 'show' or 'refresh' event.
475         - JQM patch : Fix vclick event triggered twice.
476 - Etc.
477         - Add & fix unit tests.
478
479 * Thu Jun 14 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.19
480 - Spec changes
481         - mapview : new widget.
482         - notification : add .refresh() API.
483         - pagecontrol : add .value([val]) API, and change an attribute name 'data-initVal' to 'data-value'.
484 - Improvements & Bugfixes
485         - Support minified CSS.
486         - loader : Fix & refactor 'loading globalize culture file' routine.
487         - JQM Patch : Calculate min-height of window in javascript code, and remove predefined min-height value from CSS.
488         - Many more bugfixes.
489 - Etc.
490         - Add many unit tests.
491         - Fix test coverage instrumentation tool to work with current source code.