0.2.8 release
[platform/framework/web/web-ui-fw.git] / packaging / web-ui-fw.spec
1 Name:       web-ui-fw
2 Version:    0.2.8
3 Release:    0
4 Summary:    Tizen Web UI Framework Library
5 Group:      Development/Other
6 License:    MIT
7 BuildArch:  noarch
8 BuildRequires:  make
9 BuildRequires:  nodejs
10 %ifarch %{arm}
11 BuildRequires:  nodejs-x86-arm
12 %endif
13
14 Source0:    %{name}-%{version}.tar.gz
15
16 %description
17 Tizen Web UI Framework library and theme packages
18
19 %prep
20 %setup -q
21
22 %build
23 make all
24
25 %install
26 make DESTDIR=%{buildroot} install
27
28 %post
29
30 %files
31 %manifest web-ui-fw.manifest
32 /usr/share/tizen-web-ui-fw/*/js
33 /usr/share/tizen-web-ui-fw/latest
34 /usr/share/tizen-web-ui-fw/VERSION
35
36 ###############################
37 %package -n web-ui-fw-theme-tizen-gray
38 BuildArch:  noarch
39 Summary:    Tizen Web UI Framework Theme : tizen-gray
40 %Description -n web-ui-fw-theme-tizen-gray
41     Tizen Web UI Framework Theme : tizen-gray
42
43 ###############################
44 %package -n web-ui-fw-theme-tizen-white
45 BuildArch:  noarch
46 Summary:    Tizen Web UI Framework Theme : tizen-white
47 %Description -n web-ui-fw-theme-tizen-white
48     Tizen Web UI Framework Theme : tizen-white
49 %files -n web-ui-fw-theme-tizen-white
50 %manifest web-ui-fw-theme-tizen-white.manifest
51 /usr/share/tizen-web-ui-fw/*/themes/tizen-white
52 /usr/share/tizen-web-ui-fw/*/themes/tizen-tizen
53
54 ###############################
55 %package -n web-ui-fw-theme-default
56 BuildArch:  noarch
57 Summary:    Tizen Web UI Framework Theme : default
58 %Description -n web-ui-fw-theme-default
59     Tizen Web UI Framework Theme : default
60 %files -n web-ui-fw-theme-default
61 %manifest web-ui-fw-theme-default.manifest
62 /usr/share/tizen-web-ui-fw/*/themes/default
63
64 ###############################
65 %package -n web-ui-fw-devel
66 BuildArch:  noarch
67 Summary:    Tizen Web UI Framework Developer's files
68 %Description -n web-ui-fw-devel
69     Tizen Web UI Framework Developer's files
70 %files -n web-ui-fw-devel
71 /usr/share/tizen-web-ui-fw/bin
72 /usr/share/tizen-web-ui-fw/template
73
74 ###############################
75 %package -n web-ui-fw-demo-tizen-winsets
76 BuildArch:  noarch
77 Summary:    Tizen Web UI Framework Demo Application: tizen winset demo
78 %Description -n web-ui-fw-demo-tizen-winsets
79     Tizen Web UI Framework Demo Application: tizen winset demo
80 %files  -n web-ui-fw-demo-tizen-winsets
81 /usr/share/tizen-web-ui-fw/demos/tizen-winsets
82
83
84 ###############################
85 %changelog
86
87 * Tue Jan 15 2013 Minkyu Kang <mk7.kang@samsung.com> 0.2.8
88         - Button: button padding has been updated
89         - virtuallist: fix unique listitem ID bug
90         - checkbox, radio : change display attr
91         - Button: bug fix ( when data style circle button on text )
92         - handler: bug fix (when scrolling with multi selection)
93         - JQM: adjust patch number
94         - gallery: show the widget after pageshow
95         - TokenTextArea : resource add ( press image )
96         - gallery: adds function that set the index to value API
97         - configure: set TIZEN default configures
98         - footer: h tag display attribute value has been changed
99         - buttons : demo bug fix
100         - searchbar : demo page bug fix
101         - tizen demo : bug fix
102         - build: remove JQM1.1.0
103         - Tokentextarea: Fix issues
104         - scrollview: block the multi touch
105         - list : dialogue list demo change
106         - pagelayout : update dynamic control
107         - Demo: Context popup close method has been changed
108
109 * Fri Jan 11 2013 Minkyu Kang <mk7.kang@samsung.com> 0.2.7
110         - slider: set text container's width as text length
111         - Timepicker: li max-width has been changed
112         - remove experimental feature - mapview.
113         - scrollview: added conditions for finding slider
114         - UnitTC: Pass,error count save method has been changed
115         - confix.xml: default config added for tizen basic applications
116         - Swipe: p tag margin value is set '0'
117         - packaging: remove unused file
118         - tabbar : bug fix
119         - list demo : bug fix
120         - tizen-winsets: gallery: move to new section
121         - tizen-winsets: autodivider: removes link of list
122         - demos: entry of number-pattern name is changed from 'number' to 'number-pattern'
123         - pagelayout : padding calculate change, ime footer check changed
124         - tizen-winsets: searchbar: scroll to the top when type the character
125         - searchbar : bug fix
126         - demo: Fix virtuallist demo following new list style
127         - demo: Add word-wrap:break-word and remove parag. width
128         - Demo: button max-width has been set( 3 buttons in popup )
129         - back button control demo : bug fix
130         - toggleswitch : demo page modify
131         - slider: add margin-top and margin-bottom
132         - tabbar demo : bug fix
133         - Popup: IME hide when popup is closed
134         - token textarea : bug fix
135         - Timepicker: change get attribute method
136         - footer demo : bug fix
137         - unit-test: gallery: add new APIs
138         - gallery: adds support new APIs
139
140 * Fri Jan 04 2013 Minkyu Kang <mk7.kang@samsung.com> 0.2.6
141         - JQM: patches cleanup
142         - Button: data-corners attribute has been added
143         - unit-test: slider: fix class name of background
144         - progressbar, slider: fix less variable typo
145         - Tabbar : VI update
146         - notification: add top position at fix class
147         - demo: entry demo page change
148         - css: .ui-disabled added
149         - tizen-winset: token textarea: remove back button at demo page
150         - theme: Remove unused less file
151         - pagelayout : content min height bug fix
152         - scrollview: skip the dragging when target is slider's handle
153         - scrollview: update and refactoring the scroll effect
154         - UnitTest:JQM Unit TC helper has been added,TCs have been modified
155         - Swipe: demo page html error has been fixed
156         - listview: Add add/delete animation (VI)
157         - Popup: demo page has been modified
158         - tizen demo : bug fix
159         - searchbar : demo page change(change front button and add behaviour)
160         - pagelayout : add min height to content
161         - gallery: rename 'Image Slider' to 'Gallery' in tizen-winsets demo and tests
162         - back button control demo : change url link to data-rel="back"
163         - loader: Skip loading theme CSS with a custom css code
164         - Button: support no-text in button
165         - collapsible: Fix syntax error
166         - slider: use data-highlight attribute
167         - collapsible: Rotate animation to collapsible heading icon
168         - toggleswitch : text switch bug fix
169         - remove candidates-calendarpicker
170         - Patch: Fix misc mistakes in JQM patches
171         - searchbar : animation change
172         - gallery: get the width correctly
173         - demo: data-framework-viewport-scale attribute is changed to data-framework-viewport-width
174         - collapsible: Add collapse/expand animation (VI)
175         - datetimepicker: VI update
176         - JQM: set transition to pop as default
177         - tabbar : bug fix in case none li element case
178         - scrollview: fix the drag bug
179         - Button: Button icon scrolltop, left has beed added
180         - Swipe: VI update and swipe speed has been changed
181         - jqm: fix errors in patch files
182         - unit-test: swipe: fixed the destroy test
183
184 * Wed Dec 26 2012 Youmin Ha <youmin.ha@samsung.com> 0.2.5
185         - Revert "[checkboxradio] exception handling for input"
186                 This reverts commit 72478c32704fa96362db577e6cf9511777919ea8.
187                 Tizen style supports no-label radio and checkbox when making lists.
188                 So it ignores html input operation. Instead, it supports tizen style radio and checkbox theme.
189
190 * Thu Dec 20 2012 Youmin Ha <youmin.ha@samsung.com> 0.2.4
191 - Fix:
192         - modify segment background
193         - rearrange check, radio input
194         - CtxPopup: Scale up/ down popup vi(poptop, popbottom)
195         - button: style has beed added(box,circle,nobg,round)
196         - favorite resource added
197         - demo/tizen-winsets: add footer and back button
198         - remove autodividers unit test
199         - add divider for tabbar
200         - checkboxradio: exception handling for input
201         - segment control backward compatiblity
202         - Fix collapsible unit-test
203         - remove toggleswitch
204         - add patch for remove segment text
205 - Spec changes:
206         - replace controlbar to tabbar
207
208 * Fri Dec 14 2012 Minkyu Kang <mk7.kang@samsung.com> 0.2.3
209 - FIX:
210         - slider: add image
211         - button: data-icon support, styles fix
212         - progressbar: modify the background
213         - scrollview: auto scrolling bug fix
214         - pagelayout: IME concept is changed
215 - Spec changes:
216         - dialogue: add edit mode
217         - nocontents: removed
218         - pagecontrol: removed
219         - dayselector: removed
220         - expandablelist: removed
221
222 * Thu Dec 10 2012 Youmin Ha <youmin.ha@samsung.com> 0.2.2
223 - FIX:
224         - chang searchbar/slider images
225         - delete redundant button images
226 - Spec changes:
227         - Change widget name: shortcutscroll -> fastscroll
228
229 * Thu Dec 07 2012 Youmin Ha <youmin.ha@samsung.com> 0.2.1
230 - FIX:
231         - jqm1.2: Change collapsible style to meet expandable list
232         - remove jquery-geo-1.0.a4
233         - unit-test: rename from imageslider to gallery
234         - nocontent: add warning message
235         - Handler: Fix issues in jqm1.2
236         - Multimediaview: modify APIs & comments
237         - Mapview: Fix issues in jqm1.2
238         - JQM: clean up patches
239         - Swipelist: refactoring swipelist
240         - Popup,Ctxpopup: Apply tizen style popup in JQM1.2
241         - rearrange button's data-icon resources
242 - Spec changes:
243         - Virtualgrid: remove option ('data-itemcount')
244         - gallery: rename the widget from imageslider to gallery
245         - add new style for searchbar
246         [tokentextarea] multi-button entry renamed as token text area. API & comments modified.
247
248 * Thu Dec 06 2012 Minkyu Kang <mk7.kang@samsung.com> 0.2.0
249 - FIX:
250         - fix jslint error
251         - remove unused files
252         - change naviframe style
253 - Spec changes:
254         - applied jQuery Mobile 1.2.0
255         - remove optionheader
256
257 * Fri Nov 30 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.64
258 - FIX:
259         - fix unit tests
260         - remove unused theme files
261         - timepicker: text position fix
262         - scrollview: set dragstop when mouse is out of window
263         - listview: fix margin
264 - Spec changes:
265         - support data-framework-viewport-width
266
267 * Fri Nov 23 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.63
268 - FIX:
269         - dayselector: fix size
270         - remove unised styles
271         - divider: set non-press effect to default option
272         - popupwindow: fix window closing failure
273         - handler: GUI implementation
274         - TC: fix unit TCs
275         - scrollview: fix padding size
276 - Spec changes:
277         - Remove color widgets
278         - add $.tizen.pkgVersion for SDK
279 - Etc.
280         - JSDuck documents
281
282 * Fri Nov 16 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.62
283 - FIX:
284         - Many winsets: Fix layout
285         - Footer: fix position to bottom
286 - Spec changes:
287         - Remove color widgets
288
289 * Fri Nov 09 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.61
290 - FIX:
291         - Many widgets: New UX 0.6 theme implementation
292         - widgetex: init speed up
293         - scrollview: fix scrollbar and scale animation
294         - scrollview: fix scroll position when updatelayout is triggered
295         - header/footer: make textselection disable, except input type="text"
296
297 * Wed Nov 07 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.60
298 - FIX:
299         - Remove tizen-black theme package description
300
301 * Tue Nov 06 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.59
302 - FIX:
303         - Fix theme name to meet the change of system theme name: white->tizen
304         - Popupwindow: fix left position
305         - Remove black theme
306         - footer: remove label, legend drawing
307 - Spec changes:
308         - UX guide v0.4 : button, layout
309
310 * Wed Oct 24 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.57
311 - FIX:
312         - expandablelist: icon color fix
313         - scrollview: Fix xy scroll
314         - footer: Remove dummy div
315         - Make string concatnation effective in inline-protos.sh
316 - Spec changes:
317         - refresh header/footer when drag&drop event is fired in GUI builder
318         - searchbar: delete cancel button
319         - don't trigger updatelayout event when keyup event comes
320
321 * Mon Oct 15 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.56
322 - FIX:
323         - Toggleswitch: Change event name from 'changed' to 'change'
324         - Notification: Revert interval feature
325
326 * Tue Oct 09 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.55
327 - FIX:
328         - Fix SMACK manifest bug (S1-9098)
329
330 * Fri Oct 05 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.54
331 - FIX:
332         - handler: don't append a handler if handler is not enabled
333         - scrollview: use static value
334         - datetimepicker: fix date-format HH display error
335 - ETC:
336         - provide jquery.min.js
337         - barlayout: codes clean
338         - remove unused file
339
340 * Wed Sep 26 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.53
341 - FIX:
342         - listview: change focused color
343         - multibuttonentry: code refactoring
344         - datetimepicker: modify date format when triggered date-changed event
345         - slider: fix the top of slider bar
346         - add event blocker when load a first page
347
348 * Fri Sep 21 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.52
349 - ETC.
350         - Move SMACK manifest files to the top SRCDIR
351
352 * Fri Sep 21 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.51
353 - FIX:
354         - Popup: Do not focus container
355         - Header: show backbutton when both tabbar and header are present together
356         - Multi button entry: text ellipsis, code refactoring
357
358 * Fri Sep 21 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.50
359 - ETC.
360         - Apply SMACK manifest
361
362 * Thu Sep 20 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.49
363 - FIX:
364         - JSLINT code clean-up
365         - scrollview: firefox support
366         - scrollview: fix finding slider handle
367         - list: tweak text ellipsis
368         - checkbox: fix selecting wrong label tag (N_SE-8370)
369         - imageslider: check parameter
370         - smallpopup: fix position
371         - searchbar: fix 'clear' button size
372 - Spec changes:
373         - scrollview: support outer scroll
374         - JQM: block click event only with the element that does preventdefault on vclick(N_SE-6090)
375         - remove S/W IME control
376
377 * Thu Sep 13 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.48
378 - FIX:
379         - Add missing icon: controlbar
380         - scrollview: tune scrolling animatio ninterval
381         - datetimepicker: digit/triangle position
382         - datetimepicker: fix day overflow issue
383 - Spec changes:
384         - scrollview: show scrollbar when page is showed
385         - scrollview: disable outer scroll
386         - extendablelist: change api with legacy support
387         - add ui-text-ellipsis class
388
389 * Mon Sep 10 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.47
390 - FIX:
391         - scrollveiw: fix height of view
392         - searchbar: support placeholder
393 - Spec changes:
394         - add ui-text-ellipsis class
395
396 * Fri Sep 07 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.46
397 - FIX:
398         - scrollview: scrolling bug fix
399         - controlbar: fix width of controlbar item
400 - Spec changes:
401         - searchbar: don't hide icon
402         - popup: update JQM poup widget
403
404 * Fri Sep 05 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.45
405 - FIX:
406         - controlbar: set correct controlbar width of last element
407         - slider: get popup enable value correctly
408         - use Date.now() instead of (new Data()).getTime()
409         - popupwindow: fix the background color of popup scroller
410         - listview: add padding-left to expandable list
411         - add ellipsis for title area support
412
413 * Fri Aug 31 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.44
414 - FIX:
415         - swipelist: show list items correctly
416         - datetimepicker: set last day, if day is overflowed
417 - Spec changes:
418         - controlbar: update icons
419
420 * Tue Aug 29 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.43
421 - FIX:
422         - notification: fix typo
423 - Spec changes:
424         - controlbar: update icons
425
426 * Tue Aug 28 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.42
427 - FIX:
428         - multimediaview: video progress bar display normally for too samll
429         - segmentcontrol: remove media query
430         - scrollview: add outer scroll condition
431         - datetimepicker: modify triangle size
432         - popupwindow: set the screen height explicitly
433         - notification: add multiline text
434 - Spec changes:
435         - mutibuttonentry: support new GUI
436         - virtualgrid: support new GUI
437
438 * Mon Aug 27 2012 Jinhyuk Jun <jinhyuk.jun@samsung.com> 0.1.41
439 - FIX:
440         - radio/check button : button size bug fix
441
442 * Fri Aug 24 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.40
443 - FIX:
444         - build error fixed
445
446 * Fri Aug 24 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.39
447 - FIX:
448         - listview: style fix, remove filter placeholder
449         - controlbar: divide styles
450         - scrollview: don't skip dragging when click button or inputbox
451         - slider: trim the text on text slider
452 - Spec changes:
453         - remove gray and blue theme
454         - add white and black theme
455         - support new GUI guide
456
457 * Mon Aug 20 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.38
458 - FIX:
459         - fix coment of version tag
460
461 * Fri Aug 17 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.37
462 - FIX :
463         - button: fix alignment
464         - listview: adjust the main text width
465         - virtualgrid: refactoring
466 - Spec changes:
467         - transition: support JQM 1.1.0 transitions
468         - scrollview: support the outer scroll
469         - notification: remove interval feature
470
471 * Tue Aug 14 2012 Youmin Ha <youmin.ha@samasung.com> 0.1.36
472 - FIX :
473         - checkboxRadio: Add left/right padding
474         - button: custom button & icon position
475         - virtuallist: remove 'recreate' test
476 - Spec changes:
477         - header/footer: enable/disable support
478
479 * Fri Aug 10 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.35
480 - FIX :
481         - expandablelist: modify show animation
482         - virtualgrid: Redesign programming interface
483         - popupwindow: code clean and fixed issues
484         - pagelayout: fix content height
485         - license file update
486         - virtuallist: Change programming interface
487         - datetimepicker: getting days correctly
488         - searchbar: set to hidden when cancel button is hide
489         - White theme title font tuning
490 - Spec changes:
491         - default theme tizen-gray to tizen-white
492         - set default page transition to none
493
494 * Mon Aug 02 2012 Jinhyuk Jun <jinhyuk.jun@samsung.com> 0.1.34
495 - FIX :
496         - Back Button : enlarge backbutton click size for white theme
497 - Feature :
498         - Expandable List : Add refresh api
499 * Mon Aug 02 2012 Jinhyuk Jun <jinhyuk.jun@samsung.com> 0.1.33
500 - FIX :
501         - click event touch threshold tuning
502
503 * Mon Aug 02 2012 Jinhyuk Jun <jinhyuk.jun@samsung.com> 0.1.32
504 - FIX : 
505         - Add back button highlight effect for white theme
506
507 * Mon Aug 01 2012 Jinhyuk Jun <jinhyuk.jun@samsnug.com> 0.1.31
508 - FIX : 
509         - IME checkroutine update, improve relayout on resize event
510         - Add highlight effect for radio button list 
511         - Scrollview : fix condition of updatelayout event
512 - Feature : progressing : add show/hide api
513
514 * Mon Jul 27 2012 Koeun Choi <koeun.choi@samsung.com> 0.1.30
515 - FIX : virtuallist, virtualgrid: Clean up temporary jquery.template object to clear cache
516         add default theme option on buttonMarkup for tizen theme
517         [searchbar] first fix : focus/blur fixed
518         back button does not work when long press
519         scrollview: don't auto scrolling if resizing area is too large
520 - Feature : notification : add api to set the icon at tickernoti
521         demo : update the list sample demo
522         Support tizen default theme
523
524 * Mon Jul 23 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.29
525 - Improvements & Bugfixes
526    - HOTFIX: Revert template function with jquery.template
527
528 * Thu Jul 19 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.28
529 - Improvements & Bugfixes
530    - Fix #WEB-1028: memory leak on virtuallist/virtualgrid
531 - Spec changes
532    - $.tizen.loadTheme() function accepts theme name as arguement
533    - Scrollview supports 'updatelayout' callback
534
535 * Tue Jul 17 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.27
536 - Improvements & Bugfixes
537    - Revert 'preventing long-press popup' patch, to fix backbutton to work in SocialMagazine
538
539 * Tue Jul 17 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.26
540 - Improvements & Bugfixes
541    - Add tizen-white theme package, to make rpm build to be finished
542
543 * Tue Jul 17 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.25
544 - Improvements & Bugfixes
545    - Set 'slide' as default page transition effect, by JQM patch
546
547 * Fri Jul 13 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.24
548 - Improvements & Bugfixes
549    - Fix IME show/hide algorithm
550    - Fix error on virtualgrid: link _set_scrollbar_size() function to the one in virtuallist
551
552 * Wed Jul 11 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.23
553 - Improvements & Bugfixes
554    - Fix notification position
555    - Fix unit tests
556
557  Fri Jul 6 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.22
558 - Spec changes
559         - JQM 1.1 upgrade
560 - Improvements & Bugfixes
561         - Transform3D support on scrollview
562         - Page layout supports IME control
563         - Mapview supports pinch zoom on JQM 1.1
564         - Fix wrong character on button in minified version
565         - Virtualgrid supports scrollbar
566         - Lots of bugfixes
567
568 * Fri Jun 22 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.20
569 - Spec changes
570         - Support 'latest' version (by symlink) for tizen-web-ui-fw.js path.
571         - imageslider : supports 'resize' event.
572         - listview : listview has 1px padding-bottom.
573         - loader : Change global namespace, from S to $.tizen.
574         - loader : Move loadCustomGlobalizeCulture() into $.tizen.util namespace.
575 - Improvements & Bugfixes
576         - Scrollview : supports 'translate3d', instead of 'translate'.
577         - notification : reset timer when 'show' or 'refresh' event.
578         - JQM patch : Fix vclick event triggered twice.
579 - Etc.
580         - Add & fix unit tests.
581
582 * Thu Jun 14 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.19
583 - Spec changes
584         - mapview : new widget.
585         - notification : add .refresh() API.
586         - pagecontrol : add .value([val]) API, and change an attribute name 'data-initVal' to 'data-value'.
587 - Improvements & Bugfixes
588         - Support minified CSS.
589         - loader : Fix & refactor 'loading globalize culture file' routine.
590         - JQM Patch : Calculate min-height of window in javascript code, and remove predefined min-height value from CSS.
591         - Many more bugfixes.
592 - Etc.
593         - Add many unit tests.
594         - Fix test coverage instrumentation tool to work with current source code.