Export 0.1.55
[platform/framework/web/web-ui-fw.git] / packaging / web-ui-fw.spec
1 Name:       web-ui-fw
2 Version:    0.1.55
3 Release:    0
4 Summary:    Tizen Web UI Framework Library
5 Group:      Development/Other
6 License:    MIT
7 BuildArch:  noarch
8 BuildRequires:  make
9 BuildRequires:  nodejs
10 %ifarch %{arm}
11 BuildRequires:  nodejs-x86-arm
12 %endif
13
14 Source0:    %{name}-%{version}.tar.gz
15
16 %description
17 Tizen Web UI Framework library and theme packages
18
19 %prep
20 %setup -q
21
22 %build
23 make all
24
25 %install
26 make DESTDIR=%{buildroot} install
27
28 %post
29
30 %files
31 %manifest web-ui-fw.manifest
32 /usr/share/tizen-web-ui-fw/*/js
33 /usr/share/tizen-web-ui-fw/latest
34
35 ###############################
36 %package -n web-ui-fw-theme-tizen-gray
37 BuildArch:  noarch
38 Summary:    Tizen Web UI Framework Theme : tizen-gray
39 %Description -n web-ui-fw-theme-tizen-gray
40     Tizen Web UI Framework Theme : tizen-gray
41
42 ###############################
43 %package -n web-ui-fw-theme-tizen-black
44 BuildArch:  noarch
45 Summary:    Tizen Web UI Framework Theme : tizen-black
46 %Description -n web-ui-fw-theme-tizen-black
47     Tizen Web UI Framework Theme : tizen-black
48 %files -n web-ui-fw-theme-tizen-black
49 %manifest web-ui-fw-theme-tizen-black.manifest
50 /usr/share/tizen-web-ui-fw/*/themes/tizen-black
51
52 ###############################
53 %package -n web-ui-fw-theme-tizen-white
54 BuildArch:  noarch
55 Summary:    Tizen Web UI Framework Theme : tizen-white
56 %Description -n web-ui-fw-theme-tizen-white
57     Tizen Web UI Framework Theme : tizen-white
58 %files -n web-ui-fw-theme-tizen-white
59 %manifest web-ui-fw-theme-tizen-white.manifest
60 /usr/share/tizen-web-ui-fw/*/themes/tizen-white
61
62 ###############################
63 %package -n web-ui-fw-theme-default
64 BuildArch:  noarch
65 Summary:    Tizen Web UI Framework Theme : default
66 %Description -n web-ui-fw-theme-default
67     Tizen Web UI Framework Theme : default
68 %files -n web-ui-fw-theme-default
69 %manifest web-ui-fw-theme-default.manifest
70 /usr/share/tizen-web-ui-fw/*/themes/default
71
72 ###############################
73 %package -n web-ui-fw-devel
74 BuildArch:  noarch
75 Summary:    Tizen Web UI Framework Developer's files
76 %Description -n web-ui-fw-devel
77     Tizen Web UI Framework Developer's files
78 %files -n web-ui-fw-devel
79 /usr/share/tizen-web-ui-fw/bin
80 /usr/share/tizen-web-ui-fw/template
81
82 ###############################
83 %package -n web-ui-fw-demo-tizen-winsets
84 BuildArch:  noarch
85 Summary:    Tizen Web UI Framework Demo Application: tizen winset demo
86 %Description -n web-ui-fw-demo-tizen-winsets
87     Tizen Web UI Framework Demo Application: tizen winset demo
88 %files  -n web-ui-fw-demo-tizen-winsets
89 /usr/share/tizen-web-ui-fw/demos/tizen-winsets
90
91
92 ###############################
93 %changelog
94 * Tue Oct 09 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.55
95 - FIX:
96         - Fix SMACK manifest bug (S1-9098)
97
98 * Fri Oct 05 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.54
99 - FIX:
100         - handler: don't append a handler if handler is not enabled
101         - scrollview: use static value
102         - datetimepicker: fix date-format HH display error
103 - ETC:
104         - provide jquery.min.js
105         - barlayout: codes clean
106         - remove unused file
107
108 * Wed Sep 26 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.53
109 - FIX:
110         - listview: change focused color
111         - multibuttonentry: code refactoring
112         - datetimepicker: modify date format when triggered date-changed event
113         - slider: fix the top of slider bar
114         - add event blocker when load a first page
115
116 * Fri Sep 21 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.52
117 - ETC.
118         - Move SMACK manifest files to the top SRCDIR
119
120 * Fri Sep 21 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.51
121 - FIX:
122         - Popup: Do not focus container
123         - Header: show backbutton when both tabbar and header are present together
124         - Multi button entry: text ellipsis, code refactoring
125
126 * Fri Sep 21 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.50
127 - ETC.
128         - Apply SMACK manifest
129
130 * Thu Sep 20 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.49
131 - FIX:
132         - JSLINT code clean-up
133         - scrollview: firefox support
134         - scrollview: fix finding slider handle
135         - list: tweak text ellipsis
136         - checkbox: fix selecting wrong label tag (N_SE-8370)
137         - imageslider: check parameter
138         - smallpopup: fix position
139         - searchbar: fix 'clear' button size
140 - Spec changes:
141         - scrollview: support outer scroll
142         - JQM: block click event only with the element that does preventdefault on vclick(N_SE-6090)
143         - remove S/W IME control
144
145 * Thu Sep 13 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.48
146 - FIX:
147         - Add missing icon: controlbar
148         - scrollview: tune scrolling animatio ninterval
149         - datetimepicker: digit/triangle position
150         - datetimepicker: fix day overflow issue
151 - Spec changes:
152         - scrollview: show scrollbar when page is showed
153         - scrollview: disable outer scroll
154         - extendablelist: change api with legacy support
155         - add ui-text-ellipsis class
156
157 * Mon Sep 10 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.47
158 - FIX:
159         - scrollveiw: fix height of view
160         - searchbar: support placeholder
161 - Spec changes:
162         - add ui-text-ellipsis class
163
164 * Fri Sep 07 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.46
165 - FIX:
166         - scrollview: scrolling bug fix
167         - controlbar: fix width of controlbar item
168 - Spec changes:
169         - searchbar: don't hide icon
170         - popup: update JQM poup widget
171
172 * Fri Sep 05 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.45
173 - FIX:
174         - controlbar: set correct controlbar width of last element
175         - slider: get popup enable value correctly
176         - use Date.now() instead of (new Data()).getTime()
177         - popupwindow: fix the background color of popup scroller
178         - listview: add padding-left to expandable list
179         - add ellipsis for title area support
180
181 * Fri Aug 31 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.44
182 - FIX:
183         - swipelist: show list items correctly
184         - datetimepicker: set last day, if day is overflowed
185 - Spec changes:
186         - controlbar: update icons
187
188 * Tue Aug 29 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.43
189 - FIX:
190         - notification: fix typo
191 - Spec changes:
192         - controlbar: update icons
193
194 * Tue Aug 28 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.42
195 - FIX:
196         - multimediaview: video progress bar display normally for too samll
197         - segmentcontrol: remove media query
198         - scrollview: add outer scroll condition
199         - datetimepicker: modify triangle size
200         - popupwindow: set the screen height explicitly
201         - notification: add multiline text
202 - Spec changes:
203         - mutibuttonentry: support new GUI
204         - virtualgrid: support new GUI
205
206 * Mon Aug 27 2012 Jinhyuk Jun <jinhyuk.jun@samsung.com> 0.1.41
207 - FIX:
208         - radio/check button : button size bug fix
209
210 * Fri Aug 24 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.40
211 - FIX:
212         - build error fixed
213
214 * Fri Aug 24 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.39
215 - FIX:
216         - listview: style fix, remove filter placeholder
217         - controlbar: divide styles
218         - scrollview: don't skip dragging when click button or inputbox
219         - slider: trim the text on text slider
220 - Spec changes:
221         - remove gray and blue theme
222         - add white and black theme
223         - support new GUI guide
224
225 * Mon Aug 20 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.38
226 - FIX:
227         - fix coment of version tag
228
229 * Fri Aug 17 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.37
230 - FIX :
231         - button: fix alignment
232         - listview: adjust the main text width
233         - virtualgrid: refactoring
234 - Spec changes:
235         - transition: support JQM 1.1.0 transitions
236         - scrollview: support the outer scroll
237         - notification: remove interval feature
238
239 * Tue Aug 14 2012 Youmin Ha <youmin.ha@samasung.com> 0.1.36
240 - FIX :
241         - checkboxRadio: Add left/right padding
242         - button: custom button & icon position
243         - virtuallist: remove 'recreate' test
244 - Spec changes:
245         - header/footer: enable/disable support
246
247 * Fri Aug 10 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.35
248 - FIX :
249         - expandablelist: modify show animation
250         - virtualgrid: Redesign programming interface
251         - popupwindow: code clean and fixed issues
252         - pagelayout: fix content height
253         - license file update
254         - virtuallist: Change programming interface
255         - datetimepicker: getting days correctly
256         - searchbar: set to hidden when cancel button is hide
257         - White theme title font tuning
258 - Spec changes:
259         - default theme tizen-gray to tizen-white
260         - set default page transition to none
261
262 * Mon Aug 02 2012 Jinhyuk Jun <jinhyuk.jun@samsung.com> 0.1.34
263 - FIX :
264         - Back Button : enlarge backbutton click size for white theme
265 - Feature :
266         - Expandable List : Add refresh api
267 * Mon Aug 02 2012 Jinhyuk Jun <jinhyuk.jun@samsung.com> 0.1.33
268 - FIX :
269         - click event touch threshold tuning
270
271 * Mon Aug 02 2012 Jinhyuk Jun <jinhyuk.jun@samsung.com> 0.1.32
272 - FIX : 
273         - Add back button highlight effect for white theme
274
275 * Mon Aug 01 2012 Jinhyuk Jun <jinhyuk.jun@samsnug.com> 0.1.31
276 - FIX : 
277         - IME checkroutine update, improve relayout on resize event
278         - Add highlight effect for radio button list 
279         - Scrollview : fix condition of updatelayout event
280 - Feature : progressing : add show/hide api
281
282 * Mon Jul 27 2012 Koeun Choi <koeun.choi@samsung.com> 0.1.30
283 - FIX : virtuallist, virtualgrid: Clean up temporary jquery.template object to clear cache
284         add default theme option on buttonMarkup for tizen theme
285         [searchbar] first fix : focus/blur fixed
286         back button does not work when long press
287         scrollview: don't auto scrolling if resizing area is too large
288 - Feature : notification : add api to set the icon at tickernoti
289         demo : update the list sample demo
290         Support tizen default theme
291
292 * Mon Jul 23 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.29
293 - Improvements & Bugfixes
294    - HOTFIX: Revert template function with jquery.template
295
296 * Thu Jul 19 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.28
297 - Improvements & Bugfixes
298    - Fix #WEB-1028: memory leak on virtuallist/virtualgrid
299 - Spec changes
300    - $.tizen.loadTheme() function accepts theme name as arguement
301    - Scrollview supports 'updatelayout' callback
302
303 * Tue Jul 17 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.27
304 - Improvements & Bugfixes
305    - Revert 'preventing long-press popup' patch, to fix backbutton to work in SocialMagazine
306
307 * Tue Jul 17 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.26
308 - Improvements & Bugfixes
309    - Add tizen-white theme package, to make rpm build to be finished
310
311 * Tue Jul 17 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.25
312 - Improvements & Bugfixes
313    - Set 'slide' as default page transition effect, by JQM patch
314
315 * Fri Jul 13 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.24
316 - Improvements & Bugfixes
317    - Fix IME show/hide algorithm
318    - Fix error on virtualgrid: link _set_scrollbar_size() function to the one in virtuallist
319
320 * Wed Jul 11 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.23
321 - Improvements & Bugfixes
322    - Fix notification position
323    - Fix unit tests
324
325  Fri Jul 6 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.22
326 - Spec changes
327         - JQM 1.1 upgrade
328 - Improvements & Bugfixes
329         - Transform3D support on scrollview
330         - Page layout supports IME control
331         - Mapview supports pinch zoom on JQM 1.1
332         - Fix wrong character on button in minified version
333         - Virtualgrid supports scrollbar
334         - Lots of bugfixes
335
336 * Fri Jun 22 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.20
337 - Spec changes
338         - Support 'latest' version (by symlink) for tizen-web-ui-fw.js path.
339         - imageslider : supports 'resize' event.
340         - listview : listview has 1px padding-bottom.
341         - loader : Change global namespace, from S to $.tizen.
342         - loader : Move loadCustomGlobalizeCulture() into $.tizen.util namespace.
343 - Improvements & Bugfixes
344         - Scrollview : supports 'translate3d', instead of 'translate'.
345         - notification : reset timer when 'show' or 'refresh' event.
346         - JQM patch : Fix vclick event triggered twice.
347 - Etc.
348         - Add & fix unit tests.
349
350 * Thu Jun 14 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.19
351 - Spec changes
352         - mapview : new widget.
353         - notification : add .refresh() API.
354         - pagecontrol : add .value([val]) API, and change an attribute name 'data-initVal' to 'data-value'.
355 - Improvements & Bugfixes
356         - Support minified CSS.
357         - loader : Fix & refactor 'loading globalize culture file' routine.
358         - JQM Patch : Calculate min-height of window in javascript code, and remove predefined min-height value from CSS.
359         - Many more bugfixes.
360 - Etc.
361         - Add many unit tests.
362         - Fix test coverage instrumentation tool to work with current source code.