Export 0.2.3
[platform/framework/web/web-ui-fw.git] / packaging / web-ui-fw.spec
1 Name:       web-ui-fw
2 Version:    0.2.3
3 Release:    0
4 Summary:    Tizen Web UI Framework Library
5 Group:      Development/Other
6 License:    MIT
7 BuildArch:  noarch
8 BuildRequires:  make
9 BuildRequires:  nodejs
10 %ifarch %{arm}
11 BuildRequires:  nodejs-x86-arm
12 %endif
13
14 Source0:    %{name}-%{version}.tar.gz
15
16 %description
17 Tizen Web UI Framework library and theme packages
18
19 %prep
20 %setup -q
21
22 %build
23 make all
24
25 %install
26 make DESTDIR=%{buildroot} install
27
28 %post
29
30 %files
31 %manifest web-ui-fw.manifest
32 /usr/share/tizen-web-ui-fw/*/js
33 /usr/share/tizen-web-ui-fw/latest
34 /usr/share/tizen-web-ui-fw/VERSION
35
36 ###############################
37 %package -n web-ui-fw-theme-tizen-gray
38 BuildArch:  noarch
39 Summary:    Tizen Web UI Framework Theme : tizen-gray
40 %Description -n web-ui-fw-theme-tizen-gray
41     Tizen Web UI Framework Theme : tizen-gray
42
43 ###############################
44 %package -n web-ui-fw-theme-tizen-white
45 BuildArch:  noarch
46 Summary:    Tizen Web UI Framework Theme : tizen-white
47 %Description -n web-ui-fw-theme-tizen-white
48     Tizen Web UI Framework Theme : tizen-white
49 %files -n web-ui-fw-theme-tizen-white
50 %manifest web-ui-fw-theme-tizen-white.manifest
51 /usr/share/tizen-web-ui-fw/*/themes/tizen-white
52 /usr/share/tizen-web-ui-fw/*/themes/tizen-tizen
53
54 ###############################
55 %package -n web-ui-fw-theme-default
56 BuildArch:  noarch
57 Summary:    Tizen Web UI Framework Theme : default
58 %Description -n web-ui-fw-theme-default
59     Tizen Web UI Framework Theme : default
60 %files -n web-ui-fw-theme-default
61 %manifest web-ui-fw-theme-default.manifest
62 /usr/share/tizen-web-ui-fw/*/themes/default
63
64 ###############################
65 %package -n web-ui-fw-devel
66 BuildArch:  noarch
67 Summary:    Tizen Web UI Framework Developer's files
68 %Description -n web-ui-fw-devel
69     Tizen Web UI Framework Developer's files
70 %files -n web-ui-fw-devel
71 /usr/share/tizen-web-ui-fw/bin
72 /usr/share/tizen-web-ui-fw/template
73
74 ###############################
75 %package -n web-ui-fw-demo-tizen-winsets
76 BuildArch:  noarch
77 Summary:    Tizen Web UI Framework Demo Application: tizen winset demo
78 %Description -n web-ui-fw-demo-tizen-winsets
79     Tizen Web UI Framework Demo Application: tizen winset demo
80 %files  -n web-ui-fw-demo-tizen-winsets
81 /usr/share/tizen-web-ui-fw/demos/tizen-winsets
82
83
84 ###############################
85 %changelog
86 * Fri Dec 14 2012 Minkyu Kang <mk7.kang@samsung.com> 0.2.3
87 - FIX:
88         - slider: add image
89         - button: data-icon support, styles fix
90         - progressbar: modify the background
91         - scrollview: auto scrolling bug fix
92         - pagelayout: IME concept is changed
93 - Spec changes:
94         - dialogue: add edit mode
95         - nocontents: removed
96         - pagecontrol: removed
97         - dayselector: removed
98         - expandablelist: removed
99
100 * Thu Dec 10 2012 Youmin Ha <youmin.ha@samsung.com> 0.2.2
101 - FIX:
102         - chang searchbar/slider images
103         - delete redundant button images
104 - Spec changes:
105         - Change widget name: shortcutscroll -> fastscroll
106
107 * Thu Dec 07 2012 Youmin Ha <youmin.ha@samsung.com> 0.2.1
108 - FIX:
109         - jqm1.2: Change collapsible style to meet expandable list
110         - remove jquery-geo-1.0.a4
111         - unit-test: rename from imageslider to gallery
112         - nocontent: add warning message
113         - Handler: Fix issues in jqm1.2
114         - Multimediaview: modify APIs & comments
115         - Mapview: Fix issues in jqm1.2
116         - JQM: clean up patches
117         - Swipelist: refactoring swipelist
118         - Popup,Ctxpopup: Apply tizen style popup in JQM1.2
119         - rearrange button's data-icon resources
120 - Spec changes:
121         - Virtualgrid: remove option ('data-itemcount')
122         - gallery: rename the widget from imageslider to gallery
123         - add new style for searchbar
124         [tokentextarea] multi-button entry renamed as token text area. API & comments modified.
125
126 * Thu Dec 06 2012 Minkyu Kang <mk7.kang@samsung.com> 0.2.0
127 - FIX:
128         - fix jslint error
129         - remove unused files
130         - change naviframe style
131 - Spec changes:
132         - applied jQuery Mobile 1.2.0
133         - remove optionheader
134
135 * Fri Nov 30 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.64
136 - FIX:
137         - fix unit tests
138         - remove unused theme files
139         - timepicker: text position fix
140         - scrollview: set dragstop when mouse is out of window
141         - listview: fix margin
142 - Spec changes:
143         - support data-framework-viewport-width
144
145 * Fri Nov 23 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.63
146 - FIX:
147         - dayselector: fix size
148         - remove unised styles
149         - divider: set non-press effect to default option
150         - popupwindow: fix window closing failure
151         - handler: GUI implementation
152         - TC: fix unit TCs
153         - scrollview: fix padding size
154 - Spec changes:
155         - Remove color widgets
156         - add $.tizen.pkgVersion for SDK
157 - Etc.
158         - JSDuck documents
159
160 * Fri Nov 16 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.62
161 - FIX:
162         - Many winsets: Fix layout
163         - Footer: fix position to bottom
164 - Spec changes:
165         - Remove color widgets
166
167 * Fri Nov 09 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.61
168 - FIX:
169         - Many widgets: New UX 0.6 theme implementation
170         - widgetex: init speed up
171         - scrollview: fix scrollbar and scale animation
172         - scrollview: fix scroll position when updatelayout is triggered
173         - header/footer: make textselection disable, except input type="text"
174
175 * Wed Nov 07 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.60
176 - FIX:
177         - Remove tizen-black theme package description
178
179 * Tue Nov 06 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.59
180 - FIX:
181         - Fix theme name to meet the change of system theme name: white->tizen
182         - Popupwindow: fix left position
183         - Remove black theme
184         - footer: remove label, legend drawing
185 - Spec changes:
186         - UX guide v0.4 : button, layout
187
188 * Wed Oct 24 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.57
189 - FIX:
190         - expandablelist: icon color fix
191         - scrollview: Fix xy scroll
192         - footer: Remove dummy div
193         - Make string concatnation effective in inline-protos.sh
194 - Spec changes:
195         - refresh header/footer when drag&drop event is fired in GUI builder
196         - searchbar: delete cancel button
197         - don't trigger updatelayout event when keyup event comes
198
199 * Mon Oct 15 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.56
200 - FIX:
201         - Toggleswitch: Change event name from 'changed' to 'change'
202         - Notification: Revert interval feature
203
204 * Tue Oct 09 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.55
205 - FIX:
206         - Fix SMACK manifest bug (S1-9098)
207
208 * Fri Oct 05 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.54
209 - FIX:
210         - handler: don't append a handler if handler is not enabled
211         - scrollview: use static value
212         - datetimepicker: fix date-format HH display error
213 - ETC:
214         - provide jquery.min.js
215         - barlayout: codes clean
216         - remove unused file
217
218 * Wed Sep 26 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.53
219 - FIX:
220         - listview: change focused color
221         - multibuttonentry: code refactoring
222         - datetimepicker: modify date format when triggered date-changed event
223         - slider: fix the top of slider bar
224         - add event blocker when load a first page
225
226 * Fri Sep 21 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.52
227 - ETC.
228         - Move SMACK manifest files to the top SRCDIR
229
230 * Fri Sep 21 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.51
231 - FIX:
232         - Popup: Do not focus container
233         - Header: show backbutton when both tabbar and header are present together
234         - Multi button entry: text ellipsis, code refactoring
235
236 * Fri Sep 21 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.50
237 - ETC.
238         - Apply SMACK manifest
239
240 * Thu Sep 20 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.49
241 - FIX:
242         - JSLINT code clean-up
243         - scrollview: firefox support
244         - scrollview: fix finding slider handle
245         - list: tweak text ellipsis
246         - checkbox: fix selecting wrong label tag (N_SE-8370)
247         - imageslider: check parameter
248         - smallpopup: fix position
249         - searchbar: fix 'clear' button size
250 - Spec changes:
251         - scrollview: support outer scroll
252         - JQM: block click event only with the element that does preventdefault on vclick(N_SE-6090)
253         - remove S/W IME control
254
255 * Thu Sep 13 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.48
256 - FIX:
257         - Add missing icon: controlbar
258         - scrollview: tune scrolling animatio ninterval
259         - datetimepicker: digit/triangle position
260         - datetimepicker: fix day overflow issue
261 - Spec changes:
262         - scrollview: show scrollbar when page is showed
263         - scrollview: disable outer scroll
264         - extendablelist: change api with legacy support
265         - add ui-text-ellipsis class
266
267 * Mon Sep 10 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.47
268 - FIX:
269         - scrollveiw: fix height of view
270         - searchbar: support placeholder
271 - Spec changes:
272         - add ui-text-ellipsis class
273
274 * Fri Sep 07 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.46
275 - FIX:
276         - scrollview: scrolling bug fix
277         - controlbar: fix width of controlbar item
278 - Spec changes:
279         - searchbar: don't hide icon
280         - popup: update JQM poup widget
281
282 * Fri Sep 05 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.45
283 - FIX:
284         - controlbar: set correct controlbar width of last element
285         - slider: get popup enable value correctly
286         - use Date.now() instead of (new Data()).getTime()
287         - popupwindow: fix the background color of popup scroller
288         - listview: add padding-left to expandable list
289         - add ellipsis for title area support
290
291 * Fri Aug 31 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.44
292 - FIX:
293         - swipelist: show list items correctly
294         - datetimepicker: set last day, if day is overflowed
295 - Spec changes:
296         - controlbar: update icons
297
298 * Tue Aug 29 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.43
299 - FIX:
300         - notification: fix typo
301 - Spec changes:
302         - controlbar: update icons
303
304 * Tue Aug 28 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.42
305 - FIX:
306         - multimediaview: video progress bar display normally for too samll
307         - segmentcontrol: remove media query
308         - scrollview: add outer scroll condition
309         - datetimepicker: modify triangle size
310         - popupwindow: set the screen height explicitly
311         - notification: add multiline text
312 - Spec changes:
313         - mutibuttonentry: support new GUI
314         - virtualgrid: support new GUI
315
316 * Mon Aug 27 2012 Jinhyuk Jun <jinhyuk.jun@samsung.com> 0.1.41
317 - FIX:
318         - radio/check button : button size bug fix
319
320 * Fri Aug 24 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.40
321 - FIX:
322         - build error fixed
323
324 * Fri Aug 24 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.39
325 - FIX:
326         - listview: style fix, remove filter placeholder
327         - controlbar: divide styles
328         - scrollview: don't skip dragging when click button or inputbox
329         - slider: trim the text on text slider
330 - Spec changes:
331         - remove gray and blue theme
332         - add white and black theme
333         - support new GUI guide
334
335 * Mon Aug 20 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.38
336 - FIX:
337         - fix coment of version tag
338
339 * Fri Aug 17 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.37
340 - FIX :
341         - button: fix alignment
342         - listview: adjust the main text width
343         - virtualgrid: refactoring
344 - Spec changes:
345         - transition: support JQM 1.1.0 transitions
346         - scrollview: support the outer scroll
347         - notification: remove interval feature
348
349 * Tue Aug 14 2012 Youmin Ha <youmin.ha@samasung.com> 0.1.36
350 - FIX :
351         - checkboxRadio: Add left/right padding
352         - button: custom button & icon position
353         - virtuallist: remove 'recreate' test
354 - Spec changes:
355         - header/footer: enable/disable support
356
357 * Fri Aug 10 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.35
358 - FIX :
359         - expandablelist: modify show animation
360         - virtualgrid: Redesign programming interface
361         - popupwindow: code clean and fixed issues
362         - pagelayout: fix content height
363         - license file update
364         - virtuallist: Change programming interface
365         - datetimepicker: getting days correctly
366         - searchbar: set to hidden when cancel button is hide
367         - White theme title font tuning
368 - Spec changes:
369         - default theme tizen-gray to tizen-white
370         - set default page transition to none
371
372 * Mon Aug 02 2012 Jinhyuk Jun <jinhyuk.jun@samsung.com> 0.1.34
373 - FIX :
374         - Back Button : enlarge backbutton click size for white theme
375 - Feature :
376         - Expandable List : Add refresh api
377 * Mon Aug 02 2012 Jinhyuk Jun <jinhyuk.jun@samsung.com> 0.1.33
378 - FIX :
379         - click event touch threshold tuning
380
381 * Mon Aug 02 2012 Jinhyuk Jun <jinhyuk.jun@samsung.com> 0.1.32
382 - FIX : 
383         - Add back button highlight effect for white theme
384
385 * Mon Aug 01 2012 Jinhyuk Jun <jinhyuk.jun@samsnug.com> 0.1.31
386 - FIX : 
387         - IME checkroutine update, improve relayout on resize event
388         - Add highlight effect for radio button list 
389         - Scrollview : fix condition of updatelayout event
390 - Feature : progressing : add show/hide api
391
392 * Mon Jul 27 2012 Koeun Choi <koeun.choi@samsung.com> 0.1.30
393 - FIX : virtuallist, virtualgrid: Clean up temporary jquery.template object to clear cache
394         add default theme option on buttonMarkup for tizen theme
395         [searchbar] first fix : focus/blur fixed
396         back button does not work when long press
397         scrollview: don't auto scrolling if resizing area is too large
398 - Feature : notification : add api to set the icon at tickernoti
399         demo : update the list sample demo
400         Support tizen default theme
401
402 * Mon Jul 23 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.29
403 - Improvements & Bugfixes
404    - HOTFIX: Revert template function with jquery.template
405
406 * Thu Jul 19 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.28
407 - Improvements & Bugfixes
408    - Fix #WEB-1028: memory leak on virtuallist/virtualgrid
409 - Spec changes
410    - $.tizen.loadTheme() function accepts theme name as arguement
411    - Scrollview supports 'updatelayout' callback
412
413 * Tue Jul 17 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.27
414 - Improvements & Bugfixes
415    - Revert 'preventing long-press popup' patch, to fix backbutton to work in SocialMagazine
416
417 * Tue Jul 17 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.26
418 - Improvements & Bugfixes
419    - Add tizen-white theme package, to make rpm build to be finished
420
421 * Tue Jul 17 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.25
422 - Improvements & Bugfixes
423    - Set 'slide' as default page transition effect, by JQM patch
424
425 * Fri Jul 13 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.24
426 - Improvements & Bugfixes
427    - Fix IME show/hide algorithm
428    - Fix error on virtualgrid: link _set_scrollbar_size() function to the one in virtuallist
429
430 * Wed Jul 11 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.23
431 - Improvements & Bugfixes
432    - Fix notification position
433    - Fix unit tests
434
435  Fri Jul 6 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.22
436 - Spec changes
437         - JQM 1.1 upgrade
438 - Improvements & Bugfixes
439         - Transform3D support on scrollview
440         - Page layout supports IME control
441         - Mapview supports pinch zoom on JQM 1.1
442         - Fix wrong character on button in minified version
443         - Virtualgrid supports scrollbar
444         - Lots of bugfixes
445
446 * Fri Jun 22 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.20
447 - Spec changes
448         - Support 'latest' version (by symlink) for tizen-web-ui-fw.js path.
449         - imageslider : supports 'resize' event.
450         - listview : listview has 1px padding-bottom.
451         - loader : Change global namespace, from S to $.tizen.
452         - loader : Move loadCustomGlobalizeCulture() into $.tizen.util namespace.
453 - Improvements & Bugfixes
454         - Scrollview : supports 'translate3d', instead of 'translate'.
455         - notification : reset timer when 'show' or 'refresh' event.
456         - JQM patch : Fix vclick event triggered twice.
457 - Etc.
458         - Add & fix unit tests.
459
460 * Thu Jun 14 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.19
461 - Spec changes
462         - mapview : new widget.
463         - notification : add .refresh() API.
464         - pagecontrol : add .value([val]) API, and change an attribute name 'data-initVal' to 'data-value'.
465 - Improvements & Bugfixes
466         - Support minified CSS.
467         - loader : Fix & refactor 'loading globalize culture file' routine.
468         - JQM Patch : Calculate min-height of window in javascript code, and remove predefined min-height value from CSS.
469         - Many more bugfixes.
470 - Etc.
471         - Add many unit tests.
472         - Fix test coverage instrumentation tool to work with current source code.