Export 0.1.62
[platform/framework/web/web-ui-fw.git] / packaging / web-ui-fw.spec
1 Name:       web-ui-fw
2 Version:    0.1.62
3 Release:    0
4 Summary:    Tizen Web UI Framework Library
5 Group:      Development/Other
6 License:    MIT
7 BuildArch:  noarch
8 BuildRequires:  make
9 BuildRequires:  nodejs
10 %ifarch %{arm}
11 BuildRequires:  nodejs-x86-arm
12 %endif
13
14 Source0:    %{name}-%{version}.tar.gz
15
16 %description
17 Tizen Web UI Framework library and theme packages
18
19 %prep
20 %setup -q
21
22 %build
23 make all
24
25 %install
26 make DESTDIR=%{buildroot} install
27
28 %post
29
30 %files
31 %manifest web-ui-fw.manifest
32 /usr/share/tizen-web-ui-fw/*/js
33 /usr/share/tizen-web-ui-fw/latest
34
35 ###############################
36 %package -n web-ui-fw-theme-tizen-gray
37 BuildArch:  noarch
38 Summary:    Tizen Web UI Framework Theme : tizen-gray
39 %Description -n web-ui-fw-theme-tizen-gray
40     Tizen Web UI Framework Theme : tizen-gray
41
42 ###############################
43 %package -n web-ui-fw-theme-tizen-white
44 BuildArch:  noarch
45 Summary:    Tizen Web UI Framework Theme : tizen-white
46 %Description -n web-ui-fw-theme-tizen-white
47     Tizen Web UI Framework Theme : tizen-white
48 %files -n web-ui-fw-theme-tizen-white
49 %manifest web-ui-fw-theme-tizen-white.manifest
50 /usr/share/tizen-web-ui-fw/*/themes/tizen-white
51 /usr/share/tizen-web-ui-fw/*/themes/tizen-tizen
52
53 ###############################
54 %package -n web-ui-fw-theme-default
55 BuildArch:  noarch
56 Summary:    Tizen Web UI Framework Theme : default
57 %Description -n web-ui-fw-theme-default
58     Tizen Web UI Framework Theme : default
59 %files -n web-ui-fw-theme-default
60 %manifest web-ui-fw-theme-default.manifest
61 /usr/share/tizen-web-ui-fw/*/themes/default
62
63 ###############################
64 %package -n web-ui-fw-devel
65 BuildArch:  noarch
66 Summary:    Tizen Web UI Framework Developer's files
67 %Description -n web-ui-fw-devel
68     Tizen Web UI Framework Developer's files
69 %files -n web-ui-fw-devel
70 /usr/share/tizen-web-ui-fw/bin
71 /usr/share/tizen-web-ui-fw/template
72
73 ###############################
74 %package -n web-ui-fw-demo-tizen-winsets
75 BuildArch:  noarch
76 Summary:    Tizen Web UI Framework Demo Application: tizen winset demo
77 %Description -n web-ui-fw-demo-tizen-winsets
78     Tizen Web UI Framework Demo Application: tizen winset demo
79 %files  -n web-ui-fw-demo-tizen-winsets
80 /usr/share/tizen-web-ui-fw/demos/tizen-winsets
81
82
83 ###############################
84 %changelog
85 * Fri Nov 16 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.62
86 - FIX:
87         - Many winsets: Fix layout
88         - Footer: fix position to bottom
89 - Spec changes:
90         - Remove color widgets
91
92 * Fri Nov 09 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.61
93 - FIX:
94         - Many widgets: New UX 0.6 theme implementation
95         - widgetex: init speed up
96         - scrollview: fix scrollbar and scale animation
97         - scrollview: fix scroll position when updatelayout is triggered
98         - header/footer: make textselection disable, except input type="text"
99
100 * Wed Nov 07 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.60
101 - FIX:
102         - Remove tizen-black theme package description
103
104 * Tue Nov 06 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.59
105 - FIX:
106         - Fix theme name to meet the change of system theme name: white->tizen
107         - Popupwindow: fix left position
108         - Remove black theme
109         - footer: remove label, legend drawing
110 - Spec changes:
111         - UX guide v0.4 : button, layout
112
113 * Wed Oct 24 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.57
114 - FIX:
115         - expandablelist: icon color fix
116         - scrollview: Fix xy scroll
117         - footer: Remove dummy div
118         - Make string concatnation effective in inline-protos.sh
119 - Spec changes:
120         - refresh header/footer when drag&drop event is fired in GUI builder
121         - searchbar: delete cancel button
122         - don't trigger updatelayout event when keyup event comes
123
124 * Mon Oct 15 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.56
125 - FIX:
126         - Toggleswitch: Change event name from 'changed' to 'change'
127         - Notification: Revert interval feature
128
129 * Tue Oct 09 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.55
130 - FIX:
131         - Fix SMACK manifest bug (S1-9098)
132
133 * Fri Oct 05 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.54
134 - FIX:
135         - handler: don't append a handler if handler is not enabled
136         - scrollview: use static value
137         - datetimepicker: fix date-format HH display error
138 - ETC:
139         - provide jquery.min.js
140         - barlayout: codes clean
141         - remove unused file
142
143 * Wed Sep 26 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.53
144 - FIX:
145         - listview: change focused color
146         - multibuttonentry: code refactoring
147         - datetimepicker: modify date format when triggered date-changed event
148         - slider: fix the top of slider bar
149         - add event blocker when load a first page
150
151 * Fri Sep 21 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.52
152 - ETC.
153         - Move SMACK manifest files to the top SRCDIR
154
155 * Fri Sep 21 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.51
156 - FIX:
157         - Popup: Do not focus container
158         - Header: show backbutton when both tabbar and header are present together
159         - Multi button entry: text ellipsis, code refactoring
160
161 * Fri Sep 21 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.50
162 - ETC.
163         - Apply SMACK manifest
164
165 * Thu Sep 20 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.49
166 - FIX:
167         - JSLINT code clean-up
168         - scrollview: firefox support
169         - scrollview: fix finding slider handle
170         - list: tweak text ellipsis
171         - checkbox: fix selecting wrong label tag (N_SE-8370)
172         - imageslider: check parameter
173         - smallpopup: fix position
174         - searchbar: fix 'clear' button size
175 - Spec changes:
176         - scrollview: support outer scroll
177         - JQM: block click event only with the element that does preventdefault on vclick(N_SE-6090)
178         - remove S/W IME control
179
180 * Thu Sep 13 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.48
181 - FIX:
182         - Add missing icon: controlbar
183         - scrollview: tune scrolling animatio ninterval
184         - datetimepicker: digit/triangle position
185         - datetimepicker: fix day overflow issue
186 - Spec changes:
187         - scrollview: show scrollbar when page is showed
188         - scrollview: disable outer scroll
189         - extendablelist: change api with legacy support
190         - add ui-text-ellipsis class
191
192 * Mon Sep 10 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.47
193 - FIX:
194         - scrollveiw: fix height of view
195         - searchbar: support placeholder
196 - Spec changes:
197         - add ui-text-ellipsis class
198
199 * Fri Sep 07 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.46
200 - FIX:
201         - scrollview: scrolling bug fix
202         - controlbar: fix width of controlbar item
203 - Spec changes:
204         - searchbar: don't hide icon
205         - popup: update JQM poup widget
206
207 * Fri Sep 05 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.45
208 - FIX:
209         - controlbar: set correct controlbar width of last element
210         - slider: get popup enable value correctly
211         - use Date.now() instead of (new Data()).getTime()
212         - popupwindow: fix the background color of popup scroller
213         - listview: add padding-left to expandable list
214         - add ellipsis for title area support
215
216 * Fri Aug 31 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.44
217 - FIX:
218         - swipelist: show list items correctly
219         - datetimepicker: set last day, if day is overflowed
220 - Spec changes:
221         - controlbar: update icons
222
223 * Tue Aug 29 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.43
224 - FIX:
225         - notification: fix typo
226 - Spec changes:
227         - controlbar: update icons
228
229 * Tue Aug 28 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.42
230 - FIX:
231         - multimediaview: video progress bar display normally for too samll
232         - segmentcontrol: remove media query
233         - scrollview: add outer scroll condition
234         - datetimepicker: modify triangle size
235         - popupwindow: set the screen height explicitly
236         - notification: add multiline text
237 - Spec changes:
238         - mutibuttonentry: support new GUI
239         - virtualgrid: support new GUI
240
241 * Mon Aug 27 2012 Jinhyuk Jun <jinhyuk.jun@samsung.com> 0.1.41
242 - FIX:
243         - radio/check button : button size bug fix
244
245 * Fri Aug 24 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.40
246 - FIX:
247         - build error fixed
248
249 * Fri Aug 24 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.39
250 - FIX:
251         - listview: style fix, remove filter placeholder
252         - controlbar: divide styles
253         - scrollview: don't skip dragging when click button or inputbox
254         - slider: trim the text on text slider
255 - Spec changes:
256         - remove gray and blue theme
257         - add white and black theme
258         - support new GUI guide
259
260 * Mon Aug 20 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.38
261 - FIX:
262         - fix coment of version tag
263
264 * Fri Aug 17 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.37
265 - FIX :
266         - button: fix alignment
267         - listview: adjust the main text width
268         - virtualgrid: refactoring
269 - Spec changes:
270         - transition: support JQM 1.1.0 transitions
271         - scrollview: support the outer scroll
272         - notification: remove interval feature
273
274 * Tue Aug 14 2012 Youmin Ha <youmin.ha@samasung.com> 0.1.36
275 - FIX :
276         - checkboxRadio: Add left/right padding
277         - button: custom button & icon position
278         - virtuallist: remove 'recreate' test
279 - Spec changes:
280         - header/footer: enable/disable support
281
282 * Fri Aug 10 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.35
283 - FIX :
284         - expandablelist: modify show animation
285         - virtualgrid: Redesign programming interface
286         - popupwindow: code clean and fixed issues
287         - pagelayout: fix content height
288         - license file update
289         - virtuallist: Change programming interface
290         - datetimepicker: getting days correctly
291         - searchbar: set to hidden when cancel button is hide
292         - White theme title font tuning
293 - Spec changes:
294         - default theme tizen-gray to tizen-white
295         - set default page transition to none
296
297 * Mon Aug 02 2012 Jinhyuk Jun <jinhyuk.jun@samsung.com> 0.1.34
298 - FIX :
299         - Back Button : enlarge backbutton click size for white theme
300 - Feature :
301         - Expandable List : Add refresh api
302 * Mon Aug 02 2012 Jinhyuk Jun <jinhyuk.jun@samsung.com> 0.1.33
303 - FIX :
304         - click event touch threshold tuning
305
306 * Mon Aug 02 2012 Jinhyuk Jun <jinhyuk.jun@samsung.com> 0.1.32
307 - FIX : 
308         - Add back button highlight effect for white theme
309
310 * Mon Aug 01 2012 Jinhyuk Jun <jinhyuk.jun@samsnug.com> 0.1.31
311 - FIX : 
312         - IME checkroutine update, improve relayout on resize event
313         - Add highlight effect for radio button list 
314         - Scrollview : fix condition of updatelayout event
315 - Feature : progressing : add show/hide api
316
317 * Mon Jul 27 2012 Koeun Choi <koeun.choi@samsung.com> 0.1.30
318 - FIX : virtuallist, virtualgrid: Clean up temporary jquery.template object to clear cache
319         add default theme option on buttonMarkup for tizen theme
320         [searchbar] first fix : focus/blur fixed
321         back button does not work when long press
322         scrollview: don't auto scrolling if resizing area is too large
323 - Feature : notification : add api to set the icon at tickernoti
324         demo : update the list sample demo
325         Support tizen default theme
326
327 * Mon Jul 23 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.29
328 - Improvements & Bugfixes
329    - HOTFIX: Revert template function with jquery.template
330
331 * Thu Jul 19 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.28
332 - Improvements & Bugfixes
333    - Fix #WEB-1028: memory leak on virtuallist/virtualgrid
334 - Spec changes
335    - $.tizen.loadTheme() function accepts theme name as arguement
336    - Scrollview supports 'updatelayout' callback
337
338 * Tue Jul 17 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.27
339 - Improvements & Bugfixes
340    - Revert 'preventing long-press popup' patch, to fix backbutton to work in SocialMagazine
341
342 * Tue Jul 17 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.26
343 - Improvements & Bugfixes
344    - Add tizen-white theme package, to make rpm build to be finished
345
346 * Tue Jul 17 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.25
347 - Improvements & Bugfixes
348    - Set 'slide' as default page transition effect, by JQM patch
349
350 * Fri Jul 13 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.24
351 - Improvements & Bugfixes
352    - Fix IME show/hide algorithm
353    - Fix error on virtualgrid: link _set_scrollbar_size() function to the one in virtuallist
354
355 * Wed Jul 11 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.23
356 - Improvements & Bugfixes
357    - Fix notification position
358    - Fix unit tests
359
360  Fri Jul 6 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.22
361 - Spec changes
362         - JQM 1.1 upgrade
363 - Improvements & Bugfixes
364         - Transform3D support on scrollview
365         - Page layout supports IME control
366         - Mapview supports pinch zoom on JQM 1.1
367         - Fix wrong character on button in minified version
368         - Virtualgrid supports scrollbar
369         - Lots of bugfixes
370
371 * Fri Jun 22 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.20
372 - Spec changes
373         - Support 'latest' version (by symlink) for tizen-web-ui-fw.js path.
374         - imageslider : supports 'resize' event.
375         - listview : listview has 1px padding-bottom.
376         - loader : Change global namespace, from S to $.tizen.
377         - loader : Move loadCustomGlobalizeCulture() into $.tizen.util namespace.
378 - Improvements & Bugfixes
379         - Scrollview : supports 'translate3d', instead of 'translate'.
380         - notification : reset timer when 'show' or 'refresh' event.
381         - JQM patch : Fix vclick event triggered twice.
382 - Etc.
383         - Add & fix unit tests.
384
385 * Thu Jun 14 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.19
386 - Spec changes
387         - mapview : new widget.
388         - notification : add .refresh() API.
389         - pagecontrol : add .value([val]) API, and change an attribute name 'data-initVal' to 'data-value'.
390 - Improvements & Bugfixes
391         - Support minified CSS.
392         - loader : Fix & refactor 'loading globalize culture file' routine.
393         - JQM Patch : Calculate min-height of window in javascript code, and remove predefined min-height value from CSS.
394         - Many more bugfixes.
395 - Etc.
396         - Add many unit tests.
397         - Fix test coverage instrumentation tool to work with current source code.