0.2.17 release
[platform/framework/web/web-ui-fw.git] / packaging / web-ui-fw.spec
1 Name:       web-ui-fw
2 Version:    0.2.17
3 Release:    0
4 Summary:    Tizen Web UI Framework Library
5 Group:      Development/Other
6 License:    MIT
7 BuildArch:  noarch
8 BuildRequires:  make
9 BuildRequires:  nodejs
10 %ifarch %{arm}
11 BuildRequires:  nodejs-x86-arm
12 %endif
13
14 Source0:    %{name}-%{version}.tar.gz
15
16 %description
17 Tizen Web UI Framework library and theme packages
18
19 %prep
20 %setup -q
21
22 %build
23 make all
24
25 %install
26 make DESTDIR=%{buildroot} install
27
28 %post
29
30 %files
31 %manifest web-ui-fw.manifest
32 /usr/share/tizen-web-ui-fw/*/js
33 /usr/share/tizen-web-ui-fw/latest
34 /usr/share/tizen-web-ui-fw/VERSION
35
36 ###############################
37 %package -n web-ui-fw-theme-tizen-gray
38 BuildArch:  noarch
39 Summary:    Tizen Web UI Framework Theme : tizen-gray
40 %Description -n web-ui-fw-theme-tizen-gray
41     Tizen Web UI Framework Theme : tizen-gray
42
43 ###############################
44 %package -n web-ui-fw-theme-tizen-white
45 BuildArch:  noarch
46 Summary:    Tizen Web UI Framework Theme : tizen-white
47 %Description -n web-ui-fw-theme-tizen-white
48     Tizen Web UI Framework Theme : tizen-white
49 %files -n web-ui-fw-theme-tizen-white
50 %manifest web-ui-fw-theme-tizen-white.manifest
51 /usr/share/tizen-web-ui-fw/*/themes/tizen-white
52 /usr/share/tizen-web-ui-fw/*/themes/tizen-tizen
53
54 ###############################
55 %package -n web-ui-fw-theme-default
56 BuildArch:  noarch
57 Summary:    Tizen Web UI Framework Theme : default
58 %Description -n web-ui-fw-theme-default
59     Tizen Web UI Framework Theme : default
60 %files -n web-ui-fw-theme-default
61 %manifest web-ui-fw-theme-default.manifest
62 /usr/share/tizen-web-ui-fw/*/themes/default
63
64 ###############################
65 %package -n web-ui-fw-devel
66 BuildArch:  noarch
67 Summary:    Tizen Web UI Framework Developer's files
68 %Description -n web-ui-fw-devel
69     Tizen Web UI Framework Developer's files
70 %files -n web-ui-fw-devel
71 /usr/share/tizen-web-ui-fw/bin
72 /usr/share/tizen-web-ui-fw/template
73
74 ###############################
75 %package -n web-ui-fw-demo-tizen-winsets
76 BuildArch:  noarch
77 Summary:    Tizen Web UI Framework Demo Application: tizen winset demo
78 %Description -n web-ui-fw-demo-tizen-winsets
79     Tizen Web UI Framework Demo Application: tizen winset demo
80 %files  -n web-ui-fw-demo-tizen-winsets
81 /usr/share/tizen-web-ui-fw/demos/tizen-winsets
82
83
84 ###############################
85 %changelog
86 * Tue Feb 19 2013 Minkyu Kang <mk7.kang@samsung.com> 0.2.17
87         - DialogueList : delete border top value / add sample's text ellipsis
88         - Tokentextarea: Add scroll-to-top for Grouping On/Off regarding #N_SE-24877
89         - Multimediaview: Fix mute function
90         - Tizen-winset: list vi index guide textbox has been removed
91         - Tizen-winset: custom button texts have been changed
92         - slider: move popup div to out of content
93         - TizenWinset: disable context popup in multimediaview
94         - Swipe: wrong style name has been fixed
95         - demo: add the sample at dialogue list
96         - listview: Add ui-li-has-right-btn class with toggleswitch
97         - WinsetDemo : change wrong title name
98
99 * Mon Jan 28 2013 Youmin Ha <youmin.ha@samsung.com> 0.2.16
100         - demo: checkbox: reduce button's width
101         - tabbar : delete right/left tab animation color
102         - scrollview: fix the scroll position at keydown event
103         - groupControl : change footer groupControl from min-width to percentage
104         - scrollview: get height of softkeyboard correctly
105         - tizen-winset: Add name attr to all radio inputs
106         - virtualgrid: changes event binding target
107         - scrollview: skip the drag if target is textarea
108         - scrollview: skip the dragging of parent scrollview
109         - scrollview: apply the scaling ratio to the soft keyboard
110         - demos: apply disabled option in textarea
111         - demo: remove unused codes
112         - demo: datetimepicker: show selected date correctly
113         - listview: Adjust bubble listitem width and margin
114         - pagelayout : change external refresh call and ime status follow only current page
115         - toggleSwitch : bug fix
116         - unit-test: slider: fix the move test
117         - handler: fix jslint error
118         - ToggleSwitch : set image toggleswitch background attribute
119
120 * Mon Jan 28 2013 Youmin Ha <youmin.ha@samsung.com> 0.2.15
121         - slider: increase the text width(N_SE-23397)
122         - virtualgrid: DOM element leak fix
123         - header: Move button top higher in header with tabbar(N_SE-22253)
124         - datatimepicker: don't open the popup before popupafterclose event is fired(N_SE-23027)
125         - handler: bug fix (regarding enableHandler function )
126         - demo:fix syntax error
127
128 * Sat Jan 26 2013 Youmin Ha <youmin.ha@samsung.com> 0.2.14
129         - demo: fix demo using tizen device API
130         - multimediaview: reset the height of container
131         - input: modify css correctly
132         - multimediaview: fix the height of widget
133         - gallery: bind create event
134         - progress: bind create event
135         - slider: bind create event
136         - progressbar: bind create event
137         - progressbar: event trigger correctly
138         - popup: fix height of popup scroller
139         - build: add continue option to jslint
140         - ctxpopup demo : bug fix
141         - demo: fix searchbar demo to use different IDs
142         - demo: extract routine executing Tizen device API
143         - toggleswitch : set default margin, delete box padding
144
145 * Thu Jan 24 2013 Youmin Ha <youmin.ha@samsung.com> 0.2.13
146         - virtuallist: Prevent replacing contents on nonexist element
147         - JQM: Trim text in listitem to get index in autodivider
148         - JQM: Remove trailing whitespace in jqm patch
149         - scrollview: get the height including margin
150         - multimediaview: bug fix ( scrolling in full-screen mode )
151         - virtuallist: set listitem width to exclude listitem left/right margin
152         - demo: fix virtuallist sample layout
153         - progress: set the position explicitly
154         - progress: rename from progressing to progress
155         - build: remove unused files
156         - searchbar: fix jslint errors
157         - src: fix file permissions
158         - button : change jump left icon
159
160 * Wed Jan 23 2013 Minkyu Kang <mk7.kang@samsung.com> 0.2.12
161         - theme : button icon - scrolltop, scrolleft icon changed.
162         - build: cleanaup Makefile
163         - pagelayout: fix jslint error
164         - virtualgrid: Fix jslint errors
165         - tabbar : jslint bug error fix
166         - build: add regexp option to jslint
167         - virtuallist: fix jslint errors
168         - handler: Apply the exceptional principle for scrollbar on Handler.
169         - build: remove unused copyright
170         - loader: extract log class for tizen web, and fix jslint errors
171         - loader: Viewport width is set to document width
172         - popupwindow: fix jslint error
173         - build: fix Makefile for tizen-white theme
174         - build: remove unused libraries
175         - datetimepicker: fix jslint error
176         - slider: fix jslint error
177         - demo: remove deprecated demos
178         - pagelayout : change to call relayout with this page
179         - Tokentextarea: Block size error fixed.
180         - handler: bug fix (handler activation)
181
182 * Tue Jan 22 2013 Minkyu Kang <mk7.kang@samsung.com> 0.2.11
183         - demo: clear input text value with cancel button click
184         - demo: Adjust textarea height automatically
185         - naviframe : bug fix
186         - tabbar : bug fix
187         - Fastscroll: popup position has been changed
188         - Button: custom button icon path, margin have been changed
189         - toggleswitch : bug fix
190         - slider: increase the margin
191         - datetimepicker: close the popup after select the value
192         - unit-test : add page backbutton control test
193         - Demo: added guide text and change input type in list vi
194         - remove legacy codes : jquery-geo
195         - Datetimepicker: text-main max-width has been removed
196         - Radio: control group border has been removed
197         - Demo: remove 'tab' space
198         - UnitTC: swipe unit tc has been fixed
199         - UnitTC: jQuery path has been fixed
200         - Button: bug fix when button has not a text
201         - tizen-winset: timepicker: demo title is changed
202
203 * Fri Jan 18 2013 Minkyu Kang <mk7.kang@samsung.com> 0.2.10
204         - tizen-winsets: codes cleanup
205         - datetimepicker: date calibration when year is changed
206         - Demo: textarea size has been changed
207         - Demo: Naviframe morebutton demo has been changed
208         - remove unused unit test cases : gallery3d
209         - tizen-winset: remove links
210
211 * Thu Jan 17 2013 Minkyu Kang <mk7.kang@samsung.com> 0.2.9
212         - gallery: use timeout function instead of interval
213         - Tokentextarea: Display error fixed.
214         - scrollview: Fix not selector to respond with jQuery1.8.2
215         - tabbar: remove the width of last element
216         - Demo: apply css 'user-select:none'
217         - Button: guide text has been shorten
218         - build: Update jQuery to 1.8.2 (JQM1.2 compliant)
219         - virtuallist: Fix mistyping
220         - demo: Fix tizen function namespace in demo
221         - virtuallist: Rewrite listitem replacing algorithm
222         - fastscroll: modify from not selector to function
223         - extendablelist: Fix unit-test
224         - tabbar : prefix to tabbar scroll event
225         - Popupwindow: removed unvalid selector in jquery 1.8.2
226         - slider: adjust handle text as length of value
227         - Demo: 3 buttons in popup text has been changed
228         - src: codes cleanup
229         - demo : remove trailing empty strings
230         - demo : rename TizenWinset list items
231         - button : change from long text list to multiline list
232         - build: Remove JQM1.1.0 patches
233         - Popup: Apply tizen style popup and attribute support
234         - JQM: Fix buttonmarkup bug keeping ui-btn-down class
235         - UnitTest: folder and file renamed, QUnit path was modified
236         - tizen-winsets: button: fix textarea width
237         - Swipe: event name error has been fixed
238
239 * Tue Jan 15 2013 Minkyu Kang <mk7.kang@samsung.com> 0.2.8
240         - Button: button padding has been updated
241         - virtuallist: fix unique listitem ID bug
242         - checkbox, radio : change display attr
243         - Button: bug fix ( when data style circle button on text )
244         - handler: bug fix (when scrolling with multi selection)
245         - JQM: adjust patch number
246         - gallery: show the widget after pageshow
247         - TokenTextArea : resource add ( press image )
248         - gallery: adds function that set the index to value API
249         - configure: set TIZEN default configures
250         - footer: h tag display attribute value has been changed
251         - buttons : demo bug fix
252         - searchbar : demo page bug fix
253         - tizen demo : bug fix
254         - build: remove JQM1.1.0
255         - Tokentextarea: Fix issues
256         - scrollview: block the multi touch
257         - list : dialogue list demo change
258         - pagelayout : update dynamic control
259         - Demo: Context popup close method has been changed
260
261 * Fri Jan 11 2013 Minkyu Kang <mk7.kang@samsung.com> 0.2.7
262         - slider: set text container's width as text length
263         - Timepicker: li max-width has been changed
264         - remove experimental feature - mapview.
265         - scrollview: added conditions for finding slider
266         - UnitTC: Pass,error count save method has been changed
267         - confix.xml: default config added for tizen basic applications
268         - Swipe: p tag margin value is set '0'
269         - packaging: remove unused file
270         - tabbar : bug fix
271         - list demo : bug fix
272         - tizen-winsets: gallery: move to new section
273         - tizen-winsets: autodivider: removes link of list
274         - demos: entry of number-pattern name is changed from 'number' to 'number-pattern'
275         - pagelayout : padding calculate change, ime footer check changed
276         - tizen-winsets: searchbar: scroll to the top when type the character
277         - searchbar : bug fix
278         - demo: Fix virtuallist demo following new list style
279         - demo: Add word-wrap:break-word and remove parag. width
280         - Demo: button max-width has been set( 3 buttons in popup )
281         - back button control demo : bug fix
282         - toggleswitch : demo page modify
283         - slider: add margin-top and margin-bottom
284         - tabbar demo : bug fix
285         - Popup: IME hide when popup is closed
286         - token textarea : bug fix
287         - Timepicker: change get attribute method
288         - footer demo : bug fix
289         - unit-test: gallery: add new APIs
290         - gallery: adds support new APIs
291
292 * Fri Jan 04 2013 Minkyu Kang <mk7.kang@samsung.com> 0.2.6
293         - JQM: patches cleanup
294         - Button: data-corners attribute has been added
295         - unit-test: slider: fix class name of background
296         - progressbar, slider: fix less variable typo
297         - Tabbar : VI update
298         - notification: add top position at fix class
299         - demo: entry demo page change
300         - css: .ui-disabled added
301         - tizen-winset: token textarea: remove back button at demo page
302         - theme: Remove unused less file
303         - pagelayout : content min height bug fix
304         - scrollview: skip the dragging when target is slider's handle
305         - scrollview: update and refactoring the scroll effect
306         - UnitTest:JQM Unit TC helper has been added,TCs have been modified
307         - Swipe: demo page html error has been fixed
308         - listview: Add add/delete animation (VI)
309         - Popup: demo page has been modified
310         - tizen demo : bug fix
311         - searchbar : demo page change(change front button and add behaviour)
312         - pagelayout : add min height to content
313         - gallery: rename 'Image Slider' to 'Gallery' in tizen-winsets demo and tests
314         - back button control demo : change url link to data-rel="back"
315         - loader: Skip loading theme CSS with a custom css code
316         - Button: support no-text in button
317         - collapsible: Fix syntax error
318         - slider: use data-highlight attribute
319         - collapsible: Rotate animation to collapsible heading icon
320         - toggleswitch : text switch bug fix
321         - remove candidates-calendarpicker
322         - Patch: Fix misc mistakes in JQM patches
323         - searchbar : animation change
324         - gallery: get the width correctly
325         - demo: data-framework-viewport-scale attribute is changed to data-framework-viewport-width
326         - collapsible: Add collapse/expand animation (VI)
327         - datetimepicker: VI update
328         - JQM: set transition to pop as default
329         - tabbar : bug fix in case none li element case
330         - scrollview: fix the drag bug
331         - Button: Button icon scrolltop, left has beed added
332         - Swipe: VI update and swipe speed has been changed
333         - jqm: fix errors in patch files
334         - unit-test: swipe: fixed the destroy test
335
336 * Wed Dec 26 2012 Youmin Ha <youmin.ha@samsung.com> 0.2.5
337         - Revert "[checkboxradio] exception handling for input"
338                 This reverts commit 72478c32704fa96362db577e6cf9511777919ea8.
339                 Tizen style supports no-label radio and checkbox when making lists.
340                 So it ignores html input operation. Instead, it supports tizen style radio and checkbox theme.
341
342 * Thu Dec 20 2012 Youmin Ha <youmin.ha@samsung.com> 0.2.4
343 - Fix:
344         - modify segment background
345         - rearrange check, radio input
346         - CtxPopup: Scale up/ down popup vi(poptop, popbottom)
347         - button: style has beed added(box,circle,nobg,round)
348         - favorite resource added
349         - demo/tizen-winsets: add footer and back button
350         - remove autodividers unit test
351         - add divider for tabbar
352         - checkboxradio: exception handling for input
353         - segment control backward compatiblity
354         - Fix collapsible unit-test
355         - remove toggleswitch
356         - add patch for remove segment text
357 - Spec changes:
358         - replace controlbar to tabbar
359
360 * Fri Dec 14 2012 Minkyu Kang <mk7.kang@samsung.com> 0.2.3
361 - FIX:
362         - slider: add image
363         - button: data-icon support, styles fix
364         - progressbar: modify the background
365         - scrollview: auto scrolling bug fix
366         - pagelayout: IME concept is changed
367 - Spec changes:
368         - dialogue: add edit mode
369         - nocontents: removed
370         - pagecontrol: removed
371         - dayselector: removed
372         - expandablelist: removed
373
374 * Thu Dec 10 2012 Youmin Ha <youmin.ha@samsung.com> 0.2.2
375 - FIX:
376         - chang searchbar/slider images
377         - delete redundant button images
378 - Spec changes:
379         - Change widget name: shortcutscroll -> fastscroll
380
381 * Thu Dec 07 2012 Youmin Ha <youmin.ha@samsung.com> 0.2.1
382 - FIX:
383         - jqm1.2: Change collapsible style to meet expandable list
384         - remove jquery-geo-1.0.a4
385         - unit-test: rename from imageslider to gallery
386         - nocontent: add warning message
387         - Handler: Fix issues in jqm1.2
388         - Multimediaview: modify APIs & comments
389         - Mapview: Fix issues in jqm1.2
390         - JQM: clean up patches
391         - Swipelist: refactoring swipelist
392         - Popup,Ctxpopup: Apply tizen style popup in JQM1.2
393         - rearrange button's data-icon resources
394 - Spec changes:
395         - Virtualgrid: remove option ('data-itemcount')
396         - gallery: rename the widget from imageslider to gallery
397         - add new style for searchbar
398         [tokentextarea] multi-button entry renamed as token text area. API & comments modified.
399
400 * Thu Dec 06 2012 Minkyu Kang <mk7.kang@samsung.com> 0.2.0
401 - FIX:
402         - fix jslint error
403         - remove unused files
404         - change naviframe style
405 - Spec changes:
406         - applied jQuery Mobile 1.2.0
407         - remove optionheader
408
409 * Fri Nov 30 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.64
410 - FIX:
411         - fix unit tests
412         - remove unused theme files
413         - timepicker: text position fix
414         - scrollview: set dragstop when mouse is out of window
415         - listview: fix margin
416 - Spec changes:
417         - support data-framework-viewport-width
418
419 * Fri Nov 23 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.63
420 - FIX:
421         - dayselector: fix size
422         - remove unised styles
423         - divider: set non-press effect to default option
424         - popupwindow: fix window closing failure
425         - handler: GUI implementation
426         - TC: fix unit TCs
427         - scrollview: fix padding size
428 - Spec changes:
429         - Remove color widgets
430         - add $.tizen.pkgVersion for SDK
431 - Etc.
432         - JSDuck documents
433
434 * Fri Nov 16 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.62
435 - FIX:
436         - Many winsets: Fix layout
437         - Footer: fix position to bottom
438 - Spec changes:
439         - Remove color widgets
440
441 * Fri Nov 09 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.61
442 - FIX:
443         - Many widgets: New UX 0.6 theme implementation
444         - widgetex: init speed up
445         - scrollview: fix scrollbar and scale animation
446         - scrollview: fix scroll position when updatelayout is triggered
447         - header/footer: make textselection disable, except input type="text"
448
449 * Wed Nov 07 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.60
450 - FIX:
451         - Remove tizen-black theme package description
452
453 * Tue Nov 06 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.59
454 - FIX:
455         - Fix theme name to meet the change of system theme name: white->tizen
456         - Popupwindow: fix left position
457         - Remove black theme
458         - footer: remove label, legend drawing
459 - Spec changes:
460         - UX guide v0.4 : button, layout
461
462 * Wed Oct 24 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.57
463 - FIX:
464         - expandablelist: icon color fix
465         - scrollview: Fix xy scroll
466         - footer: Remove dummy div
467         - Make string concatnation effective in inline-protos.sh
468 - Spec changes:
469         - refresh header/footer when drag&drop event is fired in GUI builder
470         - searchbar: delete cancel button
471         - don't trigger updatelayout event when keyup event comes
472
473 * Mon Oct 15 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.56
474 - FIX:
475         - Toggleswitch: Change event name from 'changed' to 'change'
476         - Notification: Revert interval feature
477
478 * Tue Oct 09 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.55
479 - FIX:
480         - Fix SMACK manifest bug (S1-9098)
481
482 * Fri Oct 05 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.54
483 - FIX:
484         - handler: don't append a handler if handler is not enabled
485         - scrollview: use static value
486         - datetimepicker: fix date-format HH display error
487 - ETC:
488         - provide jquery.min.js
489         - barlayout: codes clean
490         - remove unused file
491
492 * Wed Sep 26 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.53
493 - FIX:
494         - listview: change focused color
495         - multibuttonentry: code refactoring
496         - datetimepicker: modify date format when triggered date-changed event
497         - slider: fix the top of slider bar
498         - add event blocker when load a first page
499
500 * Fri Sep 21 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.52
501 - ETC.
502         - Move SMACK manifest files to the top SRCDIR
503
504 * Fri Sep 21 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.51
505 - FIX:
506         - Popup: Do not focus container
507         - Header: show backbutton when both tabbar and header are present together
508         - Multi button entry: text ellipsis, code refactoring
509
510 * Fri Sep 21 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.50
511 - ETC.
512         - Apply SMACK manifest
513
514 * Thu Sep 20 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.49
515 - FIX:
516         - JSLINT code clean-up
517         - scrollview: firefox support
518         - scrollview: fix finding slider handle
519         - list: tweak text ellipsis
520         - checkbox: fix selecting wrong label tag (N_SE-8370)
521         - imageslider: check parameter
522         - smallpopup: fix position
523         - searchbar: fix 'clear' button size
524 - Spec changes:
525         - scrollview: support outer scroll
526         - JQM: block click event only with the element that does preventdefault on vclick(N_SE-6090)
527         - remove S/W IME control
528
529 * Thu Sep 13 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.48
530 - FIX:
531         - Add missing icon: controlbar
532         - scrollview: tune scrolling animatio ninterval
533         - datetimepicker: digit/triangle position
534         - datetimepicker: fix day overflow issue
535 - Spec changes:
536         - scrollview: show scrollbar when page is showed
537         - scrollview: disable outer scroll
538         - extendablelist: change api with legacy support
539         - add ui-text-ellipsis class
540
541 * Mon Sep 10 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.47
542 - FIX:
543         - scrollveiw: fix height of view
544         - searchbar: support placeholder
545 - Spec changes:
546         - add ui-text-ellipsis class
547
548 * Fri Sep 07 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.46
549 - FIX:
550         - scrollview: scrolling bug fix
551         - controlbar: fix width of controlbar item
552 - Spec changes:
553         - searchbar: don't hide icon
554         - popup: update JQM poup widget
555
556 * Fri Sep 05 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.45
557 - FIX:
558         - controlbar: set correct controlbar width of last element
559         - slider: get popup enable value correctly
560         - use Date.now() instead of (new Data()).getTime()
561         - popupwindow: fix the background color of popup scroller
562         - listview: add padding-left to expandable list
563         - add ellipsis for title area support
564
565 * Fri Aug 31 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.44
566 - FIX:
567         - swipelist: show list items correctly
568         - datetimepicker: set last day, if day is overflowed
569 - Spec changes:
570         - controlbar: update icons
571
572 * Tue Aug 29 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.43
573 - FIX:
574         - notification: fix typo
575 - Spec changes:
576         - controlbar: update icons
577
578 * Tue Aug 28 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.42
579 - FIX:
580         - multimediaview: video progress bar display normally for too samll
581         - segmentcontrol: remove media query
582         - scrollview: add outer scroll condition
583         - datetimepicker: modify triangle size
584         - popupwindow: set the screen height explicitly
585         - notification: add multiline text
586 - Spec changes:
587         - mutibuttonentry: support new GUI
588         - virtualgrid: support new GUI
589
590 * Mon Aug 27 2012 Jinhyuk Jun <jinhyuk.jun@samsung.com> 0.1.41
591 - FIX:
592         - radio/check button : button size bug fix
593
594 * Fri Aug 24 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.40
595 - FIX:
596         - build error fixed
597
598 * Fri Aug 24 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.39
599 - FIX:
600         - listview: style fix, remove filter placeholder
601         - controlbar: divide styles
602         - scrollview: don't skip dragging when click button or inputbox
603         - slider: trim the text on text slider
604 - Spec changes:
605         - remove gray and blue theme
606         - add white and black theme
607         - support new GUI guide
608
609 * Mon Aug 20 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.38
610 - FIX:
611         - fix coment of version tag
612
613 * Fri Aug 17 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.37
614 - FIX :
615         - button: fix alignment
616         - listview: adjust the main text width
617         - virtualgrid: refactoring
618 - Spec changes:
619         - transition: support JQM 1.1.0 transitions
620         - scrollview: support the outer scroll
621         - notification: remove interval feature
622
623 * Tue Aug 14 2012 Youmin Ha <youmin.ha@samasung.com> 0.1.36
624 - FIX :
625         - checkboxRadio: Add left/right padding
626         - button: custom button & icon position
627         - virtuallist: remove 'recreate' test
628 - Spec changes:
629         - header/footer: enable/disable support
630
631 * Fri Aug 10 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.35
632 - FIX :
633         - expandablelist: modify show animation
634         - virtualgrid: Redesign programming interface
635         - popupwindow: code clean and fixed issues
636         - pagelayout: fix content height
637         - license file update
638         - virtuallist: Change programming interface
639         - datetimepicker: getting days correctly
640         - searchbar: set to hidden when cancel button is hide
641         - White theme title font tuning
642 - Spec changes:
643         - default theme tizen-gray to tizen-white
644         - set default page transition to none
645
646 * Mon Aug 02 2012 Jinhyuk Jun <jinhyuk.jun@samsung.com> 0.1.34
647 - FIX :
648         - Back Button : enlarge backbutton click size for white theme
649 - Feature :
650         - Expandable List : Add refresh api
651 * Mon Aug 02 2012 Jinhyuk Jun <jinhyuk.jun@samsung.com> 0.1.33
652 - FIX :
653         - click event touch threshold tuning
654
655 * Mon Aug 02 2012 Jinhyuk Jun <jinhyuk.jun@samsung.com> 0.1.32
656 - FIX : 
657         - Add back button highlight effect for white theme
658
659 * Mon Aug 01 2012 Jinhyuk Jun <jinhyuk.jun@samsnug.com> 0.1.31
660 - FIX : 
661         - IME checkroutine update, improve relayout on resize event
662         - Add highlight effect for radio button list 
663         - Scrollview : fix condition of updatelayout event
664 - Feature : progressing : add show/hide api
665
666 * Mon Jul 27 2012 Koeun Choi <koeun.choi@samsung.com> 0.1.30
667 - FIX : virtuallist, virtualgrid: Clean up temporary jquery.template object to clear cache
668         add default theme option on buttonMarkup for tizen theme
669         [searchbar] first fix : focus/blur fixed
670         back button does not work when long press
671         scrollview: don't auto scrolling if resizing area is too large
672 - Feature : notification : add api to set the icon at tickernoti
673         demo : update the list sample demo
674         Support tizen default theme
675
676 * Mon Jul 23 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.29
677 - Improvements & Bugfixes
678    - HOTFIX: Revert template function with jquery.template
679
680 * Thu Jul 19 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.28
681 - Improvements & Bugfixes
682    - Fix #WEB-1028: memory leak on virtuallist/virtualgrid
683 - Spec changes
684    - $.tizen.loadTheme() function accepts theme name as arguement
685    - Scrollview supports 'updatelayout' callback
686
687 * Tue Jul 17 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.27
688 - Improvements & Bugfixes
689    - Revert 'preventing long-press popup' patch, to fix backbutton to work in SocialMagazine
690
691 * Tue Jul 17 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.26
692 - Improvements & Bugfixes
693    - Add tizen-white theme package, to make rpm build to be finished
694
695 * Tue Jul 17 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.25
696 - Improvements & Bugfixes
697    - Set 'slide' as default page transition effect, by JQM patch
698
699 * Fri Jul 13 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.24
700 - Improvements & Bugfixes
701    - Fix IME show/hide algorithm
702    - Fix error on virtualgrid: link _set_scrollbar_size() function to the one in virtuallist
703
704 * Wed Jul 11 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.23
705 - Improvements & Bugfixes
706    - Fix notification position
707    - Fix unit tests
708
709  Fri Jul 6 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.22
710 - Spec changes
711         - JQM 1.1 upgrade
712 - Improvements & Bugfixes
713         - Transform3D support on scrollview
714         - Page layout supports IME control
715         - Mapview supports pinch zoom on JQM 1.1
716         - Fix wrong character on button in minified version
717         - Virtualgrid supports scrollbar
718         - Lots of bugfixes
719
720 * Fri Jun 22 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.20
721 - Spec changes
722         - Support 'latest' version (by symlink) for tizen-web-ui-fw.js path.
723         - imageslider : supports 'resize' event.
724         - listview : listview has 1px padding-bottom.
725         - loader : Change global namespace, from S to $.tizen.
726         - loader : Move loadCustomGlobalizeCulture() into $.tizen.util namespace.
727 - Improvements & Bugfixes
728         - Scrollview : supports 'translate3d', instead of 'translate'.
729         - notification : reset timer when 'show' or 'refresh' event.
730         - JQM patch : Fix vclick event triggered twice.
731 - Etc.
732         - Add & fix unit tests.
733
734 * Thu Jun 14 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.19
735 - Spec changes
736         - mapview : new widget.
737         - notification : add .refresh() API.
738         - pagecontrol : add .value([val]) API, and change an attribute name 'data-initVal' to 'data-value'.
739 - Improvements & Bugfixes
740         - Support minified CSS.
741         - loader : Fix & refactor 'loading globalize culture file' routine.
742         - JQM Patch : Calculate min-height of window in javascript code, and remove predefined min-height value from CSS.
743         - Many more bugfixes.
744 - Etc.
745         - Add many unit tests.
746         - Fix test coverage instrumentation tool to work with current source code.