0.2.12 release
[platform/framework/web/web-ui-fw.git] / packaging / web-ui-fw.spec
1 Name:       web-ui-fw
2 Version:    0.2.12
3 Release:    0
4 Summary:    Tizen Web UI Framework Library
5 Group:      Development/Other
6 License:    MIT
7 BuildArch:  noarch
8 BuildRequires:  make
9 BuildRequires:  nodejs
10 %ifarch %{arm}
11 BuildRequires:  nodejs-x86-arm
12 %endif
13
14 Source0:    %{name}-%{version}.tar.gz
15
16 %description
17 Tizen Web UI Framework library and theme packages
18
19 %prep
20 %setup -q
21
22 %build
23 make all
24
25 %install
26 make DESTDIR=%{buildroot} install
27
28 %post
29
30 %files
31 %manifest web-ui-fw.manifest
32 /usr/share/tizen-web-ui-fw/*/js
33 /usr/share/tizen-web-ui-fw/latest
34 /usr/share/tizen-web-ui-fw/VERSION
35
36 ###############################
37 %package -n web-ui-fw-theme-tizen-gray
38 BuildArch:  noarch
39 Summary:    Tizen Web UI Framework Theme : tizen-gray
40 %Description -n web-ui-fw-theme-tizen-gray
41     Tizen Web UI Framework Theme : tizen-gray
42
43 ###############################
44 %package -n web-ui-fw-theme-tizen-white
45 BuildArch:  noarch
46 Summary:    Tizen Web UI Framework Theme : tizen-white
47 %Description -n web-ui-fw-theme-tizen-white
48     Tizen Web UI Framework Theme : tizen-white
49 %files -n web-ui-fw-theme-tizen-white
50 %manifest web-ui-fw-theme-tizen-white.manifest
51 /usr/share/tizen-web-ui-fw/*/themes/tizen-white
52 /usr/share/tizen-web-ui-fw/*/themes/tizen-tizen
53
54 ###############################
55 %package -n web-ui-fw-theme-default
56 BuildArch:  noarch
57 Summary:    Tizen Web UI Framework Theme : default
58 %Description -n web-ui-fw-theme-default
59     Tizen Web UI Framework Theme : default
60 %files -n web-ui-fw-theme-default
61 %manifest web-ui-fw-theme-default.manifest
62 /usr/share/tizen-web-ui-fw/*/themes/default
63
64 ###############################
65 %package -n web-ui-fw-devel
66 BuildArch:  noarch
67 Summary:    Tizen Web UI Framework Developer's files
68 %Description -n web-ui-fw-devel
69     Tizen Web UI Framework Developer's files
70 %files -n web-ui-fw-devel
71 /usr/share/tizen-web-ui-fw/bin
72 /usr/share/tizen-web-ui-fw/template
73
74 ###############################
75 %package -n web-ui-fw-demo-tizen-winsets
76 BuildArch:  noarch
77 Summary:    Tizen Web UI Framework Demo Application: tizen winset demo
78 %Description -n web-ui-fw-demo-tizen-winsets
79     Tizen Web UI Framework Demo Application: tizen winset demo
80 %files  -n web-ui-fw-demo-tizen-winsets
81 /usr/share/tizen-web-ui-fw/demos/tizen-winsets
82
83
84 ###############################
85 %changelog
86 * Wed Jan 23 2013 Minkyu Kang <mk7.kang@samsung.com> 0.2.12
87         - theme : button icon - scrolltop, scrolleft icon changed.
88         - build: cleanaup Makefile
89         - pagelayout: fix jslint error
90         - virtualgrid: Fix jslint errors
91         - tabbar : jslint bug error fix
92         - build: add regexp option to jslint
93         - virtuallist: fix jslint errors
94         - handler: Apply the exceptional principle for scrollbar on Handler.
95         - build: remove unused copyright
96         - loader: extract log class for tizen web, and fix jslint errors
97         - loader: Viewport width is set to document width
98         - popupwindow: fix jslint error
99         - build: fix Makefile for tizen-white theme
100         - build: remove unused libraries
101         - datetimepicker: fix jslint error
102         - slider: fix jslint error
103         - demo: remove deprecated demos
104         - pagelayout : change to call relayout with this page
105         - Tokentextarea: Block size error fixed.
106         - handler: bug fix (handler activation)
107
108 * Tue Jan 22 2013 Minkyu Kang <mk7.kang@samsung.com> 0.2.11
109         - demo: clear input text value with cancel button click
110         - demo: Adjust textarea height automatically
111         - naviframe : bug fix
112         - tabbar : bug fix
113         - Fastscroll: popup position has been changed
114         - Button: custom button icon path, margin have been changed
115         - toggleswitch : bug fix
116         - slider: increase the margin
117         - datetimepicker: close the popup after select the value
118         - unit-test : add page backbutton control test
119         - Demo: added guide text and change input type in list vi
120         - remove legacy codes : jquery-geo
121         - Datetimepicker: text-main max-width has been removed
122         - Radio: control group border has been removed
123         - Demo: remove 'tab' space
124         - UnitTC: swipe unit tc has been fixed
125         - UnitTC: jQuery path has been fixed
126         - Button: bug fix when button has not a text
127         - tizen-winset: timepicker: demo title is changed
128
129 * Fri Jan 18 2013 Minkyu Kang <mk7.kang@samsung.com> 0.2.10
130         - tizen-winsets: codes cleanup
131         - datetimepicker: date calibration when year is changed
132         - Demo: textarea size has been changed
133         - Demo: Naviframe morebutton demo has been changed
134         - remove unused unit test cases : gallery3d
135         - tizen-winset: remove links
136
137 * Thu Jan 17 2013 Minkyu Kang <mk7.kang@samsung.com> 0.2.9
138         - gallery: use timeout function instead of interval
139         - Tokentextarea: Display error fixed.
140         - scrollview: Fix not selector to respond with jQuery1.8.2
141         - tabbar: remove the width of last element
142         - Demo: apply css 'user-select:none'
143         - Button: guide text has been shorten
144         - build: Update jQuery to 1.8.2 (JQM1.2 compliant)
145         - virtuallist: Fix mistyping
146         - demo: Fix tizen function namespace in demo
147         - virtuallist: Rewrite listitem replacing algorithm
148         - fastscroll: modify from not selector to function
149         - extendablelist: Fix unit-test
150         - tabbar : prefix to tabbar scroll event
151         - Popupwindow: removed unvalid selector in jquery 1.8.2
152         - slider: adjust handle text as length of value
153         - Demo: 3 buttons in popup text has been changed
154         - src: codes cleanup
155         - demo : remove trailing empty strings
156         - demo : rename TizenWinset list items
157         - button : change from long text list to multiline list
158         - build: Remove JQM1.1.0 patches
159         - Popup: Apply tizen style popup and attribute support
160         - JQM: Fix buttonmarkup bug keeping ui-btn-down class
161         - UnitTest: folder and file renamed, QUnit path was modified
162         - tizen-winsets: button: fix textarea width
163         - Swipe: event name error has been fixed
164
165 * Tue Jan 15 2013 Minkyu Kang <mk7.kang@samsung.com> 0.2.8
166         - Button: button padding has been updated
167         - virtuallist: fix unique listitem ID bug
168         - checkbox, radio : change display attr
169         - Button: bug fix ( when data style circle button on text )
170         - handler: bug fix (when scrolling with multi selection)
171         - JQM: adjust patch number
172         - gallery: show the widget after pageshow
173         - TokenTextArea : resource add ( press image )
174         - gallery: adds function that set the index to value API
175         - configure: set TIZEN default configures
176         - footer: h tag display attribute value has been changed
177         - buttons : demo bug fix
178         - searchbar : demo page bug fix
179         - tizen demo : bug fix
180         - build: remove JQM1.1.0
181         - Tokentextarea: Fix issues
182         - scrollview: block the multi touch
183         - list : dialogue list demo change
184         - pagelayout : update dynamic control
185         - Demo: Context popup close method has been changed
186
187 * Fri Jan 11 2013 Minkyu Kang <mk7.kang@samsung.com> 0.2.7
188         - slider: set text container's width as text length
189         - Timepicker: li max-width has been changed
190         - remove experimental feature - mapview.
191         - scrollview: added conditions for finding slider
192         - UnitTC: Pass,error count save method has been changed
193         - confix.xml: default config added for tizen basic applications
194         - Swipe: p tag margin value is set '0'
195         - packaging: remove unused file
196         - tabbar : bug fix
197         - list demo : bug fix
198         - tizen-winsets: gallery: move to new section
199         - tizen-winsets: autodivider: removes link of list
200         - demos: entry of number-pattern name is changed from 'number' to 'number-pattern'
201         - pagelayout : padding calculate change, ime footer check changed
202         - tizen-winsets: searchbar: scroll to the top when type the character
203         - searchbar : bug fix
204         - demo: Fix virtuallist demo following new list style
205         - demo: Add word-wrap:break-word and remove parag. width
206         - Demo: button max-width has been set( 3 buttons in popup )
207         - back button control demo : bug fix
208         - toggleswitch : demo page modify
209         - slider: add margin-top and margin-bottom
210         - tabbar demo : bug fix
211         - Popup: IME hide when popup is closed
212         - token textarea : bug fix
213         - Timepicker: change get attribute method
214         - footer demo : bug fix
215         - unit-test: gallery: add new APIs
216         - gallery: adds support new APIs
217
218 * Fri Jan 04 2013 Minkyu Kang <mk7.kang@samsung.com> 0.2.6
219         - JQM: patches cleanup
220         - Button: data-corners attribute has been added
221         - unit-test: slider: fix class name of background
222         - progressbar, slider: fix less variable typo
223         - Tabbar : VI update
224         - notification: add top position at fix class
225         - demo: entry demo page change
226         - css: .ui-disabled added
227         - tizen-winset: token textarea: remove back button at demo page
228         - theme: Remove unused less file
229         - pagelayout : content min height bug fix
230         - scrollview: skip the dragging when target is slider's handle
231         - scrollview: update and refactoring the scroll effect
232         - UnitTest:JQM Unit TC helper has been added,TCs have been modified
233         - Swipe: demo page html error has been fixed
234         - listview: Add add/delete animation (VI)
235         - Popup: demo page has been modified
236         - tizen demo : bug fix
237         - searchbar : demo page change(change front button and add behaviour)
238         - pagelayout : add min height to content
239         - gallery: rename 'Image Slider' to 'Gallery' in tizen-winsets demo and tests
240         - back button control demo : change url link to data-rel="back"
241         - loader: Skip loading theme CSS with a custom css code
242         - Button: support no-text in button
243         - collapsible: Fix syntax error
244         - slider: use data-highlight attribute
245         - collapsible: Rotate animation to collapsible heading icon
246         - toggleswitch : text switch bug fix
247         - remove candidates-calendarpicker
248         - Patch: Fix misc mistakes in JQM patches
249         - searchbar : animation change
250         - gallery: get the width correctly
251         - demo: data-framework-viewport-scale attribute is changed to data-framework-viewport-width
252         - collapsible: Add collapse/expand animation (VI)
253         - datetimepicker: VI update
254         - JQM: set transition to pop as default
255         - tabbar : bug fix in case none li element case
256         - scrollview: fix the drag bug
257         - Button: Button icon scrolltop, left has beed added
258         - Swipe: VI update and swipe speed has been changed
259         - jqm: fix errors in patch files
260         - unit-test: swipe: fixed the destroy test
261
262 * Wed Dec 26 2012 Youmin Ha <youmin.ha@samsung.com> 0.2.5
263         - Revert "[checkboxradio] exception handling for input"
264                 This reverts commit 72478c32704fa96362db577e6cf9511777919ea8.
265                 Tizen style supports no-label radio and checkbox when making lists.
266                 So it ignores html input operation. Instead, it supports tizen style radio and checkbox theme.
267
268 * Thu Dec 20 2012 Youmin Ha <youmin.ha@samsung.com> 0.2.4
269 - Fix:
270         - modify segment background
271         - rearrange check, radio input
272         - CtxPopup: Scale up/ down popup vi(poptop, popbottom)
273         - button: style has beed added(box,circle,nobg,round)
274         - favorite resource added
275         - demo/tizen-winsets: add footer and back button
276         - remove autodividers unit test
277         - add divider for tabbar
278         - checkboxradio: exception handling for input
279         - segment control backward compatiblity
280         - Fix collapsible unit-test
281         - remove toggleswitch
282         - add patch for remove segment text
283 - Spec changes:
284         - replace controlbar to tabbar
285
286 * Fri Dec 14 2012 Minkyu Kang <mk7.kang@samsung.com> 0.2.3
287 - FIX:
288         - slider: add image
289         - button: data-icon support, styles fix
290         - progressbar: modify the background
291         - scrollview: auto scrolling bug fix
292         - pagelayout: IME concept is changed
293 - Spec changes:
294         - dialogue: add edit mode
295         - nocontents: removed
296         - pagecontrol: removed
297         - dayselector: removed
298         - expandablelist: removed
299
300 * Thu Dec 10 2012 Youmin Ha <youmin.ha@samsung.com> 0.2.2
301 - FIX:
302         - chang searchbar/slider images
303         - delete redundant button images
304 - Spec changes:
305         - Change widget name: shortcutscroll -> fastscroll
306
307 * Thu Dec 07 2012 Youmin Ha <youmin.ha@samsung.com> 0.2.1
308 - FIX:
309         - jqm1.2: Change collapsible style to meet expandable list
310         - remove jquery-geo-1.0.a4
311         - unit-test: rename from imageslider to gallery
312         - nocontent: add warning message
313         - Handler: Fix issues in jqm1.2
314         - Multimediaview: modify APIs & comments
315         - Mapview: Fix issues in jqm1.2
316         - JQM: clean up patches
317         - Swipelist: refactoring swipelist
318         - Popup,Ctxpopup: Apply tizen style popup in JQM1.2
319         - rearrange button's data-icon resources
320 - Spec changes:
321         - Virtualgrid: remove option ('data-itemcount')
322         - gallery: rename the widget from imageslider to gallery
323         - add new style for searchbar
324         [tokentextarea] multi-button entry renamed as token text area. API & comments modified.
325
326 * Thu Dec 06 2012 Minkyu Kang <mk7.kang@samsung.com> 0.2.0
327 - FIX:
328         - fix jslint error
329         - remove unused files
330         - change naviframe style
331 - Spec changes:
332         - applied jQuery Mobile 1.2.0
333         - remove optionheader
334
335 * Fri Nov 30 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.64
336 - FIX:
337         - fix unit tests
338         - remove unused theme files
339         - timepicker: text position fix
340         - scrollview: set dragstop when mouse is out of window
341         - listview: fix margin
342 - Spec changes:
343         - support data-framework-viewport-width
344
345 * Fri Nov 23 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.63
346 - FIX:
347         - dayselector: fix size
348         - remove unised styles
349         - divider: set non-press effect to default option
350         - popupwindow: fix window closing failure
351         - handler: GUI implementation
352         - TC: fix unit TCs
353         - scrollview: fix padding size
354 - Spec changes:
355         - Remove color widgets
356         - add $.tizen.pkgVersion for SDK
357 - Etc.
358         - JSDuck documents
359
360 * Fri Nov 16 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.62
361 - FIX:
362         - Many winsets: Fix layout
363         - Footer: fix position to bottom
364 - Spec changes:
365         - Remove color widgets
366
367 * Fri Nov 09 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.61
368 - FIX:
369         - Many widgets: New UX 0.6 theme implementation
370         - widgetex: init speed up
371         - scrollview: fix scrollbar and scale animation
372         - scrollview: fix scroll position when updatelayout is triggered
373         - header/footer: make textselection disable, except input type="text"
374
375 * Wed Nov 07 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.60
376 - FIX:
377         - Remove tizen-black theme package description
378
379 * Tue Nov 06 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.59
380 - FIX:
381         - Fix theme name to meet the change of system theme name: white->tizen
382         - Popupwindow: fix left position
383         - Remove black theme
384         - footer: remove label, legend drawing
385 - Spec changes:
386         - UX guide v0.4 : button, layout
387
388 * Wed Oct 24 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.57
389 - FIX:
390         - expandablelist: icon color fix
391         - scrollview: Fix xy scroll
392         - footer: Remove dummy div
393         - Make string concatnation effective in inline-protos.sh
394 - Spec changes:
395         - refresh header/footer when drag&drop event is fired in GUI builder
396         - searchbar: delete cancel button
397         - don't trigger updatelayout event when keyup event comes
398
399 * Mon Oct 15 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.56
400 - FIX:
401         - Toggleswitch: Change event name from 'changed' to 'change'
402         - Notification: Revert interval feature
403
404 * Tue Oct 09 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.55
405 - FIX:
406         - Fix SMACK manifest bug (S1-9098)
407
408 * Fri Oct 05 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.54
409 - FIX:
410         - handler: don't append a handler if handler is not enabled
411         - scrollview: use static value
412         - datetimepicker: fix date-format HH display error
413 - ETC:
414         - provide jquery.min.js
415         - barlayout: codes clean
416         - remove unused file
417
418 * Wed Sep 26 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.53
419 - FIX:
420         - listview: change focused color
421         - multibuttonentry: code refactoring
422         - datetimepicker: modify date format when triggered date-changed event
423         - slider: fix the top of slider bar
424         - add event blocker when load a first page
425
426 * Fri Sep 21 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.52
427 - ETC.
428         - Move SMACK manifest files to the top SRCDIR
429
430 * Fri Sep 21 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.51
431 - FIX:
432         - Popup: Do not focus container
433         - Header: show backbutton when both tabbar and header are present together
434         - Multi button entry: text ellipsis, code refactoring
435
436 * Fri Sep 21 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.50
437 - ETC.
438         - Apply SMACK manifest
439
440 * Thu Sep 20 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.49
441 - FIX:
442         - JSLINT code clean-up
443         - scrollview: firefox support
444         - scrollview: fix finding slider handle
445         - list: tweak text ellipsis
446         - checkbox: fix selecting wrong label tag (N_SE-8370)
447         - imageslider: check parameter
448         - smallpopup: fix position
449         - searchbar: fix 'clear' button size
450 - Spec changes:
451         - scrollview: support outer scroll
452         - JQM: block click event only with the element that does preventdefault on vclick(N_SE-6090)
453         - remove S/W IME control
454
455 * Thu Sep 13 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.48
456 - FIX:
457         - Add missing icon: controlbar
458         - scrollview: tune scrolling animatio ninterval
459         - datetimepicker: digit/triangle position
460         - datetimepicker: fix day overflow issue
461 - Spec changes:
462         - scrollview: show scrollbar when page is showed
463         - scrollview: disable outer scroll
464         - extendablelist: change api with legacy support
465         - add ui-text-ellipsis class
466
467 * Mon Sep 10 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.47
468 - FIX:
469         - scrollveiw: fix height of view
470         - searchbar: support placeholder
471 - Spec changes:
472         - add ui-text-ellipsis class
473
474 * Fri Sep 07 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.46
475 - FIX:
476         - scrollview: scrolling bug fix
477         - controlbar: fix width of controlbar item
478 - Spec changes:
479         - searchbar: don't hide icon
480         - popup: update JQM poup widget
481
482 * Fri Sep 05 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.45
483 - FIX:
484         - controlbar: set correct controlbar width of last element
485         - slider: get popup enable value correctly
486         - use Date.now() instead of (new Data()).getTime()
487         - popupwindow: fix the background color of popup scroller
488         - listview: add padding-left to expandable list
489         - add ellipsis for title area support
490
491 * Fri Aug 31 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.44
492 - FIX:
493         - swipelist: show list items correctly
494         - datetimepicker: set last day, if day is overflowed
495 - Spec changes:
496         - controlbar: update icons
497
498 * Tue Aug 29 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.43
499 - FIX:
500         - notification: fix typo
501 - Spec changes:
502         - controlbar: update icons
503
504 * Tue Aug 28 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.42
505 - FIX:
506         - multimediaview: video progress bar display normally for too samll
507         - segmentcontrol: remove media query
508         - scrollview: add outer scroll condition
509         - datetimepicker: modify triangle size
510         - popupwindow: set the screen height explicitly
511         - notification: add multiline text
512 - Spec changes:
513         - mutibuttonentry: support new GUI
514         - virtualgrid: support new GUI
515
516 * Mon Aug 27 2012 Jinhyuk Jun <jinhyuk.jun@samsung.com> 0.1.41
517 - FIX:
518         - radio/check button : button size bug fix
519
520 * Fri Aug 24 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.40
521 - FIX:
522         - build error fixed
523
524 * Fri Aug 24 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.39
525 - FIX:
526         - listview: style fix, remove filter placeholder
527         - controlbar: divide styles
528         - scrollview: don't skip dragging when click button or inputbox
529         - slider: trim the text on text slider
530 - Spec changes:
531         - remove gray and blue theme
532         - add white and black theme
533         - support new GUI guide
534
535 * Mon Aug 20 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.38
536 - FIX:
537         - fix coment of version tag
538
539 * Fri Aug 17 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.37
540 - FIX :
541         - button: fix alignment
542         - listview: adjust the main text width
543         - virtualgrid: refactoring
544 - Spec changes:
545         - transition: support JQM 1.1.0 transitions
546         - scrollview: support the outer scroll
547         - notification: remove interval feature
548
549 * Tue Aug 14 2012 Youmin Ha <youmin.ha@samasung.com> 0.1.36
550 - FIX :
551         - checkboxRadio: Add left/right padding
552         - button: custom button & icon position
553         - virtuallist: remove 'recreate' test
554 - Spec changes:
555         - header/footer: enable/disable support
556
557 * Fri Aug 10 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.35
558 - FIX :
559         - expandablelist: modify show animation
560         - virtualgrid: Redesign programming interface
561         - popupwindow: code clean and fixed issues
562         - pagelayout: fix content height
563         - license file update
564         - virtuallist: Change programming interface
565         - datetimepicker: getting days correctly
566         - searchbar: set to hidden when cancel button is hide
567         - White theme title font tuning
568 - Spec changes:
569         - default theme tizen-gray to tizen-white
570         - set default page transition to none
571
572 * Mon Aug 02 2012 Jinhyuk Jun <jinhyuk.jun@samsung.com> 0.1.34
573 - FIX :
574         - Back Button : enlarge backbutton click size for white theme
575 - Feature :
576         - Expandable List : Add refresh api
577 * Mon Aug 02 2012 Jinhyuk Jun <jinhyuk.jun@samsung.com> 0.1.33
578 - FIX :
579         - click event touch threshold tuning
580
581 * Mon Aug 02 2012 Jinhyuk Jun <jinhyuk.jun@samsung.com> 0.1.32
582 - FIX : 
583         - Add back button highlight effect for white theme
584
585 * Mon Aug 01 2012 Jinhyuk Jun <jinhyuk.jun@samsnug.com> 0.1.31
586 - FIX : 
587         - IME checkroutine update, improve relayout on resize event
588         - Add highlight effect for radio button list 
589         - Scrollview : fix condition of updatelayout event
590 - Feature : progressing : add show/hide api
591
592 * Mon Jul 27 2012 Koeun Choi <koeun.choi@samsung.com> 0.1.30
593 - FIX : virtuallist, virtualgrid: Clean up temporary jquery.template object to clear cache
594         add default theme option on buttonMarkup for tizen theme
595         [searchbar] first fix : focus/blur fixed
596         back button does not work when long press
597         scrollview: don't auto scrolling if resizing area is too large
598 - Feature : notification : add api to set the icon at tickernoti
599         demo : update the list sample demo
600         Support tizen default theme
601
602 * Mon Jul 23 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.29
603 - Improvements & Bugfixes
604    - HOTFIX: Revert template function with jquery.template
605
606 * Thu Jul 19 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.28
607 - Improvements & Bugfixes
608    - Fix #WEB-1028: memory leak on virtuallist/virtualgrid
609 - Spec changes
610    - $.tizen.loadTheme() function accepts theme name as arguement
611    - Scrollview supports 'updatelayout' callback
612
613 * Tue Jul 17 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.27
614 - Improvements & Bugfixes
615    - Revert 'preventing long-press popup' patch, to fix backbutton to work in SocialMagazine
616
617 * Tue Jul 17 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.26
618 - Improvements & Bugfixes
619    - Add tizen-white theme package, to make rpm build to be finished
620
621 * Tue Jul 17 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.25
622 - Improvements & Bugfixes
623    - Set 'slide' as default page transition effect, by JQM patch
624
625 * Fri Jul 13 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.24
626 - Improvements & Bugfixes
627    - Fix IME show/hide algorithm
628    - Fix error on virtualgrid: link _set_scrollbar_size() function to the one in virtuallist
629
630 * Wed Jul 11 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.23
631 - Improvements & Bugfixes
632    - Fix notification position
633    - Fix unit tests
634
635  Fri Jul 6 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.22
636 - Spec changes
637         - JQM 1.1 upgrade
638 - Improvements & Bugfixes
639         - Transform3D support on scrollview
640         - Page layout supports IME control
641         - Mapview supports pinch zoom on JQM 1.1
642         - Fix wrong character on button in minified version
643         - Virtualgrid supports scrollbar
644         - Lots of bugfixes
645
646 * Fri Jun 22 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.20
647 - Spec changes
648         - Support 'latest' version (by symlink) for tizen-web-ui-fw.js path.
649         - imageslider : supports 'resize' event.
650         - listview : listview has 1px padding-bottom.
651         - loader : Change global namespace, from S to $.tizen.
652         - loader : Move loadCustomGlobalizeCulture() into $.tizen.util namespace.
653 - Improvements & Bugfixes
654         - Scrollview : supports 'translate3d', instead of 'translate'.
655         - notification : reset timer when 'show' or 'refresh' event.
656         - JQM patch : Fix vclick event triggered twice.
657 - Etc.
658         - Add & fix unit tests.
659
660 * Thu Jun 14 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.19
661 - Spec changes
662         - mapview : new widget.
663         - notification : add .refresh() API.
664         - pagecontrol : add .value([val]) API, and change an attribute name 'data-initVal' to 'data-value'.
665 - Improvements & Bugfixes
666         - Support minified CSS.
667         - loader : Fix & refactor 'loading globalize culture file' routine.
668         - JQM Patch : Calculate min-height of window in javascript code, and remove predefined min-height value from CSS.
669         - Many more bugfixes.
670 - Etc.
671         - Add many unit tests.
672         - Fix test coverage instrumentation tool to work with current source code.