0.2.16 release
[platform/framework/web/web-ui-fw.git] / packaging / web-ui-fw.spec
1 Name:       web-ui-fw
2 Version:    0.2.16
3 Release:    0
4 Summary:    Tizen Web UI Framework Library
5 Group:      Development/Other
6 License:    MIT
7 BuildArch:  noarch
8 BuildRequires:  make
9 BuildRequires:  nodejs
10 %ifarch %{arm}
11 BuildRequires:  nodejs-x86-arm
12 %endif
13
14 Source0:    %{name}-%{version}.tar.gz
15
16 %description
17 Tizen Web UI Framework library and theme packages
18
19 %prep
20 %setup -q
21
22 %build
23 make all
24
25 %install
26 make DESTDIR=%{buildroot} install
27
28 %post
29
30 %files
31 %manifest web-ui-fw.manifest
32 /usr/share/tizen-web-ui-fw/*/js
33 /usr/share/tizen-web-ui-fw/latest
34 /usr/share/tizen-web-ui-fw/VERSION
35
36 ###############################
37 %package -n web-ui-fw-theme-tizen-gray
38 BuildArch:  noarch
39 Summary:    Tizen Web UI Framework Theme : tizen-gray
40 %Description -n web-ui-fw-theme-tizen-gray
41     Tizen Web UI Framework Theme : tizen-gray
42
43 ###############################
44 %package -n web-ui-fw-theme-tizen-white
45 BuildArch:  noarch
46 Summary:    Tizen Web UI Framework Theme : tizen-white
47 %Description -n web-ui-fw-theme-tizen-white
48     Tizen Web UI Framework Theme : tizen-white
49 %files -n web-ui-fw-theme-tizen-white
50 %manifest web-ui-fw-theme-tizen-white.manifest
51 /usr/share/tizen-web-ui-fw/*/themes/tizen-white
52 /usr/share/tizen-web-ui-fw/*/themes/tizen-tizen
53
54 ###############################
55 %package -n web-ui-fw-theme-default
56 BuildArch:  noarch
57 Summary:    Tizen Web UI Framework Theme : default
58 %Description -n web-ui-fw-theme-default
59     Tizen Web UI Framework Theme : default
60 %files -n web-ui-fw-theme-default
61 %manifest web-ui-fw-theme-default.manifest
62 /usr/share/tizen-web-ui-fw/*/themes/default
63
64 ###############################
65 %package -n web-ui-fw-devel
66 BuildArch:  noarch
67 Summary:    Tizen Web UI Framework Developer's files
68 %Description -n web-ui-fw-devel
69     Tizen Web UI Framework Developer's files
70 %files -n web-ui-fw-devel
71 /usr/share/tizen-web-ui-fw/bin
72 /usr/share/tizen-web-ui-fw/template
73
74 ###############################
75 %package -n web-ui-fw-demo-tizen-winsets
76 BuildArch:  noarch
77 Summary:    Tizen Web UI Framework Demo Application: tizen winset demo
78 %Description -n web-ui-fw-demo-tizen-winsets
79     Tizen Web UI Framework Demo Application: tizen winset demo
80 %files  -n web-ui-fw-demo-tizen-winsets
81 /usr/share/tizen-web-ui-fw/demos/tizen-winsets
82
83
84 ###############################
85 %changelog
86 * Mon Jan 28 2013 Youmin Ha <youmin.ha@samsung.com> 0.2.16
87         - demo: checkbox: reduce button's width
88         - tabbar : delete right/left tab animation color
89         - scrollview: fix the scroll position at keydown event
90         - groupControl : change footer groupControl from min-width to percentage
91         - scrollview: get height of softkeyboard correctly
92         - tizen-winset: Add name attr to all radio inputs
93         - virtualgrid: changes event binding target
94         - scrollview: skip the drag if target is textarea
95         - scrollview: skip the dragging of parent scrollview
96         - scrollview: apply the scaling ratio to the soft keyboard
97         - demos: apply disabled option in textarea
98         - demo: remove unused codes
99         - demo: datetimepicker: show selected date correctly
100         - listview: Adjust bubble listitem width and margin
101         - pagelayout : change external refresh call and ime status follow only current page
102         - toggleSwitch : bug fix
103         - unit-test: slider: fix the move test
104         - handler: fix jslint error
105         - ToggleSwitch : set image toggleswitch background attribute
106
107 * Mon Jan 28 2013 Youmin Ha <youmin.ha@samsung.com> 0.2.15
108         - slider: increase the text width(N_SE-23397)
109         - virtualgrid: DOM element leak fix
110         - header: Move button top higher in header with tabbar(N_SE-22253)
111         - datatimepicker: don't open the popup before popupafterclose event is fired(N_SE-23027)
112         - handler: bug fix (regarding enableHandler function )
113         - demo:fix syntax error
114
115 * Sat Jan 26 2013 Youmin Ha <youmin.ha@samsung.com> 0.2.14
116         - demo: fix demo using tizen device API
117         - multimediaview: reset the height of container
118         - input: modify css correctly
119         - multimediaview: fix the height of widget
120         - gallery: bind create event
121         - progress: bind create event
122         - slider: bind create event
123         - progressbar: bind create event
124         - progressbar: event trigger correctly
125         - popup: fix height of popup scroller
126         - build: add continue option to jslint
127         - ctxpopup demo : bug fix
128         - demo: fix searchbar demo to use different IDs
129         - demo: extract routine executing Tizen device API
130         - toggleswitch : set default margin, delete box padding
131
132 * Thu Jan 24 2013 Youmin Ha <youmin.ha@samsung.com> 0.2.13
133         - virtuallist: Prevent replacing contents on nonexist element
134         - JQM: Trim text in listitem to get index in autodivider
135         - JQM: Remove trailing whitespace in jqm patch
136         - scrollview: get the height including margin
137         - multimediaview: bug fix ( scrolling in full-screen mode )
138         - virtuallist: set listitem width to exclude listitem left/right margin
139         - demo: fix virtuallist sample layout
140         - progress: set the position explicitly
141         - progress: rename from progressing to progress
142         - build: remove unused files
143         - searchbar: fix jslint errors
144         - src: fix file permissions
145         - button : change jump left icon
146
147 * Wed Jan 23 2013 Minkyu Kang <mk7.kang@samsung.com> 0.2.12
148         - theme : button icon - scrolltop, scrolleft icon changed.
149         - build: cleanaup Makefile
150         - pagelayout: fix jslint error
151         - virtualgrid: Fix jslint errors
152         - tabbar : jslint bug error fix
153         - build: add regexp option to jslint
154         - virtuallist: fix jslint errors
155         - handler: Apply the exceptional principle for scrollbar on Handler.
156         - build: remove unused copyright
157         - loader: extract log class for tizen web, and fix jslint errors
158         - loader: Viewport width is set to document width
159         - popupwindow: fix jslint error
160         - build: fix Makefile for tizen-white theme
161         - build: remove unused libraries
162         - datetimepicker: fix jslint error
163         - slider: fix jslint error
164         - demo: remove deprecated demos
165         - pagelayout : change to call relayout with this page
166         - Tokentextarea: Block size error fixed.
167         - handler: bug fix (handler activation)
168
169 * Tue Jan 22 2013 Minkyu Kang <mk7.kang@samsung.com> 0.2.11
170         - demo: clear input text value with cancel button click
171         - demo: Adjust textarea height automatically
172         - naviframe : bug fix
173         - tabbar : bug fix
174         - Fastscroll: popup position has been changed
175         - Button: custom button icon path, margin have been changed
176         - toggleswitch : bug fix
177         - slider: increase the margin
178         - datetimepicker: close the popup after select the value
179         - unit-test : add page backbutton control test
180         - Demo: added guide text and change input type in list vi
181         - remove legacy codes : jquery-geo
182         - Datetimepicker: text-main max-width has been removed
183         - Radio: control group border has been removed
184         - Demo: remove 'tab' space
185         - UnitTC: swipe unit tc has been fixed
186         - UnitTC: jQuery path has been fixed
187         - Button: bug fix when button has not a text
188         - tizen-winset: timepicker: demo title is changed
189
190 * Fri Jan 18 2013 Minkyu Kang <mk7.kang@samsung.com> 0.2.10
191         - tizen-winsets: codes cleanup
192         - datetimepicker: date calibration when year is changed
193         - Demo: textarea size has been changed
194         - Demo: Naviframe morebutton demo has been changed
195         - remove unused unit test cases : gallery3d
196         - tizen-winset: remove links
197
198 * Thu Jan 17 2013 Minkyu Kang <mk7.kang@samsung.com> 0.2.9
199         - gallery: use timeout function instead of interval
200         - Tokentextarea: Display error fixed.
201         - scrollview: Fix not selector to respond with jQuery1.8.2
202         - tabbar: remove the width of last element
203         - Demo: apply css 'user-select:none'
204         - Button: guide text has been shorten
205         - build: Update jQuery to 1.8.2 (JQM1.2 compliant)
206         - virtuallist: Fix mistyping
207         - demo: Fix tizen function namespace in demo
208         - virtuallist: Rewrite listitem replacing algorithm
209         - fastscroll: modify from not selector to function
210         - extendablelist: Fix unit-test
211         - tabbar : prefix to tabbar scroll event
212         - Popupwindow: removed unvalid selector in jquery 1.8.2
213         - slider: adjust handle text as length of value
214         - Demo: 3 buttons in popup text has been changed
215         - src: codes cleanup
216         - demo : remove trailing empty strings
217         - demo : rename TizenWinset list items
218         - button : change from long text list to multiline list
219         - build: Remove JQM1.1.0 patches
220         - Popup: Apply tizen style popup and attribute support
221         - JQM: Fix buttonmarkup bug keeping ui-btn-down class
222         - UnitTest: folder and file renamed, QUnit path was modified
223         - tizen-winsets: button: fix textarea width
224         - Swipe: event name error has been fixed
225
226 * Tue Jan 15 2013 Minkyu Kang <mk7.kang@samsung.com> 0.2.8
227         - Button: button padding has been updated
228         - virtuallist: fix unique listitem ID bug
229         - checkbox, radio : change display attr
230         - Button: bug fix ( when data style circle button on text )
231         - handler: bug fix (when scrolling with multi selection)
232         - JQM: adjust patch number
233         - gallery: show the widget after pageshow
234         - TokenTextArea : resource add ( press image )
235         - gallery: adds function that set the index to value API
236         - configure: set TIZEN default configures
237         - footer: h tag display attribute value has been changed
238         - buttons : demo bug fix
239         - searchbar : demo page bug fix
240         - tizen demo : bug fix
241         - build: remove JQM1.1.0
242         - Tokentextarea: Fix issues
243         - scrollview: block the multi touch
244         - list : dialogue list demo change
245         - pagelayout : update dynamic control
246         - Demo: Context popup close method has been changed
247
248 * Fri Jan 11 2013 Minkyu Kang <mk7.kang@samsung.com> 0.2.7
249         - slider: set text container's width as text length
250         - Timepicker: li max-width has been changed
251         - remove experimental feature - mapview.
252         - scrollview: added conditions for finding slider
253         - UnitTC: Pass,error count save method has been changed
254         - confix.xml: default config added for tizen basic applications
255         - Swipe: p tag margin value is set '0'
256         - packaging: remove unused file
257         - tabbar : bug fix
258         - list demo : bug fix
259         - tizen-winsets: gallery: move to new section
260         - tizen-winsets: autodivider: removes link of list
261         - demos: entry of number-pattern name is changed from 'number' to 'number-pattern'
262         - pagelayout : padding calculate change, ime footer check changed
263         - tizen-winsets: searchbar: scroll to the top when type the character
264         - searchbar : bug fix
265         - demo: Fix virtuallist demo following new list style
266         - demo: Add word-wrap:break-word and remove parag. width
267         - Demo: button max-width has been set( 3 buttons in popup )
268         - back button control demo : bug fix
269         - toggleswitch : demo page modify
270         - slider: add margin-top and margin-bottom
271         - tabbar demo : bug fix
272         - Popup: IME hide when popup is closed
273         - token textarea : bug fix
274         - Timepicker: change get attribute method
275         - footer demo : bug fix
276         - unit-test: gallery: add new APIs
277         - gallery: adds support new APIs
278
279 * Fri Jan 04 2013 Minkyu Kang <mk7.kang@samsung.com> 0.2.6
280         - JQM: patches cleanup
281         - Button: data-corners attribute has been added
282         - unit-test: slider: fix class name of background
283         - progressbar, slider: fix less variable typo
284         - Tabbar : VI update
285         - notification: add top position at fix class
286         - demo: entry demo page change
287         - css: .ui-disabled added
288         - tizen-winset: token textarea: remove back button at demo page
289         - theme: Remove unused less file
290         - pagelayout : content min height bug fix
291         - scrollview: skip the dragging when target is slider's handle
292         - scrollview: update and refactoring the scroll effect
293         - UnitTest:JQM Unit TC helper has been added,TCs have been modified
294         - Swipe: demo page html error has been fixed
295         - listview: Add add/delete animation (VI)
296         - Popup: demo page has been modified
297         - tizen demo : bug fix
298         - searchbar : demo page change(change front button and add behaviour)
299         - pagelayout : add min height to content
300         - gallery: rename 'Image Slider' to 'Gallery' in tizen-winsets demo and tests
301         - back button control demo : change url link to data-rel="back"
302         - loader: Skip loading theme CSS with a custom css code
303         - Button: support no-text in button
304         - collapsible: Fix syntax error
305         - slider: use data-highlight attribute
306         - collapsible: Rotate animation to collapsible heading icon
307         - toggleswitch : text switch bug fix
308         - remove candidates-calendarpicker
309         - Patch: Fix misc mistakes in JQM patches
310         - searchbar : animation change
311         - gallery: get the width correctly
312         - demo: data-framework-viewport-scale attribute is changed to data-framework-viewport-width
313         - collapsible: Add collapse/expand animation (VI)
314         - datetimepicker: VI update
315         - JQM: set transition to pop as default
316         - tabbar : bug fix in case none li element case
317         - scrollview: fix the drag bug
318         - Button: Button icon scrolltop, left has beed added
319         - Swipe: VI update and swipe speed has been changed
320         - jqm: fix errors in patch files
321         - unit-test: swipe: fixed the destroy test
322
323 * Wed Dec 26 2012 Youmin Ha <youmin.ha@samsung.com> 0.2.5
324         - Revert "[checkboxradio] exception handling for input"
325                 This reverts commit 72478c32704fa96362db577e6cf9511777919ea8.
326                 Tizen style supports no-label radio and checkbox when making lists.
327                 So it ignores html input operation. Instead, it supports tizen style radio and checkbox theme.
328
329 * Thu Dec 20 2012 Youmin Ha <youmin.ha@samsung.com> 0.2.4
330 - Fix:
331         - modify segment background
332         - rearrange check, radio input
333         - CtxPopup: Scale up/ down popup vi(poptop, popbottom)
334         - button: style has beed added(box,circle,nobg,round)
335         - favorite resource added
336         - demo/tizen-winsets: add footer and back button
337         - remove autodividers unit test
338         - add divider for tabbar
339         - checkboxradio: exception handling for input
340         - segment control backward compatiblity
341         - Fix collapsible unit-test
342         - remove toggleswitch
343         - add patch for remove segment text
344 - Spec changes:
345         - replace controlbar to tabbar
346
347 * Fri Dec 14 2012 Minkyu Kang <mk7.kang@samsung.com> 0.2.3
348 - FIX:
349         - slider: add image
350         - button: data-icon support, styles fix
351         - progressbar: modify the background
352         - scrollview: auto scrolling bug fix
353         - pagelayout: IME concept is changed
354 - Spec changes:
355         - dialogue: add edit mode
356         - nocontents: removed
357         - pagecontrol: removed
358         - dayselector: removed
359         - expandablelist: removed
360
361 * Thu Dec 10 2012 Youmin Ha <youmin.ha@samsung.com> 0.2.2
362 - FIX:
363         - chang searchbar/slider images
364         - delete redundant button images
365 - Spec changes:
366         - Change widget name: shortcutscroll -> fastscroll
367
368 * Thu Dec 07 2012 Youmin Ha <youmin.ha@samsung.com> 0.2.1
369 - FIX:
370         - jqm1.2: Change collapsible style to meet expandable list
371         - remove jquery-geo-1.0.a4
372         - unit-test: rename from imageslider to gallery
373         - nocontent: add warning message
374         - Handler: Fix issues in jqm1.2
375         - Multimediaview: modify APIs & comments
376         - Mapview: Fix issues in jqm1.2
377         - JQM: clean up patches
378         - Swipelist: refactoring swipelist
379         - Popup,Ctxpopup: Apply tizen style popup in JQM1.2
380         - rearrange button's data-icon resources
381 - Spec changes:
382         - Virtualgrid: remove option ('data-itemcount')
383         - gallery: rename the widget from imageslider to gallery
384         - add new style for searchbar
385         [tokentextarea] multi-button entry renamed as token text area. API & comments modified.
386
387 * Thu Dec 06 2012 Minkyu Kang <mk7.kang@samsung.com> 0.2.0
388 - FIX:
389         - fix jslint error
390         - remove unused files
391         - change naviframe style
392 - Spec changes:
393         - applied jQuery Mobile 1.2.0
394         - remove optionheader
395
396 * Fri Nov 30 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.64
397 - FIX:
398         - fix unit tests
399         - remove unused theme files
400         - timepicker: text position fix
401         - scrollview: set dragstop when mouse is out of window
402         - listview: fix margin
403 - Spec changes:
404         - support data-framework-viewport-width
405
406 * Fri Nov 23 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.63
407 - FIX:
408         - dayselector: fix size
409         - remove unised styles
410         - divider: set non-press effect to default option
411         - popupwindow: fix window closing failure
412         - handler: GUI implementation
413         - TC: fix unit TCs
414         - scrollview: fix padding size
415 - Spec changes:
416         - Remove color widgets
417         - add $.tizen.pkgVersion for SDK
418 - Etc.
419         - JSDuck documents
420
421 * Fri Nov 16 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.62
422 - FIX:
423         - Many winsets: Fix layout
424         - Footer: fix position to bottom
425 - Spec changes:
426         - Remove color widgets
427
428 * Fri Nov 09 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.61
429 - FIX:
430         - Many widgets: New UX 0.6 theme implementation
431         - widgetex: init speed up
432         - scrollview: fix scrollbar and scale animation
433         - scrollview: fix scroll position when updatelayout is triggered
434         - header/footer: make textselection disable, except input type="text"
435
436 * Wed Nov 07 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.60
437 - FIX:
438         - Remove tizen-black theme package description
439
440 * Tue Nov 06 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.59
441 - FIX:
442         - Fix theme name to meet the change of system theme name: white->tizen
443         - Popupwindow: fix left position
444         - Remove black theme
445         - footer: remove label, legend drawing
446 - Spec changes:
447         - UX guide v0.4 : button, layout
448
449 * Wed Oct 24 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.57
450 - FIX:
451         - expandablelist: icon color fix
452         - scrollview: Fix xy scroll
453         - footer: Remove dummy div
454         - Make string concatnation effective in inline-protos.sh
455 - Spec changes:
456         - refresh header/footer when drag&drop event is fired in GUI builder
457         - searchbar: delete cancel button
458         - don't trigger updatelayout event when keyup event comes
459
460 * Mon Oct 15 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.56
461 - FIX:
462         - Toggleswitch: Change event name from 'changed' to 'change'
463         - Notification: Revert interval feature
464
465 * Tue Oct 09 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.55
466 - FIX:
467         - Fix SMACK manifest bug (S1-9098)
468
469 * Fri Oct 05 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.54
470 - FIX:
471         - handler: don't append a handler if handler is not enabled
472         - scrollview: use static value
473         - datetimepicker: fix date-format HH display error
474 - ETC:
475         - provide jquery.min.js
476         - barlayout: codes clean
477         - remove unused file
478
479 * Wed Sep 26 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.53
480 - FIX:
481         - listview: change focused color
482         - multibuttonentry: code refactoring
483         - datetimepicker: modify date format when triggered date-changed event
484         - slider: fix the top of slider bar
485         - add event blocker when load a first page
486
487 * Fri Sep 21 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.52
488 - ETC.
489         - Move SMACK manifest files to the top SRCDIR
490
491 * Fri Sep 21 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.51
492 - FIX:
493         - Popup: Do not focus container
494         - Header: show backbutton when both tabbar and header are present together
495         - Multi button entry: text ellipsis, code refactoring
496
497 * Fri Sep 21 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.50
498 - ETC.
499         - Apply SMACK manifest
500
501 * Thu Sep 20 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.49
502 - FIX:
503         - JSLINT code clean-up
504         - scrollview: firefox support
505         - scrollview: fix finding slider handle
506         - list: tweak text ellipsis
507         - checkbox: fix selecting wrong label tag (N_SE-8370)
508         - imageslider: check parameter
509         - smallpopup: fix position
510         - searchbar: fix 'clear' button size
511 - Spec changes:
512         - scrollview: support outer scroll
513         - JQM: block click event only with the element that does preventdefault on vclick(N_SE-6090)
514         - remove S/W IME control
515
516 * Thu Sep 13 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.48
517 - FIX:
518         - Add missing icon: controlbar
519         - scrollview: tune scrolling animatio ninterval
520         - datetimepicker: digit/triangle position
521         - datetimepicker: fix day overflow issue
522 - Spec changes:
523         - scrollview: show scrollbar when page is showed
524         - scrollview: disable outer scroll
525         - extendablelist: change api with legacy support
526         - add ui-text-ellipsis class
527
528 * Mon Sep 10 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.47
529 - FIX:
530         - scrollveiw: fix height of view
531         - searchbar: support placeholder
532 - Spec changes:
533         - add ui-text-ellipsis class
534
535 * Fri Sep 07 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.46
536 - FIX:
537         - scrollview: scrolling bug fix
538         - controlbar: fix width of controlbar item
539 - Spec changes:
540         - searchbar: don't hide icon
541         - popup: update JQM poup widget
542
543 * Fri Sep 05 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.45
544 - FIX:
545         - controlbar: set correct controlbar width of last element
546         - slider: get popup enable value correctly
547         - use Date.now() instead of (new Data()).getTime()
548         - popupwindow: fix the background color of popup scroller
549         - listview: add padding-left to expandable list
550         - add ellipsis for title area support
551
552 * Fri Aug 31 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.44
553 - FIX:
554         - swipelist: show list items correctly
555         - datetimepicker: set last day, if day is overflowed
556 - Spec changes:
557         - controlbar: update icons
558
559 * Tue Aug 29 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.43
560 - FIX:
561         - notification: fix typo
562 - Spec changes:
563         - controlbar: update icons
564
565 * Tue Aug 28 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.42
566 - FIX:
567         - multimediaview: video progress bar display normally for too samll
568         - segmentcontrol: remove media query
569         - scrollview: add outer scroll condition
570         - datetimepicker: modify triangle size
571         - popupwindow: set the screen height explicitly
572         - notification: add multiline text
573 - Spec changes:
574         - mutibuttonentry: support new GUI
575         - virtualgrid: support new GUI
576
577 * Mon Aug 27 2012 Jinhyuk Jun <jinhyuk.jun@samsung.com> 0.1.41
578 - FIX:
579         - radio/check button : button size bug fix
580
581 * Fri Aug 24 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.40
582 - FIX:
583         - build error fixed
584
585 * Fri Aug 24 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.39
586 - FIX:
587         - listview: style fix, remove filter placeholder
588         - controlbar: divide styles
589         - scrollview: don't skip dragging when click button or inputbox
590         - slider: trim the text on text slider
591 - Spec changes:
592         - remove gray and blue theme
593         - add white and black theme
594         - support new GUI guide
595
596 * Mon Aug 20 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.38
597 - FIX:
598         - fix coment of version tag
599
600 * Fri Aug 17 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.37
601 - FIX :
602         - button: fix alignment
603         - listview: adjust the main text width
604         - virtualgrid: refactoring
605 - Spec changes:
606         - transition: support JQM 1.1.0 transitions
607         - scrollview: support the outer scroll
608         - notification: remove interval feature
609
610 * Tue Aug 14 2012 Youmin Ha <youmin.ha@samasung.com> 0.1.36
611 - FIX :
612         - checkboxRadio: Add left/right padding
613         - button: custom button & icon position
614         - virtuallist: remove 'recreate' test
615 - Spec changes:
616         - header/footer: enable/disable support
617
618 * Fri Aug 10 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.35
619 - FIX :
620         - expandablelist: modify show animation
621         - virtualgrid: Redesign programming interface
622         - popupwindow: code clean and fixed issues
623         - pagelayout: fix content height
624         - license file update
625         - virtuallist: Change programming interface
626         - datetimepicker: getting days correctly
627         - searchbar: set to hidden when cancel button is hide
628         - White theme title font tuning
629 - Spec changes:
630         - default theme tizen-gray to tizen-white
631         - set default page transition to none
632
633 * Mon Aug 02 2012 Jinhyuk Jun <jinhyuk.jun@samsung.com> 0.1.34
634 - FIX :
635         - Back Button : enlarge backbutton click size for white theme
636 - Feature :
637         - Expandable List : Add refresh api
638 * Mon Aug 02 2012 Jinhyuk Jun <jinhyuk.jun@samsung.com> 0.1.33
639 - FIX :
640         - click event touch threshold tuning
641
642 * Mon Aug 02 2012 Jinhyuk Jun <jinhyuk.jun@samsung.com> 0.1.32
643 - FIX : 
644         - Add back button highlight effect for white theme
645
646 * Mon Aug 01 2012 Jinhyuk Jun <jinhyuk.jun@samsnug.com> 0.1.31
647 - FIX : 
648         - IME checkroutine update, improve relayout on resize event
649         - Add highlight effect for radio button list 
650         - Scrollview : fix condition of updatelayout event
651 - Feature : progressing : add show/hide api
652
653 * Mon Jul 27 2012 Koeun Choi <koeun.choi@samsung.com> 0.1.30
654 - FIX : virtuallist, virtualgrid: Clean up temporary jquery.template object to clear cache
655         add default theme option on buttonMarkup for tizen theme
656         [searchbar] first fix : focus/blur fixed
657         back button does not work when long press
658         scrollview: don't auto scrolling if resizing area is too large
659 - Feature : notification : add api to set the icon at tickernoti
660         demo : update the list sample demo
661         Support tizen default theme
662
663 * Mon Jul 23 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.29
664 - Improvements & Bugfixes
665    - HOTFIX: Revert template function with jquery.template
666
667 * Thu Jul 19 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.28
668 - Improvements & Bugfixes
669    - Fix #WEB-1028: memory leak on virtuallist/virtualgrid
670 - Spec changes
671    - $.tizen.loadTheme() function accepts theme name as arguement
672    - Scrollview supports 'updatelayout' callback
673
674 * Tue Jul 17 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.27
675 - Improvements & Bugfixes
676    - Revert 'preventing long-press popup' patch, to fix backbutton to work in SocialMagazine
677
678 * Tue Jul 17 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.26
679 - Improvements & Bugfixes
680    - Add tizen-white theme package, to make rpm build to be finished
681
682 * Tue Jul 17 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.25
683 - Improvements & Bugfixes
684    - Set 'slide' as default page transition effect, by JQM patch
685
686 * Fri Jul 13 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.24
687 - Improvements & Bugfixes
688    - Fix IME show/hide algorithm
689    - Fix error on virtualgrid: link _set_scrollbar_size() function to the one in virtuallist
690
691 * Wed Jul 11 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.23
692 - Improvements & Bugfixes
693    - Fix notification position
694    - Fix unit tests
695
696  Fri Jul 6 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.22
697 - Spec changes
698         - JQM 1.1 upgrade
699 - Improvements & Bugfixes
700         - Transform3D support on scrollview
701         - Page layout supports IME control
702         - Mapview supports pinch zoom on JQM 1.1
703         - Fix wrong character on button in minified version
704         - Virtualgrid supports scrollbar
705         - Lots of bugfixes
706
707 * Fri Jun 22 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.20
708 - Spec changes
709         - Support 'latest' version (by symlink) for tizen-web-ui-fw.js path.
710         - imageslider : supports 'resize' event.
711         - listview : listview has 1px padding-bottom.
712         - loader : Change global namespace, from S to $.tizen.
713         - loader : Move loadCustomGlobalizeCulture() into $.tizen.util namespace.
714 - Improvements & Bugfixes
715         - Scrollview : supports 'translate3d', instead of 'translate'.
716         - notification : reset timer when 'show' or 'refresh' event.
717         - JQM patch : Fix vclick event triggered twice.
718 - Etc.
719         - Add & fix unit tests.
720
721 * Thu Jun 14 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.19
722 - Spec changes
723         - mapview : new widget.
724         - notification : add .refresh() API.
725         - pagecontrol : add .value([val]) API, and change an attribute name 'data-initVal' to 'data-value'.
726 - Improvements & Bugfixes
727         - Support minified CSS.
728         - loader : Fix & refactor 'loading globalize culture file' routine.
729         - JQM Patch : Calculate min-height of window in javascript code, and remove predefined min-height value from CSS.
730         - Many more bugfixes.
731 - Etc.
732         - Add many unit tests.
733         - Fix test coverage instrumentation tool to work with current source code.