0.2.9 release
[platform/framework/web/web-ui-fw.git] / packaging / web-ui-fw.spec
1 Name:       web-ui-fw
2 Version:    0.2.9
3 Release:    0
4 Summary:    Tizen Web UI Framework Library
5 Group:      Development/Other
6 License:    MIT
7 BuildArch:  noarch
8 BuildRequires:  make
9 BuildRequires:  nodejs
10 %ifarch %{arm}
11 BuildRequires:  nodejs-x86-arm
12 %endif
13
14 Source0:    %{name}-%{version}.tar.gz
15
16 %description
17 Tizen Web UI Framework library and theme packages
18
19 %prep
20 %setup -q
21
22 %build
23 make all
24
25 %install
26 make DESTDIR=%{buildroot} install
27
28 %post
29
30 %files
31 %manifest web-ui-fw.manifest
32 /usr/share/tizen-web-ui-fw/*/js
33 /usr/share/tizen-web-ui-fw/latest
34 /usr/share/tizen-web-ui-fw/VERSION
35
36 ###############################
37 %package -n web-ui-fw-theme-tizen-gray
38 BuildArch:  noarch
39 Summary:    Tizen Web UI Framework Theme : tizen-gray
40 %Description -n web-ui-fw-theme-tizen-gray
41     Tizen Web UI Framework Theme : tizen-gray
42
43 ###############################
44 %package -n web-ui-fw-theme-tizen-white
45 BuildArch:  noarch
46 Summary:    Tizen Web UI Framework Theme : tizen-white
47 %Description -n web-ui-fw-theme-tizen-white
48     Tizen Web UI Framework Theme : tizen-white
49 %files -n web-ui-fw-theme-tizen-white
50 %manifest web-ui-fw-theme-tizen-white.manifest
51 /usr/share/tizen-web-ui-fw/*/themes/tizen-white
52 /usr/share/tizen-web-ui-fw/*/themes/tizen-tizen
53
54 ###############################
55 %package -n web-ui-fw-theme-default
56 BuildArch:  noarch
57 Summary:    Tizen Web UI Framework Theme : default
58 %Description -n web-ui-fw-theme-default
59     Tizen Web UI Framework Theme : default
60 %files -n web-ui-fw-theme-default
61 %manifest web-ui-fw-theme-default.manifest
62 /usr/share/tizen-web-ui-fw/*/themes/default
63
64 ###############################
65 %package -n web-ui-fw-devel
66 BuildArch:  noarch
67 Summary:    Tizen Web UI Framework Developer's files
68 %Description -n web-ui-fw-devel
69     Tizen Web UI Framework Developer's files
70 %files -n web-ui-fw-devel
71 /usr/share/tizen-web-ui-fw/bin
72 /usr/share/tizen-web-ui-fw/template
73
74 ###############################
75 %package -n web-ui-fw-demo-tizen-winsets
76 BuildArch:  noarch
77 Summary:    Tizen Web UI Framework Demo Application: tizen winset demo
78 %Description -n web-ui-fw-demo-tizen-winsets
79     Tizen Web UI Framework Demo Application: tizen winset demo
80 %files  -n web-ui-fw-demo-tizen-winsets
81 /usr/share/tizen-web-ui-fw/demos/tizen-winsets
82
83
84 ###############################
85 %changelog
86
87 * Tue Jan 17 2013 Minkyu Kang <mk7.kang@samsung.com> 0.2.9
88         - gallery: use timeout function instead of interval
89         - Tokentextarea: Display error fixed.
90         - scrollview: Fix not selector to respond with jQuery1.8.2
91         - tabbar: remove the width of last element
92         - Demo: apply css 'user-select:none'
93         - Button: guide text has been shorten
94         - build: Update jQuery to 1.8.2 (JQM1.2 compliant)
95         - virtuallist: Fix mistyping
96         - demo: Fix tizen function namespace in demo
97         - virtuallist: Rewrite listitem replacing algorithm
98         - fastscroll: modify from not selector to function
99         - extendablelist: Fix unit-test
100         - tabbar : prefix to tabbar scroll event
101         - Popupwindow: removed unvalid selector in jquery 1.8.2
102         - slider: adjust handle text as length of value
103         - Demo: 3 buttons in popup text has been changed
104         - src: codes cleanup
105         - demo : remove trailing empty strings
106         - demo : rename TizenWinset list items
107         - button : change from long text list to multiline list
108         - build: Remove JQM1.1.0 patches
109         - Popup: Apply tizen style popup and attribute support
110         - JQM: Fix buttonmarkup bug keeping ui-btn-down class
111         - UnitTest: folder and file renamed, QUnit path was modified
112         - tizen-winsets: button: fix textarea width
113         - Swipe: event name error has been fixed
114
115 * Tue Jan 15 2013 Minkyu Kang <mk7.kang@samsung.com> 0.2.8
116         - Button: button padding has been updated
117         - virtuallist: fix unique listitem ID bug
118         - checkbox, radio : change display attr
119         - Button: bug fix ( when data style circle button on text )
120         - handler: bug fix (when scrolling with multi selection)
121         - JQM: adjust patch number
122         - gallery: show the widget after pageshow
123         - TokenTextArea : resource add ( press image )
124         - gallery: adds function that set the index to value API
125         - configure: set TIZEN default configures
126         - footer: h tag display attribute value has been changed
127         - buttons : demo bug fix
128         - searchbar : demo page bug fix
129         - tizen demo : bug fix
130         - build: remove JQM1.1.0
131         - Tokentextarea: Fix issues
132         - scrollview: block the multi touch
133         - list : dialogue list demo change
134         - pagelayout : update dynamic control
135         - Demo: Context popup close method has been changed
136
137 * Fri Jan 11 2013 Minkyu Kang <mk7.kang@samsung.com> 0.2.7
138         - slider: set text container's width as text length
139         - Timepicker: li max-width has been changed
140         - remove experimental feature - mapview.
141         - scrollview: added conditions for finding slider
142         - UnitTC: Pass,error count save method has been changed
143         - confix.xml: default config added for tizen basic applications
144         - Swipe: p tag margin value is set '0'
145         - packaging: remove unused file
146         - tabbar : bug fix
147         - list demo : bug fix
148         - tizen-winsets: gallery: move to new section
149         - tizen-winsets: autodivider: removes link of list
150         - demos: entry of number-pattern name is changed from 'number' to 'number-pattern'
151         - pagelayout : padding calculate change, ime footer check changed
152         - tizen-winsets: searchbar: scroll to the top when type the character
153         - searchbar : bug fix
154         - demo: Fix virtuallist demo following new list style
155         - demo: Add word-wrap:break-word and remove parag. width
156         - Demo: button max-width has been set( 3 buttons in popup )
157         - back button control demo : bug fix
158         - toggleswitch : demo page modify
159         - slider: add margin-top and margin-bottom
160         - tabbar demo : bug fix
161         - Popup: IME hide when popup is closed
162         - token textarea : bug fix
163         - Timepicker: change get attribute method
164         - footer demo : bug fix
165         - unit-test: gallery: add new APIs
166         - gallery: adds support new APIs
167
168 * Fri Jan 04 2013 Minkyu Kang <mk7.kang@samsung.com> 0.2.6
169         - JQM: patches cleanup
170         - Button: data-corners attribute has been added
171         - unit-test: slider: fix class name of background
172         - progressbar, slider: fix less variable typo
173         - Tabbar : VI update
174         - notification: add top position at fix class
175         - demo: entry demo page change
176         - css: .ui-disabled added
177         - tizen-winset: token textarea: remove back button at demo page
178         - theme: Remove unused less file
179         - pagelayout : content min height bug fix
180         - scrollview: skip the dragging when target is slider's handle
181         - scrollview: update and refactoring the scroll effect
182         - UnitTest:JQM Unit TC helper has been added,TCs have been modified
183         - Swipe: demo page html error has been fixed
184         - listview: Add add/delete animation (VI)
185         - Popup: demo page has been modified
186         - tizen demo : bug fix
187         - searchbar : demo page change(change front button and add behaviour)
188         - pagelayout : add min height to content
189         - gallery: rename 'Image Slider' to 'Gallery' in tizen-winsets demo and tests
190         - back button control demo : change url link to data-rel="back"
191         - loader: Skip loading theme CSS with a custom css code
192         - Button: support no-text in button
193         - collapsible: Fix syntax error
194         - slider: use data-highlight attribute
195         - collapsible: Rotate animation to collapsible heading icon
196         - toggleswitch : text switch bug fix
197         - remove candidates-calendarpicker
198         - Patch: Fix misc mistakes in JQM patches
199         - searchbar : animation change
200         - gallery: get the width correctly
201         - demo: data-framework-viewport-scale attribute is changed to data-framework-viewport-width
202         - collapsible: Add collapse/expand animation (VI)
203         - datetimepicker: VI update
204         - JQM: set transition to pop as default
205         - tabbar : bug fix in case none li element case
206         - scrollview: fix the drag bug
207         - Button: Button icon scrolltop, left has beed added
208         - Swipe: VI update and swipe speed has been changed
209         - jqm: fix errors in patch files
210         - unit-test: swipe: fixed the destroy test
211
212 * Wed Dec 26 2012 Youmin Ha <youmin.ha@samsung.com> 0.2.5
213         - Revert "[checkboxradio] exception handling for input"
214                 This reverts commit 72478c32704fa96362db577e6cf9511777919ea8.
215                 Tizen style supports no-label radio and checkbox when making lists.
216                 So it ignores html input operation. Instead, it supports tizen style radio and checkbox theme.
217
218 * Thu Dec 20 2012 Youmin Ha <youmin.ha@samsung.com> 0.2.4
219 - Fix:
220         - modify segment background
221         - rearrange check, radio input
222         - CtxPopup: Scale up/ down popup vi(poptop, popbottom)
223         - button: style has beed added(box,circle,nobg,round)
224         - favorite resource added
225         - demo/tizen-winsets: add footer and back button
226         - remove autodividers unit test
227         - add divider for tabbar
228         - checkboxradio: exception handling for input
229         - segment control backward compatiblity
230         - Fix collapsible unit-test
231         - remove toggleswitch
232         - add patch for remove segment text
233 - Spec changes:
234         - replace controlbar to tabbar
235
236 * Fri Dec 14 2012 Minkyu Kang <mk7.kang@samsung.com> 0.2.3
237 - FIX:
238         - slider: add image
239         - button: data-icon support, styles fix
240         - progressbar: modify the background
241         - scrollview: auto scrolling bug fix
242         - pagelayout: IME concept is changed
243 - Spec changes:
244         - dialogue: add edit mode
245         - nocontents: removed
246         - pagecontrol: removed
247         - dayselector: removed
248         - expandablelist: removed
249
250 * Thu Dec 10 2012 Youmin Ha <youmin.ha@samsung.com> 0.2.2
251 - FIX:
252         - chang searchbar/slider images
253         - delete redundant button images
254 - Spec changes:
255         - Change widget name: shortcutscroll -> fastscroll
256
257 * Thu Dec 07 2012 Youmin Ha <youmin.ha@samsung.com> 0.2.1
258 - FIX:
259         - jqm1.2: Change collapsible style to meet expandable list
260         - remove jquery-geo-1.0.a4
261         - unit-test: rename from imageslider to gallery
262         - nocontent: add warning message
263         - Handler: Fix issues in jqm1.2
264         - Multimediaview: modify APIs & comments
265         - Mapview: Fix issues in jqm1.2
266         - JQM: clean up patches
267         - Swipelist: refactoring swipelist
268         - Popup,Ctxpopup: Apply tizen style popup in JQM1.2
269         - rearrange button's data-icon resources
270 - Spec changes:
271         - Virtualgrid: remove option ('data-itemcount')
272         - gallery: rename the widget from imageslider to gallery
273         - add new style for searchbar
274         [tokentextarea] multi-button entry renamed as token text area. API & comments modified.
275
276 * Thu Dec 06 2012 Minkyu Kang <mk7.kang@samsung.com> 0.2.0
277 - FIX:
278         - fix jslint error
279         - remove unused files
280         - change naviframe style
281 - Spec changes:
282         - applied jQuery Mobile 1.2.0
283         - remove optionheader
284
285 * Fri Nov 30 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.64
286 - FIX:
287         - fix unit tests
288         - remove unused theme files
289         - timepicker: text position fix
290         - scrollview: set dragstop when mouse is out of window
291         - listview: fix margin
292 - Spec changes:
293         - support data-framework-viewport-width
294
295 * Fri Nov 23 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.63
296 - FIX:
297         - dayselector: fix size
298         - remove unised styles
299         - divider: set non-press effect to default option
300         - popupwindow: fix window closing failure
301         - handler: GUI implementation
302         - TC: fix unit TCs
303         - scrollview: fix padding size
304 - Spec changes:
305         - Remove color widgets
306         - add $.tizen.pkgVersion for SDK
307 - Etc.
308         - JSDuck documents
309
310 * Fri Nov 16 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.62
311 - FIX:
312         - Many winsets: Fix layout
313         - Footer: fix position to bottom
314 - Spec changes:
315         - Remove color widgets
316
317 * Fri Nov 09 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.61
318 - FIX:
319         - Many widgets: New UX 0.6 theme implementation
320         - widgetex: init speed up
321         - scrollview: fix scrollbar and scale animation
322         - scrollview: fix scroll position when updatelayout is triggered
323         - header/footer: make textselection disable, except input type="text"
324
325 * Wed Nov 07 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.60
326 - FIX:
327         - Remove tizen-black theme package description
328
329 * Tue Nov 06 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.59
330 - FIX:
331         - Fix theme name to meet the change of system theme name: white->tizen
332         - Popupwindow: fix left position
333         - Remove black theme
334         - footer: remove label, legend drawing
335 - Spec changes:
336         - UX guide v0.4 : button, layout
337
338 * Wed Oct 24 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.57
339 - FIX:
340         - expandablelist: icon color fix
341         - scrollview: Fix xy scroll
342         - footer: Remove dummy div
343         - Make string concatnation effective in inline-protos.sh
344 - Spec changes:
345         - refresh header/footer when drag&drop event is fired in GUI builder
346         - searchbar: delete cancel button
347         - don't trigger updatelayout event when keyup event comes
348
349 * Mon Oct 15 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.56
350 - FIX:
351         - Toggleswitch: Change event name from 'changed' to 'change'
352         - Notification: Revert interval feature
353
354 * Tue Oct 09 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.55
355 - FIX:
356         - Fix SMACK manifest bug (S1-9098)
357
358 * Fri Oct 05 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.54
359 - FIX:
360         - handler: don't append a handler if handler is not enabled
361         - scrollview: use static value
362         - datetimepicker: fix date-format HH display error
363 - ETC:
364         - provide jquery.min.js
365         - barlayout: codes clean
366         - remove unused file
367
368 * Wed Sep 26 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.53
369 - FIX:
370         - listview: change focused color
371         - multibuttonentry: code refactoring
372         - datetimepicker: modify date format when triggered date-changed event
373         - slider: fix the top of slider bar
374         - add event blocker when load a first page
375
376 * Fri Sep 21 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.52
377 - ETC.
378         - Move SMACK manifest files to the top SRCDIR
379
380 * Fri Sep 21 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.51
381 - FIX:
382         - Popup: Do not focus container
383         - Header: show backbutton when both tabbar and header are present together
384         - Multi button entry: text ellipsis, code refactoring
385
386 * Fri Sep 21 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.50
387 - ETC.
388         - Apply SMACK manifest
389
390 * Thu Sep 20 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.49
391 - FIX:
392         - JSLINT code clean-up
393         - scrollview: firefox support
394         - scrollview: fix finding slider handle
395         - list: tweak text ellipsis
396         - checkbox: fix selecting wrong label tag (N_SE-8370)
397         - imageslider: check parameter
398         - smallpopup: fix position
399         - searchbar: fix 'clear' button size
400 - Spec changes:
401         - scrollview: support outer scroll
402         - JQM: block click event only with the element that does preventdefault on vclick(N_SE-6090)
403         - remove S/W IME control
404
405 * Thu Sep 13 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.48
406 - FIX:
407         - Add missing icon: controlbar
408         - scrollview: tune scrolling animatio ninterval
409         - datetimepicker: digit/triangle position
410         - datetimepicker: fix day overflow issue
411 - Spec changes:
412         - scrollview: show scrollbar when page is showed
413         - scrollview: disable outer scroll
414         - extendablelist: change api with legacy support
415         - add ui-text-ellipsis class
416
417 * Mon Sep 10 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.47
418 - FIX:
419         - scrollveiw: fix height of view
420         - searchbar: support placeholder
421 - Spec changes:
422         - add ui-text-ellipsis class
423
424 * Fri Sep 07 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.46
425 - FIX:
426         - scrollview: scrolling bug fix
427         - controlbar: fix width of controlbar item
428 - Spec changes:
429         - searchbar: don't hide icon
430         - popup: update JQM poup widget
431
432 * Fri Sep 05 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.45
433 - FIX:
434         - controlbar: set correct controlbar width of last element
435         - slider: get popup enable value correctly
436         - use Date.now() instead of (new Data()).getTime()
437         - popupwindow: fix the background color of popup scroller
438         - listview: add padding-left to expandable list
439         - add ellipsis for title area support
440
441 * Fri Aug 31 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.44
442 - FIX:
443         - swipelist: show list items correctly
444         - datetimepicker: set last day, if day is overflowed
445 - Spec changes:
446         - controlbar: update icons
447
448 * Tue Aug 29 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.43
449 - FIX:
450         - notification: fix typo
451 - Spec changes:
452         - controlbar: update icons
453
454 * Tue Aug 28 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.42
455 - FIX:
456         - multimediaview: video progress bar display normally for too samll
457         - segmentcontrol: remove media query
458         - scrollview: add outer scroll condition
459         - datetimepicker: modify triangle size
460         - popupwindow: set the screen height explicitly
461         - notification: add multiline text
462 - Spec changes:
463         - mutibuttonentry: support new GUI
464         - virtualgrid: support new GUI
465
466 * Mon Aug 27 2012 Jinhyuk Jun <jinhyuk.jun@samsung.com> 0.1.41
467 - FIX:
468         - radio/check button : button size bug fix
469
470 * Fri Aug 24 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.40
471 - FIX:
472         - build error fixed
473
474 * Fri Aug 24 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.39
475 - FIX:
476         - listview: style fix, remove filter placeholder
477         - controlbar: divide styles
478         - scrollview: don't skip dragging when click button or inputbox
479         - slider: trim the text on text slider
480 - Spec changes:
481         - remove gray and blue theme
482         - add white and black theme
483         - support new GUI guide
484
485 * Mon Aug 20 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.38
486 - FIX:
487         - fix coment of version tag
488
489 * Fri Aug 17 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.37
490 - FIX :
491         - button: fix alignment
492         - listview: adjust the main text width
493         - virtualgrid: refactoring
494 - Spec changes:
495         - transition: support JQM 1.1.0 transitions
496         - scrollview: support the outer scroll
497         - notification: remove interval feature
498
499 * Tue Aug 14 2012 Youmin Ha <youmin.ha@samasung.com> 0.1.36
500 - FIX :
501         - checkboxRadio: Add left/right padding
502         - button: custom button & icon position
503         - virtuallist: remove 'recreate' test
504 - Spec changes:
505         - header/footer: enable/disable support
506
507 * Fri Aug 10 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.35
508 - FIX :
509         - expandablelist: modify show animation
510         - virtualgrid: Redesign programming interface
511         - popupwindow: code clean and fixed issues
512         - pagelayout: fix content height
513         - license file update
514         - virtuallist: Change programming interface
515         - datetimepicker: getting days correctly
516         - searchbar: set to hidden when cancel button is hide
517         - White theme title font tuning
518 - Spec changes:
519         - default theme tizen-gray to tizen-white
520         - set default page transition to none
521
522 * Mon Aug 02 2012 Jinhyuk Jun <jinhyuk.jun@samsung.com> 0.1.34
523 - FIX :
524         - Back Button : enlarge backbutton click size for white theme
525 - Feature :
526         - Expandable List : Add refresh api
527 * Mon Aug 02 2012 Jinhyuk Jun <jinhyuk.jun@samsung.com> 0.1.33
528 - FIX :
529         - click event touch threshold tuning
530
531 * Mon Aug 02 2012 Jinhyuk Jun <jinhyuk.jun@samsung.com> 0.1.32
532 - FIX : 
533         - Add back button highlight effect for white theme
534
535 * Mon Aug 01 2012 Jinhyuk Jun <jinhyuk.jun@samsnug.com> 0.1.31
536 - FIX : 
537         - IME checkroutine update, improve relayout on resize event
538         - Add highlight effect for radio button list 
539         - Scrollview : fix condition of updatelayout event
540 - Feature : progressing : add show/hide api
541
542 * Mon Jul 27 2012 Koeun Choi <koeun.choi@samsung.com> 0.1.30
543 - FIX : virtuallist, virtualgrid: Clean up temporary jquery.template object to clear cache
544         add default theme option on buttonMarkup for tizen theme
545         [searchbar] first fix : focus/blur fixed
546         back button does not work when long press
547         scrollview: don't auto scrolling if resizing area is too large
548 - Feature : notification : add api to set the icon at tickernoti
549         demo : update the list sample demo
550         Support tizen default theme
551
552 * Mon Jul 23 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.29
553 - Improvements & Bugfixes
554    - HOTFIX: Revert template function with jquery.template
555
556 * Thu Jul 19 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.28
557 - Improvements & Bugfixes
558    - Fix #WEB-1028: memory leak on virtuallist/virtualgrid
559 - Spec changes
560    - $.tizen.loadTheme() function accepts theme name as arguement
561    - Scrollview supports 'updatelayout' callback
562
563 * Tue Jul 17 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.27
564 - Improvements & Bugfixes
565    - Revert 'preventing long-press popup' patch, to fix backbutton to work in SocialMagazine
566
567 * Tue Jul 17 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.26
568 - Improvements & Bugfixes
569    - Add tizen-white theme package, to make rpm build to be finished
570
571 * Tue Jul 17 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.25
572 - Improvements & Bugfixes
573    - Set 'slide' as default page transition effect, by JQM patch
574
575 * Fri Jul 13 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.24
576 - Improvements & Bugfixes
577    - Fix IME show/hide algorithm
578    - Fix error on virtualgrid: link _set_scrollbar_size() function to the one in virtuallist
579
580 * Wed Jul 11 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.23
581 - Improvements & Bugfixes
582    - Fix notification position
583    - Fix unit tests
584
585  Fri Jul 6 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.22
586 - Spec changes
587         - JQM 1.1 upgrade
588 - Improvements & Bugfixes
589         - Transform3D support on scrollview
590         - Page layout supports IME control
591         - Mapview supports pinch zoom on JQM 1.1
592         - Fix wrong character on button in minified version
593         - Virtualgrid supports scrollbar
594         - Lots of bugfixes
595
596 * Fri Jun 22 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.20
597 - Spec changes
598         - Support 'latest' version (by symlink) for tizen-web-ui-fw.js path.
599         - imageslider : supports 'resize' event.
600         - listview : listview has 1px padding-bottom.
601         - loader : Change global namespace, from S to $.tizen.
602         - loader : Move loadCustomGlobalizeCulture() into $.tizen.util namespace.
603 - Improvements & Bugfixes
604         - Scrollview : supports 'translate3d', instead of 'translate'.
605         - notification : reset timer when 'show' or 'refresh' event.
606         - JQM patch : Fix vclick event triggered twice.
607 - Etc.
608         - Add & fix unit tests.
609
610 * Thu Jun 14 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.19
611 - Spec changes
612         - mapview : new widget.
613         - notification : add .refresh() API.
614         - pagecontrol : add .value([val]) API, and change an attribute name 'data-initVal' to 'data-value'.
615 - Improvements & Bugfixes
616         - Support minified CSS.
617         - loader : Fix & refactor 'loading globalize culture file' routine.
618         - JQM Patch : Calculate min-height of window in javascript code, and remove predefined min-height value from CSS.
619         - Many more bugfixes.
620 - Etc.
621         - Add many unit tests.
622         - Fix test coverage instrumentation tool to work with current source code.