Merge branch 'master' into tizen_2.1
[platform/framework/web/web-ui-fw.git] / packaging / web-ui-fw.spec
1 Name:       web-ui-fw
2 Version:    0.2.26
3 Release:    0
4 Summary:    Tizen Web UI Framework Library
5 Group:      Development/Other
6 License:    MIT
7 BuildArch:  noarch
8 BuildRequires:  make
9 BuildRequires:  nodejs
10 %ifarch %{arm}
11 BuildRequires:  nodejs-x86-arm
12 %endif
13
14 Source0:    %{name}-%{version}.tar.gz
15
16 %description
17 Tizen Web UI Framework library and theme packages
18
19 %prep
20 %setup -q
21
22 %build
23 make all
24
25 %install
26 make DESTDIR=%{buildroot} install
27
28 %post
29
30 %files
31 %manifest web-ui-fw.manifest
32 /usr/share/tizen-web-ui-fw/*/js/*.js
33 /usr/share/tizen-web-ui-fw/*/js/cultures
34 /usr/share/tizen-web-ui-fw/latest
35 /usr/share/tizen-web-ui-fw/VERSION
36
37 ###############################
38 %package -n web-ui-fw-theme-tizen-gray
39 BuildArch:  noarch
40 Summary:    Tizen Web UI Framework Theme : tizen-gray
41 %Description -n web-ui-fw-theme-tizen-gray
42     Tizen Web UI Framework Theme : tizen-gray
43     Deprecated package, but some binaries still refer this.
44
45 ###############################
46 %package -n web-ui-fw-theme-tizen-white
47 BuildArch:  noarch
48 Summary:    Tizen Web UI Framework Theme : tizen-white
49 %Description -n web-ui-fw-theme-tizen-white
50     Tizen Web UI Framework Theme : tizen-white
51 %files -n web-ui-fw-theme-tizen-white
52 %manifest web-ui-fw-theme-tizen-white.manifest
53 /usr/share/tizen-web-ui-fw/*/themes/tizen-white
54 /usr/share/tizen-web-ui-fw/*/themes/tizen-tizen
55
56 ###############################
57 %package -n web-ui-fw-theme-tizen-black
58 BuildArch:  noarch
59 Summary:    Tizen Web UI Framework Theme : tizen-black
60 %Description -n web-ui-fw-theme-tizen-black
61     Tizen Web UI Framework Theme : tizen-black
62 %files -n web-ui-fw-theme-tizen-black
63 %manifest web-ui-fw-theme-tizen-black.manifest
64 /usr/share/tizen-web-ui-fw/*/themes/tizen-black
65
66 ###############################
67 %package -n web-ui-fw-theme-default
68 BuildArch:  noarch
69 Summary:    Tizen Web UI Framework Theme : default
70 %Description -n web-ui-fw-theme-default
71     Tizen Web UI Framework Theme : default
72 %files -n web-ui-fw-theme-default
73 %manifest web-ui-fw-theme-default.manifest
74 /usr/share/tizen-web-ui-fw/*/themes/default
75
76 ###############################
77 %package -n web-ui-fw-devel
78 BuildArch:  noarch
79 Summary:    Tizen Web UI Framework Developer's files
80 %Description -n web-ui-fw-devel
81     Tizen Web UI Framework Developer's files
82 %files -n web-ui-fw-devel
83 /usr/share/tizen-web-ui-fw/bin
84 /usr/share/tizen-web-ui-fw/template
85 /usr/share/tizen-web-ui-fw/*/js/src
86 /usr/share/tizen-web-ui-fw/*/js/depData.json
87
88 ###############################
89 %package -n web-ui-fw-demo-tizen-winsets
90 BuildArch:  noarch
91 Summary:    Tizen Web UI Framework Demo Application: tizen winset demo
92 %Description -n web-ui-fw-demo-tizen-winsets
93     Tizen Web UI Framework Demo Application: tizen winset demo
94 %files  -n web-ui-fw-demo-tizen-winsets
95 /usr/share/tizen-web-ui-fw/demos/tizen-winsets
96
97
98 ###############################
99 %changelog
100 * Fri Apr 26 2013 Youmin Ha <youmin.ha@samsung.com> 0.2.26
101         - PageLayout : bug fix
102         - Gallery3d: Change timing of 'gl-matrix' library's execution
103         - Replace in LoadTheme function strings build with array join with the string concat
104         - Contextpopup: context popup reposition module has been added
105         - Pagelayout : skip to calculate min-height using data-scroll="none"(Issue: DCM-1453)
106         - Splitview: Fix the touchend event error.
107         - Gallery3d: Change event registration method from $.bind() to $.on()
108         - Scrollview : remove useless setTimeout in case scrolls go outside
109         - Naviframe : adjust new SIP down button
110         - Timepicker: Added return false; after vclick
111         - Popupwindow: reserved words has been removed
112         - minor changes: replace one occurrence of array.join with string concat and simplify jQuery arguments
113         - TizenWinset : set default margin for checkbox demo
114         - Tizenwinset: Context popup demo has been changed
115         - TizenDemo : add initial orientation mode to popup demo
116         - Widgets: removed parsing error for legacy javascript engine
117         - Delegate init of popup widget with delegateSelfInitWithSingleSelector
118
119 * Tue Apr 18 2013 Youmin Ha <youmin.ha@samsung.com> 0.2.25
120         - Pinch: pinch event re-implementation to use size
121         - Pagelayout : prevent code inserting window.innerHeight when content calculate
122         - BlachTheme : add missing icon (SIP down)
123         - Scrollview : support absolute position
124         - tizen-winsets: change the font-family in virtualgrid demo to default
125         - TizenWinset : Change default font
126         - tizen-winsets: Change image link
127         - tizenwinset: change images for virtual grid pages
128
129 * Tue Apr 16 2013 Youmin Ha <youmin.ha@samsung.com> 0.2.24
130         - SegmentControl: 2-buttons display issue (N_SE-34200)
131         - Naviframe : remove unnecessary img positioning(N_SE-33969)
132         - Gallery: jslint error fix
133         - TizenWinset : remove landscape SIP on mode
134         - Tizen Black Theme png file changed
135         - Gallery: Images showing bug has been fixed
136         - Scrollview : change horizontal scrollview demo(N_SE-33997)
137         - Tizenwinset: added return false in popup sample
138         - Naviframe : support data-role="button" in header
139         - Additional UnitTC: tizen winset unit tc bugs have been fixed
140         - Checkbox : remove favorite button's display:block(N_SE-33896)
141         - UnitTC: QUnit path has been changed. Priority, function type check function has been added
142         - Tizen-winset : Footer changed from lower case to upper case.
143         - Slider: enhance performance fix
144         - UnitTC: Addtional unit tc ref path has been fixed
145         - virtualgrid: apply overscrolling images to the style of widget
146         - Tabbar : Change overscroll image(left/right)
147         - ensurens: optimizations
148         - ensurens: qunit tests
149         - Tokentextarea: Fix block size error
150         - Fastscroll: Add a feature to fade out Fastscroll widget.
151         - Fastscroll: Add a user interaction at the omitted items.
152         - ImageLoader: Performance fix: apply lazy loading for canvas element
153         - Tests: Add tests for $.imageloader
154         - SegmentControl: 2-buttons display issue (N_SE-34200)
155         - virtuallist: fix width resizing trigger
156         - Timepicker: timepicker is closed when orientationchange event fired
157         - TizenWinset : Tabbar-persist issue.(N_SE-33996)
158         - Add Flora license
159         - collapsible: Fix collapsible list animation bug
160
161 * Wed Apr 10 2013 Youmin Ha <youmin.ha@samsung.com> 0.2.23
162         - Naviframe : modify SIP down button's position
163         - Core: Performance fix for disableSelection and enableSelection
164         - Tests: Core tests for disableSelection
165         - patch: fix small mistakes on the patches
166         - virtuallist: Change demo button style
167         - Button: btn-icon only css has been changed
168         - loader: Fix screen-width option processing
169         - pagelayout: Remember back key when it is hidden
170         - Tizen Black Theme : Tizen black theme png file changed.
171         - UnitTC: tizen winset unit tc bugs have been fixed
172         - TizenWinset: Swipe list sample has been fixed
173         - Radio : remove default radio's width(N_SE-33579)
174         - Scrollview : divide x/y overflow attribute
175         - Gallery: orientation image showing issue has been fixed
176         - Gallery: remove method bug has been fixed
177         - virtualgrid : fix unit-test error and increase test items
178         - Gallery3d: Modify demo & source codes for visibility enhancement.
179         - Gallery3d: Reduce loading time of widget
180         - Gallery3d: Change files' format to unix
181         - Contextpopup: context popup close when window resize event fire
182         - Popup: reverse orientation bug has been fixed
183         - Tokentextarea: modify description
184         - Multimediaview: modify description
185         - JQM: Do not add ui-btn-icon-only class at the select button
186         - build: tizen-black theme package
187         - Tizenwinset: popup script has been removed
188         - Tizenwinset: substring split view text message
189         - Timepicker: data-changed event will be deprecated
190
191 * Fri Apr 5 2013 Youmin Ha <youmin.ha@samsung.com> 0.2.22
192         - tizen-winsets: Fix demo menu
193         - Tizenwinset: Reorder tizenwinset menu
194         - SearchBar: Header button size issue has been fixed
195         - Swipe: list item overflow: hidden has been added
196         - Tizenwinset: href has been added in grouped list
197         - Tizenwinset: Page transition page has been added
198         - Tizenwinset: Radio description has been fixed
199         - This patch fixes problem when base url is changed when site is prefetched.
200         - Entry : limit textarea's width (N_SE-28653)
201         - Naviframe : hide backbutton in case SIP up(remove backbutton makes problem in binding event)
202         - Gallery : next, prev images position bug has been fixed
203         - Multimediaview: Fix display error while handling orientationchange event.
204         - Pagelayout : modify innerHeight dpr calculation in non scrollview mode
205         - Datetimepicker: picker position has been fixed when browser resize event fired
206         - Tips: generate elements sample page javascript has been fixed
207         - Tokentextarea: Fix Tizen-winsets demo.
208
209 * Wed Apr 3 2013 Youmin Ha <youmin.ha@samsung.com> 0.2.21
210         - VirtualGrid: Fix errors on centerTo and resize methods
211         - loader: Fix default font size at device-width viewport
212         - scrollview : remove overflow-x property
213         - Naviframe : fix backbutton position/ change down button icon
214         - Naviframe : bug fix
215         - Tizenwinset : Tizen-winset demo page titles changed Tizen-winset demo page titles changed from lower case to upper case.
216
217 * Fri Mar 29 2013 Youmin Ha <youmin.ha@samsung.com> 0.2.20
218         - JQM Navigation : remove page min-height
219         - Pagelayout : add refresh to pagelayout
220         - Tokentextarea: Changes 'remove' tests to asyncTest
221         - Popup: input tag alignment has been fixed
222         - Tokentextarea: add/remove events are deprecated.
223         - Contextpopup: Support horizontal list
224         - Select: icon z-index has been deleted
225         - Tizenwinset: ui widget order has been changed
226         - Tool: make web app template disable context menu by default
227         - Tizen-winset: change tips for using listview
228         - Loader: calculate font size with mobile width
229         - Naviframe : fix header's back button position
230         - TizenWinset : move locale info to another file
231
232 * Fri Mar 22 2013 Youmin Ha <youmin.ha@samsung.com> 0.2.19
233         - Tizen-winset: Support accessibility for tizen-winset
234         - Orientation : add orientataionchange to tizen-winset
235         - Tokentextarea: Adjusts VI effect for add/remove block
236         - splitview: Support accessibility for splitview
237         - Tizen-winset: Date/time picker guide text has been fixed
238         - Popup: context popup arrow position, setTimeout open method bug have been fixed
239         - fastscroll: Add new indexString API to Fastscroll widget.
240         - splitview: Add new widget
241         - gallery3d: Add new widget
242         - Scrollview : disable VI effect for gesture event
243         - Scrollview : disable SIP outerscroll
244         - Tizen-winset: resize VirtualGrid widget in demo
245         - Tizen-winsets: Refactor searchbar subpages
246         - Tizen-winsets: Remove depracated usage of virtuallist
247         - Tizen-winsets: Move js code from main.js to subpages
248         - Tizen-winsets: Refactor virtual grid demo subpages
249         - Tizen-winsets: Move css files from index to proper subpages
250         - Tizen-winsets: Refactor list dialogue edit subpage
251         - Tizen-winsets: Refactor pagelayout subpages
252         - Tizen-winsets: Refactor tips subpages
253         - Tizen-winsets: Move subpages popup files from index.html
254         - Tizen-winsets: Move subpages javascript files from index.html
255         - virtualgrid: fix improperly merged codes
256         - ColorTheme : remove unused color value(1st)
257         - Scrollview : change scrollbar draw
258         - Popup: Apply popup background dim
259         - Tizen-winsets: Move tokentextarea demo to external page.
260         - Tizen-winsets: Move tabbar persist demo to external page.
261         - Tizen-winsets: Remove notImplemented page
262         - Tizen-winsets: Move slider demo page to external subpage
263         - Tizen-winsets: Fix ids, remove duplicated names for sliders
264         - Tizen-winsets: Remove event for changing theme
265         - tool: Fix wgt sample app generator tool to make apps be installed
266         - demos : change live to on
267         - build: Trim compiled CSS files
268         - Gallery: CSS left -> translate or translate3D
269         - Tokentextarea: Disfunctional APIs fixed.
270
271 * Thu Mar 7 2013 Youmin Ha <youmin.ha@samsung.com> 0.2.18
272         - build: Fix Makefile to add globalize to the minified lib
273         - build-tools : upgrade less to v1.3.3
274         - demos : change normal js path to minified js
275         - Theme : remove reduantant less - dayselector, optionheader, nocontents
276         - multimediaview : fix full-screen mode.
277         - multimediaview : fix 'width', 'height' and 'fullScreen' methods
278         - Extendablelist: Added min-height "load more button" in listitem
279         - virtualgrid: adjusts VI effect for an overflow action
280         - ControlGroup : change ellipsis font color (press/normal)
281         - multimediaview: Add an error message to Multimediaview
282         - virtualgrid: adjusts triple flick gesture
283         - scrollview: add function for getting width of view
284         - scrollview: adds support x axis gesture scroll
285         - multimediaview : fix audio control
286         - tabbar : tabbar slide animation change
287         - TizenWinsetDemo : 2line-text demo bug fix
288         - collapsible: Fix demo to show radio button correctly in the collapsible list
289         - collapsible: Set listitem position to relative
290         - UnitTC: added list divider unit test
291         - Style: unnecessary color codes have been deleted and modified
292         - build: Module build implementation
293         - UnitTC: Additional unit testcases have been added
294         - listview : bug fix
295         - Naviframe : remove back button's hover effect
296         - TizenDemo : remove back button
297         - Transition: added more-button vi
298         - pinch: added new event called pinch
299         - Popup: css word-wrap:break-word has been added
300         - virtualgrid: memory leak fix
301         - progress: set to init state at pending bar
302         - progress: add margin of top/bottom
303         - unit-test: split progress test and progressbar test
304         - Tizen-winset: Context popup sample page guide text has been changed
305         - multimediaview: fix the height of widget when full-screen mode
306         - JQM: performance tuning
307
308 * Tue Feb 19 2013 Minkyu Kang <mk7.kang@samsung.com> 0.2.17
309         - DialogueList : delete border top value / add sample's text ellipsis
310         - Tokentextarea: Add scroll-to-top for Grouping On/Off regarding #N_SE-24877
311         - Multimediaview: Fix mute function
312         - Tizen-winset: list vi index guide textbox has been removed
313         - Tizen-winset: custom button texts have been changed
314         - slider: move popup div to out of content
315         - TizenWinset: disable context popup in multimediaview
316         - Swipe: wrong style name has been fixed
317         - demo: add the sample at dialogue list
318         - listview: Add ui-li-has-right-btn class with toggleswitch
319         - WinsetDemo : change wrong title name
320
321 * Mon Jan 28 2013 Youmin Ha <youmin.ha@samsung.com> 0.2.16
322         - demo: checkbox: reduce button's width
323         - tabbar : delete right/left tab animation color
324         - scrollview: fix the scroll position at keydown event
325         - groupControl : change footer groupControl from min-width to percentage
326         - scrollview: get height of softkeyboard correctly
327         - tizen-winset: Add name attr to all radio inputs
328         - virtualgrid: changes event binding target
329         - scrollview: skip the drag if target is textarea
330         - scrollview: skip the dragging of parent scrollview
331         - scrollview: apply the scaling ratio to the soft keyboard
332         - demos: apply disabled option in textarea
333         - demo: remove unused codes
334         - demo: datetimepicker: show selected date correctly
335         - listview: Adjust bubble listitem width and margin
336         - pagelayout : change external refresh call and ime status follow only current page
337         - toggleSwitch : bug fix
338         - unit-test: slider: fix the move test
339         - handler: fix jslint error
340         - ToggleSwitch : set image toggleswitch background attribute
341
342 * Mon Jan 28 2013 Youmin Ha <youmin.ha@samsung.com> 0.2.15
343         - slider: increase the text width(N_SE-23397)
344         - virtualgrid: DOM element leak fix
345         - header: Move button top higher in header with tabbar(N_SE-22253)
346         - datatimepicker: don't open the popup before popupafterclose event is fired(N_SE-23027)
347         - handler: bug fix (regarding enableHandler function )
348         - demo:fix syntax error
349
350 * Sat Jan 26 2013 Youmin Ha <youmin.ha@samsung.com> 0.2.14
351         - demo: fix demo using tizen device API
352         - multimediaview: reset the height of container
353         - input: modify css correctly
354         - multimediaview: fix the height of widget
355         - gallery: bind create event
356         - progress: bind create event
357         - slider: bind create event
358         - progressbar: bind create event
359         - progressbar: event trigger correctly
360         - popup: fix height of popup scroller
361         - build: add continue option to jslint
362         - ctxpopup demo : bug fix
363         - demo: fix searchbar demo to use different IDs
364         - demo: extract routine executing Tizen device API
365         - toggleswitch : set default margin, delete box padding
366
367 * Thu Jan 24 2013 Youmin Ha <youmin.ha@samsung.com> 0.2.13
368         - virtuallist: Prevent replacing contents on nonexist element
369         - JQM: Trim text in listitem to get index in autodivider
370         - JQM: Remove trailing whitespace in jqm patch
371         - scrollview: get the height including margin
372         - multimediaview: bug fix ( scrolling in full-screen mode )
373         - virtuallist: set listitem width to exclude listitem left/right margin
374         - demo: fix virtuallist sample layout
375         - progress: set the position explicitly
376         - progress: rename from progressing to progress
377         - build: remove unused files
378         - searchbar: fix jslint errors
379         - src: fix file permissions
380         - button : change jump left icon
381
382 * Wed Jan 23 2013 Minkyu Kang <mk7.kang@samsung.com> 0.2.12
383         - theme : button icon - scrolltop, scrolleft icon changed.
384         - build: cleanaup Makefile
385         - pagelayout: fix jslint error
386         - virtualgrid: Fix jslint errors
387         - tabbar : jslint bug error fix
388         - build: add regexp option to jslint
389         - virtuallist: fix jslint errors
390         - handler: Apply the exceptional principle for scrollbar on Handler.
391         - build: remove unused copyright
392         - loader: extract log class for tizen web, and fix jslint errors
393         - loader: Viewport width is set to document width
394         - popupwindow: fix jslint error
395         - build: fix Makefile for tizen-white theme
396         - build: remove unused libraries
397         - datetimepicker: fix jslint error
398         - slider: fix jslint error
399         - demo: remove deprecated demos
400         - pagelayout : change to call relayout with this page
401         - Tokentextarea: Block size error fixed.
402         - handler: bug fix (handler activation)
403
404 * Tue Jan 22 2013 Minkyu Kang <mk7.kang@samsung.com> 0.2.11
405         - demo: clear input text value with cancel button click
406         - demo: Adjust textarea height automatically
407         - naviframe : bug fix
408         - tabbar : bug fix
409         - Fastscroll: popup position has been changed
410         - Button: custom button icon path, margin have been changed
411         - toggleswitch : bug fix
412         - slider: increase the margin
413         - datetimepicker: close the popup after select the value
414         - unit-test : add page backbutton control test
415         - Demo: added guide text and change input type in list vi
416         - remove legacy codes : jquery-geo
417         - Datetimepicker: text-main max-width has been removed
418         - Radio: control group border has been removed
419         - Demo: remove 'tab' space
420         - UnitTC: swipe unit tc has been fixed
421         - UnitTC: jQuery path has been fixed
422         - Button: bug fix when button has not a text
423         - tizen-winset: timepicker: demo title is changed
424
425 * Fri Jan 18 2013 Minkyu Kang <mk7.kang@samsung.com> 0.2.10
426         - tizen-winsets: codes cleanup
427         - datetimepicker: date calibration when year is changed
428         - Demo: textarea size has been changed
429         - Demo: Naviframe morebutton demo has been changed
430         - remove unused unit test cases : gallery3d
431         - tizen-winset: remove links
432
433 * Thu Jan 17 2013 Minkyu Kang <mk7.kang@samsung.com> 0.2.9
434         - gallery: use timeout function instead of interval
435         - Tokentextarea: Display error fixed.
436         - scrollview: Fix not selector to respond with jQuery1.8.2
437         - tabbar: remove the width of last element
438         - Demo: apply css 'user-select:none'
439         - Button: guide text has been shorten
440         - build: Update jQuery to 1.8.2 (JQM1.2 compliant)
441         - virtuallist: Fix mistyping
442         - demo: Fix tizen function namespace in demo
443         - virtuallist: Rewrite listitem replacing algorithm
444         - fastscroll: modify from not selector to function
445         - extendablelist: Fix unit-test
446         - tabbar : prefix to tabbar scroll event
447         - Popupwindow: removed unvalid selector in jquery 1.8.2
448         - slider: adjust handle text as length of value
449         - Demo: 3 buttons in popup text has been changed
450         - src: codes cleanup
451         - demo : remove trailing empty strings
452         - demo : rename TizenWinset list items
453         - button : change from long text list to multiline list
454         - build: Remove JQM1.1.0 patches
455         - Popup: Apply tizen style popup and attribute support
456         - JQM: Fix buttonmarkup bug keeping ui-btn-down class
457         - UnitTest: folder and file renamed, QUnit path was modified
458         - tizen-winsets: button: fix textarea width
459         - Swipe: event name error has been fixed
460
461 * Tue Jan 15 2013 Minkyu Kang <mk7.kang@samsung.com> 0.2.8
462         - Button: button padding has been updated
463         - virtuallist: fix unique listitem ID bug
464         - checkbox, radio : change display attr
465         - Button: bug fix ( when data style circle button on text )
466         - handler: bug fix (when scrolling with multi selection)
467         - JQM: adjust patch number
468         - gallery: show the widget after pageshow
469         - TokenTextArea : resource add ( press image )
470         - gallery: adds function that set the index to value API
471         - configure: set TIZEN default configures
472         - footer: h tag display attribute value has been changed
473         - buttons : demo bug fix
474         - searchbar : demo page bug fix
475         - tizen demo : bug fix
476         - build: remove JQM1.1.0
477         - Tokentextarea: Fix issues
478         - scrollview: block the multi touch
479         - list : dialogue list demo change
480         - pagelayout : update dynamic control
481         - Demo: Context popup close method has been changed
482
483 * Fri Jan 11 2013 Minkyu Kang <mk7.kang@samsung.com> 0.2.7
484         - slider: set text container's width as text length
485         - Timepicker: li max-width has been changed
486         - remove experimental feature - mapview.
487         - scrollview: added conditions for finding slider
488         - UnitTC: Pass,error count save method has been changed
489         - confix.xml: default config added for tizen basic applications
490         - Swipe: p tag margin value is set '0'
491         - packaging: remove unused file
492         - tabbar : bug fix
493         - list demo : bug fix
494         - tizen-winsets: gallery: move to new section
495         - tizen-winsets: autodivider: removes link of list
496         - demos: entry of number-pattern name is changed from 'number' to 'number-pattern'
497         - pagelayout : padding calculate change, ime footer check changed
498         - tizen-winsets: searchbar: scroll to the top when type the character
499         - searchbar : bug fix
500         - demo: Fix virtuallist demo following new list style
501         - demo: Add word-wrap:break-word and remove parag. width
502         - Demo: button max-width has been set( 3 buttons in popup )
503         - back button control demo : bug fix
504         - toggleswitch : demo page modify
505         - slider: add margin-top and margin-bottom
506         - tabbar demo : bug fix
507         - Popup: IME hide when popup is closed
508         - token textarea : bug fix
509         - Timepicker: change get attribute method
510         - footer demo : bug fix
511         - unit-test: gallery: add new APIs
512         - gallery: adds support new APIs
513
514 * Fri Jan 04 2013 Minkyu Kang <mk7.kang@samsung.com> 0.2.6
515         - JQM: patches cleanup
516         - Button: data-corners attribute has been added
517         - unit-test: slider: fix class name of background
518         - progressbar, slider: fix less variable typo
519         - Tabbar : VI update
520         - notification: add top position at fix class
521         - demo: entry demo page change
522         - css: .ui-disabled added
523         - tizen-winset: token textarea: remove back button at demo page
524         - theme: Remove unused less file
525         - pagelayout : content min height bug fix
526         - scrollview: skip the dragging when target is slider's handle
527         - scrollview: update and refactoring the scroll effect
528         - UnitTest:JQM Unit TC helper has been added,TCs have been modified
529         - Swipe: demo page html error has been fixed
530         - listview: Add add/delete animation (VI)
531         - Popup: demo page has been modified
532         - tizen demo : bug fix
533         - searchbar : demo page change(change front button and add behaviour)
534         - pagelayout : add min height to content
535         - gallery: rename 'Image Slider' to 'Gallery' in tizen-winsets demo and tests
536         - back button control demo : change url link to data-rel="back"
537         - loader: Skip loading theme CSS with a custom css code
538         - Button: support no-text in button
539         - collapsible: Fix syntax error
540         - slider: use data-highlight attribute
541         - collapsible: Rotate animation to collapsible heading icon
542         - toggleswitch : text switch bug fix
543         - remove candidates-calendarpicker
544         - Patch: Fix misc mistakes in JQM patches
545         - searchbar : animation change
546         - gallery: get the width correctly
547         - demo: data-framework-viewport-scale attribute is changed to data-framework-viewport-width
548         - collapsible: Add collapse/expand animation (VI)
549         - datetimepicker: VI update
550         - JQM: set transition to pop as default
551         - tabbar : bug fix in case none li element case
552         - scrollview: fix the drag bug
553         - Button: Button icon scrolltop, left has beed added
554         - Swipe: VI update and swipe speed has been changed
555         - jqm: fix errors in patch files
556         - unit-test: swipe: fixed the destroy test
557
558 * Wed Dec 26 2012 Youmin Ha <youmin.ha@samsung.com> 0.2.5
559         - Revert "[checkboxradio] exception handling for input"
560                 This reverts commit 72478c32704fa96362db577e6cf9511777919ea8.
561                 Tizen style supports no-label radio and checkbox when making lists.
562                 So it ignores html input operation. Instead, it supports tizen style radio and checkbox theme.
563
564 * Thu Dec 20 2012 Youmin Ha <youmin.ha@samsung.com> 0.2.4
565 - Fix:
566         - modify segment background
567         - rearrange check, radio input
568         - CtxPopup: Scale up/ down popup vi(poptop, popbottom)
569         - button: style has beed added(box,circle,nobg,round)
570         - favorite resource added
571         - demo/tizen-winsets: add footer and back button
572         - remove autodividers unit test
573         - add divider for tabbar
574         - checkboxradio: exception handling for input
575         - segment control backward compatiblity
576         - Fix collapsible unit-test
577         - remove toggleswitch
578         - add patch for remove segment text
579 - Spec changes:
580         - replace controlbar to tabbar
581
582 * Fri Dec 14 2012 Minkyu Kang <mk7.kang@samsung.com> 0.2.3
583 - FIX:
584         - slider: add image
585         - button: data-icon support, styles fix
586         - progressbar: modify the background
587         - scrollview: auto scrolling bug fix
588         - pagelayout: IME concept is changed
589 - Spec changes:
590         - dialogue: add edit mode
591         - nocontents: removed
592         - pagecontrol: removed
593         - dayselector: removed
594         - expandablelist: removed
595
596 * Thu Dec 10 2012 Youmin Ha <youmin.ha@samsung.com> 0.2.2
597 - FIX:
598         - chang searchbar/slider images
599         - delete redundant button images
600 - Spec changes:
601         - Change widget name: shortcutscroll -> fastscroll
602
603 * Thu Dec 07 2012 Youmin Ha <youmin.ha@samsung.com> 0.2.1
604 - FIX:
605         - jqm1.2: Change collapsible style to meet expandable list
606         - remove jquery-geo-1.0.a4
607         - unit-test: rename from imageslider to gallery
608         - nocontent: add warning message
609         - Handler: Fix issues in jqm1.2
610         - Multimediaview: modify APIs & comments
611         - Mapview: Fix issues in jqm1.2
612         - JQM: clean up patches
613         - Swipelist: refactoring swipelist
614         - Popup,Ctxpopup: Apply tizen style popup in JQM1.2
615         - rearrange button's data-icon resources
616 - Spec changes:
617         - Virtualgrid: remove option ('data-itemcount')
618         - gallery: rename the widget from imageslider to gallery
619         - add new style for searchbar
620         [tokentextarea] multi-button entry renamed as token text area. API & comments modified.
621
622 * Thu Dec 06 2012 Minkyu Kang <mk7.kang@samsung.com> 0.2.0
623 - FIX:
624         - fix jslint error
625         - remove unused files
626         - change naviframe style
627 - Spec changes:
628         - applied jQuery Mobile 1.2.0
629         - remove optionheader
630
631 * Fri Nov 30 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.64
632 - FIX:
633         - fix unit tests
634         - remove unused theme files
635         - timepicker: text position fix
636         - scrollview: set dragstop when mouse is out of window
637         - listview: fix margin
638 - Spec changes:
639         - support data-framework-viewport-width
640
641 * Fri Nov 23 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.63
642 - FIX:
643         - dayselector: fix size
644         - remove unised styles
645         - divider: set non-press effect to default option
646         - popupwindow: fix window closing failure
647         - handler: GUI implementation
648         - TC: fix unit TCs
649         - scrollview: fix padding size
650 - Spec changes:
651         - Remove color widgets
652         - add $.tizen.pkgVersion for SDK
653 - Etc.
654         - JSDuck documents
655
656 * Fri Nov 16 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.62
657 - FIX:
658         - Many winsets: Fix layout
659         - Footer: fix position to bottom
660 - Spec changes:
661         - Remove color widgets
662
663 * Fri Nov 09 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.61
664 - FIX:
665         - Many widgets: New UX 0.6 theme implementation
666         - widgetex: init speed up
667         - scrollview: fix scrollbar and scale animation
668         - scrollview: fix scroll position when updatelayout is triggered
669         - header/footer: make textselection disable, except input type="text"
670
671 * Wed Nov 07 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.60
672 - FIX:
673         - Remove tizen-black theme package description
674
675 * Tue Nov 06 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.59
676 - FIX:
677         - Fix theme name to meet the change of system theme name: white->tizen
678         - Popupwindow: fix left position
679         - Remove black theme
680         - footer: remove label, legend drawing
681 - Spec changes:
682         - UX guide v0.4 : button, layout
683
684 * Fri Oct 26 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.58
685 - FIX:
686         - scrollview: Fix outer scroll amount
687         - tabbar: fix tapping twice
688         - popupwindow: fix left position
689
690 * Wed Oct 24 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.57
691 - FIX:
692         - expandablelist: icon color fix
693         - scrollview: Fix xy scroll
694         - footer: Remove dummy div
695         - Make string concatnation effective in inline-protos.sh
696 - Spec changes:
697         - refresh header/footer when drag&drop event is fired in GUI builder
698         - searchbar: delete cancel button
699         - don't trigger updatelayout event when keyup event comes
700
701 * Mon Oct 15 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.56
702 - FIX:
703         - Toggleswitch: Change event name from 'changed' to 'change'
704         - Notification: Revert interval feature
705
706 * Tue Oct 09 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.55
707 - FIX:
708         - Fix SMACK manifest bug (S1-9098)
709
710 * Fri Oct 05 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.54
711 - FIX:
712         - handler: don't append a handler if handler is not enabled
713         - scrollview: use static value
714         - datetimepicker: fix date-format HH display error
715 - ETC:
716         - provide jquery.min.js
717         - barlayout: codes clean
718         - remove unused file
719
720 * Wed Sep 26 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.53
721 - FIX:
722         - listview: change focused color
723         - multibuttonentry: code refactoring
724         - datetimepicker: modify date format when triggered date-changed event
725         - slider: fix the top of slider bar
726         - add event blocker when load a first page
727
728 * Fri Sep 21 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.52
729 - ETC.
730         - Move SMACK manifest files to the top SRCDIR
731
732 * Fri Sep 21 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.51
733 - FIX:
734         - Popup: Do not focus container
735         - Header: show backbutton when both tabbar and header are present together
736         - Multi button entry: text ellipsis, code refactoring
737
738 * Fri Sep 21 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.50
739 - ETC.
740         - Apply SMACK manifest
741
742 * Thu Sep 20 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.49
743 - FIX:
744         - JSLINT code clean-up
745         - scrollview: firefox support
746         - scrollview: fix finding slider handle
747         - list: tweak text ellipsis
748         - checkbox: fix selecting wrong label tag (N_SE-8370)
749         - imageslider: check parameter
750         - smallpopup: fix position
751         - searchbar: fix 'clear' button size
752 - Spec changes:
753         - scrollview: support outer scroll
754         - JQM: block click event only with the element that does preventdefault on vclick(N_SE-6090)
755         - remove S/W IME control
756
757 * Thu Sep 13 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.48
758 - FIX:
759         - Add missing icon: controlbar
760         - scrollview: tune scrolling animatio ninterval
761         - datetimepicker: digit/triangle position
762         - datetimepicker: fix day overflow issue
763 - Spec changes:
764         - scrollview: show scrollbar when page is showed
765         - scrollview: disable outer scroll
766         - extendablelist: change api with legacy support
767         - add ui-text-ellipsis class
768
769 * Mon Sep 10 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.47
770 - FIX:
771         - scrollveiw: fix height of view
772         - searchbar: support placeholder
773 - Spec changes:
774         - add ui-text-ellipsis class
775
776 * Fri Sep 07 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.46
777 - FIX:
778         - scrollview: scrolling bug fix
779         - controlbar: fix width of controlbar item
780 - Spec changes:
781         - searchbar: don't hide icon
782         - popup: update JQM poup widget
783
784 * Fri Sep 05 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.45
785 - FIX:
786         - controlbar: set correct controlbar width of last element
787         - slider: get popup enable value correctly
788         - use Date.now() instead of (new Data()).getTime()
789         - popupwindow: fix the background color of popup scroller
790         - listview: add padding-left to expandable list
791         - add ellipsis for title area support
792
793 * Fri Aug 31 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.44
794 - FIX:
795         - swipelist: show list items correctly
796         - datetimepicker: set last day, if day is overflowed
797 - Spec changes:
798         - controlbar: update icons
799
800 * Tue Aug 29 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.43
801 - FIX:
802         - notification: fix typo
803 - Spec changes:
804         - controlbar: update icons
805
806 * Tue Aug 28 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.42
807 - FIX:
808         - multimediaview: video progress bar display normally for too samll
809         - segmentcontrol: remove media query
810         - scrollview: add outer scroll condition
811         - datetimepicker: modify triangle size
812         - popupwindow: set the screen height explicitly
813         - notification: add multiline text
814 - Spec changes:
815         - mutibuttonentry: support new GUI
816         - virtualgrid: support new GUI
817
818 * Mon Aug 27 2012 Jinhyuk Jun <jinhyuk.jun@samsung.com> 0.1.41
819 - FIX:
820         - radio/check button : button size bug fix
821
822 * Fri Aug 24 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.40
823 - FIX:
824         - build error fixed
825
826 * Fri Aug 24 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.39
827 - FIX:
828         - listview: style fix, remove filter placeholder
829         - controlbar: divide styles
830         - scrollview: don't skip dragging when click button or inputbox
831         - slider: trim the text on text slider
832 - Spec changes:
833         - remove gray and blue theme
834         - add white and black theme
835         - support new GUI guide
836
837 * Mon Aug 20 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.38
838 - FIX:
839         - fix coment of version tag
840
841 * Fri Aug 17 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.37
842 - FIX :
843         - button: fix alignment
844         - listview: adjust the main text width
845         - virtualgrid: refactoring
846 - Spec changes:
847         - transition: support JQM 1.1.0 transitions
848         - scrollview: support the outer scroll
849         - notification: remove interval feature
850
851 * Tue Aug 14 2012 Youmin Ha <youmin.ha@samasung.com> 0.1.36
852 - FIX :
853         - checkboxRadio: Add left/right padding
854         - button: custom button & icon position
855         - virtuallist: remove 'recreate' test
856 - Spec changes:
857         - header/footer: enable/disable support
858
859 * Fri Aug 10 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.35
860 - FIX :
861         - expandablelist: modify show animation
862         - virtualgrid: Redesign programming interface
863         - popupwindow: code clean and fixed issues
864         - pagelayout: fix content height
865         - license file update
866         - virtuallist: Change programming interface
867         - datetimepicker: getting days correctly
868         - searchbar: set to hidden when cancel button is hide
869         - White theme title font tuning
870 - Spec changes:
871         - default theme tizen-gray to tizen-white
872         - set default page transition to none
873
874 * Mon Aug 02 2012 Jinhyuk Jun <jinhyuk.jun@samsung.com> 0.1.34
875 - FIX :
876         - Back Button : enlarge backbutton click size for white theme
877 - Feature :
878         - Expandable List : Add refresh api
879 * Mon Aug 02 2012 Jinhyuk Jun <jinhyuk.jun@samsung.com> 0.1.33
880 - FIX :
881         - click event touch threshold tuning
882
883 * Mon Aug 02 2012 Jinhyuk Jun <jinhyuk.jun@samsung.com> 0.1.32
884 - FIX : 
885         - Add back button highlight effect for white theme
886
887 * Mon Aug 01 2012 Jinhyuk Jun <jinhyuk.jun@samsnug.com> 0.1.31
888 - FIX : 
889         - IME checkroutine update, improve relayout on resize event
890         - Add highlight effect for radio button list 
891         - Scrollview : fix condition of updatelayout event
892 - Feature : progressing : add show/hide api
893
894 * Mon Jul 27 2012 Koeun Choi <koeun.choi@samsung.com> 0.1.30
895 - FIX : virtuallist, virtualgrid: Clean up temporary jquery.template object to clear cache
896         add default theme option on buttonMarkup for tizen theme
897         [searchbar] first fix : focus/blur fixed
898         back button does not work when long press
899         scrollview: don't auto scrolling if resizing area is too large
900 - Feature : notification : add api to set the icon at tickernoti
901         demo : update the list sample demo
902         Support tizen default theme
903
904 * Mon Jul 23 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.29
905 - Improvements & Bugfixes
906    - HOTFIX: Revert template function with jquery.template
907
908 * Thu Jul 19 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.28
909 - Improvements & Bugfixes
910    - Fix #WEB-1028: memory leak on virtuallist/virtualgrid
911 - Spec changes
912    - $.tizen.loadTheme() function accepts theme name as arguement
913    - Scrollview supports 'updatelayout' callback
914
915 * Tue Jul 17 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.27
916 - Improvements & Bugfixes
917    - Revert 'preventing long-press popup' patch, to fix backbutton to work in SocialMagazine
918
919 * Tue Jul 17 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.26
920 - Improvements & Bugfixes
921    - Add tizen-white theme package, to make rpm build to be finished
922
923 * Tue Jul 17 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.25
924 - Improvements & Bugfixes
925    - Set 'slide' as default page transition effect, by JQM patch
926
927 * Fri Jul 13 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.24
928 - Improvements & Bugfixes
929    - Fix IME show/hide algorithm
930    - Fix error on virtualgrid: link _set_scrollbar_size() function to the one in virtuallist
931
932 * Wed Jul 11 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.23
933 - Improvements & Bugfixes
934    - Fix notification position
935    - Fix unit tests
936
937  Fri Jul 6 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.22
938 - Spec changes
939         - JQM 1.1 upgrade
940 - Improvements & Bugfixes
941         - Transform3D support on scrollview
942         - Page layout supports IME control
943         - Mapview supports pinch zoom on JQM 1.1
944         - Fix wrong character on button in minified version
945         - Virtualgrid supports scrollbar
946         - Lots of bugfixes
947
948 * Fri Jun 22 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.20
949 - Spec changes
950         - Support 'latest' version (by symlink) for tizen-web-ui-fw.js path.
951         - imageslider : supports 'resize' event.
952         - listview : listview has 1px padding-bottom.
953         - loader : Change global namespace, from S to $.tizen.
954         - loader : Move loadCustomGlobalizeCulture() into $.tizen.util namespace.
955 - Improvements & Bugfixes
956         - Scrollview : supports 'translate3d', instead of 'translate'.
957         - notification : reset timer when 'show' or 'refresh' event.
958         - JQM patch : Fix vclick event triggered twice.
959 - Etc.
960         - Add & fix unit tests.
961
962 * Thu Jun 14 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.19
963 - Spec changes
964         - mapview : new widget.
965         - notification : add .refresh() API.
966         - pagecontrol : add .value([val]) API, and change an attribute name 'data-initVal' to 'data-value'.
967 - Improvements & Bugfixes
968         - Support minified CSS.
969         - loader : Fix & refactor 'loading globalize culture file' routine.
970         - JQM Patch : Calculate min-height of window in javascript code, and remove predefined min-height value from CSS.
971         - Many more bugfixes.
972 - Etc.
973         - Add many unit tests.
974         - Fix test coverage instrumentation tool to work with current source code.