Merge branch 'sdk'
[platform/framework/web/web-ui-fw.git] / packaging / web-ui-fw.spec
1 Name:       web-ui-fw
2 Version:    0.2.2
3 Release:    0
4 Summary:    Tizen Web UI Framework Library
5 Group:      Development/Other
6 License:    MIT
7 BuildArch:  noarch
8 BuildRequires:  make
9 BuildRequires:  nodejs
10 %ifarch %{arm}
11 BuildRequires:  nodejs-x86-arm
12 %endif
13
14 Source0:    %{name}-%{version}.tar.gz
15
16 %description
17 Tizen Web UI Framework library and theme packages
18
19 %prep
20 %setup -q
21
22 %build
23 make all
24
25 %install
26 make DESTDIR=%{buildroot} install
27
28 %post
29
30 %files
31 %manifest web-ui-fw.manifest
32 /usr/share/tizen-web-ui-fw/*/js
33 /usr/share/tizen-web-ui-fw/latest
34
35 ###############################
36 %package -n web-ui-fw-theme-tizen-gray
37 BuildArch:  noarch
38 Summary:    Tizen Web UI Framework Theme : tizen-gray
39 %Description -n web-ui-fw-theme-tizen-gray
40     Tizen Web UI Framework Theme : tizen-gray
41
42 ###############################
43 %package -n web-ui-fw-theme-tizen-white
44 BuildArch:  noarch
45 Summary:    Tizen Web UI Framework Theme : tizen-white
46 %Description -n web-ui-fw-theme-tizen-white
47     Tizen Web UI Framework Theme : tizen-white
48 %files -n web-ui-fw-theme-tizen-white
49 %manifest web-ui-fw-theme-tizen-white.manifest
50 /usr/share/tizen-web-ui-fw/*/themes/tizen-white
51 /usr/share/tizen-web-ui-fw/*/themes/tizen-tizen
52
53 ###############################
54 %package -n web-ui-fw-theme-default
55 BuildArch:  noarch
56 Summary:    Tizen Web UI Framework Theme : default
57 %Description -n web-ui-fw-theme-default
58     Tizen Web UI Framework Theme : default
59 %files -n web-ui-fw-theme-default
60 %manifest web-ui-fw-theme-default.manifest
61 /usr/share/tizen-web-ui-fw/*/themes/default
62
63 ###############################
64 %package -n web-ui-fw-devel
65 BuildArch:  noarch
66 Summary:    Tizen Web UI Framework Developer's files
67 %Description -n web-ui-fw-devel
68     Tizen Web UI Framework Developer's files
69 %files -n web-ui-fw-devel
70 /usr/share/tizen-web-ui-fw/bin
71 /usr/share/tizen-web-ui-fw/template
72
73 ###############################
74 %package -n web-ui-fw-demo-tizen-winsets
75 BuildArch:  noarch
76 Summary:    Tizen Web UI Framework Demo Application: tizen winset demo
77 %Description -n web-ui-fw-demo-tizen-winsets
78     Tizen Web UI Framework Demo Application: tizen winset demo
79 %files  -n web-ui-fw-demo-tizen-winsets
80 /usr/share/tizen-web-ui-fw/demos/tizen-winsets
81
82
83 ###############################
84 %changelog
85 * Thu Dec 10 2012 Youmin Ha <youmin.ha@samsung.com> 0.2.2
86 - FIX:
87         - chang searchbar/slider images
88         - delete redundant button images
89 - Spec changes:
90         - Change widget name: shortcutscroll -> fastscroll
91
92 * Thu Dec 07 2012 Youmin Ha <youmin.ha@samsung.com> 0.2.1
93 - FIX:
94         - jqm1.2: Change collapsible style to meet expandable list
95         - remove jquery-geo-1.0.a4
96         - unit-test: rename from imageslider to gallery
97         - nocontent: add warning message
98         - Handler: Fix issues in jqm1.2
99         - Multimediaview: modify APIs & comments
100         - Mapview: Fix issues in jqm1.2
101         - JQM: clean up patches
102         - Swipelist: refactoring swipelist
103         - Popup,Ctxpopup: Apply tizen style popup in JQM1.2
104         - rearrange button's data-icon resources
105 - Spec changes:
106         - Virtualgrid: remove option ('data-itemcount')
107         - gallery: rename the widget from imageslider to gallery
108         - add new style for searchbar
109         [tokentextarea] multi-button entry renamed as token text area. API & comments modified.
110
111 * Thu Dec 06 2012 Minkyu Kang <mk7.kang@samsung.com> 0.2.0
112 - FIX:
113         - fix jslint error
114         - remove unused files
115         - change naviframe style
116 - Spec changes:
117         - applied jQuery Mobile 1.2.0
118         - remove optionheader
119
120 * Fri Nov 30 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.64
121 - FIX:
122         - fix unit tests
123         - remove unused theme files
124         - timepicker: text position fix
125         - scrollview: set dragstop when mouse is out of window
126         - listview: fix margin
127 - Spec changes:
128         - support data-framework-viewport-width
129
130 * Fri Nov 23 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.63
131 - FIX:
132         - dayselector: fix size
133         - remove unised styles
134         - divider: set non-press effect to default option
135         - popupwindow: fix window closing failure
136         - handler: GUI implementation
137         - TC: fix unit TCs
138         - scrollview: fix padding size
139 - Spec changes:
140         - Remove color widgets
141         - add $.tizen.pkgVersion for SDK
142 - Etc.
143         - JSDuck documents
144
145 * Fri Nov 16 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.62
146 - FIX:
147         - Many winsets: Fix layout
148         - Footer: fix position to bottom
149 - Spec changes:
150         - Remove color widgets
151
152 * Fri Nov 09 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.61
153 - FIX:
154         - Many widgets: New UX 0.6 theme implementation
155         - widgetex: init speed up
156         - scrollview: fix scrollbar and scale animation
157         - scrollview: fix scroll position when updatelayout is triggered
158         - header/footer: make textselection disable, except input type="text"
159
160 * Wed Nov 07 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.60
161 - FIX:
162         - Remove tizen-black theme package description
163
164 * Tue Nov 06 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.59
165 - FIX:
166         - Fix theme name to meet the change of system theme name: white->tizen
167         - Popupwindow: fix left position
168         - Remove black theme
169         - footer: remove label, legend drawing
170 - Spec changes:
171         - UX guide v0.4 : button, layout
172
173 * Fri Oct 26 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.58
174 - FIX:
175         - scrollview: Fix outer scroll amount
176         - tabbar: fix tapping twice
177         - popupwindow: fix left position
178
179 * Wed Oct 24 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.57
180 - FIX:
181         - expandablelist: icon color fix
182         - scrollview: Fix xy scroll
183         - footer: Remove dummy div
184         - Make string concatnation effective in inline-protos.sh
185 - Spec changes:
186         - refresh header/footer when drag&drop event is fired in GUI builder
187         - searchbar: delete cancel button
188         - don't trigger updatelayout event when keyup event comes
189
190 * Mon Oct 15 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.56
191 - FIX:
192         - Toggleswitch: Change event name from 'changed' to 'change'
193         - Notification: Revert interval feature
194
195 * Tue Oct 09 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.55
196 - FIX:
197         - Fix SMACK manifest bug (S1-9098)
198
199 * Fri Oct 05 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.54
200 - FIX:
201         - handler: don't append a handler if handler is not enabled
202         - scrollview: use static value
203         - datetimepicker: fix date-format HH display error
204 - ETC:
205         - provide jquery.min.js
206         - barlayout: codes clean
207         - remove unused file
208
209 * Wed Sep 26 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.53
210 - FIX:
211         - listview: change focused color
212         - multibuttonentry: code refactoring
213         - datetimepicker: modify date format when triggered date-changed event
214         - slider: fix the top of slider bar
215         - add event blocker when load a first page
216
217 * Fri Sep 21 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.52
218 - ETC.
219         - Move SMACK manifest files to the top SRCDIR
220
221 * Fri Sep 21 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.51
222 - FIX:
223         - Popup: Do not focus container
224         - Header: show backbutton when both tabbar and header are present together
225         - Multi button entry: text ellipsis, code refactoring
226
227 * Fri Sep 21 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.50
228 - ETC.
229         - Apply SMACK manifest
230
231 * Thu Sep 20 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.49
232 - FIX:
233         - JSLINT code clean-up
234         - scrollview: firefox support
235         - scrollview: fix finding slider handle
236         - list: tweak text ellipsis
237         - checkbox: fix selecting wrong label tag (N_SE-8370)
238         - imageslider: check parameter
239         - smallpopup: fix position
240         - searchbar: fix 'clear' button size
241 - Spec changes:
242         - scrollview: support outer scroll
243         - JQM: block click event only with the element that does preventdefault on vclick(N_SE-6090)
244         - remove S/W IME control
245
246 * Thu Sep 13 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.48
247 - FIX:
248         - Add missing icon: controlbar
249         - scrollview: tune scrolling animatio ninterval
250         - datetimepicker: digit/triangle position
251         - datetimepicker: fix day overflow issue
252 - Spec changes:
253         - scrollview: show scrollbar when page is showed
254         - scrollview: disable outer scroll
255         - extendablelist: change api with legacy support
256         - add ui-text-ellipsis class
257
258 * Mon Sep 10 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.47
259 - FIX:
260         - scrollveiw: fix height of view
261         - searchbar: support placeholder
262 - Spec changes:
263         - add ui-text-ellipsis class
264
265 * Fri Sep 07 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.46
266 - FIX:
267         - scrollview: scrolling bug fix
268         - controlbar: fix width of controlbar item
269 - Spec changes:
270         - searchbar: don't hide icon
271         - popup: update JQM poup widget
272
273 * Fri Sep 05 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.45
274 - FIX:
275         - controlbar: set correct controlbar width of last element
276         - slider: get popup enable value correctly
277         - use Date.now() instead of (new Data()).getTime()
278         - popupwindow: fix the background color of popup scroller
279         - listview: add padding-left to expandable list
280         - add ellipsis for title area support
281
282 * Fri Aug 31 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.44
283 - FIX:
284         - swipelist: show list items correctly
285         - datetimepicker: set last day, if day is overflowed
286 - Spec changes:
287         - controlbar: update icons
288
289 * Tue Aug 29 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.43
290 - FIX:
291         - notification: fix typo
292 - Spec changes:
293         - controlbar: update icons
294
295 * Tue Aug 28 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.42
296 - FIX:
297         - multimediaview: video progress bar display normally for too samll
298         - segmentcontrol: remove media query
299         - scrollview: add outer scroll condition
300         - datetimepicker: modify triangle size
301         - popupwindow: set the screen height explicitly
302         - notification: add multiline text
303 - Spec changes:
304         - mutibuttonentry: support new GUI
305         - virtualgrid: support new GUI
306
307 * Mon Aug 27 2012 Jinhyuk Jun <jinhyuk.jun@samsung.com> 0.1.41
308 - FIX:
309         - radio/check button : button size bug fix
310
311 * Fri Aug 24 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.40
312 - FIX:
313         - build error fixed
314
315 * Fri Aug 24 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.39
316 - FIX:
317         - listview: style fix, remove filter placeholder
318         - controlbar: divide styles
319         - scrollview: don't skip dragging when click button or inputbox
320         - slider: trim the text on text slider
321 - Spec changes:
322         - remove gray and blue theme
323         - add white and black theme
324         - support new GUI guide
325
326 * Mon Aug 20 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.38
327 - FIX:
328         - fix coment of version tag
329
330 * Fri Aug 17 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.37
331 - FIX :
332         - button: fix alignment
333         - listview: adjust the main text width
334         - virtualgrid: refactoring
335 - Spec changes:
336         - transition: support JQM 1.1.0 transitions
337         - scrollview: support the outer scroll
338         - notification: remove interval feature
339
340 * Tue Aug 14 2012 Youmin Ha <youmin.ha@samasung.com> 0.1.36
341 - FIX :
342         - checkboxRadio: Add left/right padding
343         - button: custom button & icon position
344         - virtuallist: remove 'recreate' test
345 - Spec changes:
346         - header/footer: enable/disable support
347
348 * Fri Aug 10 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.35
349 - FIX :
350         - expandablelist: modify show animation
351         - virtualgrid: Redesign programming interface
352         - popupwindow: code clean and fixed issues
353         - pagelayout: fix content height
354         - license file update
355         - virtuallist: Change programming interface
356         - datetimepicker: getting days correctly
357         - searchbar: set to hidden when cancel button is hide
358         - White theme title font tuning
359 - Spec changes:
360         - default theme tizen-gray to tizen-white
361         - set default page transition to none
362
363 * Mon Aug 02 2012 Jinhyuk Jun <jinhyuk.jun@samsung.com> 0.1.34
364 - FIX :
365         - Back Button : enlarge backbutton click size for white theme
366 - Feature :
367         - Expandable List : Add refresh api
368 * Mon Aug 02 2012 Jinhyuk Jun <jinhyuk.jun@samsung.com> 0.1.33
369 - FIX :
370         - click event touch threshold tuning
371
372 * Mon Aug 02 2012 Jinhyuk Jun <jinhyuk.jun@samsung.com> 0.1.32
373 - FIX : 
374         - Add back button highlight effect for white theme
375
376 * Mon Aug 01 2012 Jinhyuk Jun <jinhyuk.jun@samsnug.com> 0.1.31
377 - FIX : 
378         - IME checkroutine update, improve relayout on resize event
379         - Add highlight effect for radio button list 
380         - Scrollview : fix condition of updatelayout event
381 - Feature : progressing : add show/hide api
382
383 * Mon Jul 27 2012 Koeun Choi <koeun.choi@samsung.com> 0.1.30
384 - FIX : virtuallist, virtualgrid: Clean up temporary jquery.template object to clear cache
385         add default theme option on buttonMarkup for tizen theme
386         [searchbar] first fix : focus/blur fixed
387         back button does not work when long press
388         scrollview: don't auto scrolling if resizing area is too large
389 - Feature : notification : add api to set the icon at tickernoti
390         demo : update the list sample demo
391         Support tizen default theme
392
393 * Mon Jul 23 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.29
394 - Improvements & Bugfixes
395    - HOTFIX: Revert template function with jquery.template
396
397 * Thu Jul 19 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.28
398 - Improvements & Bugfixes
399    - Fix #WEB-1028: memory leak on virtuallist/virtualgrid
400 - Spec changes
401    - $.tizen.loadTheme() function accepts theme name as arguement
402    - Scrollview supports 'updatelayout' callback
403
404 * Tue Jul 17 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.27
405 - Improvements & Bugfixes
406    - Revert 'preventing long-press popup' patch, to fix backbutton to work in SocialMagazine
407
408 * Tue Jul 17 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.26
409 - Improvements & Bugfixes
410    - Add tizen-white theme package, to make rpm build to be finished
411
412 * Tue Jul 17 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.25
413 - Improvements & Bugfixes
414    - Set 'slide' as default page transition effect, by JQM patch
415
416 * Fri Jul 13 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.24
417 - Improvements & Bugfixes
418    - Fix IME show/hide algorithm
419    - Fix error on virtualgrid: link _set_scrollbar_size() function to the one in virtuallist
420
421 * Wed Jul 11 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.23
422 - Improvements & Bugfixes
423    - Fix notification position
424    - Fix unit tests
425
426  Fri Jul 6 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.22
427 - Spec changes
428         - JQM 1.1 upgrade
429 - Improvements & Bugfixes
430         - Transform3D support on scrollview
431         - Page layout supports IME control
432         - Mapview supports pinch zoom on JQM 1.1
433         - Fix wrong character on button in minified version
434         - Virtualgrid supports scrollbar
435         - Lots of bugfixes
436
437 * Fri Jun 22 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.20
438 - Spec changes
439         - Support 'latest' version (by symlink) for tizen-web-ui-fw.js path.
440         - imageslider : supports 'resize' event.
441         - listview : listview has 1px padding-bottom.
442         - loader : Change global namespace, from S to $.tizen.
443         - loader : Move loadCustomGlobalizeCulture() into $.tizen.util namespace.
444 - Improvements & Bugfixes
445         - Scrollview : supports 'translate3d', instead of 'translate'.
446         - notification : reset timer when 'show' or 'refresh' event.
447         - JQM patch : Fix vclick event triggered twice.
448 - Etc.
449         - Add & fix unit tests.
450
451 * Thu Jun 14 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.19
452 - Spec changes
453         - mapview : new widget.
454         - notification : add .refresh() API.
455         - pagecontrol : add .value([val]) API, and change an attribute name 'data-initVal' to 'data-value'.
456 - Improvements & Bugfixes
457         - Support minified CSS.
458         - loader : Fix & refactor 'loading globalize culture file' routine.
459         - JQM Patch : Calculate min-height of window in javascript code, and remove predefined min-height value from CSS.
460         - Many more bugfixes.
461 - Etc.
462         - Add many unit tests.
463         - Fix test coverage instrumentation tool to work with current source code.