0.2.22 release
[platform/framework/web/web-ui-fw.git] / packaging / web-ui-fw.spec
1 Name:       web-ui-fw
2 Version:    0.2.22
3 Release:    0
4 Summary:    Tizen Web UI Framework Library
5 Group:      Development/Other
6 License:    MIT
7 BuildArch:  noarch
8 BuildRequires:  make
9 BuildRequires:  nodejs
10 %ifarch %{arm}
11 BuildRequires:  nodejs-x86-arm
12 %endif
13
14 Source0:    %{name}-%{version}.tar.gz
15
16 %description
17 Tizen Web UI Framework library and theme packages
18
19 %prep
20 %setup -q
21
22 %build
23 make all
24
25 %install
26 make DESTDIR=%{buildroot} install
27
28 %post
29
30 %files
31 %manifest web-ui-fw.manifest
32 /usr/share/tizen-web-ui-fw/*/js
33 /usr/share/tizen-web-ui-fw/latest
34 /usr/share/tizen-web-ui-fw/VERSION
35
36 ###############################
37 %package -n web-ui-fw-theme-tizen-gray
38 BuildArch:  noarch
39 Summary:    Tizen Web UI Framework Theme : tizen-gray
40 %Description -n web-ui-fw-theme-tizen-gray
41     Tizen Web UI Framework Theme : tizen-gray
42
43 ###############################
44 %package -n web-ui-fw-theme-tizen-white
45 BuildArch:  noarch
46 Summary:    Tizen Web UI Framework Theme : tizen-white
47 %Description -n web-ui-fw-theme-tizen-white
48     Tizen Web UI Framework Theme : tizen-white
49 %files -n web-ui-fw-theme-tizen-white
50 %manifest web-ui-fw-theme-tizen-white.manifest
51 /usr/share/tizen-web-ui-fw/*/themes/tizen-white
52 /usr/share/tizen-web-ui-fw/*/themes/tizen-tizen
53
54 ###############################
55 %package -n web-ui-fw-theme-default
56 BuildArch:  noarch
57 Summary:    Tizen Web UI Framework Theme : default
58 %Description -n web-ui-fw-theme-default
59     Tizen Web UI Framework Theme : default
60 %files -n web-ui-fw-theme-default
61 %manifest web-ui-fw-theme-default.manifest
62 /usr/share/tizen-web-ui-fw/*/themes/default
63
64 ###############################
65 %package -n web-ui-fw-devel
66 BuildArch:  noarch
67 Summary:    Tizen Web UI Framework Developer's files
68 %Description -n web-ui-fw-devel
69     Tizen Web UI Framework Developer's files
70 %files -n web-ui-fw-devel
71 /usr/share/tizen-web-ui-fw/bin
72 /usr/share/tizen-web-ui-fw/template
73
74 ###############################
75 %package -n web-ui-fw-demo-tizen-winsets
76 BuildArch:  noarch
77 Summary:    Tizen Web UI Framework Demo Application: tizen winset demo
78 %Description -n web-ui-fw-demo-tizen-winsets
79     Tizen Web UI Framework Demo Application: tizen winset demo
80 %files  -n web-ui-fw-demo-tizen-winsets
81 /usr/share/tizen-web-ui-fw/demos/tizen-winsets
82
83
84 ###############################
85 %changelog
86 * Fri Apr 5 2013 Youmin Ha <youmin.ha@samsung.com> 0.2.22
87         - tizen-winsets: Fix demo menu
88         - Tizenwinset: Reorder tizenwinset menu
89         - SearchBar: Header button size issue has been fixed
90         - Swipe: list item overflow: hidden has been added
91         - Tizenwinset: href has been added in grouped list
92         - Tizenwinset: Page transition page has been added
93         - Tizenwinset: Radio description has been fixed
94         - This patch fixes problem when base url is changed when site is prefetched.
95         - Entry : limit textarea's width (N_SE-28653)
96         - Naviframe : hide backbutton in case SIP up(remove backbutton makes problem in binding event)
97         - Gallery : next, prev images position bug has been fixed
98         - Multimediaview: Fix display error while handling orientationchange event.
99         - Pagelayout : modify innerHeight dpr calculation in non scrollview mode
100         - Datetimepicker: picker position has been fixed when browser resize event fired
101         - Tips: generate elements sample page javascript has been fixed
102         - Tokentextarea: Fix Tizen-winsets demo.
103
104 * Wed Apr 3 2013 Youmin Ha <youmin.ha@samsung.com> 0.2.21
105         - VirtualGrid: Fix errors on centerTo and resize methods
106         - loader: Fix default font size at device-width viewport
107         - scrollview : remove overflow-x property
108         - Naviframe : fix backbutton position/ change down button icon
109         - Naviframe : bug fix
110         - Tizenwinset : Tizen-winset demo page titles changed Tizen-winset demo page titles changed from lower case to upper case.
111
112 * Fri Mar 29 2013 Youmin Ha <youmin.ha@samsung.com> 0.2.20
113         - JQM Navigation : remove page min-height
114         - Pagelayout : add refresh to pagelayout
115         - Tokentextarea: Changes 'remove' tests to asyncTest
116         - Popup: input tag alignment has been fixed
117         - Tokentextarea: add/remove events are deprecated.
118         - Contextpopup: Support horizontal list
119         - Select: icon z-index has been deleted
120         - Tizenwinset: ui widget order has been changed
121         - Tool: make web app template disable context menu by default
122         - Tizen-winset: change tips for using listview
123         - Loader: calculate font size with mobile width
124         - Naviframe : fix header's back button position
125         - TizenWinset : move locale info to another file
126
127 * Fri Mar 29 2013 Youmin Ha <youmin.ha@samsung.com> 0.2.20
128         - JQM Navigation : remove page min-height
129         - Pagelayout : add refresh to pagelayout
130         - Tokentextarea: Changes 'remove' tests to asyncTest
131         - Popup: input tag alignment has been fixed
132         - Tokentextarea: add/remove events are deprecated.
133         - Contextpopup: Support horizontal list
134         - Select: icon z-index has been deleted
135         - Tizenwinset: ui widget order has been changed
136         - Tool: make web app template disable context menu by default
137         - Tizen-winset: change tips for using listview
138         - Loader: calculate font size with mobile width
139         - Naviframe : fix header's back button position
140         - TizenWinset : move locale info to another file
141
142 * Fri Mar 22 2013 Youmin Ha <youmin.ha@samsung.com> 0.2.19
143         - Tizen-winset: Support accessibility for tizen-winset
144         - Orientation : add orientataionchange to tizen-winset
145         - Tokentextarea: Adjusts VI effect for add/remove block
146         - splitview: Support accessibility for splitview
147         - Tizen-winset: Date/time picker guide text has been fixed
148         - Popup: context popup arrow position, setTimeout open method bug have been fixed
149         - fastscroll: Add new indexString API to Fastscroll widget.
150         - splitview: Add new widget
151         - gallery3d: Add new widget
152         - Scrollview : disable VI effect for gesture event
153         - Scrollview : disable SIP outerscroll
154         - Tizen-winset: resize VirtualGrid widget in demo
155         - Tizen-winsets: Refactor searchbar subpages
156         - Tizen-winsets: Remove depracated usage of virtuallist
157         - Tizen-winsets: Move js code from main.js to subpages
158         - Tizen-winsets: Refactor virtual grid demo subpages
159         - Tizen-winsets: Move css files from index to proper subpages
160         - Tizen-winsets: Refactor list dialogue edit subpage
161         - Tizen-winsets: Refactor pagelayout subpages
162         - Tizen-winsets: Refactor tips subpages
163         - Tizen-winsets: Move subpages popup files from index.html
164         - Tizen-winsets: Move subpages javascript files from index.html
165         - virtualgrid: fix improperly merged codes
166         - ColorTheme : remove unused color value(1st)
167         - Scrollview : change scrollbar draw
168         - Popup: Apply popup background dim
169         - Tizen-winsets: Move tokentextarea demo to external page.
170         - Tizen-winsets: Move tabbar persist demo to external page.
171         - Tizen-winsets: Remove notImplemented page
172         - Tizen-winsets: Move slider demo page to external subpage
173         - Tizen-winsets: Fix ids, remove duplicated names for sliders
174         - Tizen-winsets: Remove event for changing theme
175         - tool: Fix wgt sample app generator tool to make apps be installed
176         - demos : change live to on
177         - build: Trim compiled CSS files
178         - Gallery: CSS left -> translate or translate3D
179         - Tokentextarea: Disfunctional APIs fixed.
180
181 * Thu Mar 7 2013 Youmin Ha <youmin.ha@samsung.com> 0.2.18
182         - build: Fix Makefile to add globalize to the minified lib
183         - build-tools : upgrade less to v1.3.3
184         - demos : change normal js path to minified js
185         - Theme : remove reduantant less - dayselector, optionheader, nocontents
186         - multimediaview : fix full-screen mode.
187         - multimediaview : fix 'width', 'height' and 'fullScreen' methods
188         - Extendablelist: Added min-height "load more button" in listitem
189         - virtualgrid: adjusts VI effect for an overflow action
190         - ControlGroup : change ellipsis font color (press/normal)
191         - multimediaview: Add an error message to Multimediaview
192         - virtualgrid: adjusts triple flick gesture
193         - scrollview: add function for getting width of view
194         - scrollview: adds support x axis gesture scroll
195         - multimediaview : fix audio control
196         - tabbar : tabbar slide animation change
197         - TizenWinsetDemo : 2line-text demo bug fix
198         - collapsible: Fix demo to show radio button correctly in the collapsible list
199         - collapsible: Set listitem position to relative
200         - UnitTC: added list divider unit test
201         - Style: unnecessary color codes have been deleted and modified
202         - build: Module build implementation
203         - UnitTC: Additional unit testcases have been added
204         - listview : bug fix
205         - Naviframe : remove back button's hover effect
206         - TizenDemo : remove back button
207         - Transition: added more-button vi
208         - pinch: added new event called pinch
209         - Popup: css word-wrap:break-word has been added
210         - virtualgrid: memory leak fix
211         - progress: set to init state at pending bar
212         - progress: add margin of top/bottom
213         - unit-test: split progress test and progressbar test
214         - Tizen-winset: Context popup sample page guide text has been changed
215         - multimediaview: fix the height of widget when full-screen mode
216         - JQM: performance tuning
217
218 * Tue Feb 19 2013 Minkyu Kang <mk7.kang@samsung.com> 0.2.17
219         - DialogueList : delete border top value / add sample's text ellipsis
220         - Tokentextarea: Add scroll-to-top for Grouping On/Off regarding #N_SE-24877
221         - Multimediaview: Fix mute function
222         - Tizen-winset: list vi index guide textbox has been removed
223         - Tizen-winset: custom button texts have been changed
224         - slider: move popup div to out of content
225         - TizenWinset: disable context popup in multimediaview
226         - Swipe: wrong style name has been fixed
227         - demo: add the sample at dialogue list
228         - listview: Add ui-li-has-right-btn class with toggleswitch
229         - WinsetDemo : change wrong title name
230
231 * Mon Jan 28 2013 Youmin Ha <youmin.ha@samsung.com> 0.2.16
232         - demo: checkbox: reduce button's width
233         - tabbar : delete right/left tab animation color
234         - scrollview: fix the scroll position at keydown event
235         - groupControl : change footer groupControl from min-width to percentage
236         - scrollview: get height of softkeyboard correctly
237         - tizen-winset: Add name attr to all radio inputs
238         - virtualgrid: changes event binding target
239         - scrollview: skip the drag if target is textarea
240         - scrollview: skip the dragging of parent scrollview
241         - scrollview: apply the scaling ratio to the soft keyboard
242         - demos: apply disabled option in textarea
243         - demo: remove unused codes
244         - demo: datetimepicker: show selected date correctly
245         - listview: Adjust bubble listitem width and margin
246         - pagelayout : change external refresh call and ime status follow only current page
247         - toggleSwitch : bug fix
248         - unit-test: slider: fix the move test
249         - handler: fix jslint error
250         - ToggleSwitch : set image toggleswitch background attribute
251
252 * Mon Jan 28 2013 Youmin Ha <youmin.ha@samsung.com> 0.2.15
253         - slider: increase the text width(N_SE-23397)
254         - virtualgrid: DOM element leak fix
255         - header: Move button top higher in header with tabbar(N_SE-22253)
256         - datatimepicker: don't open the popup before popupafterclose event is fired(N_SE-23027)
257         - handler: bug fix (regarding enableHandler function )
258         - demo:fix syntax error
259
260 * Sat Jan 26 2013 Youmin Ha <youmin.ha@samsung.com> 0.2.14
261         - demo: fix demo using tizen device API
262         - multimediaview: reset the height of container
263         - input: modify css correctly
264         - multimediaview: fix the height of widget
265         - gallery: bind create event
266         - progress: bind create event
267         - slider: bind create event
268         - progressbar: bind create event
269         - progressbar: event trigger correctly
270         - popup: fix height of popup scroller
271         - build: add continue option to jslint
272         - ctxpopup demo : bug fix
273         - demo: fix searchbar demo to use different IDs
274         - demo: extract routine executing Tizen device API
275         - toggleswitch : set default margin, delete box padding
276
277 * Thu Jan 24 2013 Youmin Ha <youmin.ha@samsung.com> 0.2.13
278         - virtuallist: Prevent replacing contents on nonexist element
279         - JQM: Trim text in listitem to get index in autodivider
280         - JQM: Remove trailing whitespace in jqm patch
281         - scrollview: get the height including margin
282         - multimediaview: bug fix ( scrolling in full-screen mode )
283         - virtuallist: set listitem width to exclude listitem left/right margin
284         - demo: fix virtuallist sample layout
285         - progress: set the position explicitly
286         - progress: rename from progressing to progress
287         - build: remove unused files
288         - searchbar: fix jslint errors
289         - src: fix file permissions
290         - button : change jump left icon
291
292 * Wed Jan 23 2013 Minkyu Kang <mk7.kang@samsung.com> 0.2.12
293         - theme : button icon - scrolltop, scrolleft icon changed.
294         - build: cleanaup Makefile
295         - pagelayout: fix jslint error
296         - virtualgrid: Fix jslint errors
297         - tabbar : jslint bug error fix
298         - build: add regexp option to jslint
299         - virtuallist: fix jslint errors
300         - handler: Apply the exceptional principle for scrollbar on Handler.
301         - build: remove unused copyright
302         - loader: extract log class for tizen web, and fix jslint errors
303         - loader: Viewport width is set to document width
304         - popupwindow: fix jslint error
305         - build: fix Makefile for tizen-white theme
306         - build: remove unused libraries
307         - datetimepicker: fix jslint error
308         - slider: fix jslint error
309         - demo: remove deprecated demos
310         - pagelayout : change to call relayout with this page
311         - Tokentextarea: Block size error fixed.
312         - handler: bug fix (handler activation)
313
314 * Tue Jan 22 2013 Minkyu Kang <mk7.kang@samsung.com> 0.2.11
315         - demo: clear input text value with cancel button click
316         - demo: Adjust textarea height automatically
317         - naviframe : bug fix
318         - tabbar : bug fix
319         - Fastscroll: popup position has been changed
320         - Button: custom button icon path, margin have been changed
321         - toggleswitch : bug fix
322         - slider: increase the margin
323         - datetimepicker: close the popup after select the value
324         - unit-test : add page backbutton control test
325         - Demo: added guide text and change input type in list vi
326         - remove legacy codes : jquery-geo
327         - Datetimepicker: text-main max-width has been removed
328         - Radio: control group border has been removed
329         - Demo: remove 'tab' space
330         - UnitTC: swipe unit tc has been fixed
331         - UnitTC: jQuery path has been fixed
332         - Button: bug fix when button has not a text
333         - tizen-winset: timepicker: demo title is changed
334
335 * Fri Jan 18 2013 Minkyu Kang <mk7.kang@samsung.com> 0.2.10
336         - tizen-winsets: codes cleanup
337         - datetimepicker: date calibration when year is changed
338         - Demo: textarea size has been changed
339         - Demo: Naviframe morebutton demo has been changed
340         - remove unused unit test cases : gallery3d
341         - tizen-winset: remove links
342
343 * Thu Jan 17 2013 Minkyu Kang <mk7.kang@samsung.com> 0.2.9
344         - gallery: use timeout function instead of interval
345         - Tokentextarea: Display error fixed.
346         - scrollview: Fix not selector to respond with jQuery1.8.2
347         - tabbar: remove the width of last element
348         - Demo: apply css 'user-select:none'
349         - Button: guide text has been shorten
350         - build: Update jQuery to 1.8.2 (JQM1.2 compliant)
351         - virtuallist: Fix mistyping
352         - demo: Fix tizen function namespace in demo
353         - virtuallist: Rewrite listitem replacing algorithm
354         - fastscroll: modify from not selector to function
355         - extendablelist: Fix unit-test
356         - tabbar : prefix to tabbar scroll event
357         - Popupwindow: removed unvalid selector in jquery 1.8.2
358         - slider: adjust handle text as length of value
359         - Demo: 3 buttons in popup text has been changed
360         - src: codes cleanup
361         - demo : remove trailing empty strings
362         - demo : rename TizenWinset list items
363         - button : change from long text list to multiline list
364         - build: Remove JQM1.1.0 patches
365         - Popup: Apply tizen style popup and attribute support
366         - JQM: Fix buttonmarkup bug keeping ui-btn-down class
367         - UnitTest: folder and file renamed, QUnit path was modified
368         - tizen-winsets: button: fix textarea width
369         - Swipe: event name error has been fixed
370
371 * Tue Jan 15 2013 Minkyu Kang <mk7.kang@samsung.com> 0.2.8
372         - Button: button padding has been updated
373         - virtuallist: fix unique listitem ID bug
374         - checkbox, radio : change display attr
375         - Button: bug fix ( when data style circle button on text )
376         - handler: bug fix (when scrolling with multi selection)
377         - JQM: adjust patch number
378         - gallery: show the widget after pageshow
379         - TokenTextArea : resource add ( press image )
380         - gallery: adds function that set the index to value API
381         - configure: set TIZEN default configures
382         - footer: h tag display attribute value has been changed
383         - buttons : demo bug fix
384         - searchbar : demo page bug fix
385         - tizen demo : bug fix
386         - build: remove JQM1.1.0
387         - Tokentextarea: Fix issues
388         - scrollview: block the multi touch
389         - list : dialogue list demo change
390         - pagelayout : update dynamic control
391         - Demo: Context popup close method has been changed
392
393 * Fri Jan 11 2013 Minkyu Kang <mk7.kang@samsung.com> 0.2.7
394         - slider: set text container's width as text length
395         - Timepicker: li max-width has been changed
396         - remove experimental feature - mapview.
397         - scrollview: added conditions for finding slider
398         - UnitTC: Pass,error count save method has been changed
399         - confix.xml: default config added for tizen basic applications
400         - Swipe: p tag margin value is set '0'
401         - packaging: remove unused file
402         - tabbar : bug fix
403         - list demo : bug fix
404         - tizen-winsets: gallery: move to new section
405         - tizen-winsets: autodivider: removes link of list
406         - demos: entry of number-pattern name is changed from 'number' to 'number-pattern'
407         - pagelayout : padding calculate change, ime footer check changed
408         - tizen-winsets: searchbar: scroll to the top when type the character
409         - searchbar : bug fix
410         - demo: Fix virtuallist demo following new list style
411         - demo: Add word-wrap:break-word and remove parag. width
412         - Demo: button max-width has been set( 3 buttons in popup )
413         - back button control demo : bug fix
414         - toggleswitch : demo page modify
415         - slider: add margin-top and margin-bottom
416         - tabbar demo : bug fix
417         - Popup: IME hide when popup is closed
418         - token textarea : bug fix
419         - Timepicker: change get attribute method
420         - footer demo : bug fix
421         - unit-test: gallery: add new APIs
422         - gallery: adds support new APIs
423
424 * Fri Jan 04 2013 Minkyu Kang <mk7.kang@samsung.com> 0.2.6
425         - JQM: patches cleanup
426         - Button: data-corners attribute has been added
427         - unit-test: slider: fix class name of background
428         - progressbar, slider: fix less variable typo
429         - Tabbar : VI update
430         - notification: add top position at fix class
431         - demo: entry demo page change
432         - css: .ui-disabled added
433         - tizen-winset: token textarea: remove back button at demo page
434         - theme: Remove unused less file
435         - pagelayout : content min height bug fix
436         - scrollview: skip the dragging when target is slider's handle
437         - scrollview: update and refactoring the scroll effect
438         - UnitTest:JQM Unit TC helper has been added,TCs have been modified
439         - Swipe: demo page html error has been fixed
440         - listview: Add add/delete animation (VI)
441         - Popup: demo page has been modified
442         - tizen demo : bug fix
443         - searchbar : demo page change(change front button and add behaviour)
444         - pagelayout : add min height to content
445         - gallery: rename 'Image Slider' to 'Gallery' in tizen-winsets demo and tests
446         - back button control demo : change url link to data-rel="back"
447         - loader: Skip loading theme CSS with a custom css code
448         - Button: support no-text in button
449         - collapsible: Fix syntax error
450         - slider: use data-highlight attribute
451         - collapsible: Rotate animation to collapsible heading icon
452         - toggleswitch : text switch bug fix
453         - remove candidates-calendarpicker
454         - Patch: Fix misc mistakes in JQM patches
455         - searchbar : animation change
456         - gallery: get the width correctly
457         - demo: data-framework-viewport-scale attribute is changed to data-framework-viewport-width
458         - collapsible: Add collapse/expand animation (VI)
459         - datetimepicker: VI update
460         - JQM: set transition to pop as default
461         - tabbar : bug fix in case none li element case
462         - scrollview: fix the drag bug
463         - Button: Button icon scrolltop, left has beed added
464         - Swipe: VI update and swipe speed has been changed
465         - jqm: fix errors in patch files
466         - unit-test: swipe: fixed the destroy test
467
468 * Wed Dec 26 2012 Youmin Ha <youmin.ha@samsung.com> 0.2.5
469         - Revert "[checkboxradio] exception handling for input"
470                 This reverts commit 72478c32704fa96362db577e6cf9511777919ea8.
471                 Tizen style supports no-label radio and checkbox when making lists.
472                 So it ignores html input operation. Instead, it supports tizen style radio and checkbox theme.
473
474 * Thu Dec 20 2012 Youmin Ha <youmin.ha@samsung.com> 0.2.4
475 - Fix:
476         - modify segment background
477         - rearrange check, radio input
478         - CtxPopup: Scale up/ down popup vi(poptop, popbottom)
479         - button: style has beed added(box,circle,nobg,round)
480         - favorite resource added
481         - demo/tizen-winsets: add footer and back button
482         - remove autodividers unit test
483         - add divider for tabbar
484         - checkboxradio: exception handling for input
485         - segment control backward compatiblity
486         - Fix collapsible unit-test
487         - remove toggleswitch
488         - add patch for remove segment text
489 - Spec changes:
490         - replace controlbar to tabbar
491
492 * Fri Dec 14 2012 Minkyu Kang <mk7.kang@samsung.com> 0.2.3
493 - FIX:
494         - slider: add image
495         - button: data-icon support, styles fix
496         - progressbar: modify the background
497         - scrollview: auto scrolling bug fix
498         - pagelayout: IME concept is changed
499 - Spec changes:
500         - dialogue: add edit mode
501         - nocontents: removed
502         - pagecontrol: removed
503         - dayselector: removed
504         - expandablelist: removed
505
506 * Thu Dec 10 2012 Youmin Ha <youmin.ha@samsung.com> 0.2.2
507 - FIX:
508         - chang searchbar/slider images
509         - delete redundant button images
510 - Spec changes:
511         - Change widget name: shortcutscroll -> fastscroll
512
513 * Thu Dec 07 2012 Youmin Ha <youmin.ha@samsung.com> 0.2.1
514 - FIX:
515         - jqm1.2: Change collapsible style to meet expandable list
516         - remove jquery-geo-1.0.a4
517         - unit-test: rename from imageslider to gallery
518         - nocontent: add warning message
519         - Handler: Fix issues in jqm1.2
520         - Multimediaview: modify APIs & comments
521         - Mapview: Fix issues in jqm1.2
522         - JQM: clean up patches
523         - Swipelist: refactoring swipelist
524         - Popup,Ctxpopup: Apply tizen style popup in JQM1.2
525         - rearrange button's data-icon resources
526 - Spec changes:
527         - Virtualgrid: remove option ('data-itemcount')
528         - gallery: rename the widget from imageslider to gallery
529         - add new style for searchbar
530         [tokentextarea] multi-button entry renamed as token text area. API & comments modified.
531
532 * Thu Dec 06 2012 Minkyu Kang <mk7.kang@samsung.com> 0.2.0
533 - FIX:
534         - fix jslint error
535         - remove unused files
536         - change naviframe style
537 - Spec changes:
538         - applied jQuery Mobile 1.2.0
539         - remove optionheader
540
541 * Fri Nov 30 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.64
542 - FIX:
543         - fix unit tests
544         - remove unused theme files
545         - timepicker: text position fix
546         - scrollview: set dragstop when mouse is out of window
547         - listview: fix margin
548 - Spec changes:
549         - support data-framework-viewport-width
550
551 * Fri Nov 23 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.63
552 - FIX:
553         - dayselector: fix size
554         - remove unised styles
555         - divider: set non-press effect to default option
556         - popupwindow: fix window closing failure
557         - handler: GUI implementation
558         - TC: fix unit TCs
559         - scrollview: fix padding size
560 - Spec changes:
561         - Remove color widgets
562         - add $.tizen.pkgVersion for SDK
563 - Etc.
564         - JSDuck documents
565
566 * Fri Nov 16 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.62
567 - FIX:
568         - Many winsets: Fix layout
569         - Footer: fix position to bottom
570 - Spec changes:
571         - Remove color widgets
572
573 * Fri Nov 09 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.61
574 - FIX:
575         - Many widgets: New UX 0.6 theme implementation
576         - widgetex: init speed up
577         - scrollview: fix scrollbar and scale animation
578         - scrollview: fix scroll position when updatelayout is triggered
579         - header/footer: make textselection disable, except input type="text"
580
581 * Wed Nov 07 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.60
582 - FIX:
583         - Remove tizen-black theme package description
584
585 * Tue Nov 06 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.59
586 - FIX:
587         - Fix theme name to meet the change of system theme name: white->tizen
588         - Popupwindow: fix left position
589         - Remove black theme
590         - footer: remove label, legend drawing
591 - Spec changes:
592         - UX guide v0.4 : button, layout
593
594 * Fri Oct 26 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.58
595 - FIX:
596         - scrollview: Fix outer scroll amount
597         - tabbar: fix tapping twice
598         - popupwindow: fix left position
599
600 * Wed Oct 24 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.57
601 - FIX:
602         - expandablelist: icon color fix
603         - scrollview: Fix xy scroll
604         - footer: Remove dummy div
605         - Make string concatnation effective in inline-protos.sh
606 - Spec changes:
607         - refresh header/footer when drag&drop event is fired in GUI builder
608         - searchbar: delete cancel button
609         - don't trigger updatelayout event when keyup event comes
610
611 * Mon Oct 15 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.56
612 - FIX:
613         - Toggleswitch: Change event name from 'changed' to 'change'
614         - Notification: Revert interval feature
615
616 * Tue Oct 09 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.55
617 - FIX:
618         - Fix SMACK manifest bug (S1-9098)
619
620 * Fri Oct 05 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.54
621 - FIX:
622         - handler: don't append a handler if handler is not enabled
623         - scrollview: use static value
624         - datetimepicker: fix date-format HH display error
625 - ETC:
626         - provide jquery.min.js
627         - barlayout: codes clean
628         - remove unused file
629
630 * Wed Sep 26 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.53
631 - FIX:
632         - listview: change focused color
633         - multibuttonentry: code refactoring
634         - datetimepicker: modify date format when triggered date-changed event
635         - slider: fix the top of slider bar
636         - add event blocker when load a first page
637
638 * Fri Sep 21 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.52
639 - ETC.
640         - Move SMACK manifest files to the top SRCDIR
641
642 * Fri Sep 21 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.51
643 - FIX:
644         - Popup: Do not focus container
645         - Header: show backbutton when both tabbar and header are present together
646         - Multi button entry: text ellipsis, code refactoring
647
648 * Fri Sep 21 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.50
649 - ETC.
650         - Apply SMACK manifest
651
652 * Thu Sep 20 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.49
653 - FIX:
654         - JSLINT code clean-up
655         - scrollview: firefox support
656         - scrollview: fix finding slider handle
657         - list: tweak text ellipsis
658         - checkbox: fix selecting wrong label tag (N_SE-8370)
659         - imageslider: check parameter
660         - smallpopup: fix position
661         - searchbar: fix 'clear' button size
662 - Spec changes:
663         - scrollview: support outer scroll
664         - JQM: block click event only with the element that does preventdefault on vclick(N_SE-6090)
665         - remove S/W IME control
666
667 * Thu Sep 13 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.48
668 - FIX:
669         - Add missing icon: controlbar
670         - scrollview: tune scrolling animatio ninterval
671         - datetimepicker: digit/triangle position
672         - datetimepicker: fix day overflow issue
673 - Spec changes:
674         - scrollview: show scrollbar when page is showed
675         - scrollview: disable outer scroll
676         - extendablelist: change api with legacy support
677         - add ui-text-ellipsis class
678
679 * Mon Sep 10 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.47
680 - FIX:
681         - scrollveiw: fix height of view
682         - searchbar: support placeholder
683 - Spec changes:
684         - add ui-text-ellipsis class
685
686 * Fri Sep 07 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.46
687 - FIX:
688         - scrollview: scrolling bug fix
689         - controlbar: fix width of controlbar item
690 - Spec changes:
691         - searchbar: don't hide icon
692         - popup: update JQM poup widget
693
694 * Fri Sep 05 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.45
695 - FIX:
696         - controlbar: set correct controlbar width of last element
697         - slider: get popup enable value correctly
698         - use Date.now() instead of (new Data()).getTime()
699         - popupwindow: fix the background color of popup scroller
700         - listview: add padding-left to expandable list
701         - add ellipsis for title area support
702
703 * Fri Aug 31 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.44
704 - FIX:
705         - swipelist: show list items correctly
706         - datetimepicker: set last day, if day is overflowed
707 - Spec changes:
708         - controlbar: update icons
709
710 * Tue Aug 29 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.43
711 - FIX:
712         - notification: fix typo
713 - Spec changes:
714         - controlbar: update icons
715
716 * Tue Aug 28 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.42
717 - FIX:
718         - multimediaview: video progress bar display normally for too samll
719         - segmentcontrol: remove media query
720         - scrollview: add outer scroll condition
721         - datetimepicker: modify triangle size
722         - popupwindow: set the screen height explicitly
723         - notification: add multiline text
724 - Spec changes:
725         - mutibuttonentry: support new GUI
726         - virtualgrid: support new GUI
727
728 * Mon Aug 27 2012 Jinhyuk Jun <jinhyuk.jun@samsung.com> 0.1.41
729 - FIX:
730         - radio/check button : button size bug fix
731
732 * Fri Aug 24 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.40
733 - FIX:
734         - build error fixed
735
736 * Fri Aug 24 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.39
737 - FIX:
738         - listview: style fix, remove filter placeholder
739         - controlbar: divide styles
740         - scrollview: don't skip dragging when click button or inputbox
741         - slider: trim the text on text slider
742 - Spec changes:
743         - remove gray and blue theme
744         - add white and black theme
745         - support new GUI guide
746
747 * Mon Aug 20 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.38
748 - FIX:
749         - fix coment of version tag
750
751 * Fri Aug 17 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.37
752 - FIX :
753         - button: fix alignment
754         - listview: adjust the main text width
755         - virtualgrid: refactoring
756 - Spec changes:
757         - transition: support JQM 1.1.0 transitions
758         - scrollview: support the outer scroll
759         - notification: remove interval feature
760
761 * Tue Aug 14 2012 Youmin Ha <youmin.ha@samasung.com> 0.1.36
762 - FIX :
763         - checkboxRadio: Add left/right padding
764         - button: custom button & icon position
765         - virtuallist: remove 'recreate' test
766 - Spec changes:
767         - header/footer: enable/disable support
768
769 * Fri Aug 10 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.35
770 - FIX :
771         - expandablelist: modify show animation
772         - virtualgrid: Redesign programming interface
773         - popupwindow: code clean and fixed issues
774         - pagelayout: fix content height
775         - license file update
776         - virtuallist: Change programming interface
777         - datetimepicker: getting days correctly
778         - searchbar: set to hidden when cancel button is hide
779         - White theme title font tuning
780 - Spec changes:
781         - default theme tizen-gray to tizen-white
782         - set default page transition to none
783
784 * Mon Aug 02 2012 Jinhyuk Jun <jinhyuk.jun@samsung.com> 0.1.34
785 - FIX :
786         - Back Button : enlarge backbutton click size for white theme
787 - Feature :
788         - Expandable List : Add refresh api
789 * Mon Aug 02 2012 Jinhyuk Jun <jinhyuk.jun@samsung.com> 0.1.33
790 - FIX :
791         - click event touch threshold tuning
792
793 * Mon Aug 02 2012 Jinhyuk Jun <jinhyuk.jun@samsung.com> 0.1.32
794 - FIX : 
795         - Add back button highlight effect for white theme
796
797 * Mon Aug 01 2012 Jinhyuk Jun <jinhyuk.jun@samsnug.com> 0.1.31
798 - FIX : 
799         - IME checkroutine update, improve relayout on resize event
800         - Add highlight effect for radio button list 
801         - Scrollview : fix condition of updatelayout event
802 - Feature : progressing : add show/hide api
803
804 * Mon Jul 27 2012 Koeun Choi <koeun.choi@samsung.com> 0.1.30
805 - FIX : virtuallist, virtualgrid: Clean up temporary jquery.template object to clear cache
806         add default theme option on buttonMarkup for tizen theme
807         [searchbar] first fix : focus/blur fixed
808         back button does not work when long press
809         scrollview: don't auto scrolling if resizing area is too large
810 - Feature : notification : add api to set the icon at tickernoti
811         demo : update the list sample demo
812         Support tizen default theme
813
814 * Mon Jul 23 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.29
815 - Improvements & Bugfixes
816    - HOTFIX: Revert template function with jquery.template
817
818 * Thu Jul 19 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.28
819 - Improvements & Bugfixes
820    - Fix #WEB-1028: memory leak on virtuallist/virtualgrid
821 - Spec changes
822    - $.tizen.loadTheme() function accepts theme name as arguement
823    - Scrollview supports 'updatelayout' callback
824
825 * Tue Jul 17 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.27
826 - Improvements & Bugfixes
827    - Revert 'preventing long-press popup' patch, to fix backbutton to work in SocialMagazine
828
829 * Tue Jul 17 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.26
830 - Improvements & Bugfixes
831    - Add tizen-white theme package, to make rpm build to be finished
832
833 * Tue Jul 17 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.25
834 - Improvements & Bugfixes
835    - Set 'slide' as default page transition effect, by JQM patch
836
837 * Fri Jul 13 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.24
838 - Improvements & Bugfixes
839    - Fix IME show/hide algorithm
840    - Fix error on virtualgrid: link _set_scrollbar_size() function to the one in virtuallist
841
842 * Wed Jul 11 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.23
843 - Improvements & Bugfixes
844    - Fix notification position
845    - Fix unit tests
846
847  Fri Jul 6 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.22
848 - Spec changes
849         - JQM 1.1 upgrade
850 - Improvements & Bugfixes
851         - Transform3D support on scrollview
852         - Page layout supports IME control
853         - Mapview supports pinch zoom on JQM 1.1
854         - Fix wrong character on button in minified version
855         - Virtualgrid supports scrollbar
856         - Lots of bugfixes
857
858 * Fri Jun 22 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.20
859 - Spec changes
860         - Support 'latest' version (by symlink) for tizen-web-ui-fw.js path.
861         - imageslider : supports 'resize' event.
862         - listview : listview has 1px padding-bottom.
863         - loader : Change global namespace, from S to $.tizen.
864         - loader : Move loadCustomGlobalizeCulture() into $.tizen.util namespace.
865 - Improvements & Bugfixes
866         - Scrollview : supports 'translate3d', instead of 'translate'.
867         - notification : reset timer when 'show' or 'refresh' event.
868         - JQM patch : Fix vclick event triggered twice.
869 - Etc.
870         - Add & fix unit tests.
871
872 * Thu Jun 14 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.19
873 - Spec changes
874         - mapview : new widget.
875         - notification : add .refresh() API.
876         - pagecontrol : add .value([val]) API, and change an attribute name 'data-initVal' to 'data-value'.
877 - Improvements & Bugfixes
878         - Support minified CSS.
879         - loader : Fix & refactor 'loading globalize culture file' routine.
880         - JQM Patch : Calculate min-height of window in javascript code, and remove predefined min-height value from CSS.
881         - Many more bugfixes.
882 - Etc.
883         - Add many unit tests.
884         - Fix test coverage instrumentation tool to work with current source code.