Export 0.2.1
[platform/framework/web/web-ui-fw.git] / packaging / web-ui-fw.spec
1 Name:       web-ui-fw
2 Version:    0.2.1
3 Release:    1
4 Summary:    Tizen Web UI Framework Library
5 Group:      Development/Other
6 License:    MIT
7 BuildArch:  noarch
8 BuildRequires:  make
9 BuildRequires:  nodejs
10 %ifarch %{arm}
11 BuildRequires:  nodejs-x86-arm
12 %endif
13
14 Source0:    %{name}-%{version}.tar.gz
15
16 %description
17 Tizen Web UI Framework library and theme packages
18
19 %prep
20 %setup -q
21
22 %build
23 make all
24
25 %install
26 make DESTDIR=%{buildroot} install
27
28 %post
29
30 %files
31 %manifest web-ui-fw.manifest
32 /usr/share/tizen-web-ui-fw/*/js
33 /usr/share/tizen-web-ui-fw/latest
34
35 ###############################
36 %package -n web-ui-fw-theme-tizen-gray
37 BuildArch:  noarch
38 Summary:    Tizen Web UI Framework Theme : tizen-gray
39 %Description -n web-ui-fw-theme-tizen-gray
40     Tizen Web UI Framework Theme : tizen-gray
41
42 ###############################
43 %package -n web-ui-fw-theme-tizen-white
44 BuildArch:  noarch
45 Summary:    Tizen Web UI Framework Theme : tizen-white
46 %Description -n web-ui-fw-theme-tizen-white
47     Tizen Web UI Framework Theme : tizen-white
48 %files -n web-ui-fw-theme-tizen-white
49 %manifest web-ui-fw-theme-tizen-white.manifest
50 /usr/share/tizen-web-ui-fw/*/themes/tizen-white
51 /usr/share/tizen-web-ui-fw/*/themes/tizen-tizen
52
53 ###############################
54 %package -n web-ui-fw-theme-default
55 BuildArch:  noarch
56 Summary:    Tizen Web UI Framework Theme : default
57 %Description -n web-ui-fw-theme-default
58     Tizen Web UI Framework Theme : default
59 %files -n web-ui-fw-theme-default
60 %manifest web-ui-fw-theme-default.manifest
61 /usr/share/tizen-web-ui-fw/*/themes/default
62
63 ###############################
64 %package -n web-ui-fw-devel
65 BuildArch:  noarch
66 Summary:    Tizen Web UI Framework Developer's files
67 %Description -n web-ui-fw-devel
68     Tizen Web UI Framework Developer's files
69 %files -n web-ui-fw-devel
70 /usr/share/tizen-web-ui-fw/bin
71 /usr/share/tizen-web-ui-fw/template
72
73 ###############################
74 %package -n web-ui-fw-demo-tizen-winsets
75 BuildArch:  noarch
76 Summary:    Tizen Web UI Framework Demo Application: tizen winset demo
77 %Description -n web-ui-fw-demo-tizen-winsets
78     Tizen Web UI Framework Demo Application: tizen winset demo
79 %files  -n web-ui-fw-demo-tizen-winsets
80 /usr/share/tizen-web-ui-fw/demos/tizen-winsets
81
82
83 ###############################
84 %changelog
85 * Thu Dec 07 2012 Youmin Ha <youmin.ha@samsung.com> 0.2.1
86 - FIX:
87         - jqm1.2: Change collapsible style to meet expandable list
88         - remove jquery-geo-1.0.a4
89         - unit-test: rename from imageslider to gallery
90         - nocontent: add warning message
91         - Handler: Fix issues in jqm1.2
92         - Multimediaview: modify APIs & comments
93         - Mapview: Fix issues in jqm1.2
94         - JQM: clean up patches
95         - Swipelist: refactoring swipelist
96         - Popup,Ctxpopup: Apply tizen style popup in JQM1.2
97         - rearrange button's data-icon resources
98 - Spec changes:
99         - Virtualgrid: remove option ('data-itemcount')
100         - gallery: rename the widget from imageslider to gallery
101         - add new style for searchbar
102         [tokentextarea] multi-button entry renamed as token text area. API & comments modified.
103
104 * Thu Dec 06 2012 Minkyu Kang <mk7.kang@samsung.com> 0.2.0
105 - FIX:
106         - fix jslint error
107         - remove unused files
108         - change naviframe style
109 - Spec changes:
110         - applied jQuery Mobile 1.2.0
111         - remove optionheader
112
113 * Fri Nov 30 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.64
114 - FIX:
115         - fix unit tests
116         - remove unused theme files
117         - timepicker: text position fix
118         - scrollview: set dragstop when mouse is out of window
119         - listview: fix margin
120 - Spec changes:
121         - support data-framework-viewport-width
122
123 * Fri Nov 23 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.63
124 - FIX:
125         - dayselector: fix size
126         - remove unised styles
127         - divider: set non-press effect to default option
128         - popupwindow: fix window closing failure
129         - handler: GUI implementation
130         - TC: fix unit TCs
131         - scrollview: fix padding size
132 - Spec changes:
133         - Remove color widgets
134         - add $.tizen.pkgVersion for SDK
135 - Etc.
136         - JSDuck documents
137
138 * Fri Nov 16 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.62
139 - FIX:
140         - Many winsets: Fix layout
141         - Footer: fix position to bottom
142 - Spec changes:
143         - Remove color widgets
144
145 * Fri Nov 09 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.61
146 - FIX:
147         - Many widgets: New UX 0.6 theme implementation
148         - widgetex: init speed up
149         - scrollview: fix scrollbar and scale animation
150         - scrollview: fix scroll position when updatelayout is triggered
151         - header/footer: make textselection disable, except input type="text"
152
153 * Wed Nov 07 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.60
154 - FIX:
155         - Remove tizen-black theme package description
156
157 * Tue Nov 06 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.59
158 - FIX:
159         - Fix theme name to meet the change of system theme name: white->tizen
160         - Popupwindow: fix left position
161         - Remove black theme
162         - footer: remove label, legend drawing
163 - Spec changes:
164         - UX guide v0.4 : button, layout
165
166 * Wed Oct 24 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.57
167 - FIX:
168         - expandablelist: icon color fix
169         - scrollview: Fix xy scroll
170         - footer: Remove dummy div
171         - Make string concatnation effective in inline-protos.sh
172 - Spec changes:
173         - refresh header/footer when drag&drop event is fired in GUI builder
174         - searchbar: delete cancel button
175         - don't trigger updatelayout event when keyup event comes
176
177 * Mon Oct 15 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.56
178 - FIX:
179         - Toggleswitch: Change event name from 'changed' to 'change'
180         - Notification: Revert interval feature
181
182 * Tue Oct 09 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.55
183 - FIX:
184         - Fix SMACK manifest bug (S1-9098)
185
186 * Fri Oct 05 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.54
187 - FIX:
188         - handler: don't append a handler if handler is not enabled
189         - scrollview: use static value
190         - datetimepicker: fix date-format HH display error
191 - ETC:
192         - provide jquery.min.js
193         - barlayout: codes clean
194         - remove unused file
195
196 * Wed Sep 26 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.53
197 - FIX:
198         - listview: change focused color
199         - multibuttonentry: code refactoring
200         - datetimepicker: modify date format when triggered date-changed event
201         - slider: fix the top of slider bar
202         - add event blocker when load a first page
203
204 * Fri Sep 21 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.52
205 - ETC.
206         - Move SMACK manifest files to the top SRCDIR
207
208 * Fri Sep 21 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.51
209 - FIX:
210         - Popup: Do not focus container
211         - Header: show backbutton when both tabbar and header are present together
212         - Multi button entry: text ellipsis, code refactoring
213
214 * Fri Sep 21 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.50
215 - ETC.
216         - Apply SMACK manifest
217
218 * Thu Sep 20 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.49
219 - FIX:
220         - JSLINT code clean-up
221         - scrollview: firefox support
222         - scrollview: fix finding slider handle
223         - list: tweak text ellipsis
224         - checkbox: fix selecting wrong label tag (N_SE-8370)
225         - imageslider: check parameter
226         - smallpopup: fix position
227         - searchbar: fix 'clear' button size
228 - Spec changes:
229         - scrollview: support outer scroll
230         - JQM: block click event only with the element that does preventdefault on vclick(N_SE-6090)
231         - remove S/W IME control
232
233 * Thu Sep 13 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.48
234 - FIX:
235         - Add missing icon: controlbar
236         - scrollview: tune scrolling animatio ninterval
237         - datetimepicker: digit/triangle position
238         - datetimepicker: fix day overflow issue
239 - Spec changes:
240         - scrollview: show scrollbar when page is showed
241         - scrollview: disable outer scroll
242         - extendablelist: change api with legacy support
243         - add ui-text-ellipsis class
244
245 * Mon Sep 10 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.47
246 - FIX:
247         - scrollveiw: fix height of view
248         - searchbar: support placeholder
249 - Spec changes:
250         - add ui-text-ellipsis class
251
252 * Fri Sep 07 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.46
253 - FIX:
254         - scrollview: scrolling bug fix
255         - controlbar: fix width of controlbar item
256 - Spec changes:
257         - searchbar: don't hide icon
258         - popup: update JQM poup widget
259
260 * Fri Sep 05 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.45
261 - FIX:
262         - controlbar: set correct controlbar width of last element
263         - slider: get popup enable value correctly
264         - use Date.now() instead of (new Data()).getTime()
265         - popupwindow: fix the background color of popup scroller
266         - listview: add padding-left to expandable list
267         - add ellipsis for title area support
268
269 * Fri Aug 31 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.44
270 - FIX:
271         - swipelist: show list items correctly
272         - datetimepicker: set last day, if day is overflowed
273 - Spec changes:
274         - controlbar: update icons
275
276 * Tue Aug 29 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.43
277 - FIX:
278         - notification: fix typo
279 - Spec changes:
280         - controlbar: update icons
281
282 * Tue Aug 28 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.42
283 - FIX:
284         - multimediaview: video progress bar display normally for too samll
285         - segmentcontrol: remove media query
286         - scrollview: add outer scroll condition
287         - datetimepicker: modify triangle size
288         - popupwindow: set the screen height explicitly
289         - notification: add multiline text
290 - Spec changes:
291         - mutibuttonentry: support new GUI
292         - virtualgrid: support new GUI
293
294 * Mon Aug 27 2012 Jinhyuk Jun <jinhyuk.jun@samsung.com> 0.1.41
295 - FIX:
296         - radio/check button : button size bug fix
297
298 * Fri Aug 24 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.40
299 - FIX:
300         - build error fixed
301
302 * Fri Aug 24 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.39
303 - FIX:
304         - listview: style fix, remove filter placeholder
305         - controlbar: divide styles
306         - scrollview: don't skip dragging when click button or inputbox
307         - slider: trim the text on text slider
308 - Spec changes:
309         - remove gray and blue theme
310         - add white and black theme
311         - support new GUI guide
312
313 * Mon Aug 20 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.38
314 - FIX:
315         - fix coment of version tag
316
317 * Fri Aug 17 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.37
318 - FIX :
319         - button: fix alignment
320         - listview: adjust the main text width
321         - virtualgrid: refactoring
322 - Spec changes:
323         - transition: support JQM 1.1.0 transitions
324         - scrollview: support the outer scroll
325         - notification: remove interval feature
326
327 * Tue Aug 14 2012 Youmin Ha <youmin.ha@samasung.com> 0.1.36
328 - FIX :
329         - checkboxRadio: Add left/right padding
330         - button: custom button & icon position
331         - virtuallist: remove 'recreate' test
332 - Spec changes:
333         - header/footer: enable/disable support
334
335 * Fri Aug 10 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.35
336 - FIX :
337         - expandablelist: modify show animation
338         - virtualgrid: Redesign programming interface
339         - popupwindow: code clean and fixed issues
340         - pagelayout: fix content height
341         - license file update
342         - virtuallist: Change programming interface
343         - datetimepicker: getting days correctly
344         - searchbar: set to hidden when cancel button is hide
345         - White theme title font tuning
346 - Spec changes:
347         - default theme tizen-gray to tizen-white
348         - set default page transition to none
349
350 * Mon Aug 02 2012 Jinhyuk Jun <jinhyuk.jun@samsung.com> 0.1.34
351 - FIX :
352         - Back Button : enlarge backbutton click size for white theme
353 - Feature :
354         - Expandable List : Add refresh api
355 * Mon Aug 02 2012 Jinhyuk Jun <jinhyuk.jun@samsung.com> 0.1.33
356 - FIX :
357         - click event touch threshold tuning
358
359 * Mon Aug 02 2012 Jinhyuk Jun <jinhyuk.jun@samsung.com> 0.1.32
360 - FIX : 
361         - Add back button highlight effect for white theme
362
363 * Mon Aug 01 2012 Jinhyuk Jun <jinhyuk.jun@samsnug.com> 0.1.31
364 - FIX : 
365         - IME checkroutine update, improve relayout on resize event
366         - Add highlight effect for radio button list 
367         - Scrollview : fix condition of updatelayout event
368 - Feature : progressing : add show/hide api
369
370 * Mon Jul 27 2012 Koeun Choi <koeun.choi@samsung.com> 0.1.30
371 - FIX : virtuallist, virtualgrid: Clean up temporary jquery.template object to clear cache
372         add default theme option on buttonMarkup for tizen theme
373         [searchbar] first fix : focus/blur fixed
374         back button does not work when long press
375         scrollview: don't auto scrolling if resizing area is too large
376 - Feature : notification : add api to set the icon at tickernoti
377         demo : update the list sample demo
378         Support tizen default theme
379
380 * Mon Jul 23 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.29
381 - Improvements & Bugfixes
382    - HOTFIX: Revert template function with jquery.template
383
384 * Thu Jul 19 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.28
385 - Improvements & Bugfixes
386    - Fix #WEB-1028: memory leak on virtuallist/virtualgrid
387 - Spec changes
388    - $.tizen.loadTheme() function accepts theme name as arguement
389    - Scrollview supports 'updatelayout' callback
390
391 * Tue Jul 17 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.27
392 - Improvements & Bugfixes
393    - Revert 'preventing long-press popup' patch, to fix backbutton to work in SocialMagazine
394
395 * Tue Jul 17 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.26
396 - Improvements & Bugfixes
397    - Add tizen-white theme package, to make rpm build to be finished
398
399 * Tue Jul 17 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.25
400 - Improvements & Bugfixes
401    - Set 'slide' as default page transition effect, by JQM patch
402
403 * Fri Jul 13 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.24
404 - Improvements & Bugfixes
405    - Fix IME show/hide algorithm
406    - Fix error on virtualgrid: link _set_scrollbar_size() function to the one in virtuallist
407
408 * Wed Jul 11 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.23
409 - Improvements & Bugfixes
410    - Fix notification position
411    - Fix unit tests
412
413  Fri Jul 6 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.22
414 - Spec changes
415         - JQM 1.1 upgrade
416 - Improvements & Bugfixes
417         - Transform3D support on scrollview
418         - Page layout supports IME control
419         - Mapview supports pinch zoom on JQM 1.1
420         - Fix wrong character on button in minified version
421         - Virtualgrid supports scrollbar
422         - Lots of bugfixes
423
424 * Fri Jun 22 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.20
425 - Spec changes
426         - Support 'latest' version (by symlink) for tizen-web-ui-fw.js path.
427         - imageslider : supports 'resize' event.
428         - listview : listview has 1px padding-bottom.
429         - loader : Change global namespace, from S to $.tizen.
430         - loader : Move loadCustomGlobalizeCulture() into $.tizen.util namespace.
431 - Improvements & Bugfixes
432         - Scrollview : supports 'translate3d', instead of 'translate'.
433         - notification : reset timer when 'show' or 'refresh' event.
434         - JQM patch : Fix vclick event triggered twice.
435 - Etc.
436         - Add & fix unit tests.
437
438 * Thu Jun 14 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.19
439 - Spec changes
440         - mapview : new widget.
441         - notification : add .refresh() API.
442         - pagecontrol : add .value([val]) API, and change an attribute name 'data-initVal' to 'data-value'.
443 - Improvements & Bugfixes
444         - Support minified CSS.
445         - loader : Fix & refactor 'loading globalize culture file' routine.
446         - JQM Patch : Calculate min-height of window in javascript code, and remove predefined min-height value from CSS.
447         - Many more bugfixes.
448 - Etc.
449         - Add many unit tests.
450         - Fix test coverage instrumentation tool to work with current source code.