0.2.6 release
[platform/framework/web/web-ui-fw.git] / packaging / web-ui-fw.spec
1 Name:       web-ui-fw
2 Version:    0.2.6
3 Release:    0
4 Summary:    Tizen Web UI Framework Library
5 Group:      Development/Other
6 License:    MIT
7 BuildArch:  noarch
8 BuildRequires:  make
9 BuildRequires:  nodejs
10 %ifarch %{arm}
11 BuildRequires:  nodejs-x86-arm
12 %endif
13
14 Source0:    %{name}-%{version}.tar.gz
15
16 %description
17 Tizen Web UI Framework library and theme packages
18
19 %prep
20 %setup -q
21
22 %build
23 make all
24
25 %install
26 make DESTDIR=%{buildroot} install
27
28 %post
29
30 %files
31 %manifest web-ui-fw.manifest
32 /usr/share/tizen-web-ui-fw/*/js
33 /usr/share/tizen-web-ui-fw/latest
34 /usr/share/tizen-web-ui-fw/VERSION
35
36 ###############################
37 %package -n web-ui-fw-theme-tizen-gray
38 BuildArch:  noarch
39 Summary:    Tizen Web UI Framework Theme : tizen-gray
40 %Description -n web-ui-fw-theme-tizen-gray
41     Tizen Web UI Framework Theme : tizen-gray
42
43 ###############################
44 %package -n web-ui-fw-theme-tizen-white
45 BuildArch:  noarch
46 Summary:    Tizen Web UI Framework Theme : tizen-white
47 %Description -n web-ui-fw-theme-tizen-white
48     Tizen Web UI Framework Theme : tizen-white
49 %files -n web-ui-fw-theme-tizen-white
50 %manifest web-ui-fw-theme-tizen-white.manifest
51 /usr/share/tizen-web-ui-fw/*/themes/tizen-white
52 /usr/share/tizen-web-ui-fw/*/themes/tizen-tizen
53
54 ###############################
55 %package -n web-ui-fw-theme-default
56 BuildArch:  noarch
57 Summary:    Tizen Web UI Framework Theme : default
58 %Description -n web-ui-fw-theme-default
59     Tizen Web UI Framework Theme : default
60 %files -n web-ui-fw-theme-default
61 %manifest web-ui-fw-theme-default.manifest
62 /usr/share/tizen-web-ui-fw/*/themes/default
63
64 ###############################
65 %package -n web-ui-fw-devel
66 BuildArch:  noarch
67 Summary:    Tizen Web UI Framework Developer's files
68 %Description -n web-ui-fw-devel
69     Tizen Web UI Framework Developer's files
70 %files -n web-ui-fw-devel
71 /usr/share/tizen-web-ui-fw/bin
72 /usr/share/tizen-web-ui-fw/template
73
74 ###############################
75 %package -n web-ui-fw-demo-tizen-winsets
76 BuildArch:  noarch
77 Summary:    Tizen Web UI Framework Demo Application: tizen winset demo
78 %Description -n web-ui-fw-demo-tizen-winsets
79     Tizen Web UI Framework Demo Application: tizen winset demo
80 %files  -n web-ui-fw-demo-tizen-winsets
81 /usr/share/tizen-web-ui-fw/demos/tizen-winsets
82
83
84 ###############################
85 %changelog
86 * Fri Jan 04 2013 Minkyu Kang <mk7.kang@samsung.com> 0.2.6
87         - JQM: patches cleanup
88         - Button: data-corners attribute has been added
89         - unit-test: slider: fix class name of background
90         - progressbar, slider: fix less variable typo
91         - Tabbar : VI update
92         - notification: add top position at fix class
93         - demo: entry demo page change
94         - css: .ui-disabled added
95         - tizen-winset: token textarea: remove back button at demo page
96         - theme: Remove unused less file
97         - pagelayout : content min height bug fix
98         - scrollview: skip the dragging when target is slider's handle
99         - scrollview: update and refactoring the scroll effect
100         - UnitTest:JQM Unit TC helper has been added,TCs have been modified
101         - Swipe: demo page html error has been fixed
102         - listview: Add add/delete animation (VI)
103         - Popup: demo page has been modified
104         - tizen demo : bug fix
105         - searchbar : demo page change(change front button and add behaviour)
106         - pagelayout : add min height to content
107         - gallery: rename 'Image Slider' to 'Gallery' in tizen-winsets demo and tests
108         - back button control demo : change url link to data-rel="back"
109         - loader: Skip loading theme CSS with a custom css code
110         - Button: support no-text in button
111         - collapsible: Fix syntax error
112         - slider: use data-highlight attribute
113         - collapsible: Rotate animation to collapsible heading icon
114         - toggleswitch : text switch bug fix
115         - remove candidates-calendarpicker
116         - Patch: Fix misc mistakes in JQM patches
117         - searchbar : animation change
118         - gallery: get the width correctly
119         - demo: data-framework-viewport-scale attribute is changed to data-framework-viewport-width
120         - collapsible: Add collapse/expand animation (VI)
121         - datetimepicker: VI update
122         - JQM: set transition to pop as default
123         - tabbar : bug fix in case none li element case
124         - scrollview: fix the drag bug
125         - Button: Button icon scrolltop, left has beed added
126         - Swipe: VI update and swipe speed has been changed
127         - jqm: fix errors in patch files
128         - unit-test: swipe: fixed the destroy test
129
130 * Wed Dec 26 2012 Youmin Ha <youmin.ha@samsung.com> 0.2.5
131         - Revert "[checkboxradio] exception handling for input"
132                 This reverts commit 72478c32704fa96362db577e6cf9511777919ea8.
133                 Tizen style supports no-label radio and checkbox when making lists.
134                 So it ignores html input operation. Instead, it supports tizen style radio and checkbox theme.
135
136 * Thu Dec 20 2012 Youmin Ha <youmin.ha@samsung.com> 0.2.4
137 - Fix:
138         - modify segment background
139         - rearrange check, radio input
140         - CtxPopup: Scale up/ down popup vi(poptop, popbottom)
141         - button: style has beed added(box,circle,nobg,round)
142         - favorite resource added
143         - demo/tizen-winsets: add footer and back button
144         - remove autodividers unit test
145         - add divider for tabbar
146         - checkboxradio: exception handling for input
147         - segment control backward compatiblity
148         - Fix collapsible unit-test
149         - remove toggleswitch
150         - add patch for remove segment text
151 - Spec changes:
152         - replace controlbar to tabbar
153
154 * Fri Dec 14 2012 Minkyu Kang <mk7.kang@samsung.com> 0.2.3
155 - FIX:
156         - slider: add image
157         - button: data-icon support, styles fix
158         - progressbar: modify the background
159         - scrollview: auto scrolling bug fix
160         - pagelayout: IME concept is changed
161 - Spec changes:
162         - dialogue: add edit mode
163         - nocontents: removed
164         - pagecontrol: removed
165         - dayselector: removed
166         - expandablelist: removed
167
168 * Thu Dec 10 2012 Youmin Ha <youmin.ha@samsung.com> 0.2.2
169 - FIX:
170         - chang searchbar/slider images
171         - delete redundant button images
172 - Spec changes:
173         - Change widget name: shortcutscroll -> fastscroll
174
175 * Thu Dec 07 2012 Youmin Ha <youmin.ha@samsung.com> 0.2.1
176 - FIX:
177         - jqm1.2: Change collapsible style to meet expandable list
178         - remove jquery-geo-1.0.a4
179         - unit-test: rename from imageslider to gallery
180         - nocontent: add warning message
181         - Handler: Fix issues in jqm1.2
182         - Multimediaview: modify APIs & comments
183         - Mapview: Fix issues in jqm1.2
184         - JQM: clean up patches
185         - Swipelist: refactoring swipelist
186         - Popup,Ctxpopup: Apply tizen style popup in JQM1.2
187         - rearrange button's data-icon resources
188 - Spec changes:
189         - Virtualgrid: remove option ('data-itemcount')
190         - gallery: rename the widget from imageslider to gallery
191         - add new style for searchbar
192         [tokentextarea] multi-button entry renamed as token text area. API & comments modified.
193
194 * Thu Dec 06 2012 Minkyu Kang <mk7.kang@samsung.com> 0.2.0
195 - FIX:
196         - fix jslint error
197         - remove unused files
198         - change naviframe style
199 - Spec changes:
200         - applied jQuery Mobile 1.2.0
201         - remove optionheader
202
203 * Fri Nov 30 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.64
204 - FIX:
205         - fix unit tests
206         - remove unused theme files
207         - timepicker: text position fix
208         - scrollview: set dragstop when mouse is out of window
209         - listview: fix margin
210 - Spec changes:
211         - support data-framework-viewport-width
212
213 * Fri Nov 23 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.63
214 - FIX:
215         - dayselector: fix size
216         - remove unised styles
217         - divider: set non-press effect to default option
218         - popupwindow: fix window closing failure
219         - handler: GUI implementation
220         - TC: fix unit TCs
221         - scrollview: fix padding size
222 - Spec changes:
223         - Remove color widgets
224         - add $.tizen.pkgVersion for SDK
225 - Etc.
226         - JSDuck documents
227
228 * Fri Nov 16 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.62
229 - FIX:
230         - Many winsets: Fix layout
231         - Footer: fix position to bottom
232 - Spec changes:
233         - Remove color widgets
234
235 * Fri Nov 09 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.61
236 - FIX:
237         - Many widgets: New UX 0.6 theme implementation
238         - widgetex: init speed up
239         - scrollview: fix scrollbar and scale animation
240         - scrollview: fix scroll position when updatelayout is triggered
241         - header/footer: make textselection disable, except input type="text"
242
243 * Wed Nov 07 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.60
244 - FIX:
245         - Remove tizen-black theme package description
246
247 * Tue Nov 06 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.59
248 - FIX:
249         - Fix theme name to meet the change of system theme name: white->tizen
250         - Popupwindow: fix left position
251         - Remove black theme
252         - footer: remove label, legend drawing
253 - Spec changes:
254         - UX guide v0.4 : button, layout
255
256 * Wed Oct 24 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.57
257 - FIX:
258         - expandablelist: icon color fix
259         - scrollview: Fix xy scroll
260         - footer: Remove dummy div
261         - Make string concatnation effective in inline-protos.sh
262 - Spec changes:
263         - refresh header/footer when drag&drop event is fired in GUI builder
264         - searchbar: delete cancel button
265         - don't trigger updatelayout event when keyup event comes
266
267 * Mon Oct 15 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.56
268 - FIX:
269         - Toggleswitch: Change event name from 'changed' to 'change'
270         - Notification: Revert interval feature
271
272 * Tue Oct 09 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.55
273 - FIX:
274         - Fix SMACK manifest bug (S1-9098)
275
276 * Fri Oct 05 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.54
277 - FIX:
278         - handler: don't append a handler if handler is not enabled
279         - scrollview: use static value
280         - datetimepicker: fix date-format HH display error
281 - ETC:
282         - provide jquery.min.js
283         - barlayout: codes clean
284         - remove unused file
285
286 * Wed Sep 26 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.53
287 - FIX:
288         - listview: change focused color
289         - multibuttonentry: code refactoring
290         - datetimepicker: modify date format when triggered date-changed event
291         - slider: fix the top of slider bar
292         - add event blocker when load a first page
293
294 * Fri Sep 21 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.52
295 - ETC.
296         - Move SMACK manifest files to the top SRCDIR
297
298 * Fri Sep 21 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.51
299 - FIX:
300         - Popup: Do not focus container
301         - Header: show backbutton when both tabbar and header are present together
302         - Multi button entry: text ellipsis, code refactoring
303
304 * Fri Sep 21 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.50
305 - ETC.
306         - Apply SMACK manifest
307
308 * Thu Sep 20 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.49
309 - FIX:
310         - JSLINT code clean-up
311         - scrollview: firefox support
312         - scrollview: fix finding slider handle
313         - list: tweak text ellipsis
314         - checkbox: fix selecting wrong label tag (N_SE-8370)
315         - imageslider: check parameter
316         - smallpopup: fix position
317         - searchbar: fix 'clear' button size
318 - Spec changes:
319         - scrollview: support outer scroll
320         - JQM: block click event only with the element that does preventdefault on vclick(N_SE-6090)
321         - remove S/W IME control
322
323 * Thu Sep 13 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.48
324 - FIX:
325         - Add missing icon: controlbar
326         - scrollview: tune scrolling animatio ninterval
327         - datetimepicker: digit/triangle position
328         - datetimepicker: fix day overflow issue
329 - Spec changes:
330         - scrollview: show scrollbar when page is showed
331         - scrollview: disable outer scroll
332         - extendablelist: change api with legacy support
333         - add ui-text-ellipsis class
334
335 * Mon Sep 10 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.47
336 - FIX:
337         - scrollveiw: fix height of view
338         - searchbar: support placeholder
339 - Spec changes:
340         - add ui-text-ellipsis class
341
342 * Fri Sep 07 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.46
343 - FIX:
344         - scrollview: scrolling bug fix
345         - controlbar: fix width of controlbar item
346 - Spec changes:
347         - searchbar: don't hide icon
348         - popup: update JQM poup widget
349
350 * Fri Sep 05 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.45
351 - FIX:
352         - controlbar: set correct controlbar width of last element
353         - slider: get popup enable value correctly
354         - use Date.now() instead of (new Data()).getTime()
355         - popupwindow: fix the background color of popup scroller
356         - listview: add padding-left to expandable list
357         - add ellipsis for title area support
358
359 * Fri Aug 31 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.44
360 - FIX:
361         - swipelist: show list items correctly
362         - datetimepicker: set last day, if day is overflowed
363 - Spec changes:
364         - controlbar: update icons
365
366 * Tue Aug 29 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.43
367 - FIX:
368         - notification: fix typo
369 - Spec changes:
370         - controlbar: update icons
371
372 * Tue Aug 28 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.42
373 - FIX:
374         - multimediaview: video progress bar display normally for too samll
375         - segmentcontrol: remove media query
376         - scrollview: add outer scroll condition
377         - datetimepicker: modify triangle size
378         - popupwindow: set the screen height explicitly
379         - notification: add multiline text
380 - Spec changes:
381         - mutibuttonentry: support new GUI
382         - virtualgrid: support new GUI
383
384 * Mon Aug 27 2012 Jinhyuk Jun <jinhyuk.jun@samsung.com> 0.1.41
385 - FIX:
386         - radio/check button : button size bug fix
387
388 * Fri Aug 24 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.40
389 - FIX:
390         - build error fixed
391
392 * Fri Aug 24 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.39
393 - FIX:
394         - listview: style fix, remove filter placeholder
395         - controlbar: divide styles
396         - scrollview: don't skip dragging when click button or inputbox
397         - slider: trim the text on text slider
398 - Spec changes:
399         - remove gray and blue theme
400         - add white and black theme
401         - support new GUI guide
402
403 * Mon Aug 20 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.38
404 - FIX:
405         - fix coment of version tag
406
407 * Fri Aug 17 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.37
408 - FIX :
409         - button: fix alignment
410         - listview: adjust the main text width
411         - virtualgrid: refactoring
412 - Spec changes:
413         - transition: support JQM 1.1.0 transitions
414         - scrollview: support the outer scroll
415         - notification: remove interval feature
416
417 * Tue Aug 14 2012 Youmin Ha <youmin.ha@samasung.com> 0.1.36
418 - FIX :
419         - checkboxRadio: Add left/right padding
420         - button: custom button & icon position
421         - virtuallist: remove 'recreate' test
422 - Spec changes:
423         - header/footer: enable/disable support
424
425 * Fri Aug 10 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.35
426 - FIX :
427         - expandablelist: modify show animation
428         - virtualgrid: Redesign programming interface
429         - popupwindow: code clean and fixed issues
430         - pagelayout: fix content height
431         - license file update
432         - virtuallist: Change programming interface
433         - datetimepicker: getting days correctly
434         - searchbar: set to hidden when cancel button is hide
435         - White theme title font tuning
436 - Spec changes:
437         - default theme tizen-gray to tizen-white
438         - set default page transition to none
439
440 * Mon Aug 02 2012 Jinhyuk Jun <jinhyuk.jun@samsung.com> 0.1.34
441 - FIX :
442         - Back Button : enlarge backbutton click size for white theme
443 - Feature :
444         - Expandable List : Add refresh api
445 * Mon Aug 02 2012 Jinhyuk Jun <jinhyuk.jun@samsung.com> 0.1.33
446 - FIX :
447         - click event touch threshold tuning
448
449 * Mon Aug 02 2012 Jinhyuk Jun <jinhyuk.jun@samsung.com> 0.1.32
450 - FIX : 
451         - Add back button highlight effect for white theme
452
453 * Mon Aug 01 2012 Jinhyuk Jun <jinhyuk.jun@samsnug.com> 0.1.31
454 - FIX : 
455         - IME checkroutine update, improve relayout on resize event
456         - Add highlight effect for radio button list 
457         - Scrollview : fix condition of updatelayout event
458 - Feature : progressing : add show/hide api
459
460 * Mon Jul 27 2012 Koeun Choi <koeun.choi@samsung.com> 0.1.30
461 - FIX : virtuallist, virtualgrid: Clean up temporary jquery.template object to clear cache
462         add default theme option on buttonMarkup for tizen theme
463         [searchbar] first fix : focus/blur fixed
464         back button does not work when long press
465         scrollview: don't auto scrolling if resizing area is too large
466 - Feature : notification : add api to set the icon at tickernoti
467         demo : update the list sample demo
468         Support tizen default theme
469
470 * Mon Jul 23 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.29
471 - Improvements & Bugfixes
472    - HOTFIX: Revert template function with jquery.template
473
474 * Thu Jul 19 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.28
475 - Improvements & Bugfixes
476    - Fix #WEB-1028: memory leak on virtuallist/virtualgrid
477 - Spec changes
478    - $.tizen.loadTheme() function accepts theme name as arguement
479    - Scrollview supports 'updatelayout' callback
480
481 * Tue Jul 17 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.27
482 - Improvements & Bugfixes
483    - Revert 'preventing long-press popup' patch, to fix backbutton to work in SocialMagazine
484
485 * Tue Jul 17 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.26
486 - Improvements & Bugfixes
487    - Add tizen-white theme package, to make rpm build to be finished
488
489 * Tue Jul 17 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.25
490 - Improvements & Bugfixes
491    - Set 'slide' as default page transition effect, by JQM patch
492
493 * Fri Jul 13 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.24
494 - Improvements & Bugfixes
495    - Fix IME show/hide algorithm
496    - Fix error on virtualgrid: link _set_scrollbar_size() function to the one in virtuallist
497
498 * Wed Jul 11 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.23
499 - Improvements & Bugfixes
500    - Fix notification position
501    - Fix unit tests
502
503  Fri Jul 6 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.22
504 - Spec changes
505         - JQM 1.1 upgrade
506 - Improvements & Bugfixes
507         - Transform3D support on scrollview
508         - Page layout supports IME control
509         - Mapview supports pinch zoom on JQM 1.1
510         - Fix wrong character on button in minified version
511         - Virtualgrid supports scrollbar
512         - Lots of bugfixes
513
514 * Fri Jun 22 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.20
515 - Spec changes
516         - Support 'latest' version (by symlink) for tizen-web-ui-fw.js path.
517         - imageslider : supports 'resize' event.
518         - listview : listview has 1px padding-bottom.
519         - loader : Change global namespace, from S to $.tizen.
520         - loader : Move loadCustomGlobalizeCulture() into $.tizen.util namespace.
521 - Improvements & Bugfixes
522         - Scrollview : supports 'translate3d', instead of 'translate'.
523         - notification : reset timer when 'show' or 'refresh' event.
524         - JQM patch : Fix vclick event triggered twice.
525 - Etc.
526         - Add & fix unit tests.
527
528 * Thu Jun 14 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.19
529 - Spec changes
530         - mapview : new widget.
531         - notification : add .refresh() API.
532         - pagecontrol : add .value([val]) API, and change an attribute name 'data-initVal' to 'data-value'.
533 - Improvements & Bugfixes
534         - Support minified CSS.
535         - loader : Fix & refactor 'loading globalize culture file' routine.
536         - JQM Patch : Calculate min-height of window in javascript code, and remove predefined min-height value from CSS.
537         - Many more bugfixes.
538 - Etc.
539         - Add many unit tests.
540         - Fix test coverage instrumentation tool to work with current source code.