0.2.13 release
[platform/framework/web/web-ui-fw.git] / packaging / web-ui-fw.spec
1 Name:       web-ui-fw
2 Version:    0.2.13
3 Release:    0
4 Summary:    Tizen Web UI Framework Library
5 Group:      Development/Other
6 License:    MIT
7 BuildArch:  noarch
8 BuildRequires:  make
9 BuildRequires:  nodejs
10 %ifarch %{arm}
11 BuildRequires:  nodejs-x86-arm
12 %endif
13
14 Source0:    %{name}-%{version}.tar.gz
15
16 %description
17 Tizen Web UI Framework library and theme packages
18
19 %prep
20 %setup -q
21
22 %build
23 make all
24
25 %install
26 make DESTDIR=%{buildroot} install
27
28 %post
29
30 %files
31 %manifest web-ui-fw.manifest
32 /usr/share/tizen-web-ui-fw/*/js
33 /usr/share/tizen-web-ui-fw/latest
34 /usr/share/tizen-web-ui-fw/VERSION
35
36 ###############################
37 %package -n web-ui-fw-theme-tizen-gray
38 BuildArch:  noarch
39 Summary:    Tizen Web UI Framework Theme : tizen-gray
40 %Description -n web-ui-fw-theme-tizen-gray
41     Tizen Web UI Framework Theme : tizen-gray
42
43 ###############################
44 %package -n web-ui-fw-theme-tizen-white
45 BuildArch:  noarch
46 Summary:    Tizen Web UI Framework Theme : tizen-white
47 %Description -n web-ui-fw-theme-tizen-white
48     Tizen Web UI Framework Theme : tizen-white
49 %files -n web-ui-fw-theme-tizen-white
50 %manifest web-ui-fw-theme-tizen-white.manifest
51 /usr/share/tizen-web-ui-fw/*/themes/tizen-white
52 /usr/share/tizen-web-ui-fw/*/themes/tizen-tizen
53
54 ###############################
55 %package -n web-ui-fw-theme-default
56 BuildArch:  noarch
57 Summary:    Tizen Web UI Framework Theme : default
58 %Description -n web-ui-fw-theme-default
59     Tizen Web UI Framework Theme : default
60 %files -n web-ui-fw-theme-default
61 %manifest web-ui-fw-theme-default.manifest
62 /usr/share/tizen-web-ui-fw/*/themes/default
63
64 ###############################
65 %package -n web-ui-fw-devel
66 BuildArch:  noarch
67 Summary:    Tizen Web UI Framework Developer's files
68 %Description -n web-ui-fw-devel
69     Tizen Web UI Framework Developer's files
70 %files -n web-ui-fw-devel
71 /usr/share/tizen-web-ui-fw/bin
72 /usr/share/tizen-web-ui-fw/template
73
74 ###############################
75 %package -n web-ui-fw-demo-tizen-winsets
76 BuildArch:  noarch
77 Summary:    Tizen Web UI Framework Demo Application: tizen winset demo
78 %Description -n web-ui-fw-demo-tizen-winsets
79     Tizen Web UI Framework Demo Application: tizen winset demo
80 %files  -n web-ui-fw-demo-tizen-winsets
81 /usr/share/tizen-web-ui-fw/demos/tizen-winsets
82
83
84 ###############################
85 %changelog
86 * Thu Jan 24 2013 Youmin Ha <youmin.ha@samsung.com> 0.2.13
87         - virtuallist: Prevent replacing contents on nonexist element
88         - JQM: Trim text in listitem to get index in autodivider
89         - JQM: Remove trailing whitespace in jqm patch
90         - scrollview: get the height including margin
91         - multimediaview: bug fix ( scrolling in full-screen mode )
92         - virtuallist: set listitem width to exclude listitem left/right margin
93         - demo: fix virtuallist sample layout
94         - progress: set the position explicitly
95         - progress: rename from progressing to progress
96         - build: remove unused files
97         - searchbar: fix jslint errors
98         - src: fix file permissions
99         - button : change jump left icon
100
101 * Wed Jan 23 2013 Minkyu Kang <mk7.kang@samsung.com> 0.2.12
102         - theme : button icon - scrolltop, scrolleft icon changed.
103         - build: cleanaup Makefile
104         - pagelayout: fix jslint error
105         - virtualgrid: Fix jslint errors
106         - tabbar : jslint bug error fix
107         - build: add regexp option to jslint
108         - virtuallist: fix jslint errors
109         - handler: Apply the exceptional principle for scrollbar on Handler.
110         - build: remove unused copyright
111         - loader: extract log class for tizen web, and fix jslint errors
112         - loader: Viewport width is set to document width
113         - popupwindow: fix jslint error
114         - build: fix Makefile for tizen-white theme
115         - build: remove unused libraries
116         - datetimepicker: fix jslint error
117         - slider: fix jslint error
118         - demo: remove deprecated demos
119         - pagelayout : change to call relayout with this page
120         - Tokentextarea: Block size error fixed.
121         - handler: bug fix (handler activation)
122
123 * Tue Jan 22 2013 Minkyu Kang <mk7.kang@samsung.com> 0.2.11
124         - demo: clear input text value with cancel button click
125         - demo: Adjust textarea height automatically
126         - naviframe : bug fix
127         - tabbar : bug fix
128         - Fastscroll: popup position has been changed
129         - Button: custom button icon path, margin have been changed
130         - toggleswitch : bug fix
131         - slider: increase the margin
132         - datetimepicker: close the popup after select the value
133         - unit-test : add page backbutton control test
134         - Demo: added guide text and change input type in list vi
135         - remove legacy codes : jquery-geo
136         - Datetimepicker: text-main max-width has been removed
137         - Radio: control group border has been removed
138         - Demo: remove 'tab' space
139         - UnitTC: swipe unit tc has been fixed
140         - UnitTC: jQuery path has been fixed
141         - Button: bug fix when button has not a text
142         - tizen-winset: timepicker: demo title is changed
143
144 * Fri Jan 18 2013 Minkyu Kang <mk7.kang@samsung.com> 0.2.10
145         - tizen-winsets: codes cleanup
146         - datetimepicker: date calibration when year is changed
147         - Demo: textarea size has been changed
148         - Demo: Naviframe morebutton demo has been changed
149         - remove unused unit test cases : gallery3d
150         - tizen-winset: remove links
151
152 * Thu Jan 17 2013 Minkyu Kang <mk7.kang@samsung.com> 0.2.9
153         - gallery: use timeout function instead of interval
154         - Tokentextarea: Display error fixed.
155         - scrollview: Fix not selector to respond with jQuery1.8.2
156         - tabbar: remove the width of last element
157         - Demo: apply css 'user-select:none'
158         - Button: guide text has been shorten
159         - build: Update jQuery to 1.8.2 (JQM1.2 compliant)
160         - virtuallist: Fix mistyping
161         - demo: Fix tizen function namespace in demo
162         - virtuallist: Rewrite listitem replacing algorithm
163         - fastscroll: modify from not selector to function
164         - extendablelist: Fix unit-test
165         - tabbar : prefix to tabbar scroll event
166         - Popupwindow: removed unvalid selector in jquery 1.8.2
167         - slider: adjust handle text as length of value
168         - Demo: 3 buttons in popup text has been changed
169         - src: codes cleanup
170         - demo : remove trailing empty strings
171         - demo : rename TizenWinset list items
172         - button : change from long text list to multiline list
173         - build: Remove JQM1.1.0 patches
174         - Popup: Apply tizen style popup and attribute support
175         - JQM: Fix buttonmarkup bug keeping ui-btn-down class
176         - UnitTest: folder and file renamed, QUnit path was modified
177         - tizen-winsets: button: fix textarea width
178         - Swipe: event name error has been fixed
179
180 * Tue Jan 15 2013 Minkyu Kang <mk7.kang@samsung.com> 0.2.8
181         - Button: button padding has been updated
182         - virtuallist: fix unique listitem ID bug
183         - checkbox, radio : change display attr
184         - Button: bug fix ( when data style circle button on text )
185         - handler: bug fix (when scrolling with multi selection)
186         - JQM: adjust patch number
187         - gallery: show the widget after pageshow
188         - TokenTextArea : resource add ( press image )
189         - gallery: adds function that set the index to value API
190         - configure: set TIZEN default configures
191         - footer: h tag display attribute value has been changed
192         - buttons : demo bug fix
193         - searchbar : demo page bug fix
194         - tizen demo : bug fix
195         - build: remove JQM1.1.0
196         - Tokentextarea: Fix issues
197         - scrollview: block the multi touch
198         - list : dialogue list demo change
199         - pagelayout : update dynamic control
200         - Demo: Context popup close method has been changed
201
202 * Fri Jan 11 2013 Minkyu Kang <mk7.kang@samsung.com> 0.2.7
203         - slider: set text container's width as text length
204         - Timepicker: li max-width has been changed
205         - remove experimental feature - mapview.
206         - scrollview: added conditions for finding slider
207         - UnitTC: Pass,error count save method has been changed
208         - confix.xml: default config added for tizen basic applications
209         - Swipe: p tag margin value is set '0'
210         - packaging: remove unused file
211         - tabbar : bug fix
212         - list demo : bug fix
213         - tizen-winsets: gallery: move to new section
214         - tizen-winsets: autodivider: removes link of list
215         - demos: entry of number-pattern name is changed from 'number' to 'number-pattern'
216         - pagelayout : padding calculate change, ime footer check changed
217         - tizen-winsets: searchbar: scroll to the top when type the character
218         - searchbar : bug fix
219         - demo: Fix virtuallist demo following new list style
220         - demo: Add word-wrap:break-word and remove parag. width
221         - Demo: button max-width has been set( 3 buttons in popup )
222         - back button control demo : bug fix
223         - toggleswitch : demo page modify
224         - slider: add margin-top and margin-bottom
225         - tabbar demo : bug fix
226         - Popup: IME hide when popup is closed
227         - token textarea : bug fix
228         - Timepicker: change get attribute method
229         - footer demo : bug fix
230         - unit-test: gallery: add new APIs
231         - gallery: adds support new APIs
232
233 * Fri Jan 04 2013 Minkyu Kang <mk7.kang@samsung.com> 0.2.6
234         - JQM: patches cleanup
235         - Button: data-corners attribute has been added
236         - unit-test: slider: fix class name of background
237         - progressbar, slider: fix less variable typo
238         - Tabbar : VI update
239         - notification: add top position at fix class
240         - demo: entry demo page change
241         - css: .ui-disabled added
242         - tizen-winset: token textarea: remove back button at demo page
243         - theme: Remove unused less file
244         - pagelayout : content min height bug fix
245         - scrollview: skip the dragging when target is slider's handle
246         - scrollview: update and refactoring the scroll effect
247         - UnitTest:JQM Unit TC helper has been added,TCs have been modified
248         - Swipe: demo page html error has been fixed
249         - listview: Add add/delete animation (VI)
250         - Popup: demo page has been modified
251         - tizen demo : bug fix
252         - searchbar : demo page change(change front button and add behaviour)
253         - pagelayout : add min height to content
254         - gallery: rename 'Image Slider' to 'Gallery' in tizen-winsets demo and tests
255         - back button control demo : change url link to data-rel="back"
256         - loader: Skip loading theme CSS with a custom css code
257         - Button: support no-text in button
258         - collapsible: Fix syntax error
259         - slider: use data-highlight attribute
260         - collapsible: Rotate animation to collapsible heading icon
261         - toggleswitch : text switch bug fix
262         - remove candidates-calendarpicker
263         - Patch: Fix misc mistakes in JQM patches
264         - searchbar : animation change
265         - gallery: get the width correctly
266         - demo: data-framework-viewport-scale attribute is changed to data-framework-viewport-width
267         - collapsible: Add collapse/expand animation (VI)
268         - datetimepicker: VI update
269         - JQM: set transition to pop as default
270         - tabbar : bug fix in case none li element case
271         - scrollview: fix the drag bug
272         - Button: Button icon scrolltop, left has beed added
273         - Swipe: VI update and swipe speed has been changed
274         - jqm: fix errors in patch files
275         - unit-test: swipe: fixed the destroy test
276
277 * Wed Dec 26 2012 Youmin Ha <youmin.ha@samsung.com> 0.2.5
278         - Revert "[checkboxradio] exception handling for input"
279                 This reverts commit 72478c32704fa96362db577e6cf9511777919ea8.
280                 Tizen style supports no-label radio and checkbox when making lists.
281                 So it ignores html input operation. Instead, it supports tizen style radio and checkbox theme.
282
283 * Thu Dec 20 2012 Youmin Ha <youmin.ha@samsung.com> 0.2.4
284 - Fix:
285         - modify segment background
286         - rearrange check, radio input
287         - CtxPopup: Scale up/ down popup vi(poptop, popbottom)
288         - button: style has beed added(box,circle,nobg,round)
289         - favorite resource added
290         - demo/tizen-winsets: add footer and back button
291         - remove autodividers unit test
292         - add divider for tabbar
293         - checkboxradio: exception handling for input
294         - segment control backward compatiblity
295         - Fix collapsible unit-test
296         - remove toggleswitch
297         - add patch for remove segment text
298 - Spec changes:
299         - replace controlbar to tabbar
300
301 * Fri Dec 14 2012 Minkyu Kang <mk7.kang@samsung.com> 0.2.3
302 - FIX:
303         - slider: add image
304         - button: data-icon support, styles fix
305         - progressbar: modify the background
306         - scrollview: auto scrolling bug fix
307         - pagelayout: IME concept is changed
308 - Spec changes:
309         - dialogue: add edit mode
310         - nocontents: removed
311         - pagecontrol: removed
312         - dayselector: removed
313         - expandablelist: removed
314
315 * Thu Dec 10 2012 Youmin Ha <youmin.ha@samsung.com> 0.2.2
316 - FIX:
317         - chang searchbar/slider images
318         - delete redundant button images
319 - Spec changes:
320         - Change widget name: shortcutscroll -> fastscroll
321
322 * Thu Dec 07 2012 Youmin Ha <youmin.ha@samsung.com> 0.2.1
323 - FIX:
324         - jqm1.2: Change collapsible style to meet expandable list
325         - remove jquery-geo-1.0.a4
326         - unit-test: rename from imageslider to gallery
327         - nocontent: add warning message
328         - Handler: Fix issues in jqm1.2
329         - Multimediaview: modify APIs & comments
330         - Mapview: Fix issues in jqm1.2
331         - JQM: clean up patches
332         - Swipelist: refactoring swipelist
333         - Popup,Ctxpopup: Apply tizen style popup in JQM1.2
334         - rearrange button's data-icon resources
335 - Spec changes:
336         - Virtualgrid: remove option ('data-itemcount')
337         - gallery: rename the widget from imageslider to gallery
338         - add new style for searchbar
339         [tokentextarea] multi-button entry renamed as token text area. API & comments modified.
340
341 * Thu Dec 06 2012 Minkyu Kang <mk7.kang@samsung.com> 0.2.0
342 - FIX:
343         - fix jslint error
344         - remove unused files
345         - change naviframe style
346 - Spec changes:
347         - applied jQuery Mobile 1.2.0
348         - remove optionheader
349
350 * Fri Nov 30 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.64
351 - FIX:
352         - fix unit tests
353         - remove unused theme files
354         - timepicker: text position fix
355         - scrollview: set dragstop when mouse is out of window
356         - listview: fix margin
357 - Spec changes:
358         - support data-framework-viewport-width
359
360 * Fri Nov 23 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.63
361 - FIX:
362         - dayselector: fix size
363         - remove unised styles
364         - divider: set non-press effect to default option
365         - popupwindow: fix window closing failure
366         - handler: GUI implementation
367         - TC: fix unit TCs
368         - scrollview: fix padding size
369 - Spec changes:
370         - Remove color widgets
371         - add $.tizen.pkgVersion for SDK
372 - Etc.
373         - JSDuck documents
374
375 * Fri Nov 16 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.62
376 - FIX:
377         - Many winsets: Fix layout
378         - Footer: fix position to bottom
379 - Spec changes:
380         - Remove color widgets
381
382 * Fri Nov 09 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.61
383 - FIX:
384         - Many widgets: New UX 0.6 theme implementation
385         - widgetex: init speed up
386         - scrollview: fix scrollbar and scale animation
387         - scrollview: fix scroll position when updatelayout is triggered
388         - header/footer: make textselection disable, except input type="text"
389
390 * Wed Nov 07 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.60
391 - FIX:
392         - Remove tizen-black theme package description
393
394 * Tue Nov 06 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.59
395 - FIX:
396         - Fix theme name to meet the change of system theme name: white->tizen
397         - Popupwindow: fix left position
398         - Remove black theme
399         - footer: remove label, legend drawing
400 - Spec changes:
401         - UX guide v0.4 : button, layout
402
403 * Wed Oct 24 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.57
404 - FIX:
405         - expandablelist: icon color fix
406         - scrollview: Fix xy scroll
407         - footer: Remove dummy div
408         - Make string concatnation effective in inline-protos.sh
409 - Spec changes:
410         - refresh header/footer when drag&drop event is fired in GUI builder
411         - searchbar: delete cancel button
412         - don't trigger updatelayout event when keyup event comes
413
414 * Mon Oct 15 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.56
415 - FIX:
416         - Toggleswitch: Change event name from 'changed' to 'change'
417         - Notification: Revert interval feature
418
419 * Tue Oct 09 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.55
420 - FIX:
421         - Fix SMACK manifest bug (S1-9098)
422
423 * Fri Oct 05 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.54
424 - FIX:
425         - handler: don't append a handler if handler is not enabled
426         - scrollview: use static value
427         - datetimepicker: fix date-format HH display error
428 - ETC:
429         - provide jquery.min.js
430         - barlayout: codes clean
431         - remove unused file
432
433 * Wed Sep 26 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.53
434 - FIX:
435         - listview: change focused color
436         - multibuttonentry: code refactoring
437         - datetimepicker: modify date format when triggered date-changed event
438         - slider: fix the top of slider bar
439         - add event blocker when load a first page
440
441 * Fri Sep 21 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.52
442 - ETC.
443         - Move SMACK manifest files to the top SRCDIR
444
445 * Fri Sep 21 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.51
446 - FIX:
447         - Popup: Do not focus container
448         - Header: show backbutton when both tabbar and header are present together
449         - Multi button entry: text ellipsis, code refactoring
450
451 * Fri Sep 21 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.50
452 - ETC.
453         - Apply SMACK manifest
454
455 * Thu Sep 20 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.49
456 - FIX:
457         - JSLINT code clean-up
458         - scrollview: firefox support
459         - scrollview: fix finding slider handle
460         - list: tweak text ellipsis
461         - checkbox: fix selecting wrong label tag (N_SE-8370)
462         - imageslider: check parameter
463         - smallpopup: fix position
464         - searchbar: fix 'clear' button size
465 - Spec changes:
466         - scrollview: support outer scroll
467         - JQM: block click event only with the element that does preventdefault on vclick(N_SE-6090)
468         - remove S/W IME control
469
470 * Thu Sep 13 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.48
471 - FIX:
472         - Add missing icon: controlbar
473         - scrollview: tune scrolling animatio ninterval
474         - datetimepicker: digit/triangle position
475         - datetimepicker: fix day overflow issue
476 - Spec changes:
477         - scrollview: show scrollbar when page is showed
478         - scrollview: disable outer scroll
479         - extendablelist: change api with legacy support
480         - add ui-text-ellipsis class
481
482 * Mon Sep 10 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.47
483 - FIX:
484         - scrollveiw: fix height of view
485         - searchbar: support placeholder
486 - Spec changes:
487         - add ui-text-ellipsis class
488
489 * Fri Sep 07 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.46
490 - FIX:
491         - scrollview: scrolling bug fix
492         - controlbar: fix width of controlbar item
493 - Spec changes:
494         - searchbar: don't hide icon
495         - popup: update JQM poup widget
496
497 * Fri Sep 05 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.45
498 - FIX:
499         - controlbar: set correct controlbar width of last element
500         - slider: get popup enable value correctly
501         - use Date.now() instead of (new Data()).getTime()
502         - popupwindow: fix the background color of popup scroller
503         - listview: add padding-left to expandable list
504         - add ellipsis for title area support
505
506 * Fri Aug 31 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.44
507 - FIX:
508         - swipelist: show list items correctly
509         - datetimepicker: set last day, if day is overflowed
510 - Spec changes:
511         - controlbar: update icons
512
513 * Tue Aug 29 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.43
514 - FIX:
515         - notification: fix typo
516 - Spec changes:
517         - controlbar: update icons
518
519 * Tue Aug 28 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.42
520 - FIX:
521         - multimediaview: video progress bar display normally for too samll
522         - segmentcontrol: remove media query
523         - scrollview: add outer scroll condition
524         - datetimepicker: modify triangle size
525         - popupwindow: set the screen height explicitly
526         - notification: add multiline text
527 - Spec changes:
528         - mutibuttonentry: support new GUI
529         - virtualgrid: support new GUI
530
531 * Mon Aug 27 2012 Jinhyuk Jun <jinhyuk.jun@samsung.com> 0.1.41
532 - FIX:
533         - radio/check button : button size bug fix
534
535 * Fri Aug 24 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.40
536 - FIX:
537         - build error fixed
538
539 * Fri Aug 24 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.39
540 - FIX:
541         - listview: style fix, remove filter placeholder
542         - controlbar: divide styles
543         - scrollview: don't skip dragging when click button or inputbox
544         - slider: trim the text on text slider
545 - Spec changes:
546         - remove gray and blue theme
547         - add white and black theme
548         - support new GUI guide
549
550 * Mon Aug 20 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.38
551 - FIX:
552         - fix coment of version tag
553
554 * Fri Aug 17 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.37
555 - FIX :
556         - button: fix alignment
557         - listview: adjust the main text width
558         - virtualgrid: refactoring
559 - Spec changes:
560         - transition: support JQM 1.1.0 transitions
561         - scrollview: support the outer scroll
562         - notification: remove interval feature
563
564 * Tue Aug 14 2012 Youmin Ha <youmin.ha@samasung.com> 0.1.36
565 - FIX :
566         - checkboxRadio: Add left/right padding
567         - button: custom button & icon position
568         - virtuallist: remove 'recreate' test
569 - Spec changes:
570         - header/footer: enable/disable support
571
572 * Fri Aug 10 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.35
573 - FIX :
574         - expandablelist: modify show animation
575         - virtualgrid: Redesign programming interface
576         - popupwindow: code clean and fixed issues
577         - pagelayout: fix content height
578         - license file update
579         - virtuallist: Change programming interface
580         - datetimepicker: getting days correctly
581         - searchbar: set to hidden when cancel button is hide
582         - White theme title font tuning
583 - Spec changes:
584         - default theme tizen-gray to tizen-white
585         - set default page transition to none
586
587 * Mon Aug 02 2012 Jinhyuk Jun <jinhyuk.jun@samsung.com> 0.1.34
588 - FIX :
589         - Back Button : enlarge backbutton click size for white theme
590 - Feature :
591         - Expandable List : Add refresh api
592 * Mon Aug 02 2012 Jinhyuk Jun <jinhyuk.jun@samsung.com> 0.1.33
593 - FIX :
594         - click event touch threshold tuning
595
596 * Mon Aug 02 2012 Jinhyuk Jun <jinhyuk.jun@samsung.com> 0.1.32
597 - FIX : 
598         - Add back button highlight effect for white theme
599
600 * Mon Aug 01 2012 Jinhyuk Jun <jinhyuk.jun@samsnug.com> 0.1.31
601 - FIX : 
602         - IME checkroutine update, improve relayout on resize event
603         - Add highlight effect for radio button list 
604         - Scrollview : fix condition of updatelayout event
605 - Feature : progressing : add show/hide api
606
607 * Mon Jul 27 2012 Koeun Choi <koeun.choi@samsung.com> 0.1.30
608 - FIX : virtuallist, virtualgrid: Clean up temporary jquery.template object to clear cache
609         add default theme option on buttonMarkup for tizen theme
610         [searchbar] first fix : focus/blur fixed
611         back button does not work when long press
612         scrollview: don't auto scrolling if resizing area is too large
613 - Feature : notification : add api to set the icon at tickernoti
614         demo : update the list sample demo
615         Support tizen default theme
616
617 * Mon Jul 23 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.29
618 - Improvements & Bugfixes
619    - HOTFIX: Revert template function with jquery.template
620
621 * Thu Jul 19 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.28
622 - Improvements & Bugfixes
623    - Fix #WEB-1028: memory leak on virtuallist/virtualgrid
624 - Spec changes
625    - $.tizen.loadTheme() function accepts theme name as arguement
626    - Scrollview supports 'updatelayout' callback
627
628 * Tue Jul 17 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.27
629 - Improvements & Bugfixes
630    - Revert 'preventing long-press popup' patch, to fix backbutton to work in SocialMagazine
631
632 * Tue Jul 17 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.26
633 - Improvements & Bugfixes
634    - Add tizen-white theme package, to make rpm build to be finished
635
636 * Tue Jul 17 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.25
637 - Improvements & Bugfixes
638    - Set 'slide' as default page transition effect, by JQM patch
639
640 * Fri Jul 13 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.24
641 - Improvements & Bugfixes
642    - Fix IME show/hide algorithm
643    - Fix error on virtualgrid: link _set_scrollbar_size() function to the one in virtuallist
644
645 * Wed Jul 11 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.23
646 - Improvements & Bugfixes
647    - Fix notification position
648    - Fix unit tests
649
650  Fri Jul 6 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.22
651 - Spec changes
652         - JQM 1.1 upgrade
653 - Improvements & Bugfixes
654         - Transform3D support on scrollview
655         - Page layout supports IME control
656         - Mapview supports pinch zoom on JQM 1.1
657         - Fix wrong character on button in minified version
658         - Virtualgrid supports scrollbar
659         - Lots of bugfixes
660
661 * Fri Jun 22 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.20
662 - Spec changes
663         - Support 'latest' version (by symlink) for tizen-web-ui-fw.js path.
664         - imageslider : supports 'resize' event.
665         - listview : listview has 1px padding-bottom.
666         - loader : Change global namespace, from S to $.tizen.
667         - loader : Move loadCustomGlobalizeCulture() into $.tizen.util namespace.
668 - Improvements & Bugfixes
669         - Scrollview : supports 'translate3d', instead of 'translate'.
670         - notification : reset timer when 'show' or 'refresh' event.
671         - JQM patch : Fix vclick event triggered twice.
672 - Etc.
673         - Add & fix unit tests.
674
675 * Thu Jun 14 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.19
676 - Spec changes
677         - mapview : new widget.
678         - notification : add .refresh() API.
679         - pagecontrol : add .value([val]) API, and change an attribute name 'data-initVal' to 'data-value'.
680 - Improvements & Bugfixes
681         - Support minified CSS.
682         - loader : Fix & refactor 'loading globalize culture file' routine.
683         - JQM Patch : Calculate min-height of window in javascript code, and remove predefined min-height value from CSS.
684         - Many more bugfixes.
685 - Etc.
686         - Add many unit tests.
687         - Fix test coverage instrumentation tool to work with current source code.