Export 0.1.57
[platform/framework/web/web-ui-fw.git] / packaging / web-ui-fw.spec
1 Name:       web-ui-fw
2 Version:    0.1.57
3 Release:    0
4 Summary:    Tizen Web UI Framework Library
5 Group:      Development/Other
6 License:    MIT
7 BuildArch:  noarch
8 BuildRequires:  make
9 BuildRequires:  nodejs
10 %ifarch %{arm}
11 BuildRequires:  nodejs-x86-arm
12 %endif
13
14 Source0:    %{name}-%{version}.tar.gz
15
16 %description
17 Tizen Web UI Framework library and theme packages
18
19 %prep
20 %setup -q
21
22 %build
23 make all
24
25 %install
26 make DESTDIR=%{buildroot} install
27
28 %post
29
30 %files
31 %manifest web-ui-fw.manifest
32 /usr/share/tizen-web-ui-fw/*/js
33 /usr/share/tizen-web-ui-fw/latest
34
35 ###############################
36 %package -n web-ui-fw-theme-tizen-gray
37 BuildArch:  noarch
38 Summary:    Tizen Web UI Framework Theme : tizen-gray
39 %Description -n web-ui-fw-theme-tizen-gray
40     Tizen Web UI Framework Theme : tizen-gray
41
42 ###############################
43 %package -n web-ui-fw-theme-tizen-black
44 BuildArch:  noarch
45 Summary:    Tizen Web UI Framework Theme : tizen-black
46 %Description -n web-ui-fw-theme-tizen-black
47     Tizen Web UI Framework Theme : tizen-black
48 %files -n web-ui-fw-theme-tizen-black
49 %manifest web-ui-fw-theme-tizen-black.manifest
50 /usr/share/tizen-web-ui-fw/*/themes/tizen-black
51
52 ###############################
53 %package -n web-ui-fw-theme-tizen-white
54 BuildArch:  noarch
55 Summary:    Tizen Web UI Framework Theme : tizen-white
56 %Description -n web-ui-fw-theme-tizen-white
57     Tizen Web UI Framework Theme : tizen-white
58 %files -n web-ui-fw-theme-tizen-white
59 %manifest web-ui-fw-theme-tizen-white.manifest
60 /usr/share/tizen-web-ui-fw/*/themes/tizen-white
61
62 ###############################
63 %package -n web-ui-fw-theme-default
64 BuildArch:  noarch
65 Summary:    Tizen Web UI Framework Theme : default
66 %Description -n web-ui-fw-theme-default
67     Tizen Web UI Framework Theme : default
68 %files -n web-ui-fw-theme-default
69 %manifest web-ui-fw-theme-default.manifest
70 /usr/share/tizen-web-ui-fw/*/themes/default
71
72 ###############################
73 %package -n web-ui-fw-devel
74 BuildArch:  noarch
75 Summary:    Tizen Web UI Framework Developer's files
76 %Description -n web-ui-fw-devel
77     Tizen Web UI Framework Developer's files
78 %files -n web-ui-fw-devel
79 /usr/share/tizen-web-ui-fw/bin
80 /usr/share/tizen-web-ui-fw/template
81
82 ###############################
83 %package -n web-ui-fw-demo-tizen-winsets
84 BuildArch:  noarch
85 Summary:    Tizen Web UI Framework Demo Application: tizen winset demo
86 %Description -n web-ui-fw-demo-tizen-winsets
87     Tizen Web UI Framework Demo Application: tizen winset demo
88 %files  -n web-ui-fw-demo-tizen-winsets
89 /usr/share/tizen-web-ui-fw/demos/tizen-winsets
90
91
92 ###############################
93 %changelog
94 * Wed Oct 24 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.57
95 - FIX:
96         - expandablelist: icon color fix
97         - scrollview: Fix xy scroll
98         - footer: Remove dummy div
99         - Make string concatnation effective in inline-protos.sh
100 - Spec changes:
101         - refresh header/footer when drag&drop event is fired in GUI builder
102         - searchbar: delete cancel button
103         - don't trigger updatelayout event when keyup event comes
104
105 * Mon Oct 15 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.56
106 - FIX:
107         - Toggleswitch: Change event name from 'changed' to 'change'
108         - Notification: Revert interval feature
109
110 * Tue Oct 09 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.55
111 - FIX:
112         - Fix SMACK manifest bug (S1-9098)
113
114 * Fri Oct 05 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.54
115 - FIX:
116         - handler: don't append a handler if handler is not enabled
117         - scrollview: use static value
118         - datetimepicker: fix date-format HH display error
119 - ETC:
120         - provide jquery.min.js
121         - barlayout: codes clean
122         - remove unused file
123
124 * Wed Sep 26 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.53
125 - FIX:
126         - listview: change focused color
127         - multibuttonentry: code refactoring
128         - datetimepicker: modify date format when triggered date-changed event
129         - slider: fix the top of slider bar
130         - add event blocker when load a first page
131
132 * Fri Sep 21 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.52
133 - ETC.
134         - Move SMACK manifest files to the top SRCDIR
135
136 * Fri Sep 21 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.51
137 - FIX:
138         - Popup: Do not focus container
139         - Header: show backbutton when both tabbar and header are present together
140         - Multi button entry: text ellipsis, code refactoring
141
142 * Fri Sep 21 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.50
143 - ETC.
144         - Apply SMACK manifest
145
146 * Thu Sep 20 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.49
147 - FIX:
148         - JSLINT code clean-up
149         - scrollview: firefox support
150         - scrollview: fix finding slider handle
151         - list: tweak text ellipsis
152         - checkbox: fix selecting wrong label tag (N_SE-8370)
153         - imageslider: check parameter
154         - smallpopup: fix position
155         - searchbar: fix 'clear' button size
156 - Spec changes:
157         - scrollview: support outer scroll
158         - JQM: block click event only with the element that does preventdefault on vclick(N_SE-6090)
159         - remove S/W IME control
160
161 * Thu Sep 13 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.48
162 - FIX:
163         - Add missing icon: controlbar
164         - scrollview: tune scrolling animatio ninterval
165         - datetimepicker: digit/triangle position
166         - datetimepicker: fix day overflow issue
167 - Spec changes:
168         - scrollview: show scrollbar when page is showed
169         - scrollview: disable outer scroll
170         - extendablelist: change api with legacy support
171         - add ui-text-ellipsis class
172
173 * Mon Sep 10 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.47
174 - FIX:
175         - scrollveiw: fix height of view
176         - searchbar: support placeholder
177 - Spec changes:
178         - add ui-text-ellipsis class
179
180 * Fri Sep 07 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.46
181 - FIX:
182         - scrollview: scrolling bug fix
183         - controlbar: fix width of controlbar item
184 - Spec changes:
185         - searchbar: don't hide icon
186         - popup: update JQM poup widget
187
188 * Fri Sep 05 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.45
189 - FIX:
190         - controlbar: set correct controlbar width of last element
191         - slider: get popup enable value correctly
192         - use Date.now() instead of (new Data()).getTime()
193         - popupwindow: fix the background color of popup scroller
194         - listview: add padding-left to expandable list
195         - add ellipsis for title area support
196
197 * Fri Aug 31 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.44
198 - FIX:
199         - swipelist: show list items correctly
200         - datetimepicker: set last day, if day is overflowed
201 - Spec changes:
202         - controlbar: update icons
203
204 * Tue Aug 29 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.43
205 - FIX:
206         - notification: fix typo
207 - Spec changes:
208         - controlbar: update icons
209
210 * Tue Aug 28 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.42
211 - FIX:
212         - multimediaview: video progress bar display normally for too samll
213         - segmentcontrol: remove media query
214         - scrollview: add outer scroll condition
215         - datetimepicker: modify triangle size
216         - popupwindow: set the screen height explicitly
217         - notification: add multiline text
218 - Spec changes:
219         - mutibuttonentry: support new GUI
220         - virtualgrid: support new GUI
221
222 * Mon Aug 27 2012 Jinhyuk Jun <jinhyuk.jun@samsung.com> 0.1.41
223 - FIX:
224         - radio/check button : button size bug fix
225
226 * Fri Aug 24 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.40
227 - FIX:
228         - build error fixed
229
230 * Fri Aug 24 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.39
231 - FIX:
232         - listview: style fix, remove filter placeholder
233         - controlbar: divide styles
234         - scrollview: don't skip dragging when click button or inputbox
235         - slider: trim the text on text slider
236 - Spec changes:
237         - remove gray and blue theme
238         - add white and black theme
239         - support new GUI guide
240
241 * Mon Aug 20 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.38
242 - FIX:
243         - fix coment of version tag
244
245 * Fri Aug 17 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.37
246 - FIX :
247         - button: fix alignment
248         - listview: adjust the main text width
249         - virtualgrid: refactoring
250 - Spec changes:
251         - transition: support JQM 1.1.0 transitions
252         - scrollview: support the outer scroll
253         - notification: remove interval feature
254
255 * Tue Aug 14 2012 Youmin Ha <youmin.ha@samasung.com> 0.1.36
256 - FIX :
257         - checkboxRadio: Add left/right padding
258         - button: custom button & icon position
259         - virtuallist: remove 'recreate' test
260 - Spec changes:
261         - header/footer: enable/disable support
262
263 * Fri Aug 10 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.35
264 - FIX :
265         - expandablelist: modify show animation
266         - virtualgrid: Redesign programming interface
267         - popupwindow: code clean and fixed issues
268         - pagelayout: fix content height
269         - license file update
270         - virtuallist: Change programming interface
271         - datetimepicker: getting days correctly
272         - searchbar: set to hidden when cancel button is hide
273         - White theme title font tuning
274 - Spec changes:
275         - default theme tizen-gray to tizen-white
276         - set default page transition to none
277
278 * Mon Aug 02 2012 Jinhyuk Jun <jinhyuk.jun@samsung.com> 0.1.34
279 - FIX :
280         - Back Button : enlarge backbutton click size for white theme
281 - Feature :
282         - Expandable List : Add refresh api
283 * Mon Aug 02 2012 Jinhyuk Jun <jinhyuk.jun@samsung.com> 0.1.33
284 - FIX :
285         - click event touch threshold tuning
286
287 * Mon Aug 02 2012 Jinhyuk Jun <jinhyuk.jun@samsung.com> 0.1.32
288 - FIX : 
289         - Add back button highlight effect for white theme
290
291 * Mon Aug 01 2012 Jinhyuk Jun <jinhyuk.jun@samsnug.com> 0.1.31
292 - FIX : 
293         - IME checkroutine update, improve relayout on resize event
294         - Add highlight effect for radio button list 
295         - Scrollview : fix condition of updatelayout event
296 - Feature : progressing : add show/hide api
297
298 * Mon Jul 27 2012 Koeun Choi <koeun.choi@samsung.com> 0.1.30
299 - FIX : virtuallist, virtualgrid: Clean up temporary jquery.template object to clear cache
300         add default theme option on buttonMarkup for tizen theme
301         [searchbar] first fix : focus/blur fixed
302         back button does not work when long press
303         scrollview: don't auto scrolling if resizing area is too large
304 - Feature : notification : add api to set the icon at tickernoti
305         demo : update the list sample demo
306         Support tizen default theme
307
308 * Mon Jul 23 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.29
309 - Improvements & Bugfixes
310    - HOTFIX: Revert template function with jquery.template
311
312 * Thu Jul 19 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.28
313 - Improvements & Bugfixes
314    - Fix #WEB-1028: memory leak on virtuallist/virtualgrid
315 - Spec changes
316    - $.tizen.loadTheme() function accepts theme name as arguement
317    - Scrollview supports 'updatelayout' callback
318
319 * Tue Jul 17 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.27
320 - Improvements & Bugfixes
321    - Revert 'preventing long-press popup' patch, to fix backbutton to work in SocialMagazine
322
323 * Tue Jul 17 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.26
324 - Improvements & Bugfixes
325    - Add tizen-white theme package, to make rpm build to be finished
326
327 * Tue Jul 17 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.25
328 - Improvements & Bugfixes
329    - Set 'slide' as default page transition effect, by JQM patch
330
331 * Fri Jul 13 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.24
332 - Improvements & Bugfixes
333    - Fix IME show/hide algorithm
334    - Fix error on virtualgrid: link _set_scrollbar_size() function to the one in virtuallist
335
336 * Wed Jul 11 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.23
337 - Improvements & Bugfixes
338    - Fix notification position
339    - Fix unit tests
340
341  Fri Jul 6 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.22
342 - Spec changes
343         - JQM 1.1 upgrade
344 - Improvements & Bugfixes
345         - Transform3D support on scrollview
346         - Page layout supports IME control
347         - Mapview supports pinch zoom on JQM 1.1
348         - Fix wrong character on button in minified version
349         - Virtualgrid supports scrollbar
350         - Lots of bugfixes
351
352 * Fri Jun 22 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.20
353 - Spec changes
354         - Support 'latest' version (by symlink) for tizen-web-ui-fw.js path.
355         - imageslider : supports 'resize' event.
356         - listview : listview has 1px padding-bottom.
357         - loader : Change global namespace, from S to $.tizen.
358         - loader : Move loadCustomGlobalizeCulture() into $.tizen.util namespace.
359 - Improvements & Bugfixes
360         - Scrollview : supports 'translate3d', instead of 'translate'.
361         - notification : reset timer when 'show' or 'refresh' event.
362         - JQM patch : Fix vclick event triggered twice.
363 - Etc.
364         - Add & fix unit tests.
365
366 * Thu Jun 14 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.19
367 - Spec changes
368         - mapview : new widget.
369         - notification : add .refresh() API.
370         - pagecontrol : add .value([val]) API, and change an attribute name 'data-initVal' to 'data-value'.
371 - Improvements & Bugfixes
372         - Support minified CSS.
373         - loader : Fix & refactor 'loading globalize culture file' routine.
374         - JQM Patch : Calculate min-height of window in javascript code, and remove predefined min-height value from CSS.
375         - Many more bugfixes.
376 - Etc.
377         - Add many unit tests.
378         - Fix test coverage instrumentation tool to work with current source code.