0.2.7 release
[platform/framework/web/web-ui-fw.git] / packaging / web-ui-fw.spec
1 Name:       web-ui-fw
2 Version:    0.2.7
3 Release:    0
4 Summary:    Tizen Web UI Framework Library
5 Group:      Development/Other
6 License:    MIT
7 BuildArch:  noarch
8 BuildRequires:  make
9 BuildRequires:  nodejs
10 %ifarch %{arm}
11 BuildRequires:  nodejs-x86-arm
12 %endif
13
14 Source0:    %{name}-%{version}.tar.gz
15
16 %description
17 Tizen Web UI Framework library and theme packages
18
19 %prep
20 %setup -q
21
22 %build
23 make all
24
25 %install
26 make DESTDIR=%{buildroot} install
27
28 %post
29
30 %files
31 %manifest web-ui-fw.manifest
32 /usr/share/tizen-web-ui-fw/*/js
33 /usr/share/tizen-web-ui-fw/latest
34 /usr/share/tizen-web-ui-fw/VERSION
35
36 ###############################
37 %package -n web-ui-fw-theme-tizen-gray
38 BuildArch:  noarch
39 Summary:    Tizen Web UI Framework Theme : tizen-gray
40 %Description -n web-ui-fw-theme-tizen-gray
41     Tizen Web UI Framework Theme : tizen-gray
42
43 ###############################
44 %package -n web-ui-fw-theme-tizen-white
45 BuildArch:  noarch
46 Summary:    Tizen Web UI Framework Theme : tizen-white
47 %Description -n web-ui-fw-theme-tizen-white
48     Tizen Web UI Framework Theme : tizen-white
49 %files -n web-ui-fw-theme-tizen-white
50 %manifest web-ui-fw-theme-tizen-white.manifest
51 /usr/share/tizen-web-ui-fw/*/themes/tizen-white
52 /usr/share/tizen-web-ui-fw/*/themes/tizen-tizen
53
54 ###############################
55 %package -n web-ui-fw-theme-default
56 BuildArch:  noarch
57 Summary:    Tizen Web UI Framework Theme : default
58 %Description -n web-ui-fw-theme-default
59     Tizen Web UI Framework Theme : default
60 %files -n web-ui-fw-theme-default
61 %manifest web-ui-fw-theme-default.manifest
62 /usr/share/tizen-web-ui-fw/*/themes/default
63
64 ###############################
65 %package -n web-ui-fw-devel
66 BuildArch:  noarch
67 Summary:    Tizen Web UI Framework Developer's files
68 %Description -n web-ui-fw-devel
69     Tizen Web UI Framework Developer's files
70 %files -n web-ui-fw-devel
71 /usr/share/tizen-web-ui-fw/bin
72 /usr/share/tizen-web-ui-fw/template
73
74 ###############################
75 %package -n web-ui-fw-demo-tizen-winsets
76 BuildArch:  noarch
77 Summary:    Tizen Web UI Framework Demo Application: tizen winset demo
78 %Description -n web-ui-fw-demo-tizen-winsets
79     Tizen Web UI Framework Demo Application: tizen winset demo
80 %files  -n web-ui-fw-demo-tizen-winsets
81 /usr/share/tizen-web-ui-fw/demos/tizen-winsets
82
83
84 ###############################
85 %changelog
86
87 * Fri Jan 11 2013 Minkyu Kang <mk7.kang@samsung.com> 0.2.7
88         - slider: set text container's width as text length
89         - Timepicker: li max-width has been changed
90         - remove experimental feature - mapview.
91         - scrollview: added conditions for finding slider
92         - UnitTC: Pass,error count save method has been changed
93         - confix.xml: default config added for tizen basic applications
94         - Swipe: p tag margin value is set '0'
95         - packaging: remove unused file
96         - tabbar : bug fix
97         - list demo : bug fix
98         - tizen-winsets: gallery: move to new section
99         - tizen-winsets: autodivider: removes link of list
100         - demos: entry of number-pattern name is changed from 'number' to 'number-pattern'
101         - pagelayout : padding calculate change, ime footer check changed
102         - tizen-winsets: searchbar: scroll to the top when type the character
103         - searchbar : bug fix
104         - demo: Fix virtuallist demo following new list style
105         - demo: Add word-wrap:break-word and remove parag. width
106         - Demo: button max-width has been set( 3 buttons in popup )
107         - back button control demo : bug fix
108         - toggleswitch : demo page modify
109         - slider: add margin-top and margin-bottom
110         - tabbar demo : bug fix
111         - Popup: IME hide when popup is closed
112         - token textarea : bug fix
113         - Timepicker: change get attribute method
114         - footer demo : bug fix
115         - unit-test: gallery: add new APIs
116         - gallery: adds support new APIs
117
118 * Fri Jan 04 2013 Minkyu Kang <mk7.kang@samsung.com> 0.2.6
119         - JQM: patches cleanup
120         - Button: data-corners attribute has been added
121         - unit-test: slider: fix class name of background
122         - progressbar, slider: fix less variable typo
123         - Tabbar : VI update
124         - notification: add top position at fix class
125         - demo: entry demo page change
126         - css: .ui-disabled added
127         - tizen-winset: token textarea: remove back button at demo page
128         - theme: Remove unused less file
129         - pagelayout : content min height bug fix
130         - scrollview: skip the dragging when target is slider's handle
131         - scrollview: update and refactoring the scroll effect
132         - UnitTest:JQM Unit TC helper has been added,TCs have been modified
133         - Swipe: demo page html error has been fixed
134         - listview: Add add/delete animation (VI)
135         - Popup: demo page has been modified
136         - tizen demo : bug fix
137         - searchbar : demo page change(change front button and add behaviour)
138         - pagelayout : add min height to content
139         - gallery: rename 'Image Slider' to 'Gallery' in tizen-winsets demo and tests
140         - back button control demo : change url link to data-rel="back"
141         - loader: Skip loading theme CSS with a custom css code
142         - Button: support no-text in button
143         - collapsible: Fix syntax error
144         - slider: use data-highlight attribute
145         - collapsible: Rotate animation to collapsible heading icon
146         - toggleswitch : text switch bug fix
147         - remove candidates-calendarpicker
148         - Patch: Fix misc mistakes in JQM patches
149         - searchbar : animation change
150         - gallery: get the width correctly
151         - demo: data-framework-viewport-scale attribute is changed to data-framework-viewport-width
152         - collapsible: Add collapse/expand animation (VI)
153         - datetimepicker: VI update
154         - JQM: set transition to pop as default
155         - tabbar : bug fix in case none li element case
156         - scrollview: fix the drag bug
157         - Button: Button icon scrolltop, left has beed added
158         - Swipe: VI update and swipe speed has been changed
159         - jqm: fix errors in patch files
160         - unit-test: swipe: fixed the destroy test
161
162 * Wed Dec 26 2012 Youmin Ha <youmin.ha@samsung.com> 0.2.5
163         - Revert "[checkboxradio] exception handling for input"
164                 This reverts commit 72478c32704fa96362db577e6cf9511777919ea8.
165                 Tizen style supports no-label radio and checkbox when making lists.
166                 So it ignores html input operation. Instead, it supports tizen style radio and checkbox theme.
167
168 * Thu Dec 20 2012 Youmin Ha <youmin.ha@samsung.com> 0.2.4
169 - Fix:
170         - modify segment background
171         - rearrange check, radio input
172         - CtxPopup: Scale up/ down popup vi(poptop, popbottom)
173         - button: style has beed added(box,circle,nobg,round)
174         - favorite resource added
175         - demo/tizen-winsets: add footer and back button
176         - remove autodividers unit test
177         - add divider for tabbar
178         - checkboxradio: exception handling for input
179         - segment control backward compatiblity
180         - Fix collapsible unit-test
181         - remove toggleswitch
182         - add patch for remove segment text
183 - Spec changes:
184         - replace controlbar to tabbar
185
186 * Fri Dec 14 2012 Minkyu Kang <mk7.kang@samsung.com> 0.2.3
187 - FIX:
188         - slider: add image
189         - button: data-icon support, styles fix
190         - progressbar: modify the background
191         - scrollview: auto scrolling bug fix
192         - pagelayout: IME concept is changed
193 - Spec changes:
194         - dialogue: add edit mode
195         - nocontents: removed
196         - pagecontrol: removed
197         - dayselector: removed
198         - expandablelist: removed
199
200 * Thu Dec 10 2012 Youmin Ha <youmin.ha@samsung.com> 0.2.2
201 - FIX:
202         - chang searchbar/slider images
203         - delete redundant button images
204 - Spec changes:
205         - Change widget name: shortcutscroll -> fastscroll
206
207 * Thu Dec 07 2012 Youmin Ha <youmin.ha@samsung.com> 0.2.1
208 - FIX:
209         - jqm1.2: Change collapsible style to meet expandable list
210         - remove jquery-geo-1.0.a4
211         - unit-test: rename from imageslider to gallery
212         - nocontent: add warning message
213         - Handler: Fix issues in jqm1.2
214         - Multimediaview: modify APIs & comments
215         - Mapview: Fix issues in jqm1.2
216         - JQM: clean up patches
217         - Swipelist: refactoring swipelist
218         - Popup,Ctxpopup: Apply tizen style popup in JQM1.2
219         - rearrange button's data-icon resources
220 - Spec changes:
221         - Virtualgrid: remove option ('data-itemcount')
222         - gallery: rename the widget from imageslider to gallery
223         - add new style for searchbar
224         [tokentextarea] multi-button entry renamed as token text area. API & comments modified.
225
226 * Thu Dec 06 2012 Minkyu Kang <mk7.kang@samsung.com> 0.2.0
227 - FIX:
228         - fix jslint error
229         - remove unused files
230         - change naviframe style
231 - Spec changes:
232         - applied jQuery Mobile 1.2.0
233         - remove optionheader
234
235 * Fri Nov 30 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.64
236 - FIX:
237         - fix unit tests
238         - remove unused theme files
239         - timepicker: text position fix
240         - scrollview: set dragstop when mouse is out of window
241         - listview: fix margin
242 - Spec changes:
243         - support data-framework-viewport-width
244
245 * Fri Nov 23 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.63
246 - FIX:
247         - dayselector: fix size
248         - remove unised styles
249         - divider: set non-press effect to default option
250         - popupwindow: fix window closing failure
251         - handler: GUI implementation
252         - TC: fix unit TCs
253         - scrollview: fix padding size
254 - Spec changes:
255         - Remove color widgets
256         - add $.tizen.pkgVersion for SDK
257 - Etc.
258         - JSDuck documents
259
260 * Fri Nov 16 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.62
261 - FIX:
262         - Many winsets: Fix layout
263         - Footer: fix position to bottom
264 - Spec changes:
265         - Remove color widgets
266
267 * Fri Nov 09 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.61
268 - FIX:
269         - Many widgets: New UX 0.6 theme implementation
270         - widgetex: init speed up
271         - scrollview: fix scrollbar and scale animation
272         - scrollview: fix scroll position when updatelayout is triggered
273         - header/footer: make textselection disable, except input type="text"
274
275 * Wed Nov 07 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.60
276 - FIX:
277         - Remove tizen-black theme package description
278
279 * Tue Nov 06 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.59
280 - FIX:
281         - Fix theme name to meet the change of system theme name: white->tizen
282         - Popupwindow: fix left position
283         - Remove black theme
284         - footer: remove label, legend drawing
285 - Spec changes:
286         - UX guide v0.4 : button, layout
287
288 * Wed Oct 24 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.57
289 - FIX:
290         - expandablelist: icon color fix
291         - scrollview: Fix xy scroll
292         - footer: Remove dummy div
293         - Make string concatnation effective in inline-protos.sh
294 - Spec changes:
295         - refresh header/footer when drag&drop event is fired in GUI builder
296         - searchbar: delete cancel button
297         - don't trigger updatelayout event when keyup event comes
298
299 * Mon Oct 15 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.56
300 - FIX:
301         - Toggleswitch: Change event name from 'changed' to 'change'
302         - Notification: Revert interval feature
303
304 * Tue Oct 09 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.55
305 - FIX:
306         - Fix SMACK manifest bug (S1-9098)
307
308 * Fri Oct 05 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.54
309 - FIX:
310         - handler: don't append a handler if handler is not enabled
311         - scrollview: use static value
312         - datetimepicker: fix date-format HH display error
313 - ETC:
314         - provide jquery.min.js
315         - barlayout: codes clean
316         - remove unused file
317
318 * Wed Sep 26 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.53
319 - FIX:
320         - listview: change focused color
321         - multibuttonentry: code refactoring
322         - datetimepicker: modify date format when triggered date-changed event
323         - slider: fix the top of slider bar
324         - add event blocker when load a first page
325
326 * Fri Sep 21 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.52
327 - ETC.
328         - Move SMACK manifest files to the top SRCDIR
329
330 * Fri Sep 21 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.51
331 - FIX:
332         - Popup: Do not focus container
333         - Header: show backbutton when both tabbar and header are present together
334         - Multi button entry: text ellipsis, code refactoring
335
336 * Fri Sep 21 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.50
337 - ETC.
338         - Apply SMACK manifest
339
340 * Thu Sep 20 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.49
341 - FIX:
342         - JSLINT code clean-up
343         - scrollview: firefox support
344         - scrollview: fix finding slider handle
345         - list: tweak text ellipsis
346         - checkbox: fix selecting wrong label tag (N_SE-8370)
347         - imageslider: check parameter
348         - smallpopup: fix position
349         - searchbar: fix 'clear' button size
350 - Spec changes:
351         - scrollview: support outer scroll
352         - JQM: block click event only with the element that does preventdefault on vclick(N_SE-6090)
353         - remove S/W IME control
354
355 * Thu Sep 13 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.48
356 - FIX:
357         - Add missing icon: controlbar
358         - scrollview: tune scrolling animatio ninterval
359         - datetimepicker: digit/triangle position
360         - datetimepicker: fix day overflow issue
361 - Spec changes:
362         - scrollview: show scrollbar when page is showed
363         - scrollview: disable outer scroll
364         - extendablelist: change api with legacy support
365         - add ui-text-ellipsis class
366
367 * Mon Sep 10 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.47
368 - FIX:
369         - scrollveiw: fix height of view
370         - searchbar: support placeholder
371 - Spec changes:
372         - add ui-text-ellipsis class
373
374 * Fri Sep 07 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.46
375 - FIX:
376         - scrollview: scrolling bug fix
377         - controlbar: fix width of controlbar item
378 - Spec changes:
379         - searchbar: don't hide icon
380         - popup: update JQM poup widget
381
382 * Fri Sep 05 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.45
383 - FIX:
384         - controlbar: set correct controlbar width of last element
385         - slider: get popup enable value correctly
386         - use Date.now() instead of (new Data()).getTime()
387         - popupwindow: fix the background color of popup scroller
388         - listview: add padding-left to expandable list
389         - add ellipsis for title area support
390
391 * Fri Aug 31 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.44
392 - FIX:
393         - swipelist: show list items correctly
394         - datetimepicker: set last day, if day is overflowed
395 - Spec changes:
396         - controlbar: update icons
397
398 * Tue Aug 29 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.43
399 - FIX:
400         - notification: fix typo
401 - Spec changes:
402         - controlbar: update icons
403
404 * Tue Aug 28 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.42
405 - FIX:
406         - multimediaview: video progress bar display normally for too samll
407         - segmentcontrol: remove media query
408         - scrollview: add outer scroll condition
409         - datetimepicker: modify triangle size
410         - popupwindow: set the screen height explicitly
411         - notification: add multiline text
412 - Spec changes:
413         - mutibuttonentry: support new GUI
414         - virtualgrid: support new GUI
415
416 * Mon Aug 27 2012 Jinhyuk Jun <jinhyuk.jun@samsung.com> 0.1.41
417 - FIX:
418         - radio/check button : button size bug fix
419
420 * Fri Aug 24 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.40
421 - FIX:
422         - build error fixed
423
424 * Fri Aug 24 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.39
425 - FIX:
426         - listview: style fix, remove filter placeholder
427         - controlbar: divide styles
428         - scrollview: don't skip dragging when click button or inputbox
429         - slider: trim the text on text slider
430 - Spec changes:
431         - remove gray and blue theme
432         - add white and black theme
433         - support new GUI guide
434
435 * Mon Aug 20 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.38
436 - FIX:
437         - fix coment of version tag
438
439 * Fri Aug 17 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.37
440 - FIX :
441         - button: fix alignment
442         - listview: adjust the main text width
443         - virtualgrid: refactoring
444 - Spec changes:
445         - transition: support JQM 1.1.0 transitions
446         - scrollview: support the outer scroll
447         - notification: remove interval feature
448
449 * Tue Aug 14 2012 Youmin Ha <youmin.ha@samasung.com> 0.1.36
450 - FIX :
451         - checkboxRadio: Add left/right padding
452         - button: custom button & icon position
453         - virtuallist: remove 'recreate' test
454 - Spec changes:
455         - header/footer: enable/disable support
456
457 * Fri Aug 10 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.35
458 - FIX :
459         - expandablelist: modify show animation
460         - virtualgrid: Redesign programming interface
461         - popupwindow: code clean and fixed issues
462         - pagelayout: fix content height
463         - license file update
464         - virtuallist: Change programming interface
465         - datetimepicker: getting days correctly
466         - searchbar: set to hidden when cancel button is hide
467         - White theme title font tuning
468 - Spec changes:
469         - default theme tizen-gray to tizen-white
470         - set default page transition to none
471
472 * Mon Aug 02 2012 Jinhyuk Jun <jinhyuk.jun@samsung.com> 0.1.34
473 - FIX :
474         - Back Button : enlarge backbutton click size for white theme
475 - Feature :
476         - Expandable List : Add refresh api
477 * Mon Aug 02 2012 Jinhyuk Jun <jinhyuk.jun@samsung.com> 0.1.33
478 - FIX :
479         - click event touch threshold tuning
480
481 * Mon Aug 02 2012 Jinhyuk Jun <jinhyuk.jun@samsung.com> 0.1.32
482 - FIX : 
483         - Add back button highlight effect for white theme
484
485 * Mon Aug 01 2012 Jinhyuk Jun <jinhyuk.jun@samsnug.com> 0.1.31
486 - FIX : 
487         - IME checkroutine update, improve relayout on resize event
488         - Add highlight effect for radio button list 
489         - Scrollview : fix condition of updatelayout event
490 - Feature : progressing : add show/hide api
491
492 * Mon Jul 27 2012 Koeun Choi <koeun.choi@samsung.com> 0.1.30
493 - FIX : virtuallist, virtualgrid: Clean up temporary jquery.template object to clear cache
494         add default theme option on buttonMarkup for tizen theme
495         [searchbar] first fix : focus/blur fixed
496         back button does not work when long press
497         scrollview: don't auto scrolling if resizing area is too large
498 - Feature : notification : add api to set the icon at tickernoti
499         demo : update the list sample demo
500         Support tizen default theme
501
502 * Mon Jul 23 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.29
503 - Improvements & Bugfixes
504    - HOTFIX: Revert template function with jquery.template
505
506 * Thu Jul 19 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.28
507 - Improvements & Bugfixes
508    - Fix #WEB-1028: memory leak on virtuallist/virtualgrid
509 - Spec changes
510    - $.tizen.loadTheme() function accepts theme name as arguement
511    - Scrollview supports 'updatelayout' callback
512
513 * Tue Jul 17 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.27
514 - Improvements & Bugfixes
515    - Revert 'preventing long-press popup' patch, to fix backbutton to work in SocialMagazine
516
517 * Tue Jul 17 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.26
518 - Improvements & Bugfixes
519    - Add tizen-white theme package, to make rpm build to be finished
520
521 * Tue Jul 17 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.25
522 - Improvements & Bugfixes
523    - Set 'slide' as default page transition effect, by JQM patch
524
525 * Fri Jul 13 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.24
526 - Improvements & Bugfixes
527    - Fix IME show/hide algorithm
528    - Fix error on virtualgrid: link _set_scrollbar_size() function to the one in virtuallist
529
530 * Wed Jul 11 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.23
531 - Improvements & Bugfixes
532    - Fix notification position
533    - Fix unit tests
534
535  Fri Jul 6 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.22
536 - Spec changes
537         - JQM 1.1 upgrade
538 - Improvements & Bugfixes
539         - Transform3D support on scrollview
540         - Page layout supports IME control
541         - Mapview supports pinch zoom on JQM 1.1
542         - Fix wrong character on button in minified version
543         - Virtualgrid supports scrollbar
544         - Lots of bugfixes
545
546 * Fri Jun 22 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.20
547 - Spec changes
548         - Support 'latest' version (by symlink) for tizen-web-ui-fw.js path.
549         - imageslider : supports 'resize' event.
550         - listview : listview has 1px padding-bottom.
551         - loader : Change global namespace, from S to $.tizen.
552         - loader : Move loadCustomGlobalizeCulture() into $.tizen.util namespace.
553 - Improvements & Bugfixes
554         - Scrollview : supports 'translate3d', instead of 'translate'.
555         - notification : reset timer when 'show' or 'refresh' event.
556         - JQM patch : Fix vclick event triggered twice.
557 - Etc.
558         - Add & fix unit tests.
559
560 * Thu Jun 14 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.19
561 - Spec changes
562         - mapview : new widget.
563         - notification : add .refresh() API.
564         - pagecontrol : add .value([val]) API, and change an attribute name 'data-initVal' to 'data-value'.
565 - Improvements & Bugfixes
566         - Support minified CSS.
567         - loader : Fix & refactor 'loading globalize culture file' routine.
568         - JQM Patch : Calculate min-height of window in javascript code, and remove predefined min-height value from CSS.
569         - Many more bugfixes.
570 - Etc.
571         - Add many unit tests.
572         - Fix test coverage instrumentation tool to work with current source code.