modify wrong changelog date
[platform/framework/web/web-ui-fw.git] / packaging / web-ui-fw.spec
1 Name:       web-ui-fw
2 Version:    0.2.29
3 Release:    0
4 Summary:    Tizen Web UI Framework Library
5 Group:      Development/Other
6 License:    MIT
7 BuildArch:  noarch
8 BuildRequires:  make
9 BuildRequires:  nodejs
10
11 Source0:    %{name}-%{version}.tar.gz
12 Source1001:     %{name}.manifest
13 Source1002:     web-ui-fw-theme-tizen-white.manifest
14 Source1003:     web-ui-fw-theme-tizen-black.manifest
15 Source1004:     web-ui-fw-theme-default.manifest
16 Source1005:     web-ui-fw-devel.manifest
17 Source1006:     web-ui-fw-demo-tizen-winsets.manifest
18
19 %description
20 Tizen Web UI Framework library and theme packages
21
22 %prep
23 %setup -q
24 cp %{SOURCE1001} %{SOURCE1002} %{SOURCE1003} %{SOURCE1004} %{SOURCE1005} %{SOURCE1006} .
25
26 %build
27 make all
28
29 %install
30 make DESTDIR=%{buildroot} install
31
32 %post
33
34 %files
35 %manifest %{name}.manifest
36 /usr/share/tizen-web-ui-fw/*/js/*.js
37 /usr/share/tizen-web-ui-fw/*/js/cultures
38 /usr/share/tizen-web-ui-fw/latest
39 /usr/share/tizen-web-ui-fw/VERSION
40
41 ###############################
42 %package -n web-ui-fw-theme-tizen-gray
43 BuildArch:  noarch
44 Summary:    Tizen Web UI Framework Theme : tizen-gray
45 %Description -n web-ui-fw-theme-tizen-gray
46     Tizen Web UI Framework Theme : tizen-gray
47     Deprecated package, but some binaries still refer this.
48
49 ###############################
50 %package -n web-ui-fw-theme-tizen-white
51 BuildArch:  noarch
52 Summary:    Tizen Web UI Framework Theme : tizen-white
53 %Description -n web-ui-fw-theme-tizen-white
54     Tizen Web UI Framework Theme : tizen-white
55 %files -n web-ui-fw-theme-tizen-white
56 %manifest web-ui-fw-theme-tizen-white.manifest
57 /usr/share/tizen-web-ui-fw/*/themes/tizen-white
58 /usr/share/tizen-web-ui-fw/*/themes/tizen-tizen
59
60 ###############################
61 %package -n web-ui-fw-theme-tizen-black
62 BuildArch:  noarch
63 Summary:    Tizen Web UI Framework Theme : tizen-black
64 %Description -n web-ui-fw-theme-tizen-black
65     Tizen Web UI Framework Theme : tizen-black
66 %files -n web-ui-fw-theme-tizen-black
67 %manifest web-ui-fw-theme-tizen-black.manifest
68 /usr/share/tizen-web-ui-fw/*/themes/tizen-black
69
70 ###############################
71 %package -n web-ui-fw-theme-default
72 BuildArch:  noarch
73 Summary:    Tizen Web UI Framework Theme : default
74 %Description -n web-ui-fw-theme-default
75     Tizen Web UI Framework Theme : default
76 %files -n web-ui-fw-theme-default
77 %manifest web-ui-fw-theme-default.manifest
78 /usr/share/tizen-web-ui-fw/*/themes/default
79
80 ###############################
81 %package -n web-ui-fw-devel
82 BuildArch:  noarch
83 Summary:    Tizen Web UI Framework Developer's files
84 %Description -n web-ui-fw-devel
85     Tizen Web UI Framework Developer's files
86 %files -n web-ui-fw-devel
87 %manifest web-ui-fw-devel.manifest
88 /usr/share/tizen-web-ui-fw/bin
89 /usr/share/tizen-web-ui-fw/template
90 /usr/share/tizen-web-ui-fw/*/js/src
91 /usr/share/tizen-web-ui-fw/*/js/depData.json
92
93 ###############################
94 %package -n web-ui-fw-demo-tizen-winsets
95 BuildArch:  noarch
96 Summary:    Tizen Web UI Framework Demo Application: tizen winset demo
97 %Description -n web-ui-fw-demo-tizen-winsets
98     Tizen Web UI Framework Demo Application: tizen winset demo
99 %files  -n web-ui-fw-demo-tizen-winsets
100 %manifest web-ui-fw-demo-tizen-winsets.manifest
101 /usr/share/tizen-web-ui-fw/demos/tizen-winsets
102
103
104 ###############################
105 %changelog
106 * Fri May 10 2013 Hyunjung Kim <hjnim.kim@samsung.com> 0.2.29
107         - loader: change a warn msg to debug msg
108         - Radio: Radio issue has been fixed ( N_SE-38015 )
109         - Add gallery3D source to the flora license list
110         - Slider: JQM patch fixed ( event.target match )
111         - Tizen-winset: remove unnecessary file
112
113 * Tue May 07 2013 Hyunjung kim <hjnim.kim@samsung.com> 0.2.28
114         - Orientation : add landscape UX
115         - ToggleSwitch : divide jQM and Tizen slider on dragging outside of toggle area
116         - Slider: Popup slider issue has been fixed ( N_SE-36430 )
117
118 * Fri May 03 2013 Hyunjung kim <hjnim.kim@samsung.com> 0.2.27
119         - Splitview: Fix popup error
120         - Tests: Add slider tests checking if jqm slider is used for select elements
121         - Adjust the latest GUI
122         - Handler: Adjust the latest GUI
123         - Swipe: Adjust the latest GUI
124         - Fastscroll: Adjust the latest GUI
125         - ToggleSwitch : bug fix
126         - TizenWinset : bug fix(N_SE-36666)
127         - Gallery3d: Fix Gallery3d TC failure
128         - UnitTC: fix virtualgrid test error
129         - Popup: popup background image have been added
130         - Tokentextarea: Use jQM popup instead of window.alert().
131         - Splitview: Use jQM popup instead of window.alert().
132         - Splitview: Change an option name to start with a capital letter
133         - License: Change flora license version
134         - Tabbar: Adjust the latest GUI
135         - Tokentextarea: Change from 'px' to 'em.'
136         - Fastscroll: Add 'orientationchange' event handler.
137         - Gallery3d: Fix null reference error
138
139 * Fri Apr 26 2013 Youmin Ha <youmin.ha@samsung.com> 0.2.26
140         - PageLayout : bug fix
141         - Gallery3d: Change timing of 'gl-matrix' library's execution
142         - Replace in LoadTheme function strings build with array join with the string concat
143         - Contextpopup: context popup reposition module has been added
144         - Pagelayout : skip to calculate min-height using data-scroll="none"(Issue: DCM-1453)
145         - Splitview: Fix the touchend event error.
146         - Gallery3d: Change event registration method from $.bind() to $.on()
147         - Scrollview : remove useless setTimeout in case scrolls go outside
148         - Naviframe : adjust new SIP down button
149         - Timepicker: Added return false; after vclick
150         - Popupwindow: reserved words has been removed
151         - minor changes: replace one occurrence of array.join with string concat and simplify jQuery arguments
152         - TizenWinset : set default margin for checkbox demo
153         - Tizenwinset: Context popup demo has been changed
154         - TizenDemo : add initial orientation mode to popup demo
155         - Widgets: removed parsing error for legacy javascript engine
156         - Delegate init of popup widget with delegateSelfInitWithSingleSelector
157
158 * Thu Apr 18 2013 Youmin Ha <youmin.ha@samsung.com> 0.2.25
159         - Pinch: pinch event re-implementation to use size
160         - Pagelayout : prevent code inserting window.innerHeight when content calculate
161         - BlachTheme : add missing icon (SIP down)
162         - Scrollview : support absolute position
163         - tizen-winsets: change the font-family in virtualgrid demo to default
164         - TizenWinset : Change default font
165         - tizen-winsets: Change image link
166         - tizenwinset: change images for virtual grid pages
167
168 * Tue Apr 16 2013 Youmin Ha <youmin.ha@samsung.com> 0.2.24
169         - SegmentControl: 2-buttons display issue (N_SE-34200)
170         - Naviframe : remove unnecessary img positioning(N_SE-33969)
171         - Gallery: jslint error fix
172         - TizenWinset : remove landscape SIP on mode
173         - Tizen Black Theme png file changed
174         - Gallery: Images showing bug has been fixed
175         - Scrollview : change horizontal scrollview demo(N_SE-33997)
176         - Tizenwinset: added return false in popup sample
177         - Naviframe : support data-role="button" in header
178         - Additional UnitTC: tizen winset unit tc bugs have been fixed
179         - Checkbox : remove favorite button's display:block(N_SE-33896)
180         - UnitTC: QUnit path has been changed. Priority, function type check function has been added
181         - Tizen-winset : Footer changed from lower case to upper case.
182         - Slider: enhance performance fix
183         - UnitTC: Addtional unit tc ref path has been fixed
184         - virtualgrid: apply overscrolling images to the style of widget
185         - Tabbar : Change overscroll image(left/right)
186         - ensurens: optimizations
187         - ensurens: qunit tests
188         - Tokentextarea: Fix block size error
189         - Fastscroll: Add a feature to fade out Fastscroll widget.
190         - Fastscroll: Add a user interaction at the omitted items.
191         - ImageLoader: Performance fix: apply lazy loading for canvas element
192         - Tests: Add tests for $.imageloader
193         - SegmentControl: 2-buttons display issue (N_SE-34200)
194         - virtuallist: fix width resizing trigger
195         - Timepicker: timepicker is closed when orientationchange event fired
196         - TizenWinset : Tabbar-persist issue.(N_SE-33996)
197         - Add Flora license
198         - collapsible: Fix collapsible list animation bug
199
200 * Wed Apr 10 2013 Youmin Ha <youmin.ha@samsung.com> 0.2.23
201         - Naviframe : modify SIP down button's position
202         - Core: Performance fix for disableSelection and enableSelection
203         - Tests: Core tests for disableSelection
204         - patch: fix small mistakes on the patches
205         - virtuallist: Change demo button style
206         - Button: btn-icon only css has been changed
207         - loader: Fix screen-width option processing
208         - pagelayout: Remember back key when it is hidden
209         - Tizen Black Theme : Tizen black theme png file changed.
210         - UnitTC: tizen winset unit tc bugs have been fixed
211         - TizenWinset: Swipe list sample has been fixed
212         - Radio : remove default radio's width(N_SE-33579)
213         - Scrollview : divide x/y overflow attribute
214         - Gallery: orientation image showing issue has been fixed
215         - Gallery: remove method bug has been fixed
216         - virtualgrid : fix unit-test error and increase test items
217         - Gallery3d: Modify demo & source codes for visibility enhancement.
218         - Gallery3d: Reduce loading time of widget
219         - Gallery3d: Change files' format to unix
220         - Contextpopup: context popup close when window resize event fire
221         - Popup: reverse orientation bug has been fixed
222         - Tokentextarea: modify description
223         - Multimediaview: modify description
224         - JQM: Do not add ui-btn-icon-only class at the select button
225         - build: tizen-black theme package
226         - Tizenwinset: popup script has been removed
227         - Tizenwinset: substring split view text message
228         - Timepicker: data-changed event will be deprecated
229
230 * Fri Apr 5 2013 Youmin Ha <youmin.ha@samsung.com> 0.2.22
231         - tizen-winsets: Fix demo menu
232         - Tizenwinset: Reorder tizenwinset menu
233         - SearchBar: Header button size issue has been fixed
234         - Swipe: list item overflow: hidden has been added
235         - Tizenwinset: href has been added in grouped list
236         - Tizenwinset: Page transition page has been added
237         - Tizenwinset: Radio description has been fixed
238         - This patch fixes problem when base url is changed when site is prefetched.
239         - Entry : limit textarea's width (N_SE-28653)
240         - Naviframe : hide backbutton in case SIP up(remove backbutton makes problem in binding event)
241         - Gallery : next, prev images position bug has been fixed
242         - Multimediaview: Fix display error while handling orientationchange event.
243         - Pagelayout : modify innerHeight dpr calculation in non scrollview mode
244         - Datetimepicker: picker position has been fixed when browser resize event fired
245         - Tips: generate elements sample page javascript has been fixed
246         - Tokentextarea: Fix Tizen-winsets demo.
247
248 * Wed Apr 3 2013 Youmin Ha <youmin.ha@samsung.com> 0.2.21
249         - VirtualGrid: Fix errors on centerTo and resize methods
250         - loader: Fix default font size at device-width viewport
251         - scrollview : remove overflow-x property
252         - Naviframe : fix backbutton position/ change down button icon
253         - Naviframe : bug fix
254         - Tizenwinset : Tizen-winset demo page titles changed Tizen-winset demo page titles changed from lower case to upper case.
255
256 * Fri Mar 29 2013 Youmin Ha <youmin.ha@samsung.com> 0.2.20
257         - JQM Navigation : remove page min-height
258         - Pagelayout : add refresh to pagelayout
259         - Tokentextarea: Changes 'remove' tests to asyncTest
260         - Popup: input tag alignment has been fixed
261         - Tokentextarea: add/remove events are deprecated.
262         - Contextpopup: Support horizontal list
263         - Select: icon z-index has been deleted
264         - Tizenwinset: ui widget order has been changed
265         - Tool: make web app template disable context menu by default
266         - Tizen-winset: change tips for using listview
267         - Loader: calculate font size with mobile width
268         - Naviframe : fix header's back button position
269         - TizenWinset : move locale info to another file
270
271 * Fri Mar 22 2013 Youmin Ha <youmin.ha@samsung.com> 0.2.19
272         - Tizen-winset: Support accessibility for tizen-winset
273         - Orientation : add orientataionchange to tizen-winset
274         - Tokentextarea: Adjusts VI effect for add/remove block
275         - splitview: Support accessibility for splitview
276         - Tizen-winset: Date/time picker guide text has been fixed
277         - Popup: context popup arrow position, setTimeout open method bug have been fixed
278         - fastscroll: Add new indexString API to Fastscroll widget.
279         - splitview: Add new widget
280         - gallery3d: Add new widget
281         - Scrollview : disable VI effect for gesture event
282         - Scrollview : disable SIP outerscroll
283         - Tizen-winset: resize VirtualGrid widget in demo
284         - Tizen-winsets: Refactor searchbar subpages
285         - Tizen-winsets: Remove depracated usage of virtuallist
286         - Tizen-winsets: Move js code from main.js to subpages
287         - Tizen-winsets: Refactor virtual grid demo subpages
288         - Tizen-winsets: Move css files from index to proper subpages
289         - Tizen-winsets: Refactor list dialogue edit subpage
290         - Tizen-winsets: Refactor pagelayout subpages
291         - Tizen-winsets: Refactor tips subpages
292         - Tizen-winsets: Move subpages popup files from index.html
293         - Tizen-winsets: Move subpages javascript files from index.html
294         - virtualgrid: fix improperly merged codes
295         - ColorTheme : remove unused color value(1st)
296         - Scrollview : change scrollbar draw
297         - Popup: Apply popup background dim
298         - Tizen-winsets: Move tokentextarea demo to external page.
299         - Tizen-winsets: Move tabbar persist demo to external page.
300         - Tizen-winsets: Remove notImplemented page
301         - Tizen-winsets: Move slider demo page to external subpage
302         - Tizen-winsets: Fix ids, remove duplicated names for sliders
303         - Tizen-winsets: Remove event for changing theme
304         - tool: Fix wgt sample app generator tool to make apps be installed
305         - demos : change live to on
306         - build: Trim compiled CSS files
307         - Gallery: CSS left -> translate or translate3D
308         - Tokentextarea: Disfunctional APIs fixed.
309
310 * Thu Mar 7 2013 Youmin Ha <youmin.ha@samsung.com> 0.2.18
311         - build: Fix Makefile to add globalize to the minified lib
312         - build-tools : upgrade less to v1.3.3
313         - demos : change normal js path to minified js
314         - Theme : remove reduantant less - dayselector, optionheader, nocontents
315         - multimediaview : fix full-screen mode.
316         - multimediaview : fix 'width', 'height' and 'fullScreen' methods
317         - Extendablelist: Added min-height "load more button" in listitem
318         - virtualgrid: adjusts VI effect for an overflow action
319         - ControlGroup : change ellipsis font color (press/normal)
320         - multimediaview: Add an error message to Multimediaview
321         - virtualgrid: adjusts triple flick gesture
322         - scrollview: add function for getting width of view
323         - scrollview: adds support x axis gesture scroll
324         - multimediaview : fix audio control
325         - tabbar : tabbar slide animation change
326         - TizenWinsetDemo : 2line-text demo bug fix
327         - collapsible: Fix demo to show radio button correctly in the collapsible list
328         - collapsible: Set listitem position to relative
329         - UnitTC: added list divider unit test
330         - Style: unnecessary color codes have been deleted and modified
331         - build: Module build implementation
332         - UnitTC: Additional unit testcases have been added
333         - listview : bug fix
334         - Naviframe : remove back button's hover effect
335         - TizenDemo : remove back button
336         - Transition: added more-button vi
337         - pinch: added new event called pinch
338         - Popup: css word-wrap:break-word has been added
339         - virtualgrid: memory leak fix
340         - progress: set to init state at pending bar
341         - progress: add margin of top/bottom
342         - unit-test: split progress test and progressbar test
343         - Tizen-winset: Context popup sample page guide text has been changed
344         - multimediaview: fix the height of widget when full-screen mode
345         - JQM: performance tuning
346
347 * Tue Feb 19 2013 Minkyu Kang <mk7.kang@samsung.com> 0.2.17
348         - DialogueList : delete border top value / add sample's text ellipsis
349         - Tokentextarea: Add scroll-to-top for Grouping On/Off regarding #N_SE-24877
350         - Multimediaview: Fix mute function
351         - Tizen-winset: list vi index guide textbox has been removed
352         - Tizen-winset: custom button texts have been changed
353         - slider: move popup div to out of content
354         - TizenWinset: disable context popup in multimediaview
355         - Swipe: wrong style name has been fixed
356         - demo: add the sample at dialogue list
357         - listview: Add ui-li-has-right-btn class with toggleswitch
358         - WinsetDemo : change wrong title name
359
360 * Mon Jan 28 2013 Youmin Ha <youmin.ha@samsung.com> 0.2.16
361         - demo: checkbox: reduce button's width
362         - tabbar : delete right/left tab animation color
363         - scrollview: fix the scroll position at keydown event
364         - groupControl : change footer groupControl from min-width to percentage
365         - scrollview: get height of softkeyboard correctly
366         - tizen-winset: Add name attr to all radio inputs
367         - virtualgrid: changes event binding target
368         - scrollview: skip the drag if target is textarea
369         - scrollview: skip the dragging of parent scrollview
370         - scrollview: apply the scaling ratio to the soft keyboard
371         - demos: apply disabled option in textarea
372         - demo: remove unused codes
373         - demo: datetimepicker: show selected date correctly
374         - listview: Adjust bubble listitem width and margin
375         - pagelayout : change external refresh call and ime status follow only current page
376         - toggleSwitch : bug fix
377         - unit-test: slider: fix the move test
378         - handler: fix jslint error
379         - ToggleSwitch : set image toggleswitch background attribute
380
381 * Mon Jan 28 2013 Youmin Ha <youmin.ha@samsung.com> 0.2.15
382         - slider: increase the text width(N_SE-23397)
383         - virtualgrid: DOM element leak fix
384         - header: Move button top higher in header with tabbar(N_SE-22253)
385         - datatimepicker: don't open the popup before popupafterclose event is fired(N_SE-23027)
386         - handler: bug fix (regarding enableHandler function )
387         - demo:fix syntax error
388
389 * Sat Jan 26 2013 Youmin Ha <youmin.ha@samsung.com> 0.2.14
390         - demo: fix demo using tizen device API
391         - multimediaview: reset the height of container
392         - input: modify css correctly
393         - multimediaview: fix the height of widget
394         - gallery: bind create event
395         - progress: bind create event
396         - slider: bind create event
397         - progressbar: bind create event
398         - progressbar: event trigger correctly
399         - popup: fix height of popup scroller
400         - build: add continue option to jslint
401         - ctxpopup demo : bug fix
402         - demo: fix searchbar demo to use different IDs
403         - demo: extract routine executing Tizen device API
404         - toggleswitch : set default margin, delete box padding
405
406 * Thu Jan 24 2013 Youmin Ha <youmin.ha@samsung.com> 0.2.13
407         - virtuallist: Prevent replacing contents on nonexist element
408         - JQM: Trim text in listitem to get index in autodivider
409         - JQM: Remove trailing whitespace in jqm patch
410         - scrollview: get the height including margin
411         - multimediaview: bug fix ( scrolling in full-screen mode )
412         - virtuallist: set listitem width to exclude listitem left/right margin
413         - demo: fix virtuallist sample layout
414         - progress: set the position explicitly
415         - progress: rename from progressing to progress
416         - build: remove unused files
417         - searchbar: fix jslint errors
418         - src: fix file permissions
419         - button : change jump left icon
420
421 * Wed Jan 23 2013 Minkyu Kang <mk7.kang@samsung.com> 0.2.12
422         - theme : button icon - scrolltop, scrolleft icon changed.
423         - build: cleanaup Makefile
424         - pagelayout: fix jslint error
425         - virtualgrid: Fix jslint errors
426         - tabbar : jslint bug error fix
427         - build: add regexp option to jslint
428         - virtuallist: fix jslint errors
429         - handler: Apply the exceptional principle for scrollbar on Handler.
430         - build: remove unused copyright
431         - loader: extract log class for tizen web, and fix jslint errors
432         - loader: Viewport width is set to document width
433         - popupwindow: fix jslint error
434         - build: fix Makefile for tizen-white theme
435         - build: remove unused libraries
436         - datetimepicker: fix jslint error
437         - slider: fix jslint error
438         - demo: remove deprecated demos
439         - pagelayout : change to call relayout with this page
440         - Tokentextarea: Block size error fixed.
441         - handler: bug fix (handler activation)
442
443 * Tue Jan 22 2013 Minkyu Kang <mk7.kang@samsung.com> 0.2.11
444         - demo: clear input text value with cancel button click
445         - demo: Adjust textarea height automatically
446         - naviframe : bug fix
447         - tabbar : bug fix
448         - Fastscroll: popup position has been changed
449         - Button: custom button icon path, margin have been changed
450         - toggleswitch : bug fix
451         - slider: increase the margin
452         - datetimepicker: close the popup after select the value
453         - unit-test : add page backbutton control test
454         - Demo: added guide text and change input type in list vi
455         - remove legacy codes : jquery-geo
456         - Datetimepicker: text-main max-width has been removed
457         - Radio: control group border has been removed
458         - Demo: remove 'tab' space
459         - UnitTC: swipe unit tc has been fixed
460         - UnitTC: jQuery path has been fixed
461         - Button: bug fix when button has not a text
462         - tizen-winset: timepicker: demo title is changed
463
464 * Fri Jan 18 2013 Minkyu Kang <mk7.kang@samsung.com> 0.2.10
465         - tizen-winsets: codes cleanup
466         - datetimepicker: date calibration when year is changed
467         - Demo: textarea size has been changed
468         - Demo: Naviframe morebutton demo has been changed
469         - remove unused unit test cases : gallery3d
470         - tizen-winset: remove links
471
472 * Thu Jan 17 2013 Minkyu Kang <mk7.kang@samsung.com> 0.2.9
473         - gallery: use timeout function instead of interval
474         - Tokentextarea: Display error fixed.
475         - scrollview: Fix not selector to respond with jQuery1.8.2
476         - tabbar: remove the width of last element
477         - Demo: apply css 'user-select:none'
478         - Button: guide text has been shorten
479         - build: Update jQuery to 1.8.2 (JQM1.2 compliant)
480         - virtuallist: Fix mistyping
481         - demo: Fix tizen function namespace in demo
482         - virtuallist: Rewrite listitem replacing algorithm
483         - fastscroll: modify from not selector to function
484         - extendablelist: Fix unit-test
485         - tabbar : prefix to tabbar scroll event
486         - Popupwindow: removed unvalid selector in jquery 1.8.2
487         - slider: adjust handle text as length of value
488         - Demo: 3 buttons in popup text has been changed
489         - src: codes cleanup
490         - demo : remove trailing empty strings
491         - demo : rename TizenWinset list items
492         - button : change from long text list to multiline list
493         - build: Remove JQM1.1.0 patches
494         - Popup: Apply tizen style popup and attribute support
495         - JQM: Fix buttonmarkup bug keeping ui-btn-down class
496         - UnitTest: folder and file renamed, QUnit path was modified
497         - tizen-winsets: button: fix textarea width
498         - Swipe: event name error has been fixed
499
500 * Tue Jan 15 2013 Minkyu Kang <mk7.kang@samsung.com> 0.2.8
501         - Button: button padding has been updated
502         - virtuallist: fix unique listitem ID bug
503         - checkbox, radio : change display attr
504         - Button: bug fix ( when data style circle button on text )
505         - handler: bug fix (when scrolling with multi selection)
506         - JQM: adjust patch number
507         - gallery: show the widget after pageshow
508         - TokenTextArea : resource add ( press image )
509         - gallery: adds function that set the index to value API
510         - configure: set TIZEN default configures
511         - footer: h tag display attribute value has been changed
512         - buttons : demo bug fix
513         - searchbar : demo page bug fix
514         - tizen demo : bug fix
515         - build: remove JQM1.1.0
516         - Tokentextarea: Fix issues
517         - scrollview: block the multi touch
518         - list : dialogue list demo change
519         - pagelayout : update dynamic control
520         - Demo: Context popup close method has been changed
521
522 * Fri Jan 11 2013 Minkyu Kang <mk7.kang@samsung.com> 0.2.7
523         - slider: set text container's width as text length
524         - Timepicker: li max-width has been changed
525         - remove experimental feature - mapview.
526         - scrollview: added conditions for finding slider
527         - UnitTC: Pass,error count save method has been changed
528         - confix.xml: default config added for tizen basic applications
529         - Swipe: p tag margin value is set '0'
530         - packaging: remove unused file
531         - tabbar : bug fix
532         - list demo : bug fix
533         - tizen-winsets: gallery: move to new section
534         - tizen-winsets: autodivider: removes link of list
535         - demos: entry of number-pattern name is changed from 'number' to 'number-pattern'
536         - pagelayout : padding calculate change, ime footer check changed
537         - tizen-winsets: searchbar: scroll to the top when type the character
538         - searchbar : bug fix
539         - demo: Fix virtuallist demo following new list style
540         - demo: Add word-wrap:break-word and remove parag. width
541         - Demo: button max-width has been set( 3 buttons in popup )
542         - back button control demo : bug fix
543         - toggleswitch : demo page modify
544         - slider: add margin-top and margin-bottom
545         - tabbar demo : bug fix
546         - Popup: IME hide when popup is closed
547         - token textarea : bug fix
548         - Timepicker: change get attribute method
549         - footer demo : bug fix
550         - unit-test: gallery: add new APIs
551         - gallery: adds support new APIs
552
553 * Fri Jan 04 2013 Minkyu Kang <mk7.kang@samsung.com> 0.2.6
554         - JQM: patches cleanup
555         - Button: data-corners attribute has been added
556         - unit-test: slider: fix class name of background
557         - progressbar, slider: fix less variable typo
558         - Tabbar : VI update
559         - notification: add top position at fix class
560         - demo: entry demo page change
561         - css: .ui-disabled added
562         - tizen-winset: token textarea: remove back button at demo page
563         - theme: Remove unused less file
564         - pagelayout : content min height bug fix
565         - scrollview: skip the dragging when target is slider's handle
566         - scrollview: update and refactoring the scroll effect
567         - UnitTest:JQM Unit TC helper has been added,TCs have been modified
568         - Swipe: demo page html error has been fixed
569         - listview: Add add/delete animation (VI)
570         - Popup: demo page has been modified
571         - tizen demo : bug fix
572         - searchbar : demo page change(change front button and add behaviour)
573         - pagelayout : add min height to content
574         - gallery: rename 'Image Slider' to 'Gallery' in tizen-winsets demo and tests
575         - back button control demo : change url link to data-rel="back"
576         - loader: Skip loading theme CSS with a custom css code
577         - Button: support no-text in button
578         - collapsible: Fix syntax error
579         - slider: use data-highlight attribute
580         - collapsible: Rotate animation to collapsible heading icon
581         - toggleswitch : text switch bug fix
582         - remove candidates-calendarpicker
583         - Patch: Fix misc mistakes in JQM patches
584         - searchbar : animation change
585         - gallery: get the width correctly
586         - demo: data-framework-viewport-scale attribute is changed to data-framework-viewport-width
587         - collapsible: Add collapse/expand animation (VI)
588         - datetimepicker: VI update
589         - JQM: set transition to pop as default
590         - tabbar : bug fix in case none li element case
591         - scrollview: fix the drag bug
592         - Button: Button icon scrolltop, left has beed added
593         - Swipe: VI update and swipe speed has been changed
594         - jqm: fix errors in patch files
595         - unit-test: swipe: fixed the destroy test
596
597 * Wed Dec 26 2012 Youmin Ha <youmin.ha@samsung.com> 0.2.5
598         - Revert "[checkboxradio] exception handling for input"
599                 This reverts commit 72478c32704fa96362db577e6cf9511777919ea8.
600                 Tizen style supports no-label radio and checkbox when making lists.
601                 So it ignores html input operation. Instead, it supports tizen style radio and checkbox theme.
602
603 * Thu Dec 20 2012 Youmin Ha <youmin.ha@samsung.com> 0.2.4
604 - Fix:
605         - modify segment background
606         - rearrange check, radio input
607         - CtxPopup: Scale up/ down popup vi(poptop, popbottom)
608         - button: style has beed added(box,circle,nobg,round)
609         - favorite resource added
610         - demo/tizen-winsets: add footer and back button
611         - remove autodividers unit test
612         - add divider for tabbar
613         - checkboxradio: exception handling for input
614         - segment control backward compatiblity
615         - Fix collapsible unit-test
616         - remove toggleswitch
617         - add patch for remove segment text
618 - Spec changes:
619         - replace controlbar to tabbar
620
621 * Fri Dec 14 2012 Minkyu Kang <mk7.kang@samsung.com> 0.2.3
622 - FIX:
623         - slider: add image
624         - button: data-icon support, styles fix
625         - progressbar: modify the background
626         - scrollview: auto scrolling bug fix
627         - pagelayout: IME concept is changed
628 - Spec changes:
629         - dialogue: add edit mode
630         - nocontents: removed
631         - pagecontrol: removed
632         - dayselector: removed
633         - expandablelist: removed
634
635 * Mon Dec 10 2012 Youmin Ha <youmin.ha@samsung.com> 0.2.2
636 - FIX:
637         - chang searchbar/slider images
638         - delete redundant button images
639 - Spec changes:
640         - Change widget name: shortcutscroll -> fastscroll
641
642 * Fri Dec 07 2012 Youmin Ha <youmin.ha@samsung.com> 0.2.1
643 - FIX:
644         - jqm1.2: Change collapsible style to meet expandable list
645         - remove jquery-geo-1.0.a4
646         - unit-test: rename from imageslider to gallery
647         - nocontent: add warning message
648         - Handler: Fix issues in jqm1.2
649         - Multimediaview: modify APIs & comments
650         - Mapview: Fix issues in jqm1.2
651         - JQM: clean up patches
652         - Swipelist: refactoring swipelist
653         - Popup,Ctxpopup: Apply tizen style popup in JQM1.2
654         - rearrange button's data-icon resources
655 - Spec changes:
656         - Virtualgrid: remove option ('data-itemcount')
657         - gallery: rename the widget from imageslider to gallery
658         - add new style for searchbar
659         [tokentextarea] multi-button entry renamed as token text area. API & comments modified.
660
661 * Thu Dec 06 2012 Minkyu Kang <mk7.kang@samsung.com> 0.2.0
662 - FIX:
663         - fix jslint error
664         - remove unused files
665         - change naviframe style
666 - Spec changes:
667         - applied jQuery Mobile 1.2.0
668         - remove optionheader
669
670 * Fri Nov 30 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.64
671 - FIX:
672         - fix unit tests
673         - remove unused theme files
674         - timepicker: text position fix
675         - scrollview: set dragstop when mouse is out of window
676         - listview: fix margin
677 - Spec changes:
678         - support data-framework-viewport-width
679
680 * Fri Nov 23 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.63
681 - FIX:
682         - dayselector: fix size
683         - remove unised styles
684         - divider: set non-press effect to default option
685         - popupwindow: fix window closing failure
686         - handler: GUI implementation
687         - TC: fix unit TCs
688         - scrollview: fix padding size
689 - Spec changes:
690         - Remove color widgets
691         - add $.tizen.pkgVersion for SDK
692 - Etc.
693         - JSDuck documents
694
695 * Fri Nov 16 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.62
696 - FIX:
697         - Many winsets: Fix layout
698         - Footer: fix position to bottom
699 - Spec changes:
700         - Remove color widgets
701
702 * Fri Nov 09 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.61
703 - FIX:
704         - Many widgets: New UX 0.6 theme implementation
705         - widgetex: init speed up
706         - scrollview: fix scrollbar and scale animation
707         - scrollview: fix scroll position when updatelayout is triggered
708         - header/footer: make textselection disable, except input type="text"
709
710 * Wed Nov 07 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.60
711 - FIX:
712         - Remove tizen-black theme package description
713
714 * Tue Nov 06 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.59
715 - FIX:
716         - Fix theme name to meet the change of system theme name: white->tizen
717         - Popupwindow: fix left position
718         - Remove black theme
719         - footer: remove label, legend drawing
720 - Spec changes:
721         - UX guide v0.4 : button, layout
722
723 * Fri Oct 26 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.58
724 - FIX:
725         - scrollview: Fix outer scroll amount
726         - tabbar: fix tapping twice
727         - popupwindow: fix left position
728
729 * Wed Oct 24 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.57
730 - FIX:
731         - expandablelist: icon color fix
732         - scrollview: Fix xy scroll
733         - footer: Remove dummy div
734         - Make string concatnation effective in inline-protos.sh
735 - Spec changes:
736         - refresh header/footer when drag&drop event is fired in GUI builder
737         - searchbar: delete cancel button
738         - don't trigger updatelayout event when keyup event comes
739
740 * Mon Oct 15 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.56
741 - FIX:
742         - Toggleswitch: Change event name from 'changed' to 'change'
743         - Notification: Revert interval feature
744
745 * Tue Oct 09 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.55
746 - FIX:
747         - Fix SMACK manifest bug (S1-9098)
748
749 * Fri Oct 05 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.54
750 - FIX:
751         - handler: don't append a handler if handler is not enabled
752         - scrollview: use static value
753         - datetimepicker: fix date-format HH display error
754 - ETC:
755         - provide jquery.min.js
756         - barlayout: codes clean
757         - remove unused file
758
759 * Wed Sep 26 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.53
760 - FIX:
761         - listview: change focused color
762         - multibuttonentry: code refactoring
763         - datetimepicker: modify date format when triggered date-changed event
764         - slider: fix the top of slider bar
765         - add event blocker when load a first page
766
767 * Fri Sep 21 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.52
768 - ETC.
769         - Move SMACK manifest files to the top SRCDIR
770
771 * Fri Sep 21 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.51
772 - FIX:
773         - Popup: Do not focus container
774         - Header: show backbutton when both tabbar and header are present together
775         - Multi button entry: text ellipsis, code refactoring
776
777 * Fri Sep 21 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.50
778 - ETC.
779         - Apply SMACK manifest
780
781 * Thu Sep 20 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.49
782 - FIX:
783         - JSLINT code clean-up
784         - scrollview: firefox support
785         - scrollview: fix finding slider handle
786         - list: tweak text ellipsis
787         - checkbox: fix selecting wrong label tag (N_SE-8370)
788         - imageslider: check parameter
789         - smallpopup: fix position
790         - searchbar: fix 'clear' button size
791 - Spec changes:
792         - scrollview: support outer scroll
793         - JQM: block click event only with the element that does preventdefault on vclick(N_SE-6090)
794         - remove S/W IME control
795
796 * Thu Sep 13 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.48
797 - FIX:
798         - Add missing icon: controlbar
799         - scrollview: tune scrolling animatio ninterval
800         - datetimepicker: digit/triangle position
801         - datetimepicker: fix day overflow issue
802 - Spec changes:
803         - scrollview: show scrollbar when page is showed
804         - scrollview: disable outer scroll
805         - extendablelist: change api with legacy support
806         - add ui-text-ellipsis class
807
808 * Mon Sep 10 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.47
809 - FIX:
810         - scrollveiw: fix height of view
811         - searchbar: support placeholder
812 - Spec changes:
813         - add ui-text-ellipsis class
814
815 * Fri Sep 07 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.46
816 - FIX:
817         - scrollview: scrolling bug fix
818         - controlbar: fix width of controlbar item
819 - Spec changes:
820         - searchbar: don't hide icon
821         - popup: update JQM poup widget
822
823 * Wed Sep 05 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.45
824 - FIX:
825         - controlbar: set correct controlbar width of last element
826         - slider: get popup enable value correctly
827         - use Date.now() instead of (new Data()).getTime()
828         - popupwindow: fix the background color of popup scroller
829         - listview: add padding-left to expandable list
830         - add ellipsis for title area support
831
832 * Fri Aug 31 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.44
833 - FIX:
834         - swipelist: show list items correctly
835         - datetimepicker: set last day, if day is overflowed
836 - Spec changes:
837         - controlbar: update icons
838
839 * Wed Aug 29 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.43
840 - FIX:
841         - notification: fix typo
842 - Spec changes:
843         - controlbar: update icons
844
845 * Tue Aug 28 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.42
846 - FIX:
847         - multimediaview: video progress bar display normally for too samll
848         - segmentcontrol: remove media query
849         - scrollview: add outer scroll condition
850         - datetimepicker: modify triangle size
851         - popupwindow: set the screen height explicitly
852         - notification: add multiline text
853 - Spec changes:
854         - mutibuttonentry: support new GUI
855         - virtualgrid: support new GUI
856
857 * Mon Aug 27 2012 Jinhyuk Jun <jinhyuk.jun@samsung.com> 0.1.41
858 - FIX:
859         - radio/check button : button size bug fix
860
861 * Fri Aug 24 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.40
862 - FIX:
863         - build error fixed
864
865 * Fri Aug 24 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.39
866 - FIX:
867         - listview: style fix, remove filter placeholder
868         - controlbar: divide styles
869         - scrollview: don't skip dragging when click button or inputbox
870         - slider: trim the text on text slider
871 - Spec changes:
872         - remove gray and blue theme
873         - add white and black theme
874         - support new GUI guide
875
876 * Mon Aug 20 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.38
877 - FIX:
878         - fix coment of version tag
879
880 * Fri Aug 17 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.37
881 - FIX :
882         - button: fix alignment
883         - listview: adjust the main text width
884         - virtualgrid: refactoring
885 - Spec changes:
886         - transition: support JQM 1.1.0 transitions
887         - scrollview: support the outer scroll
888         - notification: remove interval feature
889
890 * Tue Aug 14 2012 Youmin Ha <youmin.ha@samasung.com> 0.1.36
891 - FIX :
892         - checkboxRadio: Add left/right padding
893         - button: custom button & icon position
894         - virtuallist: remove 'recreate' test
895 - Spec changes:
896         - header/footer: enable/disable support
897
898 * Fri Aug 10 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.35
899 - FIX :
900         - expandablelist: modify show animation
901         - virtualgrid: Redesign programming interface
902         - popupwindow: code clean and fixed issues
903         - pagelayout: fix content height
904         - license file update
905         - virtuallist: Change programming interface
906         - datetimepicker: getting days correctly
907         - searchbar: set to hidden when cancel button is hide
908         - White theme title font tuning
909 - Spec changes:
910         - default theme tizen-gray to tizen-white
911         - set default page transition to none
912
913 * Thu Aug 02 2012 Jinhyuk Jun <jinhyuk.jun@samsung.com> 0.1.34
914 - FIX :
915         - Back Button : enlarge backbutton click size for white theme
916 - Feature :
917         - Expandable List : Add refresh api
918 * Thu Aug 02 2012 Jinhyuk Jun <jinhyuk.jun@samsung.com> 0.1.33
919 - FIX :
920         - click event touch threshold tuning
921
922 * Thu Aug 02 2012 Jinhyuk Jun <jinhyuk.jun@samsung.com> 0.1.32
923 - FIX :
924         - Add back button highlight effect for white theme
925
926 * Wed Aug 01 2012 Jinhyuk Jun <jinhyuk.jun@samsnug.com> 0.1.31
927 - FIX :
928         - IME checkroutine update, improve relayout on resize event
929         - Add highlight effect for radio button list
930         - Scrollview : fix condition of updatelayout event
931 - Feature : progressing : add show/hide api
932
933 * Fri Jul 27 2012 Koeun Choi <koeun.choi@samsung.com> 0.1.30
934 - FIX : virtuallist, virtualgrid: Clean up temporary jquery.template object to clear cache
935         add default theme option on buttonMarkup for tizen theme
936         [searchbar] first fix : focus/blur fixed
937         back button does not work when long press
938         scrollview: don't auto scrolling if resizing area is too large
939 - Feature : notification : add api to set the icon at tickernoti
940         demo : update the list sample demo
941         Support tizen default theme
942
943 * Mon Jul 23 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.29
944 - Improvements & Bugfixes
945    - HOTFIX: Revert template function with jquery.template
946
947 * Thu Jul 19 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.28
948 - Improvements & Bugfixes
949    - Fix #WEB-1028: memory leak on virtuallist/virtualgrid
950 - Spec changes
951    - $.tizen.loadTheme() function accepts theme name as arguement
952    - Scrollview supports 'updatelayout' callback
953
954 * Tue Jul 17 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.27
955 - Improvements & Bugfixes
956    - Revert 'preventing long-press popup' patch, to fix backbutton to work in SocialMagazine
957
958 * Tue Jul 17 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.26
959 - Improvements & Bugfixes
960    - Add tizen-white theme package, to make rpm build to be finished
961
962 * Tue Jul 17 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.25
963 - Improvements & Bugfixes
964    - Set 'slide' as default page transition effect, by JQM patch
965
966 * Fri Jul 13 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.24
967 - Improvements & Bugfixes
968    - Fix IME show/hide algorithm
969    - Fix error on virtualgrid: link _set_scrollbar_size() function to the one in virtuallist
970
971 * Wed Jul 11 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.23
972 - Improvements & Bugfixes
973    - Fix notification position
974    - Fix unit tests
975
976  Fri Jul 6 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.22
977 - Spec changes
978         - JQM 1.1 upgrade
979 - Improvements & Bugfixes
980         - Transform3D support on scrollview
981         - Page layout supports IME control
982         - Mapview supports pinch zoom on JQM 1.1
983         - Fix wrong character on button in minified version
984         - Virtualgrid supports scrollbar
985         - Lots of bugfixes
986
987 * Fri Jun 22 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.20
988 - Spec changes
989         - Support 'latest' version (by symlink) for tizen-web-ui-fw.js path.
990         - imageslider : supports 'resize' event.
991         - listview : listview has 1px padding-bottom.
992         - loader : Change global namespace, from S to $.tizen.
993         - loader : Move loadCustomGlobalizeCulture() into $.tizen.util namespace.
994 - Improvements & Bugfixes
995         - Scrollview : supports 'translate3d', instead of 'translate'.
996         - notification : reset timer when 'show' or 'refresh' event.
997         - JQM patch : Fix vclick event triggered twice.
998 - Etc.
999         - Add & fix unit tests.
1000
1001 * Thu Jun 14 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.19
1002 - Spec changes
1003         - mapview : new widget.
1004         - notification : add .refresh() API.
1005         - pagecontrol : add .value([val]) API, and change an attribute name 'data-initVal' to 'data-value'.
1006 - Improvements & Bugfixes
1007         - Support minified CSS.
1008         - loader : Fix & refactor 'loading globalize culture file' routine.
1009         - JQM Patch : Calculate min-height of window in javascript code, and remove predefined min-height value from CSS.
1010         - Many more bugfixes.
1011 - Etc.
1012         - Add many unit tests.
1013         - Fix test coverage instrumentation tool to work with current source code.