b990fbe1455d011b952bc1932376334d03219c05
[platform/framework/web/web-ui-fw.git] / packaging / web-ui-fw.spec
1 Name:       web-ui-fw
2 Version:    0.2.29
3 Release:    0
4 Summary:    Tizen Web UI Framework Library
5 Group:      Development/Other
6 License:    MIT
7 BuildArch:  noarch
8 BuildRequires:  make
9 BuildRequires:  nodejs
10 %ifarch %{arm}
11 BuildRequires:  nodejs-x86-arm
12 %endif
13
14 Source0:    %{name}-%{version}.tar.gz
15 Source1001:     %{name}.manifest
16 Source1002:     web-ui-fw-theme-tizen-white.manifest
17 Source1003:     web-ui-fw-theme-tizen-black.manifest
18 Source1004:     web-ui-fw-theme-default.manifest
19 Source1005:     web-ui-fw-devel.manifest
20 Source1006:     web-ui-fw-demo-tizen-winsets.manifest
21
22 %description
23 Tizen Web UI Framework library and theme packages
24
25 %prep
26 %setup -q
27 cp %{SOURCE1001} %{SOURCE1002} %{SOURCE1003} %{SOURCE1004} %{SOURCE1005} %{SOURCE1006} .
28
29 %build
30 make all
31
32 %install
33 make DESTDIR=%{buildroot} install
34
35 %post
36
37 %files
38 %manifest %{name}.manifest
39 /usr/share/tizen-web-ui-fw/*/js/*.js
40 /usr/share/tizen-web-ui-fw/*/js/cultures
41 /usr/share/tizen-web-ui-fw/latest
42 /usr/share/tizen-web-ui-fw/VERSION
43
44 ###############################
45 %package -n web-ui-fw-theme-tizen-gray
46 BuildArch:  noarch
47 Summary:    Tizen Web UI Framework Theme : tizen-gray
48 %Description -n web-ui-fw-theme-tizen-gray
49     Tizen Web UI Framework Theme : tizen-gray
50     Deprecated package, but some binaries still refer this.
51
52 ###############################
53 %package -n web-ui-fw-theme-tizen-white
54 BuildArch:  noarch
55 Summary:    Tizen Web UI Framework Theme : tizen-white
56 %Description -n web-ui-fw-theme-tizen-white
57     Tizen Web UI Framework Theme : tizen-white
58 %files -n web-ui-fw-theme-tizen-white
59 %manifest web-ui-fw-theme-tizen-white.manifest
60 /usr/share/tizen-web-ui-fw/*/themes/tizen-white
61 /usr/share/tizen-web-ui-fw/*/themes/tizen-tizen
62
63 ###############################
64 %package -n web-ui-fw-theme-tizen-black
65 BuildArch:  noarch
66 Summary:    Tizen Web UI Framework Theme : tizen-black
67 %Description -n web-ui-fw-theme-tizen-black
68     Tizen Web UI Framework Theme : tizen-black
69 %files -n web-ui-fw-theme-tizen-black
70 %manifest web-ui-fw-theme-tizen-black.manifest
71 /usr/share/tizen-web-ui-fw/*/themes/tizen-black
72
73 ###############################
74 %package -n web-ui-fw-theme-default
75 BuildArch:  noarch
76 Summary:    Tizen Web UI Framework Theme : default
77 %Description -n web-ui-fw-theme-default
78     Tizen Web UI Framework Theme : default
79 %files -n web-ui-fw-theme-default
80 %manifest web-ui-fw-theme-default.manifest
81 /usr/share/tizen-web-ui-fw/*/themes/default
82
83 ###############################
84 %package -n web-ui-fw-devel
85 BuildArch:  noarch
86 Summary:    Tizen Web UI Framework Developer's files
87 %Description -n web-ui-fw-devel
88     Tizen Web UI Framework Developer's files
89 %files -n web-ui-fw-devel
90 %manifest web-ui-fw-devel.manifest
91 /usr/share/tizen-web-ui-fw/bin
92 /usr/share/tizen-web-ui-fw/template
93 /usr/share/tizen-web-ui-fw/*/js/src
94 /usr/share/tizen-web-ui-fw/*/js/depData.json
95
96 ###############################
97 %package -n web-ui-fw-demo-tizen-winsets
98 BuildArch:  noarch
99 Summary:    Tizen Web UI Framework Demo Application: tizen winset demo
100 %Description -n web-ui-fw-demo-tizen-winsets
101     Tizen Web UI Framework Demo Application: tizen winset demo
102 %files  -n web-ui-fw-demo-tizen-winsets
103 %manifest web-ui-fw-demo-tizen-winsets.manifest
104 /usr/share/tizen-web-ui-fw/demos/tizen-winsets
105
106
107 ###############################
108 %changelog
109 * Fri May 10 2013 Hyunjung Kim <hjnim.kim@samsung.com> 0.2.29
110         - loader: change a warn msg to debug msg
111         - Radio: Radio issue has been fixed ( N_SE-38015 )
112         - Add gallery3D source to the flora license list
113         - Slider: JQM patch fixed ( event.target match )
114         - Tizen-winset: remove unnecessary file
115
116 * Tue May 07 2013 Hyunjung kim <hjnim.kim@samsung.com> 0.2.28
117         - Orientation : add landscape UX
118         - ToggleSwitch : divide jQM and Tizen slider on dragging outside of toggle area
119         - Slider: Popup slider issue has been fixed ( N_SE-36430 )
120
121 * Fri May 03 2013 Hyunjung kim <hjnim.kim@samsung.com> 0.2.27
122         - Splitview: Fix popup error
123         - Tests: Add slider tests checking if jqm slider is used for select elements
124         - Adjust the latest GUI
125         - Handler: Adjust the latest GUI
126         - Swipe: Adjust the latest GUI
127         - Fastscroll: Adjust the latest GUI
128         - ToggleSwitch : bug fix
129         - TizenWinset : bug fix(N_SE-36666)
130         - Gallery3d: Fix Gallery3d TC failure
131         - UnitTC: fix virtualgrid test error
132         - Popup: popup background image have been added
133         - Tokentextarea: Use jQM popup instead of window.alert().
134         - Splitview: Use jQM popup instead of window.alert().
135         - Splitview: Change an option name to start with a capital letter
136         - License: Change flora license version
137         - Tabbar: Adjust the latest GUI
138         - Tokentextarea: Change from 'px' to 'em.'
139         - Fastscroll: Add 'orientationchange' event handler.
140         - Gallery3d: Fix null reference error
141
142 * Fri Apr 26 2013 Youmin Ha <youmin.ha@samsung.com> 0.2.26
143         - PageLayout : bug fix
144         - Gallery3d: Change timing of 'gl-matrix' library's execution
145         - Replace in LoadTheme function strings build with array join with the string concat
146         - Contextpopup: context popup reposition module has been added
147         - Pagelayout : skip to calculate min-height using data-scroll="none"(Issue: DCM-1453)
148         - Splitview: Fix the touchend event error.
149         - Gallery3d: Change event registration method from $.bind() to $.on()
150         - Scrollview : remove useless setTimeout in case scrolls go outside
151         - Naviframe : adjust new SIP down button
152         - Timepicker: Added return false; after vclick
153         - Popupwindow: reserved words has been removed
154         - minor changes: replace one occurrence of array.join with string concat and simplify jQuery arguments
155         - TizenWinset : set default margin for checkbox demo
156         - Tizenwinset: Context popup demo has been changed
157         - TizenDemo : add initial orientation mode to popup demo
158         - Widgets: removed parsing error for legacy javascript engine
159         - Delegate init of popup widget with delegateSelfInitWithSingleSelector
160
161 * Tue Apr 18 2013 Youmin Ha <youmin.ha@samsung.com> 0.2.25
162         - Pinch: pinch event re-implementation to use size
163         - Pagelayout : prevent code inserting window.innerHeight when content calculate
164         - BlachTheme : add missing icon (SIP down)
165         - Scrollview : support absolute position
166         - tizen-winsets: change the font-family in virtualgrid demo to default
167         - TizenWinset : Change default font
168         - tizen-winsets: Change image link
169         - tizenwinset: change images for virtual grid pages
170
171 * Tue Apr 16 2013 Youmin Ha <youmin.ha@samsung.com> 0.2.24
172         - SegmentControl: 2-buttons display issue (N_SE-34200)
173         - Naviframe : remove unnecessary img positioning(N_SE-33969)
174         - Gallery: jslint error fix
175         - TizenWinset : remove landscape SIP on mode
176         - Tizen Black Theme png file changed
177         - Gallery: Images showing bug has been fixed
178         - Scrollview : change horizontal scrollview demo(N_SE-33997)
179         - Tizenwinset: added return false in popup sample
180         - Naviframe : support data-role="button" in header
181         - Additional UnitTC: tizen winset unit tc bugs have been fixed
182         - Checkbox : remove favorite button's display:block(N_SE-33896)
183         - UnitTC: QUnit path has been changed. Priority, function type check function has been added
184         - Tizen-winset : Footer changed from lower case to upper case.
185         - Slider: enhance performance fix
186         - UnitTC: Addtional unit tc ref path has been fixed
187         - virtualgrid: apply overscrolling images to the style of widget
188         - Tabbar : Change overscroll image(left/right)
189         - ensurens: optimizations
190         - ensurens: qunit tests
191         - Tokentextarea: Fix block size error
192         - Fastscroll: Add a feature to fade out Fastscroll widget.
193         - Fastscroll: Add a user interaction at the omitted items.
194         - ImageLoader: Performance fix: apply lazy loading for canvas element
195         - Tests: Add tests for $.imageloader
196         - SegmentControl: 2-buttons display issue (N_SE-34200)
197         - virtuallist: fix width resizing trigger
198         - Timepicker: timepicker is closed when orientationchange event fired
199         - TizenWinset : Tabbar-persist issue.(N_SE-33996)
200         - Add Flora license
201         - collapsible: Fix collapsible list animation bug
202
203 * Wed Apr 10 2013 Youmin Ha <youmin.ha@samsung.com> 0.2.23
204         - Naviframe : modify SIP down button's position
205         - Core: Performance fix for disableSelection and enableSelection
206         - Tests: Core tests for disableSelection
207         - patch: fix small mistakes on the patches
208         - virtuallist: Change demo button style
209         - Button: btn-icon only css has been changed
210         - loader: Fix screen-width option processing
211         - pagelayout: Remember back key when it is hidden
212         - Tizen Black Theme : Tizen black theme png file changed.
213         - UnitTC: tizen winset unit tc bugs have been fixed
214         - TizenWinset: Swipe list sample has been fixed
215         - Radio : remove default radio's width(N_SE-33579)
216         - Scrollview : divide x/y overflow attribute
217         - Gallery: orientation image showing issue has been fixed
218         - Gallery: remove method bug has been fixed
219         - virtualgrid : fix unit-test error and increase test items
220         - Gallery3d: Modify demo & source codes for visibility enhancement.
221         - Gallery3d: Reduce loading time of widget
222         - Gallery3d: Change files' format to unix
223         - Contextpopup: context popup close when window resize event fire
224         - Popup: reverse orientation bug has been fixed
225         - Tokentextarea: modify description
226         - Multimediaview: modify description
227         - JQM: Do not add ui-btn-icon-only class at the select button
228         - build: tizen-black theme package
229         - Tizenwinset: popup script has been removed
230         - Tizenwinset: substring split view text message
231         - Timepicker: data-changed event will be deprecated
232
233 * Fri Apr 5 2013 Youmin Ha <youmin.ha@samsung.com> 0.2.22
234         - tizen-winsets: Fix demo menu
235         - Tizenwinset: Reorder tizenwinset menu
236         - SearchBar: Header button size issue has been fixed
237         - Swipe: list item overflow: hidden has been added
238         - Tizenwinset: href has been added in grouped list
239         - Tizenwinset: Page transition page has been added
240         - Tizenwinset: Radio description has been fixed
241         - This patch fixes problem when base url is changed when site is prefetched.
242         - Entry : limit textarea's width (N_SE-28653)
243         - Naviframe : hide backbutton in case SIP up(remove backbutton makes problem in binding event)
244         - Gallery : next, prev images position bug has been fixed
245         - Multimediaview: Fix display error while handling orientationchange event.
246         - Pagelayout : modify innerHeight dpr calculation in non scrollview mode
247         - Datetimepicker: picker position has been fixed when browser resize event fired
248         - Tips: generate elements sample page javascript has been fixed
249         - Tokentextarea: Fix Tizen-winsets demo.
250
251 * Wed Apr 3 2013 Youmin Ha <youmin.ha@samsung.com> 0.2.21
252         - VirtualGrid: Fix errors on centerTo and resize methods
253         - loader: Fix default font size at device-width viewport
254         - scrollview : remove overflow-x property
255         - Naviframe : fix backbutton position/ change down button icon
256         - Naviframe : bug fix
257         - Tizenwinset : Tizen-winset demo page titles changed Tizen-winset demo page titles changed from lower case to upper case.
258
259 * Fri Mar 29 2013 Youmin Ha <youmin.ha@samsung.com> 0.2.20
260         - JQM Navigation : remove page min-height
261         - Pagelayout : add refresh to pagelayout
262         - Tokentextarea: Changes 'remove' tests to asyncTest
263         - Popup: input tag alignment has been fixed
264         - Tokentextarea: add/remove events are deprecated.
265         - Contextpopup: Support horizontal list
266         - Select: icon z-index has been deleted
267         - Tizenwinset: ui widget order has been changed
268         - Tool: make web app template disable context menu by default
269         - Tizen-winset: change tips for using listview
270         - Loader: calculate font size with mobile width
271         - Naviframe : fix header's back button position
272         - TizenWinset : move locale info to another file
273
274 * Fri Mar 22 2013 Youmin Ha <youmin.ha@samsung.com> 0.2.19
275         - Tizen-winset: Support accessibility for tizen-winset
276         - Orientation : add orientataionchange to tizen-winset
277         - Tokentextarea: Adjusts VI effect for add/remove block
278         - splitview: Support accessibility for splitview
279         - Tizen-winset: Date/time picker guide text has been fixed
280         - Popup: context popup arrow position, setTimeout open method bug have been fixed
281         - fastscroll: Add new indexString API to Fastscroll widget.
282         - splitview: Add new widget
283         - gallery3d: Add new widget
284         - Scrollview : disable VI effect for gesture event
285         - Scrollview : disable SIP outerscroll
286         - Tizen-winset: resize VirtualGrid widget in demo
287         - Tizen-winsets: Refactor searchbar subpages
288         - Tizen-winsets: Remove depracated usage of virtuallist
289         - Tizen-winsets: Move js code from main.js to subpages
290         - Tizen-winsets: Refactor virtual grid demo subpages
291         - Tizen-winsets: Move css files from index to proper subpages
292         - Tizen-winsets: Refactor list dialogue edit subpage
293         - Tizen-winsets: Refactor pagelayout subpages
294         - Tizen-winsets: Refactor tips subpages
295         - Tizen-winsets: Move subpages popup files from index.html
296         - Tizen-winsets: Move subpages javascript files from index.html
297         - virtualgrid: fix improperly merged codes
298         - ColorTheme : remove unused color value(1st)
299         - Scrollview : change scrollbar draw
300         - Popup: Apply popup background dim
301         - Tizen-winsets: Move tokentextarea demo to external page.
302         - Tizen-winsets: Move tabbar persist demo to external page.
303         - Tizen-winsets: Remove notImplemented page
304         - Tizen-winsets: Move slider demo page to external subpage
305         - Tizen-winsets: Fix ids, remove duplicated names for sliders
306         - Tizen-winsets: Remove event for changing theme
307         - tool: Fix wgt sample app generator tool to make apps be installed
308         - demos : change live to on
309         - build: Trim compiled CSS files
310         - Gallery: CSS left -> translate or translate3D
311         - Tokentextarea: Disfunctional APIs fixed.
312
313 * Thu Mar 7 2013 Youmin Ha <youmin.ha@samsung.com> 0.2.18
314         - build: Fix Makefile to add globalize to the minified lib
315         - build-tools : upgrade less to v1.3.3
316         - demos : change normal js path to minified js
317         - Theme : remove reduantant less - dayselector, optionheader, nocontents
318         - multimediaview : fix full-screen mode.
319         - multimediaview : fix 'width', 'height' and 'fullScreen' methods
320         - Extendablelist: Added min-height "load more button" in listitem
321         - virtualgrid: adjusts VI effect for an overflow action
322         - ControlGroup : change ellipsis font color (press/normal)
323         - multimediaview: Add an error message to Multimediaview
324         - virtualgrid: adjusts triple flick gesture
325         - scrollview: add function for getting width of view
326         - scrollview: adds support x axis gesture scroll
327         - multimediaview : fix audio control
328         - tabbar : tabbar slide animation change
329         - TizenWinsetDemo : 2line-text demo bug fix
330         - collapsible: Fix demo to show radio button correctly in the collapsible list
331         - collapsible: Set listitem position to relative
332         - UnitTC: added list divider unit test
333         - Style: unnecessary color codes have been deleted and modified
334         - build: Module build implementation
335         - UnitTC: Additional unit testcases have been added
336         - listview : bug fix
337         - Naviframe : remove back button's hover effect
338         - TizenDemo : remove back button
339         - Transition: added more-button vi
340         - pinch: added new event called pinch
341         - Popup: css word-wrap:break-word has been added
342         - virtualgrid: memory leak fix
343         - progress: set to init state at pending bar
344         - progress: add margin of top/bottom
345         - unit-test: split progress test and progressbar test
346         - Tizen-winset: Context popup sample page guide text has been changed
347         - multimediaview: fix the height of widget when full-screen mode
348         - JQM: performance tuning
349
350 * Tue Feb 19 2013 Minkyu Kang <mk7.kang@samsung.com> 0.2.17
351         - DialogueList : delete border top value / add sample's text ellipsis
352         - Tokentextarea: Add scroll-to-top for Grouping On/Off regarding #N_SE-24877
353         - Multimediaview: Fix mute function
354         - Tizen-winset: list vi index guide textbox has been removed
355         - Tizen-winset: custom button texts have been changed
356         - slider: move popup div to out of content
357         - TizenWinset: disable context popup in multimediaview
358         - Swipe: wrong style name has been fixed
359         - demo: add the sample at dialogue list
360         - listview: Add ui-li-has-right-btn class with toggleswitch
361         - WinsetDemo : change wrong title name
362
363 * Mon Jan 28 2013 Youmin Ha <youmin.ha@samsung.com> 0.2.16
364         - demo: checkbox: reduce button's width
365         - tabbar : delete right/left tab animation color
366         - scrollview: fix the scroll position at keydown event
367         - groupControl : change footer groupControl from min-width to percentage
368         - scrollview: get height of softkeyboard correctly
369         - tizen-winset: Add name attr to all radio inputs
370         - virtualgrid: changes event binding target
371         - scrollview: skip the drag if target is textarea
372         - scrollview: skip the dragging of parent scrollview
373         - scrollview: apply the scaling ratio to the soft keyboard
374         - demos: apply disabled option in textarea
375         - demo: remove unused codes
376         - demo: datetimepicker: show selected date correctly
377         - listview: Adjust bubble listitem width and margin
378         - pagelayout : change external refresh call and ime status follow only current page
379         - toggleSwitch : bug fix
380         - unit-test: slider: fix the move test
381         - handler: fix jslint error
382         - ToggleSwitch : set image toggleswitch background attribute
383
384 * Mon Jan 28 2013 Youmin Ha <youmin.ha@samsung.com> 0.2.15
385         - slider: increase the text width(N_SE-23397)
386         - virtualgrid: DOM element leak fix
387         - header: Move button top higher in header with tabbar(N_SE-22253)
388         - datatimepicker: don't open the popup before popupafterclose event is fired(N_SE-23027)
389         - handler: bug fix (regarding enableHandler function )
390         - demo:fix syntax error
391
392 * Sat Jan 26 2013 Youmin Ha <youmin.ha@samsung.com> 0.2.14
393         - demo: fix demo using tizen device API
394         - multimediaview: reset the height of container
395         - input: modify css correctly
396         - multimediaview: fix the height of widget
397         - gallery: bind create event
398         - progress: bind create event
399         - slider: bind create event
400         - progressbar: bind create event
401         - progressbar: event trigger correctly
402         - popup: fix height of popup scroller
403         - build: add continue option to jslint
404         - ctxpopup demo : bug fix
405         - demo: fix searchbar demo to use different IDs
406         - demo: extract routine executing Tizen device API
407         - toggleswitch : set default margin, delete box padding
408
409 * Thu Jan 24 2013 Youmin Ha <youmin.ha@samsung.com> 0.2.13
410         - virtuallist: Prevent replacing contents on nonexist element
411         - JQM: Trim text in listitem to get index in autodivider
412         - JQM: Remove trailing whitespace in jqm patch
413         - scrollview: get the height including margin
414         - multimediaview: bug fix ( scrolling in full-screen mode )
415         - virtuallist: set listitem width to exclude listitem left/right margin
416         - demo: fix virtuallist sample layout
417         - progress: set the position explicitly
418         - progress: rename from progressing to progress
419         - build: remove unused files
420         - searchbar: fix jslint errors
421         - src: fix file permissions
422         - button : change jump left icon
423
424 * Wed Jan 23 2013 Minkyu Kang <mk7.kang@samsung.com> 0.2.12
425         - theme : button icon - scrolltop, scrolleft icon changed.
426         - build: cleanaup Makefile
427         - pagelayout: fix jslint error
428         - virtualgrid: Fix jslint errors
429         - tabbar : jslint bug error fix
430         - build: add regexp option to jslint
431         - virtuallist: fix jslint errors
432         - handler: Apply the exceptional principle for scrollbar on Handler.
433         - build: remove unused copyright
434         - loader: extract log class for tizen web, and fix jslint errors
435         - loader: Viewport width is set to document width
436         - popupwindow: fix jslint error
437         - build: fix Makefile for tizen-white theme
438         - build: remove unused libraries
439         - datetimepicker: fix jslint error
440         - slider: fix jslint error
441         - demo: remove deprecated demos
442         - pagelayout : change to call relayout with this page
443         - Tokentextarea: Block size error fixed.
444         - handler: bug fix (handler activation)
445
446 * Tue Jan 22 2013 Minkyu Kang <mk7.kang@samsung.com> 0.2.11
447         - demo: clear input text value with cancel button click
448         - demo: Adjust textarea height automatically
449         - naviframe : bug fix
450         - tabbar : bug fix
451         - Fastscroll: popup position has been changed
452         - Button: custom button icon path, margin have been changed
453         - toggleswitch : bug fix
454         - slider: increase the margin
455         - datetimepicker: close the popup after select the value
456         - unit-test : add page backbutton control test
457         - Demo: added guide text and change input type in list vi
458         - remove legacy codes : jquery-geo
459         - Datetimepicker: text-main max-width has been removed
460         - Radio: control group border has been removed
461         - Demo: remove 'tab' space
462         - UnitTC: swipe unit tc has been fixed
463         - UnitTC: jQuery path has been fixed
464         - Button: bug fix when button has not a text
465         - tizen-winset: timepicker: demo title is changed
466
467 * Fri Jan 18 2013 Minkyu Kang <mk7.kang@samsung.com> 0.2.10
468         - tizen-winsets: codes cleanup
469         - datetimepicker: date calibration when year is changed
470         - Demo: textarea size has been changed
471         - Demo: Naviframe morebutton demo has been changed
472         - remove unused unit test cases : gallery3d
473         - tizen-winset: remove links
474
475 * Thu Jan 17 2013 Minkyu Kang <mk7.kang@samsung.com> 0.2.9
476         - gallery: use timeout function instead of interval
477         - Tokentextarea: Display error fixed.
478         - scrollview: Fix not selector to respond with jQuery1.8.2
479         - tabbar: remove the width of last element
480         - Demo: apply css 'user-select:none'
481         - Button: guide text has been shorten
482         - build: Update jQuery to 1.8.2 (JQM1.2 compliant)
483         - virtuallist: Fix mistyping
484         - demo: Fix tizen function namespace in demo
485         - virtuallist: Rewrite listitem replacing algorithm
486         - fastscroll: modify from not selector to function
487         - extendablelist: Fix unit-test
488         - tabbar : prefix to tabbar scroll event
489         - Popupwindow: removed unvalid selector in jquery 1.8.2
490         - slider: adjust handle text as length of value
491         - Demo: 3 buttons in popup text has been changed
492         - src: codes cleanup
493         - demo : remove trailing empty strings
494         - demo : rename TizenWinset list items
495         - button : change from long text list to multiline list
496         - build: Remove JQM1.1.0 patches
497         - Popup: Apply tizen style popup and attribute support
498         - JQM: Fix buttonmarkup bug keeping ui-btn-down class
499         - UnitTest: folder and file renamed, QUnit path was modified
500         - tizen-winsets: button: fix textarea width
501         - Swipe: event name error has been fixed
502
503 * Tue Jan 15 2013 Minkyu Kang <mk7.kang@samsung.com> 0.2.8
504         - Button: button padding has been updated
505         - virtuallist: fix unique listitem ID bug
506         - checkbox, radio : change display attr
507         - Button: bug fix ( when data style circle button on text )
508         - handler: bug fix (when scrolling with multi selection)
509         - JQM: adjust patch number
510         - gallery: show the widget after pageshow
511         - TokenTextArea : resource add ( press image )
512         - gallery: adds function that set the index to value API
513         - configure: set TIZEN default configures
514         - footer: h tag display attribute value has been changed
515         - buttons : demo bug fix
516         - searchbar : demo page bug fix
517         - tizen demo : bug fix
518         - build: remove JQM1.1.0
519         - Tokentextarea: Fix issues
520         - scrollview: block the multi touch
521         - list : dialogue list demo change
522         - pagelayout : update dynamic control
523         - Demo: Context popup close method has been changed
524
525 * Fri Jan 11 2013 Minkyu Kang <mk7.kang@samsung.com> 0.2.7
526         - slider: set text container's width as text length
527         - Timepicker: li max-width has been changed
528         - remove experimental feature - mapview.
529         - scrollview: added conditions for finding slider
530         - UnitTC: Pass,error count save method has been changed
531         - confix.xml: default config added for tizen basic applications
532         - Swipe: p tag margin value is set '0'
533         - packaging: remove unused file
534         - tabbar : bug fix
535         - list demo : bug fix
536         - tizen-winsets: gallery: move to new section
537         - tizen-winsets: autodivider: removes link of list
538         - demos: entry of number-pattern name is changed from 'number' to 'number-pattern'
539         - pagelayout : padding calculate change, ime footer check changed
540         - tizen-winsets: searchbar: scroll to the top when type the character
541         - searchbar : bug fix
542         - demo: Fix virtuallist demo following new list style
543         - demo: Add word-wrap:break-word and remove parag. width
544         - Demo: button max-width has been set( 3 buttons in popup )
545         - back button control demo : bug fix
546         - toggleswitch : demo page modify
547         - slider: add margin-top and margin-bottom
548         - tabbar demo : bug fix
549         - Popup: IME hide when popup is closed
550         - token textarea : bug fix
551         - Timepicker: change get attribute method
552         - footer demo : bug fix
553         - unit-test: gallery: add new APIs
554         - gallery: adds support new APIs
555
556 * Fri Jan 04 2013 Minkyu Kang <mk7.kang@samsung.com> 0.2.6
557         - JQM: patches cleanup
558         - Button: data-corners attribute has been added
559         - unit-test: slider: fix class name of background
560         - progressbar, slider: fix less variable typo
561         - Tabbar : VI update
562         - notification: add top position at fix class
563         - demo: entry demo page change
564         - css: .ui-disabled added
565         - tizen-winset: token textarea: remove back button at demo page
566         - theme: Remove unused less file
567         - pagelayout : content min height bug fix
568         - scrollview: skip the dragging when target is slider's handle
569         - scrollview: update and refactoring the scroll effect
570         - UnitTest:JQM Unit TC helper has been added,TCs have been modified
571         - Swipe: demo page html error has been fixed
572         - listview: Add add/delete animation (VI)
573         - Popup: demo page has been modified
574         - tizen demo : bug fix
575         - searchbar : demo page change(change front button and add behaviour)
576         - pagelayout : add min height to content
577         - gallery: rename 'Image Slider' to 'Gallery' in tizen-winsets demo and tests
578         - back button control demo : change url link to data-rel="back"
579         - loader: Skip loading theme CSS with a custom css code
580         - Button: support no-text in button
581         - collapsible: Fix syntax error
582         - slider: use data-highlight attribute
583         - collapsible: Rotate animation to collapsible heading icon
584         - toggleswitch : text switch bug fix
585         - remove candidates-calendarpicker
586         - Patch: Fix misc mistakes in JQM patches
587         - searchbar : animation change
588         - gallery: get the width correctly
589         - demo: data-framework-viewport-scale attribute is changed to data-framework-viewport-width
590         - collapsible: Add collapse/expand animation (VI)
591         - datetimepicker: VI update
592         - JQM: set transition to pop as default
593         - tabbar : bug fix in case none li element case
594         - scrollview: fix the drag bug
595         - Button: Button icon scrolltop, left has beed added
596         - Swipe: VI update and swipe speed has been changed
597         - jqm: fix errors in patch files
598         - unit-test: swipe: fixed the destroy test
599
600 * Wed Dec 26 2012 Youmin Ha <youmin.ha@samsung.com> 0.2.5
601         - Revert "[checkboxradio] exception handling for input"
602                 This reverts commit 72478c32704fa96362db577e6cf9511777919ea8.
603                 Tizen style supports no-label radio and checkbox when making lists.
604                 So it ignores html input operation. Instead, it supports tizen style radio and checkbox theme.
605
606 * Thu Dec 20 2012 Youmin Ha <youmin.ha@samsung.com> 0.2.4
607 - Fix:
608         - modify segment background
609         - rearrange check, radio input
610         - CtxPopup: Scale up/ down popup vi(poptop, popbottom)
611         - button: style has beed added(box,circle,nobg,round)
612         - favorite resource added
613         - demo/tizen-winsets: add footer and back button
614         - remove autodividers unit test
615         - add divider for tabbar
616         - checkboxradio: exception handling for input
617         - segment control backward compatiblity
618         - Fix collapsible unit-test
619         - remove toggleswitch
620         - add patch for remove segment text
621 - Spec changes:
622         - replace controlbar to tabbar
623
624 * Fri Dec 14 2012 Minkyu Kang <mk7.kang@samsung.com> 0.2.3
625 - FIX:
626         - slider: add image
627         - button: data-icon support, styles fix
628         - progressbar: modify the background
629         - scrollview: auto scrolling bug fix
630         - pagelayout: IME concept is changed
631 - Spec changes:
632         - dialogue: add edit mode
633         - nocontents: removed
634         - pagecontrol: removed
635         - dayselector: removed
636         - expandablelist: removed
637
638 * Thu Dec 10 2012 Youmin Ha <youmin.ha@samsung.com> 0.2.2
639 - FIX:
640         - chang searchbar/slider images
641         - delete redundant button images
642 - Spec changes:
643         - Change widget name: shortcutscroll -> fastscroll
644
645 * Thu Dec 07 2012 Youmin Ha <youmin.ha@samsung.com> 0.2.1
646 - FIX:
647         - jqm1.2: Change collapsible style to meet expandable list
648         - remove jquery-geo-1.0.a4
649         - unit-test: rename from imageslider to gallery
650         - nocontent: add warning message
651         - Handler: Fix issues in jqm1.2
652         - Multimediaview: modify APIs & comments
653         - Mapview: Fix issues in jqm1.2
654         - JQM: clean up patches
655         - Swipelist: refactoring swipelist
656         - Popup,Ctxpopup: Apply tizen style popup in JQM1.2
657         - rearrange button's data-icon resources
658 - Spec changes:
659         - Virtualgrid: remove option ('data-itemcount')
660         - gallery: rename the widget from imageslider to gallery
661         - add new style for searchbar
662         [tokentextarea] multi-button entry renamed as token text area. API & comments modified.
663
664 * Thu Dec 06 2012 Minkyu Kang <mk7.kang@samsung.com> 0.2.0
665 - FIX:
666         - fix jslint error
667         - remove unused files
668         - change naviframe style
669 - Spec changes:
670         - applied jQuery Mobile 1.2.0
671         - remove optionheader
672
673 * Fri Nov 30 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.64
674 - FIX:
675         - fix unit tests
676         - remove unused theme files
677         - timepicker: text position fix
678         - scrollview: set dragstop when mouse is out of window
679         - listview: fix margin
680 - Spec changes:
681         - support data-framework-viewport-width
682
683 * Fri Nov 23 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.63
684 - FIX:
685         - dayselector: fix size
686         - remove unised styles
687         - divider: set non-press effect to default option
688         - popupwindow: fix window closing failure
689         - handler: GUI implementation
690         - TC: fix unit TCs
691         - scrollview: fix padding size
692 - Spec changes:
693         - Remove color widgets
694         - add $.tizen.pkgVersion for SDK
695 - Etc.
696         - JSDuck documents
697
698 * Fri Nov 16 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.62
699 - FIX:
700         - Many winsets: Fix layout
701         - Footer: fix position to bottom
702 - Spec changes:
703         - Remove color widgets
704
705 * Fri Nov 09 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.61
706 - FIX:
707         - Many widgets: New UX 0.6 theme implementation
708         - widgetex: init speed up
709         - scrollview: fix scrollbar and scale animation
710         - scrollview: fix scroll position when updatelayout is triggered
711         - header/footer: make textselection disable, except input type="text"
712
713 * Wed Nov 07 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.60
714 - FIX:
715         - Remove tizen-black theme package description
716
717 * Tue Nov 06 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.59
718 - FIX:
719         - Fix theme name to meet the change of system theme name: white->tizen
720         - Popupwindow: fix left position
721         - Remove black theme
722         - footer: remove label, legend drawing
723 - Spec changes:
724         - UX guide v0.4 : button, layout
725
726 * Fri Oct 26 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.58
727 - FIX:
728         - scrollview: Fix outer scroll amount
729         - tabbar: fix tapping twice
730         - popupwindow: fix left position
731
732 * Wed Oct 24 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.57
733 - FIX:
734         - expandablelist: icon color fix
735         - scrollview: Fix xy scroll
736         - footer: Remove dummy div
737         - Make string concatnation effective in inline-protos.sh
738 - Spec changes:
739         - refresh header/footer when drag&drop event is fired in GUI builder
740         - searchbar: delete cancel button
741         - don't trigger updatelayout event when keyup event comes
742
743 * Mon Oct 15 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.56
744 - FIX:
745         - Toggleswitch: Change event name from 'changed' to 'change'
746         - Notification: Revert interval feature
747
748 * Tue Oct 09 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.55
749 - FIX:
750         - Fix SMACK manifest bug (S1-9098)
751
752 * Fri Oct 05 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.54
753 - FIX:
754         - handler: don't append a handler if handler is not enabled
755         - scrollview: use static value
756         - datetimepicker: fix date-format HH display error
757 - ETC:
758         - provide jquery.min.js
759         - barlayout: codes clean
760         - remove unused file
761
762 * Wed Sep 26 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.53
763 - FIX:
764         - listview: change focused color
765         - multibuttonentry: code refactoring
766         - datetimepicker: modify date format when triggered date-changed event
767         - slider: fix the top of slider bar
768         - add event blocker when load a first page
769
770 * Fri Sep 21 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.52
771 - ETC.
772         - Move SMACK manifest files to the top SRCDIR
773
774 * Fri Sep 21 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.51
775 - FIX:
776         - Popup: Do not focus container
777         - Header: show backbutton when both tabbar and header are present together
778         - Multi button entry: text ellipsis, code refactoring
779
780 * Fri Sep 21 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.50
781 - ETC.
782         - Apply SMACK manifest
783
784 * Thu Sep 20 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.49
785 - FIX:
786         - JSLINT code clean-up
787         - scrollview: firefox support
788         - scrollview: fix finding slider handle
789         - list: tweak text ellipsis
790         - checkbox: fix selecting wrong label tag (N_SE-8370)
791         - imageslider: check parameter
792         - smallpopup: fix position
793         - searchbar: fix 'clear' button size
794 - Spec changes:
795         - scrollview: support outer scroll
796         - JQM: block click event only with the element that does preventdefault on vclick(N_SE-6090)
797         - remove S/W IME control
798
799 * Thu Sep 13 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.48
800 - FIX:
801         - Add missing icon: controlbar
802         - scrollview: tune scrolling animatio ninterval
803         - datetimepicker: digit/triangle position
804         - datetimepicker: fix day overflow issue
805 - Spec changes:
806         - scrollview: show scrollbar when page is showed
807         - scrollview: disable outer scroll
808         - extendablelist: change api with legacy support
809         - add ui-text-ellipsis class
810
811 * Mon Sep 10 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.47
812 - FIX:
813         - scrollveiw: fix height of view
814         - searchbar: support placeholder
815 - Spec changes:
816         - add ui-text-ellipsis class
817
818 * Fri Sep 07 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.46
819 - FIX:
820         - scrollview: scrolling bug fix
821         - controlbar: fix width of controlbar item
822 - Spec changes:
823         - searchbar: don't hide icon
824         - popup: update JQM poup widget
825
826 * Fri Sep 05 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.45
827 - FIX:
828         - controlbar: set correct controlbar width of last element
829         - slider: get popup enable value correctly
830         - use Date.now() instead of (new Data()).getTime()
831         - popupwindow: fix the background color of popup scroller
832         - listview: add padding-left to expandable list
833         - add ellipsis for title area support
834
835 * Fri Aug 31 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.44
836 - FIX:
837         - swipelist: show list items correctly
838         - datetimepicker: set last day, if day is overflowed
839 - Spec changes:
840         - controlbar: update icons
841
842 * Tue Aug 29 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.43
843 - FIX:
844         - notification: fix typo
845 - Spec changes:
846         - controlbar: update icons
847
848 * Tue Aug 28 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.42
849 - FIX:
850         - multimediaview: video progress bar display normally for too samll
851         - segmentcontrol: remove media query
852         - scrollview: add outer scroll condition
853         - datetimepicker: modify triangle size
854         - popupwindow: set the screen height explicitly
855         - notification: add multiline text
856 - Spec changes:
857         - mutibuttonentry: support new GUI
858         - virtualgrid: support new GUI
859
860 * Mon Aug 27 2012 Jinhyuk Jun <jinhyuk.jun@samsung.com> 0.1.41
861 - FIX:
862         - radio/check button : button size bug fix
863
864 * Fri Aug 24 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.40
865 - FIX:
866         - build error fixed
867
868 * Fri Aug 24 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.39
869 - FIX:
870         - listview: style fix, remove filter placeholder
871         - controlbar: divide styles
872         - scrollview: don't skip dragging when click button or inputbox
873         - slider: trim the text on text slider
874 - Spec changes:
875         - remove gray and blue theme
876         - add white and black theme
877         - support new GUI guide
878
879 * Mon Aug 20 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.38
880 - FIX:
881         - fix coment of version tag
882
883 * Fri Aug 17 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.37
884 - FIX :
885         - button: fix alignment
886         - listview: adjust the main text width
887         - virtualgrid: refactoring
888 - Spec changes:
889         - transition: support JQM 1.1.0 transitions
890         - scrollview: support the outer scroll
891         - notification: remove interval feature
892
893 * Tue Aug 14 2012 Youmin Ha <youmin.ha@samasung.com> 0.1.36
894 - FIX :
895         - checkboxRadio: Add left/right padding
896         - button: custom button & icon position
897         - virtuallist: remove 'recreate' test
898 - Spec changes:
899         - header/footer: enable/disable support
900
901 * Fri Aug 10 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.35
902 - FIX :
903         - expandablelist: modify show animation
904         - virtualgrid: Redesign programming interface
905         - popupwindow: code clean and fixed issues
906         - pagelayout: fix content height
907         - license file update
908         - virtuallist: Change programming interface
909         - datetimepicker: getting days correctly
910         - searchbar: set to hidden when cancel button is hide
911         - White theme title font tuning
912 - Spec changes:
913         - default theme tizen-gray to tizen-white
914         - set default page transition to none
915
916 * Mon Aug 02 2012 Jinhyuk Jun <jinhyuk.jun@samsung.com> 0.1.34
917 - FIX :
918         - Back Button : enlarge backbutton click size for white theme
919 - Feature :
920         - Expandable List : Add refresh api
921 * Mon Aug 02 2012 Jinhyuk Jun <jinhyuk.jun@samsung.com> 0.1.33
922 - FIX :
923         - click event touch threshold tuning
924
925 * Mon Aug 02 2012 Jinhyuk Jun <jinhyuk.jun@samsung.com> 0.1.32
926 - FIX :
927         - Add back button highlight effect for white theme
928
929 * Mon Aug 01 2012 Jinhyuk Jun <jinhyuk.jun@samsnug.com> 0.1.31
930 - FIX :
931         - IME checkroutine update, improve relayout on resize event
932         - Add highlight effect for radio button list
933         - Scrollview : fix condition of updatelayout event
934 - Feature : progressing : add show/hide api
935
936 * Mon Jul 27 2012 Koeun Choi <koeun.choi@samsung.com> 0.1.30
937 - FIX : virtuallist, virtualgrid: Clean up temporary jquery.template object to clear cache
938         add default theme option on buttonMarkup for tizen theme
939         [searchbar] first fix : focus/blur fixed
940         back button does not work when long press
941         scrollview: don't auto scrolling if resizing area is too large
942 - Feature : notification : add api to set the icon at tickernoti
943         demo : update the list sample demo
944         Support tizen default theme
945
946 * Mon Jul 23 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.29
947 - Improvements & Bugfixes
948    - HOTFIX: Revert template function with jquery.template
949
950 * Thu Jul 19 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.28
951 - Improvements & Bugfixes
952    - Fix #WEB-1028: memory leak on virtuallist/virtualgrid
953 - Spec changes
954    - $.tizen.loadTheme() function accepts theme name as arguement
955    - Scrollview supports 'updatelayout' callback
956
957 * Tue Jul 17 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.27
958 - Improvements & Bugfixes
959    - Revert 'preventing long-press popup' patch, to fix backbutton to work in SocialMagazine
960
961 * Tue Jul 17 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.26
962 - Improvements & Bugfixes
963    - Add tizen-white theme package, to make rpm build to be finished
964
965 * Tue Jul 17 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.25
966 - Improvements & Bugfixes
967    - Set 'slide' as default page transition effect, by JQM patch
968
969 * Fri Jul 13 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.24
970 - Improvements & Bugfixes
971    - Fix IME show/hide algorithm
972    - Fix error on virtualgrid: link _set_scrollbar_size() function to the one in virtuallist
973
974 * Wed Jul 11 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.23
975 - Improvements & Bugfixes
976    - Fix notification position
977    - Fix unit tests
978
979  Fri Jul 6 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.22
980 - Spec changes
981         - JQM 1.1 upgrade
982 - Improvements & Bugfixes
983         - Transform3D support on scrollview
984         - Page layout supports IME control
985         - Mapview supports pinch zoom on JQM 1.1
986         - Fix wrong character on button in minified version
987         - Virtualgrid supports scrollbar
988         - Lots of bugfixes
989
990 * Fri Jun 22 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.20
991 - Spec changes
992         - Support 'latest' version (by symlink) for tizen-web-ui-fw.js path.
993         - imageslider : supports 'resize' event.
994         - listview : listview has 1px padding-bottom.
995         - loader : Change global namespace, from S to $.tizen.
996         - loader : Move loadCustomGlobalizeCulture() into $.tizen.util namespace.
997 - Improvements & Bugfixes
998         - Scrollview : supports 'translate3d', instead of 'translate'.
999         - notification : reset timer when 'show' or 'refresh' event.
1000         - JQM patch : Fix vclick event triggered twice.
1001 - Etc.
1002         - Add & fix unit tests.
1003
1004 * Thu Jun 14 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.19
1005 - Spec changes
1006         - mapview : new widget.
1007         - notification : add .refresh() API.
1008         - pagecontrol : add .value([val]) API, and change an attribute name 'data-initVal' to 'data-value'.
1009 - Improvements & Bugfixes
1010         - Support minified CSS.
1011         - loader : Fix & refactor 'loading globalize culture file' routine.
1012         - JQM Patch : Calculate min-height of window in javascript code, and remove predefined min-height value from CSS.
1013         - Many more bugfixes.
1014 - Etc.
1015         - Add many unit tests.
1016         - Fix test coverage instrumentation tool to work with current source code.