Add gallery3D source to the flora license list
[platform/framework/web/web-ui-fw.git] / packaging / web-ui-fw.spec
1 Name:       web-ui-fw
2 Version:    0.2.28
3 Release:    0
4 Summary:    Tizen Web UI Framework Library
5 Group:      Development/Other
6 License:    MIT
7 BuildArch:  noarch
8 BuildRequires:  make
9 BuildRequires:  nodejs
10 %ifarch %{arm}
11 BuildRequires:  nodejs-x86-arm
12 %endif
13
14 Source0:    %{name}-%{version}.tar.gz
15
16 %description
17 Tizen Web UI Framework library and theme packages
18
19 %prep
20 %setup -q
21
22 %build
23 make all
24
25 %install
26 make DESTDIR=%{buildroot} install
27
28 %post
29
30 %files
31 %manifest web-ui-fw.manifest
32 /usr/share/tizen-web-ui-fw/*/js/*.js
33 /usr/share/tizen-web-ui-fw/*/js/cultures
34 /usr/share/tizen-web-ui-fw/latest
35 /usr/share/tizen-web-ui-fw/VERSION
36
37 ###############################
38 %package -n web-ui-fw-theme-tizen-gray
39 BuildArch:  noarch
40 Summary:    Tizen Web UI Framework Theme : tizen-gray
41 %Description -n web-ui-fw-theme-tizen-gray
42     Tizen Web UI Framework Theme : tizen-gray
43     Deprecated package, but some binaries still refer this.
44
45 ###############################
46 %package -n web-ui-fw-theme-tizen-white
47 BuildArch:  noarch
48 Summary:    Tizen Web UI Framework Theme : tizen-white
49 %Description -n web-ui-fw-theme-tizen-white
50     Tizen Web UI Framework Theme : tizen-white
51 %files -n web-ui-fw-theme-tizen-white
52 %manifest web-ui-fw-theme-tizen-white.manifest
53 /usr/share/tizen-web-ui-fw/*/themes/tizen-white
54 /usr/share/tizen-web-ui-fw/*/themes/tizen-tizen
55
56 ###############################
57 %package -n web-ui-fw-theme-tizen-black
58 BuildArch:  noarch
59 Summary:    Tizen Web UI Framework Theme : tizen-black
60 %Description -n web-ui-fw-theme-tizen-black
61     Tizen Web UI Framework Theme : tizen-black
62 %files -n web-ui-fw-theme-tizen-black
63 %manifest web-ui-fw-theme-tizen-black.manifest
64 /usr/share/tizen-web-ui-fw/*/themes/tizen-black
65
66 ###############################
67 %package -n web-ui-fw-theme-default
68 BuildArch:  noarch
69 Summary:    Tizen Web UI Framework Theme : default
70 %Description -n web-ui-fw-theme-default
71     Tizen Web UI Framework Theme : default
72 %files -n web-ui-fw-theme-default
73 %manifest web-ui-fw-theme-default.manifest
74 /usr/share/tizen-web-ui-fw/*/themes/default
75
76 ###############################
77 %package -n web-ui-fw-devel
78 BuildArch:  noarch
79 Summary:    Tizen Web UI Framework Developer's files
80 %Description -n web-ui-fw-devel
81     Tizen Web UI Framework Developer's files
82 %files -n web-ui-fw-devel
83 /usr/share/tizen-web-ui-fw/bin
84 /usr/share/tizen-web-ui-fw/template
85 /usr/share/tizen-web-ui-fw/*/js/src
86 /usr/share/tizen-web-ui-fw/*/js/depData.json
87
88 ###############################
89 %package -n web-ui-fw-demo-tizen-winsets
90 BuildArch:  noarch
91 Summary:    Tizen Web UI Framework Demo Application: tizen winset demo
92 %Description -n web-ui-fw-demo-tizen-winsets
93     Tizen Web UI Framework Demo Application: tizen winset demo
94 %files  -n web-ui-fw-demo-tizen-winsets
95 /usr/share/tizen-web-ui-fw/demos/tizen-winsets
96
97
98 ###############################
99 %changelog
100 * Tue May 07 2013 Hyunjung kim <hjnim.kim@samsung.com> 0.2.28
101         - Orientation : add landscape UX
102         - ToggleSwitch : divide jQM and Tizen slider on dragging outside of toggle area 
103         - Slider: Popup slider issue has been fixed ( N_SE-36430 )
104
105 * Fri May 03 2013 Hyunjung kim <hjnim.kim@samsung.com> 0.2.27
106         - Splitview: Fix popup error
107         - Tests: Add slider tests checking if jqm slider is used for select elements
108         - Adjust the latest GUI
109         - Handler: Adjust the latest GUI
110         - Swipe: Adjust the latest GUI
111         - Fastscroll: Adjust the latest GUI
112         - ToggleSwitch : bug fix
113         - TizenWinset : bug fix(N_SE-36666)
114         - Gallery3d: Fix Gallery3d TC failure
115         - UnitTC: fix virtualgrid test error
116         - Popup: popup background image have been added
117         - Tokentextarea: Use jQM popup instead of window.alert().
118         - Splitview: Use jQM popup instead of window.alert().
119         - Splitview: Change an option name to start with a capital letter
120         - License: Change flora license version
121         - Tabbar: Adjust the latest GUI
122         - Tokentextarea: Change from 'px' to 'em.'
123         - Fastscroll: Add 'orientationchange' event handler.
124         - Gallery3d: Fix null reference error
125
126 * Fri Apr 26 2013 Youmin Ha <youmin.ha@samsung.com> 0.2.26
127         - PageLayout : bug fix
128         - Gallery3d: Change timing of 'gl-matrix' library's execution
129         - Replace in LoadTheme function strings build with array join with the string concat
130         - Contextpopup: context popup reposition module has been added
131         - Pagelayout : skip to calculate min-height using data-scroll="none"(Issue: DCM-1453)
132         - Splitview: Fix the touchend event error.
133         - Gallery3d: Change event registration method from $.bind() to $.on()
134         - Scrollview : remove useless setTimeout in case scrolls go outside
135         - Naviframe : adjust new SIP down button
136         - Timepicker: Added return false; after vclick
137         - Popupwindow: reserved words has been removed
138         - minor changes: replace one occurrence of array.join with string concat and simplify jQuery arguments
139         - TizenWinset : set default margin for checkbox demo
140         - Tizenwinset: Context popup demo has been changed
141         - TizenDemo : add initial orientation mode to popup demo
142         - Widgets: removed parsing error for legacy javascript engine
143         - Delegate init of popup widget with delegateSelfInitWithSingleSelector
144
145 * Tue Apr 18 2013 Youmin Ha <youmin.ha@samsung.com> 0.2.25
146         - Pinch: pinch event re-implementation to use size
147         - Pagelayout : prevent code inserting window.innerHeight when content calculate
148         - BlachTheme : add missing icon (SIP down)
149         - Scrollview : support absolute position
150         - tizen-winsets: change the font-family in virtualgrid demo to default
151         - TizenWinset : Change default font
152         - tizen-winsets: Change image link
153         - tizenwinset: change images for virtual grid pages
154
155 * Tue Apr 16 2013 Youmin Ha <youmin.ha@samsung.com> 0.2.24
156         - SegmentControl: 2-buttons display issue (N_SE-34200)
157         - Naviframe : remove unnecessary img positioning(N_SE-33969)
158         - Gallery: jslint error fix
159         - TizenWinset : remove landscape SIP on mode
160         - Tizen Black Theme png file changed
161         - Gallery: Images showing bug has been fixed
162         - Scrollview : change horizontal scrollview demo(N_SE-33997)
163         - Tizenwinset: added return false in popup sample
164         - Naviframe : support data-role="button" in header
165         - Additional UnitTC: tizen winset unit tc bugs have been fixed
166         - Checkbox : remove favorite button's display:block(N_SE-33896)
167         - UnitTC: QUnit path has been changed. Priority, function type check function has been added
168         - Tizen-winset : Footer changed from lower case to upper case.
169         - Slider: enhance performance fix
170         - UnitTC: Addtional unit tc ref path has been fixed
171         - virtualgrid: apply overscrolling images to the style of widget
172         - Tabbar : Change overscroll image(left/right)
173         - ensurens: optimizations
174         - ensurens: qunit tests
175         - Tokentextarea: Fix block size error
176         - Fastscroll: Add a feature to fade out Fastscroll widget.
177         - Fastscroll: Add a user interaction at the omitted items.
178         - ImageLoader: Performance fix: apply lazy loading for canvas element
179         - Tests: Add tests for $.imageloader
180         - SegmentControl: 2-buttons display issue (N_SE-34200)
181         - virtuallist: fix width resizing trigger
182         - Timepicker: timepicker is closed when orientationchange event fired
183         - TizenWinset : Tabbar-persist issue.(N_SE-33996)
184         - Add Flora license
185         - collapsible: Fix collapsible list animation bug
186
187 * Wed Apr 10 2013 Youmin Ha <youmin.ha@samsung.com> 0.2.23
188         - Naviframe : modify SIP down button's position
189         - Core: Performance fix for disableSelection and enableSelection
190         - Tests: Core tests for disableSelection
191         - patch: fix small mistakes on the patches
192         - virtuallist: Change demo button style
193         - Button: btn-icon only css has been changed
194         - loader: Fix screen-width option processing
195         - pagelayout: Remember back key when it is hidden
196         - Tizen Black Theme : Tizen black theme png file changed.
197         - UnitTC: tizen winset unit tc bugs have been fixed
198         - TizenWinset: Swipe list sample has been fixed
199         - Radio : remove default radio's width(N_SE-33579)
200         - Scrollview : divide x/y overflow attribute
201         - Gallery: orientation image showing issue has been fixed
202         - Gallery: remove method bug has been fixed
203         - virtualgrid : fix unit-test error and increase test items
204         - Gallery3d: Modify demo & source codes for visibility enhancement.
205         - Gallery3d: Reduce loading time of widget
206         - Gallery3d: Change files' format to unix
207         - Contextpopup: context popup close when window resize event fire
208         - Popup: reverse orientation bug has been fixed
209         - Tokentextarea: modify description
210         - Multimediaview: modify description
211         - JQM: Do not add ui-btn-icon-only class at the select button
212         - build: tizen-black theme package
213         - Tizenwinset: popup script has been removed
214         - Tizenwinset: substring split view text message
215         - Timepicker: data-changed event will be deprecated
216
217 * Fri Apr 5 2013 Youmin Ha <youmin.ha@samsung.com> 0.2.22
218         - tizen-winsets: Fix demo menu
219         - Tizenwinset: Reorder tizenwinset menu
220         - SearchBar: Header button size issue has been fixed
221         - Swipe: list item overflow: hidden has been added
222         - Tizenwinset: href has been added in grouped list
223         - Tizenwinset: Page transition page has been added
224         - Tizenwinset: Radio description has been fixed
225         - This patch fixes problem when base url is changed when site is prefetched.
226         - Entry : limit textarea's width (N_SE-28653)
227         - Naviframe : hide backbutton in case SIP up(remove backbutton makes problem in binding event)
228         - Gallery : next, prev images position bug has been fixed
229         - Multimediaview: Fix display error while handling orientationchange event.
230         - Pagelayout : modify innerHeight dpr calculation in non scrollview mode
231         - Datetimepicker: picker position has been fixed when browser resize event fired
232         - Tips: generate elements sample page javascript has been fixed
233         - Tokentextarea: Fix Tizen-winsets demo.
234
235 * Wed Apr 3 2013 Youmin Ha <youmin.ha@samsung.com> 0.2.21
236         - VirtualGrid: Fix errors on centerTo and resize methods
237         - loader: Fix default font size at device-width viewport
238         - scrollview : remove overflow-x property
239         - Naviframe : fix backbutton position/ change down button icon
240         - Naviframe : bug fix
241         - Tizenwinset : Tizen-winset demo page titles changed Tizen-winset demo page titles changed from lower case to upper case.
242
243 * Fri Mar 29 2013 Youmin Ha <youmin.ha@samsung.com> 0.2.20
244         - JQM Navigation : remove page min-height
245         - Pagelayout : add refresh to pagelayout
246         - Tokentextarea: Changes 'remove' tests to asyncTest
247         - Popup: input tag alignment has been fixed
248         - Tokentextarea: add/remove events are deprecated.
249         - Contextpopup: Support horizontal list
250         - Select: icon z-index has been deleted
251         - Tizenwinset: ui widget order has been changed
252         - Tool: make web app template disable context menu by default
253         - Tizen-winset: change tips for using listview
254         - Loader: calculate font size with mobile width
255         - Naviframe : fix header's back button position
256         - TizenWinset : move locale info to another file
257
258 * Fri Mar 22 2013 Youmin Ha <youmin.ha@samsung.com> 0.2.19
259         - Tizen-winset: Support accessibility for tizen-winset
260         - Orientation : add orientataionchange to tizen-winset
261         - Tokentextarea: Adjusts VI effect for add/remove block
262         - splitview: Support accessibility for splitview
263         - Tizen-winset: Date/time picker guide text has been fixed
264         - Popup: context popup arrow position, setTimeout open method bug have been fixed
265         - fastscroll: Add new indexString API to Fastscroll widget.
266         - splitview: Add new widget
267         - gallery3d: Add new widget
268         - Scrollview : disable VI effect for gesture event
269         - Scrollview : disable SIP outerscroll
270         - Tizen-winset: resize VirtualGrid widget in demo
271         - Tizen-winsets: Refactor searchbar subpages
272         - Tizen-winsets: Remove depracated usage of virtuallist
273         - Tizen-winsets: Move js code from main.js to subpages
274         - Tizen-winsets: Refactor virtual grid demo subpages
275         - Tizen-winsets: Move css files from index to proper subpages
276         - Tizen-winsets: Refactor list dialogue edit subpage
277         - Tizen-winsets: Refactor pagelayout subpages
278         - Tizen-winsets: Refactor tips subpages
279         - Tizen-winsets: Move subpages popup files from index.html
280         - Tizen-winsets: Move subpages javascript files from index.html
281         - virtualgrid: fix improperly merged codes
282         - ColorTheme : remove unused color value(1st)
283         - Scrollview : change scrollbar draw
284         - Popup: Apply popup background dim
285         - Tizen-winsets: Move tokentextarea demo to external page.
286         - Tizen-winsets: Move tabbar persist demo to external page.
287         - Tizen-winsets: Remove notImplemented page
288         - Tizen-winsets: Move slider demo page to external subpage
289         - Tizen-winsets: Fix ids, remove duplicated names for sliders
290         - Tizen-winsets: Remove event for changing theme
291         - tool: Fix wgt sample app generator tool to make apps be installed
292         - demos : change live to on
293         - build: Trim compiled CSS files
294         - Gallery: CSS left -> translate or translate3D
295         - Tokentextarea: Disfunctional APIs fixed.
296
297 * Thu Mar 7 2013 Youmin Ha <youmin.ha@samsung.com> 0.2.18
298         - build: Fix Makefile to add globalize to the minified lib
299         - build-tools : upgrade less to v1.3.3
300         - demos : change normal js path to minified js
301         - Theme : remove reduantant less - dayselector, optionheader, nocontents
302         - multimediaview : fix full-screen mode.
303         - multimediaview : fix 'width', 'height' and 'fullScreen' methods
304         - Extendablelist: Added min-height "load more button" in listitem
305         - virtualgrid: adjusts VI effect for an overflow action
306         - ControlGroup : change ellipsis font color (press/normal)
307         - multimediaview: Add an error message to Multimediaview
308         - virtualgrid: adjusts triple flick gesture
309         - scrollview: add function for getting width of view
310         - scrollview: adds support x axis gesture scroll
311         - multimediaview : fix audio control
312         - tabbar : tabbar slide animation change
313         - TizenWinsetDemo : 2line-text demo bug fix
314         - collapsible: Fix demo to show radio button correctly in the collapsible list
315         - collapsible: Set listitem position to relative
316         - UnitTC: added list divider unit test
317         - Style: unnecessary color codes have been deleted and modified
318         - build: Module build implementation
319         - UnitTC: Additional unit testcases have been added
320         - listview : bug fix
321         - Naviframe : remove back button's hover effect
322         - TizenDemo : remove back button
323         - Transition: added more-button vi
324         - pinch: added new event called pinch
325         - Popup: css word-wrap:break-word has been added
326         - virtualgrid: memory leak fix
327         - progress: set to init state at pending bar
328         - progress: add margin of top/bottom
329         - unit-test: split progress test and progressbar test
330         - Tizen-winset: Context popup sample page guide text has been changed
331         - multimediaview: fix the height of widget when full-screen mode
332         - JQM: performance tuning
333
334 * Tue Feb 19 2013 Minkyu Kang <mk7.kang@samsung.com> 0.2.17
335         - DialogueList : delete border top value / add sample's text ellipsis
336         - Tokentextarea: Add scroll-to-top for Grouping On/Off regarding #N_SE-24877
337         - Multimediaview: Fix mute function
338         - Tizen-winset: list vi index guide textbox has been removed
339         - Tizen-winset: custom button texts have been changed
340         - slider: move popup div to out of content
341         - TizenWinset: disable context popup in multimediaview
342         - Swipe: wrong style name has been fixed
343         - demo: add the sample at dialogue list
344         - listview: Add ui-li-has-right-btn class with toggleswitch
345         - WinsetDemo : change wrong title name
346
347 * Mon Jan 28 2013 Youmin Ha <youmin.ha@samsung.com> 0.2.16
348         - demo: checkbox: reduce button's width
349         - tabbar : delete right/left tab animation color
350         - scrollview: fix the scroll position at keydown event
351         - groupControl : change footer groupControl from min-width to percentage
352         - scrollview: get height of softkeyboard correctly
353         - tizen-winset: Add name attr to all radio inputs
354         - virtualgrid: changes event binding target
355         - scrollview: skip the drag if target is textarea
356         - scrollview: skip the dragging of parent scrollview
357         - scrollview: apply the scaling ratio to the soft keyboard
358         - demos: apply disabled option in textarea
359         - demo: remove unused codes
360         - demo: datetimepicker: show selected date correctly
361         - listview: Adjust bubble listitem width and margin
362         - pagelayout : change external refresh call and ime status follow only current page
363         - toggleSwitch : bug fix
364         - unit-test: slider: fix the move test
365         - handler: fix jslint error
366         - ToggleSwitch : set image toggleswitch background attribute
367
368 * Mon Jan 28 2013 Youmin Ha <youmin.ha@samsung.com> 0.2.15
369         - slider: increase the text width(N_SE-23397)
370         - virtualgrid: DOM element leak fix
371         - header: Move button top higher in header with tabbar(N_SE-22253)
372         - datatimepicker: don't open the popup before popupafterclose event is fired(N_SE-23027)
373         - handler: bug fix (regarding enableHandler function )
374         - demo:fix syntax error
375
376 * Sat Jan 26 2013 Youmin Ha <youmin.ha@samsung.com> 0.2.14
377         - demo: fix demo using tizen device API
378         - multimediaview: reset the height of container
379         - input: modify css correctly
380         - multimediaview: fix the height of widget
381         - gallery: bind create event
382         - progress: bind create event
383         - slider: bind create event
384         - progressbar: bind create event
385         - progressbar: event trigger correctly
386         - popup: fix height of popup scroller
387         - build: add continue option to jslint
388         - ctxpopup demo : bug fix
389         - demo: fix searchbar demo to use different IDs
390         - demo: extract routine executing Tizen device API
391         - toggleswitch : set default margin, delete box padding
392
393 * Thu Jan 24 2013 Youmin Ha <youmin.ha@samsung.com> 0.2.13
394         - virtuallist: Prevent replacing contents on nonexist element
395         - JQM: Trim text in listitem to get index in autodivider
396         - JQM: Remove trailing whitespace in jqm patch
397         - scrollview: get the height including margin
398         - multimediaview: bug fix ( scrolling in full-screen mode )
399         - virtuallist: set listitem width to exclude listitem left/right margin
400         - demo: fix virtuallist sample layout
401         - progress: set the position explicitly
402         - progress: rename from progressing to progress
403         - build: remove unused files
404         - searchbar: fix jslint errors
405         - src: fix file permissions
406         - button : change jump left icon
407
408 * Wed Jan 23 2013 Minkyu Kang <mk7.kang@samsung.com> 0.2.12
409         - theme : button icon - scrolltop, scrolleft icon changed.
410         - build: cleanaup Makefile
411         - pagelayout: fix jslint error
412         - virtualgrid: Fix jslint errors
413         - tabbar : jslint bug error fix
414         - build: add regexp option to jslint
415         - virtuallist: fix jslint errors
416         - handler: Apply the exceptional principle for scrollbar on Handler.
417         - build: remove unused copyright
418         - loader: extract log class for tizen web, and fix jslint errors
419         - loader: Viewport width is set to document width
420         - popupwindow: fix jslint error
421         - build: fix Makefile for tizen-white theme
422         - build: remove unused libraries
423         - datetimepicker: fix jslint error
424         - slider: fix jslint error
425         - demo: remove deprecated demos
426         - pagelayout : change to call relayout with this page
427         - Tokentextarea: Block size error fixed.
428         - handler: bug fix (handler activation)
429
430 * Tue Jan 22 2013 Minkyu Kang <mk7.kang@samsung.com> 0.2.11
431         - demo: clear input text value with cancel button click
432         - demo: Adjust textarea height automatically
433         - naviframe : bug fix
434         - tabbar : bug fix
435         - Fastscroll: popup position has been changed
436         - Button: custom button icon path, margin have been changed
437         - toggleswitch : bug fix
438         - slider: increase the margin
439         - datetimepicker: close the popup after select the value
440         - unit-test : add page backbutton control test
441         - Demo: added guide text and change input type in list vi
442         - remove legacy codes : jquery-geo
443         - Datetimepicker: text-main max-width has been removed
444         - Radio: control group border has been removed
445         - Demo: remove 'tab' space
446         - UnitTC: swipe unit tc has been fixed
447         - UnitTC: jQuery path has been fixed
448         - Button: bug fix when button has not a text
449         - tizen-winset: timepicker: demo title is changed
450
451 * Fri Jan 18 2013 Minkyu Kang <mk7.kang@samsung.com> 0.2.10
452         - tizen-winsets: codes cleanup
453         - datetimepicker: date calibration when year is changed
454         - Demo: textarea size has been changed
455         - Demo: Naviframe morebutton demo has been changed
456         - remove unused unit test cases : gallery3d
457         - tizen-winset: remove links
458
459 * Thu Jan 17 2013 Minkyu Kang <mk7.kang@samsung.com> 0.2.9
460         - gallery: use timeout function instead of interval
461         - Tokentextarea: Display error fixed.
462         - scrollview: Fix not selector to respond with jQuery1.8.2
463         - tabbar: remove the width of last element
464         - Demo: apply css 'user-select:none'
465         - Button: guide text has been shorten
466         - build: Update jQuery to 1.8.2 (JQM1.2 compliant)
467         - virtuallist: Fix mistyping
468         - demo: Fix tizen function namespace in demo
469         - virtuallist: Rewrite listitem replacing algorithm
470         - fastscroll: modify from not selector to function
471         - extendablelist: Fix unit-test
472         - tabbar : prefix to tabbar scroll event
473         - Popupwindow: removed unvalid selector in jquery 1.8.2
474         - slider: adjust handle text as length of value
475         - Demo: 3 buttons in popup text has been changed
476         - src: codes cleanup
477         - demo : remove trailing empty strings
478         - demo : rename TizenWinset list items
479         - button : change from long text list to multiline list
480         - build: Remove JQM1.1.0 patches
481         - Popup: Apply tizen style popup and attribute support
482         - JQM: Fix buttonmarkup bug keeping ui-btn-down class
483         - UnitTest: folder and file renamed, QUnit path was modified
484         - tizen-winsets: button: fix textarea width
485         - Swipe: event name error has been fixed
486
487 * Tue Jan 15 2013 Minkyu Kang <mk7.kang@samsung.com> 0.2.8
488         - Button: button padding has been updated
489         - virtuallist: fix unique listitem ID bug
490         - checkbox, radio : change display attr
491         - Button: bug fix ( when data style circle button on text )
492         - handler: bug fix (when scrolling with multi selection)
493         - JQM: adjust patch number
494         - gallery: show the widget after pageshow
495         - TokenTextArea : resource add ( press image )
496         - gallery: adds function that set the index to value API
497         - configure: set TIZEN default configures
498         - footer: h tag display attribute value has been changed
499         - buttons : demo bug fix
500         - searchbar : demo page bug fix
501         - tizen demo : bug fix
502         - build: remove JQM1.1.0
503         - Tokentextarea: Fix issues
504         - scrollview: block the multi touch
505         - list : dialogue list demo change
506         - pagelayout : update dynamic control
507         - Demo: Context popup close method has been changed
508
509 * Fri Jan 11 2013 Minkyu Kang <mk7.kang@samsung.com> 0.2.7
510         - slider: set text container's width as text length
511         - Timepicker: li max-width has been changed
512         - remove experimental feature - mapview.
513         - scrollview: added conditions for finding slider
514         - UnitTC: Pass,error count save method has been changed
515         - confix.xml: default config added for tizen basic applications
516         - Swipe: p tag margin value is set '0'
517         - packaging: remove unused file
518         - tabbar : bug fix
519         - list demo : bug fix
520         - tizen-winsets: gallery: move to new section
521         - tizen-winsets: autodivider: removes link of list
522         - demos: entry of number-pattern name is changed from 'number' to 'number-pattern'
523         - pagelayout : padding calculate change, ime footer check changed
524         - tizen-winsets: searchbar: scroll to the top when type the character
525         - searchbar : bug fix
526         - demo: Fix virtuallist demo following new list style
527         - demo: Add word-wrap:break-word and remove parag. width
528         - Demo: button max-width has been set( 3 buttons in popup )
529         - back button control demo : bug fix
530         - toggleswitch : demo page modify
531         - slider: add margin-top and margin-bottom
532         - tabbar demo : bug fix
533         - Popup: IME hide when popup is closed
534         - token textarea : bug fix
535         - Timepicker: change get attribute method
536         - footer demo : bug fix
537         - unit-test: gallery: add new APIs
538         - gallery: adds support new APIs
539
540 * Fri Jan 04 2013 Minkyu Kang <mk7.kang@samsung.com> 0.2.6
541         - JQM: patches cleanup
542         - Button: data-corners attribute has been added
543         - unit-test: slider: fix class name of background
544         - progressbar, slider: fix less variable typo
545         - Tabbar : VI update
546         - notification: add top position at fix class
547         - demo: entry demo page change
548         - css: .ui-disabled added
549         - tizen-winset: token textarea: remove back button at demo page
550         - theme: Remove unused less file
551         - pagelayout : content min height bug fix
552         - scrollview: skip the dragging when target is slider's handle
553         - scrollview: update and refactoring the scroll effect
554         - UnitTest:JQM Unit TC helper has been added,TCs have been modified
555         - Swipe: demo page html error has been fixed
556         - listview: Add add/delete animation (VI)
557         - Popup: demo page has been modified
558         - tizen demo : bug fix
559         - searchbar : demo page change(change front button and add behaviour)
560         - pagelayout : add min height to content
561         - gallery: rename 'Image Slider' to 'Gallery' in tizen-winsets demo and tests
562         - back button control demo : change url link to data-rel="back"
563         - loader: Skip loading theme CSS with a custom css code
564         - Button: support no-text in button
565         - collapsible: Fix syntax error
566         - slider: use data-highlight attribute
567         - collapsible: Rotate animation to collapsible heading icon
568         - toggleswitch : text switch bug fix
569         - remove candidates-calendarpicker
570         - Patch: Fix misc mistakes in JQM patches
571         - searchbar : animation change
572         - gallery: get the width correctly
573         - demo: data-framework-viewport-scale attribute is changed to data-framework-viewport-width
574         - collapsible: Add collapse/expand animation (VI)
575         - datetimepicker: VI update
576         - JQM: set transition to pop as default
577         - tabbar : bug fix in case none li element case
578         - scrollview: fix the drag bug
579         - Button: Button icon scrolltop, left has beed added
580         - Swipe: VI update and swipe speed has been changed
581         - jqm: fix errors in patch files
582         - unit-test: swipe: fixed the destroy test
583
584 * Wed Dec 26 2012 Youmin Ha <youmin.ha@samsung.com> 0.2.5
585         - Revert "[checkboxradio] exception handling for input"
586                 This reverts commit 72478c32704fa96362db577e6cf9511777919ea8.
587                 Tizen style supports no-label radio and checkbox when making lists.
588                 So it ignores html input operation. Instead, it supports tizen style radio and checkbox theme.
589
590 * Thu Dec 20 2012 Youmin Ha <youmin.ha@samsung.com> 0.2.4
591 - Fix:
592         - modify segment background
593         - rearrange check, radio input
594         - CtxPopup: Scale up/ down popup vi(poptop, popbottom)
595         - button: style has beed added(box,circle,nobg,round)
596         - favorite resource added
597         - demo/tizen-winsets: add footer and back button
598         - remove autodividers unit test
599         - add divider for tabbar
600         - checkboxradio: exception handling for input
601         - segment control backward compatiblity
602         - Fix collapsible unit-test
603         - remove toggleswitch
604         - add patch for remove segment text
605 - Spec changes:
606         - replace controlbar to tabbar
607
608 * Fri Dec 14 2012 Minkyu Kang <mk7.kang@samsung.com> 0.2.3
609 - FIX:
610         - slider: add image
611         - button: data-icon support, styles fix
612         - progressbar: modify the background
613         - scrollview: auto scrolling bug fix
614         - pagelayout: IME concept is changed
615 - Spec changes:
616         - dialogue: add edit mode
617         - nocontents: removed
618         - pagecontrol: removed
619         - dayselector: removed
620         - expandablelist: removed
621
622 * Thu Dec 10 2012 Youmin Ha <youmin.ha@samsung.com> 0.2.2
623 - FIX:
624         - chang searchbar/slider images
625         - delete redundant button images
626 - Spec changes:
627         - Change widget name: shortcutscroll -> fastscroll
628
629 * Thu Dec 07 2012 Youmin Ha <youmin.ha@samsung.com> 0.2.1
630 - FIX:
631         - jqm1.2: Change collapsible style to meet expandable list
632         - remove jquery-geo-1.0.a4
633         - unit-test: rename from imageslider to gallery
634         - nocontent: add warning message
635         - Handler: Fix issues in jqm1.2
636         - Multimediaview: modify APIs & comments
637         - Mapview: Fix issues in jqm1.2
638         - JQM: clean up patches
639         - Swipelist: refactoring swipelist
640         - Popup,Ctxpopup: Apply tizen style popup in JQM1.2
641         - rearrange button's data-icon resources
642 - Spec changes:
643         - Virtualgrid: remove option ('data-itemcount')
644         - gallery: rename the widget from imageslider to gallery
645         - add new style for searchbar
646         [tokentextarea] multi-button entry renamed as token text area. API & comments modified.
647
648 * Thu Dec 06 2012 Minkyu Kang <mk7.kang@samsung.com> 0.2.0
649 - FIX:
650         - fix jslint error
651         - remove unused files
652         - change naviframe style
653 - Spec changes:
654         - applied jQuery Mobile 1.2.0
655         - remove optionheader
656
657 * Fri Nov 30 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.64
658 - FIX:
659         - fix unit tests
660         - remove unused theme files
661         - timepicker: text position fix
662         - scrollview: set dragstop when mouse is out of window
663         - listview: fix margin
664 - Spec changes:
665         - support data-framework-viewport-width
666
667 * Fri Nov 23 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.63
668 - FIX:
669         - dayselector: fix size
670         - remove unised styles
671         - divider: set non-press effect to default option
672         - popupwindow: fix window closing failure
673         - handler: GUI implementation
674         - TC: fix unit TCs
675         - scrollview: fix padding size
676 - Spec changes:
677         - Remove color widgets
678         - add $.tizen.pkgVersion for SDK
679 - Etc.
680         - JSDuck documents
681
682 * Fri Nov 16 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.62
683 - FIX:
684         - Many winsets: Fix layout
685         - Footer: fix position to bottom
686 - Spec changes:
687         - Remove color widgets
688
689 * Fri Nov 09 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.61
690 - FIX:
691         - Many widgets: New UX 0.6 theme implementation
692         - widgetex: init speed up
693         - scrollview: fix scrollbar and scale animation
694         - scrollview: fix scroll position when updatelayout is triggered
695         - header/footer: make textselection disable, except input type="text"
696
697 * Wed Nov 07 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.60
698 - FIX:
699         - Remove tizen-black theme package description
700
701 * Tue Nov 06 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.59
702 - FIX:
703         - Fix theme name to meet the change of system theme name: white->tizen
704         - Popupwindow: fix left position
705         - Remove black theme
706         - footer: remove label, legend drawing
707 - Spec changes:
708         - UX guide v0.4 : button, layout
709
710 * Fri Oct 26 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.58
711 - FIX:
712         - scrollview: Fix outer scroll amount
713         - tabbar: fix tapping twice
714         - popupwindow: fix left position
715
716 * Wed Oct 24 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.57
717 - FIX:
718         - expandablelist: icon color fix
719         - scrollview: Fix xy scroll
720         - footer: Remove dummy div
721         - Make string concatnation effective in inline-protos.sh
722 - Spec changes:
723         - refresh header/footer when drag&drop event is fired in GUI builder
724         - searchbar: delete cancel button
725         - don't trigger updatelayout event when keyup event comes
726
727 * Mon Oct 15 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.56
728 - FIX:
729         - Toggleswitch: Change event name from 'changed' to 'change'
730         - Notification: Revert interval feature
731
732 * Tue Oct 09 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.55
733 - FIX:
734         - Fix SMACK manifest bug (S1-9098)
735
736 * Fri Oct 05 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.54
737 - FIX:
738         - handler: don't append a handler if handler is not enabled
739         - scrollview: use static value
740         - datetimepicker: fix date-format HH display error
741 - ETC:
742         - provide jquery.min.js
743         - barlayout: codes clean
744         - remove unused file
745
746 * Wed Sep 26 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.53
747 - FIX:
748         - listview: change focused color
749         - multibuttonentry: code refactoring
750         - datetimepicker: modify date format when triggered date-changed event
751         - slider: fix the top of slider bar
752         - add event blocker when load a first page
753
754 * Fri Sep 21 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.52
755 - ETC.
756         - Move SMACK manifest files to the top SRCDIR
757
758 * Fri Sep 21 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.51
759 - FIX:
760         - Popup: Do not focus container
761         - Header: show backbutton when both tabbar and header are present together
762         - Multi button entry: text ellipsis, code refactoring
763
764 * Fri Sep 21 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.50
765 - ETC.
766         - Apply SMACK manifest
767
768 * Thu Sep 20 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.49
769 - FIX:
770         - JSLINT code clean-up
771         - scrollview: firefox support
772         - scrollview: fix finding slider handle
773         - list: tweak text ellipsis
774         - checkbox: fix selecting wrong label tag (N_SE-8370)
775         - imageslider: check parameter
776         - smallpopup: fix position
777         - searchbar: fix 'clear' button size
778 - Spec changes:
779         - scrollview: support outer scroll
780         - JQM: block click event only with the element that does preventdefault on vclick(N_SE-6090)
781         - remove S/W IME control
782
783 * Thu Sep 13 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.48
784 - FIX:
785         - Add missing icon: controlbar
786         - scrollview: tune scrolling animatio ninterval
787         - datetimepicker: digit/triangle position
788         - datetimepicker: fix day overflow issue
789 - Spec changes:
790         - scrollview: show scrollbar when page is showed
791         - scrollview: disable outer scroll
792         - extendablelist: change api with legacy support
793         - add ui-text-ellipsis class
794
795 * Mon Sep 10 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.47
796 - FIX:
797         - scrollveiw: fix height of view
798         - searchbar: support placeholder
799 - Spec changes:
800         - add ui-text-ellipsis class
801
802 * Fri Sep 07 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.46
803 - FIX:
804         - scrollview: scrolling bug fix
805         - controlbar: fix width of controlbar item
806 - Spec changes:
807         - searchbar: don't hide icon
808         - popup: update JQM poup widget
809
810 * Fri Sep 05 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.45
811 - FIX:
812         - controlbar: set correct controlbar width of last element
813         - slider: get popup enable value correctly
814         - use Date.now() instead of (new Data()).getTime()
815         - popupwindow: fix the background color of popup scroller
816         - listview: add padding-left to expandable list
817         - add ellipsis for title area support
818
819 * Fri Aug 31 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.44
820 - FIX:
821         - swipelist: show list items correctly
822         - datetimepicker: set last day, if day is overflowed
823 - Spec changes:
824         - controlbar: update icons
825
826 * Tue Aug 29 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.43
827 - FIX:
828         - notification: fix typo
829 - Spec changes:
830         - controlbar: update icons
831
832 * Tue Aug 28 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.42
833 - FIX:
834         - multimediaview: video progress bar display normally for too samll
835         - segmentcontrol: remove media query
836         - scrollview: add outer scroll condition
837         - datetimepicker: modify triangle size
838         - popupwindow: set the screen height explicitly
839         - notification: add multiline text
840 - Spec changes:
841         - mutibuttonentry: support new GUI
842         - virtualgrid: support new GUI
843
844 * Mon Aug 27 2012 Jinhyuk Jun <jinhyuk.jun@samsung.com> 0.1.41
845 - FIX:
846         - radio/check button : button size bug fix
847
848 * Fri Aug 24 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.40
849 - FIX:
850         - build error fixed
851
852 * Fri Aug 24 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.39
853 - FIX:
854         - listview: style fix, remove filter placeholder
855         - controlbar: divide styles
856         - scrollview: don't skip dragging when click button or inputbox
857         - slider: trim the text on text slider
858 - Spec changes:
859         - remove gray and blue theme
860         - add white and black theme
861         - support new GUI guide
862
863 * Mon Aug 20 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.38
864 - FIX:
865         - fix coment of version tag
866
867 * Fri Aug 17 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.37
868 - FIX :
869         - button: fix alignment
870         - listview: adjust the main text width
871         - virtualgrid: refactoring
872 - Spec changes:
873         - transition: support JQM 1.1.0 transitions
874         - scrollview: support the outer scroll
875         - notification: remove interval feature
876
877 * Tue Aug 14 2012 Youmin Ha <youmin.ha@samasung.com> 0.1.36
878 - FIX :
879         - checkboxRadio: Add left/right padding
880         - button: custom button & icon position
881         - virtuallist: remove 'recreate' test
882 - Spec changes:
883         - header/footer: enable/disable support
884
885 * Fri Aug 10 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.35
886 - FIX :
887         - expandablelist: modify show animation
888         - virtualgrid: Redesign programming interface
889         - popupwindow: code clean and fixed issues
890         - pagelayout: fix content height
891         - license file update
892         - virtuallist: Change programming interface
893         - datetimepicker: getting days correctly
894         - searchbar: set to hidden when cancel button is hide
895         - White theme title font tuning
896 - Spec changes:
897         - default theme tizen-gray to tizen-white
898         - set default page transition to none
899
900 * Mon Aug 02 2012 Jinhyuk Jun <jinhyuk.jun@samsung.com> 0.1.34
901 - FIX :
902         - Back Button : enlarge backbutton click size for white theme
903 - Feature :
904         - Expandable List : Add refresh api
905 * Mon Aug 02 2012 Jinhyuk Jun <jinhyuk.jun@samsung.com> 0.1.33
906 - FIX :
907         - click event touch threshold tuning
908
909 * Mon Aug 02 2012 Jinhyuk Jun <jinhyuk.jun@samsung.com> 0.1.32
910 - FIX : 
911         - Add back button highlight effect for white theme
912
913 * Mon Aug 01 2012 Jinhyuk Jun <jinhyuk.jun@samsnug.com> 0.1.31
914 - FIX : 
915         - IME checkroutine update, improve relayout on resize event
916         - Add highlight effect for radio button list 
917         - Scrollview : fix condition of updatelayout event
918 - Feature : progressing : add show/hide api
919
920 * Mon Jul 27 2012 Koeun Choi <koeun.choi@samsung.com> 0.1.30
921 - FIX : virtuallist, virtualgrid: Clean up temporary jquery.template object to clear cache
922         add default theme option on buttonMarkup for tizen theme
923         [searchbar] first fix : focus/blur fixed
924         back button does not work when long press
925         scrollview: don't auto scrolling if resizing area is too large
926 - Feature : notification : add api to set the icon at tickernoti
927         demo : update the list sample demo
928         Support tizen default theme
929
930 * Mon Jul 23 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.29
931 - Improvements & Bugfixes
932    - HOTFIX: Revert template function with jquery.template
933
934 * Thu Jul 19 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.28
935 - Improvements & Bugfixes
936    - Fix #WEB-1028: memory leak on virtuallist/virtualgrid
937 - Spec changes
938    - $.tizen.loadTheme() function accepts theme name as arguement
939    - Scrollview supports 'updatelayout' callback
940
941 * Tue Jul 17 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.27
942 - Improvements & Bugfixes
943    - Revert 'preventing long-press popup' patch, to fix backbutton to work in SocialMagazine
944
945 * Tue Jul 17 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.26
946 - Improvements & Bugfixes
947    - Add tizen-white theme package, to make rpm build to be finished
948
949 * Tue Jul 17 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.25
950 - Improvements & Bugfixes
951    - Set 'slide' as default page transition effect, by JQM patch
952
953 * Fri Jul 13 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.24
954 - Improvements & Bugfixes
955    - Fix IME show/hide algorithm
956    - Fix error on virtualgrid: link _set_scrollbar_size() function to the one in virtuallist
957
958 * Wed Jul 11 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.23
959 - Improvements & Bugfixes
960    - Fix notification position
961    - Fix unit tests
962
963  Fri Jul 6 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.22
964 - Spec changes
965         - JQM 1.1 upgrade
966 - Improvements & Bugfixes
967         - Transform3D support on scrollview
968         - Page layout supports IME control
969         - Mapview supports pinch zoom on JQM 1.1
970         - Fix wrong character on button in minified version
971         - Virtualgrid supports scrollbar
972         - Lots of bugfixes
973
974 * Fri Jun 22 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.20
975 - Spec changes
976         - Support 'latest' version (by symlink) for tizen-web-ui-fw.js path.
977         - imageslider : supports 'resize' event.
978         - listview : listview has 1px padding-bottom.
979         - loader : Change global namespace, from S to $.tizen.
980         - loader : Move loadCustomGlobalizeCulture() into $.tizen.util namespace.
981 - Improvements & Bugfixes
982         - Scrollview : supports 'translate3d', instead of 'translate'.
983         - notification : reset timer when 'show' or 'refresh' event.
984         - JQM patch : Fix vclick event triggered twice.
985 - Etc.
986         - Add & fix unit tests.
987
988 * Thu Jun 14 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.19
989 - Spec changes
990         - mapview : new widget.
991         - notification : add .refresh() API.
992         - pagecontrol : add .value([val]) API, and change an attribute name 'data-initVal' to 'data-value'.
993 - Improvements & Bugfixes
994         - Support minified CSS.
995         - loader : Fix & refactor 'loading globalize culture file' routine.
996         - JQM Patch : Calculate min-height of window in javascript code, and remove predefined min-height value from CSS.
997         - Many more bugfixes.
998 - Etc.
999         - Add many unit tests.
1000         - Fix test coverage instrumentation tool to work with current source code.