Export 0.1.61
[platform/framework/web/web-ui-fw.git] / packaging / web-ui-fw.spec
1 Name:       web-ui-fw
2 Version:    0.1.61
3 Release:    0
4 Summary:    Tizen Web UI Framework Library
5 Group:      Development/Other
6 License:    MIT
7 BuildArch:  noarch
8 BuildRequires:  make
9 BuildRequires:  nodejs
10 %ifarch %{arm}
11 BuildRequires:  nodejs-x86-arm
12 %endif
13
14 Source0:    %{name}-%{version}.tar.gz
15
16 %description
17 Tizen Web UI Framework library and theme packages
18
19 %prep
20 %setup -q
21
22 %build
23 make all
24
25 %install
26 make DESTDIR=%{buildroot} install
27
28 %post
29
30 %files
31 %manifest web-ui-fw.manifest
32 /usr/share/tizen-web-ui-fw/*/js
33 /usr/share/tizen-web-ui-fw/latest
34
35 ###############################
36 %package -n web-ui-fw-theme-tizen-gray
37 BuildArch:  noarch
38 Summary:    Tizen Web UI Framework Theme : tizen-gray
39 %Description -n web-ui-fw-theme-tizen-gray
40     Tizen Web UI Framework Theme : tizen-gray
41
42 ###############################
43 %package -n web-ui-fw-theme-tizen-white
44 BuildArch:  noarch
45 Summary:    Tizen Web UI Framework Theme : tizen-white
46 %Description -n web-ui-fw-theme-tizen-white
47     Tizen Web UI Framework Theme : tizen-white
48 %files -n web-ui-fw-theme-tizen-white
49 %manifest web-ui-fw-theme-tizen-white.manifest
50 /usr/share/tizen-web-ui-fw/*/themes/tizen-white
51 /usr/share/tizen-web-ui-fw/*/themes/tizen-tizen
52
53 ###############################
54 %package -n web-ui-fw-theme-default
55 BuildArch:  noarch
56 Summary:    Tizen Web UI Framework Theme : default
57 %Description -n web-ui-fw-theme-default
58     Tizen Web UI Framework Theme : default
59 %files -n web-ui-fw-theme-default
60 %manifest web-ui-fw-theme-default.manifest
61 /usr/share/tizen-web-ui-fw/*/themes/default
62
63 ###############################
64 %package -n web-ui-fw-devel
65 BuildArch:  noarch
66 Summary:    Tizen Web UI Framework Developer's files
67 %Description -n web-ui-fw-devel
68     Tizen Web UI Framework Developer's files
69 %files -n web-ui-fw-devel
70 /usr/share/tizen-web-ui-fw/bin
71 /usr/share/tizen-web-ui-fw/template
72
73 ###############################
74 %package -n web-ui-fw-demo-tizen-winsets
75 BuildArch:  noarch
76 Summary:    Tizen Web UI Framework Demo Application: tizen winset demo
77 %Description -n web-ui-fw-demo-tizen-winsets
78     Tizen Web UI Framework Demo Application: tizen winset demo
79 %files  -n web-ui-fw-demo-tizen-winsets
80 /usr/share/tizen-web-ui-fw/demos/tizen-winsets
81
82
83 ###############################
84 %changelog
85 * Fri Nov 09 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.61
86 - FIX:
87         - Many widgets: New UX 0.6 theme implementation
88         - widgetex: init speed up
89         - scrollview: fix scrollbar and scale animation
90         - scrollview: fix scroll position when updatelayout is triggered
91         - header/footer: make textselection disable, except input type="text"
92
93 * Wed Nov 07 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.60
94 - FIX:
95         - Remove tizen-black theme package description
96
97 * Tue Nov 06 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.59
98 - FIX:
99         - Fix theme name to meet the change of system theme name: white->tizen
100         - Popupwindow: fix left position
101         - Remove black theme
102         - footer: remove label, legend drawing
103 - Spec changes:
104         - UX guide v0.4 : button, layout
105
106 * Wed Oct 24 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.57
107 - FIX:
108         - expandablelist: icon color fix
109         - scrollview: Fix xy scroll
110         - footer: Remove dummy div
111         - Make string concatnation effective in inline-protos.sh
112 - Spec changes:
113         - refresh header/footer when drag&drop event is fired in GUI builder
114         - searchbar: delete cancel button
115         - don't trigger updatelayout event when keyup event comes
116
117 * Mon Oct 15 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.56
118 - FIX:
119         - Toggleswitch: Change event name from 'changed' to 'change'
120         - Notification: Revert interval feature
121
122 * Tue Oct 09 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.55
123 - FIX:
124         - Fix SMACK manifest bug (S1-9098)
125
126 * Fri Oct 05 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.54
127 - FIX:
128         - handler: don't append a handler if handler is not enabled
129         - scrollview: use static value
130         - datetimepicker: fix date-format HH display error
131 - ETC:
132         - provide jquery.min.js
133         - barlayout: codes clean
134         - remove unused file
135
136 * Wed Sep 26 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.53
137 - FIX:
138         - listview: change focused color
139         - multibuttonentry: code refactoring
140         - datetimepicker: modify date format when triggered date-changed event
141         - slider: fix the top of slider bar
142         - add event blocker when load a first page
143
144 * Fri Sep 21 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.52
145 - ETC.
146         - Move SMACK manifest files to the top SRCDIR
147
148 * Fri Sep 21 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.51
149 - FIX:
150         - Popup: Do not focus container
151         - Header: show backbutton when both tabbar and header are present together
152         - Multi button entry: text ellipsis, code refactoring
153
154 * Fri Sep 21 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.50
155 - ETC.
156         - Apply SMACK manifest
157
158 * Thu Sep 20 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.49
159 - FIX:
160         - JSLINT code clean-up
161         - scrollview: firefox support
162         - scrollview: fix finding slider handle
163         - list: tweak text ellipsis
164         - checkbox: fix selecting wrong label tag (N_SE-8370)
165         - imageslider: check parameter
166         - smallpopup: fix position
167         - searchbar: fix 'clear' button size
168 - Spec changes:
169         - scrollview: support outer scroll
170         - JQM: block click event only with the element that does preventdefault on vclick(N_SE-6090)
171         - remove S/W IME control
172
173 * Thu Sep 13 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.48
174 - FIX:
175         - Add missing icon: controlbar
176         - scrollview: tune scrolling animatio ninterval
177         - datetimepicker: digit/triangle position
178         - datetimepicker: fix day overflow issue
179 - Spec changes:
180         - scrollview: show scrollbar when page is showed
181         - scrollview: disable outer scroll
182         - extendablelist: change api with legacy support
183         - add ui-text-ellipsis class
184
185 * Mon Sep 10 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.47
186 - FIX:
187         - scrollveiw: fix height of view
188         - searchbar: support placeholder
189 - Spec changes:
190         - add ui-text-ellipsis class
191
192 * Fri Sep 07 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.46
193 - FIX:
194         - scrollview: scrolling bug fix
195         - controlbar: fix width of controlbar item
196 - Spec changes:
197         - searchbar: don't hide icon
198         - popup: update JQM poup widget
199
200 * Fri Sep 05 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.45
201 - FIX:
202         - controlbar: set correct controlbar width of last element
203         - slider: get popup enable value correctly
204         - use Date.now() instead of (new Data()).getTime()
205         - popupwindow: fix the background color of popup scroller
206         - listview: add padding-left to expandable list
207         - add ellipsis for title area support
208
209 * Fri Aug 31 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.44
210 - FIX:
211         - swipelist: show list items correctly
212         - datetimepicker: set last day, if day is overflowed
213 - Spec changes:
214         - controlbar: update icons
215
216 * Tue Aug 29 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.43
217 - FIX:
218         - notification: fix typo
219 - Spec changes:
220         - controlbar: update icons
221
222 * Tue Aug 28 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.42
223 - FIX:
224         - multimediaview: video progress bar display normally for too samll
225         - segmentcontrol: remove media query
226         - scrollview: add outer scroll condition
227         - datetimepicker: modify triangle size
228         - popupwindow: set the screen height explicitly
229         - notification: add multiline text
230 - Spec changes:
231         - mutibuttonentry: support new GUI
232         - virtualgrid: support new GUI
233
234 * Mon Aug 27 2012 Jinhyuk Jun <jinhyuk.jun@samsung.com> 0.1.41
235 - FIX:
236         - radio/check button : button size bug fix
237
238 * Fri Aug 24 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.40
239 - FIX:
240         - build error fixed
241
242 * Fri Aug 24 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.39
243 - FIX:
244         - listview: style fix, remove filter placeholder
245         - controlbar: divide styles
246         - scrollview: don't skip dragging when click button or inputbox
247         - slider: trim the text on text slider
248 - Spec changes:
249         - remove gray and blue theme
250         - add white and black theme
251         - support new GUI guide
252
253 * Mon Aug 20 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.38
254 - FIX:
255         - fix coment of version tag
256
257 * Fri Aug 17 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.37
258 - FIX :
259         - button: fix alignment
260         - listview: adjust the main text width
261         - virtualgrid: refactoring
262 - Spec changes:
263         - transition: support JQM 1.1.0 transitions
264         - scrollview: support the outer scroll
265         - notification: remove interval feature
266
267 * Tue Aug 14 2012 Youmin Ha <youmin.ha@samasung.com> 0.1.36
268 - FIX :
269         - checkboxRadio: Add left/right padding
270         - button: custom button & icon position
271         - virtuallist: remove 'recreate' test
272 - Spec changes:
273         - header/footer: enable/disable support
274
275 * Fri Aug 10 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.35
276 - FIX :
277         - expandablelist: modify show animation
278         - virtualgrid: Redesign programming interface
279         - popupwindow: code clean and fixed issues
280         - pagelayout: fix content height
281         - license file update
282         - virtuallist: Change programming interface
283         - datetimepicker: getting days correctly
284         - searchbar: set to hidden when cancel button is hide
285         - White theme title font tuning
286 - Spec changes:
287         - default theme tizen-gray to tizen-white
288         - set default page transition to none
289
290 * Mon Aug 02 2012 Jinhyuk Jun <jinhyuk.jun@samsung.com> 0.1.34
291 - FIX :
292         - Back Button : enlarge backbutton click size for white theme
293 - Feature :
294         - Expandable List : Add refresh api
295 * Mon Aug 02 2012 Jinhyuk Jun <jinhyuk.jun@samsung.com> 0.1.33
296 - FIX :
297         - click event touch threshold tuning
298
299 * Mon Aug 02 2012 Jinhyuk Jun <jinhyuk.jun@samsung.com> 0.1.32
300 - FIX : 
301         - Add back button highlight effect for white theme
302
303 * Mon Aug 01 2012 Jinhyuk Jun <jinhyuk.jun@samsnug.com> 0.1.31
304 - FIX : 
305         - IME checkroutine update, improve relayout on resize event
306         - Add highlight effect for radio button list 
307         - Scrollview : fix condition of updatelayout event
308 - Feature : progressing : add show/hide api
309
310 * Mon Jul 27 2012 Koeun Choi <koeun.choi@samsung.com> 0.1.30
311 - FIX : virtuallist, virtualgrid: Clean up temporary jquery.template object to clear cache
312         add default theme option on buttonMarkup for tizen theme
313         [searchbar] first fix : focus/blur fixed
314         back button does not work when long press
315         scrollview: don't auto scrolling if resizing area is too large
316 - Feature : notification : add api to set the icon at tickernoti
317         demo : update the list sample demo
318         Support tizen default theme
319
320 * Mon Jul 23 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.29
321 - Improvements & Bugfixes
322    - HOTFIX: Revert template function with jquery.template
323
324 * Thu Jul 19 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.28
325 - Improvements & Bugfixes
326    - Fix #WEB-1028: memory leak on virtuallist/virtualgrid
327 - Spec changes
328    - $.tizen.loadTheme() function accepts theme name as arguement
329    - Scrollview supports 'updatelayout' callback
330
331 * Tue Jul 17 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.27
332 - Improvements & Bugfixes
333    - Revert 'preventing long-press popup' patch, to fix backbutton to work in SocialMagazine
334
335 * Tue Jul 17 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.26
336 - Improvements & Bugfixes
337    - Add tizen-white theme package, to make rpm build to be finished
338
339 * Tue Jul 17 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.25
340 - Improvements & Bugfixes
341    - Set 'slide' as default page transition effect, by JQM patch
342
343 * Fri Jul 13 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.24
344 - Improvements & Bugfixes
345    - Fix IME show/hide algorithm
346    - Fix error on virtualgrid: link _set_scrollbar_size() function to the one in virtuallist
347
348 * Wed Jul 11 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.23
349 - Improvements & Bugfixes
350    - Fix notification position
351    - Fix unit tests
352
353  Fri Jul 6 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.22
354 - Spec changes
355         - JQM 1.1 upgrade
356 - Improvements & Bugfixes
357         - Transform3D support on scrollview
358         - Page layout supports IME control
359         - Mapview supports pinch zoom on JQM 1.1
360         - Fix wrong character on button in minified version
361         - Virtualgrid supports scrollbar
362         - Lots of bugfixes
363
364 * Fri Jun 22 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.20
365 - Spec changes
366         - Support 'latest' version (by symlink) for tizen-web-ui-fw.js path.
367         - imageslider : supports 'resize' event.
368         - listview : listview has 1px padding-bottom.
369         - loader : Change global namespace, from S to $.tizen.
370         - loader : Move loadCustomGlobalizeCulture() into $.tizen.util namespace.
371 - Improvements & Bugfixes
372         - Scrollview : supports 'translate3d', instead of 'translate'.
373         - notification : reset timer when 'show' or 'refresh' event.
374         - JQM patch : Fix vclick event triggered twice.
375 - Etc.
376         - Add & fix unit tests.
377
378 * Thu Jun 14 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.19
379 - Spec changes
380         - mapview : new widget.
381         - notification : add .refresh() API.
382         - pagecontrol : add .value([val]) API, and change an attribute name 'data-initVal' to 'data-value'.
383 - Improvements & Bugfixes
384         - Support minified CSS.
385         - loader : Fix & refactor 'loading globalize culture file' routine.
386         - JQM Patch : Calculate min-height of window in javascript code, and remove predefined min-height value from CSS.
387         - Many more bugfixes.
388 - Etc.
389         - Add many unit tests.
390         - Fix test coverage instrumentation tool to work with current source code.