f484d1088e00b79b5aa244198149b601898da7ef
[profile/ivi/wayland.git] / packaging / wayland.spec
1 Name:       wayland
2 Summary:    Wayland
3 Version:    1.0.1
4 Release:    1
5 Group:      System/Libraries
6 License:    MIT
7 URL:        http://wayland.freedesktop.org
8 Source0:    %{name}-%{version}.tar.bz2
9 Requires(post): /sbin/ldconfig
10 Requires(postun): /sbin/ldconfig
11 BuildRequires:  libffi-devel
12 BuildRequires: expat-devel
13
14 %description
15 Wayland is a protocol for a compositor to talk to its clients as well as a C library implementation of that protocol. 
16 The compositor can be a standalone display server running on Linux kernel modesetting and evdev input devices, an X application, 
17 or a wayland client itself. The clients can be traditional applications, X servers (rootless or fullscreen) or other display servers.
18
19
20 %package devel
21 Summary:    Development files for %{name}
22 Group:      Development/Libraries
23 Requires:   %{name} = %{version}-%{release}
24
25 %description devel
26 Development files needed for building wayland clients
27
28 %prep
29 %setup -q -n %{name}-%{version}
30
31 %build
32
33 %autogen --disable-documentation
34
35 make %{?jobs:-j%jobs}
36
37 %install
38 rm -rf %{buildroot}
39 %make_install
40
41
42 %post -p /sbin/ldconfig
43
44 %postun -p /sbin/ldconfig
45
46 %files
47 %defattr(-,root,root,-)
48 %{_libdir}/libwayland-client.so.*
49 %{_libdir}/libwayland-server.so.*
50 %{_libdir}/libwayland-cursor.so.*
51 %{_bindir}/wayland-scanner
52
53 %files devel
54 %defattr(-,root,root,-)
55 %{_includedir}/wayland*.h
56 %{_libdir}/libwayland-client.so
57 %{_libdir}/libwayland-server.so
58 %{_libdir}/libwayland-cursor.so
59 %{_libdir}/pkgconfig/*.pc
60 %{_prefix}/share/aclocal/*.m*
61