Packaging: update version to 1.2.0
[platform/core/uifw/wayland-extension.git] / packaging / wayland-extension.spec
1 Name:           wayland-extension
2 Version:        1.2.0
3 Release:        0
4 Summary:        Wayland extenstion protocols that add functionality not available in the Wayland core protocol
5 License:        MIT
6 Group:          Graphics & UI Framework/Wayland Window System
7 URL:            http://www.tizen.org/
8 Source:         %name-%version.tar.xz
9 Source1001:     %name.manifest
10 BuildRequires:  autoconf >= 2.64, automake >= 1.11
11 BuildRequires:  libtool >= 2.2
12 BuildRequires:  pkgconfig
13 BuildRequires:  pkgconfig(wayland-server)
14 BuildRequires:  pkgconfig(wayland-client)
15
16 %description
17 wayland-extension contains Wayland protocols that add functionality not available in the Wayland core protocol.
18
19 %package -n libwayland-extension-client
20 Group:          Graphics & UI Framework/Wayland Window System
21 Summary:        Wayland Extension client library
22 Requires:   libwayland-client
23
24 %description -n libwayland-extension-client
25 wayland-extension is a protocol for tizen window system.
26
27 %package -n libwayland-extension-server
28 Group:          Graphics & UI Framework/Wayland Window System
29 Summary:        Wayland Extension server library
30 Requires:   libwayland-server
31
32 %description -n libwayland-extension-server
33 wayland-extension is a protocol for tizen window system.
34
35 %package -n wayland-extension-client-devel
36 Summary:        Client development files for the Wayland Extension Protocol
37 Group:          Graphics & UI Framework/Development
38 Requires:       libwayland-extension-client = %version
39
40 %description -n wayland-extension-client-devel
41 wayland-extension is a protocol for tizen window system.
42
43 This package contains all necessary include files and libraries needed
44 to develop applications that require these.
45
46 %package -n wayland-extension-server-devel
47 Summary:        Server development files for the Wayland Extension Protocol
48 Group:          Graphics & UI Framework/Development
49 Requires:       libwayland-extension-server = %version
50
51 %description -n wayland-extension-server-devel
52 wayland-extension is a protocol for tizen window system.
53
54 This package contains all necessary include files and libraries needed
55 to develop a compositor that require these.
56
57 %package -n wayland-protocols
58 Summary:        Wayland upstream protocols
59 Group:          Graphics & UI Framework/Development
60 Requires:   libwayland-client
61
62 %description -n wayland-protocols
63 wayland-protocols contains Wayland upstream protocols that add functionality not available in the Wayland core protocol
64
65
66 %prep
67 %setup -q
68 cp %{SOURCE1001} .
69
70 %build
71 export CFLAGS+=" -Wall -Werror"
72 %reconfigure --disable-static
73 make %{?_smp_mflags}
74
75 %install
76 %make_install
77
78 %post -n libwayland-extension-client -p /sbin/ldconfig
79 %postun -n libwayland-extension-client -p /sbin/ldconfig
80 %post -n libwayland-extension-server -p /sbin/ldconfig
81 %postun -n libwayland-extension-server -p /sbin/ldconfig
82
83 %files -n libwayland-extension-client
84 %manifest %{name}.manifest
85 %license COPYING
86 %defattr(-,root,root)
87 %_libdir/*-client.so.0*
88
89 %files -n libwayland-extension-server
90 %manifest %{name}.manifest
91 %license COPYING
92 %defattr(-,root,root)
93 %_libdir/*-server.so.0*
94
95 %files -n wayland-extension-client-devel
96 %manifest %{name}.manifest
97 %defattr(-,root,root)
98 %_includedir/wayland-extension/wayland-extension-version.h
99 %_includedir/wayland-extension/*-client-protocol.h
100 %_libdir/*-client.so
101 %_libdir/pkgconfig/*-client.pc
102
103 %files -n wayland-extension-server-devel
104 %manifest %{name}.manifest
105 %defattr(-,root,root)
106 %_includedir/wayland-extension/wayland-extension-version.h
107 %_includedir/wayland-extension/*-server-protocol.h
108 %_libdir/*-server.so
109 %_libdir/pkgconfig/*-server.pc
110
111 %files -n wayland-protocols
112 %manifest %{name}.manifest
113 %license COPYING
114 %defattr(-,root,root)
115 %_datadir/wayland-extension/protocol/stable/*
116 %_datadir/wayland-extension/protocol/unstable/*
117 %_libdir/pkgconfig/wayland-protocols.pc
118
119 %changelog